]> git.pld-linux.org Git - packages/xz.git/blob - xz.spec
- use proper rpm macros instead
[packages/xz.git] / xz.spec
1 # TODO:
2 # - wait for alpha7 which will fix headers installation issue
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform make check
6 #
7 %define snap    alpha
8 Summary:        LZMA Encoder/Decoder
9 Summary(pl.UTF-8):      Koder/Dekoder LZMA
10 Name:           lzma
11 Version:        4.42.2
12 Release:        0.%{snap}.2
13 Epoch:          1
14 License:        LGPL v2.1+, helper scripts on GPL v2+
15 Group:          Applications/Archiving
16 Source0:        http://tukaani.org/lzma/%{name}-%{version}%{snap}.tar.gz
17 # Source0-md5:  5cef8b41aecee8ce1c6fbc681701fe61
18 URL:            http://tukaani.org/lzma/
19 BuildRequires:  rpmbuild(macros) >= 1.402
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 LZMA is default and general compression method of 7z format in 7-Zip
24 program. LZMA provides high compression ratio and very fast
25 decompression, so it is very suitable for embedded applications. For
26 example, it can be used for ROM (firmware) compressing.
27
28 LZMA features:
29
30 - Compressing speed: 500 KB/s on 1 GHz CPU
31 - Decompressing speed:
32   - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
33   - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
34     CPU.
35 - Small memory requirements for decompressing: 8-32 KB + dictionary
36   size
37 - Small code size for decompressing: 2-8 KB (depending from speed
38   optimizations)
39
40 %description -l pl.UTF-8
41 LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
42 stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
43 bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
44 Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
45
46 Cechy LZMA:
47
48 - Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
49 - Szybkość dekompresowania:
50   - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
51   - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
52     prostych RISC-ach,
53 - Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
54   słownika,
55 - Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
56   optymalizacji).
57
58 %package libs
59 Summary:        LZMA shared library
60 Summary(pl.UTF-8):      Biblioteka współdzielona LZMA
61 Group:          Libraries
62
63 %description libs
64 LZMA shared library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka współdzielona LZMA.
68
69 %package devel
70 Summary:        Header file for LZMA library
71 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki LZMA
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
74
75 %description devel
76 Header file for LZMA library.
77
78 %description devel -l pl.UTF-8
79 Plik nagłówkowy biblioteki LZMA.
80
81 %package static
82 Summary:        LZMA static library
83 Summary(pl.UTF-8):      Biblioteka statyczna LZMA
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
86
87 %description static
88 LZMA static library.
89
90 %description static -l pl.UTF-8
91 Biblioteka statyczna LZMA.
92
93 %prep
94 %setup -q -n %{name}-%{version}%{snap}
95
96 %build
97 %configure
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %find_lang %{name}
108
109 %{?with_tests:%{__make} check}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   libs -p /sbin/ldconfig
115 %postun libs -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/lz*
120 %{_mandir}/man1/lz*.1*
121
122 %files libs -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS COPYING README THANKS TODO
125 %doc doc/{bugs,faq,file-format,history,lzma-intro}.txt
126 %attr(755,root,root) %{_libdir}/liblzma.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/liblzma.so.0
128
129 %files devel
130 %defattr(644,root,root,755)
131 %doc doc/liblzma-*.txt
132 %attr(755,root,root) %{_libdir}/liblzma.so
133 %{_libdir}/liblzma.la
134 %{_includedir}/lzma.h
135 %{_includedir}/lzma
136 %{_pkgconfigdir}/lzma.pc
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/liblzma.a
This page took 0.040688 seconds and 3 git commands to generate.