]> git.pld-linux.org Git - packages/xz.git/blob - xz.spec
- License is basically LGPL v2.1+;
[packages/xz.git] / xz.spec
1 # TODO:
2 # - wait for alpha7 which will fix headers installation issue
3 #
4 # Conditional build:
5 %bcond_without  tests   # don't perform make check
6 #
7 %define snap    alpha
8 Summary:        LZMA Encoder/Decoder
9 Summary(pl.UTF-8):      Koder/Dekoder LZMA
10 Name:           lzma
11 Version:        4.42.2
12 Release:        0.%{snap}.1
13 Epoch:          1
14 License:        LGPL v2.1+, helper scripts on GPL v2+
15 Group:          Applications/Archiving
16 Source0:        http://tukaani.org/lzma/%{name}-%{version}%{snap}.tar.gz
17 # Source0-md5:  5cef8b41aecee8ce1c6fbc681701fe61
18 URL:            http://tukaani.org/lzma/
19 BuildRequires:  libstdc++-devel
20 # does not need -libs, due apps being not linked with shared lib
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 LZMA is default and general compression method of 7z format in 7-Zip
25 program. LZMA provides high compression ratio and very fast
26 decompression, so it is very suitable for embedded applications. For
27 example, it can be used for ROM (firmware) compressing.
28
29 LZMA features:
30
31 - Compressing speed: 500 KB/s on 1 GHz CPU
32 - Decompressing speed:
33   - 8-12 MB/s on 1 GHz Intel Pentium 3 or AMD Athlon.
34   - 500-1000 KB/s on 100 MHz ARM, MIPS, PowerPC or other simple RISC
35     CPU.
36 - Small memory requirements for decompressing: 8-32 KB + dictionary
37   size
38 - Small code size for decompressing: 2-8 KB (depending from speed
39   optimizations)
40
41 %description -l pl.UTF-8
42 LZMA jest domyślnym i ogólnym algorytmem kompresji formatu 7z
43 stosowanego przez 7-Zip. LZMA zapewnia wysoki stopień kompresji i
44 bardzo szybką dekompresję, więc nadaje się do zastosowań osadzonych.
45 Przykładowo, może być użyty do kompresji ROM-u (firmware'u).
46
47 Cechy LZMA:
48
49 - Szybkość kompresowania: 500 KB/s na 1 GHz procesorze,
50 - Szybkość dekompresowania:
51   - 8-12 MB/s na 1 GHz Pentium 3 lub Athlonie,
52   - 500-1000 KB/s na 100 MHz procesorach ARM, MIPS, PowerPC lub innych
53     prostych RISC-ach,
54 - Mała ilość pamięci potrzebna do dekompresowania: 8-32 KB + rozmiar
55   słownika,
56 - Mały rozmiar kodu dekompresującego: 2-8 KB (w zależności od opcji
57   optymalizacji).
58
59 %package libs
60 Summary:        LZMA shared library
61 Summary(pl.UTF-8):      Biblioteka współdzielona LZMA
62 Group:          Libraries
63
64 %description libs
65 LZMA shared library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka współdzielona LZMA.
69
70 %package devel
71 Summary:        Header file for LZMA library
72 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki LZMA
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75
76 %description devel
77 Header file for LZMA library.
78
79 %description devel -l pl.UTF-8
80 Plik nagłówkowy biblioteki LZMA.
81
82 %package static
83 Summary:        LZMA static library
84 Summary(pl.UTF-8):      Biblioteka statyczna LZMA
85 Group:          Development/Libraries
86 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
87
88 %description static
89 LZMA static library.
90
91 %description static -l pl.UTF-8
92 Biblioteka statyczna LZMA.
93
94 %prep
95 %setup -q -n %{name}-%{version}%{snap}
96
97 %build
98 %configure
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %find_lang %{name}
109
110 %{?with_tests:%{__make} check}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   libs -p /sbin/ldconfig
116 %postun libs -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/lz*
121 %{_mandir}/man1/lz*.1*
122
123 %files libs -f %{name}.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS COPYING README THANKS TODO
126 %doc doc/{bugs,faq,file-format,history,lzma-intro}.txt
127 %attr(755,root,root) %{_libdir}/liblzma.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/liblzma.so.0
129
130 %files devel
131 %defattr(644,root,root,755)
132 %doc doc/liblzma-*.txt
133 %attr(755,root,root) %{_libdir}/liblzma.so
134 %{_libdir}/liblzma.la
135 %{_includedir}/lzma.h
136 %{_includedir}/lzma
137 %{_pkgconfigdir}/lzma.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/liblzma.a
This page took 0.079236 seconds and 3 git commands to generate.