]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- rel 2; xorg.conf.d instead of conf.d
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_with     record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       3.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        7.0
16 %define xorg_xserver_server_xinput_abi          9.0
17
18 %define         rel             3
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.8.0
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  7cec3a11890bb53f4a07854319360348
28 Source2:        xserver.pamd
29 Patch0:         %{name}-xwrapper.patch
30 Patch1:         %{name}-pic-libxf86config.patch
31 Patch2:         %{name}-fb-size.patch
32 Patch3:         %{name}-less-acpi-brokenness.patch
33 URL:            http://xorg.freedesktop.org/
34 BuildRequires:  Mesa-libGL-devel >= 7.8
35 # for glx headers
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 BuildRequires:  cpp
40 %if %{with hal} || %{with dbus}
41 BuildRequires:  dbus-devel
42 %endif
43 %{?with_hal:BuildRequires:      hal-devel}
44 BuildRequires:  libdrm-devel >= 2.4.5
45 BuildRequires:  libtool
46 BuildRequires:  ncurses-devel
47 BuildRequires:  openssl-devel
48 BuildRequires:  pam-devel
49 BuildRequires:  perl-base
50 BuildRequires:  pixman-devel >= 0.16.0
51 BuildRequires:  pkgconfig >= 1:0.19
52 BuildRequires:  xorg-app-mkfontscale
53 BuildRequires:  xorg-font-font-util >= 1.1
54 BuildRequires:  xorg-lib-libX11-devel
55 BuildRequires:  xorg-lib-libXau-devel
56 BuildRequires:  xorg-lib-libXaw-devel
57 BuildRequires:  xorg-lib-libXdamage-devel
58 BuildRequires:  xorg-lib-libXdmcp-devel
59 BuildRequires:  xorg-lib-libXext-devel
60 BuildRequires:  xorg-lib-libXfont-devel
61 BuildRequires:  xorg-lib-libXi-devel >= 1.2
62 BuildRequires:  xorg-lib-libXmu-devel
63 BuildRequires:  xorg-lib-libXpm-devel
64 BuildRequires:  xorg-lib-libXrender-devel
65 BuildRequires:  xorg-lib-libXres-devel
66 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
67 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
68 BuildRequires:  xorg-lib-libXv-devel
69 BuildRequires:  xorg-lib-libXxf86dga-devel
70 BuildRequires:  xorg-lib-libXxf86misc-devel
71 BuildRequires:  xorg-lib-libXxf86vm-devel
72 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
73 BuildRequires:  xorg-lib-libfontenc-devel
74 BuildRequires:  xorg-lib-libpciaccess-devel
75 BuildRequires:  xorg-lib-libxkbfile-devel
76 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
77 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
78 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
79 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
80 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
81 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel}
82 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.1}
83 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
84 BuildRequires:  xorg-proto-fontcacheproto-devel
85 BuildRequires:  xorg-proto-fontsproto-devel
86 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
87 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
88 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
89 BuildRequires:  xorg-proto-printproto-devel
90 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
91 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel}
92 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
93 BuildRequires:  xorg-proto-resourceproto-devel
94 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
95 BuildRequires:  xorg-proto-videoproto-devel
96 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
97 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
98 BuildRequires:  xorg-proto-xf86bigfontproto-devel
99 BuildRequires:  xorg-proto-xf86dgaproto-devel
100 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.0.4
101 BuildRequires:  xorg-proto-xf86miscproto-devel
102 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
103 BuildRequires:  xorg-proto-xineramaproto-devel
104 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
105 BuildRequires:  xorg-util-util-macros >= 1.5
106 #BR: xcalibrateproto, tslib (for KDRIVE only)
107 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
108 Requires(triggerpostun):        sed >= 4.0
109 Requires:       pixman >= 0.16.0
110 Requires:       xkeyboard-config
111 # for rgb.txt
112 Requires:       xorg-app-rgb >= 0.99.3
113 Requires:       xorg-app-xkbcomp
114 # xserver default config expects evdev+dbus+hald
115 %{?with_hal:Suggests:   dbus}
116 Suggests:       hal
117 Suggests:       udev-acl
118 Suggests:       xorg-driver-input-evdev
119 # xserver requires fixed and cursor fonts
120 Requires:       xorg-font-font-alias
121 Requires:       xorg-font-font-cursor-misc
122 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
123 Suggests:       xkeyboard-config
124 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
125 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
126 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
127 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
128 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
129 Obsoletes:      X11-Xserver < 1:7.0.0
130 Obsoletes:      X11-driver-i2c < 1:7.0.0
131 Obsoletes:      X11-modules < 1:7.0.0
132 Obsoletes:      X11-setup < 1:7.0.0
133 Obsoletes:      XFree86-Xserver < 1:7.0.0
134 Obsoletes:      XFree86-modules < 1:7.0.0
135 Obsoletes:      XFree86-setup < 1:7.0.0
136 Obsoletes:      Xserver
137 Obsoletes:      xorg-xserver-server-xorgcfg
138 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
139
140 # avoid self-dependencies on included modules
141 %define         _noautoreq      libscanpci.so libxf1bpp.so
142
143 %description
144 Xorg server is a generally used X server which uses display hardware.
145 It requires proper driver for your display hardware.
146
147 %description -l pl.UTF-8
148 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
149 graficznej. Do działania wymaga odpowiedniego sterownika.
150
151 %package -n xorg-xserver-Xdmx
152 Summary:        Xdmx - distributed multi-head X server
153 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
154 Group:          X11/Servers
155
156 %description -n xorg-xserver-Xdmx
157 Xdmx - distributed multi-head X server.
158
159 %description -n xorg-xserver-Xdmx -l pl.UTF-8
160 Xdmx - rozproszony, wielomonitorowy serwer X.
161
162 %package -n xorg-xserver-Xnest
163 Summary:        Xnest - nested X server
164 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
165 Group:          X11/Servers
166 Obsoletes:      X11-Xnest < 1:7.0.0
167 Obsoletes:      XFree86-Xnest < 1:7.0.0
168 Obsoletes:      Xserver-Xnest
169
170 %description -n xorg-xserver-Xnest
171 Xnest is an X Window System server which runs in an X window. Xnest is
172 a 'nested' window server, actually a client of the real X server,
173 which manages windows and graphics requests for Xnest, while Xnest
174 manages the windows and graphics requests for its own clients.
175
176 %description -n xorg-xserver-Xnest -l pl.UTF-8
177 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
178 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
179 serwer X dla własnych klientów.
180
181 %description -n xorg-xserver-Xnest -l ru.UTF-8
182 Xnest - это сервер X Window System, который работает в окне X. На
183 самом деле это клиент реального X-сервера, который управляет окнами и
184 графическими запросами для Xnest в то время, как Xnest управляет
185 окнами и графическими запросами для своих собственных клиентов.
186
187 %description -n xorg-xserver-Xnest -l uk.UTF-8
188 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
189 клієнт реального X-сервера, який керує вікнами та графічними запитами
190 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
191 своїх власних клієнтів.
192
193 %package -n xorg-xserver-Xephyr
194 Summary:        Xephyr - nested X server
195 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
196 Group:          X11/Servers
197 Requires:       pixman >= 0.15.0
198
199 %description -n xorg-xserver-Xephyr
200 Xephyr is a a kdrive server that outputs to a window on a pre-existing
201 'host' X display. Think Xnest but with support for modern extensions
202 like composite, damage and randr.
203
204 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
205 the host X server, Xephyr is a real X server which uses the host X
206 server window as "framebuffer" via fast SHM XImages.
207
208 It also has support for 'visually' debugging what the server is
209 painting.
210
211 %description -n xorg-xserver-Xephyr -l pl.UTF-8
212 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
213 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
214 wspólczesnych rozszerzeń jak composite, damage i randr.
215
216 %package -n xorg-xserver-Xfbdev
217 Summary:        Xfbdev - Linux framebuffer device X server
218 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
219 Group:          X11/Servers
220
221 %description -n xorg-xserver-Xfbdev
222 Xfbdev is a Linux framebuffer device X server based on the kdrive X
223 server.
224
225 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
226 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
227
228 %package -n xorg-xserver-Xvfb
229 Summary:        Xvfb - virtual framebuffer X server
230 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
231 Group:          X11/Servers
232 # requires fixed and cursor fonts
233 Requires:       xorg-font-font-alias
234 Requires:       xorg-font-font-cursor-misc
235 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
236 Obsoletes:      X11-Xvfb < 1:7.0.0
237 Obsoletes:      XFree86-Xvfb < 1:7.0.0
238
239 %description -n xorg-xserver-Xvfb
240 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
241 capable of running on machines with no display hardware and no
242 physical input devices. Xvfb emulates a dumb framebuffer using virtual
243 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
244 display. Xvfb is normally used for testing servers. Using Xvfb, the
245 mfb or cfb code for any depth can be exercised without using real
246 hardware that supports the desired depths. Xvfb has also been used to
247 test X clients against unusual depths and screen configurations, to do
248 batch processing with Xvfb as a background rendering engine, to do
249 load testing, to help with porting an X server to a new platform, and
250 to provide an unobtrusive way of running applications which really
251 don't need an X server but insist on having one.
252
253 %description -n xorg-xserver-Xvfb -l pl.UTF-8
254 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
255 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
256 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
257 używany do testowania serwerów X, może też być używany do testowania
258 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
259 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
260 serwera X, ale odmawiają uruchomienia bez niego.
261
262 %package devel
263 Summary:        Header files for X.org server
264 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
265 Group:          X11/Development/Libraries
266 Requires:       libdrm-devel >= 2.4.5
267 Requires:       pixman-devel >= 0.16.0
268 Requires:       xorg-lib-libpciaccess-devel
269 Requires:       xorg-lib-libxkbfile-devel
270 Requires:       xorg-proto-dri2proto-devel >= 2.1
271 Requires:       xorg-proto-fontsproto-devel
272 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
273 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
274 Requires:       xorg-proto-renderproto-devel >= 0.9.3
275 Requires:       xorg-proto-videoproto-devel
276 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
277 Requires:       xorg-proto-xproto-devel >= 7.0.13
278 Obsoletes:      X11-Xserver-devel < 1:7.0.0
279 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
280
281 %description devel
282 Header files for X.org server.
283
284 %description devel -l pl.UTF-8
285 Pliki nagłówkowe dla serwera X.org.
286
287 %package -n xorg-xserver-libdri
288 Summary:        DRI extension library for X.org server
289 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
290 Group:          X11/Servers
291 Requires:       %{name} = %{version}-%{release}
292 Provides:       xorg-xserver-module(dri)
293 %if %{without multigl}
294 Conflicts:      xorg-driver-video-fglrx-libdri
295 Conflicts:      xorg-driver-video-nvidia
296 %endif
297
298 %description -n xorg-xserver-libdri
299 DRI extension library for X.org server.
300
301 %description -n xorg-xserver-libdri -l pl.UTF-8
302 Biblioteka rozszerzenia DRI dla serwera X.org.
303
304 %package -n xorg-xserver-libglx
305 Summary:        GLX extension library for X.org server
306 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
307 Group:          X11/Servers
308 Requires:       %{name} = %{version}-%{release}
309 Requires:       xorg-xserver-libdri = %{version}-%{release}
310 # Mesa version glapi tables in glx/ dir come from
311 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
312 Provides:       xorg-xserver-module(glx)
313 Obsoletes:      X11-OpenGL-core < 1:7.0.0
314 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
315 %if %{without multigl}
316 Conflicts:      xorg-driver-video-fglrx-libglx
317 Conflicts:      xorg-driver-video-nvidia
318 %endif
319
320 %description -n xorg-xserver-libglx
321 GLX extension library for X.org server.
322
323 %description -n xorg-xserver-libglx -l pl.UTF-8
324 Biblioteka rozszerzenia GLX dla serwera X.org.
325
326 %prep
327 %setup -q -n xorg-server-%{version}
328 %patch0 -p0
329 %patch1 -p1
330 %patch2 -p1
331 %patch3 -p1
332
333 # xserver uses pixman-1 API/ABI so put that explictly here
334 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
335
336 %build
337 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
338 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
339         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
340         exit 1
341 fi
342
343 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
344 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
345         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
346         exit 1
347 fi
348
349 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
350 if [ $API != %{xorg_xserver_server_font_abi} ]; then
351         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
352         exit 1
353 fi
354 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
355 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
356         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
357         exit 1
358 fi
359 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
360 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
361         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
362         exit 1
363 fi
364
365 %{__libtoolize}
366 %{__aclocal} -I m4
367 %{__autoconf}
368 %{__autoheader}
369 %{__automake}
370 %configure \
371         --with-os-name="PLD/Linux" \
372         --with-os-vendor="PLD/Team" \
373         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
374         %{!?with_hal:--disable-config-hal} \
375         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
376         --enable-aiglx \
377         --enable-builddocs \
378         --enable-dga \
379         %{?with_dmx:--enable-dmx} \
380         --enable-glx-tls \
381         --enable-install-libxf86config \
382         %{?with_record:--enable-record} \
383         --enable-kdrive \
384         --enable-xephyr \
385         --enable-xfbdev \
386         --enable-glx-tls \
387         --disable-xsdl \
388         --disable-xfake \
389         --enable-secure-rpc \
390         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
391         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
392         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
393         --with-xkb-output=/var/lib/xkb
394
395 %{__make}
396
397 %install
398 rm -rf $RPM_BUILD_ROOT
399
400 %{__make} install \
401         DESTDIR=$RPM_BUILD_ROOT
402
403 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
404 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
405 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
406 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
407 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
408
409 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
410
411 %if %{with udev}
412 mv $RPM_BUILD_ROOT%{_prefix}/etc/X11/xorg.conf.d/10-evdev.conf $RPM_BUILD_ROOT/etc/X11/xorg.conf.d
413 %endif
414
415 %if %{with multigl}
416 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
417 mv -f libglx.so libglx.so.%{version}
418 ln -sf libglx.so.%{version} libglx.so
419 %endif
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %if %{with multigl}
425 %post -n xorg-xserver-libglx
426 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
427         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
428 fi
429 %endif
430
431 %triggerpostun -- xorg-xserver-server < 1.5.0
432 if [ -f /etc/X11/xorg.conf ]; then
433         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
434         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
435 %if %{without record}
436         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
437 %endif
438         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
439 fi
440
441 %files
442 %defattr(644,root,root,755)
443 %doc COPYING ChangeLog
444 %attr(755,root,root) %{_bindir}/X
445 %attr(755,root,root) %{_bindir}/Xorg
446 %attr(4755,root,root) %{_bindir}/Xwrapper
447 %attr(755,root,root) %{_bindir}/cvt
448 %attr(755,root,root) %{_bindir}/gtf
449 %dir %{_libdir}/xorg
450 %{_libdir}/xorg/protocol.txt
451 %dir %{_libdir}/xorg/modules
452 %dir %{_libdir}/xorg/modules/dri
453 %dir %{_libdir}/xorg/modules/drivers
454 %dir %{_libdir}/xorg/modules/extensions
455 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
456 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
457 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
458 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
459 %dir %{_libdir}/xorg/modules/input
460 %dir %{_libdir}/xorg/modules/linux
461 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
462 %dir %{_libdir}/xorg/modules/multimedia
463 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
464 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
465 %dir /var/lib/xkb
466 /var/lib/xkb/README.compiled
467 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
468 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
469 %config(missingok) /etc/security/console.apps/xserver
470 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
471 %dir /etc/X11/xorg.conf.d
472 %if %{with udev}
473 %config(noreplace) %verify(not md5 mtime size) /etc/X11/xorg.conf.d/10-evdev.conf
474 %endif
475 %{_mandir}/man1/Xorg.1x*
476 %{_mandir}/man1/Xserver.1x*
477 %{_mandir}/man1/cvt.1*
478 %{_mandir}/man1/gtf.1x*
479 %{_mandir}/man4/exa.4*
480 %{_mandir}/man4/fbdevhw.4*
481 %{_mandir}/man5/xorg.conf.5x*
482
483 %if %{with dmx}
484 %files -n xorg-xserver-Xdmx
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_bindir}/Xdmx
487 %attr(755,root,root) %{_bindir}/dmxaddinput
488 %attr(755,root,root) %{_bindir}/dmxaddscreen
489 %attr(755,root,root) %{_bindir}/dmxinfo
490 %attr(755,root,root) %{_bindir}/dmxreconfig
491 %attr(755,root,root) %{_bindir}/dmxresize
492 %attr(755,root,root) %{_bindir}/dmxrminput
493 %attr(755,root,root) %{_bindir}/dmxrmscreen
494 %attr(755,root,root) %{_bindir}/dmxtodmx
495 %attr(755,root,root) %{_bindir}/dmxwininfo
496 %attr(755,root,root) %{_bindir}/vdltodmx
497 %attr(755,root,root) %{_bindir}/xdmxconfig
498 %{_mandir}/man1/Xdmx.1x*
499 %{_mandir}/man1/dmxtodmx.1x*
500 %{_mandir}/man1/vdltodmx.1x*
501 %{_mandir}/man1/xdmxconfig.1x*
502 %endif
503
504 %files -n xorg-xserver-Xnest
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_bindir}/Xnest
507 %{_mandir}/man1/Xnest.1x*
508
509 %files -n xorg-xserver-Xephyr
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_bindir}/Xephyr
512 %{_mandir}/man1/Xephyr.1x*
513
514 %files -n xorg-xserver-Xfbdev
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/Xfbdev
517
518 %files -n xorg-xserver-Xvfb
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/Xvfb
521 %{_mandir}/man1/Xvfb.1x*
522
523 %files devel
524 %defattr(644,root,root,755)
525 %{_includedir}/xorg
526 %{_libdir}/libxf86config.a
527 %{_aclocaldir}/xorg-server.m4
528 %{_pkgconfigdir}/xorg-server.pc
529
530 %files -n xorg-xserver-libdri
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
533
534 %files -n xorg-xserver-libglx
535 %defattr(644,root,root,755)
536 %if %{with multigl}
537 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
538 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
539 %else
540 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
541 %endif
This page took 0.088357 seconds and 4 git commands to generate.