]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- note on commented out patch
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dri2            # DRI2 extension
8 %bcond_without  dmx             # DMX support
9 %bcond_without  record          # RECORD extension
10 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
11 %bcond_with     xf86bigfont     # XF86BigFont extension
12 %bcond_with     xselinux        # SELinux extension
13 #
14 # ABI versions, see hw/xfree86/common/xf86Module.h
15 %define xorg_xserver_server_ansic_abi           0.4
16 %define xorg_xserver_server_extension_abi       6.0
17 %define xorg_xserver_server_font_abi            0.6
18 %define xorg_xserver_server_videodrv_abi        12.0
19 %define xorg_xserver_server_xinput_abi          16.0
20 #
21 %define pixman_ver      0.24.4
22
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.12.0
27 Release:        2
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  3a3c4281f32c8702749e8f129372a355
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38 Patch2:         %{name}-fb-size.patch
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 Patch5:         %{name}-export-GetMaster.patch
42 Patch6:         110_nvidia_slowdow_fix.patch
43 Patch7:         %{name}-include-defs.patch
44 URL:            http://xorg.freedesktop.org/
45 BuildRequires:  Mesa-libGL-devel >= 7.8.1
46 # for glx headers
47 BuildRequires:  OpenGL-GLX-devel
48 %{?with_xselinux:BuildRequires: audit-libs-devel}
49 BuildRequires:  autoconf >= 2.57
50 BuildRequires:  automake
51 BuildRequires:  cpp
52 BuildRequires:  docbook-dtd43-xml
53 #BuildRequires: doxygen >= 1.6.1
54 %if %{with hal} || %{with dbus}
55 BuildRequires:  dbus-devel >= 1.0
56 %endif
57 %{?with_hal:BuildRequires:      hal-devel}
58 BuildRequires:  libdrm-devel >= 2.4.5
59 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
60 BuildRequires:  libtool
61 BuildRequires:  ncurses-devel
62 BuildRequires:  pam-devel
63 BuildRequires:  perl-base
64 BuildRequires:  pixman-devel >= %{pixman_ver}
65 BuildRequires:  pkgconfig >= 1:0.19
66 BuildRequires:  udev-devel >= 1:143
67 BuildRequires:  xmlto >= 0.0.20
68 BuildRequires:  xorg-app-mkfontscale
69 BuildRequires:  xorg-font-font-util >= 1.1
70 BuildRequires:  xorg-lib-libX11-devel
71 BuildRequires:  xorg-lib-libXau-devel
72 BuildRequires:  xorg-lib-libXaw-devel
73 BuildRequires:  xorg-lib-libXdamage-devel
74 BuildRequires:  xorg-lib-libXdmcp-devel
75 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
76 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
77 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
78 BuildRequires:  xorg-lib-libXmu-devel
79 BuildRequires:  xorg-lib-libXpm-devel
80 BuildRequires:  xorg-lib-libXrender-devel
81 BuildRequires:  xorg-lib-libXres-devel
82 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
83 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
84 BuildRequires:  xorg-lib-libXv-devel
85 BuildRequires:  xorg-lib-libXxf86dga-devel
86 BuildRequires:  xorg-lib-libXxf86misc-devel
87 BuildRequires:  xorg-lib-libXxf86vm-devel
88 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
89 BuildRequires:  xorg-lib-libfontenc-devel
90 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
91 BuildRequires:  xorg-lib-libxkbfile-devel
92 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
93 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
94 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
95 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
96 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
97 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
98 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
99 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
100 BuildRequires:  xorg-proto-fontcacheproto-devel
101 BuildRequires:  xorg-proto-fontsproto-devel
102 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
103 BuildRequires:  xorg-proto-inputproto-devel >= 2.2
104 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
105 BuildRequires:  xorg-proto-printproto-devel
106 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
107 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
108 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
109 BuildRequires:  xorg-proto-resourceproto-devel
110 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
111 BuildRequires:  xorg-proto-videoproto-devel
112 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
113 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
114 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
115 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
116 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
117 BuildRequires:  xorg-proto-xf86miscproto-devel
118 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
119 BuildRequires:  xorg-proto-xineramaproto-devel
120 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
121 BuildRequires:  xorg-sgml-doctools >= 1.8
122 BuildRequires:  xorg-util-util-macros >= 1.14
123 #BR: tslib (for KDRIVE only)
124 Requires(triggerpostun):        sed >= 4.0
125 Requires:       pixman >= %{pixman_ver}
126 Requires:       xkeyboard-config
127 # for rgb.txt
128 Requires:       xorg-app-rgb >= 0.99.3
129 Requires:       xorg-app-xkbcomp
130 %{?with_hal:Suggests:   hal}
131 Suggests:       udev-acl >= 1:143
132 %{?with_udev:Suggests:  udev-core >= 1:143}
133 Suggests:       xorg-driver-input-evdev
134 # xserver requires fixed and cursor fonts
135 Requires:       xorg-font-font-alias
136 Requires:       xorg-font-font-cursor-misc
137 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
138 Suggests:       dbus-x11 >= 1.0
139 Suggests:       xkeyboard-config
140 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
141 Suggests:       xorg-driver-video
142 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
143 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
144 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
145 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
146 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
147 Obsoletes:      X11-Xserver < 1:7.0.0
148 Obsoletes:      X11-driver-i2c < 1:7.0.0
149 Obsoletes:      X11-modules < 1:7.0.0
150 Obsoletes:      X11-setup < 1:7.0.0
151 Obsoletes:      XFree86-Xserver < 1:7.0.0
152 Obsoletes:      XFree86-modules < 1:7.0.0
153 Obsoletes:      XFree86-setup < 1:7.0.0
154 Obsoletes:      Xserver
155 Obsoletes:      xorg-xserver-server-xorgcfg
156 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
157
158 # avoid self-dependencies on included modules
159 %define         _noautoreq      libscanpci.so libxf1bpp.so
160
161 %description
162 Xorg server is a generally used X server which uses display hardware.
163 It requires proper driver for your display hardware.
164
165 %description -l pl.UTF-8
166 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
167 graficznej. Do działania wymaga odpowiedniego sterownika.
168
169 %package -n xorg-xserver-Xdmx
170 Summary:        Xdmx - distributed multi-head X server
171 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
172 Group:          X11/Servers
173
174 %description -n xorg-xserver-Xdmx
175 Xdmx - distributed multi-head X server.
176
177 %description -n xorg-xserver-Xdmx -l pl.UTF-8
178 Xdmx - rozproszony, wielomonitorowy serwer X.
179
180 %package -n xorg-xserver-Xnest
181 Summary:        Xnest - nested X server
182 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
183 Group:          X11/Servers
184 Obsoletes:      X11-Xnest < 1:7.0.0
185 Obsoletes:      XFree86-Xnest < 1:7.0.0
186 Obsoletes:      Xserver-Xnest
187
188 %description -n xorg-xserver-Xnest
189 Xnest is an X Window System server which runs in an X window. Xnest is
190 a 'nested' window server, actually a client of the real X server,
191 which manages windows and graphics requests for Xnest, while Xnest
192 manages the windows and graphics requests for its own clients.
193
194 %description -n xorg-xserver-Xnest -l pl.UTF-8
195 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
196 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
197 serwer X dla własnych klientów.
198
199 %description -n xorg-xserver-Xnest -l ru.UTF-8
200 Xnest - это сервер X Window System, который работает в окне X. На
201 самом деле это клиент реального X-сервера, который управляет окнами и
202 графическими запросами для Xnest в то время, как Xnest управляет
203 окнами и графическими запросами для своих собственных клиентов.
204
205 %description -n xorg-xserver-Xnest -l uk.UTF-8
206 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
207 клієнт реального X-сервера, який керує вікнами та графічними запитами
208 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
209 своїх власних клієнтів.
210
211 %package -n xorg-xserver-Xephyr
212 Summary:        Xephyr - nested X server
213 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
214 Group:          X11/Servers
215 Requires:       pixman >= %{pixman_ver}
216
217 %description -n xorg-xserver-Xephyr
218 Xephyr is a a kdrive server that outputs to a window on a pre-existing
219 'host' X display. Think Xnest but with support for modern extensions
220 like composite, damage and randr.
221
222 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
223 the host X server, Xephyr is a real X server which uses the host X
224 server window as "framebuffer" via fast SHM XImages.
225
226 It also has support for 'visually' debugging what the server is
227 painting.
228
229 %description -n xorg-xserver-Xephyr -l pl.UTF-8
230 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
231 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
232 wspólczesnych rozszerzeń jak composite, damage i randr.
233
234 %package -n xorg-xserver-Xfbdev
235 Summary:        Xfbdev - Linux framebuffer device X server
236 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
237 Group:          X11/Servers
238
239 %description -n xorg-xserver-Xfbdev
240 Xfbdev is a Linux framebuffer device X server based on the kdrive X
241 server.
242
243 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
244 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
245
246 %package -n xorg-xserver-Xvfb
247 Summary:        Xvfb - virtual framebuffer X server
248 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
249 Group:          X11/Servers
250 # requires fixed and cursor fonts
251 Requires:       xorg-font-font-alias
252 Requires:       xorg-font-font-cursor-misc
253 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
254 Obsoletes:      X11-Xvfb < 1:7.0.0
255 Obsoletes:      XFree86-Xvfb < 1:7.0.0
256
257 %description -n xorg-xserver-Xvfb
258 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
259 capable of running on machines with no display hardware and no
260 physical input devices. Xvfb emulates a dumb framebuffer using virtual
261 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
262 display. Xvfb is normally used for testing servers. Using Xvfb, the
263 mfb or cfb code for any depth can be exercised without using real
264 hardware that supports the desired depths. Xvfb has also been used to
265 test X clients against unusual depths and screen configurations, to do
266 batch processing with Xvfb as a background rendering engine, to do
267 load testing, to help with porting an X server to a new platform, and
268 to provide an unobtrusive way of running applications which really
269 don't need an X server but insist on having one.
270
271 %description -n xorg-xserver-Xvfb -l pl.UTF-8
272 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
273 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
274 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
275 używany do testowania serwerów X, może też być używany do testowania
276 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
277 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
278 serwera X, ale odmawiają uruchomienia bez niego.
279
280 %package -n xorg-xserver-Xvfb-init
281 Summary:        Init scripts for Xvfb
282 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
283 Group:          X11/Servers
284 Requires:       xorg-xserver-Xvfb
285
286 %description -n xorg-xserver-Xvfb-init
287 This package contains init scripts for Xvfb and registers Xvfb as
288 system service.
289
290 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
291 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
292 usługę systemową.
293
294 %package devel
295 Summary:        Header files for X.org server
296 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
297 Group:          X11/Development/Libraries
298 Requires:       libdrm-devel >= 2.4.5
299 Requires:       pixman-devel >= %{pixman_ver}
300 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
301 Requires:       xorg-lib-libxkbfile-devel
302 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
303 Requires:       xorg-proto-fontsproto-devel
304 Requires:       xorg-proto-inputproto-devel >= 2.2
305 Requires:       xorg-proto-kbproto-devel >= 1.0.3
306 Requires:       xorg-proto-randrproto-devel >= 1.3
307 Requires:       xorg-proto-renderproto-devel >= 0.11
308 Requires:       xorg-proto-videoproto-devel
309 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
310 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
311 Requires:       xorg-proto-xineramaproto-devel
312 Requires:       xorg-proto-xproto-devel >= 7.0.22
313 Obsoletes:      X11-Xserver-devel < 1:7.0.0
314 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
315
316 %description devel
317 Header files for X.org server.
318
319 %description devel -l pl.UTF-8
320 Pliki nagłówkowe dla serwera X.org.
321
322 %package source
323 Summary:        X.org server source code
324 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
325 Group:          X11/Development/Libraries
326
327 %description source
328 X.org server source code.
329
330 %description source -l pl.UTF-8
331 Pliki źródłowe dla serwera X.org.
332
333 %package -n xorg-xserver-libdri
334 Summary:        DRI extension library for X.org server
335 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
336 Group:          X11/Servers
337 Requires:       %{name} = %{version}-%{release}
338 Provides:       xorg-xserver-module(dri)
339
340 %description -n xorg-xserver-libdri
341 DRI extension library for X.org server.
342
343 %description -n xorg-xserver-libdri -l pl.UTF-8
344 Biblioteka rozszerzenia DRI dla serwera X.org.
345
346 %package -n xorg-xserver-libglx
347 Summary:        GLX extension library for X.org server
348 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
349 Group:          X11/Servers
350 Requires:       %{name} = %{version}-%{release}
351 Requires:       xorg-xserver-libdri = %{version}-%{release}
352 # Mesa version glapi tables in glx/ dir come from
353 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
354 Provides:       xorg-xserver-module(glx)
355 Obsoletes:      X11-OpenGL-core < 1:7.0.0
356 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
357
358 %description -n xorg-xserver-libglx
359 GLX extension library for X.org server.
360
361 %description -n xorg-xserver-libglx -l pl.UTF-8
362 Biblioteka rozszerzenia GLX dla serwera X.org.
363
364 %prep
365 %setup -q -n xorg-server-%{version}
366 %patch0 -p0
367 %patch1 -p1
368 %patch2 -p1
369 %patch3 -p1
370 %patch4 -p1
371 %patch5 -p1
372 %patch6 -p1
373 #unfortunately breaks build
374 #patch7 -p1
375
376 # xserver uses pixman-1 API/ABI so put that explictly here
377 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
378
379 %build
380 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
381 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
382         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
383         exit 1
384 fi
385
386 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
387 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
388         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
389         exit 1
390 fi
391
392 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
393 if [ $API != %{xorg_xserver_server_font_abi} ]; then
394         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
395         exit 1
396 fi
397 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
398 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
399         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
400         exit 1
401 fi
402 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
403 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
404         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
405         exit 1
406 fi
407
408 %{__libtoolize}
409 %{__aclocal} -I m4
410 %{__autoconf}
411 %{__autoheader}
412 %{__automake}
413 %configure \
414         --with-os-name="PLD/Linux" \
415         --with-os-vendor="PLD/Team" \
416         --without-fop \
417         %{?with_dbus:--enable-config-dbus} \
418         --enable-config-hal%{!?with_hal:=no} \
419         --enable-config-udev%{!?with_udev:=no} \
420         --enable-aiglx \
421         --enable-dga \
422         %{?with_dmx:--enable-dmx} \
423         --enable-glx-tls \
424         --enable-install-libxf86config \
425         %{?with_record:--enable-record} \
426         --enable-kdrive \
427         %{?with_xcsecurity:--enable-xcsecurity} \
428         --enable-xephyr \
429         %{?with_xf86bigfont:--enable-xf86bigfont} \
430         --enable-xfbdev \
431         %{?with_xselinux:--enable-xselinux} \
432         --enable-glx-tls \
433         --disable-xfake \
434         --enable-secure-rpc \
435         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
436         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
437         --with-xkb-output=/var/lib/xkb
438
439 %{__make}
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443
444 %{__make} install \
445         DESTDIR=$RPM_BUILD_ROOT
446
447 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
448 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
449 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
450 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
451
452 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
453 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
454
455 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
456
457 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
458
459 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
460 install -d $RPM_BUILD_ROOT/etc/sysconfig
461 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
462 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
463
464 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
465 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
466 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
467 %{__make} distclean
468 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
469 find -name '*.h' | xargs chmod a-x
470
471 %clean
472 rm -rf $RPM_BUILD_ROOT
473
474 %triggerpostun -- xorg-xserver-server < 1.5.0
475 if [ -f /etc/X11/xorg.conf ]; then
476         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
477         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
478 %if %{without record}
479         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
480 %endif
481         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
482 fi
483
484 %post -n xorg-xserver-Xvfb-init
485 /sbin/chkconfig --add Xvfb
486 %service Xvfb restart
487
488 %preun -n xorg-xserver-Xvfb-init
489 if [ "$1" = "0" ]; then
490         %service -q Xvfb stop
491         /sbin/chkconfig --del Xvfb
492 fi
493
494 %files
495 %defattr(644,root,root,755)
496 %doc COPYING ChangeLog README
497 %attr(755,root,root) %{_bindir}/X
498 %attr(755,root,root) %{_bindir}/Xorg
499 %attr(4755,root,root) %{_bindir}/Xwrapper
500 %attr(755,root,root) %{_bindir}/cvt
501 %attr(755,root,root) %{_bindir}/gtf
502 %dir %{_libdir}/xorg
503 %{_libdir}/xorg/protocol.txt
504 %dir %{_libdir}/xorg/modules
505 %dir %{_libdir}/xorg/modules/dri
506 %dir %{_libdir}/xorg/modules/drivers
507 %dir %{_libdir}/xorg/modules/extensions
508 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
509 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
510 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
511 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
512 %dir %{_libdir}/xorg/modules/input
513 %dir %{_libdir}/xorg/modules/multimedia
514 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
515 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
516 %dir /var/lib/xkb
517 /var/lib/xkb/README.compiled
518 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
519 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
520 %config(missingok) /etc/security/console.apps/xserver
521 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
522 %dir /etc/X11/xorg.conf.d
523 %dir %{_datadir}/X11/xorg.conf.d
524 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
525 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
526 %{_mandir}/man1/Xorg.1x*
527 %{_mandir}/man1/Xserver.1x*
528 %{_mandir}/man1/cvt.1*
529 %{_mandir}/man1/gtf.1x*
530 %{_mandir}/man4/exa.4*
531 %{_mandir}/man4/fbdevhw.4*
532 %{_mandir}/man5/xorg.conf.5x*
533 %{_mandir}/man5/xorg.conf.d.5x
534
535 %if %{with dmx}
536 %files -n xorg-xserver-Xdmx
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_bindir}/Xdmx
539 %attr(755,root,root) %{_bindir}/dmxaddinput
540 %attr(755,root,root) %{_bindir}/dmxaddscreen
541 %attr(755,root,root) %{_bindir}/dmxinfo
542 %attr(755,root,root) %{_bindir}/dmxreconfig
543 %attr(755,root,root) %{_bindir}/dmxresize
544 %attr(755,root,root) %{_bindir}/dmxrminput
545 %attr(755,root,root) %{_bindir}/dmxrmscreen
546 %attr(755,root,root) %{_bindir}/dmxtodmx
547 %attr(755,root,root) %{_bindir}/dmxwininfo
548 %attr(755,root,root) %{_bindir}/vdltodmx
549 %attr(755,root,root) %{_bindir}/xdmxconfig
550 %{_mandir}/man1/Xdmx.1x*
551 %{_mandir}/man1/dmxtodmx.1x*
552 %{_mandir}/man1/vdltodmx.1x*
553 %{_mandir}/man1/xdmxconfig.1x*
554 %endif
555
556 %files -n xorg-xserver-Xnest
557 %defattr(644,root,root,755)
558 %attr(755,root,root) %{_bindir}/Xnest
559 %{_mandir}/man1/Xnest.1x*
560
561 %files -n xorg-xserver-Xephyr
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/Xephyr
564 %{_mandir}/man1/Xephyr.1x*
565
566 %files -n xorg-xserver-Xfbdev
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/Xfbdev
569
570 %files -n xorg-xserver-Xvfb
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/Xvfb
573 %{_mandir}/man1/Xvfb.1x*
574
575 %files -n xorg-xserver-Xvfb-init
576 %defattr(644,root,root,755)
577 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
578 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
579
580 %files devel
581 %defattr(644,root,root,755)
582 %doc doc/{Xinput,Xserver-spec}.html
583 %{_includedir}/xorg
584 %{_libdir}/libxf86config.a
585 %{_libdir}/libxf86config.la
586 %{_aclocaldir}/xorg-server.m4
587 %{_pkgconfigdir}/xorg-server.pc
588
589 %files source
590 %defattr(644,root,root,755)
591 # keep file perms from install time, but have default defattr to keep adapter happy
592 %defattr(-,root,root,755)
593 %{_usrsrc}/%{name}-%{version}
594
595 %files -n xorg-xserver-libdri
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
598
599 %files -n xorg-xserver-libglx
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.114605 seconds and 4 git commands to generate.