]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- added multigl bcond (see bcond comment)
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1
2 # ABI versions, see hw/xfree86/common/xf86Module.h
3 %define xorg_xserver_server_ansic_abi           0.3
4 %define xorg_xserver_server_extension_abi       0.3
5 %define xorg_xserver_server_font_abi            0.5
6 %define xorg_xserver_server_videodrv_abi        2.0
7 %define xorg_xserver_server_xinput_abi          2.0
8
9 #
10 # Conditional build:
11 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
12
13 Summary:        X.org server
14 Summary(pl.UTF-8):      Serwer X.org
15 Name:           xorg-xserver-server
16 Version:        1.4
17 Release:        3
18 License:        MIT
19 Group:          X11/Servers
20 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
21 # Source0-md5:  a06d9fe4f9f1d459ae02657f9ce64220
22 %define         mesa_version    7.0.1
23 Source1:        http://dl.sourceforge.net/mesa3d/MesaLib-%{mesa_version}.tar.bz2
24 # Source1-md5:  c056abd763e899114bf745c9eedbf9ad
25 Source2:        xserver.pamd
26 Patch0:         %{name}-ncurses.patch
27 Patch1:         %{name}-xwrapper.patch
28 # nasty hack for http://gcc.gnu.org/bugzilla/show_bug.cgi?id=30052
29 Patch2:         %{name}-gcc-x86_64-workaround.patch
30 Patch3:         %{name}-link.patch
31 Patch4:         %{name}-dbus.patch
32 Patch5:         %{name}-dbus_core.patch
33 URL:            http://xorg.freedesktop.org/
34 # for glx headers
35 BuildRequires:  OpenGL-GLX-devel
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 BuildRequires:  cpp
39 BuildRequires:  dbus-devel
40 BuildRequires:  hal-devel
41 BuildRequires:  libdrm-devel >= 2.3.0
42 BuildRequires:  libtool
43 BuildRequires:  ncurses-devel
44 BuildRequires:  pam-devel
45 BuildRequires:  perl-base
46 BuildRequires:  pixman-devel >= 0.9.5
47 BuildRequires:  pkgconfig >= 1:0.19
48 BuildRequires:  xorg-app-mkfontscale
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xorg-lib-libXau-devel
51 BuildRequires:  xorg-lib-libXaw-devel
52 BuildRequires:  xorg-lib-libXdmcp-devel
53 BuildRequires:  xorg-lib-libXext-devel
54 BuildRequires:  xorg-lib-libXfont-devel
55 BuildRequires:  xorg-lib-libXi-devel
56 BuildRequires:  xorg-lib-libXmu-devel
57 BuildRequires:  xorg-lib-libXpm-devel
58 BuildRequires:  xorg-lib-libXrender-devel
59 BuildRequires:  xorg-lib-libXres-devel
60 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
61 BuildRequires:  xorg-lib-libXtst-devel
62 BuildRequires:  xorg-lib-libXxf86dga-devel
63 BuildRequires:  xorg-lib-libXxf86misc-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 BuildRequires:  xorg-lib-libdmx-devel
66 BuildRequires:  xorg-lib-libfontenc-devel
67 BuildRequires:  xorg-lib-liblbxutil-devel
68 BuildRequires:  xorg-lib-libxkbfile-devel
69 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
70 BuildRequires:  xorg-lib-xtrans-devel
71 BuildRequires:  xorg-proto-bigreqsproto-devel
72 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
73 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
74 BuildRequires:  xorg-proto-dmxproto-devel
75 BuildRequires:  xorg-proto-evieext-devel
76 BuildRequires:  xorg-proto-fixesproto-devel >= 4.0
77 BuildRequires:  xorg-proto-fontcacheproto-devel
78 BuildRequires:  xorg-proto-fontsproto-devel
79 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
80 BuildRequires:  xorg-proto-inputproto-devel >= 1.4.2
81 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
82 BuildRequires:  xorg-proto-printproto-devel
83 BuildRequires:  xorg-proto-randrproto-devel >= 1.2
84 BuildRequires:  xorg-proto-recordproto-devel
85 BuildRequires:  xorg-proto-renderproto-devel >= 0.9.3
86 BuildRequires:  xorg-proto-resourceproto-devel
87 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
88 BuildRequires:  xorg-proto-trapproto-devel
89 BuildRequires:  xorg-proto-videoproto-devel
90 BuildRequires:  xorg-proto-xcmiscproto-devel
91 BuildRequires:  xorg-proto-xextproto-devel
92 BuildRequires:  xorg-proto-xf86bigfontproto-devel
93 BuildRequires:  xorg-proto-xf86dgaproto-devel
94 BuildRequires:  xorg-proto-xf86driproto-devel
95 BuildRequires:  xorg-proto-xf86miscproto-devel
96 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
97 BuildRequires:  xorg-proto-xineramaproto-devel
98 BuildRequires:  xorg-proto-xproto-devel >= 7.0.9
99 BuildRequires:  xorg-util-util-macros >= 0.99.2
100 #BR: xcalibrateproto, tslib (for KDRIVE only)
101 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
102 Requires:       pixman >= 0.9.5
103 Requires:       xkeyboard-config
104 # for rgb.txt
105 Requires:       xorg-app-rgb >= 0.99.3
106 Requires:       xorg-app-xkbcomp
107 # xserver requires fixed and cursor fonts
108 Requires:       xorg-font-font-alias
109 Requires:       xorg-font-font-cursor-misc
110 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
111 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
112 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
113 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
114 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
115 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
116 Obsoletes:      X11-Xserver < 1:7.0.0
117 Obsoletes:      X11-driver-i2c < 1:7.0.0
118 Obsoletes:      X11-modules < 1:7.0.0
119 Obsoletes:      X11-setup < 1:7.0.0
120 Obsoletes:      XFree86-Xserver < 1:7.0.0
121 Obsoletes:      XFree86-modules < 1:7.0.0
122 Obsoletes:      XFree86-setup < 1:7.0.0
123 Obsoletes:      Xserver
124 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
125
126 # avoid self-dependencies on included modules
127 %define         _noautoreq      libscanpci.so libxf1bpp.so
128
129 %description
130 Xorg server is a generally used X server which uses display hardware.
131 It requires proper driver for your display hardware.
132
133 %description -l pl.UTF-8
134 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
135 graficznej. Do działania wymaga odpowiedniego sterownika.
136
137 %package -n xorg-xserver-Xdmx
138 Summary:        Xdmx - distributed multi-head X server
139 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
140 Group:          X11/Servers
141
142 %description -n xorg-xserver-Xdmx
143 Xdmx - distributed multi-head X server.
144
145 %description -n xorg-xserver-Xdmx -l pl.UTF-8
146 Xdmx - rozproszony, wielomonitorowy serwer X.
147
148 %package -n xorg-xserver-Xnest
149 Summary:        Xnest - nested X server
150 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
151 Group:          X11/Servers
152 Obsoletes:      X11-Xnest < 1:7.0.0
153 Obsoletes:      XFree86-Xnest < 1:7.0.0
154 Obsoletes:      Xserver-Xnest
155
156 %description -n xorg-xserver-Xnest
157 Xnest is an X Window System server which runs in an X window. Xnest is
158 a 'nested' window server, actually a client of the real X server,
159 which manages windows and graphics requests for Xnest, while Xnest
160 manages the windows and graphics requests for its own clients.
161
162 %description -n xorg-xserver-Xnest -l pl.UTF-8
163 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
164 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
165 serwer X dla własnych klientów.
166
167 %description -n xorg-xserver-Xnest -l ru.UTF-8
168 Xnest - это сервер X Window System, который работает в окне X. На
169 самом деле это клиент реального X-сервера, который управляет окнами и
170 графическими запросами для Xnest в то время, как Xnest управляет
171 окнами и графическими запросами для своих собственных клиентов.
172
173 %description -n xorg-xserver-Xnest -l uk.UTF-8
174 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
175 клієнт реального X-сервера, який керує вікнами та графічними запитами
176 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
177 своїх власних клієнтів.
178
179 %package -n xorg-xserver-Xprt
180 Summary:        Xprt - Xprint server for X
181 Summary(pl.UTF-8):      Xprt - serwer Xprint dla X
182 Group:          X11/Servers
183 Obsoletes:      X11-Xprt < 1:7.0.0
184 Obsoletes:      XFree86-Xprt < 1:7.0.0
185
186 %description -n xorg-xserver-Xprt
187 Xprt is the Xprint print server for X Window System for non display
188 devices such as printers and fax machines.
189
190 %description -n xorg-xserver-Xprt -l pl.UTF-8
191 Xprt to serwer wydruków Xprint dla X Window System dla urządzeń nie
192 wyświetlających, takich jak drukarki czy faksy.
193
194 %package -n xorg-xserver-Xvfb
195 Summary:        Xvfb - virtual framebuffer X server
196 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
197 Group:          X11/Servers
198 # requires fixed and cursor fonts
199 Requires:       xorg-font-font-alias
200 Requires:       xorg-font-font-cursor-misc
201 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
202 Obsoletes:      X11-Xvfb < 1:7.0.0
203 Obsoletes:      XFree86-Xvfb < 1:7.0.0
204
205 %description -n xorg-xserver-Xvfb
206 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
207 capable of running on machines with no display hardware and no
208 physical input devices. Xvfb emulates a dumb framebuffer using virtual
209 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
210 display. Xvfb is normally used for testing servers. Using Xvfb, the
211 mfb or cfb code for any depth can be exercised without using real
212 hardware that supports the desired depths. Xvfb has also been used to
213 test X clients against unusual depths and screen configurations, to do
214 batch processing with Xvfb as a background rendering engine, to do
215 load testing, to help with porting an X server to a new platform, and
216 to provide an unobtrusive way of running applications which really
217 don't need an X server but insist on having one.
218
219 %description -n xorg-xserver-Xvfb -l pl.UTF-8
220 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
221 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
222 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
223 używany do testowania serwerów X, może też być używany do testowania
224 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
225 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
226 serwera X, ale odmawiają uruchomienia bez niego.
227
228 %package devel
229 Summary:        Header files for X.org server
230 Summary(pl.UTF-8):      Pliki nagłówkowe dla servera X.org
231 Group:          X11/Development/Libraries
232 Requires:       libdrm-devel >= 2.3.0
233 Requires:       pixman-devel >= 0.9.5
234 Requires:       xorg-proto-fontsproto-devel
235 Requires:       xorg-proto-renderproto-devel >= 0.9.3
236 Requires:       xorg-proto-videoproto-devel
237 Requires:       xorg-proto-xextproto-devel
238 Requires:       xorg-proto-xproto-devel >= 7.0.9
239 Obsoletes:      X11-Xserver-devel < 1:7.0.0
240 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
241
242 %description devel
243 Header files for X.org server.
244
245 %description devel -l pl.UTF-8
246 Pliki nagłówkowe dla serwera X.org.
247
248 %package xorgcfg
249 Summary:        xorgcfg - graphical configuration tool for X.org server
250 Summary(pl.UTF-8):      xorgcfg - graficzne narzędzie konfiguracyjne dla serwera X.org
251 Group:          X11/Servers
252 Requires:       %{name} = %{version}-%{release}
253 # just for %{_includedir}/bitmaps dir?
254 Requires:       xorg-data-xbitmaps
255 # for new app-defaults location
256 Requires:       xorg-lib-libXt >= 1.0.0
257 Requires:       xorg-lib-libxkbui >= 1.0.2
258
259 %description xorgcfg
260 xorgcfg is a tool to configure X.org server, and can be used to either
261 write the initial configuration file or make customizations to the
262 current configuration.
263
264 %description xorgcfg -l pl.UTF-8
265 xorgcfg to narzędzie do konfiguracji serwera X.org. Można go użyć do
266 utworzenia początkowego pliku konfiguracyjnego lub dokonania
267 modyfikacji istniejącej konfiguracji.
268
269 %package -n xorg-xserver-libglx
270 Summary:        GLX extension library fo X.org server
271 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
272 Group:          X11/Servers
273 Requires:       %{name} = %{version}-%{release}
274 Provides:       xorg-xserver-libglx(glapi) = %{mesa_version}
275 Provides:       xorg-xserver-modules-libglx
276 Obsoletes:      X11-OpenGL-core < 1:7.0.0
277 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
278 Conflicts:      xorg-driver-video-nvidia
279
280 %description -n xorg-xserver-libglx
281 GLX extension library fo X.org server.
282
283 %description -n xorg-xserver-libglx -l pl.UTF-8
284 Biblioteka rozszerzenia GLX dla serwera X.org.
285
286 %prep
287 %setup -q -a1 -n xorg-server-%{version}
288 %patch0 -p1
289 %patch1 -p0
290 %ifarch %{x8664} i486
291 %patch2 -p1
292 %endif
293 %patch3 -p1
294 %patch4 -p0
295 %patch5 -p1
296
297 # xserver uses pixman-1 API/ABI so put that explictly here
298 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
299
300 %build
301 if API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h) && \
302         [ $API != %{xorg_xserver_server_ansic_abi} ]; then
303         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
304         exit 1
305 fi
306
307 if API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h) && \
308         [ $API != %{xorg_xserver_server_extension_abi} ]; then
309         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
310         exit 1
311 fi
312
313 if API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h) && \
314         [ $API != %{xorg_xserver_server_font_abi} ]; then
315         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
316         exit 1
317 fi
318 if API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h) && \
319         [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
320         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
321         exit 1
322 fi
323 if API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h) && \
324         [ $API != %{xorg_xserver_server_xinput_abi} ]; then
325         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
326         exit 1
327 fi
328
329 %{__libtoolize}
330 %{__aclocal}
331 %{__autoconf}
332 %{__autoheader}
333 %{__automake}
334 %configure \
335         --with-os-name="PLD/Linux" \
336         --with-os-vendor="PLD/Team" \
337         --enable-aiglx \
338         --enable-builddocs \
339         --enable-dga \
340         --enable-dmx \
341         --enable-glx-tls \
342         --enable-lbx \
343         --enable-xevie \
344         --enable-xorgcfg \
345         --enable-xprint \
346         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
347         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
348         --with-mesa-source="`pwd`/Mesa-%{mesa_version}" \
349         --with-xkb-output=/var/lib/xkb
350
351 %{__make}
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355
356 %{__make} install \
357         DESTDIR=$RPM_BUILD_ROOT
358
359 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
360 install -d $RPM_BUILD_ROOT/etc/security/console.apps
361 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
362 install hw/xfree86/parser/xf86Parser.h $RPM_BUILD_ROOT%{_includedir}/xorg/xf86Parser.h
363 install hw/xfree86/parser/xf86Optrec.h $RPM_BUILD_ROOT%{_includedir}/xorg/xf86Optrec.h
364 install hw/xfree86/parser/libxf86config.a $RPM_BUILD_ROOT%{_libdir}/libxf86config.a
365 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
366 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
367
368 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
369
370 %if %{with multigl}
371 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
372 mv -f libglx.so libglx.so.%{version}
373 ln -sf libglx.so.%{version} libglx.so
374 %endif
375
376 %clean
377 rm -rf $RPM_BUILD_ROOT
378
379 %files
380 %defattr(644,root,root,755)
381 %doc COPYING ChangeLog
382 %attr(755,root,root) %{_bindir}/X
383 %attr(755,root,root) %{_bindir}/Xorg
384 %attr(4755,root,root) %{_bindir}/Xwrapper
385 %attr(755,root,root) %{_bindir}/cvt
386 %attr(755,root,root) %{_bindir}/gtf
387 %attr(755,root,root) %{_bindir}/in[bwl]
388 %attr(755,root,root) %{_bindir}/ioport
389 %attr(755,root,root) %{_bindir}/out[bwl]
390 %attr(755,root,root) %{_bindir}/pcitweak
391 %attr(755,root,root) %{_bindir}/scanpci
392 %attr(755,root,root) %{_bindir}/xorgconfig
393 %{_libdir}/X11/Cards
394 %{_libdir}/X11/Options
395 %dir %{_libdir}/xorg
396 %dir %{_libdir}/xorg/modules
397 %dir %{_libdir}/xorg/modules/dri
398 %dir %{_libdir}/xorg/modules/drivers
399 %dir %{_libdir}/xorg/modules/extensions
400 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libGLcore.so
401 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
402 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
403 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
404 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so
405 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libxtrap.so
406 %dir %{_libdir}/xorg/modules/fonts
407 %attr(755,root,root) %{_libdir}/xorg/modules/fonts/lib*.so
408 %dir %{_libdir}/xorg/modules/input
409 %dir %{_libdir}/xorg/modules/linux
410 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
411 %dir %{_libdir}/xorg/modules/multimedia
412 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
413 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
414 %dir %{_libdir}/xserver
415 %{_libdir}/xserver/SecurityPolicy
416 %dir /var/lib/xkb
417 /var/lib/xkb/README.compiled
418 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
419 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
420 %config(missingok) /etc/security/console.apps/xserver
421 %{_mandir}/man1/Xorg.1x*
422 %{_mandir}/man1/Xserver.1x*
423 %{_mandir}/man1/cvt.1*
424 %{_mandir}/man1/gtf.1x*
425 %{_mandir}/man1/pcitweak.1x*
426 %{_mandir}/man1/scanpci.1x*
427 %{_mandir}/man1/xorgconfig.1*
428 %{_mandir}/man4/exa.4*
429 %{_mandir}/man4/fbdevhw.4*
430 %{_mandir}/man5/xorg.conf.5x*
431 %{_mandir}/man5/SecurityPolicy.5x*
432
433 %files -n xorg-xserver-Xdmx
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_bindir}/Xdmx
436 %attr(755,root,root) %{_bindir}/dmxaddinput
437 %attr(755,root,root) %{_bindir}/dmxaddscreen
438 %attr(755,root,root) %{_bindir}/dmxreconfig
439 %attr(755,root,root) %{_bindir}/dmxresize
440 %attr(755,root,root) %{_bindir}/dmxrminput
441 %attr(755,root,root) %{_bindir}/dmxrmscreen
442 %attr(755,root,root) %{_bindir}/dmxtodmx
443 %attr(755,root,root) %{_bindir}/dmxwininfo
444 %attr(755,root,root) %{_bindir}/vdltodmx
445 %attr(755,root,root) %{_bindir}/xdmx
446 %attr(755,root,root) %{_bindir}/xdmxconfig
447 %{_mandir}/man1/Xdmx.1x*
448 %{_mandir}/man1/dmxtodmx.1x*
449 %{_mandir}/man1/vdltodmx.1x*
450 %{_mandir}/man1/xdmxconfig.1x*
451
452 %files -n xorg-xserver-Xnest
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_bindir}/Xnest
455 %{_mandir}/man1/Xnest.1x*
456
457 %files -n xorg-xserver-Xprt
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_bindir}/Xprt
460 %{_libdir}/X11/xserver
461 %{_mandir}/man1/Xprt.1x*
462
463 %files -n xorg-xserver-Xvfb
464 %defattr(644,root,root,755)
465 %attr(755,root,root) %{_bindir}/Xvfb
466 %{_mandir}/man1/Xvfb.1x*
467
468 %files devel
469 %defattr(644,root,root,755)
470 %{_includedir}/xorg
471 %{_libdir}/libxf86config.a
472 %{_aclocaldir}/xorg-server.m4
473 %{_pkgconfigdir}/xorg-server.pc
474
475 %files xorgcfg
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/xorgcfg
478 %{_includedir}/X11/bitmaps/*
479 %{_includedir}/X11/pixmaps
480 %{_datadir}/X11/app-defaults/XOrgCfg
481 %{_mandir}/man1/xorgcfg.1x*
482
483 %files -n xorg-xserver-libglx
484 %defattr(644,root,root,755)
485 %if %{with multigl}
486 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
487 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
488 %else
489 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
490 %endif
This page took 0.066411 seconds and 4 git commands to generate.