]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- O: glamor
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dmx             # DMX support
10 %bcond_without  dri2            # DRI2 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_without  systemtap       # systemtap/dtrace probes
13 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
14 %bcond_with     xf86bigfont     # XF86BigFont extension
15 %bcond_with     xselinux        # SELinux extension
16 #
17 # ABI versions, see hw/xfree86/common/xf86Module.h
18 %define xorg_xserver_server_ansic_abi           0.4
19 %define xorg_xserver_server_extension_abi       8.0
20 %define xorg_xserver_server_font_abi            0.6
21 %define xorg_xserver_server_videodrv_abi        18.0
22 %define xorg_xserver_server_xinput_abi          21.0
23
24 %define pixman_ver      0.30.0
25
26 Summary:        X.org server
27 Summary(pl.UTF-8):      Serwer X.org
28 Name:           xorg-xserver-server
29 Version:        1.16.0
30 Release:        1
31 License:        MIT
32 Group:          X11/Servers
33 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
34 # Source0-md5:  8a9ff6ee9907360f09b5bdabb8089502
35 Source1:        10-quirks.conf
36 Source2:        xserver.pamd
37 Source10:       %{name}-Xvfb.init
38 Source11:       %{name}-Xvfb.sysconfig
39 Source12:       xvfb-run.sh
40
41 Patch0:         %{name}-xwrapper.patch
42 Patch1:         %{name}-pic-libxf86config.patch
43
44 Patch4:         %{name}-builtin-SHA1.patch
45 Patch5:         %{name}-export-GetMaster.patch
46 Patch6:         110_nvidia_slowdow_fix.patch
47 Patch7:         %{name}-include-defs.patch
48 URL:            http://xorg.freedesktop.org/
49 BuildRequires:  Mesa-libGL-devel >= 7.8.1
50 # for glx headers
51 BuildRequires:  OpenGL-GLX-devel
52 %{?with_xselinux:BuildRequires: audit-libs-devel}
53 BuildRequires:  autoconf >= 2.60
54 BuildRequires:  automake
55 BuildRequires:  cpp
56 BuildRequires:  docbook-dtd43-xml
57 #BuildRequires: doxygen >= 1.6.1
58 %if %{with hal} || %{with dbus}
59 BuildRequires:  dbus-devel >= 1.0
60 %endif
61 %{?with_hal:BuildRequires:      hal-devel}
62 BuildRequires:  libdrm-devel >= 2.4.39
63 BuildRequires:  libepoxy-devel
64 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
65 BuildRequires:  libtool
66 BuildRequires:  libunwind-devel
67 BuildRequires:  libxcb-devel >= 1.6
68 BuildRequires:  ncurses-devel
69 BuildRequires:  pam-devel
70 BuildRequires:  perl-base
71 BuildRequires:  pixman-devel >= %{pixman_ver}
72 BuildRequires:  pkgconfig >= 1:0.19
73 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
74 BuildRequires:  udev-devel >= 1:143
75 BuildRequires:  wayland-devel
76 BuildRequires:  xcb-util-devel
77 BuildRequires:  xcb-util-image-devel
78 BuildRequires:  xcb-util-keysyms-devel
79 BuildRequires:  xcb-util-wm-devel
80 BuildRequires:  xmlto >= 0.0.20
81 BuildRequires:  xorg-app-mkfontscale
82 BuildRequires:  xorg-font-font-util >= 1.1
83 BuildRequires:  xorg-lib-libX11-devel >= 1.6
84 BuildRequires:  xorg-lib-libXau-devel
85 BuildRequires:  xorg-lib-libXaw-devel
86 BuildRequires:  xorg-lib-libXdamage-devel
87 BuildRequires:  xorg-lib-libXdmcp-devel
88 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
89 BuildRequires:  xorg-lib-libXfixes-devel
90 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
91 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
92 BuildRequires:  xorg-lib-libXmu-devel
93 BuildRequires:  xorg-lib-libXpm-devel
94 BuildRequires:  xorg-lib-libXrender-devel
95 BuildRequires:  xorg-lib-libXres-devel
96 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
97 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
98 BuildRequires:  xorg-lib-libXv-devel
99 BuildRequires:  xorg-lib-libXxf86dga-devel
100 BuildRequires:  xorg-lib-libXxf86misc-devel
101 BuildRequires:  xorg-lib-libXxf86vm-devel
102 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
103 BuildRequires:  xorg-lib-libfontenc-devel
104 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
105 BuildRequires:  xorg-lib-libxkbfile-devel
106 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
107 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.2
108 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
109 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
110 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
111 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
112 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
113 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
114 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
115 BuildRequires:  xorg-proto-fontcacheproto-devel
116 BuildRequires:  xorg-proto-fontsproto-devel
117 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
118 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
119 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
120 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
121 BuildRequires:  xorg-proto-printproto-devel
122 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
123 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
124 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
125 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
126 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
127 BuildRequires:  xorg-proto-videoproto-devel
128 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
129 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
130 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
131 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
132 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
133 BuildRequires:  xorg-proto-xf86miscproto-devel
134 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
135 BuildRequires:  xorg-proto-xineramaproto-devel
136 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
137 BuildRequires:  xorg-sgml-doctools >= 1.8
138 BuildRequires:  xorg-util-util-macros >= 1.14
139 #BR: tslib (for KDRIVE only)
140 Requires(triggerpostun):        sed >= 4.0
141 Requires:       libdrm >= 2.4.39
142 Requires:       pixman >= %{pixman_ver}
143 Requires:       udev-libs >= 1:143
144 Requires:       xkeyboard-config
145 # for rgb.txt
146 Requires:       xorg-app-rgb >= 0.99.3
147 Requires:       xorg-app-xkbcomp
148 # xserver requires fixed and cursor fonts
149 Requires:       xorg-font-font-alias
150 Requires:       xorg-font-font-cursor-misc
151 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
152 Requires:       xorg-lib-libXfont >= 1.4.2
153 Requires:       xorg-lib-libpciaccess >= 0.12.901
154 Requires:       xorg-lib-libxshmfence >= 1.1
155 Suggests:       dbus-x11 >= 1.0
156 %{?with_hal:Suggests:   hal}
157 Suggests:       udev-acl >= 1:143
158 %{?with_udev:Suggests:  udev-core >= 1:143}
159 Suggests:       xkeyboard-config
160 Suggests:       xorg-driver-input-evdev
161 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
162 Suggests:       xorg-driver-video
163 Provides:       xorg-xserver-libdri = %{version}-%{release}
164 Provides:       xorg-xserver-module(dri)
165 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
166 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
167 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
168 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
169 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
170 Obsoletes:      X11-Xserver < 1:7.0.0
171 Obsoletes:      X11-driver-i2c < 1:7.0.0
172 Obsoletes:      X11-modules < 1:7.0.0
173 Obsoletes:      X11-setup < 1:7.0.0
174 Obsoletes:      XFree86-Xserver < 1:7.0.0
175 Obsoletes:      XFree86-modules < 1:7.0.0
176 Obsoletes:      XFree86-setup < 1:7.0.0
177 Obsoletes:      Xserver
178 Obsoletes:      glamor
179 Obsoletes:      xorg-xserver-libdri
180 Obsoletes:      xorg-xserver-server-xorgcfg
181 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
182
183 # avoid self-dependencies on included modules
184 %define         _noautoreq      libscanpci.so libxf1bpp.so
185
186 %description
187 Xorg server is a generally used X server which uses display hardware.
188 It requires proper driver for your display hardware.
189
190 %description -l pl.UTF-8
191 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
192 graficznej. Do działania wymaga odpowiedniego sterownika.
193
194 %package -n xorg-xserver-Xdmx
195 Summary:        Xdmx - distributed multi-head X server
196 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
197 Group:          X11/Servers
198 Requires:       pixman >= %{pixman_ver}
199 Requires:       xorg-lib-libX11 >= 1.6
200 Requires:       xorg-lib-libXext >= 1.0.99.4
201 Requires:       xorg-lib-libXfont >= 1.4.2
202 Requires:       xorg-lib-libXi >= 1.2.99.1
203 Requires:       xorg-lib-libdmx >= 1.0.99.1
204
205 %description -n xorg-xserver-Xdmx
206 Xdmx - distributed multi-head X server.
207
208 %description -n xorg-xserver-Xdmx -l pl.UTF-8
209 Xdmx - rozproszony, wielomonitorowy serwer X.
210
211 %package -n xorg-xserver-Xnest
212 Summary:        Xnest - nested X server
213 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
214 Group:          X11/Servers
215 Requires:       pixman >= %{pixman_ver}
216 Requires:       xorg-lib-libXext >= 1.0.99.4
217 Requires:       xorg-lib-libXfont >= 1.4.2
218 Obsoletes:      X11-Xnest < 1:7.0.0
219 Obsoletes:      XFree86-Xnest < 1:7.0.0
220 Obsoletes:      Xserver-Xnest
221
222 %description -n xorg-xserver-Xnest
223 Xnest is an X Window System server which runs in an X window. Xnest is
224 a 'nested' window server, actually a client of the real X server,
225 which manages windows and graphics requests for Xnest, while Xnest
226 manages the windows and graphics requests for its own clients.
227
228 %description -n xorg-xserver-Xnest -l pl.UTF-8
229 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
230 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
231 serwer X dla własnych klientów.
232
233 %description -n xorg-xserver-Xnest -l ru.UTF-8
234 Xnest - это сервер X Window System, который работает в окне X. На
235 самом деле это клиент реального X-сервера, который управляет окнами и
236 графическими запросами для Xnest в то время, как Xnest управляет
237 окнами и графическими запросами для своих собственных клиентов.
238
239 %description -n xorg-xserver-Xnest -l uk.UTF-8
240 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
241 клієнт реального X-сервера, який керує вікнами та графічними запитами
242 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
243 своїх власних клієнтів.
244
245 %package -n xorg-xserver-Xephyr
246 Summary:        Xephyr - nested X server
247 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
248 Group:          X11/Servers
249 Requires:       Mesa-libGL >= 7.1.0
250 Requires:       libxcb >= 1.6
251 Requires:       pixman >= %{pixman_ver}
252 Requires:       xorg-lib-libXfont >= 1.4.2
253
254 %description -n xorg-xserver-Xephyr
255 Xephyr is a a kdrive server that outputs to a window on a pre-existing
256 'host' X display. Think Xnest but with support for modern extensions
257 like composite, damage and randr.
258
259 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
260 the host X server, Xephyr is a real X server which uses the host X
261 server window as "framebuffer" via fast SHM XImages.
262
263 It also has support for 'visually' debugging what the server is
264 painting.
265
266 %description -n xorg-xserver-Xephyr -l pl.UTF-8
267 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
268 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
269 wspólczesnych rozszerzeń jak composite, damage i randr.
270
271 %package -n xorg-xserver-Xfbdev
272 Summary:        Xfbdev - Linux framebuffer device X server
273 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
274 Group:          X11/Servers
275 Requires:       pixman >= %{pixman_ver}
276 Requires:       xorg-lib-libXfont >= 1.4.2
277
278 %description -n xorg-xserver-Xfbdev
279 Xfbdev is a Linux framebuffer device X server based on the kdrive X
280 server.
281
282 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
283 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
284
285 %package -n xorg-xserver-Xvfb
286 Summary:        Xvfb - virtual framebuffer X server
287 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
288 Group:          X11/Servers
289 Requires:       Mesa-libGL >= 7.1.0
290 Requires:       mktemp
291 Requires:       pixman >= %{pixman_ver}
292 Requires:       util-linux
293 Requires:       which
294 Requires:       xkeyboard-config
295 Requires:       xorg-app-xauth
296 Requires:       xorg-app-xkbcomp
297 # requires fixed and cursor fonts
298 Requires:       xorg-font-font-alias
299 Requires:       xorg-font-font-cursor-misc
300 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
301 Requires:       xorg-lib-libXfont >= 1.4.2
302 Obsoletes:      X11-Xvfb < 1:7.0.0
303 Obsoletes:      XFree86-Xvfb < 1:7.0.0
304
305 %description -n xorg-xserver-Xvfb
306 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
307 capable of running on machines with no display hardware and no
308 physical input devices. Xvfb emulates a dumb framebuffer using virtual
309 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
310 display. Xvfb is normally used for testing servers. Using Xvfb, the
311 mfb or cfb code for any depth can be exercised without using real
312 hardware that supports the desired depths. Xvfb has also been used to
313 test X clients against unusual depths and screen configurations, to do
314 batch processing with Xvfb as a background rendering engine, to do
315 load testing, to help with porting an X server to a new platform, and
316 to provide an unobtrusive way of running applications which really
317 don't need an X server but insist on having one.
318
319 %description -n xorg-xserver-Xvfb -l pl.UTF-8
320 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
321 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
322 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
323 używany do testowania serwerów X, może też być używany do testowania
324 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
325 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
326 serwera X, ale odmawiają uruchomienia bez niego.
327
328 %package -n xorg-xserver-Xvfb-init
329 Summary:        Init scripts for Xvfb
330 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
331 Group:          X11/Servers
332 Requires:       xorg-xserver-Xvfb
333
334 %description -n xorg-xserver-Xvfb-init
335 This package contains init scripts for Xvfb and registers Xvfb as
336 system service.
337
338 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
339 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
340 usługę systemową.
341
342 %package -n xorg-xserver-Xwayland
343 Summary:        Xwayland - X server integrated into a Wayland window system
344 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
345 Group:          X11/Servers
346 Requires:       pixman >= %{pixman_ver}
347 Requires:       xorg-lib-libX11 >= 1.6
348 Requires:       xorg-lib-libXext >= 1.0.99.4
349 Requires:       xorg-lib-libXfont >= 1.4.2
350 Requires:       xorg-lib-libXi >= 1.2.99.1
351
352 %description -n xorg-xserver-Xwayland
353 Xwayland - server integrated into a Wayland window system.
354
355 %description -n xorg-xserver-Xwayland -l pl.UTF-8
356 Xwayland - serwer X integrowalny w Wayland.
357
358 %package devel
359 Summary:        Header files for X.org server
360 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
361 Group:          X11/Development/Libraries
362 Requires:       Mesa-libGL-devel >= 7.8.0
363 Requires:       libdrm-devel >= 2.4.39
364 Requires:       pixman-devel >= %{pixman_ver}
365 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
366 Requires:       xorg-lib-libxkbfile-devel
367 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
368 Requires:       xorg-proto-dri3proto-devel >= 1.0
369 Requires:       xorg-proto-fontsproto-devel
370 Requires:       xorg-proto-glproto-devel >= 1.4.17
371 Requires:       xorg-proto-inputproto-devel >= 2.3
372 Requires:       xorg-proto-kbproto-devel >= 1.0.3
373 Requires:       xorg-proto-presentproto-devel >= 1.0
374 Requires:       xorg-proto-randrproto-devel >= 1.4.0
375 Requires:       xorg-proto-renderproto-devel >= 0.11
376 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
377 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
378 Requires:       xorg-proto-videoproto-devel
379 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
380 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
381 Requires:       xorg-proto-xineramaproto-devel
382 Requires:       xorg-proto-xproto-devel >= 7.0.22
383 Obsoletes:      X11-Xserver-devel < 1:7.0.0
384 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
385 Obsoletes:      glamor-devel
386
387 %description devel
388 Header files for X.org server.
389
390 %description devel -l pl.UTF-8
391 Pliki nagłówkowe dla serwera X.org.
392
393 %package source
394 Summary:        X.org server source code
395 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
396 Group:          X11/Development/Libraries
397
398 %description source
399 X.org server source code.
400
401 %description source -l pl.UTF-8
402 Pliki źródłowe dla serwera X.org.
403
404 %package -n xorg-xserver-libglx
405 Summary:        GLX extension library for X.org server
406 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
407 Group:          X11/Servers
408 Requires:       %{name} = %{version}-%{release}
409 Requires:       Mesa-libGL >= 7.1.0
410 # Mesa version glapi tables in glx/ dir come from
411 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
412 Provides:       xorg-xserver-module(glx)
413 Obsoletes:      X11-OpenGL-core < 1:7.0.0
414 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
415
416 %description -n xorg-xserver-libglx
417 GLX extension library for X.org server.
418
419 %description -n xorg-xserver-libglx -l pl.UTF-8
420 Biblioteka rozszerzenia GLX dla serwera X.org.
421
422 %prep
423 %setup -q -n xorg-server-%{version}
424 %patch0 -p0
425 %patch1 -p1
426
427 %patch4 -p1
428 %patch5 -p1
429 %patch6 -p1
430
431 #unfortunately breaks build
432 #patch7 -p1
433
434 # xserver uses pixman-1 API/ABI so put that explictly here
435 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
436
437 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
438 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
439
440 %build
441 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
442 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
443         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
444         exit 1
445 fi
446
447 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
448 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
449         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
450         exit 1
451 fi
452
453 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
454 if [ $API != %{xorg_xserver_server_font_abi} ]; then
455         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
456         exit 1
457 fi
458 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
459 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
460         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
461         exit 1
462 fi
463 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
464 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
465         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
466         exit 1
467 fi
468
469 %{__libtoolize}
470 %{__aclocal} -I m4
471 %{__autoconf}
472 %{__autoheader}
473 %{__automake}
474 %configure \
475         --with-os-name="PLD/Linux" \
476         --with-os-vendor="PLD/Team" \
477         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
478         --with-xkb-output=/var/lib/xkb \
479         %{!?with_systemtap:--without-dtrace} \
480         --without-fop \
481         --disable-linux-acpi \
482         --disable-linux-apm \
483         --enable-aiglx \
484         %{?with_dbus:--enable-config-dbus} \
485         --enable-config-hal%{!?with_hal:=no} \
486         --enable-config-udev%{!?with_udev:=no} \
487         --enable-dga \
488         %{?with_dmx:--enable-dmx} \
489         --enable-dri2%{!?with_dri2:=no} \
490         --enable-glx-tls \
491         --enable-install-libxf86config \
492         --enable-kdrive \
493         --enable-libunwind \
494         %{?with_record:--enable-record} \
495         --enable-secure-rpc \
496         %{?with_xcsecurity:--enable-xcsecurity} \
497         --enable-xephyr \
498         %{?with_xf86bigfont:--enable-xf86bigfont} \
499         --disable-xfake \
500         --enable-xfbdev \
501         --with-systemd-daemon \
502         --enable-xwayland \
503         --enable-glamor \
504         %{?with_xselinux:--enable-xselinux}
505
506 %{__make}
507
508 %install
509 rm -rf $RPM_BUILD_ROOT
510
511 %if "%{_libdir}" != "%{_exec_prefix}/lib"
512 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
513 %endif
514
515 %{__make} install \
516         DESTDIR=$RPM_BUILD_ROOT
517
518 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
519 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
520 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
521 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
522 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
523
524 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
525 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
526
527 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
528
529 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
530
531 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
532 install -d $RPM_BUILD_ROOT/etc/sysconfig
533 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
534 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
535
536 # prepare source package
537 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
538 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
539 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
540 %{__make} distclean
541 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
542 find -name '*.h' | xargs chmod a-x
543
544 %if %{with systemtap}
545 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
546 %endif
547
548 %clean
549 rm -rf $RPM_BUILD_ROOT
550
551 %triggerpostun -- xorg-xserver-server < 1.5.0
552 if [ -f /etc/X11/xorg.conf ]; then
553         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
554         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
555 %if %{without record}
556         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
557 %endif
558         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
559 fi
560
561 %post -n xorg-xserver-Xvfb-init
562 /sbin/chkconfig --add Xvfb
563 %service Xvfb restart
564
565 %preun -n xorg-xserver-Xvfb-init
566 if [ "$1" = "0" ]; then
567         %service -q Xvfb stop
568         /sbin/chkconfig --del Xvfb
569 fi
570
571 %files
572 %defattr(644,root,root,755)
573 %doc COPYING ChangeLog README
574 %attr(755,root,root) %{_bindir}/X
575 %attr(755,root,root) %{_bindir}/Xorg
576 %attr(4755,root,root) %{_bindir}/Xwrapper
577 %attr(755,root,root) %{_bindir}/cvt
578 %attr(755,root,root) %{_bindir}/gtf
579 %dir %{_libdir}/xorg
580 %{_libdir}/xorg/protocol.txt
581 %dir %{_libdir}/xorg/modules
582 %dir %{_libdir}/xorg/modules/dri
583 %dir %{_libdir}/xorg/modules/drivers
584 %dir %{_libdir}/xorg/modules/extensions
585 %dir %{_libdir}/xorg/modules/input
586 %dir %{_libdir}/xorg/modules/multimedia
587 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
588 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
589 %if "%{_libdir}" != "%{_exec_prefix}/lib"
590 %dir %{_exec_prefix}/lib/xorg
591 %dir %{_exec_prefix}/lib/xorg/modules
592 %dir %{_exec_prefix}/lib/xorg/modules/dri
593 %endif
594 %dir /var/lib/xkb
595 /var/lib/xkb/README.compiled
596 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
597 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
598 %config(missingok) /etc/security/console.apps/xserver
599 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
600 %dir /etc/X11/xorg.conf.d
601 %dir %{_datadir}/X11/xorg.conf.d
602 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
603 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
604 %{_mandir}/man1/Xorg.1*
605 %{_mandir}/man1/Xserver.1*
606 %{_mandir}/man1/cvt.1*
607 %{_mandir}/man1/gtf.1*
608 %{_mandir}/man4/exa.4*
609 %{_mandir}/man4/fbdevhw.4*
610 %{_mandir}/man5/xorg.conf.5*
611 %{_mandir}/man5/xorg.conf.d.5*
612
613 %if %{with dmx}
614 %files -n xorg-xserver-Xdmx
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/Xdmx
617 %attr(755,root,root) %{_bindir}/dmxaddinput
618 %attr(755,root,root) %{_bindir}/dmxaddscreen
619 %attr(755,root,root) %{_bindir}/dmxinfo
620 %attr(755,root,root) %{_bindir}/dmxreconfig
621 %attr(755,root,root) %{_bindir}/dmxresize
622 %attr(755,root,root) %{_bindir}/dmxrminput
623 %attr(755,root,root) %{_bindir}/dmxrmscreen
624 %attr(755,root,root) %{_bindir}/dmxtodmx
625 %attr(755,root,root) %{_bindir}/dmxwininfo
626 %attr(755,root,root) %{_bindir}/vdltodmx
627 %attr(755,root,root) %{_bindir}/xdmxconfig
628 %{_mandir}/man1/Xdmx.1*
629 %{_mandir}/man1/dmxtodmx.1*
630 %{_mandir}/man1/vdltodmx.1*
631 %{_mandir}/man1/xdmxconfig.1*
632 %endif
633
634 %files -n xorg-xserver-Xnest
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_bindir}/Xnest
637 %{_mandir}/man1/Xnest.1*
638
639 %files -n xorg-xserver-Xephyr
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_bindir}/Xephyr
642 %{_mandir}/man1/Xephyr.1*
643
644 %files -n xorg-xserver-Xfbdev
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/Xfbdev
647
648 %files -n xorg-xserver-Xvfb
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/Xvfb
651 %attr(755,root,root) %{_bindir}/xvfb-run
652 %{_mandir}/man1/Xvfb.1*
653
654 %files -n xorg-xserver-Xvfb-init
655 %defattr(644,root,root,755)
656 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
657 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
658
659 %files -n xorg-xserver-Xwayland
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_bindir}/Xwayland
662
663 %files devel
664 %defattr(644,root,root,755)
665 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
666 %{_includedir}/xorg
667 %{_libdir}/libxf86config.a
668 %{_libdir}/libxf86config.la
669 %{_aclocaldir}/xorg-server.m4
670 %{_pkgconfigdir}/xorg-server.pc
671
672 %files source
673 %defattr(644,root,root,755)
674 # keep file perms from install time, but have default defattr to keep adapter happy
675 %defattr(-,root,root,755)
676 %{_usrsrc}/%{name}-%{version}
677
678 %files -n xorg-xserver-libglx
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.116495 seconds and 4 git commands to generate.