]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
P: xorg-driver-video-modesetting, xorg-driver-video
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       10.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        23.0
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.19.0
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  6a4d01e4e5047ab8f556960424ba1fa9
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49 Patch2:         dtrace-link.patch
50
51 Patch4:         %{name}-builtin-SHA1.patch
52
53 Patch6:         110_nvidia_slowdow_fix.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel >= 209
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 BuildRequires:  xcb-util-devel
88 BuildRequires:  xcb-util-image-devel
89 BuildRequires:  xcb-util-keysyms-devel
90 BuildRequires:  xcb-util-renderutil-devel
91 BuildRequires:  xcb-util-wm-devel
92 BuildRequires:  xmlto >= 0.0.20
93 BuildRequires:  xorg-app-mkfontscale
94 BuildRequires:  xorg-font-font-util >= 1.1
95 BuildRequires:  xorg-lib-libX11-devel >= 1.6
96 BuildRequires:  xorg-lib-libXau-devel
97 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
98 BuildRequires:  xorg-lib-libXdamage-devel
99 BuildRequires:  xorg-lib-libXdmcp-devel
100 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
101 BuildRequires:  xorg-lib-libXfixes-devel
102 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
103 BuildRequires:  xorg-lib-libXfont2-devel
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
106 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
107 BuildRequires:  xorg-lib-libXrender-devel
108 BuildRequires:  xorg-lib-libXres-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
110 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
111 BuildRequires:  xorg-lib-libXv-devel
112 BuildRequires:  xorg-lib-libXxf86dga-devel
113 BuildRequires:  xorg-lib-libXxf86misc-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
116 BuildRequires:  xorg-lib-libfontenc-devel
117 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
118 BuildRequires:  xorg-lib-libxkbfile-devel
119 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
120 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
121 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
122 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
123 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
124 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
125 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
126 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
127 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
128 BuildRequires:  xorg-proto-fontcacheproto-devel
129 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
130 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
131 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
132 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
133 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
134 BuildRequires:  xorg-proto-printproto-devel
135 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
136 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
137 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
138 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
139 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
140 BuildRequires:  xorg-proto-videoproto-devel
141 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
142 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
143 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
144 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
145 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
146 BuildRequires:  xorg-proto-xf86miscproto-devel
147 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
148 BuildRequires:  xorg-proto-xineramaproto-devel
149 BuildRequires:  xorg-proto-xproto-devel >= 7.0.28
150 BuildRequires:  xorg-sgml-doctools >= 1.8
151 BuildRequires:  xorg-util-util-macros >= 1.14
152 #BR: tslib (for KDRIVE only)
153 Requires(triggerpostun):        sed >= 4.0
154 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
155 Requires:       libdrm >= 2.4.46
156 Requires:       pixman >= %{pixman_ver}
157 Requires:       udev-libs >= 1:143
158 Requires:       xkeyboard-config
159 # for rgb.txt
160 Requires:       xorg-app-rgb >= 0.99.3
161 Requires:       xorg-app-xkbcomp
162 Requires:       xorg-lib-libXfont >= 1.4.2
163 Requires:       xorg-lib-libpciaccess >= 0.12.901
164 Requires:       xorg-lib-libxshmfence >= 1.1
165 Suggests:       dbus-x11 >= 1.0
166 %{?with_hal:Suggests:   hal}
167 Suggests:       udev-acl >= 1:143
168 %{?with_udev:Suggests:  udev-core >= 1:143}
169 Suggests:       xkeyboard-config
170 Suggests:       xorg-driver-input-evdev
171 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
172 Suggests:       xorg-driver-video
173 Provides:       xorg-driver-video
174 Provides:       xorg-driver-video-modesetting
175 Provides:       xorg-xserver-libdri = %{version}-%{release}
176 Provides:       xorg-xserver-module(dri)
177 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
178 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
179 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
180 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
181 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
182 Obsoletes:      X11-Xserver < 1:7.0.0
183 Obsoletes:      X11-driver-i2c < 1:7.0.0
184 Obsoletes:      X11-modules < 1:7.0.0
185 Obsoletes:      X11-setup < 1:7.0.0
186 Obsoletes:      XFree86-Xserver < 1:7.0.0
187 Obsoletes:      XFree86-modules < 1:7.0.0
188 Obsoletes:      XFree86-setup < 1:7.0.0
189 Obsoletes:      Xserver
190 %{?with_glamor:Obsoletes:       glamor}
191 Obsoletes:      xorg-xserver-libdri
192 Obsoletes:      xorg-xserver-server-xorgcfg
193 Obsoletes:      xorg-driver-video-modesetting
194 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
195
196 # avoid self-dependencies on included modules
197 %define         _noautoreq      libscanpci.so libxf1bpp.so
198
199 %description
200 Xorg server is a generally used X server which uses display hardware.
201 It requires proper driver for your display hardware.
202
203 %description -l pl.UTF-8
204 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
205 graficznej. Do działania wymaga odpowiedniego sterownika.
206
207 %package -n xorg-xserver-Xdmx
208 Summary:        Xdmx - distributed multi-head X server
209 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
210 Group:          X11/Servers
211 Requires:       pixman >= %{pixman_ver}
212 Requires:       xorg-lib-libX11 >= 1.6
213 Requires:       xorg-lib-libXext >= 1.0.99.4
214 Requires:       xorg-lib-libXfont >= 1.4.2
215 Requires:       xorg-lib-libXi >= 1.2.99.1
216 Requires:       xorg-lib-libdmx >= 1.0.99.1
217
218 %description -n xorg-xserver-Xdmx
219 Xdmx - distributed multi-head X server.
220
221 %description -n xorg-xserver-Xdmx -l pl.UTF-8
222 Xdmx - rozproszony, wielomonitorowy serwer X.
223
224 %package -n xorg-xserver-Xnest
225 Summary:        Xnest - nested X server
226 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
227 Group:          X11/Servers
228 Requires:       pixman >= %{pixman_ver}
229 Requires:       xorg-lib-libXext >= 1.0.99.4
230 Requires:       xorg-lib-libXfont >= 1.4.2
231 Obsoletes:      X11-Xnest < 1:7.0.0
232 Obsoletes:      XFree86-Xnest < 1:7.0.0
233 Obsoletes:      Xserver-Xnest
234
235 %description -n xorg-xserver-Xnest
236 Xnest is an X Window System server which runs in an X window. Xnest is
237 a 'nested' window server, actually a client of the real X server,
238 which manages windows and graphics requests for Xnest, while Xnest
239 manages the windows and graphics requests for its own clients.
240
241 %description -n xorg-xserver-Xnest -l pl.UTF-8
242 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
243 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
244 serwer X dla własnych klientów.
245
246 %description -n xorg-xserver-Xnest -l ru.UTF-8
247 Xnest - это сервер X Window System, который работает в окне X. На
248 самом деле это клиент реального X-сервера, который управляет окнами и
249 графическими запросами для Xnest в то время, как Xnest управляет
250 окнами и графическими запросами для своих собственных клиентов.
251
252 %description -n xorg-xserver-Xnest -l uk.UTF-8
253 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
254 клієнт реального X-сервера, який керує вікнами та графічними запитами
255 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
256 своїх власних клієнтів.
257
258 %package -n xorg-xserver-Xephyr
259 Summary:        Xephyr - nested X server
260 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
261 Group:          X11/Servers
262 Requires:       Mesa-libGL >= 7.1.0
263 Requires:       libxcb >= 1.6
264 Requires:       pixman >= %{pixman_ver}
265 Requires:       xorg-lib-libXfont >= 1.4.2
266
267 %description -n xorg-xserver-Xephyr
268 Xephyr is a kdrive server that outputs to a window on a pre-existing
269 'host' X display. Think Xnest but with support for modern extensions
270 like composite, damage and randr.
271
272 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
273 the host X server, Xephyr is a real X server which uses the host X
274 server window as "framebuffer" via fast SHM XImages.
275
276 It also has support for 'visually' debugging what the server is
277 painting.
278
279 %description -n xorg-xserver-Xephyr -l pl.UTF-8
280 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
281 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
282 wspólczesnych rozszerzeń jak composite, damage i randr.
283
284 %package -n xorg-xserver-Xfbdev
285 Summary:        Xfbdev - Linux framebuffer device X server
286 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
287 Group:          X11/Servers
288 Requires:       pixman >= %{pixman_ver}
289 Requires:       xorg-lib-libXfont >= 1.4.2
290
291 %description -n xorg-xserver-Xfbdev
292 Xfbdev is a Linux framebuffer device X server based on the kdrive X
293 server.
294
295 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
296 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
297
298 %package -n xorg-xserver-Xvfb
299 Summary:        Xvfb - virtual framebuffer X server
300 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
301 Group:          X11/Servers
302 Requires:       Mesa-libGL >= 7.1.0
303 Requires:       mktemp
304 Requires:       pixman >= %{pixman_ver}
305 Requires:       util-linux
306 Requires:       which
307 Requires:       xkeyboard-config
308 Requires:       xorg-app-xauth
309 Requires:       xorg-app-xkbcomp
310 Requires:       xorg-lib-libXfont >= 1.4.2
311 Obsoletes:      X11-Xvfb < 1:7.0.0
312 Obsoletes:      XFree86-Xvfb < 1:7.0.0
313
314 %description -n xorg-xserver-Xvfb
315 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
316 capable of running on machines with no display hardware and no
317 physical input devices. Xvfb emulates a dumb framebuffer using virtual
318 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
319 display. Xvfb is normally used for testing servers. Using Xvfb, the
320 mfb or cfb code for any depth can be exercised without using real
321 hardware that supports the desired depths. Xvfb has also been used to
322 test X clients against unusual depths and screen configurations, to do
323 batch processing with Xvfb as a background rendering engine, to do
324 load testing, to help with porting an X server to a new platform, and
325 to provide an unobtrusive way of running applications which really
326 don't need an X server but insist on having one.
327
328 %description -n xorg-xserver-Xvfb -l pl.UTF-8
329 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
330 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
331 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
332 używany do testowania serwerów X, może też być używany do testowania
333 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
334 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
335 serwera X, ale odmawiają uruchomienia bez niego.
336
337 %package -n xorg-xserver-Xvfb-init
338 Summary:        Init scripts for Xvfb
339 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
340 Group:          X11/Servers
341 Requires:       xorg-xserver-Xvfb
342
343 %description -n xorg-xserver-Xvfb-init
344 This package contains init scripts for Xvfb and registers Xvfb as
345 system service.
346
347 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
348 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
349 usługę systemową.
350
351 %package -n xorg-xserver-Xwayland
352 Summary:        Xwayland - X server integrated into a Wayland window system
353 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
354 Group:          X11/Servers
355 Requires:       pixman >= %{pixman_ver}
356 Requires:       xorg-lib-libX11 >= 1.6
357 Requires:       xorg-lib-libXext >= 1.0.99.4
358 Requires:       xorg-lib-libXfont >= 1.4.2
359 Requires:       xorg-lib-libXi >= 1.2.99.1
360
361 %description -n xorg-xserver-Xwayland
362 Xwayland - server integrated into a Wayland window system.
363
364 %description -n xorg-xserver-Xwayland -l pl.UTF-8
365 Xwayland - serwer X integrowalny w Wayland.
366
367 %package devel
368 Summary:        Header files for X.org server
369 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
370 Group:          X11/Development/Libraries
371 Requires:       Mesa-libGL-devel >= 7.8.0
372 Requires:       libdrm-devel >= 2.4.46
373 Requires:       pixman-devel >= %{pixman_ver}
374 Requires:       xorg-lib-libXfont-devel
375 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
376 Requires:       xorg-lib-libxkbfile-devel
377 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
378 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
379 Requires:       xorg-proto-dri3proto-devel >= 1.0
380 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
381 Requires:       xorg-proto-glproto-devel >= 1.4.17
382 Requires:       xorg-proto-inputproto-devel >= 2.3
383 Requires:       xorg-proto-kbproto-devel >= 1.0.3
384 Requires:       xorg-proto-presentproto-devel >= 1.0
385 Requires:       xorg-proto-randrproto-devel >= 1.5.0
386 Requires:       xorg-proto-renderproto-devel >= 0.11
387 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
388 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
389 Requires:       xorg-proto-videoproto-devel
390 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
391 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
392 Requires:       xorg-proto-xineramaproto-devel
393 Requires:       xorg-proto-xproto-devel >= 7.0.28
394 Obsoletes:      X11-Xserver-devel < 1:7.0.0
395 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
396 %{?with_glamor:Obsoletes:       glamor-devel}
397
398 %description devel
399 Header files for X.org server.
400
401 %description devel -l pl.UTF-8
402 Pliki nagłówkowe dla serwera X.org.
403
404 %package source
405 Summary:        X.org server source code
406 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
407 Group:          X11/Development/Libraries
408
409 %description source
410 X.org server source code.
411
412 %description source -l pl.UTF-8
413 Pliki źródłowe dla serwera X.org.
414
415 %package -n xorg-xserver-libglx
416 Summary:        GLX extension library for X.org server
417 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
418 Group:          X11/Servers
419 Requires:       %{name} = %{version}-%{release}
420 Requires:       Mesa-libGL >= 7.1.0
421 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
422 # Mesa version glapi tables in glx/ dir come from
423 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
424 Provides:       xorg-xserver-module(glx)
425 Obsoletes:      X11-OpenGL-core < 1:7.0.0
426 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
427
428 %description -n xorg-xserver-libglx
429 GLX extension library for X.org server.
430
431 %description -n xorg-xserver-libglx -l pl.UTF-8
432 Biblioteka rozszerzenia GLX dla serwera X.org.
433
434 %prep
435 %setup -q -n xorg-server-%{version}
436 %patch1 -p1
437 %patch2 -p1
438
439 %patch4 -p1
440
441 %patch6 -p1
442
443 # xserver uses pixman-1 API/ABI so put that explictly here
444 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
445
446 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
447 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
448
449 %build
450 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
451 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
452         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
453         exit 1
454 fi
455
456 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
457 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
458         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
459         exit 1
460 fi
461
462 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
463 if [ $API != %{xorg_xserver_server_font_abi} ]; then
464         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
465         exit 1
466 fi
467 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
468 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
469         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
470         exit 1
471 fi
472 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
473 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
474         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
475         exit 1
476 fi
477
478 %{__libtoolize}
479 %{__aclocal} -I m4
480 %{__autoconf}
481 %{__autoheader}
482 %{__automake}
483 %configure \
484         --libexecdir=%{_libdir}/xorg \
485         --with-os-name="PLD/Linux" \
486         --with-os-vendor="PLD/Team" \
487         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
488         --with-xkb-output=/var/lib/xkb \
489         --disable-linux-acpi \
490         --disable-linux-apm \
491         --enable-aiglx \
492         %{?with_dbus:--enable-config-dbus} \
493         --enable-config-hal%{!?with_hal:=no} \
494         --enable-config-udev%{!?with_udev:=no} \
495         --enable-dga \
496         %{?with_dmx:--enable-dmx} \
497         --enable-dri2%{!?with_dri2:=no} \
498         --enable-dri3%{!?with_dri3:=no} \
499         %{?with_glamor:--enable-glamor} \
500         --enable-kdrive \
501         %{?with_libunwind:--enable-libunwind} \
502         %{?with_record:--enable-record} \
503         --enable-secure-rpc \
504         %{?with_xcsecurity:--enable-xcsecurity} \
505         --enable-xephyr \
506         %{?with_xf86bigfont:--enable-xf86bigfont} \
507         --disable-xfake \
508         --enable-xfbdev \
509         %{?with_xselinux:--enable-xselinux} \
510         %{?with_wayland:--enable-xwayland} \
511         %{!?with_systemtap:--without-dtrace} \
512         --without-fop \
513         --enable-suid-wrapper \
514         --with-systemd-daemon
515
516 %{__make} -j1
517
518 %install
519 rm -rf $RPM_BUILD_ROOT
520
521 %if "%{_libdir}" != "%{_exec_prefix}/lib"
522 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
523 %endif
524
525 %{__make} install \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
529 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
530 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
531 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
532 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
533
534 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
535 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
536
537 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
538
539 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
540
541 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
542 install -d $RPM_BUILD_ROOT/etc/sysconfig
543 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
544 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
545
546 # Xorg.wrap config
547 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
548 # allowed values: rootonly console anybody pam
549 allowed_users = pam
550
551 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
552 #needs_root_rights = yes
553 EOF
554
555 # compatibility with old xwrapper
556 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
557
558 # prepare source package
559 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
560 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
561 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
562 %{__make} distclean
563 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
564 find -name '*.h' | xargs chmod a-x
565
566 %if %{with systemtap}
567 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
568 %endif
569
570 %clean
571 rm -rf $RPM_BUILD_ROOT
572
573 %triggerpostun -- xorg-xserver-server < 1.5.0
574 if [ -f /etc/X11/xorg.conf ]; then
575         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
576         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
577 %if %{without record}
578         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
579 %endif
580         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
581 fi
582
583 %post -n xorg-xserver-Xvfb-init
584 /sbin/chkconfig --add Xvfb
585 %service Xvfb restart
586
587 %preun -n xorg-xserver-Xvfb-init
588 if [ "$1" = "0" ]; then
589         %service -q Xvfb stop
590         /sbin/chkconfig --del Xvfb
591 fi
592
593 %files
594 %defattr(644,root,root,755)
595 %doc COPYING ChangeLog README
596 %attr(755,root,root) %{_bindir}/X
597 %attr(755,root,root) %{_bindir}/Xorg
598 %attr(4755,root,root) %{_bindir}/Xwrapper
599 %attr(755,root,root) %{_bindir}/cvt
600 %attr(755,root,root) %{_bindir}/gtf
601 %dir %{_libdir}/xorg
602 %{_libdir}/xorg/protocol.txt
603 %attr(755,root,root) %{_libdir}/xorg/Xorg
604 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
605 %dir %{_libdir}/xorg/modules
606 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
609 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
610 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
612 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
613 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
614 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
615 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
616 %dir %{_libdir}/xorg/modules/dri
617 %dir %{_libdir}/xorg/modules/drivers
618 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
619 %dir %{_libdir}/xorg/modules/extensions
620 %dir %{_libdir}/xorg/modules/input
621 %if "%{_libdir}" != "%{_exec_prefix}/lib"
622 %dir %{_exec_prefix}/lib/xorg
623 %dir %{_exec_prefix}/lib/xorg/modules
624 %dir %{_exec_prefix}/lib/xorg/modules/dri
625 %endif
626 %dir /var/lib/xkb
627 /var/lib/xkb/README.compiled
628 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
630 %config(missingok) /etc/security/console.apps/xserver
631 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
632 %dir /etc/X11/xorg.conf.d
633 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
634 %dir %{_datadir}/X11/xorg.conf.d
635 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
636 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
637 %{_mandir}/man1/Xorg.1*
638 %{_mandir}/man1/Xorg.wrap.1*
639 %{_mandir}/man1/Xserver.1*
640 %{_mandir}/man1/cvt.1*
641 %{_mandir}/man1/gtf.1*
642 %{_mandir}/man4/exa.4*
643 %{_mandir}/man4/fbdevhw.4*
644 %{_mandir}/man4/modesetting.4*
645 %{_mandir}/man5/Xwrapper.config.5*
646 %{_mandir}/man5/xorg.conf.5*
647 %{_mandir}/man5/xorg.conf.d.5*
648
649 %if %{with dmx}
650 %files -n xorg-xserver-Xdmx
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/Xdmx
653 %attr(755,root,root) %{_bindir}/dmxaddinput
654 %attr(755,root,root) %{_bindir}/dmxaddscreen
655 %attr(755,root,root) %{_bindir}/dmxinfo
656 %attr(755,root,root) %{_bindir}/dmxreconfig
657 %attr(755,root,root) %{_bindir}/dmxresize
658 %attr(755,root,root) %{_bindir}/dmxrminput
659 %attr(755,root,root) %{_bindir}/dmxrmscreen
660 %attr(755,root,root) %{_bindir}/dmxtodmx
661 %attr(755,root,root) %{_bindir}/dmxwininfo
662 %attr(755,root,root) %{_bindir}/vdltodmx
663 %attr(755,root,root) %{_bindir}/xdmxconfig
664 %{_mandir}/man1/Xdmx.1*
665 %{_mandir}/man1/dmxtodmx.1*
666 %{_mandir}/man1/vdltodmx.1*
667 %{_mandir}/man1/xdmxconfig.1*
668 %endif
669
670 %files -n xorg-xserver-Xnest
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/Xnest
673 %{_mandir}/man1/Xnest.1*
674
675 %files -n xorg-xserver-Xephyr
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_bindir}/Xephyr
678 %{_mandir}/man1/Xephyr.1*
679
680 %files -n xorg-xserver-Xfbdev
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_bindir}/Xfbdev
683
684 %files -n xorg-xserver-Xvfb
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_bindir}/Xvfb
687 %attr(755,root,root) %{_bindir}/xvfb-run
688 %{_mandir}/man1/Xvfb.1*
689
690 %files -n xorg-xserver-Xvfb-init
691 %defattr(644,root,root,755)
692 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
693 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
694
695 %if %{with wayland}
696 %files -n xorg-xserver-Xwayland
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/Xwayland
699 %endif
700
701 %files devel
702 %defattr(644,root,root,755)
703 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
704 %{_includedir}/xorg
705 %{_aclocaldir}/xorg-server.m4
706 %{_pkgconfigdir}/xorg-server.pc
707
708 %files source
709 %defattr(644,root,root,755)
710 # keep file perms from install time, but have default defattr to keep adapter happy
711 %defattr(-,root,root,755)
712 %{_usrsrc}/%{name}-%{version}
713
714 %files -n xorg-xserver-libglx
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.078665 seconds and 4 git commands to generate.