]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- final 1.9.1
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_without  record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       4.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        8.0
16 %define xorg_xserver_server_xinput_abi          11.0
17
18 %define         rel     1
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.9.1
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  64f2a021667ac3a2bc007f2567170f03
28 Source1:        10-quirks.conf
29 Source2:        xserver.pamd
30 Source10:       %{name}-Xvfb.init
31 Source11:       %{name}-Xvfb.sysconfig
32 Patch0:         %{name}-xwrapper.patch
33 Patch1:         %{name}-pic-libxf86config.patch
34 Patch2:         %{name}-fb-size.patch
35 Patch3:         %{name}-less-acpi-brokenness.patch
36 Patch4:         %{name}-builtin-SHA1.patch
37 URL:            http://xorg.freedesktop.org/
38 BuildRequires:  Mesa-libGL-devel >= 7.8.1
39 # for glx headers
40 BuildRequires:  OpenGL-GLX-devel
41 BuildRequires:  autoconf >= 2.57
42 BuildRequires:  automake
43 BuildRequires:  cpp
44 #BuildRequires: doxygen >= 1.6.1
45 %if %{with hal} || %{with dbus}
46 BuildRequires:  dbus-devel >= 1.0
47 %endif
48 # Note: fop is invoked by xmlto. It is not a dependency of xmlto, because it is
49 # quite rare usecase, and it is very "havy" dependency (requires Java, %post
50 # scripts execytes long time). So we need to add it here.
51 BuildRequires:  fop
52 %{?with_hal:BuildRequires:      hal-devel}
53 BuildRequires:  libdrm-devel >= 2.4.5
54 BuildRequires:  libtool
55 BuildRequires:  ncurses-devel
56 BuildRequires:  pam-devel
57 BuildRequires:  perl-base
58 BuildRequires:  pixman-devel >= 0.16.0
59 BuildRequires:  pkgconfig >= 1:0.19
60 BuildRequires:  udev-devel >= 1:143
61 BuildRequires:  xmlto >= 0.0.20
62 BuildRequires:  xorg-app-mkfontscale
63 BuildRequires:  xorg-font-font-util >= 1.1
64 BuildRequires:  xorg-lib-libX11-devel
65 BuildRequires:  xorg-lib-libXau-devel
66 BuildRequires:  xorg-lib-libXaw-devel
67 BuildRequires:  xorg-lib-libXdamage-devel
68 BuildRequires:  xorg-lib-libXdmcp-devel
69 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
70 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
71 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
72 BuildRequires:  xorg-lib-libXmu-devel
73 BuildRequires:  xorg-lib-libXpm-devel
74 BuildRequires:  xorg-lib-libXrender-devel
75 BuildRequires:  xorg-lib-libXres-devel
76 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
77 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
78 BuildRequires:  xorg-lib-libXv-devel
79 BuildRequires:  xorg-lib-libXxf86dga-devel
80 BuildRequires:  xorg-lib-libXxf86misc-devel
81 BuildRequires:  xorg-lib-libXxf86vm-devel
82 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
83 BuildRequires:  xorg-lib-libfontenc-devel
84 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
85 BuildRequires:  xorg-lib-libxkbfile-devel
86 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
87 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
88 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
89 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
90 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
91 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
92 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
93 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
94 BuildRequires:  xorg-proto-fontcacheproto-devel
95 BuildRequires:  xorg-proto-fontsproto-devel
96 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
97 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
98 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
99 BuildRequires:  xorg-proto-printproto-devel
100 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
101 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
102 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
103 BuildRequires:  xorg-proto-resourceproto-devel
104 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
105 BuildRequires:  xorg-proto-videoproto-devel
106 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
107 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
108 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
109 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
110 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
111 BuildRequires:  xorg-proto-xf86miscproto-devel
112 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
113 BuildRequires:  xorg-proto-xineramaproto-devel
114 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
115 BuildRequires:  xorg-sgml-doctools >= 1.5
116 BuildRequires:  xorg-util-util-macros >= 1.10
117 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
118 #BR: xcalibrateproto, tslib (for KDRIVE only)
119 Requires(triggerpostun):        sed >= 4.0
120 Requires:       pixman >= 0.16.0
121 Requires:       xkeyboard-config
122 # for rgb.txt
123 Requires:       xorg-app-rgb >= 0.99.3
124 Requires:       xorg-app-xkbcomp
125 %{?with_hal:Suggests:   dbus >= 1.0}
126 %{?with_hal:Suggests:   hal}
127 Suggests:       udev-acl
128 %{?with_udev:Suggests:  udev-core >= 1:143}
129 Suggests:       xorg-driver-input-evdev
130 # xserver requires fixed and cursor fonts
131 Requires:       xorg-font-font-alias
132 Requires:       xorg-font-font-cursor-misc
133 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
134 Suggests:       xkeyboard-config
135 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
136 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
137 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
138 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
139 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
140 Obsoletes:      X11-Xserver < 1:7.0.0
141 Obsoletes:      X11-driver-i2c < 1:7.0.0
142 Obsoletes:      X11-modules < 1:7.0.0
143 Obsoletes:      X11-setup < 1:7.0.0
144 Obsoletes:      XFree86-Xserver < 1:7.0.0
145 Obsoletes:      XFree86-modules < 1:7.0.0
146 Obsoletes:      XFree86-setup < 1:7.0.0
147 Obsoletes:      Xserver
148 Obsoletes:      xorg-xserver-server-xorgcfg
149 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
150
151 # avoid self-dependencies on included modules
152 %define         _noautoreq      libscanpci.so libxf1bpp.so
153
154 %description
155 Xorg server is a generally used X server which uses display hardware.
156 It requires proper driver for your display hardware.
157
158 %description -l pl.UTF-8
159 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
160 graficznej. Do działania wymaga odpowiedniego sterownika.
161
162 %package -n xorg-xserver-Xdmx
163 Summary:        Xdmx - distributed multi-head X server
164 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
165 Group:          X11/Servers
166
167 %description -n xorg-xserver-Xdmx
168 Xdmx - distributed multi-head X server.
169
170 %description -n xorg-xserver-Xdmx -l pl.UTF-8
171 Xdmx - rozproszony, wielomonitorowy serwer X.
172
173 %package -n xorg-xserver-Xnest
174 Summary:        Xnest - nested X server
175 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
176 Group:          X11/Servers
177 Obsoletes:      X11-Xnest < 1:7.0.0
178 Obsoletes:      XFree86-Xnest < 1:7.0.0
179 Obsoletes:      Xserver-Xnest
180
181 %description -n xorg-xserver-Xnest
182 Xnest is an X Window System server which runs in an X window. Xnest is
183 a 'nested' window server, actually a client of the real X server,
184 which manages windows and graphics requests for Xnest, while Xnest
185 manages the windows and graphics requests for its own clients.
186
187 %description -n xorg-xserver-Xnest -l pl.UTF-8
188 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
189 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
190 serwer X dla własnych klientów.
191
192 %description -n xorg-xserver-Xnest -l ru.UTF-8
193 Xnest - это сервер X Window System, который работает в окне X. На
194 самом деле это клиент реального X-сервера, который управляет окнами и
195 графическими запросами для Xnest в то время, как Xnest управляет
196 окнами и графическими запросами для своих собственных клиентов.
197
198 %description -n xorg-xserver-Xnest -l uk.UTF-8
199 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
200 клієнт реального X-сервера, який керує вікнами та графічними запитами
201 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
202 своїх власних клієнтів.
203
204 %package -n xorg-xserver-Xephyr
205 Summary:        Xephyr - nested X server
206 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
207 Group:          X11/Servers
208 Requires:       pixman >= 0.15.0
209
210 %description -n xorg-xserver-Xephyr
211 Xephyr is a a kdrive server that outputs to a window on a pre-existing
212 'host' X display. Think Xnest but with support for modern extensions
213 like composite, damage and randr.
214
215 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
216 the host X server, Xephyr is a real X server which uses the host X
217 server window as "framebuffer" via fast SHM XImages.
218
219 It also has support for 'visually' debugging what the server is
220 painting.
221
222 %description -n xorg-xserver-Xephyr -l pl.UTF-8
223 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
224 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
225 wspólczesnych rozszerzeń jak composite, damage i randr.
226
227 %package -n xorg-xserver-Xfbdev
228 Summary:        Xfbdev - Linux framebuffer device X server
229 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
230 Group:          X11/Servers
231
232 %description -n xorg-xserver-Xfbdev
233 Xfbdev is a Linux framebuffer device X server based on the kdrive X
234 server.
235
236 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
237 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
238
239 %package -n xorg-xserver-Xvfb
240 Summary:        Xvfb - virtual framebuffer X server
241 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
242 Group:          X11/Servers
243 # requires fixed and cursor fonts
244 Requires:       xorg-font-font-alias
245 Requires:       xorg-font-font-cursor-misc
246 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
247 Obsoletes:      X11-Xvfb < 1:7.0.0
248 Obsoletes:      XFree86-Xvfb < 1:7.0.0
249
250 %description -n xorg-xserver-Xvfb
251 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
252 capable of running on machines with no display hardware and no
253 physical input devices. Xvfb emulates a dumb framebuffer using virtual
254 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
255 display. Xvfb is normally used for testing servers. Using Xvfb, the
256 mfb or cfb code for any depth can be exercised without using real
257 hardware that supports the desired depths. Xvfb has also been used to
258 test X clients against unusual depths and screen configurations, to do
259 batch processing with Xvfb as a background rendering engine, to do
260 load testing, to help with porting an X server to a new platform, and
261 to provide an unobtrusive way of running applications which really
262 don't need an X server but insist on having one.
263
264 %description -n xorg-xserver-Xvfb -l pl.UTF-8
265 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
266 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
267 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
268 używany do testowania serwerów X, może też być używany do testowania
269 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
270 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
271 serwera X, ale odmawiają uruchomienia bez niego.
272
273 %package -n xorg-xserver-Xvfb-init
274 Summary:        Init scripts for Xvfb
275 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
276 Group:          X11/Servers
277 Requires:       xorg-xserver-Xvfb
278
279 %description -n xorg-xserver-Xvfb-init
280 This package contains init scripts for Xvfb and registers Xvfb as
281 system service.
282
283 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
284 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
285 usługę systemową.
286
287 %package devel
288 Summary:        Header files for X.org server
289 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
290 Group:          X11/Development/Libraries
291 Requires:       libdrm-devel >= 2.4.5
292 Requires:       pixman-devel >= 0.16.0
293 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
294 Requires:       xorg-lib-libxkbfile-devel
295 Requires:       xorg-proto-dri2proto-devel >= 2.3
296 Requires:       xorg-proto-fontsproto-devel
297 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
298 Requires:       xorg-proto-kbproto-devel >= 1.0.3
299 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
300 Requires:       xorg-proto-renderproto-devel >= 0.11
301 Requires:       xorg-proto-videoproto-devel
302 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
303 Requires:       xorg-proto-xproto-devel >= 7.0.17
304 Obsoletes:      X11-Xserver-devel < 1:7.0.0
305 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
306
307 %description devel
308 Header files for X.org server.
309
310 %description devel -l pl.UTF-8
311 Pliki nagłówkowe dla serwera X.org.
312
313 %package source
314 Summary:        X.org server source code
315 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
316 Group:          X11/Development/Libraries
317
318 %description source
319 X.org server source code.
320
321 %description source -l pl.UTF-8
322 Pliki źródłowe dla serwera X.org.
323
324 %package -n xorg-xserver-libdri
325 Summary:        DRI extension library for X.org server
326 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
327 Group:          X11/Servers
328 Requires:       %{name} = %{version}-%{release}
329 Provides:       xorg-xserver-module(dri)
330 %if %{without multigl}
331 Conflicts:      xorg-driver-video-fglrx
332 Conflicts:      xorg-driver-video-nvidia
333 %endif
334
335 %description -n xorg-xserver-libdri
336 DRI extension library for X.org server.
337
338 %description -n xorg-xserver-libdri -l pl.UTF-8
339 Biblioteka rozszerzenia DRI dla serwera X.org.
340
341 %package -n xorg-xserver-libglx
342 Summary:        GLX extension library for X.org server
343 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
344 Group:          X11/Servers
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       xorg-xserver-libdri = %{version}-%{release}
347 # Mesa version glapi tables in glx/ dir come from
348 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
349 Provides:       xorg-xserver-module(glx)
350 Obsoletes:      X11-OpenGL-core < 1:7.0.0
351 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
352 %if %{without multigl}
353 Conflicts:      xorg-driver-video-fglrx
354 Conflicts:      xorg-driver-video-nvidia
355 %endif
356
357 %description -n xorg-xserver-libglx
358 GLX extension library for X.org server.
359
360 %description -n xorg-xserver-libglx -l pl.UTF-8
361 Biblioteka rozszerzenia GLX dla serwera X.org.
362
363 %prep
364 %setup -q -n xorg-server-%{version}
365 %patch0 -p0
366 %patch1 -p1
367 %patch2 -p1
368 %patch3 -p1
369 %patch4 -p1
370
371 # xserver uses pixman-1 API/ABI so put that explictly here
372 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
373
374 %build
375 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
376 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
377         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
378         exit 1
379 fi
380
381 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
382 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
383         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
384         exit 1
385 fi
386
387 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
388 if [ $API != %{xorg_xserver_server_font_abi} ]; then
389         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
390         exit 1
391 fi
392 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
393 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
394         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
395         exit 1
396 fi
397 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
398 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
399         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
400         exit 1
401 fi
402
403 %{__libtoolize}
404 %{__aclocal} -I m4
405 %{__autoconf}
406 %{__autoheader}
407 %{__automake}
408 %configure \
409         --with-os-name="PLD/Linux" \
410         --with-os-vendor="PLD/Team" \
411         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
412         %{!?with_hal:--disable-config-hal} \
413         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
414         --enable-aiglx \
415         --enable-builddocs \
416         --enable-dga \
417         %{?with_dmx:--enable-dmx} \
418         --enable-glx-tls \
419         --enable-install-libxf86config \
420         %{?with_record:--enable-record} \
421         --enable-kdrive \
422         --enable-xephyr \
423         --enable-xfbdev \
424         --enable-glx-tls \
425         --disable-xsdl \
426         --disable-xfake \
427         --enable-secure-rpc \
428         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
429         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
430         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
431         --with-xkb-output=/var/lib/xkb
432
433 %{__make}
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437
438 %{__make} install \
439         DESTDIR=$RPM_BUILD_ROOT
440
441 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
442 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
443 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
444 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
445
446 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
447 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
448
449 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
450
451 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
452
453 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
454 install -d $RPM_BUILD_ROOT/etc/sysconfig
455 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
456 install %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
457
458 %if %{with multigl}
459 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
460 mv -f libglx.so libglx.so.%{version}
461 ln -sf libglx.so.%{version} libglx.so
462 cd -
463 %endif
464
465 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
466 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
467 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
468 %{__make} distclean
469 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
470
471 %clean
472 rm -rf $RPM_BUILD_ROOT
473
474 %if %{with multigl}
475 %post -n xorg-xserver-libglx
476 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
477         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
478 fi
479 %endif
480
481 %triggerpostun -- xorg-xserver-server < 1.5.0
482 if [ -f /etc/X11/xorg.conf ]; then
483         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
484         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
485 %if %{without record}
486         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
487 %endif
488         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
489 fi
490
491 %post -n xorg-xserver-Xvfb-init
492 /sbin/chkconfig --add Xvfb
493 %service Xvfb restart
494
495 %preun -n xorg-xserver-Xvfb-init
496 if [ "$1" = "0" ]; then
497         %service -q Xvfb stop
498         /sbin/chkconfig --del Xvfb
499 fi
500
501 %files
502 %defattr(644,root,root,755)
503 %doc COPYING ChangeLog README
504 %attr(755,root,root) %{_bindir}/X
505 %attr(755,root,root) %{_bindir}/Xorg
506 %attr(4755,root,root) %{_bindir}/Xwrapper
507 %attr(755,root,root) %{_bindir}/cvt
508 %attr(755,root,root) %{_bindir}/gtf
509 %dir %{_libdir}/xorg
510 %{_libdir}/xorg/protocol.txt
511 %dir %{_libdir}/xorg/modules
512 %dir %{_libdir}/xorg/modules/dri
513 %dir %{_libdir}/xorg/modules/drivers
514 %dir %{_libdir}/xorg/modules/extensions
515 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
516 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
517 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
518 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
519 %dir %{_libdir}/xorg/modules/input
520 %dir %{_libdir}/xorg/modules/multimedia
521 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
522 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
523 %dir /var/lib/xkb
524 /var/lib/xkb/README.compiled
525 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
526 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
527 %config(missingok) /etc/security/console.apps/xserver
528 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
529 %dir /etc/X11/xorg.conf.d
530 %dir %{_datadir}/X11/xorg.conf.d
531 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
532 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
533 %{_mandir}/man1/Xorg.1x*
534 %{_mandir}/man1/Xserver.1x*
535 %{_mandir}/man1/cvt.1*
536 %{_mandir}/man1/gtf.1x*
537 %{_mandir}/man4/exa.4*
538 %{_mandir}/man4/fbdevhw.4*
539 %{_mandir}/man5/xorg.conf.5x*
540
541 %if %{with dmx}
542 %files -n xorg-xserver-Xdmx
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_bindir}/Xdmx
545 %attr(755,root,root) %{_bindir}/dmxaddinput
546 %attr(755,root,root) %{_bindir}/dmxaddscreen
547 %attr(755,root,root) %{_bindir}/dmxinfo
548 %attr(755,root,root) %{_bindir}/dmxreconfig
549 %attr(755,root,root) %{_bindir}/dmxresize
550 %attr(755,root,root) %{_bindir}/dmxrminput
551 %attr(755,root,root) %{_bindir}/dmxrmscreen
552 %attr(755,root,root) %{_bindir}/dmxtodmx
553 %attr(755,root,root) %{_bindir}/dmxwininfo
554 %attr(755,root,root) %{_bindir}/vdltodmx
555 %attr(755,root,root) %{_bindir}/xdmxconfig
556 %{_mandir}/man1/Xdmx.1x*
557 %{_mandir}/man1/dmxtodmx.1x*
558 %{_mandir}/man1/vdltodmx.1x*
559 %{_mandir}/man1/xdmxconfig.1x*
560 %endif
561
562 %files -n xorg-xserver-Xnest
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/Xnest
565 %{_mandir}/man1/Xnest.1x*
566
567 %files -n xorg-xserver-Xephyr
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/Xephyr
570 %{_mandir}/man1/Xephyr.1x*
571
572 %files -n xorg-xserver-Xfbdev
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/Xfbdev
575
576 %files -n xorg-xserver-Xvfb
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_bindir}/Xvfb
579 %{_mandir}/man1/Xvfb.1x*
580
581 %files -n xorg-xserver-Xvfb-init
582 %defattr(644,root,root,755)
583 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
584 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
585
586 %files devel
587 %defattr(644,root,root,755)
588 %doc doc/xml/{Xserver-spec.html,xorg.css}
589 %{_includedir}/xorg
590 %{_libdir}/libxf86config.a
591 %{_aclocaldir}/xorg-server.m4
592 %{_pkgconfigdir}/xorg-server.pc
593
594 %files source
595 %defattr(-,root,root,755)
596 %{_usrsrc}/%{name}-%{version}
597
598 %files -n xorg-xserver-libdri
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
601
602 %files -n xorg-xserver-libglx
603 %defattr(644,root,root,755)
604 %if %{with multigl}
605 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
607 %else
608 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
609 %endif
This page took 0.094084 seconds and 4 git commands to generate.