]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- updated xf86driproto-devel R
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_without  record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       5.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        10.0
16 %define xorg_xserver_server_xinput_abi          12.2
17
18 %define         rel     1
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.10.1
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  75f117c74f2ecaf9dd167f6a66ac98de
28 Source1:        10-quirks.conf
29 Source2:        xserver.pamd
30 Source10:       %{name}-Xvfb.init
31 Source11:       %{name}-Xvfb.sysconfig
32 Patch0:         %{name}-xwrapper.patch
33 Patch1:         %{name}-pic-libxf86config.patch
34 Patch2:         %{name}-fb-size.patch
35 Patch3:         %{name}-less-acpi-brokenness.patch
36 Patch4:         %{name}-builtin-SHA1.patch
37 Patch5:         %{name}-nvidia-randr.patch
38 URL:            http://xorg.freedesktop.org/
39 BuildRequires:  Mesa-libGL-devel >= 7.8.1
40 # for glx headers
41 BuildRequires:  OpenGL-GLX-devel
42 BuildRequires:  autoconf >= 2.57
43 BuildRequires:  automake
44 BuildRequires:  cpp
45 #BuildRequires: doxygen >= 1.6.1
46 BuildRequires:  docbook-dtd43-xml
47 %if %{with hal} || %{with dbus}
48 BuildRequires:  dbus-devel >= 1.0
49 %endif
50 %{?with_hal:BuildRequires:      hal-devel}
51 BuildRequires:  libdrm-devel >= 2.4.5
52 BuildRequires:  libtool
53 BuildRequires:  ncurses-devel
54 BuildRequires:  pam-devel
55 BuildRequires:  perl-base
56 BuildRequires:  pixman-devel >= 0.16.0
57 BuildRequires:  pkgconfig >= 1:0.19
58 BuildRequires:  udev-devel >= 1:143
59 BuildRequires:  xmlto >= 0.0.20
60 BuildRequires:  xorg-app-mkfontscale
61 BuildRequires:  xorg-font-font-util >= 1.1
62 BuildRequires:  xorg-lib-libX11-devel
63 BuildRequires:  xorg-lib-libXau-devel
64 BuildRequires:  xorg-lib-libXaw-devel
65 BuildRequires:  xorg-lib-libXdamage-devel
66 BuildRequires:  xorg-lib-libXdmcp-devel
67 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
68 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
69 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
70 BuildRequires:  xorg-lib-libXmu-devel
71 BuildRequires:  xorg-lib-libXpm-devel
72 BuildRequires:  xorg-lib-libXrender-devel
73 BuildRequires:  xorg-lib-libXres-devel
74 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
75 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
76 BuildRequires:  xorg-lib-libXv-devel
77 BuildRequires:  xorg-lib-libXxf86dga-devel
78 BuildRequires:  xorg-lib-libXxf86misc-devel
79 BuildRequires:  xorg-lib-libXxf86vm-devel
80 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
81 BuildRequires:  xorg-lib-libfontenc-devel
82 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
83 BuildRequires:  xorg-lib-libxkbfile-devel
84 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
85 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
86 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
87 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
88 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
89 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
90 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
91 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
92 BuildRequires:  xorg-proto-fontcacheproto-devel
93 BuildRequires:  xorg-proto-fontsproto-devel
94 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
95 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
96 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
97 BuildRequires:  xorg-proto-printproto-devel
98 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
99 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
100 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
101 BuildRequires:  xorg-proto-resourceproto-devel
102 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
103 BuildRequires:  xorg-proto-videoproto-devel
104 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
105 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
106 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
107 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
108 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
109 BuildRequires:  xorg-proto-xf86miscproto-devel
110 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
111 BuildRequires:  xorg-proto-xineramaproto-devel
112 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
113 BuildRequires:  xorg-sgml-doctools >= 1.5
114 BuildRequires:  xorg-util-util-macros >= 1.10
115 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
116 #BR: xcalibrateproto, tslib (for KDRIVE only)
117 Requires(triggerpostun):        sed >= 4.0
118 Requires:       pixman >= 0.16.0
119 Requires:       xkeyboard-config
120 # for rgb.txt
121 Requires:       xorg-app-rgb >= 0.99.3
122 Requires:       xorg-app-xkbcomp
123 %{?with_hal:Suggests:   dbus >= 1.0}
124 %{?with_hal:Suggests:   hal}
125 Suggests:       udev-acl
126 %{?with_udev:Suggests:  udev-core >= 1:143}
127 Suggests:       xorg-driver-input-evdev
128 # xserver requires fixed and cursor fonts
129 Requires:       xorg-font-font-alias
130 Requires:       xorg-font-font-cursor-misc
131 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
132 Suggests:       xkeyboard-config
133 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
134 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
135 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
136 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
137 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
138 Obsoletes:      X11-Xserver < 1:7.0.0
139 Obsoletes:      X11-driver-i2c < 1:7.0.0
140 Obsoletes:      X11-modules < 1:7.0.0
141 Obsoletes:      X11-setup < 1:7.0.0
142 Obsoletes:      XFree86-Xserver < 1:7.0.0
143 Obsoletes:      XFree86-modules < 1:7.0.0
144 Obsoletes:      XFree86-setup < 1:7.0.0
145 Obsoletes:      Xserver
146 Obsoletes:      xorg-xserver-server-xorgcfg
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 # avoid self-dependencies on included modules
150 %define         _noautoreq      libscanpci.so libxf1bpp.so
151
152 %description
153 Xorg server is a generally used X server which uses display hardware.
154 It requires proper driver for your display hardware.
155
156 %description -l pl.UTF-8
157 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
158 graficznej. Do działania wymaga odpowiedniego sterownika.
159
160 %package -n xorg-xserver-Xdmx
161 Summary:        Xdmx - distributed multi-head X server
162 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
163 Group:          X11/Servers
164
165 %description -n xorg-xserver-Xdmx
166 Xdmx - distributed multi-head X server.
167
168 %description -n xorg-xserver-Xdmx -l pl.UTF-8
169 Xdmx - rozproszony, wielomonitorowy serwer X.
170
171 %package -n xorg-xserver-Xnest
172 Summary:        Xnest - nested X server
173 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
174 Group:          X11/Servers
175 Obsoletes:      X11-Xnest < 1:7.0.0
176 Obsoletes:      XFree86-Xnest < 1:7.0.0
177 Obsoletes:      Xserver-Xnest
178
179 %description -n xorg-xserver-Xnest
180 Xnest is an X Window System server which runs in an X window. Xnest is
181 a 'nested' window server, actually a client of the real X server,
182 which manages windows and graphics requests for Xnest, while Xnest
183 manages the windows and graphics requests for its own clients.
184
185 %description -n xorg-xserver-Xnest -l pl.UTF-8
186 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
187 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
188 serwer X dla własnych klientów.
189
190 %description -n xorg-xserver-Xnest -l ru.UTF-8
191 Xnest - это сервер X Window System, который работает в окне X. На
192 самом деле это клиент реального X-сервера, который управляет окнами и
193 графическими запросами для Xnest в то время, как Xnest управляет
194 окнами и графическими запросами для своих собственных клиентов.
195
196 %description -n xorg-xserver-Xnest -l uk.UTF-8
197 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
198 клієнт реального X-сервера, який керує вікнами та графічними запитами
199 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
200 своїх власних клієнтів.
201
202 %package -n xorg-xserver-Xephyr
203 Summary:        Xephyr - nested X server
204 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
205 Group:          X11/Servers
206 Requires:       pixman >= 0.16.0
207
208 %description -n xorg-xserver-Xephyr
209 Xephyr is a a kdrive server that outputs to a window on a pre-existing
210 'host' X display. Think Xnest but with support for modern extensions
211 like composite, damage and randr.
212
213 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
214 the host X server, Xephyr is a real X server which uses the host X
215 server window as "framebuffer" via fast SHM XImages.
216
217 It also has support for 'visually' debugging what the server is
218 painting.
219
220 %description -n xorg-xserver-Xephyr -l pl.UTF-8
221 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
222 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
223 wspólczesnych rozszerzeń jak composite, damage i randr.
224
225 %package -n xorg-xserver-Xfbdev
226 Summary:        Xfbdev - Linux framebuffer device X server
227 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
228 Group:          X11/Servers
229
230 %description -n xorg-xserver-Xfbdev
231 Xfbdev is a Linux framebuffer device X server based on the kdrive X
232 server.
233
234 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
235 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
236
237 %package -n xorg-xserver-Xvfb
238 Summary:        Xvfb - virtual framebuffer X server
239 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
240 Group:          X11/Servers
241 # requires fixed and cursor fonts
242 Requires:       xorg-font-font-alias
243 Requires:       xorg-font-font-cursor-misc
244 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
245 Obsoletes:      X11-Xvfb < 1:7.0.0
246 Obsoletes:      XFree86-Xvfb < 1:7.0.0
247
248 %description -n xorg-xserver-Xvfb
249 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
250 capable of running on machines with no display hardware and no
251 physical input devices. Xvfb emulates a dumb framebuffer using virtual
252 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
253 display. Xvfb is normally used for testing servers. Using Xvfb, the
254 mfb or cfb code for any depth can be exercised without using real
255 hardware that supports the desired depths. Xvfb has also been used to
256 test X clients against unusual depths and screen configurations, to do
257 batch processing with Xvfb as a background rendering engine, to do
258 load testing, to help with porting an X server to a new platform, and
259 to provide an unobtrusive way of running applications which really
260 don't need an X server but insist on having one.
261
262 %description -n xorg-xserver-Xvfb -l pl.UTF-8
263 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
264 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
265 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
266 używany do testowania serwerów X, może też być używany do testowania
267 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
268 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
269 serwera X, ale odmawiają uruchomienia bez niego.
270
271 %package -n xorg-xserver-Xvfb-init
272 Summary:        Init scripts for Xvfb
273 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
274 Group:          X11/Servers
275 Requires:       xorg-xserver-Xvfb
276
277 %description -n xorg-xserver-Xvfb-init
278 This package contains init scripts for Xvfb and registers Xvfb as
279 system service.
280
281 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
282 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
283 usługę systemową.
284
285 %package devel
286 Summary:        Header files for X.org server
287 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
288 Group:          X11/Development/Libraries
289 Requires:       libdrm-devel >= 2.4.5
290 Requires:       pixman-devel >= 0.16.0
291 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
292 Requires:       xorg-lib-libxkbfile-devel
293 Requires:       xorg-proto-dri2proto-devel >= 2.3
294 Requires:       xorg-proto-fontsproto-devel
295 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
296 Requires:       xorg-proto-kbproto-devel >= 1.0.3
297 Requires:       xorg-proto-randrproto-devel >= 1.3
298 Requires:       xorg-proto-renderproto-devel >= 0.11
299 Requires:       xorg-proto-videoproto-devel
300 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
301 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
302 Requires:       xorg-proto-xineramaproto-devel
303 Requires:       xorg-proto-xproto-devel >= 7.0.17
304 Obsoletes:      X11-Xserver-devel < 1:7.0.0
305 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
306
307 %description devel
308 Header files for X.org server.
309
310 %description devel -l pl.UTF-8
311 Pliki nagłówkowe dla serwera X.org.
312
313 %package source
314 Summary:        X.org server source code
315 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
316 Group:          X11/Development/Libraries
317
318 %description source
319 X.org server source code.
320
321 %description source -l pl.UTF-8
322 Pliki źródłowe dla serwera X.org.
323
324 %package -n xorg-xserver-libdri
325 Summary:        DRI extension library for X.org server
326 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
327 Group:          X11/Servers
328 Requires:       %{name} = %{version}-%{release}
329 Provides:       xorg-xserver-module(dri)
330 %if %{without multigl}
331 Conflicts:      xorg-driver-video-fglrx
332 Conflicts:      xorg-driver-video-nvidia
333 %endif
334
335 %description -n xorg-xserver-libdri
336 DRI extension library for X.org server.
337
338 %description -n xorg-xserver-libdri -l pl.UTF-8
339 Biblioteka rozszerzenia DRI dla serwera X.org.
340
341 %package -n xorg-xserver-libglx
342 Summary:        GLX extension library for X.org server
343 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
344 Group:          X11/Servers
345 Requires:       %{name} = %{version}-%{release}
346 Requires:       xorg-xserver-libdri = %{version}-%{release}
347 # Mesa version glapi tables in glx/ dir come from
348 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
349 Provides:       xorg-xserver-module(glx)
350 Obsoletes:      X11-OpenGL-core < 1:7.0.0
351 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
352 %if %{without multigl}
353 Conflicts:      xorg-driver-video-fglrx
354 Conflicts:      xorg-driver-video-nvidia
355 %endif
356
357 %description -n xorg-xserver-libglx
358 GLX extension library for X.org server.
359
360 %description -n xorg-xserver-libglx -l pl.UTF-8
361 Biblioteka rozszerzenia GLX dla serwera X.org.
362
363 %prep
364 %setup -q -n xorg-server-%{version}
365 %patch0 -p0
366 %patch1 -p1
367 %patch2 -p1
368 %patch3 -p1
369 %patch4 -p1
370 %patch5 -p1
371
372 # xserver uses pixman-1 API/ABI so put that explictly here
373 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
374
375 %build
376 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
377 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
378         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
379         exit 1
380 fi
381
382 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
383 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
384         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
385         exit 1
386 fi
387
388 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
389 if [ $API != %{xorg_xserver_server_font_abi} ]; then
390         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
391         exit 1
392 fi
393 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
394 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
395         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
396         exit 1
397 fi
398 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
399 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
400         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
401         exit 1
402 fi
403
404 %{__libtoolize}
405 %{__aclocal} -I m4
406 %{__autoconf}
407 %{__autoheader}
408 %{__automake}
409 %configure \
410         --with-os-name="PLD/Linux" \
411         --with-os-vendor="PLD/Team" \
412         --without-fop \
413         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
414         %{!?with_hal:--disable-config-hal} \
415         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
416         --enable-aiglx \
417         --enable-builddocs \
418         --enable-dga \
419         %{?with_dmx:--enable-dmx} \
420         --enable-glx-tls \
421         --enable-install-libxf86config \
422         %{?with_record:--enable-record} \
423         --enable-kdrive \
424         --enable-xephyr \
425         --enable-xfbdev \
426         --enable-glx-tls \
427         --disable-xfake \
428         --enable-secure-rpc \
429         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
430         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
431         --with-xkb-output=/var/lib/xkb
432
433 %{__make}
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437
438 %{__make} install \
439         DESTDIR=$RPM_BUILD_ROOT
440
441 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
442 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
443 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
444 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
445
446 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
447 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
448
449 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
450
451 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
452
453 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
454 install -d $RPM_BUILD_ROOT/etc/sysconfig
455 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
456 install %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
457
458 %if %{with multigl}
459 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
460 mv -f libglx.so libglx.so.%{version}
461 ln -sf libglx.so.%{version} libglx.so
462 cd -
463 %endif
464
465 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
466 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
467 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
468 %{__make} distclean
469 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
470 find -name '*.h' | xargs chmod a-x
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %if %{with multigl}
476 %post -n xorg-xserver-libglx
477 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
478         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
479 fi
480 %endif
481
482 %triggerpostun -- xorg-xserver-server < 1.5.0
483 if [ -f /etc/X11/xorg.conf ]; then
484         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
485         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
486 %if %{without record}
487         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
488 %endif
489         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
490 fi
491
492 %post -n xorg-xserver-Xvfb-init
493 /sbin/chkconfig --add Xvfb
494 %service Xvfb restart
495
496 %preun -n xorg-xserver-Xvfb-init
497 if [ "$1" = "0" ]; then
498         %service -q Xvfb stop
499         /sbin/chkconfig --del Xvfb
500 fi
501
502 %files
503 %defattr(644,root,root,755)
504 %doc COPYING ChangeLog README
505 %attr(755,root,root) %{_bindir}/X
506 %attr(755,root,root) %{_bindir}/Xorg
507 %attr(4755,root,root) %{_bindir}/Xwrapper
508 %attr(755,root,root) %{_bindir}/cvt
509 %attr(755,root,root) %{_bindir}/gtf
510 %dir %{_libdir}/xorg
511 %{_libdir}/xorg/protocol.txt
512 %dir %{_libdir}/xorg/modules
513 %dir %{_libdir}/xorg/modules/dri
514 %dir %{_libdir}/xorg/modules/drivers
515 %dir %{_libdir}/xorg/modules/extensions
516 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
517 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
518 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
519 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
520 %dir %{_libdir}/xorg/modules/input
521 %dir %{_libdir}/xorg/modules/multimedia
522 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
523 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
524 %dir /var/lib/xkb
525 /var/lib/xkb/README.compiled
526 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
527 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
528 %config(missingok) /etc/security/console.apps/xserver
529 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
530 %dir /etc/X11/xorg.conf.d
531 %dir %{_datadir}/X11/xorg.conf.d
532 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
533 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
534 %{_mandir}/man1/Xorg.1x*
535 %{_mandir}/man1/Xserver.1x*
536 %{_mandir}/man1/cvt.1*
537 %{_mandir}/man1/gtf.1x*
538 %{_mandir}/man4/exa.4*
539 %{_mandir}/man4/fbdevhw.4*
540 %{_mandir}/man5/xorg.conf.5x*
541 %{_mandir}/man5/xorg.conf.d.5x
542
543 %if %{with dmx}
544 %files -n xorg-xserver-Xdmx
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/Xdmx
547 %attr(755,root,root) %{_bindir}/dmxaddinput
548 %attr(755,root,root) %{_bindir}/dmxaddscreen
549 %attr(755,root,root) %{_bindir}/dmxinfo
550 %attr(755,root,root) %{_bindir}/dmxreconfig
551 %attr(755,root,root) %{_bindir}/dmxresize
552 %attr(755,root,root) %{_bindir}/dmxrminput
553 %attr(755,root,root) %{_bindir}/dmxrmscreen
554 %attr(755,root,root) %{_bindir}/dmxtodmx
555 %attr(755,root,root) %{_bindir}/dmxwininfo
556 %attr(755,root,root) %{_bindir}/vdltodmx
557 %attr(755,root,root) %{_bindir}/xdmxconfig
558 %{_mandir}/man1/Xdmx.1x*
559 %{_mandir}/man1/dmxtodmx.1x*
560 %{_mandir}/man1/vdltodmx.1x*
561 %{_mandir}/man1/xdmxconfig.1x*
562 %endif
563
564 %files -n xorg-xserver-Xnest
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_bindir}/Xnest
567 %{_mandir}/man1/Xnest.1x*
568
569 %files -n xorg-xserver-Xephyr
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_bindir}/Xephyr
572 %{_mandir}/man1/Xephyr.1x*
573
574 %files -n xorg-xserver-Xfbdev
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/Xfbdev
577
578 %files -n xorg-xserver-Xvfb
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/Xvfb
581 %{_mandir}/man1/Xvfb.1x*
582
583 %files -n xorg-xserver-Xvfb-init
584 %defattr(644,root,root,755)
585 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
586 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
587
588 %files devel
589 %defattr(644,root,root,755)
590 %doc doc/xml/Xserver-spec.html
591 %{_includedir}/xorg
592 %{_libdir}/libxf86config.a
593 %{_libdir}/libxf86config.la
594 %{_aclocaldir}/xorg-server.m4
595 %{_pkgconfigdir}/xorg-server.pc
596
597 %files source
598 %defattr(-,root,root,755)
599 %{_usrsrc}/%{name}-%{version}
600
601 %files -n xorg-xserver-libdri
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
604
605 %files -n xorg-xserver-libglx
606 %defattr(644,root,root,755)
607 %if %{with multigl}
608 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
610 %else
611 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
612 %endif
This page took 0.087185 seconds and 4 git commands to generate.