]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- drop BR: xorg-proto-evieext-devel
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_without  dbus    # D-BUS support
6 %bcond_without  hal     # HAL support
7 %bcond_without  dmx     # DMX support
8 %bcond_with     record  # RECORD extension
9 #
10 # ABI versions, see hw/xfree86/common/xf86Module.h
11 %define xorg_xserver_server_ansic_abi           0.4
12 %define xorg_xserver_server_extension_abi       2.0
13 %define xorg_xserver_server_font_abi            0.6
14 %define xorg_xserver_server_videodrv_abi        6.0
15 %define xorg_xserver_server_xinput_abi          7.0
16
17 Summary:        X.org server
18 Summary(pl.UTF-8):      Serwer X.org
19 Name:           xorg-xserver-server
20 Version:        1.7.2
21 Release:        1%{?with_multigl:.mgl}
22 License:        MIT
23 Group:          X11/Servers
24 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
25 # Source0-md5:  5c087e0f555203065fd90d02ef5f736e
26 Source2:        xserver.pamd
27 Patch0:         %{name}-xwrapper.patch
28 Patch1:         %{name}-pic-libxf86config.patch
29 Patch2:         %{name}-fb-size.patch
30 Patch6:         %{name}-less-acpi-brokenness.patch
31 Patch7:         %{name}-ac.patch
32 URL:            http://xorg.freedesktop.org/
33 BuildRequires:  Mesa-libGL-devel >= 7.3
34 # for glx headers
35 BuildRequires:  OpenGL-GLX-devel
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 BuildRequires:  cpp
39 %if %{with hal} || %{with dbus}
40 BuildRequires:  dbus-devel
41 %endif
42 %{?with_hal:BuildRequires:      hal-devel}
43 BuildRequires:  libdrm-devel >= 2.4.5
44 BuildRequires:  libtool
45 BuildRequires:  ncurses-devel
46 BuildRequires:  openssl-devel
47 BuildRequires:  pam-devel
48 BuildRequires:  perl-base
49 BuildRequires:  pixman-devel >= 0.16.0
50 BuildRequires:  pkgconfig >= 1:0.19
51 BuildRequires:  xorg-app-mkfontscale
52 BuildRequires:  xorg-lib-libX11-devel
53 BuildRequires:  xorg-lib-libXau-devel
54 BuildRequires:  xorg-lib-libXaw-devel
55 BuildRequires:  xorg-lib-libXdamage-devel
56 BuildRequires:  xorg-lib-libXdmcp-devel
57 BuildRequires:  xorg-lib-libXext-devel
58 BuildRequires:  xorg-lib-libXfont-devel
59 BuildRequires:  xorg-lib-libXi-devel >= 1.2
60 BuildRequires:  xorg-lib-libXmu-devel
61 BuildRequires:  xorg-lib-libXpm-devel
62 BuildRequires:  xorg-lib-libXrender-devel
63 BuildRequires:  xorg-lib-libXres-devel
64 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
65 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
66 BuildRequires:  xorg-lib-libXv-devel
67 BuildRequires:  xorg-lib-libXxf86dga-devel
68 BuildRequires:  xorg-lib-libXxf86misc-devel
69 BuildRequires:  xorg-lib-libXxf86vm-devel
70 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
71 BuildRequires:  xorg-lib-libfontenc-devel
72 BuildRequires:  xorg-lib-libpciaccess-devel
73 BuildRequires:  xorg-lib-libxkbfile-devel
74 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
75 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
76 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
77 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
78 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
79 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel}
80 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.1}
81 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
82 BuildRequires:  xorg-proto-fontcacheproto-devel
83 BuildRequires:  xorg-proto-fontsproto-devel
84 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
85 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
86 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
87 BuildRequires:  xorg-proto-printproto-devel
88 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
89 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel}
90 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
91 BuildRequires:  xorg-proto-resourceproto-devel
92 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
93 BuildRequires:  xorg-proto-videoproto-devel
94 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
95 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
96 BuildRequires:  xorg-proto-xf86bigfontproto-devel
97 BuildRequires:  xorg-proto-xf86dgaproto-devel
98 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.0.4
99 BuildRequires:  xorg-proto-xf86miscproto-devel
100 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
101 BuildRequires:  xorg-proto-xineramaproto-devel
102 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
103 BuildRequires:  xorg-util-util-macros >= 0.99.2
104 #BR: xcalibrateproto, tslib (for KDRIVE only)
105 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
106 Requires(triggerpostun):        sed >= 4.0
107 Requires:       pixman >= 0.16.0
108 Requires:       xkeyboard-config
109 # for rgb.txt
110 Requires:       xorg-app-rgb >= 0.99.3
111 Requires:       xorg-app-xkbcomp
112 # xserver default config expects evdev+dbus+hald
113 Suggests:       dbus
114 Suggests:       hal
115 Suggests:       xorg-driver-input-evdev
116 # xserver requires fixed and cursor fonts
117 Requires:       xorg-font-font-alias
118 Requires:       xorg-font-font-cursor-misc
119 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
120 Suggests:       xkeyboard-config
121 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
122 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
123 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
124 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
125 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
126 Obsoletes:      X11-Xserver < 1:7.0.0
127 Obsoletes:      X11-driver-i2c < 1:7.0.0
128 Obsoletes:      X11-modules < 1:7.0.0
129 Obsoletes:      X11-setup < 1:7.0.0
130 Obsoletes:      XFree86-Xserver < 1:7.0.0
131 Obsoletes:      XFree86-modules < 1:7.0.0
132 Obsoletes:      XFree86-setup < 1:7.0.0
133 Obsoletes:      Xserver
134 Obsoletes:      xorg-xserver-server-xorgcfg
135 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
136
137 # avoid self-dependencies on included modules
138 %define         _noautoreq      libscanpci.so libxf1bpp.so
139
140 %description
141 Xorg server is a generally used X server which uses display hardware.
142 It requires proper driver for your display hardware.
143
144 %description -l pl.UTF-8
145 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
146 graficznej. Do działania wymaga odpowiedniego sterownika.
147
148 %package -n xorg-xserver-Xdmx
149 Summary:        Xdmx - distributed multi-head X server
150 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
151 Group:          X11/Servers
152
153 %description -n xorg-xserver-Xdmx
154 Xdmx - distributed multi-head X server.
155
156 %description -n xorg-xserver-Xdmx -l pl.UTF-8
157 Xdmx - rozproszony, wielomonitorowy serwer X.
158
159 %package -n xorg-xserver-Xnest
160 Summary:        Xnest - nested X server
161 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
162 Group:          X11/Servers
163 Obsoletes:      X11-Xnest < 1:7.0.0
164 Obsoletes:      XFree86-Xnest < 1:7.0.0
165 Obsoletes:      Xserver-Xnest
166
167 %description -n xorg-xserver-Xnest
168 Xnest is an X Window System server which runs in an X window. Xnest is
169 a 'nested' window server, actually a client of the real X server,
170 which manages windows and graphics requests for Xnest, while Xnest
171 manages the windows and graphics requests for its own clients.
172
173 %description -n xorg-xserver-Xnest -l pl.UTF-8
174 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
175 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
176 serwer X dla własnych klientów.
177
178 %description -n xorg-xserver-Xnest -l ru.UTF-8
179 Xnest - это сервер X Window System, который работает в окне X. На
180 самом деле это клиент реального X-сервера, который управляет окнами и
181 графическими запросами для Xnest в то время, как Xnest управляет
182 окнами и графическими запросами для своих собственных клиентов.
183
184 %description -n xorg-xserver-Xnest -l uk.UTF-8
185 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
186 клієнт реального X-сервера, який керує вікнами та графічними запитами
187 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
188 своїх власних клієнтів.
189
190 %package -n xorg-xserver-Xephyr
191 Summary:        Xephyr - nested X server
192 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
193 Group:          X11/Servers
194
195 %description -n xorg-xserver-Xephyr
196 Xephyr is a a kdrive server that outputs to a window on a pre-existing
197 'host' X display. Think Xnest but with support for modern extensions
198 like composite, damage and randr.
199
200 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
201 the host X server, Xephyr is a real X server which uses the host X
202 server window as "framebuffer" via fast SHM XImages.
203
204 It also has support for 'visually' debugging what the server is
205 painting.
206
207 %description -n xorg-xserver-Xephyr -l pl.UTF-8
208 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
209 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
210 wspólczesnych rozszerzeń jak composite, damage i randr.
211
212 %package -n xorg-xserver-Xfbdev
213 Summary:        Xfbdev - Linux framebuffer device X server
214 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
215 Group:          X11/Servers
216
217 %description -n xorg-xserver-Xfbdev
218 Xfbdev is a Linux framebuffer device X server based on the kdrive X
219 server.
220
221 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
222 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
223
224 %package -n xorg-xserver-Xvfb
225 Summary:        Xvfb - virtual framebuffer X server
226 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
227 Group:          X11/Servers
228 # requires fixed and cursor fonts
229 Requires:       xorg-font-font-alias
230 Requires:       xorg-font-font-cursor-misc
231 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
232 Obsoletes:      X11-Xvfb < 1:7.0.0
233 Obsoletes:      XFree86-Xvfb < 1:7.0.0
234
235 %description -n xorg-xserver-Xvfb
236 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
237 capable of running on machines with no display hardware and no
238 physical input devices. Xvfb emulates a dumb framebuffer using virtual
239 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
240 display. Xvfb is normally used for testing servers. Using Xvfb, the
241 mfb or cfb code for any depth can be exercised without using real
242 hardware that supports the desired depths. Xvfb has also been used to
243 test X clients against unusual depths and screen configurations, to do
244 batch processing with Xvfb as a background rendering engine, to do
245 load testing, to help with porting an X server to a new platform, and
246 to provide an unobtrusive way of running applications which really
247 don't need an X server but insist on having one.
248
249 %description -n xorg-xserver-Xvfb -l pl.UTF-8
250 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
251 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
252 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
253 używany do testowania serwerów X, może też być używany do testowania
254 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
255 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
256 serwera X, ale odmawiają uruchomienia bez niego.
257
258 %package devel
259 Summary:        Header files for X.org server
260 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
261 Group:          X11/Development/Libraries
262 Requires:       libdrm-devel >= 2.4.5
263 Requires:       pixman-devel >= 0.16.0
264 Requires:       xorg-lib-libpciaccess-devel
265 Requires:       xorg-lib-libxkbfile-devel
266 Requires:       xorg-proto-dri2proto-devel >= 2.1
267 Requires:       xorg-proto-fontsproto-devel
268 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
269 Requires:       xorg-proto-renderproto-devel >= 0.9.3
270 Requires:       xorg-proto-videoproto-devel
271 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
272 Requires:       xorg-proto-xproto-devel >= 7.0.13
273 Obsoletes:      X11-Xserver-devel < 1:7.0.0
274 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
275
276 %description devel
277 Header files for X.org server.
278
279 %description devel -l pl.UTF-8
280 Pliki nagłówkowe dla serwera X.org.
281
282 %package -n xorg-xserver-libdri
283 Summary:        DRI extension library for X.org server
284 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
285 Group:          X11/Servers
286 Requires:       %{name} = %{version}-%{release}
287 Provides:       xorg-xserver-module(dri)
288 %if %{without multigl}
289 Conflicts:      xorg-driver-video-fglrx-libdri
290 Conflicts:      xorg-driver-video-nvidia
291 %endif
292
293 %description -n xorg-xserver-libdri
294 DRI extension library for X.org server.
295
296 %description -n xorg-xserver-libdri -l pl.UTF-8
297 Biblioteka rozszerzenia DRI dla serwera X.org.
298
299 %package -n xorg-xserver-libglx
300 Summary:        GLX extension library for X.org server
301 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
302 Group:          X11/Servers
303 Requires:       %{name} = %{version}-%{release}
304 Requires:       xorg-xserver-libdri = %{version}-%{release}
305 # Mesa version glapi tables in glx/ dir come from
306 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
307 Provides:       xorg-xserver-module(glx)
308 Obsoletes:      X11-OpenGL-core < 1:7.0.0
309 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
310 %if %{without multigl}
311 Conflicts:      xorg-driver-video-fglrx-libglx
312 Conflicts:      xorg-driver-video-nvidia
313 %endif
314
315 %description -n xorg-xserver-libglx
316 GLX extension library for X.org server.
317
318 %description -n xorg-xserver-libglx -l pl.UTF-8
319 Biblioteka rozszerzenia GLX dla serwera X.org.
320
321 %prep
322 %setup -q -n xorg-server-%{version}
323 %patch0 -p0
324 %patch1 -p1
325 %patch2 -p1
326 %patch6 -p1
327 %patch7 -p0
328
329 # xserver uses pixman-1 API/ABI so put that explictly here
330 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
331
332 %build
333 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
334 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
335         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
336         exit 1
337 fi
338
339 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
340 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
341         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
342         exit 1
343 fi
344
345 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
346 if [ $API != %{xorg_xserver_server_font_abi} ]; then
347         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
348         exit 1
349 fi
350 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
351 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
352         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
353         exit 1
354 fi
355 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
356 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
357         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
358         exit 1
359 fi
360
361 %{__libtoolize}
362 %{__aclocal} -I m4
363 %{__autoconf}
364 %{__autoheader}
365 %{__automake}
366 %configure \
367         --with-os-name="PLD/Linux" \
368         --with-os-vendor="PLD/Team" \
369         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
370         %{!?with_hal:--disable-config-hal} \
371         --enable-aiglx \
372         --enable-builddocs \
373         --enable-dga \
374         %{?with_dmx:--enable-dmx} \
375         --enable-glx-tls \
376         --enable-install-libxf86config \
377         %{?with_record:--enable-record} \
378         --enable-kdrive \
379         --enable-xephyr \
380         --enable-xfbdev \
381         --enable-glx-tls \
382         --disable-xsdl \
383         --disable-xfake \
384         --enable-secure-rpc \
385         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
386         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
387         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
388         --with-xkb-output=/var/lib/xkb
389
390 %{__make}
391
392 %install
393 rm -rf $RPM_BUILD_ROOT
394
395 %{__make} install \
396         DESTDIR=$RPM_BUILD_ROOT
397
398 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
399 install -d $RPM_BUILD_ROOT/etc/security/console.apps
400 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
401 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
402 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
403
404 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
405
406 %if %{with multigl}
407 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
408 mv -f libglx.so libglx.so.%{version}
409 ln -sf libglx.so.%{version} libglx.so
410 %endif
411
412 %clean
413 rm -rf $RPM_BUILD_ROOT
414
415 %if %{with multigl}
416 %post -n xorg-xserver-libglx
417 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
418         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
419 fi
420 %endif
421
422 %triggerpostun -- xorg-xserver-server < 1.5.0
423 if [ -f /etc/X11/xorg.conf ]; then
424         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
425         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
426 %if %{without record}
427         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
428 %endif
429         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
430 fi
431
432 %files
433 %defattr(644,root,root,755)
434 %doc COPYING ChangeLog
435 %attr(755,root,root) %{_bindir}/X
436 %attr(755,root,root) %{_bindir}/Xorg
437 %attr(4755,root,root) %{_bindir}/Xwrapper
438 %attr(755,root,root) %{_bindir}/cvt
439 %attr(755,root,root) %{_bindir}/gtf
440 %dir %{_libdir}/xorg
441 %{_libdir}/xorg/protocol.txt
442 %dir %{_libdir}/xorg/modules
443 %dir %{_libdir}/xorg/modules/dri
444 %dir %{_libdir}/xorg/modules/drivers
445 %dir %{_libdir}/xorg/modules/extensions
446 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
447 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
448 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
449 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
450 %dir %{_libdir}/xorg/modules/input
451 %dir %{_libdir}/xorg/modules/linux
452 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
453 %dir %{_libdir}/xorg/modules/multimedia
454 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
455 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
456 %dir /var/lib/xkb
457 /var/lib/xkb/README.compiled
458 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
459 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
460 %config(missingok) /etc/security/console.apps/xserver
461 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
462 %{_mandir}/man1/Xorg.1x*
463 %{_mandir}/man1/Xserver.1x*
464 %{_mandir}/man1/cvt.1*
465 %{_mandir}/man1/gtf.1x*
466 %{_mandir}/man4/exa.4*
467 %{_mandir}/man4/fbdevhw.4*
468 %{_mandir}/man5/xorg.conf.5x*
469
470 %if %{with dmx}
471 %files -n xorg-xserver-Xdmx
472 %defattr(644,root,root,755)
473 %attr(755,root,root) %{_bindir}/Xdmx
474 %attr(755,root,root) %{_bindir}/dmxaddinput
475 %attr(755,root,root) %{_bindir}/dmxaddscreen
476 %attr(755,root,root) %{_bindir}/dmxreconfig
477 %attr(755,root,root) %{_bindir}/dmxresize
478 %attr(755,root,root) %{_bindir}/dmxrminput
479 %attr(755,root,root) %{_bindir}/dmxrmscreen
480 %attr(755,root,root) %{_bindir}/dmxtodmx
481 %attr(755,root,root) %{_bindir}/dmxwininfo
482 %attr(755,root,root) %{_bindir}/vdltodmx
483 %attr(755,root,root) %{_bindir}/xdmx
484 %attr(755,root,root) %{_bindir}/xdmxconfig
485 %{_mandir}/man1/Xdmx.1x*
486 %{_mandir}/man1/dmxtodmx.1x*
487 %{_mandir}/man1/vdltodmx.1x*
488 %{_mandir}/man1/xdmxconfig.1x*
489 %endif
490
491 %files -n xorg-xserver-Xnest
492 %defattr(644,root,root,755)
493 %attr(755,root,root) %{_bindir}/Xnest
494 %{_mandir}/man1/Xnest.1x*
495
496 %files -n xorg-xserver-Xephyr
497 %defattr(644,root,root,755)
498 %attr(755,root,root) %{_bindir}/Xephyr
499 %{_mandir}/man1/Xephyr.1x*
500
501 %files -n xorg-xserver-Xfbdev
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_bindir}/Xfbdev
504
505 %files -n xorg-xserver-Xvfb
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/Xvfb
508 %{_mandir}/man1/Xvfb.1x*
509
510 %files devel
511 %defattr(644,root,root,755)
512 %{_includedir}/xorg
513 %{_libdir}/libxf86config.a
514 %{_aclocaldir}/xorg-server.m4
515 %{_pkgconfigdir}/xorg-server.pc
516
517 %files -n xorg-xserver-libdri
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
520
521 %files -n xorg-xserver-libglx
522 %defattr(644,root,root,755)
523 %if %{with multigl}
524 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
525 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
526 %else
527 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
528 %endif
This page took 0.110716 seconds and 4 git commands to generate.