]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- xinerama qt crash fix
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_without  record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       4.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        8.0
16 %define xorg_xserver_server_xinput_abi          11.0
17
18 %define         rel     1
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.9.2
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  5c8773499a6a8c1ddaedf33577ec9634
28 Source1:        10-quirks.conf
29 Source2:        xserver.pamd
30 Source10:       %{name}-Xvfb.init
31 Source11:       %{name}-Xvfb.sysconfig
32 Patch0:         %{name}-xwrapper.patch
33 Patch1:         %{name}-pic-libxf86config.patch
34 Patch2:         %{name}-fb-size.patch
35 Patch3:         %{name}-less-acpi-brokenness.patch
36 Patch4:         %{name}-builtin-SHA1.patch
37 Patch5:         %{name}-qt-crash.patch
38 URL:            http://xorg.freedesktop.org/
39 BuildRequires:  Mesa-libGL-devel >= 7.8.1
40 # for glx headers
41 BuildRequires:  OpenGL-GLX-devel
42 BuildRequires:  autoconf >= 2.57
43 BuildRequires:  automake
44 BuildRequires:  cpp
45 #BuildRequires: doxygen >= 1.6.1
46 %if %{with hal} || %{with dbus}
47 BuildRequires:  dbus-devel >= 1.0
48 %endif
49 %{?with_hal:BuildRequires:      hal-devel}
50 BuildRequires:  libdrm-devel >= 2.4.5
51 BuildRequires:  libtool
52 BuildRequires:  ncurses-devel
53 BuildRequires:  pam-devel
54 BuildRequires:  perl-base
55 BuildRequires:  pixman-devel >= 0.16.0
56 BuildRequires:  pkgconfig >= 1:0.19
57 BuildRequires:  udev-devel >= 1:143
58 BuildRequires:  xmlto >= 0.0.20
59 BuildRequires:  xorg-app-mkfontscale
60 BuildRequires:  xorg-font-font-util >= 1.1
61 BuildRequires:  xorg-lib-libX11-devel
62 BuildRequires:  xorg-lib-libXau-devel
63 BuildRequires:  xorg-lib-libXaw-devel
64 BuildRequires:  xorg-lib-libXdamage-devel
65 BuildRequires:  xorg-lib-libXdmcp-devel
66 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
67 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
68 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
69 BuildRequires:  xorg-lib-libXmu-devel
70 BuildRequires:  xorg-lib-libXpm-devel
71 BuildRequires:  xorg-lib-libXrender-devel
72 BuildRequires:  xorg-lib-libXres-devel
73 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
74 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
75 BuildRequires:  xorg-lib-libXv-devel
76 BuildRequires:  xorg-lib-libXxf86dga-devel
77 BuildRequires:  xorg-lib-libXxf86misc-devel
78 BuildRequires:  xorg-lib-libXxf86vm-devel
79 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
80 BuildRequires:  xorg-lib-libfontenc-devel
81 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
82 BuildRequires:  xorg-lib-libxkbfile-devel
83 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
84 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
85 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
86 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
87 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
88 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
89 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
90 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
91 BuildRequires:  xorg-proto-fontcacheproto-devel
92 BuildRequires:  xorg-proto-fontsproto-devel
93 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
94 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
95 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
96 BuildRequires:  xorg-proto-printproto-devel
97 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
98 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
99 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
100 BuildRequires:  xorg-proto-resourceproto-devel
101 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
102 BuildRequires:  xorg-proto-videoproto-devel
103 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
104 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
105 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
106 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
107 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
108 BuildRequires:  xorg-proto-xf86miscproto-devel
109 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
110 BuildRequires:  xorg-proto-xineramaproto-devel
111 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
112 BuildRequires:  xorg-sgml-doctools >= 1.5
113 BuildRequires:  xorg-util-util-macros >= 1.10
114 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
115 #BR: xcalibrateproto, tslib (for KDRIVE only)
116 Requires(triggerpostun):        sed >= 4.0
117 Requires:       pixman >= 0.16.0
118 Requires:       xkeyboard-config
119 # for rgb.txt
120 Requires:       xorg-app-rgb >= 0.99.3
121 Requires:       xorg-app-xkbcomp
122 %{?with_hal:Suggests:   dbus >= 1.0}
123 %{?with_hal:Suggests:   hal}
124 Suggests:       udev-acl
125 %{?with_udev:Suggests:  udev-core >= 1:143}
126 Suggests:       xorg-driver-input-evdev
127 # xserver requires fixed and cursor fonts
128 Requires:       xorg-font-font-alias
129 Requires:       xorg-font-font-cursor-misc
130 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
131 Suggests:       xkeyboard-config
132 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
133 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
134 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
135 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
136 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
137 Obsoletes:      X11-Xserver < 1:7.0.0
138 Obsoletes:      X11-driver-i2c < 1:7.0.0
139 Obsoletes:      X11-modules < 1:7.0.0
140 Obsoletes:      X11-setup < 1:7.0.0
141 Obsoletes:      XFree86-Xserver < 1:7.0.0
142 Obsoletes:      XFree86-modules < 1:7.0.0
143 Obsoletes:      XFree86-setup < 1:7.0.0
144 Obsoletes:      Xserver
145 Obsoletes:      xorg-xserver-server-xorgcfg
146 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
147
148 # avoid self-dependencies on included modules
149 %define         _noautoreq      libscanpci.so libxf1bpp.so
150
151 %description
152 Xorg server is a generally used X server which uses display hardware.
153 It requires proper driver for your display hardware.
154
155 %description -l pl.UTF-8
156 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
157 graficznej. Do działania wymaga odpowiedniego sterownika.
158
159 %package -n xorg-xserver-Xdmx
160 Summary:        Xdmx - distributed multi-head X server
161 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
162 Group:          X11/Servers
163
164 %description -n xorg-xserver-Xdmx
165 Xdmx - distributed multi-head X server.
166
167 %description -n xorg-xserver-Xdmx -l pl.UTF-8
168 Xdmx - rozproszony, wielomonitorowy serwer X.
169
170 %package -n xorg-xserver-Xnest
171 Summary:        Xnest - nested X server
172 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
173 Group:          X11/Servers
174 Obsoletes:      X11-Xnest < 1:7.0.0
175 Obsoletes:      XFree86-Xnest < 1:7.0.0
176 Obsoletes:      Xserver-Xnest
177
178 %description -n xorg-xserver-Xnest
179 Xnest is an X Window System server which runs in an X window. Xnest is
180 a 'nested' window server, actually a client of the real X server,
181 which manages windows and graphics requests for Xnest, while Xnest
182 manages the windows and graphics requests for its own clients.
183
184 %description -n xorg-xserver-Xnest -l pl.UTF-8
185 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
186 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
187 serwer X dla własnych klientów.
188
189 %description -n xorg-xserver-Xnest -l ru.UTF-8
190 Xnest - это сервер X Window System, который работает в окне X. На
191 самом деле это клиент реального X-сервера, который управляет окнами и
192 графическими запросами для Xnest в то время, как Xnest управляет
193 окнами и графическими запросами для своих собственных клиентов.
194
195 %description -n xorg-xserver-Xnest -l uk.UTF-8
196 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
197 клієнт реального X-сервера, який керує вікнами та графічними запитами
198 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
199 своїх власних клієнтів.
200
201 %package -n xorg-xserver-Xephyr
202 Summary:        Xephyr - nested X server
203 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
204 Group:          X11/Servers
205 Requires:       pixman >= 0.15.0
206
207 %description -n xorg-xserver-Xephyr
208 Xephyr is a a kdrive server that outputs to a window on a pre-existing
209 'host' X display. Think Xnest but with support for modern extensions
210 like composite, damage and randr.
211
212 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
213 the host X server, Xephyr is a real X server which uses the host X
214 server window as "framebuffer" via fast SHM XImages.
215
216 It also has support for 'visually' debugging what the server is
217 painting.
218
219 %description -n xorg-xserver-Xephyr -l pl.UTF-8
220 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
221 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
222 wspólczesnych rozszerzeń jak composite, damage i randr.
223
224 %package -n xorg-xserver-Xfbdev
225 Summary:        Xfbdev - Linux framebuffer device X server
226 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
227 Group:          X11/Servers
228
229 %description -n xorg-xserver-Xfbdev
230 Xfbdev is a Linux framebuffer device X server based on the kdrive X
231 server.
232
233 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
234 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
235
236 %package -n xorg-xserver-Xvfb
237 Summary:        Xvfb - virtual framebuffer X server
238 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
239 Group:          X11/Servers
240 # requires fixed and cursor fonts
241 Requires:       xorg-font-font-alias
242 Requires:       xorg-font-font-cursor-misc
243 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
244 Obsoletes:      X11-Xvfb < 1:7.0.0
245 Obsoletes:      XFree86-Xvfb < 1:7.0.0
246
247 %description -n xorg-xserver-Xvfb
248 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
249 capable of running on machines with no display hardware and no
250 physical input devices. Xvfb emulates a dumb framebuffer using virtual
251 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
252 display. Xvfb is normally used for testing servers. Using Xvfb, the
253 mfb or cfb code for any depth can be exercised without using real
254 hardware that supports the desired depths. Xvfb has also been used to
255 test X clients against unusual depths and screen configurations, to do
256 batch processing with Xvfb as a background rendering engine, to do
257 load testing, to help with porting an X server to a new platform, and
258 to provide an unobtrusive way of running applications which really
259 don't need an X server but insist on having one.
260
261 %description -n xorg-xserver-Xvfb -l pl.UTF-8
262 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
263 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
264 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
265 używany do testowania serwerów X, może też być używany do testowania
266 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
267 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
268 serwera X, ale odmawiają uruchomienia bez niego.
269
270 %package -n xorg-xserver-Xvfb-init
271 Summary:        Init scripts for Xvfb
272 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
273 Group:          X11/Servers
274 Requires:       xorg-xserver-Xvfb
275
276 %description -n xorg-xserver-Xvfb-init
277 This package contains init scripts for Xvfb and registers Xvfb as
278 system service.
279
280 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
281 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
282 usługę systemową.
283
284 %package devel
285 Summary:        Header files for X.org server
286 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
287 Group:          X11/Development/Libraries
288 Requires:       libdrm-devel >= 2.4.5
289 Requires:       pixman-devel >= 0.16.0
290 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
291 Requires:       xorg-lib-libxkbfile-devel
292 Requires:       xorg-proto-dri2proto-devel >= 2.3
293 Requires:       xorg-proto-fontsproto-devel
294 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
295 Requires:       xorg-proto-kbproto-devel >= 1.0.3
296 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
297 Requires:       xorg-proto-renderproto-devel >= 0.11
298 Requires:       xorg-proto-videoproto-devel
299 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
300 Requires:       xorg-proto-xproto-devel >= 7.0.17
301 Obsoletes:      X11-Xserver-devel < 1:7.0.0
302 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
303
304 %description devel
305 Header files for X.org server.
306
307 %description devel -l pl.UTF-8
308 Pliki nagłówkowe dla serwera X.org.
309
310 %package source
311 Summary:        X.org server source code
312 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
313 Group:          X11/Development/Libraries
314
315 %description source
316 X.org server source code.
317
318 %description source -l pl.UTF-8
319 Pliki źródłowe dla serwera X.org.
320
321 %package -n xorg-xserver-libdri
322 Summary:        DRI extension library for X.org server
323 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
324 Group:          X11/Servers
325 Requires:       %{name} = %{version}-%{release}
326 Provides:       xorg-xserver-module(dri)
327 %if %{without multigl}
328 Conflicts:      xorg-driver-video-fglrx
329 Conflicts:      xorg-driver-video-nvidia
330 %endif
331
332 %description -n xorg-xserver-libdri
333 DRI extension library for X.org server.
334
335 %description -n xorg-xserver-libdri -l pl.UTF-8
336 Biblioteka rozszerzenia DRI dla serwera X.org.
337
338 %package -n xorg-xserver-libglx
339 Summary:        GLX extension library for X.org server
340 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
341 Group:          X11/Servers
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       xorg-xserver-libdri = %{version}-%{release}
344 # Mesa version glapi tables in glx/ dir come from
345 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
346 Provides:       xorg-xserver-module(glx)
347 Obsoletes:      X11-OpenGL-core < 1:7.0.0
348 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
349 %if %{without multigl}
350 Conflicts:      xorg-driver-video-fglrx
351 Conflicts:      xorg-driver-video-nvidia
352 %endif
353
354 %description -n xorg-xserver-libglx
355 GLX extension library for X.org server.
356
357 %description -n xorg-xserver-libglx -l pl.UTF-8
358 Biblioteka rozszerzenia GLX dla serwera X.org.
359
360 %prep
361 %setup -q -n xorg-server-%{version}
362 %patch0 -p0
363 %patch1 -p1
364 %patch2 -p1
365 %patch3 -p1
366 %patch4 -p1
367 %patch5 -p1
368
369 # xserver uses pixman-1 API/ABI so put that explictly here
370 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
371
372 %build
373 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
374 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
375         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
376         exit 1
377 fi
378
379 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
380 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
381         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
382         exit 1
383 fi
384
385 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
386 if [ $API != %{xorg_xserver_server_font_abi} ]; then
387         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
388         exit 1
389 fi
390 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
391 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
392         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
393         exit 1
394 fi
395 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
396 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
397         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
398         exit 1
399 fi
400
401 %{__libtoolize}
402 %{__aclocal} -I m4
403 %{__autoconf}
404 %{__autoheader}
405 %{__automake}
406 %configure \
407         --with-os-name="PLD/Linux" \
408         --with-os-vendor="PLD/Team" \
409         --without-fop \
410         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
411         %{!?with_hal:--disable-config-hal} \
412         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
413         --enable-aiglx \
414         --enable-builddocs \
415         --enable-dga \
416         %{?with_dmx:--enable-dmx} \
417         --enable-glx-tls \
418         --enable-install-libxf86config \
419         %{?with_record:--enable-record} \
420         --enable-kdrive \
421         --enable-xephyr \
422         --enable-xfbdev \
423         --enable-glx-tls \
424         --disable-xsdl \
425         --disable-xfake \
426         --enable-secure-rpc \
427         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
428         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
429         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
430         --with-xkb-output=/var/lib/xkb
431
432 %{__make}
433
434 %install
435 rm -rf $RPM_BUILD_ROOT
436
437 %{__make} install \
438         DESTDIR=$RPM_BUILD_ROOT
439
440 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
441 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
442 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
443 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
444
445 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
446 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
447
448 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
449
450 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
451
452 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
453 install -d $RPM_BUILD_ROOT/etc/sysconfig
454 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
455 install %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
456
457 %if %{with multigl}
458 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
459 mv -f libglx.so libglx.so.%{version}
460 ln -sf libglx.so.%{version} libglx.so
461 cd -
462 %endif
463
464 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
465 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
466 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
467 %{__make} distclean
468 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %if %{with multigl}
474 %post -n xorg-xserver-libglx
475 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
476         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
477 fi
478 %endif
479
480 %triggerpostun -- xorg-xserver-server < 1.5.0
481 if [ -f /etc/X11/xorg.conf ]; then
482         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
483         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
484 %if %{without record}
485         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
486 %endif
487         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
488 fi
489
490 %post -n xorg-xserver-Xvfb-init
491 /sbin/chkconfig --add Xvfb
492 %service Xvfb restart
493
494 %preun -n xorg-xserver-Xvfb-init
495 if [ "$1" = "0" ]; then
496         %service -q Xvfb stop
497         /sbin/chkconfig --del Xvfb
498 fi
499
500 %files
501 %defattr(644,root,root,755)
502 %doc COPYING ChangeLog README
503 %attr(755,root,root) %{_bindir}/X
504 %attr(755,root,root) %{_bindir}/Xorg
505 %attr(4755,root,root) %{_bindir}/Xwrapper
506 %attr(755,root,root) %{_bindir}/cvt
507 %attr(755,root,root) %{_bindir}/gtf
508 %dir %{_libdir}/xorg
509 %{_libdir}/xorg/protocol.txt
510 %dir %{_libdir}/xorg/modules
511 %dir %{_libdir}/xorg/modules/dri
512 %dir %{_libdir}/xorg/modules/drivers
513 %dir %{_libdir}/xorg/modules/extensions
514 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
515 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
516 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
517 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
518 %dir %{_libdir}/xorg/modules/input
519 %dir %{_libdir}/xorg/modules/multimedia
520 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
521 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
522 %dir /var/lib/xkb
523 /var/lib/xkb/README.compiled
524 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
525 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
526 %config(missingok) /etc/security/console.apps/xserver
527 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
528 %dir /etc/X11/xorg.conf.d
529 %dir %{_datadir}/X11/xorg.conf.d
530 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
531 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
532 %{_mandir}/man1/Xorg.1x*
533 %{_mandir}/man1/Xserver.1x*
534 %{_mandir}/man1/cvt.1*
535 %{_mandir}/man1/gtf.1x*
536 %{_mandir}/man4/exa.4*
537 %{_mandir}/man4/fbdevhw.4*
538 %{_mandir}/man5/xorg.conf.5x*
539
540 %if %{with dmx}
541 %files -n xorg-xserver-Xdmx
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_bindir}/Xdmx
544 %attr(755,root,root) %{_bindir}/dmxaddinput
545 %attr(755,root,root) %{_bindir}/dmxaddscreen
546 %attr(755,root,root) %{_bindir}/dmxinfo
547 %attr(755,root,root) %{_bindir}/dmxreconfig
548 %attr(755,root,root) %{_bindir}/dmxresize
549 %attr(755,root,root) %{_bindir}/dmxrminput
550 %attr(755,root,root) %{_bindir}/dmxrmscreen
551 %attr(755,root,root) %{_bindir}/dmxtodmx
552 %attr(755,root,root) %{_bindir}/dmxwininfo
553 %attr(755,root,root) %{_bindir}/vdltodmx
554 %attr(755,root,root) %{_bindir}/xdmxconfig
555 %{_mandir}/man1/Xdmx.1x*
556 %{_mandir}/man1/dmxtodmx.1x*
557 %{_mandir}/man1/vdltodmx.1x*
558 %{_mandir}/man1/xdmxconfig.1x*
559 %endif
560
561 %files -n xorg-xserver-Xnest
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/Xnest
564 %{_mandir}/man1/Xnest.1x*
565
566 %files -n xorg-xserver-Xephyr
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/Xephyr
569 %{_mandir}/man1/Xephyr.1x*
570
571 %files -n xorg-xserver-Xfbdev
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_bindir}/Xfbdev
574
575 %files -n xorg-xserver-Xvfb
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_bindir}/Xvfb
578 %{_mandir}/man1/Xvfb.1x*
579
580 %files -n xorg-xserver-Xvfb-init
581 %defattr(644,root,root,755)
582 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
583 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
584
585 %files devel
586 %defattr(644,root,root,755)
587 %doc doc/xml/{Xserver-spec.html,xorg.css}
588 %{_includedir}/xorg
589 %{_libdir}/libxf86config.a
590 %{_aclocaldir}/xorg-server.m4
591 %{_pkgconfigdir}/xorg-server.pc
592
593 %files source
594 %defattr(-,root,root,755)
595 %{_usrsrc}/%{name}-%{version}
596
597 %files -n xorg-xserver-libdri
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
600
601 %files -n xorg-xserver-libglx
602 %defattr(644,root,root,755)
603 %if %{with multigl}
604 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
605 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
606 %else
607 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
608 %endif
This page took 0.079726 seconds and 4 git commands to generate.