]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- 1.10 rc2
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_without  record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       5.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        9.0
16 %define xorg_xserver_server_xinput_abi          12.2
17
18 %define         rel     0.1
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.9.99.902
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  40f8976981c2d644d5ea3160ece78a24
28 Source1:        10-quirks.conf
29 Source2:        xserver.pamd
30 Source10:       %{name}-Xvfb.init
31 Source11:       %{name}-Xvfb.sysconfig
32 Patch0:         %{name}-xwrapper.patch
33 Patch1:         %{name}-pic-libxf86config.patch
34 Patch2:         %{name}-fb-size.patch
35 Patch3:         %{name}-less-acpi-brokenness.patch
36 Patch4:         %{name}-builtin-SHA1.patch
37 URL:            http://xorg.freedesktop.org/
38 BuildRequires:  Mesa-libGL-devel >= 7.8.1
39 # for glx headers
40 BuildRequires:  OpenGL-GLX-devel
41 BuildRequires:  autoconf >= 2.57
42 BuildRequires:  automake
43 BuildRequires:  cpp
44 #BuildRequires: doxygen >= 1.6.1
45 %if %{with hal} || %{with dbus}
46 BuildRequires:  dbus-devel >= 1.0
47 %endif
48 %{?with_hal:BuildRequires:      hal-devel}
49 BuildRequires:  libdrm-devel >= 2.4.5
50 BuildRequires:  libtool
51 BuildRequires:  ncurses-devel
52 BuildRequires:  pam-devel
53 BuildRequires:  perl-base
54 BuildRequires:  pixman-devel >= 0.16.0
55 BuildRequires:  pkgconfig >= 1:0.19
56 BuildRequires:  udev-devel >= 1:143
57 BuildRequires:  xmlto >= 0.0.20
58 BuildRequires:  xorg-app-mkfontscale
59 BuildRequires:  xorg-font-font-util >= 1.1
60 BuildRequires:  xorg-lib-libX11-devel
61 BuildRequires:  xorg-lib-libXau-devel
62 BuildRequires:  xorg-lib-libXaw-devel
63 BuildRequires:  xorg-lib-libXdamage-devel
64 BuildRequires:  xorg-lib-libXdmcp-devel
65 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
66 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
67 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
68 BuildRequires:  xorg-lib-libXmu-devel
69 BuildRequires:  xorg-lib-libXpm-devel
70 BuildRequires:  xorg-lib-libXrender-devel
71 BuildRequires:  xorg-lib-libXres-devel
72 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
73 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
74 BuildRequires:  xorg-lib-libXv-devel
75 BuildRequires:  xorg-lib-libXxf86dga-devel
76 BuildRequires:  xorg-lib-libXxf86misc-devel
77 BuildRequires:  xorg-lib-libXxf86vm-devel
78 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
79 BuildRequires:  xorg-lib-libfontenc-devel
80 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
81 BuildRequires:  xorg-lib-libxkbfile-devel
82 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
83 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
84 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
85 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
86 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
87 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
88 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.3}
89 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
90 BuildRequires:  xorg-proto-fontcacheproto-devel
91 BuildRequires:  xorg-proto-fontsproto-devel
92 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
93 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
94 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
95 BuildRequires:  xorg-proto-printproto-devel
96 BuildRequires:  xorg-proto-randrproto-devel >= 1.4
97 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
98 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
99 BuildRequires:  xorg-proto-resourceproto-devel
100 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
101 BuildRequires:  xorg-proto-videoproto-devel
102 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
103 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.1.99
104 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
105 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
106 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
107 BuildRequires:  xorg-proto-xf86miscproto-devel
108 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
109 BuildRequires:  xorg-proto-xineramaproto-devel
110 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
111 BuildRequires:  xorg-sgml-doctools >= 1.5
112 BuildRequires:  xorg-util-util-macros >= 1.10
113 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
114 #BR: xcalibrateproto, tslib (for KDRIVE only)
115 Requires(triggerpostun):        sed >= 4.0
116 Requires:       pixman >= 0.16.0
117 Requires:       xkeyboard-config
118 # for rgb.txt
119 Requires:       xorg-app-rgb >= 0.99.3
120 Requires:       xorg-app-xkbcomp
121 %{?with_hal:Suggests:   dbus >= 1.0}
122 %{?with_hal:Suggests:   hal}
123 Suggests:       udev-acl
124 %{?with_udev:Suggests:  udev-core >= 1:143}
125 Suggests:       xorg-driver-input-evdev
126 # xserver requires fixed and cursor fonts
127 Requires:       xorg-font-font-alias
128 Requires:       xorg-font-font-cursor-misc
129 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
130 Suggests:       xkeyboard-config
131 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
132 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
133 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
134 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
135 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
136 Obsoletes:      X11-Xserver < 1:7.0.0
137 Obsoletes:      X11-driver-i2c < 1:7.0.0
138 Obsoletes:      X11-modules < 1:7.0.0
139 Obsoletes:      X11-setup < 1:7.0.0
140 Obsoletes:      XFree86-Xserver < 1:7.0.0
141 Obsoletes:      XFree86-modules < 1:7.0.0
142 Obsoletes:      XFree86-setup < 1:7.0.0
143 Obsoletes:      Xserver
144 Obsoletes:      xorg-xserver-server-xorgcfg
145 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
146
147 # avoid self-dependencies on included modules
148 %define         _noautoreq      libscanpci.so libxf1bpp.so
149
150 %description
151 Xorg server is a generally used X server which uses display hardware.
152 It requires proper driver for your display hardware.
153
154 %description -l pl.UTF-8
155 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
156 graficznej. Do działania wymaga odpowiedniego sterownika.
157
158 %package -n xorg-xserver-Xdmx
159 Summary:        Xdmx - distributed multi-head X server
160 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
161 Group:          X11/Servers
162
163 %description -n xorg-xserver-Xdmx
164 Xdmx - distributed multi-head X server.
165
166 %description -n xorg-xserver-Xdmx -l pl.UTF-8
167 Xdmx - rozproszony, wielomonitorowy serwer X.
168
169 %package -n xorg-xserver-Xnest
170 Summary:        Xnest - nested X server
171 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
172 Group:          X11/Servers
173 Obsoletes:      X11-Xnest < 1:7.0.0
174 Obsoletes:      XFree86-Xnest < 1:7.0.0
175 Obsoletes:      Xserver-Xnest
176
177 %description -n xorg-xserver-Xnest
178 Xnest is an X Window System server which runs in an X window. Xnest is
179 a 'nested' window server, actually a client of the real X server,
180 which manages windows and graphics requests for Xnest, while Xnest
181 manages the windows and graphics requests for its own clients.
182
183 %description -n xorg-xserver-Xnest -l pl.UTF-8
184 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
185 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
186 serwer X dla własnych klientów.
187
188 %description -n xorg-xserver-Xnest -l ru.UTF-8
189 Xnest - это сервер X Window System, который работает в окне X. На
190 самом деле это клиент реального X-сервера, который управляет окнами и
191 графическими запросами для Xnest в то время, как Xnest управляет
192 окнами и графическими запросами для своих собственных клиентов.
193
194 %description -n xorg-xserver-Xnest -l uk.UTF-8
195 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
196 клієнт реального X-сервера, який керує вікнами та графічними запитами
197 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
198 своїх власних клієнтів.
199
200 %package -n xorg-xserver-Xephyr
201 Summary:        Xephyr - nested X server
202 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
203 Group:          X11/Servers
204 Requires:       pixman >= 0.15.0
205
206 %description -n xorg-xserver-Xephyr
207 Xephyr is a a kdrive server that outputs to a window on a pre-existing
208 'host' X display. Think Xnest but with support for modern extensions
209 like composite, damage and randr.
210
211 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
212 the host X server, Xephyr is a real X server which uses the host X
213 server window as "framebuffer" via fast SHM XImages.
214
215 It also has support for 'visually' debugging what the server is
216 painting.
217
218 %description -n xorg-xserver-Xephyr -l pl.UTF-8
219 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
220 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
221 wspólczesnych rozszerzeń jak composite, damage i randr.
222
223 %package -n xorg-xserver-Xfbdev
224 Summary:        Xfbdev - Linux framebuffer device X server
225 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
226 Group:          X11/Servers
227
228 %description -n xorg-xserver-Xfbdev
229 Xfbdev is a Linux framebuffer device X server based on the kdrive X
230 server.
231
232 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
233 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
234
235 %package -n xorg-xserver-Xvfb
236 Summary:        Xvfb - virtual framebuffer X server
237 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
238 Group:          X11/Servers
239 # requires fixed and cursor fonts
240 Requires:       xorg-font-font-alias
241 Requires:       xorg-font-font-cursor-misc
242 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
243 Obsoletes:      X11-Xvfb < 1:7.0.0
244 Obsoletes:      XFree86-Xvfb < 1:7.0.0
245
246 %description -n xorg-xserver-Xvfb
247 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
248 capable of running on machines with no display hardware and no
249 physical input devices. Xvfb emulates a dumb framebuffer using virtual
250 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
251 display. Xvfb is normally used for testing servers. Using Xvfb, the
252 mfb or cfb code for any depth can be exercised without using real
253 hardware that supports the desired depths. Xvfb has also been used to
254 test X clients against unusual depths and screen configurations, to do
255 batch processing with Xvfb as a background rendering engine, to do
256 load testing, to help with porting an X server to a new platform, and
257 to provide an unobtrusive way of running applications which really
258 don't need an X server but insist on having one.
259
260 %description -n xorg-xserver-Xvfb -l pl.UTF-8
261 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
262 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
263 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
264 używany do testowania serwerów X, może też być używany do testowania
265 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
266 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
267 serwera X, ale odmawiają uruchomienia bez niego.
268
269 %package -n xorg-xserver-Xvfb-init
270 Summary:        Init scripts for Xvfb
271 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
272 Group:          X11/Servers
273 Requires:       xorg-xserver-Xvfb
274
275 %description -n xorg-xserver-Xvfb-init
276 This package contains init scripts for Xvfb and registers Xvfb as
277 system service.
278
279 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
280 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
281 usługę systemową.
282
283 %package devel
284 Summary:        Header files for X.org server
285 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
286 Group:          X11/Development/Libraries
287 Requires:       libdrm-devel >= 2.4.5
288 Requires:       pixman-devel >= 0.16.0
289 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
290 Requires:       xorg-lib-libxkbfile-devel
291 Requires:       xorg-proto-dri2proto-devel >= 2.3
292 Requires:       xorg-proto-fontsproto-devel
293 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
294 Requires:       xorg-proto-kbproto-devel >= 1.0.3
295 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
296 Requires:       xorg-proto-renderproto-devel >= 0.11
297 Requires:       xorg-proto-videoproto-devel
298 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
299 Requires:       xorg-proto-xineramaproto-devel
300 Requires:       xorg-proto-xproto-devel >= 7.0.17
301 Obsoletes:      X11-Xserver-devel < 1:7.0.0
302 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
303
304 %description devel
305 Header files for X.org server.
306
307 %description devel -l pl.UTF-8
308 Pliki nagłówkowe dla serwera X.org.
309
310 %package source
311 Summary:        X.org server source code
312 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
313 Group:          X11/Development/Libraries
314
315 %description source
316 X.org server source code.
317
318 %description source -l pl.UTF-8
319 Pliki źródłowe dla serwera X.org.
320
321 %package -n xorg-xserver-libdri
322 Summary:        DRI extension library for X.org server
323 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
324 Group:          X11/Servers
325 Requires:       %{name} = %{version}-%{release}
326 Provides:       xorg-xserver-module(dri)
327 %if %{without multigl}
328 Conflicts:      xorg-driver-video-fglrx
329 Conflicts:      xorg-driver-video-nvidia
330 %endif
331
332 %description -n xorg-xserver-libdri
333 DRI extension library for X.org server.
334
335 %description -n xorg-xserver-libdri -l pl.UTF-8
336 Biblioteka rozszerzenia DRI dla serwera X.org.
337
338 %package -n xorg-xserver-libglx
339 Summary:        GLX extension library for X.org server
340 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
341 Group:          X11/Servers
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       xorg-xserver-libdri = %{version}-%{release}
344 # Mesa version glapi tables in glx/ dir come from
345 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
346 Provides:       xorg-xserver-module(glx)
347 Obsoletes:      X11-OpenGL-core < 1:7.0.0
348 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
349 %if %{without multigl}
350 Conflicts:      xorg-driver-video-fglrx
351 Conflicts:      xorg-driver-video-nvidia
352 %endif
353
354 %description -n xorg-xserver-libglx
355 GLX extension library for X.org server.
356
357 %description -n xorg-xserver-libglx -l pl.UTF-8
358 Biblioteka rozszerzenia GLX dla serwera X.org.
359
360 %prep
361 %setup -q -n xorg-server-%{version}
362 %patch0 -p0
363 %patch1 -p1
364 %patch2 -p1
365 %patch3 -p1
366 %patch4 -p1
367
368 # xserver uses pixman-1 API/ABI so put that explictly here
369 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
370
371 %build
372 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
373 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
374         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
375         exit 1
376 fi
377
378 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
379 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
380         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
381         exit 1
382 fi
383
384 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
385 if [ $API != %{xorg_xserver_server_font_abi} ]; then
386         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
387         exit 1
388 fi
389 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
390 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
391         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
392         exit 1
393 fi
394 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
395 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
396         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
397         exit 1
398 fi
399
400 %{__libtoolize}
401 %{__aclocal} -I m4
402 %{__autoconf}
403 %{__autoheader}
404 %{__automake}
405 %configure \
406         --with-os-name="PLD/Linux" \
407         --with-os-vendor="PLD/Team" \
408         --without-fop \
409         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
410         %{!?with_hal:--disable-config-hal} \
411         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
412         --enable-aiglx \
413         --enable-builddocs \
414         --enable-dga \
415         %{?with_dmx:--enable-dmx} \
416         --enable-glx-tls \
417         --enable-install-libxf86config \
418         %{?with_record:--enable-record} \
419         --enable-kdrive \
420         --enable-xephyr \
421         --enable-xfbdev \
422         --enable-glx-tls \
423         --disable-xfake \
424         --enable-secure-rpc \
425         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
426         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
427         --with-xkb-output=/var/lib/xkb
428
429 %{__make}
430
431 %install
432 rm -rf $RPM_BUILD_ROOT
433
434 %{__make} install \
435         DESTDIR=$RPM_BUILD_ROOT
436
437 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
438 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
439 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
440 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
441
442 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
443 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
444
445 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
446
447 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
448
449 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
450 install -d $RPM_BUILD_ROOT/etc/sysconfig
451 install %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
452 install %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
453
454 %if %{with multigl}
455 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
456 mv -f libglx.so libglx.so.%{version}
457 ln -sf libglx.so.%{version} libglx.so
458 cd -
459 %endif
460
461 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
462 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
463 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
464 %{__make} distclean
465 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %if %{with multigl}
471 %post -n xorg-xserver-libglx
472 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
473         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
474 fi
475 %endif
476
477 %triggerpostun -- xorg-xserver-server < 1.5.0
478 if [ -f /etc/X11/xorg.conf ]; then
479         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
480         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
481 %if %{without record}
482         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
483 %endif
484         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
485 fi
486
487 %post -n xorg-xserver-Xvfb-init
488 /sbin/chkconfig --add Xvfb
489 %service Xvfb restart
490
491 %preun -n xorg-xserver-Xvfb-init
492 if [ "$1" = "0" ]; then
493         %service -q Xvfb stop
494         /sbin/chkconfig --del Xvfb
495 fi
496
497 %files
498 %defattr(644,root,root,755)
499 %doc COPYING ChangeLog README
500 %attr(755,root,root) %{_bindir}/X
501 %attr(755,root,root) %{_bindir}/Xorg
502 %attr(4755,root,root) %{_bindir}/Xwrapper
503 %attr(755,root,root) %{_bindir}/cvt
504 %attr(755,root,root) %{_bindir}/gtf
505 %dir %{_libdir}/xorg
506 %{_libdir}/xorg/protocol.txt
507 %dir %{_libdir}/xorg/modules
508 %dir %{_libdir}/xorg/modules/dri
509 %dir %{_libdir}/xorg/modules/drivers
510 %dir %{_libdir}/xorg/modules/extensions
511 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
512 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
513 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
514 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
515 %dir %{_libdir}/xorg/modules/input
516 %dir %{_libdir}/xorg/modules/multimedia
517 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
518 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
519 %dir /var/lib/xkb
520 /var/lib/xkb/README.compiled
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
522 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
523 %config(missingok) /etc/security/console.apps/xserver
524 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
525 %dir /etc/X11/xorg.conf.d
526 %dir %{_datadir}/X11/xorg.conf.d
527 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
528 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
529 %{_mandir}/man1/Xorg.1x*
530 %{_mandir}/man1/Xserver.1x*
531 %{_mandir}/man1/cvt.1*
532 %{_mandir}/man1/gtf.1x*
533 %{_mandir}/man4/exa.4*
534 %{_mandir}/man4/fbdevhw.4*
535 %{_mandir}/man5/xorg.conf.5x*
536
537 %if %{with dmx}
538 %files -n xorg-xserver-Xdmx
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/Xdmx
541 %attr(755,root,root) %{_bindir}/dmxaddinput
542 %attr(755,root,root) %{_bindir}/dmxaddscreen
543 %attr(755,root,root) %{_bindir}/dmxinfo
544 %attr(755,root,root) %{_bindir}/dmxreconfig
545 %attr(755,root,root) %{_bindir}/dmxresize
546 %attr(755,root,root) %{_bindir}/dmxrminput
547 %attr(755,root,root) %{_bindir}/dmxrmscreen
548 %attr(755,root,root) %{_bindir}/dmxtodmx
549 %attr(755,root,root) %{_bindir}/dmxwininfo
550 %attr(755,root,root) %{_bindir}/vdltodmx
551 %attr(755,root,root) %{_bindir}/xdmxconfig
552 %{_mandir}/man1/Xdmx.1x*
553 %{_mandir}/man1/dmxtodmx.1x*
554 %{_mandir}/man1/vdltodmx.1x*
555 %{_mandir}/man1/xdmxconfig.1x*
556 %endif
557
558 %files -n xorg-xserver-Xnest
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xnest
561 %{_mandir}/man1/Xnest.1x*
562
563 %files -n xorg-xserver-Xephyr
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/Xephyr
566 %{_mandir}/man1/Xephyr.1x*
567
568 %files -n xorg-xserver-Xfbdev
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_bindir}/Xfbdev
571
572 %files -n xorg-xserver-Xvfb
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/Xvfb
575 %{_mandir}/man1/Xvfb.1x*
576
577 %files -n xorg-xserver-Xvfb-init
578 %defattr(644,root,root,755)
579 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
580 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
581
582 %files devel
583 %defattr(644,root,root,755)
584 %doc doc/xml/{Xserver-spec.html,xorg.css}
585 %{_includedir}/xorg
586 %{_libdir}/libxf86config.a
587 %{_aclocaldir}/xorg-server.m4
588 %{_pkgconfigdir}/xorg-server.pc
589
590 %files source
591 %defattr(-,root,root,755)
592 %{_usrsrc}/%{name}-%{version}
593
594 %files -n xorg-xserver-libdri
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
597
598 %files -n xorg-xserver-libglx
599 %defattr(644,root,root,755)
600 %if %{with multigl}
601 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
602 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
603 %else
604 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
605 %endif
This page took 0.078969 seconds and 4 git commands to generate.