]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.11.3
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
5 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
6 %bcond_with     hal             # HAL support for configuration (if no udev)
7 %bcond_without  udev            # UDEV support for configuration
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  dmx             # DMX support
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       6.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        11.0
20 %define xorg_xserver_server_xinput_abi          13.0
21 #
22 %define pixman_ver      0.24.0
23
24 %define         rel     1
25 Summary:        X.org server
26 Summary(pl.UTF-8):      Serwer X.org
27 Name:           xorg-xserver-server
28 Version:        1.11.3
29 Release:        %{rel}%{?with_multigl:.mgl}
30 License:        MIT
31 Group:          X11/Servers
32 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
33 # Source0-md5:  a7194c437963627e1db0dd2d6c1a1984
34 Source1:        10-quirks.conf
35 Source2:        xserver.pamd
36 Source10:       %{name}-Xvfb.init
37 Source11:       %{name}-Xvfb.sysconfig
38 Patch0:         %{name}-xwrapper.patch
39 Patch1:         %{name}-pic-libxf86config.patch
40 Patch2:         %{name}-fb-size.patch
41 Patch3:         %{name}-less-acpi-brokenness.patch
42 Patch4:         %{name}-builtin-SHA1.patch
43 Patch5:         %{name}-export-GetMaster.patch
44 Patch6:         110_nvidia_slowdow_fix.patch
45 Patch7:         %{name}-build.patch
46 URL:            http://xorg.freedesktop.org/
47 BuildRequires:  Mesa-libGL-devel >= 7.8.1
48 # for glx headers
49 BuildRequires:  OpenGL-GLX-devel
50 %{?with_xselinux:BuildRequires: audit-libs-devel}
51 BuildRequires:  autoconf >= 2.57
52 BuildRequires:  automake
53 BuildRequires:  cpp
54 BuildRequires:  docbook-dtd43-xml
55 #BuildRequires: doxygen >= 1.6.1
56 %if %{with hal} || %{with dbus}
57 BuildRequires:  dbus-devel >= 1.0
58 %endif
59 %{?with_hal:BuildRequires:      hal-devel}
60 BuildRequires:  libdrm-devel >= 2.4.5
61 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
62 BuildRequires:  libtool
63 BuildRequires:  ncurses-devel
64 BuildRequires:  pam-devel
65 BuildRequires:  perl-base
66 BuildRequires:  pixman-devel >= %{pixman_ver}
67 BuildRequires:  pkgconfig >= 1:0.19
68 BuildRequires:  udev-devel >= 1:143
69 BuildRequires:  xmlto >= 0.0.20
70 BuildRequires:  xorg-app-mkfontscale
71 BuildRequires:  xorg-font-font-util >= 1.1
72 BuildRequires:  xorg-lib-libX11-devel
73 BuildRequires:  xorg-lib-libXau-devel
74 BuildRequires:  xorg-lib-libXaw-devel
75 BuildRequires:  xorg-lib-libXdamage-devel
76 BuildRequires:  xorg-lib-libXdmcp-devel
77 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
78 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
79 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
80 BuildRequires:  xorg-lib-libXmu-devel
81 BuildRequires:  xorg-lib-libXpm-devel
82 BuildRequires:  xorg-lib-libXrender-devel
83 BuildRequires:  xorg-lib-libXres-devel
84 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
85 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
86 BuildRequires:  xorg-lib-libXv-devel
87 BuildRequires:  xorg-lib-libXxf86dga-devel
88 BuildRequires:  xorg-lib-libXxf86misc-devel
89 BuildRequires:  xorg-lib-libXxf86vm-devel
90 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
91 BuildRequires:  xorg-lib-libfontenc-devel
92 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
93 BuildRequires:  xorg-lib-libxkbfile-devel
94 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
95 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
96 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
97 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
98 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
99 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
100 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
101 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
102 BuildRequires:  xorg-proto-fontcacheproto-devel
103 BuildRequires:  xorg-proto-fontsproto-devel
104 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
105 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
106 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
107 BuildRequires:  xorg-proto-printproto-devel
108 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
109 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
110 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
111 BuildRequires:  xorg-proto-resourceproto-devel
112 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
113 BuildRequires:  xorg-proto-videoproto-devel
114 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
115 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
116 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
117 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
118 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
119 BuildRequires:  xorg-proto-xf86miscproto-devel
120 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
121 BuildRequires:  xorg-proto-xineramaproto-devel
122 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
123 BuildRequires:  xorg-sgml-doctools >= 1.8
124 BuildRequires:  xorg-util-util-macros >= 1.14
125 #BR: xcalibrateproto, tslib (for KDRIVE only)
126 Requires(triggerpostun):        sed >= 4.0
127 Requires:       pixman >= %{pixman_ver}
128 Requires:       xkeyboard-config
129 # for rgb.txt
130 Requires:       xorg-app-rgb >= 0.99.3
131 Requires:       xorg-app-xkbcomp
132 %{?with_hal:Suggests:   hal}
133 Suggests:       udev-acl >= 1:143
134 %{?with_udev:Suggests:  udev-core >= 1:143}
135 Suggests:       xorg-driver-input-evdev
136 # xserver requires fixed and cursor fonts
137 Requires:       xorg-font-font-alias
138 Requires:       xorg-font-font-cursor-misc
139 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
140 Suggests:       dbus-x11 >= 1.0
141 Suggests:       xkeyboard-config
142 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
143 Suggests:       xorg-driver-video
144 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
145 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
146 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
147 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
148 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
149 Obsoletes:      X11-Xserver < 1:7.0.0
150 Obsoletes:      X11-driver-i2c < 1:7.0.0
151 Obsoletes:      X11-modules < 1:7.0.0
152 Obsoletes:      X11-setup < 1:7.0.0
153 Obsoletes:      XFree86-Xserver < 1:7.0.0
154 Obsoletes:      XFree86-modules < 1:7.0.0
155 Obsoletes:      XFree86-setup < 1:7.0.0
156 Obsoletes:      Xserver
157 Obsoletes:      xorg-xserver-server-xorgcfg
158 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
159
160 # avoid self-dependencies on included modules
161 %define         _noautoreq      libscanpci.so libxf1bpp.so
162
163 %if %{with multigl}
164 # executable Xorg provides symbols this library:
165 %define         skip_post_check_so      libglx.so.*
166 %endif
167
168 %description
169 Xorg server is a generally used X server which uses display hardware.
170 It requires proper driver for your display hardware.
171
172 %description -l pl.UTF-8
173 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
174 graficznej. Do działania wymaga odpowiedniego sterownika.
175
176 %package -n xorg-xserver-Xdmx
177 Summary:        Xdmx - distributed multi-head X server
178 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
179 Group:          X11/Servers
180
181 %description -n xorg-xserver-Xdmx
182 Xdmx - distributed multi-head X server.
183
184 %description -n xorg-xserver-Xdmx -l pl.UTF-8
185 Xdmx - rozproszony, wielomonitorowy serwer X.
186
187 %package -n xorg-xserver-Xnest
188 Summary:        Xnest - nested X server
189 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
190 Group:          X11/Servers
191 Obsoletes:      X11-Xnest < 1:7.0.0
192 Obsoletes:      XFree86-Xnest < 1:7.0.0
193 Obsoletes:      Xserver-Xnest
194
195 %description -n xorg-xserver-Xnest
196 Xnest is an X Window System server which runs in an X window. Xnest is
197 a 'nested' window server, actually a client of the real X server,
198 which manages windows and graphics requests for Xnest, while Xnest
199 manages the windows and graphics requests for its own clients.
200
201 %description -n xorg-xserver-Xnest -l pl.UTF-8
202 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
203 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
204 serwer X dla własnych klientów.
205
206 %description -n xorg-xserver-Xnest -l ru.UTF-8
207 Xnest - это сервер X Window System, который работает в окне X. На
208 самом деле это клиент реального X-сервера, который управляет окнами и
209 графическими запросами для Xnest в то время, как Xnest управляет
210 окнами и графическими запросами для своих собственных клиентов.
211
212 %description -n xorg-xserver-Xnest -l uk.UTF-8
213 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
214 клієнт реального X-сервера, який керує вікнами та графічними запитами
215 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
216 своїх власних клієнтів.
217
218 %package -n xorg-xserver-Xephyr
219 Summary:        Xephyr - nested X server
220 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
221 Group:          X11/Servers
222 Requires:       pixman >= %{pixman_ver}
223
224 %description -n xorg-xserver-Xephyr
225 Xephyr is a a kdrive server that outputs to a window on a pre-existing
226 'host' X display. Think Xnest but with support for modern extensions
227 like composite, damage and randr.
228
229 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
230 the host X server, Xephyr is a real X server which uses the host X
231 server window as "framebuffer" via fast SHM XImages.
232
233 It also has support for 'visually' debugging what the server is
234 painting.
235
236 %description -n xorg-xserver-Xephyr -l pl.UTF-8
237 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
238 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
239 wspólczesnych rozszerzeń jak composite, damage i randr.
240
241 %package -n xorg-xserver-Xfbdev
242 Summary:        Xfbdev - Linux framebuffer device X server
243 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
244 Group:          X11/Servers
245
246 %description -n xorg-xserver-Xfbdev
247 Xfbdev is a Linux framebuffer device X server based on the kdrive X
248 server.
249
250 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
251 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
252
253 %package -n xorg-xserver-Xvfb
254 Summary:        Xvfb - virtual framebuffer X server
255 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
256 Group:          X11/Servers
257 # requires fixed and cursor fonts
258 Requires:       xorg-font-font-alias
259 Requires:       xorg-font-font-cursor-misc
260 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
261 Obsoletes:      X11-Xvfb < 1:7.0.0
262 Obsoletes:      XFree86-Xvfb < 1:7.0.0
263
264 %description -n xorg-xserver-Xvfb
265 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
266 capable of running on machines with no display hardware and no
267 physical input devices. Xvfb emulates a dumb framebuffer using virtual
268 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
269 display. Xvfb is normally used for testing servers. Using Xvfb, the
270 mfb or cfb code for any depth can be exercised without using real
271 hardware that supports the desired depths. Xvfb has also been used to
272 test X clients against unusual depths and screen configurations, to do
273 batch processing with Xvfb as a background rendering engine, to do
274 load testing, to help with porting an X server to a new platform, and
275 to provide an unobtrusive way of running applications which really
276 don't need an X server but insist on having one.
277
278 %description -n xorg-xserver-Xvfb -l pl.UTF-8
279 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
280 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
281 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
282 używany do testowania serwerów X, może też być używany do testowania
283 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
284 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
285 serwera X, ale odmawiają uruchomienia bez niego.
286
287 %package -n xorg-xserver-Xvfb-init
288 Summary:        Init scripts for Xvfb
289 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
290 Group:          X11/Servers
291 Requires:       xorg-xserver-Xvfb
292
293 %description -n xorg-xserver-Xvfb-init
294 This package contains init scripts for Xvfb and registers Xvfb as
295 system service.
296
297 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
298 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
299 usługę systemową.
300
301 %package devel
302 Summary:        Header files for X.org server
303 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
304 Group:          X11/Development/Libraries
305 Requires:       libdrm-devel >= 2.4.5
306 Requires:       pixman-devel >= %{pixman_ver}
307 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
308 Requires:       xorg-lib-libxkbfile-devel
309 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
310 Requires:       xorg-proto-fontsproto-devel
311 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
312 Requires:       xorg-proto-kbproto-devel >= 1.0.3
313 Requires:       xorg-proto-randrproto-devel >= 1.3
314 Requires:       xorg-proto-renderproto-devel >= 0.11
315 Requires:       xorg-proto-videoproto-devel
316 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
317 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
318 Requires:       xorg-proto-xineramaproto-devel
319 Requires:       xorg-proto-xproto-devel >= 7.0.22
320 Obsoletes:      X11-Xserver-devel < 1:7.0.0
321 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
322
323 %description devel
324 Header files for X.org server.
325
326 %description devel -l pl.UTF-8
327 Pliki nagłówkowe dla serwera X.org.
328
329 %package source
330 Summary:        X.org server source code
331 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
332 Group:          X11/Development/Libraries
333
334 %description source
335 X.org server source code.
336
337 %description source -l pl.UTF-8
338 Pliki źródłowe dla serwera X.org.
339
340 %package -n xorg-xserver-libdri
341 Summary:        DRI extension library for X.org server
342 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
343 Group:          X11/Servers
344 Requires:       %{name} = %{version}-%{release}
345 Provides:       xorg-xserver-module(dri)
346 %if %{without multigl}
347 Conflicts:      xorg-driver-video-fglrx
348 Conflicts:      xorg-driver-video-nvidia
349 %endif
350
351 %description -n xorg-xserver-libdri
352 DRI extension library for X.org server.
353
354 %description -n xorg-xserver-libdri -l pl.UTF-8
355 Biblioteka rozszerzenia DRI dla serwera X.org.
356
357 %package -n xorg-xserver-libglx
358 Summary:        GLX extension library for X.org server
359 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
360 Group:          X11/Servers
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       xorg-xserver-libdri = %{version}-%{release}
363 # Mesa version glapi tables in glx/ dir come from
364 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
365 Provides:       xorg-xserver-module(glx)
366 Obsoletes:      X11-OpenGL-core < 1:7.0.0
367 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
368 %if %{without multigl}
369 Conflicts:      xorg-driver-video-fglrx
370 Conflicts:      xorg-driver-video-nvidia
371 %endif
372
373 %description -n xorg-xserver-libglx
374 GLX extension library for X.org server.
375
376 %description -n xorg-xserver-libglx -l pl.UTF-8
377 Biblioteka rozszerzenia GLX dla serwera X.org.
378
379 %prep
380 %setup -q -n xorg-server-%{version}
381 %patch0 -p0
382 %patch1 -p1
383 %patch2 -p1
384 %patch3 -p1
385 %patch4 -p1
386 %patch5 -p1
387 %patch6 -p1
388 %patch7 -p1
389
390 # xserver uses pixman-1 API/ABI so put that explictly here
391 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
392
393 %build
394 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
395 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
396         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
397         exit 1
398 fi
399
400 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
401 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
402         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
403         exit 1
404 fi
405
406 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
407 if [ $API != %{xorg_xserver_server_font_abi} ]; then
408         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
409         exit 1
410 fi
411 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
412 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
413         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
414         exit 1
415 fi
416 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
417 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
418         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
419         exit 1
420 fi
421
422 %{__libtoolize}
423 %{__aclocal} -I m4
424 %{__autoconf}
425 %{__autoheader}
426 %{__automake}
427 %configure \
428         --with-os-name="PLD/Linux" \
429         --with-os-vendor="PLD/Team" \
430         --without-fop \
431         %{?with_dbus:--enable-config-dbus} \
432         --enable-config-hal%{!?with_hal:=no} \
433         --enable-config-udev%{!?with_udev:=no} \
434         --enable-aiglx \
435         --enable-dga \
436         %{?with_dmx:--enable-dmx} \
437         --enable-glx-tls \
438         --enable-install-libxf86config \
439         %{?with_record:--enable-record} \
440         --enable-kdrive \
441         %{?with_xcsecurity:--enable-xcsecurity} \
442         --enable-xephyr \
443         %{?with_xf86bigfont:--enable-xf86bigfont} \
444         --enable-xfbdev \
445         %{?with_xselinux:--enable-xselinux} \
446         --enable-glx-tls \
447         --disable-xfake \
448         --enable-secure-rpc \
449         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
450         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
451         --with-xkb-output=/var/lib/xkb
452
453 %{__make}
454
455 %install
456 rm -rf $RPM_BUILD_ROOT
457
458 %{__make} install \
459         DESTDIR=$RPM_BUILD_ROOT
460
461 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
462 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
463 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
464 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
465
466 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
467 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
468
469 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
470
471 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
472
473 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
474 install -d $RPM_BUILD_ROOT/etc/sysconfig
475 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
476 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
477
478 %if %{with multigl}
479 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
480 mv -f libglx.so libglx.so.%{version}
481 ln -sf libglx.so.%{version} libglx.so
482 cd -
483 %endif
484
485 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
486 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
487 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
488 %{__make} distclean
489 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
490 find -name '*.h' | xargs chmod a-x
491
492 %clean
493 rm -rf $RPM_BUILD_ROOT
494
495 %if %{with multigl}
496 %post -n xorg-xserver-libglx
497 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
498         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
499 fi
500 %endif
501
502 %triggerpostun -- xorg-xserver-server < 1.5.0
503 if [ -f /etc/X11/xorg.conf ]; then
504         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
505         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
506 %if %{without record}
507         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
508 %endif
509         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
510 fi
511
512 %post -n xorg-xserver-Xvfb-init
513 /sbin/chkconfig --add Xvfb
514 %service Xvfb restart
515
516 %preun -n xorg-xserver-Xvfb-init
517 if [ "$1" = "0" ]; then
518         %service -q Xvfb stop
519         /sbin/chkconfig --del Xvfb
520 fi
521
522 %files
523 %defattr(644,root,root,755)
524 %doc COPYING ChangeLog README
525 %attr(755,root,root) %{_bindir}/X
526 %attr(755,root,root) %{_bindir}/Xorg
527 %attr(4755,root,root) %{_bindir}/Xwrapper
528 %attr(755,root,root) %{_bindir}/cvt
529 %attr(755,root,root) %{_bindir}/gtf
530 %dir %{_libdir}/xorg
531 %{_libdir}/xorg/protocol.txt
532 %dir %{_libdir}/xorg/modules
533 %dir %{_libdir}/xorg/modules/dri
534 %dir %{_libdir}/xorg/modules/drivers
535 %dir %{_libdir}/xorg/modules/extensions
536 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
537 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
538 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
539 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
540 %dir %{_libdir}/xorg/modules/input
541 %dir %{_libdir}/xorg/modules/multimedia
542 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
543 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
544 %dir /var/lib/xkb
545 /var/lib/xkb/README.compiled
546 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
548 %config(missingok) /etc/security/console.apps/xserver
549 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
550 %dir /etc/X11/xorg.conf.d
551 %dir %{_datadir}/X11/xorg.conf.d
552 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
553 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
554 %{_mandir}/man1/Xorg.1x*
555 %{_mandir}/man1/Xserver.1x*
556 %{_mandir}/man1/cvt.1*
557 %{_mandir}/man1/gtf.1x*
558 %{_mandir}/man4/exa.4*
559 %{_mandir}/man4/fbdevhw.4*
560 %{_mandir}/man5/xorg.conf.5x*
561 %{_mandir}/man5/xorg.conf.d.5x
562
563 %if %{with dmx}
564 %files -n xorg-xserver-Xdmx
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_bindir}/Xdmx
567 %attr(755,root,root) %{_bindir}/dmxaddinput
568 %attr(755,root,root) %{_bindir}/dmxaddscreen
569 %attr(755,root,root) %{_bindir}/dmxinfo
570 %attr(755,root,root) %{_bindir}/dmxreconfig
571 %attr(755,root,root) %{_bindir}/dmxresize
572 %attr(755,root,root) %{_bindir}/dmxrminput
573 %attr(755,root,root) %{_bindir}/dmxrmscreen
574 %attr(755,root,root) %{_bindir}/dmxtodmx
575 %attr(755,root,root) %{_bindir}/dmxwininfo
576 %attr(755,root,root) %{_bindir}/vdltodmx
577 %attr(755,root,root) %{_bindir}/xdmxconfig
578 %{_mandir}/man1/Xdmx.1x*
579 %{_mandir}/man1/dmxtodmx.1x*
580 %{_mandir}/man1/vdltodmx.1x*
581 %{_mandir}/man1/xdmxconfig.1x*
582 %endif
583
584 %files -n xorg-xserver-Xnest
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_bindir}/Xnest
587 %{_mandir}/man1/Xnest.1x*
588
589 %files -n xorg-xserver-Xephyr
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_bindir}/Xephyr
592 %{_mandir}/man1/Xephyr.1x*
593
594 %files -n xorg-xserver-Xfbdev
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/Xfbdev
597
598 %files -n xorg-xserver-Xvfb
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_bindir}/Xvfb
601 %{_mandir}/man1/Xvfb.1x*
602
603 %files -n xorg-xserver-Xvfb-init
604 %defattr(644,root,root,755)
605 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
606 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
607
608 %files devel
609 %defattr(644,root,root,755)
610 %doc doc/{Xinput,Xserver-spec}.html
611 %{_includedir}/xorg
612 %{_libdir}/libxf86config.a
613 %{_libdir}/libxf86config.la
614 %{_aclocaldir}/xorg-server.m4
615 %{_pkgconfigdir}/xorg-server.pc
616
617 %files source
618 %defattr(644,root,root,755)
619 # keep file perms from install time, but have default defattr to keep adapter happy
620 %defattr(-,root,root,755)
621 %{_usrsrc}/%{name}-%{version}
622
623 %files -n xorg-xserver-libdri
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
626
627 %files -n xorg-xserver-libglx
628 %defattr(644,root,root,755)
629 %if %{with multigl}
630 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
631 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
632 %else
633 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
634 %endif
This page took 0.969539 seconds and 4 git commands to generate.