]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- rel 2
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dri2            # DRI2 extension
8 %bcond_without  dmx             # DMX support
9 %bcond_without  record          # RECORD extension
10 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
11 %bcond_with     xf86bigfont     # XF86BigFont extension
12 %bcond_with     xselinux        # SELinux extension
13 #
14 # ABI versions, see hw/xfree86/common/xf86Module.h
15 %define xorg_xserver_server_ansic_abi           0.4
16 %define xorg_xserver_server_extension_abi       6.0
17 %define xorg_xserver_server_font_abi            0.6
18 %define xorg_xserver_server_videodrv_abi        11.0
19 %define xorg_xserver_server_xinput_abi          13.0
20 #
21 %define pixman_ver      0.24.0
22
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.11.4
27 Release:        2
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  256325e9b17dff479d92bed97f6b0adb
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38 Patch2:         %{name}-fb-size.patch
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 Patch5:         %{name}-export-GetMaster.patch
42 Patch6:         110_nvidia_slowdow_fix.patch
43 URL:            http://xorg.freedesktop.org/
44 BuildRequires:  Mesa-libGL-devel >= 7.8.1
45 # for glx headers
46 BuildRequires:  OpenGL-GLX-devel
47 %{?with_xselinux:BuildRequires: audit-libs-devel}
48 BuildRequires:  autoconf >= 2.57
49 BuildRequires:  automake
50 BuildRequires:  cpp
51 BuildRequires:  docbook-dtd43-xml
52 #BuildRequires: doxygen >= 1.6.1
53 %if %{with hal} || %{with dbus}
54 BuildRequires:  dbus-devel >= 1.0
55 %endif
56 %{?with_hal:BuildRequires:      hal-devel}
57 BuildRequires:  libdrm-devel >= 2.4.5
58 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
59 BuildRequires:  libtool
60 BuildRequires:  ncurses-devel
61 BuildRequires:  pam-devel
62 BuildRequires:  perl-base
63 BuildRequires:  pixman-devel >= %{pixman_ver}
64 BuildRequires:  pkgconfig >= 1:0.19
65 BuildRequires:  udev-devel >= 1:143
66 BuildRequires:  xmlto >= 0.0.20
67 BuildRequires:  xorg-app-mkfontscale
68 BuildRequires:  xorg-font-font-util >= 1.1
69 BuildRequires:  xorg-lib-libX11-devel
70 BuildRequires:  xorg-lib-libXau-devel
71 BuildRequires:  xorg-lib-libXaw-devel
72 BuildRequires:  xorg-lib-libXdamage-devel
73 BuildRequires:  xorg-lib-libXdmcp-devel
74 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
75 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
76 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
77 BuildRequires:  xorg-lib-libXmu-devel
78 BuildRequires:  xorg-lib-libXpm-devel
79 BuildRequires:  xorg-lib-libXrender-devel
80 BuildRequires:  xorg-lib-libXres-devel
81 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
82 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
83 BuildRequires:  xorg-lib-libXv-devel
84 BuildRequires:  xorg-lib-libXxf86dga-devel
85 BuildRequires:  xorg-lib-libXxf86misc-devel
86 BuildRequires:  xorg-lib-libXxf86vm-devel
87 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
88 BuildRequires:  xorg-lib-libfontenc-devel
89 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
90 BuildRequires:  xorg-lib-libxkbfile-devel
91 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
92 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
93 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
94 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
95 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
96 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
97 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
98 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
99 BuildRequires:  xorg-proto-fontcacheproto-devel
100 BuildRequires:  xorg-proto-fontsproto-devel
101 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
102 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
103 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
104 BuildRequires:  xorg-proto-printproto-devel
105 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
106 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
107 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
108 BuildRequires:  xorg-proto-resourceproto-devel
109 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
110 BuildRequires:  xorg-proto-videoproto-devel
111 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
112 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
113 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
114 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
115 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
116 BuildRequires:  xorg-proto-xf86miscproto-devel
117 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
118 BuildRequires:  xorg-proto-xineramaproto-devel
119 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
120 BuildRequires:  xorg-sgml-doctools >= 1.8
121 BuildRequires:  xorg-util-util-macros >= 1.14
122 #BR: xcalibrateproto, tslib (for KDRIVE only)
123 Requires(triggerpostun):        sed >= 4.0
124 Requires:       pixman >= %{pixman_ver}
125 Requires:       xkeyboard-config
126 # for rgb.txt
127 Requires:       xorg-app-rgb >= 0.99.3
128 Requires:       xorg-app-xkbcomp
129 %{?with_hal:Suggests:   hal}
130 Suggests:       udev-acl >= 1:143
131 %{?with_udev:Suggests:  udev-core >= 1:143}
132 Suggests:       xorg-driver-input-evdev
133 # xserver requires fixed and cursor fonts
134 Requires:       xorg-font-font-alias
135 Requires:       xorg-font-font-cursor-misc
136 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
137 Suggests:       dbus-x11 >= 1.0
138 Suggests:       xkeyboard-config
139 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
140 Suggests:       xorg-driver-video
141 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
142 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
143 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
144 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
145 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
146 Obsoletes:      X11-Xserver < 1:7.0.0
147 Obsoletes:      X11-driver-i2c < 1:7.0.0
148 Obsoletes:      X11-modules < 1:7.0.0
149 Obsoletes:      X11-setup < 1:7.0.0
150 Obsoletes:      XFree86-Xserver < 1:7.0.0
151 Obsoletes:      XFree86-modules < 1:7.0.0
152 Obsoletes:      XFree86-setup < 1:7.0.0
153 Obsoletes:      Xserver
154 Obsoletes:      xorg-xserver-server-xorgcfg
155 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
156
157 # avoid self-dependencies on included modules
158 %define         _noautoreq      libscanpci.so libxf1bpp.so
159
160 %description
161 Xorg server is a generally used X server which uses display hardware.
162 It requires proper driver for your display hardware.
163
164 %description -l pl.UTF-8
165 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
166 graficznej. Do działania wymaga odpowiedniego sterownika.
167
168 %package -n xorg-xserver-Xdmx
169 Summary:        Xdmx - distributed multi-head X server
170 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
171 Group:          X11/Servers
172
173 %description -n xorg-xserver-Xdmx
174 Xdmx - distributed multi-head X server.
175
176 %description -n xorg-xserver-Xdmx -l pl.UTF-8
177 Xdmx - rozproszony, wielomonitorowy serwer X.
178
179 %package -n xorg-xserver-Xnest
180 Summary:        Xnest - nested X server
181 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
182 Group:          X11/Servers
183 Obsoletes:      X11-Xnest < 1:7.0.0
184 Obsoletes:      XFree86-Xnest < 1:7.0.0
185 Obsoletes:      Xserver-Xnest
186
187 %description -n xorg-xserver-Xnest
188 Xnest is an X Window System server which runs in an X window. Xnest is
189 a 'nested' window server, actually a client of the real X server,
190 which manages windows and graphics requests for Xnest, while Xnest
191 manages the windows and graphics requests for its own clients.
192
193 %description -n xorg-xserver-Xnest -l pl.UTF-8
194 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
195 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
196 serwer X dla własnych klientów.
197
198 %description -n xorg-xserver-Xnest -l ru.UTF-8
199 Xnest - это сервер X Window System, который работает в окне X. На
200 самом деле это клиент реального X-сервера, который управляет окнами и
201 графическими запросами для Xnest в то время, как Xnest управляет
202 окнами и графическими запросами для своих собственных клиентов.
203
204 %description -n xorg-xserver-Xnest -l uk.UTF-8
205 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
206 клієнт реального X-сервера, який керує вікнами та графічними запитами
207 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
208 своїх власних клієнтів.
209
210 %package -n xorg-xserver-Xephyr
211 Summary:        Xephyr - nested X server
212 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
213 Group:          X11/Servers
214 Requires:       pixman >= %{pixman_ver}
215
216 %description -n xorg-xserver-Xephyr
217 Xephyr is a a kdrive server that outputs to a window on a pre-existing
218 'host' X display. Think Xnest but with support for modern extensions
219 like composite, damage and randr.
220
221 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
222 the host X server, Xephyr is a real X server which uses the host X
223 server window as "framebuffer" via fast SHM XImages.
224
225 It also has support for 'visually' debugging what the server is
226 painting.
227
228 %description -n xorg-xserver-Xephyr -l pl.UTF-8
229 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
230 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
231 wspólczesnych rozszerzeń jak composite, damage i randr.
232
233 %package -n xorg-xserver-Xfbdev
234 Summary:        Xfbdev - Linux framebuffer device X server
235 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
236 Group:          X11/Servers
237
238 %description -n xorg-xserver-Xfbdev
239 Xfbdev is a Linux framebuffer device X server based on the kdrive X
240 server.
241
242 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
243 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
244
245 %package -n xorg-xserver-Xvfb
246 Summary:        Xvfb - virtual framebuffer X server
247 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
248 Group:          X11/Servers
249 # requires fixed and cursor fonts
250 Requires:       xorg-font-font-alias
251 Requires:       xorg-font-font-cursor-misc
252 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
253 Obsoletes:      X11-Xvfb < 1:7.0.0
254 Obsoletes:      XFree86-Xvfb < 1:7.0.0
255
256 %description -n xorg-xserver-Xvfb
257 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
258 capable of running on machines with no display hardware and no
259 physical input devices. Xvfb emulates a dumb framebuffer using virtual
260 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
261 display. Xvfb is normally used for testing servers. Using Xvfb, the
262 mfb or cfb code for any depth can be exercised without using real
263 hardware that supports the desired depths. Xvfb has also been used to
264 test X clients against unusual depths and screen configurations, to do
265 batch processing with Xvfb as a background rendering engine, to do
266 load testing, to help with porting an X server to a new platform, and
267 to provide an unobtrusive way of running applications which really
268 don't need an X server but insist on having one.
269
270 %description -n xorg-xserver-Xvfb -l pl.UTF-8
271 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
272 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
273 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
274 używany do testowania serwerów X, może też być używany do testowania
275 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
276 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
277 serwera X, ale odmawiają uruchomienia bez niego.
278
279 %package -n xorg-xserver-Xvfb-init
280 Summary:        Init scripts for Xvfb
281 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
282 Group:          X11/Servers
283 Requires:       xorg-xserver-Xvfb
284
285 %description -n xorg-xserver-Xvfb-init
286 This package contains init scripts for Xvfb and registers Xvfb as
287 system service.
288
289 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
290 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
291 usługę systemową.
292
293 %package devel
294 Summary:        Header files for X.org server
295 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
296 Group:          X11/Development/Libraries
297 Requires:       libdrm-devel >= 2.4.5
298 Requires:       pixman-devel >= %{pixman_ver}
299 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
300 Requires:       xorg-lib-libxkbfile-devel
301 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
302 Requires:       xorg-proto-fontsproto-devel
303 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
304 Requires:       xorg-proto-kbproto-devel >= 1.0.3
305 Requires:       xorg-proto-randrproto-devel >= 1.3
306 Requires:       xorg-proto-renderproto-devel >= 0.11
307 Requires:       xorg-proto-videoproto-devel
308 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
309 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
310 Requires:       xorg-proto-xineramaproto-devel
311 Requires:       xorg-proto-xproto-devel >= 7.0.22
312 Obsoletes:      X11-Xserver-devel < 1:7.0.0
313 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
314
315 %description devel
316 Header files for X.org server.
317
318 %description devel -l pl.UTF-8
319 Pliki nagłówkowe dla serwera X.org.
320
321 %package source
322 Summary:        X.org server source code
323 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
324 Group:          X11/Development/Libraries
325
326 %description source
327 X.org server source code.
328
329 %description source -l pl.UTF-8
330 Pliki źródłowe dla serwera X.org.
331
332 %package -n xorg-xserver-libdri
333 Summary:        DRI extension library for X.org server
334 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
335 Group:          X11/Servers
336 Requires:       %{name} = %{version}-%{release}
337 Provides:       xorg-xserver-module(dri)
338
339 %description -n xorg-xserver-libdri
340 DRI extension library for X.org server.
341
342 %description -n xorg-xserver-libdri -l pl.UTF-8
343 Biblioteka rozszerzenia DRI dla serwera X.org.
344
345 %package -n xorg-xserver-libglx
346 Summary:        GLX extension library for X.org server
347 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
348 Group:          X11/Servers
349 Requires:       %{name} = %{version}-%{release}
350 Requires:       xorg-xserver-libdri = %{version}-%{release}
351 # Mesa version glapi tables in glx/ dir come from
352 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
353 Provides:       xorg-xserver-module(glx)
354 Obsoletes:      X11-OpenGL-core < 1:7.0.0
355 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
356
357 %description -n xorg-xserver-libglx
358 GLX extension library for X.org server.
359
360 %description -n xorg-xserver-libglx -l pl.UTF-8
361 Biblioteka rozszerzenia GLX dla serwera X.org.
362
363 %prep
364 %setup -q -n xorg-server-%{version}
365 %patch0 -p0
366 %patch1 -p1
367 %patch2 -p1
368 %patch3 -p1
369 %patch4 -p1
370 %patch5 -p1
371 %patch6 -p1
372
373 # xserver uses pixman-1 API/ABI so put that explictly here
374 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
375
376 %build
377 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
378 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
379         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
380         exit 1
381 fi
382
383 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
384 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
385         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
386         exit 1
387 fi
388
389 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
390 if [ $API != %{xorg_xserver_server_font_abi} ]; then
391         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
392         exit 1
393 fi
394 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
395 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
396         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
397         exit 1
398 fi
399 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
400 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
401         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
402         exit 1
403 fi
404
405 %{__libtoolize}
406 %{__aclocal} -I m4
407 %{__autoconf}
408 %{__autoheader}
409 %{__automake}
410 %configure \
411         --with-os-name="PLD/Linux" \
412         --with-os-vendor="PLD/Team" \
413         --without-fop \
414         %{?with_dbus:--enable-config-dbus} \
415         --enable-config-hal%{!?with_hal:=no} \
416         --enable-config-udev%{!?with_udev:=no} \
417         --enable-aiglx \
418         --enable-dga \
419         %{?with_dmx:--enable-dmx} \
420         --enable-glx-tls \
421         --enable-install-libxf86config \
422         %{?with_record:--enable-record} \
423         --enable-kdrive \
424         %{?with_xcsecurity:--enable-xcsecurity} \
425         --enable-xephyr \
426         %{?with_xf86bigfont:--enable-xf86bigfont} \
427         --enable-xfbdev \
428         %{?with_xselinux:--enable-xselinux} \
429         --enable-glx-tls \
430         --disable-xfake \
431         --enable-secure-rpc \
432         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
433         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
434         --with-xkb-output=/var/lib/xkb
435
436 %{__make}
437
438 %install
439 rm -rf $RPM_BUILD_ROOT
440
441 %{__make} install \
442         DESTDIR=$RPM_BUILD_ROOT
443
444 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
445 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
446 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
447 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
448
449 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
450 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
451
452 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
453
454 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
455
456 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
457 install -d $RPM_BUILD_ROOT/etc/sysconfig
458 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
459 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
460
461 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
462 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
463 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
464 %{__make} distclean
465 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
466 find -name '*.h' | xargs chmod a-x
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %triggerpostun -- xorg-xserver-server < 1.5.0
472 if [ -f /etc/X11/xorg.conf ]; then
473         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
474         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
475 %if %{without record}
476         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
477 %endif
478         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
479 fi
480
481 %post -n xorg-xserver-Xvfb-init
482 /sbin/chkconfig --add Xvfb
483 %service Xvfb restart
484
485 %preun -n xorg-xserver-Xvfb-init
486 if [ "$1" = "0" ]; then
487         %service -q Xvfb stop
488         /sbin/chkconfig --del Xvfb
489 fi
490
491 %files
492 %defattr(644,root,root,755)
493 %doc COPYING ChangeLog README
494 %attr(755,root,root) %{_bindir}/X
495 %attr(755,root,root) %{_bindir}/Xorg
496 %attr(4755,root,root) %{_bindir}/Xwrapper
497 %attr(755,root,root) %{_bindir}/cvt
498 %attr(755,root,root) %{_bindir}/gtf
499 %dir %{_libdir}/xorg
500 %{_libdir}/xorg/protocol.txt
501 %dir %{_libdir}/xorg/modules
502 %dir %{_libdir}/xorg/modules/dri
503 %dir %{_libdir}/xorg/modules/drivers
504 %dir %{_libdir}/xorg/modules/extensions
505 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
506 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
507 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
508 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
509 %dir %{_libdir}/xorg/modules/input
510 %dir %{_libdir}/xorg/modules/multimedia
511 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
512 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
513 %dir /var/lib/xkb
514 /var/lib/xkb/README.compiled
515 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
516 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
517 %config(missingok) /etc/security/console.apps/xserver
518 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
519 %dir /etc/X11/xorg.conf.d
520 %dir %{_datadir}/X11/xorg.conf.d
521 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
522 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
523 %{_mandir}/man1/Xorg.1x*
524 %{_mandir}/man1/Xserver.1x*
525 %{_mandir}/man1/cvt.1*
526 %{_mandir}/man1/gtf.1x*
527 %{_mandir}/man4/exa.4*
528 %{_mandir}/man4/fbdevhw.4*
529 %{_mandir}/man5/xorg.conf.5x*
530 %{_mandir}/man5/xorg.conf.d.5x
531
532 %if %{with dmx}
533 %files -n xorg-xserver-Xdmx
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/Xdmx
536 %attr(755,root,root) %{_bindir}/dmxaddinput
537 %attr(755,root,root) %{_bindir}/dmxaddscreen
538 %attr(755,root,root) %{_bindir}/dmxinfo
539 %attr(755,root,root) %{_bindir}/dmxreconfig
540 %attr(755,root,root) %{_bindir}/dmxresize
541 %attr(755,root,root) %{_bindir}/dmxrminput
542 %attr(755,root,root) %{_bindir}/dmxrmscreen
543 %attr(755,root,root) %{_bindir}/dmxtodmx
544 %attr(755,root,root) %{_bindir}/dmxwininfo
545 %attr(755,root,root) %{_bindir}/vdltodmx
546 %attr(755,root,root) %{_bindir}/xdmxconfig
547 %{_mandir}/man1/Xdmx.1x*
548 %{_mandir}/man1/dmxtodmx.1x*
549 %{_mandir}/man1/vdltodmx.1x*
550 %{_mandir}/man1/xdmxconfig.1x*
551 %endif
552
553 %files -n xorg-xserver-Xnest
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/Xnest
556 %{_mandir}/man1/Xnest.1x*
557
558 %files -n xorg-xserver-Xephyr
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xephyr
561 %{_mandir}/man1/Xephyr.1x*
562
563 %files -n xorg-xserver-Xfbdev
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/Xfbdev
566
567 %files -n xorg-xserver-Xvfb
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/Xvfb
570 %{_mandir}/man1/Xvfb.1x*
571
572 %files -n xorg-xserver-Xvfb-init
573 %defattr(644,root,root,755)
574 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
575 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
576
577 %files devel
578 %defattr(644,root,root,755)
579 %doc doc/{Xinput,Xserver-spec}.html
580 %{_includedir}/xorg
581 %{_libdir}/libxf86config.a
582 %{_libdir}/libxf86config.la
583 %{_aclocaldir}/xorg-server.m4
584 %{_pkgconfigdir}/xorg-server.pc
585
586 %files source
587 %defattr(644,root,root,755)
588 # keep file perms from install time, but have default defattr to keep adapter happy
589 %defattr(-,root,root,755)
590 %{_usrsrc}/%{name}-%{version}
591
592 %files -n xorg-xserver-libdri
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
595
596 %files -n xorg-xserver-libglx
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.104295 seconds and 4 git commands to generate.