]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- rel 2
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
5 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
6 %bcond_with     hal             # HAL support for configuration (if no udev)
7 %bcond_without  udev            # UDEV support for configuration
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  dmx             # DMX support
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       6.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        11.0
20 %define xorg_xserver_server_xinput_abi          13.0
21
22 %define         rel     2
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.11.1.902
27 Release:        %{rel}%{?with_multigl:.mgl}
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  87dd7958ace0509f6e4da2908c2ee4fd
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38 Patch2:         %{name}-fb-size.patch
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 Patch5:         %{name}-export-GetMaster.patch
42 URL:            http://xorg.freedesktop.org/
43 BuildRequires:  Mesa-libGL-devel >= 7.8.1
44 # for glx headers
45 BuildRequires:  OpenGL-GLX-devel
46 %{?with_xselinux:BuildRequires: audit-libs-devel}
47 BuildRequires:  autoconf >= 2.57
48 BuildRequires:  automake
49 BuildRequires:  cpp
50 BuildRequires:  docbook-dtd43-xml
51 #BuildRequires: doxygen >= 1.6.1
52 %if %{with hal} || %{with dbus}
53 BuildRequires:  dbus-devel >= 1.0
54 %endif
55 %{?with_hal:BuildRequires:      hal-devel}
56 BuildRequires:  libdrm-devel >= 2.4.5
57 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
58 BuildRequires:  libtool
59 BuildRequires:  ncurses-devel
60 BuildRequires:  pam-devel
61 BuildRequires:  perl-base
62 BuildRequires:  pixman-devel >= 0.22.0
63 BuildRequires:  pkgconfig >= 1:0.19
64 BuildRequires:  udev-devel >= 1:143
65 BuildRequires:  xmlto >= 0.0.20
66 BuildRequires:  xorg-app-mkfontscale
67 BuildRequires:  xorg-font-font-util >= 1.1
68 BuildRequires:  xorg-lib-libX11-devel
69 BuildRequires:  xorg-lib-libXau-devel
70 BuildRequires:  xorg-lib-libXaw-devel
71 BuildRequires:  xorg-lib-libXdamage-devel
72 BuildRequires:  xorg-lib-libXdmcp-devel
73 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
74 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
75 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
76 BuildRequires:  xorg-lib-libXmu-devel
77 BuildRequires:  xorg-lib-libXpm-devel
78 BuildRequires:  xorg-lib-libXrender-devel
79 BuildRequires:  xorg-lib-libXres-devel
80 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
81 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
82 BuildRequires:  xorg-lib-libXv-devel
83 BuildRequires:  xorg-lib-libXxf86dga-devel
84 BuildRequires:  xorg-lib-libXxf86misc-devel
85 BuildRequires:  xorg-lib-libXxf86vm-devel
86 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
87 BuildRequires:  xorg-lib-libfontenc-devel
88 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
89 BuildRequires:  xorg-lib-libxkbfile-devel
90 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
91 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
92 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
93 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
94 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
95 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
96 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
97 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
98 BuildRequires:  xorg-proto-fontcacheproto-devel
99 BuildRequires:  xorg-proto-fontsproto-devel
100 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
101 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
102 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
103 BuildRequires:  xorg-proto-printproto-devel
104 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
105 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
106 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
107 BuildRequires:  xorg-proto-resourceproto-devel
108 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
109 BuildRequires:  xorg-proto-videoproto-devel
110 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
111 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
112 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
113 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
114 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
115 BuildRequires:  xorg-proto-xf86miscproto-devel
116 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
117 BuildRequires:  xorg-proto-xineramaproto-devel
118 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
119 BuildRequires:  xorg-sgml-doctools >= 1.8
120 BuildRequires:  xorg-util-util-macros >= 1.14
121 #BR: xcalibrateproto, tslib (for KDRIVE only)
122 Requires(triggerpostun):        sed >= 4.0
123 Requires:       pixman >= 0.22.0
124 Requires:       xkeyboard-config
125 # for rgb.txt
126 Requires:       xorg-app-rgb >= 0.99.3
127 Requires:       xorg-app-xkbcomp
128 %{?with_hal:Suggests:   hal}
129 Suggests:       udev-acl >= 1:143
130 %{?with_udev:Suggests:  udev-core >= 1:143}
131 Suggests:       xorg-driver-input-evdev
132 # xserver requires fixed and cursor fonts
133 Requires:       xorg-font-font-alias
134 Requires:       xorg-font-font-cursor-misc
135 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
136 Suggests:       dbus-x11 >= 1.0
137 Suggests:       xkeyboard-config
138 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
139 Suggests:       xorg-driver-video
140 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
141 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
142 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
143 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
144 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
145 Obsoletes:      X11-Xserver < 1:7.0.0
146 Obsoletes:      X11-driver-i2c < 1:7.0.0
147 Obsoletes:      X11-modules < 1:7.0.0
148 Obsoletes:      X11-setup < 1:7.0.0
149 Obsoletes:      XFree86-Xserver < 1:7.0.0
150 Obsoletes:      XFree86-modules < 1:7.0.0
151 Obsoletes:      XFree86-setup < 1:7.0.0
152 Obsoletes:      Xserver
153 Obsoletes:      xorg-xserver-server-xorgcfg
154 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
155
156 # avoid self-dependencies on included modules
157 %define         _noautoreq      libscanpci.so libxf1bpp.so
158
159 %if %{with multigl}
160 # executable Xorg provides symbols this library:
161 %define         skip_post_check_so      libglx.so.*
162 %endif
163
164 %description
165 Xorg server is a generally used X server which uses display hardware.
166 It requires proper driver for your display hardware.
167
168 %description -l pl.UTF-8
169 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
170 graficznej. Do działania wymaga odpowiedniego sterownika.
171
172 %package -n xorg-xserver-Xdmx
173 Summary:        Xdmx - distributed multi-head X server
174 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
175 Group:          X11/Servers
176
177 %description -n xorg-xserver-Xdmx
178 Xdmx - distributed multi-head X server.
179
180 %description -n xorg-xserver-Xdmx -l pl.UTF-8
181 Xdmx - rozproszony, wielomonitorowy serwer X.
182
183 %package -n xorg-xserver-Xnest
184 Summary:        Xnest - nested X server
185 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
186 Group:          X11/Servers
187 Obsoletes:      X11-Xnest < 1:7.0.0
188 Obsoletes:      XFree86-Xnest < 1:7.0.0
189 Obsoletes:      Xserver-Xnest
190
191 %description -n xorg-xserver-Xnest
192 Xnest is an X Window System server which runs in an X window. Xnest is
193 a 'nested' window server, actually a client of the real X server,
194 which manages windows and graphics requests for Xnest, while Xnest
195 manages the windows and graphics requests for its own clients.
196
197 %description -n xorg-xserver-Xnest -l pl.UTF-8
198 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
199 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
200 serwer X dla własnych klientów.
201
202 %description -n xorg-xserver-Xnest -l ru.UTF-8
203 Xnest - это сервер X Window System, который работает в окне X. На
204 самом деле это клиент реального X-сервера, который управляет окнами и
205 графическими запросами для Xnest в то время, как Xnest управляет
206 окнами и графическими запросами для своих собственных клиентов.
207
208 %description -n xorg-xserver-Xnest -l uk.UTF-8
209 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
210 клієнт реального X-сервера, який керує вікнами та графічними запитами
211 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
212 своїх власних клієнтів.
213
214 %package -n xorg-xserver-Xephyr
215 Summary:        Xephyr - nested X server
216 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
217 Group:          X11/Servers
218 Requires:       pixman >= 0.22.0
219
220 %description -n xorg-xserver-Xephyr
221 Xephyr is a a kdrive server that outputs to a window on a pre-existing
222 'host' X display. Think Xnest but with support for modern extensions
223 like composite, damage and randr.
224
225 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
226 the host X server, Xephyr is a real X server which uses the host X
227 server window as "framebuffer" via fast SHM XImages.
228
229 It also has support for 'visually' debugging what the server is
230 painting.
231
232 %description -n xorg-xserver-Xephyr -l pl.UTF-8
233 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
234 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
235 wspólczesnych rozszerzeń jak composite, damage i randr.
236
237 %package -n xorg-xserver-Xfbdev
238 Summary:        Xfbdev - Linux framebuffer device X server
239 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
240 Group:          X11/Servers
241
242 %description -n xorg-xserver-Xfbdev
243 Xfbdev is a Linux framebuffer device X server based on the kdrive X
244 server.
245
246 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
247 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
248
249 %package -n xorg-xserver-Xvfb
250 Summary:        Xvfb - virtual framebuffer X server
251 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
252 Group:          X11/Servers
253 # requires fixed and cursor fonts
254 Requires:       xorg-font-font-alias
255 Requires:       xorg-font-font-cursor-misc
256 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
257 Obsoletes:      X11-Xvfb < 1:7.0.0
258 Obsoletes:      XFree86-Xvfb < 1:7.0.0
259
260 %description -n xorg-xserver-Xvfb
261 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
262 capable of running on machines with no display hardware and no
263 physical input devices. Xvfb emulates a dumb framebuffer using virtual
264 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
265 display. Xvfb is normally used for testing servers. Using Xvfb, the
266 mfb or cfb code for any depth can be exercised without using real
267 hardware that supports the desired depths. Xvfb has also been used to
268 test X clients against unusual depths and screen configurations, to do
269 batch processing with Xvfb as a background rendering engine, to do
270 load testing, to help with porting an X server to a new platform, and
271 to provide an unobtrusive way of running applications which really
272 don't need an X server but insist on having one.
273
274 %description -n xorg-xserver-Xvfb -l pl.UTF-8
275 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
276 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
277 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
278 używany do testowania serwerów X, może też być używany do testowania
279 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
280 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
281 serwera X, ale odmawiają uruchomienia bez niego.
282
283 %package -n xorg-xserver-Xvfb-init
284 Summary:        Init scripts for Xvfb
285 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
286 Group:          X11/Servers
287 Requires:       xorg-xserver-Xvfb
288
289 %description -n xorg-xserver-Xvfb-init
290 This package contains init scripts for Xvfb and registers Xvfb as
291 system service.
292
293 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
294 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
295 usługę systemową.
296
297 %package devel
298 Summary:        Header files for X.org server
299 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
300 Group:          X11/Development/Libraries
301 Requires:       libdrm-devel >= 2.4.5
302 Requires:       pixman-devel >= 0.22.0
303 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
304 Requires:       xorg-lib-libxkbfile-devel
305 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
306 Requires:       xorg-proto-fontsproto-devel
307 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
308 Requires:       xorg-proto-kbproto-devel >= 1.0.3
309 Requires:       xorg-proto-randrproto-devel >= 1.3
310 Requires:       xorg-proto-renderproto-devel >= 0.11
311 Requires:       xorg-proto-videoproto-devel
312 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
313 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
314 Requires:       xorg-proto-xineramaproto-devel
315 Requires:       xorg-proto-xproto-devel >= 7.0.22
316 Obsoletes:      X11-Xserver-devel < 1:7.0.0
317 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
318
319 %description devel
320 Header files for X.org server.
321
322 %description devel -l pl.UTF-8
323 Pliki nagłówkowe dla serwera X.org.
324
325 %package source
326 Summary:        X.org server source code
327 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
328 Group:          X11/Development/Libraries
329
330 %description source
331 X.org server source code.
332
333 %description source -l pl.UTF-8
334 Pliki źródłowe dla serwera X.org.
335
336 %package -n xorg-xserver-libdri
337 Summary:        DRI extension library for X.org server
338 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
339 Group:          X11/Servers
340 Requires:       %{name} = %{version}-%{release}
341 Provides:       xorg-xserver-module(dri)
342 %if %{without multigl}
343 Conflicts:      xorg-driver-video-fglrx
344 Conflicts:      xorg-driver-video-nvidia
345 %endif
346
347 %description -n xorg-xserver-libdri
348 DRI extension library for X.org server.
349
350 %description -n xorg-xserver-libdri -l pl.UTF-8
351 Biblioteka rozszerzenia DRI dla serwera X.org.
352
353 %package -n xorg-xserver-libglx
354 Summary:        GLX extension library for X.org server
355 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
356 Group:          X11/Servers
357 Requires:       %{name} = %{version}-%{release}
358 Requires:       xorg-xserver-libdri = %{version}-%{release}
359 # Mesa version glapi tables in glx/ dir come from
360 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
361 Provides:       xorg-xserver-module(glx)
362 Obsoletes:      X11-OpenGL-core < 1:7.0.0
363 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
364 %if %{without multigl}
365 Conflicts:      xorg-driver-video-fglrx
366 Conflicts:      xorg-driver-video-nvidia
367 %endif
368
369 %description -n xorg-xserver-libglx
370 GLX extension library for X.org server.
371
372 %description -n xorg-xserver-libglx -l pl.UTF-8
373 Biblioteka rozszerzenia GLX dla serwera X.org.
374
375 %prep
376 %setup -q -n xorg-server-%{version}
377 %patch0 -p0
378 %patch1 -p1
379 %patch2 -p1
380 %patch3 -p1
381 %patch4 -p1
382 %patch5 -p1
383
384 # xserver uses pixman-1 API/ABI so put that explictly here
385 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
386
387 %build
388 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
389 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
390         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
391         exit 1
392 fi
393
394 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
395 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
396         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
397         exit 1
398 fi
399
400 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
401 if [ $API != %{xorg_xserver_server_font_abi} ]; then
402         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
403         exit 1
404 fi
405 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
406 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
407         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
408         exit 1
409 fi
410 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
411 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
412         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
413         exit 1
414 fi
415
416 %{__libtoolize}
417 %{__aclocal} -I m4
418 %{__autoconf}
419 %{__autoheader}
420 %{__automake}
421 %configure \
422         --with-os-name="PLD/Linux" \
423         --with-os-vendor="PLD/Team" \
424         --without-fop \
425         %{?with_dbus:--enable-config-dbus} \
426         --enable-config-hal%{!?with_hal:=no} \
427         --enable-config-udev%{!?with_udev:=no} \
428         --enable-aiglx \
429         --enable-dga \
430         %{?with_dmx:--enable-dmx} \
431         --enable-glx-tls \
432         --enable-install-libxf86config \
433         %{?with_record:--enable-record} \
434         --enable-kdrive \
435         %{?with_xcsecurity:--enable-xcsecurity} \
436         --enable-xephyr \
437         %{?with_xf86bigfont:--enable-xf86bigfont} \
438         --enable-xfbdev \
439         %{?with_xselinux:--enable-xselinux} \
440         --enable-glx-tls \
441         --disable-xfake \
442         --enable-secure-rpc \
443         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
444         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
445         --with-xkb-output=/var/lib/xkb
446
447 %{__make}
448
449 %install
450 rm -rf $RPM_BUILD_ROOT
451
452 %{__make} install \
453         DESTDIR=$RPM_BUILD_ROOT
454
455 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
456 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
457 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
458 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
459
460 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
461 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
462
463 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
464
465 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
466
467 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
468 install -d $RPM_BUILD_ROOT/etc/sysconfig
469 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
470 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
471
472 %if %{with multigl}
473 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
474 mv -f libglx.so libglx.so.%{version}
475 ln -sf libglx.so.%{version} libglx.so
476 cd -
477 %endif
478
479 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
480 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
481 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
482 %{__make} distclean
483 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
484 find -name '*.h' | xargs chmod a-x
485
486 %clean
487 rm -rf $RPM_BUILD_ROOT
488
489 %if %{with multigl}
490 %post -n xorg-xserver-libglx
491 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
492         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
493 fi
494 %endif
495
496 %triggerpostun -- xorg-xserver-server < 1.5.0
497 if [ -f /etc/X11/xorg.conf ]; then
498         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
499         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
500 %if %{without record}
501         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
502 %endif
503         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
504 fi
505
506 %post -n xorg-xserver-Xvfb-init
507 /sbin/chkconfig --add Xvfb
508 %service Xvfb restart
509
510 %preun -n xorg-xserver-Xvfb-init
511 if [ "$1" = "0" ]; then
512         %service -q Xvfb stop
513         /sbin/chkconfig --del Xvfb
514 fi
515
516 %files
517 %defattr(644,root,root,755)
518 %doc COPYING ChangeLog README
519 %attr(755,root,root) %{_bindir}/X
520 %attr(755,root,root) %{_bindir}/Xorg
521 %attr(4755,root,root) %{_bindir}/Xwrapper
522 %attr(755,root,root) %{_bindir}/cvt
523 %attr(755,root,root) %{_bindir}/gtf
524 %dir %{_libdir}/xorg
525 %{_libdir}/xorg/protocol.txt
526 %dir %{_libdir}/xorg/modules
527 %dir %{_libdir}/xorg/modules/dri
528 %dir %{_libdir}/xorg/modules/drivers
529 %dir %{_libdir}/xorg/modules/extensions
530 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
531 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
532 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
533 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
534 %dir %{_libdir}/xorg/modules/input
535 %dir %{_libdir}/xorg/modules/multimedia
536 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
537 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
538 %dir /var/lib/xkb
539 /var/lib/xkb/README.compiled
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
542 %config(missingok) /etc/security/console.apps/xserver
543 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
544 %dir /etc/X11/xorg.conf.d
545 %dir %{_datadir}/X11/xorg.conf.d
546 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
547 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
548 %{_mandir}/man1/Xorg.1x*
549 %{_mandir}/man1/Xserver.1x*
550 %{_mandir}/man1/cvt.1*
551 %{_mandir}/man1/gtf.1x*
552 %{_mandir}/man4/exa.4*
553 %{_mandir}/man4/fbdevhw.4*
554 %{_mandir}/man5/xorg.conf.5x*
555 %{_mandir}/man5/xorg.conf.d.5x
556
557 %if %{with dmx}
558 %files -n xorg-xserver-Xdmx
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xdmx
561 %attr(755,root,root) %{_bindir}/dmxaddinput
562 %attr(755,root,root) %{_bindir}/dmxaddscreen
563 %attr(755,root,root) %{_bindir}/dmxinfo
564 %attr(755,root,root) %{_bindir}/dmxreconfig
565 %attr(755,root,root) %{_bindir}/dmxresize
566 %attr(755,root,root) %{_bindir}/dmxrminput
567 %attr(755,root,root) %{_bindir}/dmxrmscreen
568 %attr(755,root,root) %{_bindir}/dmxtodmx
569 %attr(755,root,root) %{_bindir}/dmxwininfo
570 %attr(755,root,root) %{_bindir}/vdltodmx
571 %attr(755,root,root) %{_bindir}/xdmxconfig
572 %{_mandir}/man1/Xdmx.1x*
573 %{_mandir}/man1/dmxtodmx.1x*
574 %{_mandir}/man1/vdltodmx.1x*
575 %{_mandir}/man1/xdmxconfig.1x*
576 %endif
577
578 %files -n xorg-xserver-Xnest
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/Xnest
581 %{_mandir}/man1/Xnest.1x*
582
583 %files -n xorg-xserver-Xephyr
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/Xephyr
586 %{_mandir}/man1/Xephyr.1x*
587
588 %files -n xorg-xserver-Xfbdev
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_bindir}/Xfbdev
591
592 %files -n xorg-xserver-Xvfb
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_bindir}/Xvfb
595 %{_mandir}/man1/Xvfb.1x*
596
597 %files -n xorg-xserver-Xvfb-init
598 %defattr(644,root,root,755)
599 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
600 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
601
602 %files devel
603 %defattr(644,root,root,755)
604 %doc doc/{Xinput,Xserver-spec}.html
605 %{_includedir}/xorg
606 %{_libdir}/libxf86config.a
607 %{_libdir}/libxf86config.la
608 %{_aclocaldir}/xorg-server.m4
609 %{_pkgconfigdir}/xorg-server.pc
610
611 %files source
612 %defattr(644,root,root,755)
613 # keep file perms from install time, but have default defattr to keep adapter happy
614 %defattr(-,root,root,755)
615 %{_usrsrc}/%{name}-%{version}
616
617 %files -n xorg-xserver-libdri
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
620
621 %files -n xorg-xserver-libglx
622 %defattr(644,root,root,755)
623 %if %{with multigl}
624 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
625 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
626 %else
627 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
628 %endif
This page took 0.090428 seconds and 4 git commands to generate.