]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- added libunwind bcond, no libunwind on x32
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 # - upstream --enable-suid-wrapper vs Xwrapper patch?
5 #
6 # Conditional build:
7 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
8 %bcond_with     hal             # HAL support for configuration (if no udev)
9 %bcond_without  udev            # UDEV support for configuration
10 %bcond_without  dri2            # DRI2 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       8.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        18.0
26 %define xorg_xserver_server_xinput_abi          21.0
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.16.3
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  afd93977235584a9caa7528a737c1b52
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48
49 Patch0:         %{name}-xwrapper.patch
50 Patch1:         %{name}-pic-libxf86config.patch
51
52 Patch4:         %{name}-builtin-SHA1.patch
53 Patch5:         %{name}-export-GetMaster.patch
54 Patch6:         110_nvidia_slowdow_fix.patch
55 Patch7:         %{name}-include-defs.patch
56 URL:            http://xorg.freedesktop.org/
57 BuildRequires:  Mesa-libGL-devel >= 7.8.1
58 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
59 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
60 # for glx headers
61 BuildRequires:  OpenGL-GLX-devel
62 %{?with_xselinux:BuildRequires: audit-libs-devel}
63 BuildRequires:  autoconf >= 2.60
64 BuildRequires:  automake
65 BuildRequires:  cpp
66 BuildRequires:  docbook-dtd43-xml
67 #BuildRequires: doxygen >= 1.6.1
68 %if %{with hal} || %{with dbus}
69 BuildRequires:  dbus-devel >= 1.0
70 %endif
71 %{?with_hal:BuildRequires:      hal-devel}
72 BuildRequires:  libdrm-devel >= 2.4.39
73 %if %{with glamor} || %{with wayland}
74 BuildRequires:  libepoxy-devel
75 %endif
76 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
77 BuildRequires:  libtool >= 2:2.2
78 %{?with_libunwind:BuildRequires:        libunwind-devel}
79 BuildRequires:  libxcb-devel >= 1.6
80 BuildRequires:  pam-devel
81 BuildRequires:  perl-base
82 BuildRequires:  pixman-devel >= %{pixman_ver}
83 BuildRequires:  pkgconfig >= 1:0.19
84 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
85 BuildRequires:  udev-devel >= 1:143
86 # wayland-client
87 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
88 BuildRequires:  xcb-util-devel
89 BuildRequires:  xcb-util-image-devel
90 BuildRequires:  xcb-util-keysyms-devel
91 BuildRequires:  xcb-util-wm-devel
92 BuildRequires:  xmlto >= 0.0.20
93 BuildRequires:  xorg-app-mkfontscale
94 BuildRequires:  xorg-lib-libX11-devel >= 1.6
95 BuildRequires:  xorg-lib-libXau-devel
96 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
97 BuildRequires:  xorg-lib-libXdamage-devel
98 BuildRequires:  xorg-lib-libXdmcp-devel
99 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
100 BuildRequires:  xorg-lib-libXfixes-devel
101 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
102 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
103 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
104 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
105 BuildRequires:  xorg-lib-libXrender-devel
106 BuildRequires:  xorg-lib-libXres-devel
107 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
108 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
109 BuildRequires:  xorg-lib-libXv-devel
110 BuildRequires:  xorg-lib-libXxf86dga-devel
111 BuildRequires:  xorg-lib-libXxf86misc-devel
112 BuildRequires:  xorg-lib-libXxf86vm-devel
113 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
114 BuildRequires:  xorg-lib-libfontenc-devel
115 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
116 BuildRequires:  xorg-lib-libxkbfile-devel
117 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
118 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.3
119 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
120 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
121 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
122 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
123 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
124 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
125 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
126 BuildRequires:  xorg-proto-fontcacheproto-devel
127 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
128 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
129 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
130 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
131 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
132 BuildRequires:  xorg-proto-printproto-devel
133 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
134 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
135 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
136 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
137 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
138 BuildRequires:  xorg-proto-videoproto-devel
139 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
140 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
141 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
142 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
143 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
144 BuildRequires:  xorg-proto-xf86miscproto-devel
145 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
146 BuildRequires:  xorg-proto-xineramaproto-devel
147 BuildRequires:  xorg-proto-xproto-devel >= 7.0.26
148 BuildRequires:  xorg-sgml-doctools >= 1.8
149 BuildRequires:  xorg-util-util-macros >= 1.14
150 #BR: tslib (for KDRIVE only)
151 Requires(triggerpostun):        sed >= 4.0
152 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
153 Requires:       libdrm >= 2.4.39
154 Requires:       pixman >= %{pixman_ver}
155 Requires:       udev-libs >= 1:143
156 Requires:       xkeyboard-config
157 # for rgb.txt
158 Requires:       xorg-app-rgb >= 0.99.3
159 Requires:       xorg-app-xkbcomp
160 Requires:       xorg-lib-libXfont >= 1.4.2
161 Requires:       xorg-lib-libpciaccess >= 0.12.901
162 Requires:       xorg-lib-libxshmfence >= 1.1
163 Suggests:       dbus-x11 >= 1.0
164 %{?with_hal:Suggests:   hal}
165 Suggests:       udev-acl >= 1:143
166 %{?with_udev:Suggests:  udev-core >= 1:143}
167 Suggests:       xkeyboard-config
168 Suggests:       xorg-driver-input-evdev
169 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
170 Suggests:       xorg-driver-video
171 Provides:       xorg-xserver-libdri = %{version}-%{release}
172 Provides:       xorg-xserver-module(dri)
173 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
174 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
175 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
176 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
177 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
178 Obsoletes:      X11-Xserver < 1:7.0.0
179 Obsoletes:      X11-driver-i2c < 1:7.0.0
180 Obsoletes:      X11-modules < 1:7.0.0
181 Obsoletes:      X11-setup < 1:7.0.0
182 Obsoletes:      XFree86-Xserver < 1:7.0.0
183 Obsoletes:      XFree86-modules < 1:7.0.0
184 Obsoletes:      XFree86-setup < 1:7.0.0
185 Obsoletes:      Xserver
186 %{?with_glamor:Obsoletes:       glamor}
187 Obsoletes:      xorg-xserver-libdri
188 Obsoletes:      xorg-xserver-server-xorgcfg
189 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
190
191 # avoid self-dependencies on included modules
192 %define         _noautoreq      libscanpci.so libxf1bpp.so
193
194 %description
195 Xorg server is a generally used X server which uses display hardware.
196 It requires proper driver for your display hardware.
197
198 %description -l pl.UTF-8
199 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
200 graficznej. Do działania wymaga odpowiedniego sterownika.
201
202 %package -n xorg-xserver-Xdmx
203 Summary:        Xdmx - distributed multi-head X server
204 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
205 Group:          X11/Servers
206 Requires:       pixman >= %{pixman_ver}
207 Requires:       xorg-lib-libX11 >= 1.6
208 Requires:       xorg-lib-libXext >= 1.0.99.4
209 Requires:       xorg-lib-libXfont >= 1.4.2
210 Requires:       xorg-lib-libXi >= 1.2.99.1
211 Requires:       xorg-lib-libdmx >= 1.0.99.1
212
213 %description -n xorg-xserver-Xdmx
214 Xdmx - distributed multi-head X server.
215
216 %description -n xorg-xserver-Xdmx -l pl.UTF-8
217 Xdmx - rozproszony, wielomonitorowy serwer X.
218
219 %package -n xorg-xserver-Xnest
220 Summary:        Xnest - nested X server
221 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
222 Group:          X11/Servers
223 Requires:       pixman >= %{pixman_ver}
224 Requires:       xorg-lib-libXext >= 1.0.99.4
225 Requires:       xorg-lib-libXfont >= 1.4.2
226 Obsoletes:      X11-Xnest < 1:7.0.0
227 Obsoletes:      XFree86-Xnest < 1:7.0.0
228 Obsoletes:      Xserver-Xnest
229
230 %description -n xorg-xserver-Xnest
231 Xnest is an X Window System server which runs in an X window. Xnest is
232 a 'nested' window server, actually a client of the real X server,
233 which manages windows and graphics requests for Xnest, while Xnest
234 manages the windows and graphics requests for its own clients.
235
236 %description -n xorg-xserver-Xnest -l pl.UTF-8
237 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
238 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
239 serwer X dla własnych klientów.
240
241 %description -n xorg-xserver-Xnest -l ru.UTF-8
242 Xnest - это сервер X Window System, который работает в окне X. На
243 самом деле это клиент реального X-сервера, который управляет окнами и
244 графическими запросами для Xnest в то время, как Xnest управляет
245 окнами и графическими запросами для своих собственных клиентов.
246
247 %description -n xorg-xserver-Xnest -l uk.UTF-8
248 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
249 клієнт реального X-сервера, який керує вікнами та графічними запитами
250 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
251 своїх власних клієнтів.
252
253 %package -n xorg-xserver-Xephyr
254 Summary:        Xephyr - nested X server
255 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
256 Group:          X11/Servers
257 Requires:       Mesa-libGL >= 7.1.0
258 Requires:       libxcb >= 1.6
259 Requires:       pixman >= %{pixman_ver}
260 Requires:       xorg-lib-libXfont >= 1.4.2
261
262 %description -n xorg-xserver-Xephyr
263 Xephyr is a kdrive server that outputs to a window on a pre-existing
264 'host' X display. Think Xnest but with support for modern extensions
265 like composite, damage and randr.
266
267 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
268 the host X server, Xephyr is a real X server which uses the host X
269 server window as "framebuffer" via fast SHM XImages.
270
271 It also has support for 'visually' debugging what the server is
272 painting.
273
274 %description -n xorg-xserver-Xephyr -l pl.UTF-8
275 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
276 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
277 wspólczesnych rozszerzeń jak composite, damage i randr.
278
279 %package -n xorg-xserver-Xfbdev
280 Summary:        Xfbdev - Linux framebuffer device X server
281 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
282 Group:          X11/Servers
283 Requires:       pixman >= %{pixman_ver}
284 Requires:       xorg-lib-libXfont >= 1.4.2
285
286 %description -n xorg-xserver-Xfbdev
287 Xfbdev is a Linux framebuffer device X server based on the kdrive X
288 server.
289
290 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
291 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
292
293 %package -n xorg-xserver-Xvfb
294 Summary:        Xvfb - virtual framebuffer X server
295 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
296 Group:          X11/Servers
297 Requires:       Mesa-libGL >= 7.1.0
298 Requires:       mktemp
299 Requires:       pixman >= %{pixman_ver}
300 Requires:       util-linux
301 Requires:       which
302 Requires:       xkeyboard-config
303 Requires:       xorg-app-xauth
304 Requires:       xorg-app-xkbcomp
305 Requires:       xorg-lib-libXfont >= 1.4.2
306 Obsoletes:      X11-Xvfb < 1:7.0.0
307 Obsoletes:      XFree86-Xvfb < 1:7.0.0
308
309 %description -n xorg-xserver-Xvfb
310 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
311 capable of running on machines with no display hardware and no
312 physical input devices. Xvfb emulates a dumb framebuffer using virtual
313 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
314 display. Xvfb is normally used for testing servers. Using Xvfb, the
315 mfb or cfb code for any depth can be exercised without using real
316 hardware that supports the desired depths. Xvfb has also been used to
317 test X clients against unusual depths and screen configurations, to do
318 batch processing with Xvfb as a background rendering engine, to do
319 load testing, to help with porting an X server to a new platform, and
320 to provide an unobtrusive way of running applications which really
321 don't need an X server but insist on having one.
322
323 %description -n xorg-xserver-Xvfb -l pl.UTF-8
324 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
325 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
326 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
327 używany do testowania serwerów X, może też być używany do testowania
328 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
329 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
330 serwera X, ale odmawiają uruchomienia bez niego.
331
332 %package -n xorg-xserver-Xvfb-init
333 Summary:        Init scripts for Xvfb
334 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
335 Group:          X11/Servers
336 Requires:       xorg-xserver-Xvfb
337
338 %description -n xorg-xserver-Xvfb-init
339 This package contains init scripts for Xvfb and registers Xvfb as
340 system service.
341
342 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
343 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
344 usługę systemową.
345
346 %package -n xorg-xserver-Xwayland
347 Summary:        Xwayland - X server integrated into a Wayland window system
348 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
349 Group:          X11/Servers
350 Requires:       pixman >= %{pixman_ver}
351 Requires:       xorg-lib-libX11 >= 1.6
352 Requires:       xorg-lib-libXext >= 1.0.99.4
353 Requires:       xorg-lib-libXfont >= 1.4.2
354 Requires:       xorg-lib-libXi >= 1.2.99.1
355
356 %description -n xorg-xserver-Xwayland
357 Xwayland - server integrated into a Wayland window system.
358
359 %description -n xorg-xserver-Xwayland -l pl.UTF-8
360 Xwayland - serwer X integrowalny w Wayland.
361
362 %package devel
363 Summary:        Header files for X.org server
364 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
365 Group:          X11/Development/Libraries
366 Requires:       Mesa-libGL-devel >= 7.8.0
367 Requires:       libdrm-devel >= 2.4.39
368 Requires:       pixman-devel >= %{pixman_ver}
369 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
370 Requires:       xorg-lib-libxkbfile-devel
371 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
372 Requires:       xorg-proto-dri3proto-devel >= 1.0
373 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
374 Requires:       xorg-proto-glproto-devel >= 1.4.17
375 Requires:       xorg-proto-inputproto-devel >= 2.3
376 Requires:       xorg-proto-kbproto-devel >= 1.0.3
377 Requires:       xorg-proto-presentproto-devel >= 1.0
378 Requires:       xorg-proto-randrproto-devel >= 1.4.0
379 Requires:       xorg-proto-renderproto-devel >= 0.11
380 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
381 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
382 Requires:       xorg-proto-videoproto-devel
383 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
384 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
385 Requires:       xorg-proto-xineramaproto-devel
386 Requires:       xorg-proto-xproto-devel >= 7.0.26
387 Obsoletes:      X11-Xserver-devel < 1:7.0.0
388 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
389 %{?with_glamor:Obsoletes:       glamor-devel}
390
391 %description devel
392 Header files for X.org server.
393
394 %description devel -l pl.UTF-8
395 Pliki nagłówkowe dla serwera X.org.
396
397 %package source
398 Summary:        X.org server source code
399 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
400 Group:          X11/Development/Libraries
401
402 %description source
403 X.org server source code.
404
405 %description source -l pl.UTF-8
406 Pliki źródłowe dla serwera X.org.
407
408 %package -n xorg-xserver-libglx
409 Summary:        GLX extension library for X.org server
410 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
411 Group:          X11/Servers
412 Requires:       %{name} = %{version}-%{release}
413 Requires:       Mesa-libGL >= 7.1.0
414 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
415 # Mesa version glapi tables in glx/ dir come from
416 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
417 Provides:       xorg-xserver-module(glx)
418 Obsoletes:      X11-OpenGL-core < 1:7.0.0
419 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
420
421 %description -n xorg-xserver-libglx
422 GLX extension library for X.org server.
423
424 %description -n xorg-xserver-libglx -l pl.UTF-8
425 Biblioteka rozszerzenia GLX dla serwera X.org.
426
427 %prep
428 %setup -q -n xorg-server-%{version}
429 %patch0 -p0
430 %patch1 -p1
431
432 %patch4 -p1
433 %patch5 -p1
434 %patch6 -p1
435
436 #unfortunately breaks build
437 #patch7 -p1
438
439 # xserver uses pixman-1 API/ABI so put that explictly here
440 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
441
442 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
443 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
444
445 %build
446 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
447 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
448         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
449         exit 1
450 fi
451
452 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
453 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
454         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
455         exit 1
456 fi
457
458 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
459 if [ $API != %{xorg_xserver_server_font_abi} ]; then
460         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
461         exit 1
462 fi
463 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
464 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
465         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
466         exit 1
467 fi
468 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
469 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
470         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
471         exit 1
472 fi
473
474 %{__libtoolize}
475 %{__aclocal} -I m4
476 %{__autoconf}
477 %{__autoheader}
478 %{__automake}
479 %configure \
480         --with-os-name="PLD/Linux" \
481         --with-os-vendor="PLD/Team" \
482         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
483         --with-xkb-output=/var/lib/xkb \
484         --disable-linux-acpi \
485         --disable-linux-apm \
486         --enable-aiglx \
487         %{?with_dbus:--enable-config-dbus} \
488         --enable-config-hal%{!?with_hal:=no} \
489         --enable-config-udev%{!?with_udev:=no} \
490         --enable-dga \
491         %{?with_dmx:--enable-dmx} \
492         --enable-dri2%{!?with_dri2:=no} \
493         %{?with_glamor:--enable-glamor} \
494         --enable-glx-tls \
495         --enable-install-libxf86config \
496         --enable-kdrive \
497         %{?with_libunwind:--enable-libunwind} \
498         %{?with_record:--enable-record} \
499         --enable-secure-rpc \
500         %{?with_xcsecurity:--enable-xcsecurity} \
501         --enable-xephyr \
502         %{?with_xf86bigfont:--enable-xf86bigfont} \
503         --disable-xfake \
504         --enable-xfbdev \
505         %{?with_xselinux:--enable-xselinux} \
506         %{?with_wayland:--enable-xwayland} \
507         %{!?with_systemtap:--without-dtrace} \
508         --without-fop \
509         --with-systemd-daemon
510
511 %{__make}
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515
516 %if "%{_libdir}" != "%{_exec_prefix}/lib"
517 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
518 %endif
519
520 %{__make} install \
521         DESTDIR=$RPM_BUILD_ROOT
522
523 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
524 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
525 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
526 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
527 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
528
529 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
530 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
531
532 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
533
534 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
535
536 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
537 install -d $RPM_BUILD_ROOT/etc/sysconfig
538 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
539 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
540
541 # prepare source package
542 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
543 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
544 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
545 %{__make} distclean
546 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
547 find -name '*.h' | xargs chmod a-x
548
549 %if %{with systemtap}
550 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
551 %endif
552
553 %clean
554 rm -rf $RPM_BUILD_ROOT
555
556 %triggerpostun -- xorg-xserver-server < 1.5.0
557 if [ -f /etc/X11/xorg.conf ]; then
558         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
559         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
560 %if %{without record}
561         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
562 %endif
563         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
564 fi
565
566 %post -n xorg-xserver-Xvfb-init
567 /sbin/chkconfig --add Xvfb
568 %service Xvfb restart
569
570 %preun -n xorg-xserver-Xvfb-init
571 if [ "$1" = "0" ]; then
572         %service -q Xvfb stop
573         /sbin/chkconfig --del Xvfb
574 fi
575
576 %files
577 %defattr(644,root,root,755)
578 %doc COPYING ChangeLog README
579 %attr(755,root,root) %{_bindir}/X
580 %attr(755,root,root) %{_bindir}/Xorg
581 %attr(4755,root,root) %{_bindir}/Xwrapper
582 %attr(755,root,root) %{_bindir}/cvt
583 %attr(755,root,root) %{_bindir}/gtf
584 %dir %{_libdir}/xorg
585 %{_libdir}/xorg/protocol.txt
586 %dir %{_libdir}/xorg/modules
587 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
588 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
589 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
590 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
591 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
592 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
594 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
595 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
596 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
597 %dir %{_libdir}/xorg/modules/dri
598 %dir %{_libdir}/xorg/modules/drivers
599 %dir %{_libdir}/xorg/modules/extensions
600 %dir %{_libdir}/xorg/modules/input
601 %dir %{_libdir}/xorg/modules/multimedia
602 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/bt829_drv.so
603 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/fi1236_drv.so
604 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/msp3430_drv.so
605 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda8425_drv.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9850_drv.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9885_drv.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/uda1380_drv.so
609 %if "%{_libdir}" != "%{_exec_prefix}/lib"
610 %dir %{_exec_prefix}/lib/xorg
611 %dir %{_exec_prefix}/lib/xorg/modules
612 %dir %{_exec_prefix}/lib/xorg/modules/dri
613 %endif
614 %dir /var/lib/xkb
615 /var/lib/xkb/README.compiled
616 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
617 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
618 %config(missingok) /etc/security/console.apps/xserver
619 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
620 %dir /etc/X11/xorg.conf.d
621 %dir %{_datadir}/X11/xorg.conf.d
622 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
623 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-evdev.conf
624 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
625 %{_mandir}/man1/Xorg.1*
626 %{_mandir}/man1/Xserver.1*
627 %{_mandir}/man1/cvt.1*
628 %{_mandir}/man1/gtf.1*
629 %{_mandir}/man4/exa.4*
630 %{_mandir}/man4/fbdevhw.4*
631 %{_mandir}/man5/xorg.conf.5*
632 %{_mandir}/man5/xorg.conf.d.5*
633
634 %if %{with dmx}
635 %files -n xorg-xserver-Xdmx
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/Xdmx
638 %attr(755,root,root) %{_bindir}/dmxaddinput
639 %attr(755,root,root) %{_bindir}/dmxaddscreen
640 %attr(755,root,root) %{_bindir}/dmxinfo
641 %attr(755,root,root) %{_bindir}/dmxreconfig
642 %attr(755,root,root) %{_bindir}/dmxresize
643 %attr(755,root,root) %{_bindir}/dmxrminput
644 %attr(755,root,root) %{_bindir}/dmxrmscreen
645 %attr(755,root,root) %{_bindir}/dmxtodmx
646 %attr(755,root,root) %{_bindir}/dmxwininfo
647 %attr(755,root,root) %{_bindir}/vdltodmx
648 %attr(755,root,root) %{_bindir}/xdmxconfig
649 %{_mandir}/man1/Xdmx.1*
650 %{_mandir}/man1/dmxtodmx.1*
651 %{_mandir}/man1/vdltodmx.1*
652 %{_mandir}/man1/xdmxconfig.1*
653 %endif
654
655 %files -n xorg-xserver-Xnest
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/Xnest
658 %{_mandir}/man1/Xnest.1*
659
660 %files -n xorg-xserver-Xephyr
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/Xephyr
663 %{_mandir}/man1/Xephyr.1*
664
665 %files -n xorg-xserver-Xfbdev
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/Xfbdev
668
669 %files -n xorg-xserver-Xvfb
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/Xvfb
672 %attr(755,root,root) %{_bindir}/xvfb-run
673 %{_mandir}/man1/Xvfb.1*
674
675 %files -n xorg-xserver-Xvfb-init
676 %defattr(644,root,root,755)
677 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
678 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
679
680 %if %{with wayland}
681 %files -n xorg-xserver-Xwayland
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_bindir}/Xwayland
684 %endif
685
686 %files devel
687 %defattr(644,root,root,755)
688 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
689 %{_includedir}/xorg
690 %{_libdir}/libxf86config.a
691 %{_libdir}/libxf86config.la
692 %{_aclocaldir}/xorg-server.m4
693 %{_pkgconfigdir}/xorg-server.pc
694
695 %files source
696 %defattr(644,root,root,755)
697 # keep file perms from install time, but have default defattr to keep adapter happy
698 %defattr(-,root,root,755)
699 %{_usrsrc}/%{name}-%{version}
700
701 %files -n xorg-xserver-libglx
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.094341 seconds and 4 git commands to generate.