]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- Xephyr R: pixman >= 0.15.0 due to pixman_disable_out_of_bounds_workaround symbol
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_without  dbus    # D-BUS support
6 %bcond_without  hal     # HAL support
7 %bcond_without  dmx     # DMX support
8 %bcond_with     record  # RECORD extension
9 #
10 # ABI versions, see hw/xfree86/common/xf86Module.h
11 %define xorg_xserver_server_ansic_abi           0.4
12 %define xorg_xserver_server_extension_abi       2.0
13 %define xorg_xserver_server_font_abi            0.6
14 %define xorg_xserver_server_videodrv_abi        6.0
15 %define xorg_xserver_server_xinput_abi          7.0
16
17 %define         rel             1
18 Summary:        X.org server
19 Summary(pl.UTF-8):      Serwer X.org
20 Name:           xorg-xserver-server
21 Version:        1.7.4
22 Release:        %{rel}%{?with_multigl:.mgl}
23 License:        MIT
24 Group:          X11/Servers
25 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
26 # Source0-md5:  75d27c3a1c12293f620a2d6518fcbdfa
27 Source2:        xserver.pamd
28 Patch0:         %{name}-xwrapper.patch
29 Patch1:         %{name}-pic-libxf86config.patch
30 Patch2:         %{name}-fb-size.patch
31 Patch6:         %{name}-less-acpi-brokenness.patch
32 Patch7:         %{name}-ac.patch
33 URL:            http://xorg.freedesktop.org/
34 BuildRequires:  Mesa-libGL-devel >= 7.3
35 # for glx headers
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 BuildRequires:  cpp
40 %if %{with hal} || %{with dbus}
41 BuildRequires:  dbus-devel
42 %endif
43 %{?with_hal:BuildRequires:      hal-devel}
44 BuildRequires:  libdrm-devel >= 2.4.5
45 BuildRequires:  libtool
46 BuildRequires:  ncurses-devel
47 BuildRequires:  openssl-devel
48 BuildRequires:  pam-devel
49 BuildRequires:  perl-base
50 BuildRequires:  pixman-devel >= 0.16.0
51 BuildRequires:  pkgconfig >= 1:0.19
52 BuildRequires:  xorg-app-mkfontscale
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXau-devel
55 BuildRequires:  xorg-lib-libXaw-devel
56 BuildRequires:  xorg-lib-libXdamage-devel
57 BuildRequires:  xorg-lib-libXdmcp-devel
58 BuildRequires:  xorg-lib-libXext-devel
59 BuildRequires:  xorg-lib-libXfont-devel
60 BuildRequires:  xorg-lib-libXi-devel >= 1.2
61 BuildRequires:  xorg-lib-libXmu-devel
62 BuildRequires:  xorg-lib-libXpm-devel
63 BuildRequires:  xorg-lib-libXrender-devel
64 BuildRequires:  xorg-lib-libXres-devel
65 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
66 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
67 BuildRequires:  xorg-lib-libXv-devel
68 BuildRequires:  xorg-lib-libXxf86dga-devel
69 BuildRequires:  xorg-lib-libXxf86misc-devel
70 BuildRequires:  xorg-lib-libXxf86vm-devel
71 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
72 BuildRequires:  xorg-lib-libfontenc-devel
73 BuildRequires:  xorg-lib-libpciaccess-devel
74 BuildRequires:  xorg-lib-libxkbfile-devel
75 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
76 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
77 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
78 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
79 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
80 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel}
81 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.1}
82 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
83 BuildRequires:  xorg-proto-fontcacheproto-devel
84 BuildRequires:  xorg-proto-fontsproto-devel
85 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
86 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
87 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
88 BuildRequires:  xorg-proto-printproto-devel
89 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
90 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel}
91 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
92 BuildRequires:  xorg-proto-resourceproto-devel
93 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
94 BuildRequires:  xorg-proto-videoproto-devel
95 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
96 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
97 BuildRequires:  xorg-proto-xf86bigfontproto-devel
98 BuildRequires:  xorg-proto-xf86dgaproto-devel
99 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.0.4
100 BuildRequires:  xorg-proto-xf86miscproto-devel
101 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
102 BuildRequires:  xorg-proto-xineramaproto-devel
103 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
104 BuildRequires:  xorg-util-util-macros >= 0.99.2
105 #BR: xcalibrateproto, tslib (for KDRIVE only)
106 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
107 Requires(triggerpostun):        sed >= 4.0
108 Requires:       pixman >= 0.16.0
109 Requires:       xkeyboard-config
110 # for rgb.txt
111 Requires:       xorg-app-rgb >= 0.99.3
112 Requires:       xorg-app-xkbcomp
113 # xserver default config expects evdev+dbus+hald
114 Suggests:       dbus
115 Suggests:       hal
116 Suggests:       udev-acl
117 Suggests:       xorg-driver-input-evdev
118 # xserver requires fixed and cursor fonts
119 Requires:       xorg-font-font-alias
120 Requires:       xorg-font-font-cursor-misc
121 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
122 Suggests:       xkeyboard-config
123 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
124 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
125 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
126 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
127 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
128 Obsoletes:      X11-Xserver < 1:7.0.0
129 Obsoletes:      X11-driver-i2c < 1:7.0.0
130 Obsoletes:      X11-modules < 1:7.0.0
131 Obsoletes:      X11-setup < 1:7.0.0
132 Obsoletes:      XFree86-Xserver < 1:7.0.0
133 Obsoletes:      XFree86-modules < 1:7.0.0
134 Obsoletes:      XFree86-setup < 1:7.0.0
135 Obsoletes:      Xserver
136 Obsoletes:      xorg-xserver-server-xorgcfg
137 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
138
139 # avoid self-dependencies on included modules
140 %define         _noautoreq      libscanpci.so libxf1bpp.so
141
142 %description
143 Xorg server is a generally used X server which uses display hardware.
144 It requires proper driver for your display hardware.
145
146 %description -l pl.UTF-8
147 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
148 graficznej. Do działania wymaga odpowiedniego sterownika.
149
150 %package -n xorg-xserver-Xdmx
151 Summary:        Xdmx - distributed multi-head X server
152 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
153 Group:          X11/Servers
154
155 %description -n xorg-xserver-Xdmx
156 Xdmx - distributed multi-head X server.
157
158 %description -n xorg-xserver-Xdmx -l pl.UTF-8
159 Xdmx - rozproszony, wielomonitorowy serwer X.
160
161 %package -n xorg-xserver-Xnest
162 Summary:        Xnest - nested X server
163 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
164 Group:          X11/Servers
165 Obsoletes:      X11-Xnest < 1:7.0.0
166 Obsoletes:      XFree86-Xnest < 1:7.0.0
167 Obsoletes:      Xserver-Xnest
168
169 %description -n xorg-xserver-Xnest
170 Xnest is an X Window System server which runs in an X window. Xnest is
171 a 'nested' window server, actually a client of the real X server,
172 which manages windows and graphics requests for Xnest, while Xnest
173 manages the windows and graphics requests for its own clients.
174
175 %description -n xorg-xserver-Xnest -l pl.UTF-8
176 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
177 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
178 serwer X dla własnych klientów.
179
180 %description -n xorg-xserver-Xnest -l ru.UTF-8
181 Xnest - это сервер X Window System, который работает в окне X. На
182 самом деле это клиент реального X-сервера, который управляет окнами и
183 графическими запросами для Xnest в то время, как Xnest управляет
184 окнами и графическими запросами для своих собственных клиентов.
185
186 %description -n xorg-xserver-Xnest -l uk.UTF-8
187 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
188 клієнт реального X-сервера, який керує вікнами та графічними запитами
189 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
190 своїх власних клієнтів.
191
192 %package -n xorg-xserver-Xephyr
193 Summary:        Xephyr - nested X server
194 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
195 Group:          X11/Servers
196 Requires:       pixman >= 0.15.0
197
198 %description -n xorg-xserver-Xephyr
199 Xephyr is a a kdrive server that outputs to a window on a pre-existing
200 'host' X display. Think Xnest but with support for modern extensions
201 like composite, damage and randr.
202
203 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
204 the host X server, Xephyr is a real X server which uses the host X
205 server window as "framebuffer" via fast SHM XImages.
206
207 It also has support for 'visually' debugging what the server is
208 painting.
209
210 %description -n xorg-xserver-Xephyr -l pl.UTF-8
211 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
212 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
213 wspólczesnych rozszerzeń jak composite, damage i randr.
214
215 %package -n xorg-xserver-Xfbdev
216 Summary:        Xfbdev - Linux framebuffer device X server
217 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
218 Group:          X11/Servers
219
220 %description -n xorg-xserver-Xfbdev
221 Xfbdev is a Linux framebuffer device X server based on the kdrive X
222 server.
223
224 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
225 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
226
227 %package -n xorg-xserver-Xvfb
228 Summary:        Xvfb - virtual framebuffer X server
229 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
230 Group:          X11/Servers
231 # requires fixed and cursor fonts
232 Requires:       xorg-font-font-alias
233 Requires:       xorg-font-font-cursor-misc
234 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
235 Obsoletes:      X11-Xvfb < 1:7.0.0
236 Obsoletes:      XFree86-Xvfb < 1:7.0.0
237
238 %description -n xorg-xserver-Xvfb
239 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
240 capable of running on machines with no display hardware and no
241 physical input devices. Xvfb emulates a dumb framebuffer using virtual
242 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
243 display. Xvfb is normally used for testing servers. Using Xvfb, the
244 mfb or cfb code for any depth can be exercised without using real
245 hardware that supports the desired depths. Xvfb has also been used to
246 test X clients against unusual depths and screen configurations, to do
247 batch processing with Xvfb as a background rendering engine, to do
248 load testing, to help with porting an X server to a new platform, and
249 to provide an unobtrusive way of running applications which really
250 don't need an X server but insist on having one.
251
252 %description -n xorg-xserver-Xvfb -l pl.UTF-8
253 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
254 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
255 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
256 używany do testowania serwerów X, może też być używany do testowania
257 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
258 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
259 serwera X, ale odmawiają uruchomienia bez niego.
260
261 %package devel
262 Summary:        Header files for X.org server
263 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
264 Group:          X11/Development/Libraries
265 Requires:       libdrm-devel >= 2.4.5
266 Requires:       pixman-devel >= 0.16.0
267 Requires:       xorg-lib-libpciaccess-devel
268 Requires:       xorg-lib-libxkbfile-devel
269 Requires:       xorg-proto-dri2proto-devel >= 2.1
270 Requires:       xorg-proto-fontsproto-devel
271 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
272 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
273 Requires:       xorg-proto-renderproto-devel >= 0.9.3
274 Requires:       xorg-proto-videoproto-devel
275 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
276 Requires:       xorg-proto-xproto-devel >= 7.0.13
277 Obsoletes:      X11-Xserver-devel < 1:7.0.0
278 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
279
280 %description devel
281 Header files for X.org server.
282
283 %description devel -l pl.UTF-8
284 Pliki nagłówkowe dla serwera X.org.
285
286 %package -n xorg-xserver-libdri
287 Summary:        DRI extension library for X.org server
288 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
289 Group:          X11/Servers
290 Requires:       %{name} = %{version}-%{release}
291 Provides:       xorg-xserver-module(dri)
292 %if %{without multigl}
293 Conflicts:      xorg-driver-video-fglrx-libdri
294 Conflicts:      xorg-driver-video-nvidia
295 %endif
296
297 %description -n xorg-xserver-libdri
298 DRI extension library for X.org server.
299
300 %description -n xorg-xserver-libdri -l pl.UTF-8
301 Biblioteka rozszerzenia DRI dla serwera X.org.
302
303 %package -n xorg-xserver-libglx
304 Summary:        GLX extension library for X.org server
305 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
306 Group:          X11/Servers
307 Requires:       %{name} = %{version}-%{release}
308 Requires:       xorg-xserver-libdri = %{version}-%{release}
309 # Mesa version glapi tables in glx/ dir come from
310 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
311 Provides:       xorg-xserver-module(glx)
312 Obsoletes:      X11-OpenGL-core < 1:7.0.0
313 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
314 %if %{without multigl}
315 Conflicts:      xorg-driver-video-fglrx-libglx
316 Conflicts:      xorg-driver-video-nvidia
317 %endif
318
319 %description -n xorg-xserver-libglx
320 GLX extension library for X.org server.
321
322 %description -n xorg-xserver-libglx -l pl.UTF-8
323 Biblioteka rozszerzenia GLX dla serwera X.org.
324
325 %prep
326 %setup -q -n xorg-server-%{version}
327 %patch0 -p0
328 %patch1 -p1
329 %patch2 -p1
330 %patch6 -p1
331 %patch7 -p0
332
333 # xserver uses pixman-1 API/ABI so put that explictly here
334 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
335
336 %build
337 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
338 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
339         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
340         exit 1
341 fi
342
343 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
344 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
345         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
346         exit 1
347 fi
348
349 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
350 if [ $API != %{xorg_xserver_server_font_abi} ]; then
351         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
352         exit 1
353 fi
354 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
355 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
356         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
357         exit 1
358 fi
359 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
360 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
361         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
362         exit 1
363 fi
364
365 %{__libtoolize}
366 %{__aclocal} -I m4
367 %{__autoconf}
368 %{__autoheader}
369 %{__automake}
370 %configure \
371         --with-os-name="PLD/Linux" \
372         --with-os-vendor="PLD/Team" \
373         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
374         %{!?with_hal:--disable-config-hal} \
375         --enable-aiglx \
376         --enable-builddocs \
377         --enable-dga \
378         %{?with_dmx:--enable-dmx} \
379         --enable-glx-tls \
380         --enable-install-libxf86config \
381         %{?with_record:--enable-record} \
382         --enable-kdrive \
383         --enable-xephyr \
384         --enable-xfbdev \
385         --enable-glx-tls \
386         --disable-xsdl \
387         --disable-xfake \
388         --enable-secure-rpc \
389         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
390         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
391         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
392         --with-xkb-output=/var/lib/xkb
393
394 %{__make}
395
396 %install
397 rm -rf $RPM_BUILD_ROOT
398
399 %{__make} install \
400         DESTDIR=$RPM_BUILD_ROOT
401
402 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
403 install -d $RPM_BUILD_ROOT/etc/security/console.apps
404 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
405 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
406 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
407
408 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
409
410 %if %{with multigl}
411 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
412 mv -f libglx.so libglx.so.%{version}
413 ln -sf libglx.so.%{version} libglx.so
414 %endif
415
416 %clean
417 rm -rf $RPM_BUILD_ROOT
418
419 %if %{with multigl}
420 %post -n xorg-xserver-libglx
421 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
422         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
423 fi
424 %endif
425
426 %triggerpostun -- xorg-xserver-server < 1.5.0
427 if [ -f /etc/X11/xorg.conf ]; then
428         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
429         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
430 %if %{without record}
431         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
432 %endif
433         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
434 fi
435
436 %files
437 %defattr(644,root,root,755)
438 %doc COPYING ChangeLog
439 %attr(755,root,root) %{_bindir}/X
440 %attr(755,root,root) %{_bindir}/Xorg
441 %attr(4755,root,root) %{_bindir}/Xwrapper
442 %attr(755,root,root) %{_bindir}/cvt
443 %attr(755,root,root) %{_bindir}/gtf
444 %dir %{_libdir}/xorg
445 %{_libdir}/xorg/protocol.txt
446 %dir %{_libdir}/xorg/modules
447 %dir %{_libdir}/xorg/modules/dri
448 %dir %{_libdir}/xorg/modules/drivers
449 %dir %{_libdir}/xorg/modules/extensions
450 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
451 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
452 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
453 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
454 %dir %{_libdir}/xorg/modules/input
455 %dir %{_libdir}/xorg/modules/linux
456 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
457 %dir %{_libdir}/xorg/modules/multimedia
458 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
459 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
460 %dir /var/lib/xkb
461 /var/lib/xkb/README.compiled
462 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
463 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
464 %config(missingok) /etc/security/console.apps/xserver
465 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
466 %{_mandir}/man1/Xorg.1x*
467 %{_mandir}/man1/Xserver.1x*
468 %{_mandir}/man1/cvt.1*
469 %{_mandir}/man1/gtf.1x*
470 %{_mandir}/man4/exa.4*
471 %{_mandir}/man4/fbdevhw.4*
472 %{_mandir}/man5/xorg.conf.5x*
473
474 %if %{with dmx}
475 %files -n xorg-xserver-Xdmx
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/Xdmx
478 %attr(755,root,root) %{_bindir}/dmxaddinput
479 %attr(755,root,root) %{_bindir}/dmxaddscreen
480 %attr(755,root,root) %{_bindir}/dmxreconfig
481 %attr(755,root,root) %{_bindir}/dmxresize
482 %attr(755,root,root) %{_bindir}/dmxrminput
483 %attr(755,root,root) %{_bindir}/dmxrmscreen
484 %attr(755,root,root) %{_bindir}/dmxtodmx
485 %attr(755,root,root) %{_bindir}/dmxwininfo
486 %attr(755,root,root) %{_bindir}/vdltodmx
487 %attr(755,root,root) %{_bindir}/xdmx
488 %attr(755,root,root) %{_bindir}/xdmxconfig
489 %{_mandir}/man1/Xdmx.1x*
490 %{_mandir}/man1/dmxtodmx.1x*
491 %{_mandir}/man1/vdltodmx.1x*
492 %{_mandir}/man1/xdmxconfig.1x*
493 %endif
494
495 %files -n xorg-xserver-Xnest
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_bindir}/Xnest
498 %{_mandir}/man1/Xnest.1x*
499
500 %files -n xorg-xserver-Xephyr
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_bindir}/Xephyr
503 %{_mandir}/man1/Xephyr.1x*
504
505 %files -n xorg-xserver-Xfbdev
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/Xfbdev
508
509 %files -n xorg-xserver-Xvfb
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{_bindir}/Xvfb
512 %{_mandir}/man1/Xvfb.1x*
513
514 %files devel
515 %defattr(644,root,root,755)
516 %{_includedir}/xorg
517 %{_libdir}/libxf86config.a
518 %{_aclocaldir}/xorg-server.m4
519 %{_pkgconfigdir}/xorg-server.pc
520
521 %files -n xorg-xserver-libdri
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
524
525 %files -n xorg-xserver-libglx
526 %defattr(644,root,root,755)
527 %if %{with multigl}
528 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
529 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
530 %else
531 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
532 %endif
This page took 0.068441 seconds and 4 git commands to generate.