]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
f686760ae28e2270ef4452cea4c39a28a456c645
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
5 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
6 %bcond_with     hal             # HAL support for configuration (if no udev)
7 %bcond_without  udev            # UDEV support for configuration
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  dmx             # DMX support
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       6.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        11.0
20 %define xorg_xserver_server_xinput_abi          13.0
21
22 %define         rel     1
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.11.1
27 Release:        %{rel}%{?with_multigl:.mgl}
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  4cdf54dc569b6a5548257c93a45dcd3d
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Patch0:         %{name}-xwrapper.patch
37 Patch1:         %{name}-pic-libxf86config.patch
38 Patch2:         %{name}-fb-size.patch
39 Patch3:         %{name}-less-acpi-brokenness.patch
40 Patch4:         %{name}-builtin-SHA1.patch
41 URL:            http://xorg.freedesktop.org/
42 BuildRequires:  Mesa-libGL-devel >= 7.8.1
43 # for glx headers
44 BuildRequires:  OpenGL-GLX-devel
45 %{?with_xselinux:BuildRequires: audit-libs-devel}
46 BuildRequires:  autoconf >= 2.57
47 BuildRequires:  automake
48 BuildRequires:  cpp
49 BuildRequires:  docbook-dtd43-xml
50 #BuildRequires: doxygen >= 1.6.1
51 %if %{with hal} || %{with dbus}
52 BuildRequires:  dbus-devel >= 1.0
53 %endif
54 %{?with_hal:BuildRequires:      hal-devel}
55 BuildRequires:  libdrm-devel >= 2.4.5
56 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
57 BuildRequires:  libtool
58 BuildRequires:  ncurses-devel
59 BuildRequires:  pam-devel
60 BuildRequires:  perl-base
61 BuildRequires:  pixman-devel >= 0.22.0
62 BuildRequires:  pkgconfig >= 1:0.19
63 BuildRequires:  udev-devel >= 1:143
64 BuildRequires:  xmlto >= 0.0.20
65 BuildRequires:  xorg-app-mkfontscale
66 BuildRequires:  xorg-font-font-util >= 1.1
67 BuildRequires:  xorg-lib-libX11-devel
68 BuildRequires:  xorg-lib-libXau-devel
69 BuildRequires:  xorg-lib-libXaw-devel
70 BuildRequires:  xorg-lib-libXdamage-devel
71 BuildRequires:  xorg-lib-libXdmcp-devel
72 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
73 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
74 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
75 BuildRequires:  xorg-lib-libXmu-devel
76 BuildRequires:  xorg-lib-libXpm-devel
77 BuildRequires:  xorg-lib-libXrender-devel
78 BuildRequires:  xorg-lib-libXres-devel
79 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
80 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
81 BuildRequires:  xorg-lib-libXv-devel
82 BuildRequires:  xorg-lib-libXxf86dga-devel
83 BuildRequires:  xorg-lib-libXxf86misc-devel
84 BuildRequires:  xorg-lib-libXxf86vm-devel
85 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
86 BuildRequires:  xorg-lib-libfontenc-devel
87 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
88 BuildRequires:  xorg-lib-libxkbfile-devel
89 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
90 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
91 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
92 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
93 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
94 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
95 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
96 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
97 BuildRequires:  xorg-proto-fontcacheproto-devel
98 BuildRequires:  xorg-proto-fontsproto-devel
99 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
100 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
101 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
102 BuildRequires:  xorg-proto-printproto-devel
103 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
104 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
105 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
106 BuildRequires:  xorg-proto-resourceproto-devel
107 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
108 BuildRequires:  xorg-proto-videoproto-devel
109 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
110 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
111 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
112 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
113 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
114 BuildRequires:  xorg-proto-xf86miscproto-devel
115 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
116 BuildRequires:  xorg-proto-xineramaproto-devel
117 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
118 BuildRequires:  xorg-sgml-doctools >= 1.8
119 BuildRequires:  xorg-util-util-macros >= 1.14
120 #BR: xcalibrateproto, tslib (for KDRIVE only)
121 Requires(triggerpostun):        sed >= 4.0
122 Requires:       pixman >= 0.22.0
123 Requires:       xkeyboard-config
124 # for rgb.txt
125 Requires:       xorg-app-rgb >= 0.99.3
126 Requires:       xorg-app-xkbcomp
127 %{?with_hal:Suggests:   hal}
128 Suggests:       udev-acl >= 1:143
129 %{?with_udev:Suggests:  udev-core >= 1:143}
130 Suggests:       xorg-driver-input-evdev
131 # xserver requires fixed and cursor fonts
132 Requires:       xorg-font-font-alias
133 Requires:       xorg-font-font-cursor-misc
134 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
135 Suggests:       dbus-x11 >= 1.0
136 Suggests:       xkeyboard-config
137 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
138 Suggests:       xorg-driver-video
139 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
140 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
141 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
142 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
143 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
144 Obsoletes:      X11-Xserver < 1:7.0.0
145 Obsoletes:      X11-driver-i2c < 1:7.0.0
146 Obsoletes:      X11-modules < 1:7.0.0
147 Obsoletes:      X11-setup < 1:7.0.0
148 Obsoletes:      XFree86-Xserver < 1:7.0.0
149 Obsoletes:      XFree86-modules < 1:7.0.0
150 Obsoletes:      XFree86-setup < 1:7.0.0
151 Obsoletes:      Xserver
152 Obsoletes:      xorg-xserver-server-xorgcfg
153 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
154
155 # avoid self-dependencies on included modules
156 %define         _noautoreq      libscanpci.so libxf1bpp.so
157
158 %if %{with multigl}
159 # executable Xorg provides symbols this library:
160 %define         skip_post_check_so      libglx.so.*
161 %endif
162
163 %description
164 Xorg server is a generally used X server which uses display hardware.
165 It requires proper driver for your display hardware.
166
167 %description -l pl.UTF-8
168 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
169 graficznej. Do działania wymaga odpowiedniego sterownika.
170
171 %package -n xorg-xserver-Xdmx
172 Summary:        Xdmx - distributed multi-head X server
173 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
174 Group:          X11/Servers
175
176 %description -n xorg-xserver-Xdmx
177 Xdmx - distributed multi-head X server.
178
179 %description -n xorg-xserver-Xdmx -l pl.UTF-8
180 Xdmx - rozproszony, wielomonitorowy serwer X.
181
182 %package -n xorg-xserver-Xnest
183 Summary:        Xnest - nested X server
184 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
185 Group:          X11/Servers
186 Obsoletes:      X11-Xnest < 1:7.0.0
187 Obsoletes:      XFree86-Xnest < 1:7.0.0
188 Obsoletes:      Xserver-Xnest
189
190 %description -n xorg-xserver-Xnest
191 Xnest is an X Window System server which runs in an X window. Xnest is
192 a 'nested' window server, actually a client of the real X server,
193 which manages windows and graphics requests for Xnest, while Xnest
194 manages the windows and graphics requests for its own clients.
195
196 %description -n xorg-xserver-Xnest -l pl.UTF-8
197 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
198 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
199 serwer X dla własnych klientów.
200
201 %description -n xorg-xserver-Xnest -l ru.UTF-8
202 Xnest - это сервер X Window System, который работает в окне X. На
203 самом деле это клиент реального X-сервера, который управляет окнами и
204 графическими запросами для Xnest в то время, как Xnest управляет
205 окнами и графическими запросами для своих собственных клиентов.
206
207 %description -n xorg-xserver-Xnest -l uk.UTF-8
208 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
209 клієнт реального X-сервера, який керує вікнами та графічними запитами
210 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
211 своїх власних клієнтів.
212
213 %package -n xorg-xserver-Xephyr
214 Summary:        Xephyr - nested X server
215 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
216 Group:          X11/Servers
217 Requires:       pixman >= 0.22.0
218
219 %description -n xorg-xserver-Xephyr
220 Xephyr is a a kdrive server that outputs to a window on a pre-existing
221 'host' X display. Think Xnest but with support for modern extensions
222 like composite, damage and randr.
223
224 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
225 the host X server, Xephyr is a real X server which uses the host X
226 server window as "framebuffer" via fast SHM XImages.
227
228 It also has support for 'visually' debugging what the server is
229 painting.
230
231 %description -n xorg-xserver-Xephyr -l pl.UTF-8
232 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
233 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
234 wspólczesnych rozszerzeń jak composite, damage i randr.
235
236 %package -n xorg-xserver-Xfbdev
237 Summary:        Xfbdev - Linux framebuffer device X server
238 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
239 Group:          X11/Servers
240
241 %description -n xorg-xserver-Xfbdev
242 Xfbdev is a Linux framebuffer device X server based on the kdrive X
243 server.
244
245 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
246 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
247
248 %package -n xorg-xserver-Xvfb
249 Summary:        Xvfb - virtual framebuffer X server
250 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
251 Group:          X11/Servers
252 # requires fixed and cursor fonts
253 Requires:       xorg-font-font-alias
254 Requires:       xorg-font-font-cursor-misc
255 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
256 Obsoletes:      X11-Xvfb < 1:7.0.0
257 Obsoletes:      XFree86-Xvfb < 1:7.0.0
258
259 %description -n xorg-xserver-Xvfb
260 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
261 capable of running on machines with no display hardware and no
262 physical input devices. Xvfb emulates a dumb framebuffer using virtual
263 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
264 display. Xvfb is normally used for testing servers. Using Xvfb, the
265 mfb or cfb code for any depth can be exercised without using real
266 hardware that supports the desired depths. Xvfb has also been used to
267 test X clients against unusual depths and screen configurations, to do
268 batch processing with Xvfb as a background rendering engine, to do
269 load testing, to help with porting an X server to a new platform, and
270 to provide an unobtrusive way of running applications which really
271 don't need an X server but insist on having one.
272
273 %description -n xorg-xserver-Xvfb -l pl.UTF-8
274 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
275 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
276 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
277 używany do testowania serwerów X, może też być używany do testowania
278 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
279 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
280 serwera X, ale odmawiają uruchomienia bez niego.
281
282 %package -n xorg-xserver-Xvfb-init
283 Summary:        Init scripts for Xvfb
284 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
285 Group:          X11/Servers
286 Requires:       xorg-xserver-Xvfb
287
288 %description -n xorg-xserver-Xvfb-init
289 This package contains init scripts for Xvfb and registers Xvfb as
290 system service.
291
292 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
293 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
294 usługę systemową.
295
296 %package devel
297 Summary:        Header files for X.org server
298 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
299 Group:          X11/Development/Libraries
300 Requires:       libdrm-devel >= 2.4.5
301 Requires:       pixman-devel >= 0.22.0
302 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
303 Requires:       xorg-lib-libxkbfile-devel
304 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
305 Requires:       xorg-proto-fontsproto-devel
306 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
307 Requires:       xorg-proto-kbproto-devel >= 1.0.3
308 Requires:       xorg-proto-randrproto-devel >= 1.3
309 Requires:       xorg-proto-renderproto-devel >= 0.11
310 Requires:       xorg-proto-videoproto-devel
311 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
312 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
313 Requires:       xorg-proto-xineramaproto-devel
314 Requires:       xorg-proto-xproto-devel >= 7.0.22
315 Obsoletes:      X11-Xserver-devel < 1:7.0.0
316 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
317
318 %description devel
319 Header files for X.org server.
320
321 %description devel -l pl.UTF-8
322 Pliki nagłówkowe dla serwera X.org.
323
324 %package source
325 Summary:        X.org server source code
326 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
327 Group:          X11/Development/Libraries
328
329 %description source
330 X.org server source code.
331
332 %description source -l pl.UTF-8
333 Pliki źródłowe dla serwera X.org.
334
335 %package -n xorg-xserver-libdri
336 Summary:        DRI extension library for X.org server
337 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
338 Group:          X11/Servers
339 Requires:       %{name} = %{version}-%{release}
340 Provides:       xorg-xserver-module(dri)
341 %if %{without multigl}
342 Conflicts:      xorg-driver-video-fglrx
343 Conflicts:      xorg-driver-video-nvidia
344 %endif
345
346 %description -n xorg-xserver-libdri
347 DRI extension library for X.org server.
348
349 %description -n xorg-xserver-libdri -l pl.UTF-8
350 Biblioteka rozszerzenia DRI dla serwera X.org.
351
352 %package -n xorg-xserver-libglx
353 Summary:        GLX extension library for X.org server
354 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
355 Group:          X11/Servers
356 Requires:       %{name} = %{version}-%{release}
357 Requires:       xorg-xserver-libdri = %{version}-%{release}
358 # Mesa version glapi tables in glx/ dir come from
359 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
360 Provides:       xorg-xserver-module(glx)
361 Obsoletes:      X11-OpenGL-core < 1:7.0.0
362 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
363 %if %{without multigl}
364 Conflicts:      xorg-driver-video-fglrx
365 Conflicts:      xorg-driver-video-nvidia
366 %endif
367
368 %description -n xorg-xserver-libglx
369 GLX extension library for X.org server.
370
371 %description -n xorg-xserver-libglx -l pl.UTF-8
372 Biblioteka rozszerzenia GLX dla serwera X.org.
373
374 %prep
375 %setup -q -n xorg-server-%{version}
376 %patch0 -p0
377 %patch1 -p1
378 %patch2 -p1
379 %patch3 -p1
380 %patch4 -p1
381
382 # xserver uses pixman-1 API/ABI so put that explictly here
383 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
384
385 %build
386 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
387 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
388         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
389         exit 1
390 fi
391
392 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
393 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
394         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
395         exit 1
396 fi
397
398 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
399 if [ $API != %{xorg_xserver_server_font_abi} ]; then
400         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
401         exit 1
402 fi
403 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
404 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
405         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
406         exit 1
407 fi
408 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
409 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
410         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
411         exit 1
412 fi
413
414 %{__libtoolize}
415 %{__aclocal} -I m4
416 %{__autoconf}
417 %{__autoheader}
418 %{__automake}
419 %configure \
420         --with-os-name="PLD/Linux" \
421         --with-os-vendor="PLD/Team" \
422         --without-fop \
423         %{?with_dbus:--enable-config-dbus} \
424         --enable-config-hal%{!?with_hal:=no} \
425         --enable-config-udev%{!?with_udev:=no} \
426         --enable-aiglx \
427         --enable-builddocs \
428         --enable-dga \
429         %{?with_dmx:--enable-dmx} \
430         --enable-glx-tls \
431         --enable-install-libxf86config \
432         %{?with_record:--enable-record} \
433         --enable-kdrive \
434         %{?with_xcsecurity:--enable-xcsecurity} \
435         --enable-xephyr \
436         %{?with_xf86bigfont:--enable-xf86bigfont} \
437         --enable-xfbdev \
438         %{?with_xselinux:--enable-xselinux} \
439         --enable-glx-tls \
440         --disable-xfake \
441         --enable-secure-rpc \
442         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
443         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
444         --with-xkb-output=/var/lib/xkb
445
446 %{__make}
447
448 %install
449 rm -rf $RPM_BUILD_ROOT
450
451 %{__make} install \
452         DESTDIR=$RPM_BUILD_ROOT
453
454 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
455 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
456 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
457 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
458
459 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
460 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
461
462 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
463
464 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
465
466 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
467 install -d $RPM_BUILD_ROOT/etc/sysconfig
468 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
469 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
470
471 %if %{with multigl}
472 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
473 mv -f libglx.so libglx.so.%{version}
474 ln -sf libglx.so.%{version} libglx.so
475 cd -
476 %endif
477
478 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
479 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
480 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
481 %{__make} distclean
482 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
483 find -name '*.h' | xargs chmod a-x
484
485 %clean
486 rm -rf $RPM_BUILD_ROOT
487
488 %if %{with multigl}
489 %post -n xorg-xserver-libglx
490 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
491         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
492 fi
493 %endif
494
495 %triggerpostun -- xorg-xserver-server < 1.5.0
496 if [ -f /etc/X11/xorg.conf ]; then
497         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
498         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
499 %if %{without record}
500         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
501 %endif
502         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
503 fi
504
505 %post -n xorg-xserver-Xvfb-init
506 /sbin/chkconfig --add Xvfb
507 %service Xvfb restart
508
509 %preun -n xorg-xserver-Xvfb-init
510 if [ "$1" = "0" ]; then
511         %service -q Xvfb stop
512         /sbin/chkconfig --del Xvfb
513 fi
514
515 %files
516 %defattr(644,root,root,755)
517 %doc COPYING ChangeLog README
518 %attr(755,root,root) %{_bindir}/X
519 %attr(755,root,root) %{_bindir}/Xorg
520 %attr(4755,root,root) %{_bindir}/Xwrapper
521 %attr(755,root,root) %{_bindir}/cvt
522 %attr(755,root,root) %{_bindir}/gtf
523 %dir %{_libdir}/xorg
524 %{_libdir}/xorg/protocol.txt
525 %dir %{_libdir}/xorg/modules
526 %dir %{_libdir}/xorg/modules/dri
527 %dir %{_libdir}/xorg/modules/drivers
528 %dir %{_libdir}/xorg/modules/extensions
529 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
530 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
531 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
532 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
533 %dir %{_libdir}/xorg/modules/input
534 %dir %{_libdir}/xorg/modules/multimedia
535 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
536 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
537 %dir /var/lib/xkb
538 /var/lib/xkb/README.compiled
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
541 %config(missingok) /etc/security/console.apps/xserver
542 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
543 %dir /etc/X11/xorg.conf.d
544 %dir %{_datadir}/X11/xorg.conf.d
545 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
546 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
547 %{_mandir}/man1/Xorg.1x*
548 %{_mandir}/man1/Xserver.1x*
549 %{_mandir}/man1/cvt.1*
550 %{_mandir}/man1/gtf.1x*
551 %{_mandir}/man4/exa.4*
552 %{_mandir}/man4/fbdevhw.4*
553 %{_mandir}/man5/xorg.conf.5x*
554 %{_mandir}/man5/xorg.conf.d.5x
555
556 %if %{with dmx}
557 %files -n xorg-xserver-Xdmx
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/Xdmx
560 %attr(755,root,root) %{_bindir}/dmxaddinput
561 %attr(755,root,root) %{_bindir}/dmxaddscreen
562 %attr(755,root,root) %{_bindir}/dmxinfo
563 %attr(755,root,root) %{_bindir}/dmxreconfig
564 %attr(755,root,root) %{_bindir}/dmxresize
565 %attr(755,root,root) %{_bindir}/dmxrminput
566 %attr(755,root,root) %{_bindir}/dmxrmscreen
567 %attr(755,root,root) %{_bindir}/dmxtodmx
568 %attr(755,root,root) %{_bindir}/dmxwininfo
569 %attr(755,root,root) %{_bindir}/vdltodmx
570 %attr(755,root,root) %{_bindir}/xdmxconfig
571 %{_mandir}/man1/Xdmx.1x*
572 %{_mandir}/man1/dmxtodmx.1x*
573 %{_mandir}/man1/vdltodmx.1x*
574 %{_mandir}/man1/xdmxconfig.1x*
575 %endif
576
577 %files -n xorg-xserver-Xnest
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_bindir}/Xnest
580 %{_mandir}/man1/Xnest.1x*
581
582 %files -n xorg-xserver-Xephyr
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_bindir}/Xephyr
585 %{_mandir}/man1/Xephyr.1x*
586
587 %files -n xorg-xserver-Xfbdev
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/Xfbdev
590
591 %files -n xorg-xserver-Xvfb
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/Xvfb
594 %{_mandir}/man1/Xvfb.1x*
595
596 %files -n xorg-xserver-Xvfb-init
597 %defattr(644,root,root,755)
598 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
599 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
600
601 %files devel
602 %defattr(644,root,root,755)
603 %doc doc/{Xinput,Xserver-spec}.html
604 %{_includedir}/xorg
605 %{_libdir}/libxf86config.a
606 %{_libdir}/libxf86config.la
607 %{_aclocaldir}/xorg-server.m4
608 %{_pkgconfigdir}/xorg-server.pc
609
610 %files source
611 %defattr(644,root,root,755)
612 # keep file perms from install time, but have default defattr to keep adapter happy
613 %defattr(-,root,root,755)
614 %{_usrsrc}/%{name}-%{version}
615
616 %files -n xorg-xserver-libdri
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
619
620 %files -n xorg-xserver-libglx
621 %defattr(644,root,root,755)
622 %if %{with multigl}
623 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
624 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
625 %else
626 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
627 %endif
This page took 0.165413 seconds and 2 git commands to generate.