]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
e5e3e60fc6bbe45e2d9bbb632399fa227288c45f
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       10.0
24 %define xorg_xserver_server_videodrv_abi        23.0
25 %define xorg_xserver_server_xinput_abi          24.1
26
27 %define pixman_ver      0.30.0
28
29 %ifarch x32
30 %undefine       with_libunwind
31 %endif
32
33 Summary:        X.org server
34 Summary(pl.UTF-8):      Serwer X.org
35 Name:           xorg-xserver-server
36 Version:        1.19.6
37 Release:        1
38 License:        MIT
39 Group:          X11/Servers
40 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
41 # Source0-md5:  3e47777ff034a331aed2322b078694a8
42 Source1:        10-quirks.conf
43 Source2:        xserver.pamd
44 Source10:       %{name}-Xvfb.init
45 Source11:       %{name}-Xvfb.sysconfig
46 Source12:       xvfb-run.sh
47 Patch1:         %{name}-xwrapper-pam.patch
48
49 Patch4:         %{name}-builtin-SHA1.patch
50
51 Patch6:         110_nvidia_slowdow_fix.patch
52 URL:            http://xorg.freedesktop.org/
53 BuildRequires:  Mesa-libGL-devel >= 7.8.1
54 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
55 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
56 # for glx headers
57 BuildRequires:  OpenGL-GLX-devel
58 %{?with_xselinux:BuildRequires: audit-libs-devel}
59 BuildRequires:  autoconf >= 2.60
60 BuildRequires:  automake
61 BuildRequires:  cpp
62 BuildRequires:  docbook-dtd43-xml
63 #BuildRequires: doxygen >= 1.6.1
64 %if %{with hal} || %{with dbus}
65 BuildRequires:  dbus-devel >= 1.0
66 %endif
67 %{?with_hal:BuildRequires:      hal-devel}
68 BuildRequires:  libdrm-devel >= 2.4.46
69 %if %{with glamor} || %{with wayland}
70 BuildRequires:  libepoxy-devel
71 %endif
72 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
73 BuildRequires:  libtool >= 2:2.2
74 %{?with_libunwind:BuildRequires:        libunwind-devel}
75 BuildRequires:  libxcb-devel >= 1.6
76 BuildRequires:  pam-devel
77 BuildRequires:  perl-base
78 BuildRequires:  pixman-devel >= %{pixman_ver}
79 BuildRequires:  pkgconfig >= 1:0.19
80 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
81 BuildRequires:  systemd-devel >= 209
82 BuildRequires:  udev-devel >= 1:143
83 # wayland-client
84 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
85 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.1}
86 BuildRequires:  xcb-util-devel
87 BuildRequires:  xcb-util-image-devel
88 BuildRequires:  xcb-util-keysyms-devel
89 BuildRequires:  xcb-util-renderutil-devel
90 BuildRequires:  xcb-util-wm-devel
91 BuildRequires:  xmlto >= 0.0.20
92 BuildRequires:  xorg-app-mkfontscale
93 BuildRequires:  xorg-font-font-util >= 1.1
94 BuildRequires:  xorg-lib-libX11-devel >= 1.6
95 BuildRequires:  xorg-lib-libXau-devel
96 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
97 BuildRequires:  xorg-lib-libXdamage-devel
98 BuildRequires:  xorg-lib-libXdmcp-devel
99 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
100 BuildRequires:  xorg-lib-libXfixes-devel
101 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
102 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
103 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
104 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
105 BuildRequires:  xorg-lib-libXrender-devel
106 BuildRequires:  xorg-lib-libXres-devel
107 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
108 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
109 BuildRequires:  xorg-lib-libXv-devel
110 BuildRequires:  xorg-lib-libXxf86dga-devel
111 BuildRequires:  xorg-lib-libXxf86misc-devel
112 BuildRequires:  xorg-lib-libXxf86vm-devel
113 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
114 BuildRequires:  xorg-lib-libfontenc-devel
115 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
116 BuildRequires:  xorg-lib-libxkbfile-devel
117 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
118 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
119 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
120 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
121 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
122 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
123 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
124 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
125 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
126 BuildRequires:  xorg-proto-fontcacheproto-devel
127 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
128 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
129 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
130 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
131 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
132 BuildRequires:  xorg-proto-printproto-devel
133 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
134 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
135 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
136 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
137 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
138 BuildRequires:  xorg-proto-videoproto-devel
139 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
140 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
141 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
142 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
143 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
144 BuildRequires:  xorg-proto-xf86miscproto-devel
145 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
146 BuildRequires:  xorg-proto-xineramaproto-devel
147 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
148 BuildRequires:  xorg-sgml-doctools >= 1.8
149 BuildRequires:  xorg-util-util-macros >= 1.14
150 #BR: tslib (for KDRIVE only)
151 Requires(triggerpostun):        sed >= 4.0
152 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
153 Requires:       libdrm >= 2.4.46
154 Requires:       pixman >= %{pixman_ver}
155 Requires:       udev-libs >= 1:143
156 Requires:       xkeyboard-config
157 # for rgb.txt
158 Requires:       xorg-app-rgb >= 0.99.3
159 Requires:       xorg-app-xkbcomp
160 Requires:       xorg-lib-libXfont2 >= 2.0.0
161 Requires:       xorg-lib-libpciaccess >= 0.12.901
162 Requires:       xorg-lib-libxshmfence >= 1.1
163 Suggests:       dbus-x11 >= 1.0
164 %{?with_hal:Suggests:   hal}
165 Suggests:       udev-acl >= 1:143
166 %{?with_udev:Suggests:  udev-core >= 1:143}
167 Suggests:       xkeyboard-config
168 Suggests:       xorg-driver-input-libinput
169 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
170 Suggests:       xorg-driver-video
171 Provides:       xorg-driver-video-modesetting
172 Provides:       xorg-xserver-libdri = %{version}-%{release}
173 Provides:       xorg-xserver-module(dri)
174 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
175 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
176 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
177 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
178 Obsoletes:      X11-Xserver < 1:7.0.0
179 Obsoletes:      X11-driver-i2c < 1:7.0.0
180 Obsoletes:      X11-modules < 1:7.0.0
181 Obsoletes:      X11-setup < 1:7.0.0
182 Obsoletes:      XFree86-Xserver < 1:7.0.0
183 Obsoletes:      XFree86-modules < 1:7.0.0
184 Obsoletes:      XFree86-setup < 1:7.0.0
185 Obsoletes:      Xserver
186 %{?with_glamor:Obsoletes:       glamor}
187 Obsoletes:      xorg-xserver-libdri
188 Obsoletes:      xorg-xserver-server-xorgcfg
189 Obsoletes:      xorg-driver-video-modesetting
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 %description
193 Xorg server is a generally used X server which uses display hardware.
194 It requires proper driver for your display hardware.
195
196 %description -l pl.UTF-8
197 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
198 graficznej. Do działania wymaga odpowiedniego sterownika.
199
200 %package -n xorg-xserver-Xdmx
201 Summary:        Xdmx - distributed multi-head X server
202 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
203 Group:          X11/Servers
204 Requires:       pixman >= %{pixman_ver}
205 Requires:       xorg-lib-libX11 >= 1.6
206 Requires:       xorg-lib-libXext >= 1.0.99.4
207 Requires:       xorg-lib-libXfont2 >= 2.0.0
208 Requires:       xorg-lib-libXi >= 1.2.99.1
209 Requires:       xorg-lib-libdmx >= 1.0.99.1
210
211 %description -n xorg-xserver-Xdmx
212 Xdmx - distributed multi-head X server.
213
214 %description -n xorg-xserver-Xdmx -l pl.UTF-8
215 Xdmx - rozproszony, wielomonitorowy serwer X.
216
217 %package -n xorg-xserver-Xnest
218 Summary:        Xnest - nested X server
219 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
220 Group:          X11/Servers
221 Requires:       pixman >= %{pixman_ver}
222 Requires:       xorg-lib-libXext >= 1.0.99.4
223 Requires:       xorg-lib-libXfont2 >= 2.0.0
224 Obsoletes:      X11-Xnest < 1:7.0.0
225 Obsoletes:      XFree86-Xnest < 1:7.0.0
226 Obsoletes:      Xserver-Xnest
227
228 %description -n xorg-xserver-Xnest
229 Xnest is an X Window System server which runs in an X window. Xnest is
230 a 'nested' window server, actually a client of the real X server,
231 which manages windows and graphics requests for Xnest, while Xnest
232 manages the windows and graphics requests for its own clients.
233
234 %description -n xorg-xserver-Xnest -l pl.UTF-8
235 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
236 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
237 serwer X dla własnych klientów.
238
239 %description -n xorg-xserver-Xnest -l ru.UTF-8
240 Xnest - это сервер X Window System, который работает в окне X. На
241 самом деле это клиент реального X-сервера, который управляет окнами и
242 графическими запросами для Xnest в то время, как Xnest управляет
243 окнами и графическими запросами для своих собственных клиентов.
244
245 %description -n xorg-xserver-Xnest -l uk.UTF-8
246 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
247 клієнт реального X-сервера, який керує вікнами та графічними запитами
248 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
249 своїх власних клієнтів.
250
251 %package -n xorg-xserver-Xephyr
252 Summary:        Xephyr - nested X server
253 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
254 Group:          X11/Servers
255 Requires:       Mesa-libGL >= 7.1.0
256 Requires:       libxcb >= 1.6
257 Requires:       pixman >= %{pixman_ver}
258 Requires:       xorg-lib-libXfont2 >= 2.0.0
259
260 %description -n xorg-xserver-Xephyr
261 Xephyr is a kdrive server that outputs to a window on a pre-existing
262 'host' X display. Think Xnest but with support for modern extensions
263 like composite, damage and randr.
264
265 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
266 the host X server, Xephyr is a real X server which uses the host X
267 server window as "framebuffer" via fast SHM XImages.
268
269 It also has support for 'visually' debugging what the server is
270 painting.
271
272 %description -n xorg-xserver-Xephyr -l pl.UTF-8
273 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
274 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
275 wspólczesnych rozszerzeń jak composite, damage i randr.
276
277 %package -n xorg-xserver-Xfbdev
278 Summary:        Xfbdev - Linux framebuffer device X server
279 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
280 Group:          X11/Servers
281 Requires:       pixman >= %{pixman_ver}
282 Requires:       xorg-lib-libXfont2 >= 2.0.0
283
284 %description -n xorg-xserver-Xfbdev
285 Xfbdev is a Linux framebuffer device X server based on the kdrive X
286 server.
287
288 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
289 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
290
291 %package -n xorg-xserver-Xvfb
292 Summary:        Xvfb - virtual framebuffer X server
293 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
294 Group:          X11/Servers
295 Requires:       Mesa-libGL >= 7.1.0
296 Requires:       mktemp
297 Requires:       pixman >= %{pixman_ver}
298 Requires:       util-linux
299 Requires:       which
300 Requires:       xkeyboard-config
301 Requires:       xorg-app-xauth
302 Requires:       xorg-app-xkbcomp
303 Requires:       xorg-lib-libXfont2 >= 2.0.0
304 Obsoletes:      X11-Xvfb < 1:7.0.0
305 Obsoletes:      XFree86-Xvfb < 1:7.0.0
306
307 %description -n xorg-xserver-Xvfb
308 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
309 capable of running on machines with no display hardware and no
310 physical input devices. Xvfb emulates a dumb framebuffer using virtual
311 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
312 display. Xvfb is normally used for testing servers. Using Xvfb, the
313 mfb or cfb code for any depth can be exercised without using real
314 hardware that supports the desired depths. Xvfb has also been used to
315 test X clients against unusual depths and screen configurations, to do
316 batch processing with Xvfb as a background rendering engine, to do
317 load testing, to help with porting an X server to a new platform, and
318 to provide an unobtrusive way of running applications which really
319 don't need an X server but insist on having one.
320
321 %description -n xorg-xserver-Xvfb -l pl.UTF-8
322 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
323 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
324 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
325 używany do testowania serwerów X, może też być używany do testowania
326 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
327 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
328 serwera X, ale odmawiają uruchomienia bez niego.
329
330 %package -n xorg-xserver-Xvfb-init
331 Summary:        Init scripts for Xvfb
332 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
333 Group:          X11/Servers
334 Requires:       xorg-xserver-Xvfb
335
336 %description -n xorg-xserver-Xvfb-init
337 This package contains init scripts for Xvfb and registers Xvfb as
338 system service.
339
340 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
341 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
342 usługę systemową.
343
344 %package -n xorg-xserver-Xwayland
345 Summary:        Xwayland - X server integrated into a Wayland window system
346 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
347 Group:          X11/Servers
348 Requires:       pixman >= %{pixman_ver}
349 Requires:       xorg-lib-libX11 >= 1.6
350 Requires:       xorg-lib-libXext >= 1.0.99.4
351 Requires:       xorg-lib-libXfont2 >= 2.0.0
352 Requires:       xorg-lib-libXi >= 1.2.99.1
353
354 %description -n xorg-xserver-Xwayland
355 Xwayland - server integrated into a Wayland window system.
356
357 %description -n xorg-xserver-Xwayland -l pl.UTF-8
358 Xwayland - serwer X integrowalny w Wayland.
359
360 %package devel
361 Summary:        Header files for X.org server
362 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
363 Group:          X11/Development/Libraries
364 Requires:       Mesa-libGL-devel >= 7.8.0
365 Requires:       libdrm-devel >= 2.4.46
366 Requires:       pixman-devel >= %{pixman_ver}
367 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
368 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
369 Requires:       xorg-lib-libxkbfile-devel
370 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
371 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
372 Requires:       xorg-proto-dri3proto-devel >= 1.0
373 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
374 Requires:       xorg-proto-glproto-devel >= 1.4.17
375 Requires:       xorg-proto-inputproto-devel >= 2.3
376 Requires:       xorg-proto-kbproto-devel >= 1.0.3
377 Requires:       xorg-proto-presentproto-devel >= 1.0
378 Requires:       xorg-proto-randrproto-devel >= 1.5.0
379 Requires:       xorg-proto-renderproto-devel >= 0.11
380 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
381 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
382 Requires:       xorg-proto-videoproto-devel
383 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
384 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
385 Requires:       xorg-proto-xineramaproto-devel
386 Requires:       xorg-proto-xproto-devel >= 7.0.31
387 Obsoletes:      X11-Xserver-devel < 1:7.0.0
388 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
389 %{?with_glamor:Obsoletes:       glamor-devel}
390
391 %description devel
392 Header files for X.org server.
393
394 %description devel -l pl.UTF-8
395 Pliki nagłówkowe dla serwera X.org.
396
397 %package source
398 Summary:        X.org server source code
399 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
400 Group:          X11/Development/Libraries
401
402 %description source
403 X.org server source code.
404
405 %description source -l pl.UTF-8
406 Pliki źródłowe dla serwera X.org.
407
408 %package -n xorg-xserver-libglx
409 Summary:        GLX extension library for X.org server
410 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
411 Group:          X11/Servers
412 Requires:       %{name} = %{version}-%{release}
413 Requires:       Mesa-libGL >= 7.1.0
414 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
415 # Mesa version glapi tables in glx/ dir come from
416 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
417 Provides:       xorg-xserver-module(glx)
418 Obsoletes:      X11-OpenGL-core < 1:7.0.0
419 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
420
421 %description -n xorg-xserver-libglx
422 GLX extension library for X.org server.
423
424 %description -n xorg-xserver-libglx -l pl.UTF-8
425 Biblioteka rozszerzenia GLX dla serwera X.org.
426
427 %prep
428 %setup -q -n xorg-server-%{version}
429 %patch1 -p1
430
431 %patch4 -p1
432
433 %patch6 -p1
434
435 # xserver uses pixman-1 API/ABI so put that explictly here
436 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
437
438 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
439 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
440
441 %build
442 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
443 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
444         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
445         exit 1
446 fi
447
448 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
449 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
450         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
451         exit 1
452 fi
453
454 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
455 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
456         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
457         exit 1
458 fi
459 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
460 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
461         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
462         exit 1
463 fi
464
465 %{__libtoolize}
466 %{__aclocal} -I m4
467 %{__autoconf}
468 %{__autoheader}
469 %{__automake}
470 %configure \
471         --libexecdir=%{_libdir}/xorg \
472         --with-os-name="PLD/Linux" \
473         --with-os-vendor="PLD/Team" \
474         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
475         --with-xkb-output=/var/lib/xkb \
476         --disable-linux-acpi \
477         --disable-linux-apm \
478         %{?with_dbus:--enable-config-dbus} \
479         --enable-config-hal%{!?with_hal:=no} \
480         --enable-config-udev%{!?with_udev:=no} \
481         --enable-dga \
482         %{?with_dmx:--enable-dmx} \
483         --enable-dri2%{!?with_dri2:=no} \
484         --enable-dri3%{!?with_dri3:=no} \
485         %{?with_glamor:--enable-glamor} \
486         --enable-kdrive \
487         %{?with_libunwind:--enable-libunwind} \
488         %{?with_record:--enable-record} \
489         --enable-secure-rpc \
490         %{?with_xcsecurity:--enable-xcsecurity} \
491         --enable-xephyr \
492         %{?with_xf86bigfont:--enable-xf86bigfont} \
493         --disable-xfake \
494         --enable-xfbdev \
495         %{?with_xselinux:--enable-xselinux} \
496         %{?with_wayland:--enable-xwayland} \
497         %{!?with_systemtap:--without-dtrace} \
498         --without-fop \
499         --enable-suid-wrapper \
500         --with-systemd-daemon
501
502 %{__make} -j1
503
504 %install
505 rm -rf $RPM_BUILD_ROOT
506
507 %if "%{_libdir}" != "%{_exec_prefix}/lib"
508 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
509 %endif
510
511 %{__make} install \
512         DESTDIR=$RPM_BUILD_ROOT
513
514 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
515 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
516 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
517 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
518 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
519
520 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
521 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
522
523 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
524
525 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
526
527 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
528 install -d $RPM_BUILD_ROOT/etc/sysconfig
529 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
530 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
531
532 # Xorg.wrap config
533 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
534 # allowed values: rootonly console anybody pam
535 allowed_users = pam
536
537 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
538 #needs_root_rights = yes
539 EOF
540
541 # compatibility with old xwrapper
542 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
543
544 # prepare source package
545 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
546 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
547 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
548 %{__make} distclean
549 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
550 find -name '*.h' | xargs chmod a-x
551
552 %if %{with systemtap}
553 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
554 %endif
555
556 %clean
557 rm -rf $RPM_BUILD_ROOT
558
559 %triggerpostun -- xorg-xserver-server < 1.5.0
560 if [ -f /etc/X11/xorg.conf ]; then
561         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
562         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
563 %if %{without record}
564         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
565 %endif
566         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
567 fi
568
569 %post -n xorg-xserver-Xvfb-init
570 /sbin/chkconfig --add Xvfb
571 %service Xvfb restart
572
573 %preun -n xorg-xserver-Xvfb-init
574 if [ "$1" = "0" ]; then
575         %service -q Xvfb stop
576         /sbin/chkconfig --del Xvfb
577 fi
578
579 %files
580 %defattr(644,root,root,755)
581 %doc COPYING ChangeLog README
582 %attr(755,root,root) %{_bindir}/X
583 %attr(755,root,root) %{_bindir}/Xorg
584 %attr(4755,root,root) %{_bindir}/Xwrapper
585 %attr(755,root,root) %{_bindir}/cvt
586 %attr(755,root,root) %{_bindir}/gtf
587 %dir %{_libdir}/xorg
588 %{_libdir}/xorg/protocol.txt
589 %attr(755,root,root) %{_libdir}/xorg/Xorg
590 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
591 %dir %{_libdir}/xorg/modules
592 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
594 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
595 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
596 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
599 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
600 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
601 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
602 %dir %{_libdir}/xorg/modules/dri
603 %dir %{_libdir}/xorg/modules/drivers
604 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
605 %dir %{_libdir}/xorg/modules/extensions
606 %dir %{_libdir}/xorg/modules/input
607 %if "%{_libdir}" != "%{_exec_prefix}/lib"
608 %dir %{_exec_prefix}/lib/xorg
609 %dir %{_exec_prefix}/lib/xorg/modules
610 %dir %{_exec_prefix}/lib/xorg/modules/dri
611 %endif
612 %dir /var/lib/xkb
613 /var/lib/xkb/README.compiled
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
616 %config(missingok) /etc/security/console.apps/xserver
617 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
618 %dir /etc/X11/xorg.conf.d
619 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
620 %dir %{_datadir}/X11/xorg.conf.d
621 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
622 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
623 %{_mandir}/man1/Xorg.1*
624 %{_mandir}/man1/Xorg.wrap.1*
625 %{_mandir}/man1/Xserver.1*
626 %{_mandir}/man1/cvt.1*
627 %{_mandir}/man1/gtf.1*
628 %{_mandir}/man4/exa.4*
629 %{_mandir}/man4/fbdevhw.4*
630 %{_mandir}/man4/modesetting.4*
631 %{_mandir}/man5/Xwrapper.config.5*
632 %{_mandir}/man5/xorg.conf.5*
633 %{_mandir}/man5/xorg.conf.d.5*
634
635 %if %{with dmx}
636 %files -n xorg-xserver-Xdmx
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/Xdmx
639 %attr(755,root,root) %{_bindir}/dmxaddinput
640 %attr(755,root,root) %{_bindir}/dmxaddscreen
641 %attr(755,root,root) %{_bindir}/dmxinfo
642 %attr(755,root,root) %{_bindir}/dmxreconfig
643 %attr(755,root,root) %{_bindir}/dmxresize
644 %attr(755,root,root) %{_bindir}/dmxrminput
645 %attr(755,root,root) %{_bindir}/dmxrmscreen
646 %attr(755,root,root) %{_bindir}/dmxtodmx
647 %attr(755,root,root) %{_bindir}/dmxwininfo
648 %attr(755,root,root) %{_bindir}/vdltodmx
649 %attr(755,root,root) %{_bindir}/xdmxconfig
650 %{_mandir}/man1/Xdmx.1*
651 %{_mandir}/man1/dmxtodmx.1*
652 %{_mandir}/man1/vdltodmx.1*
653 %{_mandir}/man1/xdmxconfig.1*
654 %endif
655
656 %files -n xorg-xserver-Xnest
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_bindir}/Xnest
659 %{_mandir}/man1/Xnest.1*
660
661 %files -n xorg-xserver-Xephyr
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/Xephyr
664 %{_mandir}/man1/Xephyr.1*
665
666 %files -n xorg-xserver-Xfbdev
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/Xfbdev
669
670 %files -n xorg-xserver-Xvfb
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/Xvfb
673 %attr(755,root,root) %{_bindir}/xvfb-run
674 %{_mandir}/man1/Xvfb.1*
675
676 %files -n xorg-xserver-Xvfb-init
677 %defattr(644,root,root,755)
678 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
679 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
680
681 %if %{with wayland}
682 %files -n xorg-xserver-Xwayland
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/Xwayland
685 %endif
686
687 %files devel
688 %defattr(644,root,root,755)
689 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
690 %{_includedir}/xorg
691 %{_aclocaldir}/xorg-server.m4
692 %{_pkgconfigdir}/xorg-server.pc
693
694 %files source
695 %defattr(644,root,root,755)
696 # keep file perms from install time, but have default defattr to keep adapter happy
697 %defattr(-,root,root,755)
698 %{_usrsrc}/%{name}-%{version}
699
700 %files -n xorg-xserver-libglx
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.070186 seconds and 3 git commands to generate.