]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- up to 1.19.0
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       10.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        23.0
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.19.0
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  6a4d01e4e5047ab8f556960424ba1fa9
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49 Patch2:         dtrace-link.patch
50
51 Patch4:         %{name}-builtin-SHA1.patch
52
53 Patch6:         110_nvidia_slowdow_fix.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel >= 209
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 BuildRequires:  xcb-util-devel
88 BuildRequires:  xcb-util-image-devel
89 BuildRequires:  xcb-util-keysyms-devel
90 BuildRequires:  xcb-util-renderutil-devel
91 BuildRequires:  xcb-util-wm-devel
92 BuildRequires:  xmlto >= 0.0.20
93 BuildRequires:  xorg-app-mkfontscale
94 BuildRequires:  xorg-font-font-util >= 1.1
95 BuildRequires:  xorg-lib-libX11-devel >= 1.6
96 BuildRequires:  xorg-lib-libXau-devel
97 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
98 BuildRequires:  xorg-lib-libXdamage-devel
99 BuildRequires:  xorg-lib-libXdmcp-devel
100 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
101 BuildRequires:  xorg-lib-libXfixes-devel
102 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
103 BuildRequires:  xorg-lib-libXfont2-devel
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
106 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
107 BuildRequires:  xorg-lib-libXrender-devel
108 BuildRequires:  xorg-lib-libXres-devel
109 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
110 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
111 BuildRequires:  xorg-lib-libXv-devel
112 BuildRequires:  xorg-lib-libXxf86dga-devel
113 BuildRequires:  xorg-lib-libXxf86misc-devel
114 BuildRequires:  xorg-lib-libXxf86vm-devel
115 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
116 BuildRequires:  xorg-lib-libfontenc-devel
117 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
118 BuildRequires:  xorg-lib-libxkbfile-devel
119 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
120 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
121 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
122 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
123 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
124 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
125 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
126 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
127 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
128 BuildRequires:  xorg-proto-fontcacheproto-devel
129 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
130 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
131 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
132 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
133 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
134 BuildRequires:  xorg-proto-printproto-devel
135 BuildRequires:  xorg-proto-randrproto-devel >= 1.5.0
136 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
137 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
138 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
139 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
140 BuildRequires:  xorg-proto-videoproto-devel
141 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
142 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
143 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
144 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
145 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
146 BuildRequires:  xorg-proto-xf86miscproto-devel
147 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
148 BuildRequires:  xorg-proto-xineramaproto-devel
149 BuildRequires:  xorg-proto-xproto-devel >= 7.0.28
150 BuildRequires:  xorg-sgml-doctools >= 1.8
151 BuildRequires:  xorg-util-util-macros >= 1.14
152 #BR: tslib (for KDRIVE only)
153 Requires(triggerpostun):        sed >= 4.0
154 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
155 Requires:       libdrm >= 2.4.46
156 Requires:       pixman >= %{pixman_ver}
157 Requires:       udev-libs >= 1:143
158 Requires:       xkeyboard-config
159 # for rgb.txt
160 Requires:       xorg-app-rgb >= 0.99.3
161 Requires:       xorg-app-xkbcomp
162 Requires:       xorg-lib-libXfont >= 1.4.2
163 Requires:       xorg-lib-libpciaccess >= 0.12.901
164 Requires:       xorg-lib-libxshmfence >= 1.1
165 Suggests:       dbus-x11 >= 1.0
166 %{?with_hal:Suggests:   hal}
167 Suggests:       udev-acl >= 1:143
168 %{?with_udev:Suggests:  udev-core >= 1:143}
169 Suggests:       xkeyboard-config
170 Suggests:       xorg-driver-input-evdev
171 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
172 Suggests:       xorg-driver-video
173 Provides:       xorg-xserver-libdri = %{version}-%{release}
174 Provides:       xorg-xserver-module(dri)
175 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
176 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
177 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
178 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
179 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
180 Obsoletes:      X11-Xserver < 1:7.0.0
181 Obsoletes:      X11-driver-i2c < 1:7.0.0
182 Obsoletes:      X11-modules < 1:7.0.0
183 Obsoletes:      X11-setup < 1:7.0.0
184 Obsoletes:      XFree86-Xserver < 1:7.0.0
185 Obsoletes:      XFree86-modules < 1:7.0.0
186 Obsoletes:      XFree86-setup < 1:7.0.0
187 Obsoletes:      Xserver
188 %{?with_glamor:Obsoletes:       glamor}
189 Obsoletes:      xorg-xserver-libdri
190 Obsoletes:      xorg-xserver-server-xorgcfg
191 Obsoletes:      xorg-driver-video-modesetting
192 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
193
194 # avoid self-dependencies on included modules
195 %define         _noautoreq      libscanpci.so libxf1bpp.so
196
197 %description
198 Xorg server is a generally used X server which uses display hardware.
199 It requires proper driver for your display hardware.
200
201 %description -l pl.UTF-8
202 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
203 graficznej. Do działania wymaga odpowiedniego sterownika.
204
205 %package -n xorg-xserver-Xdmx
206 Summary:        Xdmx - distributed multi-head X server
207 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
208 Group:          X11/Servers
209 Requires:       pixman >= %{pixman_ver}
210 Requires:       xorg-lib-libX11 >= 1.6
211 Requires:       xorg-lib-libXext >= 1.0.99.4
212 Requires:       xorg-lib-libXfont >= 1.4.2
213 Requires:       xorg-lib-libXi >= 1.2.99.1
214 Requires:       xorg-lib-libdmx >= 1.0.99.1
215
216 %description -n xorg-xserver-Xdmx
217 Xdmx - distributed multi-head X server.
218
219 %description -n xorg-xserver-Xdmx -l pl.UTF-8
220 Xdmx - rozproszony, wielomonitorowy serwer X.
221
222 %package -n xorg-xserver-Xnest
223 Summary:        Xnest - nested X server
224 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
225 Group:          X11/Servers
226 Requires:       pixman >= %{pixman_ver}
227 Requires:       xorg-lib-libXext >= 1.0.99.4
228 Requires:       xorg-lib-libXfont >= 1.4.2
229 Obsoletes:      X11-Xnest < 1:7.0.0
230 Obsoletes:      XFree86-Xnest < 1:7.0.0
231 Obsoletes:      Xserver-Xnest
232
233 %description -n xorg-xserver-Xnest
234 Xnest is an X Window System server which runs in an X window. Xnest is
235 a 'nested' window server, actually a client of the real X server,
236 which manages windows and graphics requests for Xnest, while Xnest
237 manages the windows and graphics requests for its own clients.
238
239 %description -n xorg-xserver-Xnest -l pl.UTF-8
240 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
241 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
242 serwer X dla własnych klientów.
243
244 %description -n xorg-xserver-Xnest -l ru.UTF-8
245 Xnest - это сервер X Window System, который работает в окне X. На
246 самом деле это клиент реального X-сервера, который управляет окнами и
247 графическими запросами для Xnest в то время, как Xnest управляет
248 окнами и графическими запросами для своих собственных клиентов.
249
250 %description -n xorg-xserver-Xnest -l uk.UTF-8
251 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
252 клієнт реального X-сервера, який керує вікнами та графічними запитами
253 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
254 своїх власних клієнтів.
255
256 %package -n xorg-xserver-Xephyr
257 Summary:        Xephyr - nested X server
258 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
259 Group:          X11/Servers
260 Requires:       Mesa-libGL >= 7.1.0
261 Requires:       libxcb >= 1.6
262 Requires:       pixman >= %{pixman_ver}
263 Requires:       xorg-lib-libXfont >= 1.4.2
264
265 %description -n xorg-xserver-Xephyr
266 Xephyr is a kdrive server that outputs to a window on a pre-existing
267 'host' X display. Think Xnest but with support for modern extensions
268 like composite, damage and randr.
269
270 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
271 the host X server, Xephyr is a real X server which uses the host X
272 server window as "framebuffer" via fast SHM XImages.
273
274 It also has support for 'visually' debugging what the server is
275 painting.
276
277 %description -n xorg-xserver-Xephyr -l pl.UTF-8
278 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
279 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
280 wspólczesnych rozszerzeń jak composite, damage i randr.
281
282 %package -n xorg-xserver-Xfbdev
283 Summary:        Xfbdev - Linux framebuffer device X server
284 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
285 Group:          X11/Servers
286 Requires:       pixman >= %{pixman_ver}
287 Requires:       xorg-lib-libXfont >= 1.4.2
288
289 %description -n xorg-xserver-Xfbdev
290 Xfbdev is a Linux framebuffer device X server based on the kdrive X
291 server.
292
293 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
294 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
295
296 %package -n xorg-xserver-Xvfb
297 Summary:        Xvfb - virtual framebuffer X server
298 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
299 Group:          X11/Servers
300 Requires:       Mesa-libGL >= 7.1.0
301 Requires:       mktemp
302 Requires:       pixman >= %{pixman_ver}
303 Requires:       util-linux
304 Requires:       which
305 Requires:       xkeyboard-config
306 Requires:       xorg-app-xauth
307 Requires:       xorg-app-xkbcomp
308 Requires:       xorg-lib-libXfont >= 1.4.2
309 Obsoletes:      X11-Xvfb < 1:7.0.0
310 Obsoletes:      XFree86-Xvfb < 1:7.0.0
311
312 %description -n xorg-xserver-Xvfb
313 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
314 capable of running on machines with no display hardware and no
315 physical input devices. Xvfb emulates a dumb framebuffer using virtual
316 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
317 display. Xvfb is normally used for testing servers. Using Xvfb, the
318 mfb or cfb code for any depth can be exercised without using real
319 hardware that supports the desired depths. Xvfb has also been used to
320 test X clients against unusual depths and screen configurations, to do
321 batch processing with Xvfb as a background rendering engine, to do
322 load testing, to help with porting an X server to a new platform, and
323 to provide an unobtrusive way of running applications which really
324 don't need an X server but insist on having one.
325
326 %description -n xorg-xserver-Xvfb -l pl.UTF-8
327 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
328 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
329 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
330 używany do testowania serwerów X, może też być używany do testowania
331 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
332 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
333 serwera X, ale odmawiają uruchomienia bez niego.
334
335 %package -n xorg-xserver-Xvfb-init
336 Summary:        Init scripts for Xvfb
337 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
338 Group:          X11/Servers
339 Requires:       xorg-xserver-Xvfb
340
341 %description -n xorg-xserver-Xvfb-init
342 This package contains init scripts for Xvfb and registers Xvfb as
343 system service.
344
345 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
346 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
347 usługę systemową.
348
349 %package -n xorg-xserver-Xwayland
350 Summary:        Xwayland - X server integrated into a Wayland window system
351 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
352 Group:          X11/Servers
353 Requires:       pixman >= %{pixman_ver}
354 Requires:       xorg-lib-libX11 >= 1.6
355 Requires:       xorg-lib-libXext >= 1.0.99.4
356 Requires:       xorg-lib-libXfont >= 1.4.2
357 Requires:       xorg-lib-libXi >= 1.2.99.1
358
359 %description -n xorg-xserver-Xwayland
360 Xwayland - server integrated into a Wayland window system.
361
362 %description -n xorg-xserver-Xwayland -l pl.UTF-8
363 Xwayland - serwer X integrowalny w Wayland.
364
365 %package devel
366 Summary:        Header files for X.org server
367 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
368 Group:          X11/Development/Libraries
369 Requires:       Mesa-libGL-devel >= 7.8.0
370 Requires:       libdrm-devel >= 2.4.46
371 Requires:       pixman-devel >= %{pixman_ver}
372 Requires:       xorg-lib-libXfont-devel
373 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
374 Requires:       xorg-lib-libxkbfile-devel
375 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
376 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
377 Requires:       xorg-proto-dri3proto-devel >= 1.0
378 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
379 Requires:       xorg-proto-glproto-devel >= 1.4.17
380 Requires:       xorg-proto-inputproto-devel >= 2.3
381 Requires:       xorg-proto-kbproto-devel >= 1.0.3
382 Requires:       xorg-proto-presentproto-devel >= 1.0
383 Requires:       xorg-proto-randrproto-devel >= 1.5.0
384 Requires:       xorg-proto-renderproto-devel >= 0.11
385 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
386 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
387 Requires:       xorg-proto-videoproto-devel
388 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
389 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
390 Requires:       xorg-proto-xineramaproto-devel
391 Requires:       xorg-proto-xproto-devel >= 7.0.28
392 Obsoletes:      X11-Xserver-devel < 1:7.0.0
393 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
394 %{?with_glamor:Obsoletes:       glamor-devel}
395
396 %description devel
397 Header files for X.org server.
398
399 %description devel -l pl.UTF-8
400 Pliki nagłówkowe dla serwera X.org.
401
402 %package source
403 Summary:        X.org server source code
404 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
405 Group:          X11/Development/Libraries
406
407 %description source
408 X.org server source code.
409
410 %description source -l pl.UTF-8
411 Pliki źródłowe dla serwera X.org.
412
413 %package -n xorg-xserver-libglx
414 Summary:        GLX extension library for X.org server
415 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
416 Group:          X11/Servers
417 Requires:       %{name} = %{version}-%{release}
418 Requires:       Mesa-libGL >= 7.1.0
419 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
420 # Mesa version glapi tables in glx/ dir come from
421 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
422 Provides:       xorg-xserver-module(glx)
423 Obsoletes:      X11-OpenGL-core < 1:7.0.0
424 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
425
426 %description -n xorg-xserver-libglx
427 GLX extension library for X.org server.
428
429 %description -n xorg-xserver-libglx -l pl.UTF-8
430 Biblioteka rozszerzenia GLX dla serwera X.org.
431
432 %prep
433 %setup -q -n xorg-server-%{version}
434 %patch1 -p1
435 %patch2 -p1
436
437 %patch4 -p1
438
439 %patch6 -p1
440
441 # xserver uses pixman-1 API/ABI so put that explictly here
442 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
443
444 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
445 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
446
447 %build
448 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
449 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
450         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
451         exit 1
452 fi
453
454 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
455 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
456         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
457         exit 1
458 fi
459
460 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
461 if [ $API != %{xorg_xserver_server_font_abi} ]; then
462         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
463         exit 1
464 fi
465 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
466 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
467         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
468         exit 1
469 fi
470 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
471 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
472         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
473         exit 1
474 fi
475
476 %{__libtoolize}
477 %{__aclocal} -I m4
478 %{__autoconf}
479 %{__autoheader}
480 %{__automake}
481 %configure \
482         --libexecdir=%{_libdir}/xorg \
483         --with-os-name="PLD/Linux" \
484         --with-os-vendor="PLD/Team" \
485         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
486         --with-xkb-output=/var/lib/xkb \
487         --disable-linux-acpi \
488         --disable-linux-apm \
489         --enable-aiglx \
490         %{?with_dbus:--enable-config-dbus} \
491         --enable-config-hal%{!?with_hal:=no} \
492         --enable-config-udev%{!?with_udev:=no} \
493         --enable-dga \
494         %{?with_dmx:--enable-dmx} \
495         --enable-dri2%{!?with_dri2:=no} \
496         --enable-dri3%{!?with_dri3:=no} \
497         %{?with_glamor:--enable-glamor} \
498         --enable-kdrive \
499         %{?with_libunwind:--enable-libunwind} \
500         %{?with_record:--enable-record} \
501         --enable-secure-rpc \
502         %{?with_xcsecurity:--enable-xcsecurity} \
503         --enable-xephyr \
504         %{?with_xf86bigfont:--enable-xf86bigfont} \
505         --disable-xfake \
506         --enable-xfbdev \
507         %{?with_xselinux:--enable-xselinux} \
508         %{?with_wayland:--enable-xwayland} \
509         %{!?with_systemtap:--without-dtrace} \
510         --without-fop \
511         --enable-suid-wrapper \
512         --with-systemd-daemon
513
514 %{__make} -j1
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518
519 %if "%{_libdir}" != "%{_exec_prefix}/lib"
520 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
521 %endif
522
523 %{__make} install \
524         DESTDIR=$RPM_BUILD_ROOT
525
526 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
527 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
528 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
529 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
530 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
531
532 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
533 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
534
535 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
536
537 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
538
539 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
540 install -d $RPM_BUILD_ROOT/etc/sysconfig
541 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
542 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
543
544 # Xorg.wrap config
545 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
546 # allowed values: rootonly console anybody pam
547 allowed_users = pam
548
549 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
550 #needs_root_rights = yes
551 EOF
552
553 # compatibility with old xwrapper
554 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
555
556 # prepare source package
557 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
558 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
559 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
560 %{__make} distclean
561 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
562 find -name '*.h' | xargs chmod a-x
563
564 %if %{with systemtap}
565 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
566 %endif
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %triggerpostun -- xorg-xserver-server < 1.5.0
572 if [ -f /etc/X11/xorg.conf ]; then
573         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
574         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
575 %if %{without record}
576         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
577 %endif
578         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
579 fi
580
581 %post -n xorg-xserver-Xvfb-init
582 /sbin/chkconfig --add Xvfb
583 %service Xvfb restart
584
585 %preun -n xorg-xserver-Xvfb-init
586 if [ "$1" = "0" ]; then
587         %service -q Xvfb stop
588         /sbin/chkconfig --del Xvfb
589 fi
590
591 %files
592 %defattr(644,root,root,755)
593 %doc COPYING ChangeLog README
594 %attr(755,root,root) %{_bindir}/X
595 %attr(755,root,root) %{_bindir}/Xorg
596 %attr(4755,root,root) %{_bindir}/Xwrapper
597 %attr(755,root,root) %{_bindir}/cvt
598 %attr(755,root,root) %{_bindir}/gtf
599 %dir %{_libdir}/xorg
600 %{_libdir}/xorg/protocol.txt
601 %attr(755,root,root) %{_libdir}/xorg/Xorg
602 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
603 %dir %{_libdir}/xorg/modules
604 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
605 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
607 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
608 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
612 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
613 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
614 %dir %{_libdir}/xorg/modules/dri
615 %dir %{_libdir}/xorg/modules/drivers
616 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
617 %dir %{_libdir}/xorg/modules/extensions
618 %dir %{_libdir}/xorg/modules/input
619 %if "%{_libdir}" != "%{_exec_prefix}/lib"
620 %dir %{_exec_prefix}/lib/xorg
621 %dir %{_exec_prefix}/lib/xorg/modules
622 %dir %{_exec_prefix}/lib/xorg/modules/dri
623 %endif
624 %dir /var/lib/xkb
625 /var/lib/xkb/README.compiled
626 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
627 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
628 %config(missingok) /etc/security/console.apps/xserver
629 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
630 %dir /etc/X11/xorg.conf.d
631 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
632 %dir %{_datadir}/X11/xorg.conf.d
633 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
634 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
635 %{_mandir}/man1/Xorg.1*
636 %{_mandir}/man1/Xorg.wrap.1*
637 %{_mandir}/man1/Xserver.1*
638 %{_mandir}/man1/cvt.1*
639 %{_mandir}/man1/gtf.1*
640 %{_mandir}/man4/exa.4*
641 %{_mandir}/man4/fbdevhw.4*
642 %{_mandir}/man4/modesetting.4*
643 %{_mandir}/man5/Xwrapper.config.5*
644 %{_mandir}/man5/xorg.conf.5*
645 %{_mandir}/man5/xorg.conf.d.5*
646
647 %if %{with dmx}
648 %files -n xorg-xserver-Xdmx
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/Xdmx
651 %attr(755,root,root) %{_bindir}/dmxaddinput
652 %attr(755,root,root) %{_bindir}/dmxaddscreen
653 %attr(755,root,root) %{_bindir}/dmxinfo
654 %attr(755,root,root) %{_bindir}/dmxreconfig
655 %attr(755,root,root) %{_bindir}/dmxresize
656 %attr(755,root,root) %{_bindir}/dmxrminput
657 %attr(755,root,root) %{_bindir}/dmxrmscreen
658 %attr(755,root,root) %{_bindir}/dmxtodmx
659 %attr(755,root,root) %{_bindir}/dmxwininfo
660 %attr(755,root,root) %{_bindir}/vdltodmx
661 %attr(755,root,root) %{_bindir}/xdmxconfig
662 %{_mandir}/man1/Xdmx.1*
663 %{_mandir}/man1/dmxtodmx.1*
664 %{_mandir}/man1/vdltodmx.1*
665 %{_mandir}/man1/xdmxconfig.1*
666 %endif
667
668 %files -n xorg-xserver-Xnest
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/Xnest
671 %{_mandir}/man1/Xnest.1*
672
673 %files -n xorg-xserver-Xephyr
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/Xephyr
676 %{_mandir}/man1/Xephyr.1*
677
678 %files -n xorg-xserver-Xfbdev
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_bindir}/Xfbdev
681
682 %files -n xorg-xserver-Xvfb
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_bindir}/Xvfb
685 %attr(755,root,root) %{_bindir}/xvfb-run
686 %{_mandir}/man1/Xvfb.1*
687
688 %files -n xorg-xserver-Xvfb-init
689 %defattr(644,root,root,755)
690 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
691 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
692
693 %if %{with wayland}
694 %files -n xorg-xserver-Xwayland
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/Xwayland
697 %endif
698
699 %files devel
700 %defattr(644,root,root,755)
701 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
702 %{_includedir}/xorg
703 %{_aclocaldir}/xorg-server.m4
704 %{_pkgconfigdir}/xorg-server.pc
705
706 %files source
707 %defattr(644,root,root,755)
708 # keep file perms from install time, but have default defattr to keep adapter happy
709 %defattr(-,root,root,755)
710 %{_usrsrc}/%{name}-%{version}
711
712 %files -n xorg-xserver-libglx
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.096915 seconds and 3 git commands to generate.