]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
cb64fb7fb25225f42ee1fa1241839b683bedde42
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dri2            # DRI2 extension
8 %bcond_without  dmx             # DMX support
9 %bcond_without  record          # RECORD extension
10 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
11 %bcond_with     xf86bigfont     # XF86BigFont extension
12 %bcond_with     xselinux        # SELinux extension
13 #
14 # ABI versions, see hw/xfree86/common/xf86Module.h
15 %define xorg_xserver_server_ansic_abi           0.4
16 %define xorg_xserver_server_extension_abi       7.0
17 %define xorg_xserver_server_font_abi            0.6
18 %define xorg_xserver_server_videodrv_abi        14.1
19 %define xorg_xserver_server_xinput_abi          19.1
20 #
21 %define pixman_ver      0.28.0
22
23 Summary:        X.org server
24 Summary(pl.UTF-8):      Serwer X.org
25 Name:           xorg-xserver-server
26 Version:        1.14.2
27 Release:        2
28 License:        MIT
29 Group:          X11/Servers
30 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
31 # Source0-md5:  5d36a6483e8e301875131e8302c67727
32 Source1:        10-quirks.conf
33 Source2:        xserver.pamd
34 Source10:       %{name}-Xvfb.init
35 Source11:       %{name}-Xvfb.sysconfig
36 Source12:       xvfb-run.sh
37
38 Patch0:         %{name}-xwrapper.patch
39 Patch1:         %{name}-pic-libxf86config.patch
40
41 Patch3:         %{name}-less-acpi-brokenness.patch
42 Patch4:         %{name}-builtin-SHA1.patch
43 Patch5:         %{name}-export-GetMaster.patch
44 Patch6:         110_nvidia_slowdow_fix.patch
45 Patch7:         %{name}-include-defs.patch
46 URL:            http://xorg.freedesktop.org/
47 BuildRequires:  Mesa-libGL-devel >= 7.8.1
48 # for glx headers
49 BuildRequires:  OpenGL-GLX-devel
50 %{?with_xselinux:BuildRequires: audit-libs-devel}
51 BuildRequires:  autoconf >= 2.60
52 BuildRequires:  automake
53 BuildRequires:  cpp
54 BuildRequires:  docbook-dtd43-xml
55 #BuildRequires: doxygen >= 1.6.1
56 %if %{with hal} || %{with dbus}
57 BuildRequires:  dbus-devel >= 1.0
58 %endif
59 %{?with_hal:BuildRequires:      hal-devel}
60 BuildRequires:  libdrm-devel >= 2.4.39
61 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
62 BuildRequires:  libtool
63 BuildRequires:  ncurses-devel
64 BuildRequires:  pam-devel
65 BuildRequires:  perl-base
66 BuildRequires:  pixman-devel >= %{pixman_ver}
67 BuildRequires:  pkgconfig >= 1:0.19
68 BuildRequires:  udev-devel >= 1:143
69 BuildRequires:  xmlto >= 0.0.20
70 BuildRequires:  xorg-app-mkfontscale
71 BuildRequires:  xorg-font-font-util >= 1.1
72 BuildRequires:  xorg-lib-libX11-devel
73 BuildRequires:  xorg-lib-libXau-devel
74 BuildRequires:  xorg-lib-libXaw-devel
75 BuildRequires:  xorg-lib-libXdamage-devel
76 BuildRequires:  xorg-lib-libXdmcp-devel
77 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
78 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
79 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
80 BuildRequires:  xorg-lib-libXmu-devel
81 BuildRequires:  xorg-lib-libXpm-devel
82 BuildRequires:  xorg-lib-libXrender-devel
83 BuildRequires:  xorg-lib-libXres-devel
84 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
85 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
86 BuildRequires:  xorg-lib-libXv-devel
87 BuildRequires:  xorg-lib-libXxf86dga-devel
88 BuildRequires:  xorg-lib-libXxf86misc-devel
89 BuildRequires:  xorg-lib-libXxf86vm-devel
90 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
91 BuildRequires:  xorg-lib-libfontenc-devel
92 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
93 BuildRequires:  xorg-lib-libxkbfile-devel
94 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
95 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
96 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
97 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
98 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
99 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
100 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
101 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
102 BuildRequires:  xorg-proto-fontcacheproto-devel
103 BuildRequires:  xorg-proto-fontsproto-devel
104 BuildRequires:  xorg-proto-glproto-devel >= 1.4.16
105 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
106 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
107 BuildRequires:  xorg-proto-printproto-devel
108 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
109 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
110 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
111 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
112 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
113 BuildRequires:  xorg-proto-videoproto-devel
114 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
115 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
116 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
117 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
118 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
119 BuildRequires:  xorg-proto-xf86miscproto-devel
120 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
121 BuildRequires:  xorg-proto-xineramaproto-devel
122 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
123 BuildRequires:  xorg-sgml-doctools >= 1.8
124 BuildRequires:  xorg-util-util-macros >= 1.14
125 #BR: tslib (for KDRIVE only)
126 Requires(triggerpostun):        sed >= 4.0
127 Requires:       pixman >= %{pixman_ver}
128 Requires:       xkeyboard-config
129 # for rgb.txt
130 Requires:       xorg-app-rgb >= 0.99.3
131 Requires:       xorg-app-xkbcomp
132 %{?with_hal:Suggests:   hal}
133 Suggests:       udev-acl >= 1:143
134 %{?with_udev:Suggests:  udev-core >= 1:143}
135 Suggests:       xorg-driver-input-evdev
136 # xserver requires fixed and cursor fonts
137 Requires:       xorg-font-font-alias
138 Requires:       xorg-font-font-cursor-misc
139 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
140 Suggests:       dbus-x11 >= 1.0
141 Suggests:       xkeyboard-config
142 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
143 Suggests:       xorg-driver-video
144 Provides:       xorg-xserver-libdri = %{version}-%{release}
145 Provides:       xorg-xserver-module(dri)
146 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
147 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
148 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
149 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
150 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
151 Obsoletes:      X11-Xserver < 1:7.0.0
152 Obsoletes:      X11-driver-i2c < 1:7.0.0
153 Obsoletes:      X11-modules < 1:7.0.0
154 Obsoletes:      X11-setup < 1:7.0.0
155 Obsoletes:      XFree86-Xserver < 1:7.0.0
156 Obsoletes:      XFree86-modules < 1:7.0.0
157 Obsoletes:      XFree86-setup < 1:7.0.0
158 Obsoletes:      Xserver
159 Obsoletes:      xorg-xserver-libdri
160 Obsoletes:      xorg-xserver-server-xorgcfg
161 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
162
163 # avoid self-dependencies on included modules
164 %define         _noautoreq      libscanpci.so libxf1bpp.so
165
166 %description
167 Xorg server is a generally used X server which uses display hardware.
168 It requires proper driver for your display hardware.
169
170 %description -l pl.UTF-8
171 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
172 graficznej. Do działania wymaga odpowiedniego sterownika.
173
174 %package -n xorg-xserver-Xdmx
175 Summary:        Xdmx - distributed multi-head X server
176 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
177 Group:          X11/Servers
178
179 %description -n xorg-xserver-Xdmx
180 Xdmx - distributed multi-head X server.
181
182 %description -n xorg-xserver-Xdmx -l pl.UTF-8
183 Xdmx - rozproszony, wielomonitorowy serwer X.
184
185 %package -n xorg-xserver-Xnest
186 Summary:        Xnest - nested X server
187 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
188 Group:          X11/Servers
189 Obsoletes:      X11-Xnest < 1:7.0.0
190 Obsoletes:      XFree86-Xnest < 1:7.0.0
191 Obsoletes:      Xserver-Xnest
192
193 %description -n xorg-xserver-Xnest
194 Xnest is an X Window System server which runs in an X window. Xnest is
195 a 'nested' window server, actually a client of the real X server,
196 which manages windows and graphics requests for Xnest, while Xnest
197 manages the windows and graphics requests for its own clients.
198
199 %description -n xorg-xserver-Xnest -l pl.UTF-8
200 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
201 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
202 serwer X dla własnych klientów.
203
204 %description -n xorg-xserver-Xnest -l ru.UTF-8
205 Xnest - это сервер X Window System, который работает в окне X. На
206 самом деле это клиент реального X-сервера, который управляет окнами и
207 графическими запросами для Xnest в то время, как Xnest управляет
208 окнами и графическими запросами для своих собственных клиентов.
209
210 %description -n xorg-xserver-Xnest -l uk.UTF-8
211 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
212 клієнт реального X-сервера, який керує вікнами та графічними запитами
213 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
214 своїх власних клієнтів.
215
216 %package -n xorg-xserver-Xephyr
217 Summary:        Xephyr - nested X server
218 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
219 Group:          X11/Servers
220 Requires:       pixman >= %{pixman_ver}
221
222 %description -n xorg-xserver-Xephyr
223 Xephyr is a a kdrive server that outputs to a window on a pre-existing
224 'host' X display. Think Xnest but with support for modern extensions
225 like composite, damage and randr.
226
227 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
228 the host X server, Xephyr is a real X server which uses the host X
229 server window as "framebuffer" via fast SHM XImages.
230
231 It also has support for 'visually' debugging what the server is
232 painting.
233
234 %description -n xorg-xserver-Xephyr -l pl.UTF-8
235 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
236 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
237 wspólczesnych rozszerzeń jak composite, damage i randr.
238
239 %package -n xorg-xserver-Xfbdev
240 Summary:        Xfbdev - Linux framebuffer device X server
241 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
242 Group:          X11/Servers
243
244 %description -n xorg-xserver-Xfbdev
245 Xfbdev is a Linux framebuffer device X server based on the kdrive X
246 server.
247
248 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
249 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
250
251 %package -n xorg-xserver-Xvfb
252 Summary:        Xvfb - virtual framebuffer X server
253 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
254 Group:          X11/Servers
255 Requires:       mktemp
256 Requires:       util-linux
257 Requires:       which
258 Requires:       xorg-app-xauth
259 # requires fixed and cursor fonts
260 Requires:       xorg-font-font-alias
261 Requires:       xorg-font-font-cursor-misc
262 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
263 Obsoletes:      X11-Xvfb < 1:7.0.0
264 Obsoletes:      XFree86-Xvfb < 1:7.0.0
265
266 %description -n xorg-xserver-Xvfb
267 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
268 capable of running on machines with no display hardware and no
269 physical input devices. Xvfb emulates a dumb framebuffer using virtual
270 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
271 display. Xvfb is normally used for testing servers. Using Xvfb, the
272 mfb or cfb code for any depth can be exercised without using real
273 hardware that supports the desired depths. Xvfb has also been used to
274 test X clients against unusual depths and screen configurations, to do
275 batch processing with Xvfb as a background rendering engine, to do
276 load testing, to help with porting an X server to a new platform, and
277 to provide an unobtrusive way of running applications which really
278 don't need an X server but insist on having one.
279
280 %description -n xorg-xserver-Xvfb -l pl.UTF-8
281 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
282 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
283 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
284 używany do testowania serwerów X, może też być używany do testowania
285 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
286 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
287 serwera X, ale odmawiają uruchomienia bez niego.
288
289 %package -n xorg-xserver-Xvfb-init
290 Summary:        Init scripts for Xvfb
291 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
292 Group:          X11/Servers
293 Requires:       xorg-xserver-Xvfb
294
295 %description -n xorg-xserver-Xvfb-init
296 This package contains init scripts for Xvfb and registers Xvfb as
297 system service.
298
299 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
300 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
301 usługę systemową.
302
303 %package devel
304 Summary:        Header files for X.org server
305 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
306 Group:          X11/Development/Libraries
307 Requires:       libdrm-devel >= 2.4.39
308 Requires:       pixman-devel >= %{pixman_ver}
309 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
310 Requires:       xorg-lib-libxkbfile-devel
311 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
312 Requires:       xorg-proto-fontsproto-devel
313 Requires:       xorg-proto-inputproto-devel >= 2.3
314 Requires:       xorg-proto-kbproto-devel >= 1.0.3
315 Requires:       xorg-proto-randrproto-devel >= 1.4.0
316 Requires:       xorg-proto-renderproto-devel >= 0.11
317 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
318 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
319 Requires:       xorg-proto-videoproto-devel
320 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
321 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
322 Requires:       xorg-proto-xineramaproto-devel
323 Requires:       xorg-proto-xproto-devel >= 7.0.22
324 Obsoletes:      X11-Xserver-devel < 1:7.0.0
325 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
326
327 %description devel
328 Header files for X.org server.
329
330 %description devel -l pl.UTF-8
331 Pliki nagłówkowe dla serwera X.org.
332
333 %package source
334 Summary:        X.org server source code
335 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
336 Group:          X11/Development/Libraries
337
338 %description source
339 X.org server source code.
340
341 %description source -l pl.UTF-8
342 Pliki źródłowe dla serwera X.org.
343
344 %package -n xorg-xserver-libglx
345 Summary:        GLX extension library for X.org server
346 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
347 Group:          X11/Servers
348 Requires:       %{name} = %{version}-%{release}
349 # Mesa version glapi tables in glx/ dir come from
350 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
351 Provides:       xorg-xserver-module(glx)
352 Obsoletes:      X11-OpenGL-core < 1:7.0.0
353 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
354
355 %description -n xorg-xserver-libglx
356 GLX extension library for X.org server.
357
358 %description -n xorg-xserver-libglx -l pl.UTF-8
359 Biblioteka rozszerzenia GLX dla serwera X.org.
360
361 %prep
362 %setup -q -n xorg-server-%{version}
363 %patch0 -p0
364 %patch1 -p1
365
366 %patch3 -p1
367 %patch4 -p1
368 %patch5 -p1
369 %patch6 -p1
370
371 #unfortunately breaks build
372 #patch7 -p1
373
374 # xserver uses pixman-1 API/ABI so put that explictly here
375 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
376
377 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
378 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
379
380 %build
381 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
382 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
383         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
384         exit 1
385 fi
386
387 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
388 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
389         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
390         exit 1
391 fi
392
393 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
394 if [ $API != %{xorg_xserver_server_font_abi} ]; then
395         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
396         exit 1
397 fi
398 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
399 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
400         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
401         exit 1
402 fi
403 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
404 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
405         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
406         exit 1
407 fi
408
409 %{__libtoolize}
410 %{__aclocal} -I m4
411 %{__autoconf}
412 %{__autoheader}
413 %{__automake}
414 %configure \
415         --with-os-name="PLD/Linux" \
416         --with-os-vendor="PLD/Team" \
417         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
418         --with-xkb-output=/var/lib/xkb \
419         --without-fop \
420         --enable-aiglx \
421         %{?with_dbus:--enable-config-dbus} \
422         --enable-config-hal%{!?with_hal:=no} \
423         --enable-config-udev%{!?with_udev:=no} \
424         --enable-dga \
425         %{?with_dmx:--enable-dmx} \
426         --enable-dri2%{!?with_dri2:=no} \
427         --enable-glx-tls \
428         --enable-install-libxf86config \
429         --enable-kdrive \
430         %{?with_record:--enable-record} \
431         --enable-secure-rpc \
432         %{?with_xcsecurity:--enable-xcsecurity} \
433         --enable-xephyr \
434         %{?with_xf86bigfont:--enable-xf86bigfont} \
435         --disable-xfake \
436         --enable-xfbdev \
437         %{?with_xselinux:--enable-xselinux}
438
439 %{__make}
440
441 %install
442 rm -rf $RPM_BUILD_ROOT
443
444 %{__make} install \
445         DESTDIR=$RPM_BUILD_ROOT
446
447 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
448 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
449 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
450 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
451 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
452
453 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
454 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
455
456 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
457
458 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
459
460 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
461 install -d $RPM_BUILD_ROOT/etc/sysconfig
462 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
463 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
464
465 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
466 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
467 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
468 %{__make} distclean
469 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
470 find -name '*.h' | xargs chmod a-x
471
472 %clean
473 rm -rf $RPM_BUILD_ROOT
474
475 %triggerpostun -- xorg-xserver-server < 1.5.0
476 if [ -f /etc/X11/xorg.conf ]; then
477         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
478         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
479 %if %{without record}
480         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
481 %endif
482         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
483 fi
484
485 %post -n xorg-xserver-Xvfb-init
486 /sbin/chkconfig --add Xvfb
487 %service Xvfb restart
488
489 %preun -n xorg-xserver-Xvfb-init
490 if [ "$1" = "0" ]; then
491         %service -q Xvfb stop
492         /sbin/chkconfig --del Xvfb
493 fi
494
495 %files
496 %defattr(644,root,root,755)
497 %doc COPYING ChangeLog README
498 %attr(755,root,root) %{_bindir}/X
499 %attr(755,root,root) %{_bindir}/Xorg
500 %attr(4755,root,root) %{_bindir}/Xwrapper
501 %attr(755,root,root) %{_bindir}/cvt
502 %attr(755,root,root) %{_bindir}/gtf
503 %dir %{_libdir}/xorg
504 %{_libdir}/xorg/protocol.txt
505 %dir %{_libdir}/xorg/modules
506 %dir %{_libdir}/xorg/modules/dri
507 %dir %{_libdir}/xorg/modules/drivers
508 %dir %{_libdir}/xorg/modules/extensions
509 %dir %{_libdir}/xorg/modules/input
510 %dir %{_libdir}/xorg/modules/multimedia
511 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
512 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
513 %dir /var/lib/xkb
514 /var/lib/xkb/README.compiled
515 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
516 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
517 %config(missingok) /etc/security/console.apps/xserver
518 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
519 %dir /etc/X11/xorg.conf.d
520 %dir %{_datadir}/X11/xorg.conf.d
521 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
522 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
523 %{_mandir}/man1/Xorg.1*
524 %{_mandir}/man1/Xserver.1*
525 %{_mandir}/man1/cvt.1*
526 %{_mandir}/man1/gtf.1*
527 %{_mandir}/man4/exa.4*
528 %{_mandir}/man4/fbdevhw.4*
529 %{_mandir}/man5/xorg.conf.5*
530 %{_mandir}/man5/xorg.conf.d.5*
531
532 %if %{with dmx}
533 %files -n xorg-xserver-Xdmx
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/Xdmx
536 %attr(755,root,root) %{_bindir}/dmxaddinput
537 %attr(755,root,root) %{_bindir}/dmxaddscreen
538 %attr(755,root,root) %{_bindir}/dmxinfo
539 %attr(755,root,root) %{_bindir}/dmxreconfig
540 %attr(755,root,root) %{_bindir}/dmxresize
541 %attr(755,root,root) %{_bindir}/dmxrminput
542 %attr(755,root,root) %{_bindir}/dmxrmscreen
543 %attr(755,root,root) %{_bindir}/dmxtodmx
544 %attr(755,root,root) %{_bindir}/dmxwininfo
545 %attr(755,root,root) %{_bindir}/vdltodmx
546 %attr(755,root,root) %{_bindir}/xdmxconfig
547 %{_mandir}/man1/Xdmx.1*
548 %{_mandir}/man1/dmxtodmx.1*
549 %{_mandir}/man1/vdltodmx.1*
550 %{_mandir}/man1/xdmxconfig.1*
551 %endif
552
553 %files -n xorg-xserver-Xnest
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_bindir}/Xnest
556 %{_mandir}/man1/Xnest.1*
557
558 %files -n xorg-xserver-Xephyr
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/Xephyr
561 %{_mandir}/man1/Xephyr.1*
562
563 %files -n xorg-xserver-Xfbdev
564 %defattr(644,root,root,755)
565 %attr(755,root,root) %{_bindir}/Xfbdev
566
567 %files -n xorg-xserver-Xvfb
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/Xvfb
570 %attr(755,root,root) %{_bindir}/xvfb-run
571 %{_mandir}/man1/Xvfb.1*
572
573 %files -n xorg-xserver-Xvfb-init
574 %defattr(644,root,root,755)
575 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
576 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
577
578 %files devel
579 %defattr(644,root,root,755)
580 %doc doc/{Xinput,Xserver-spec}.html
581 %{_includedir}/xorg
582 %{_libdir}/libxf86config.a
583 %{_libdir}/libxf86config.la
584 %{_aclocaldir}/xorg-server.m4
585 %{_pkgconfigdir}/xorg-server.pc
586
587 %files source
588 %defattr(644,root,root,755)
589 # keep file perms from install time, but have default defattr to keep adapter happy
590 %defattr(-,root,root,755)
591 %{_usrsrc}/%{name}-%{version}
592
593 %files -n xorg-xserver-libglx
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.070899 seconds and 3 git commands to generate.