]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- group packages by server kind, separated xorg-xserver-common with common files...
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_with     eglstream       # XWayland eglstream support
18 %bcond_without  glamor          # glamor dix module
19 %bcond_without  systemtap       # systemtap/dtrace probes
20 %bcond_without  libunwind       # use libunwind for backtracing
21 #
22 # ABI versions, see hw/xfree86/common/xf86Module.h
23 %define xorg_xserver_server_ansic_abi           0.4
24 %define xorg_xserver_server_extension_abi       10.0
25 %define xorg_xserver_server_videodrv_abi        24.1
26 %define xorg_xserver_server_xinput_abi          24.1
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.20.11
38 Release:        2
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  a22ccd74a5eee721cad6805e489c7144
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 Patch7:         platform_probe_crash.patch
54 URL:            https://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
70 %{?with_hal:BuildRequires:      hal-devel}
71 BuildRequires:  libdrm-devel >= 2.4.89
72 %if %{with glamor}
73 BuildRequires:  libepoxy-devel >= 1.5.4
74 %endif
75 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
76 BuildRequires:  libtirpc-devel
77 BuildRequires:  libtool >= 2:2.2
78 %{?with_libunwind:BuildRequires:        libunwind-devel}
79 BuildRequires:  libxcb-devel >= 1.9.3
80 BuildRequires:  pam-devel
81 BuildRequires:  perl-base
82 BuildRequires:  pixman-devel >= %{pixman_ver}
83 BuildRequires:  pkgconfig >= 1:0.19
84 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
85 BuildRequires:  systemd-devel >= 1:209
86 BuildRequires:  udev-devel >= 1:143
87 # wayland-client
88 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
89 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
90 BuildRequires:  xcb-util-devel
91 BuildRequires:  xcb-util-image-devel
92 BuildRequires:  xcb-util-keysyms-devel
93 BuildRequires:  xcb-util-renderutil-devel
94 BuildRequires:  xcb-util-wm-devel
95 BuildRequires:  xmlto >= 0.0.20
96 BuildRequires:  xorg-app-mkfontscale
97 BuildRequires:  xorg-font-font-util >= 1.1
98 BuildRequires:  xorg-lib-libX11-devel >= 1.6
99 BuildRequires:  xorg-lib-libXau-devel
100 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
101 BuildRequires:  xorg-lib-libXdamage-devel
102 BuildRequires:  xorg-lib-libXdmcp-devel
103 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
104 BuildRequires:  xorg-lib-libXfixes-devel
105 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
106 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
107 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
108 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
109 BuildRequires:  xorg-lib-libXrender-devel
110 BuildRequires:  xorg-lib-libXres-devel
111 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
112 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
113 BuildRequires:  xorg-lib-libXv-devel
114 BuildRequires:  xorg-lib-libXxf86dga-devel
115 BuildRequires:  xorg-lib-libXxf86misc-devel
116 BuildRequires:  xorg-lib-libXxf86vm-devel
117 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
118 BuildRequires:  xorg-lib-libfontenc-devel
119 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
120 BuildRequires:  xorg-lib-libxkbfile-devel
121 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
122 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
123 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
124 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
125 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
126 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
127 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
128 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
129 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
130 BuildRequires:  xorg-proto-fontcacheproto-devel
131 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
132 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
133 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
134 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
135 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
136 BuildRequires:  xorg-proto-printproto-devel
137 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
138 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
139 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
140 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
141 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
142 BuildRequires:  xorg-proto-videoproto-devel
143 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
144 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
145 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
146 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
147 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
148 BuildRequires:  xorg-proto-xf86miscproto-devel
149 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
150 BuildRequires:  xorg-proto-xineramaproto-devel
151 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
152 BuildRequires:  xorg-sgml-doctools >= 1.8
153 BuildRequires:  xorg-util-util-macros >= 1.14
154 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
155 Requires:       libdrm >= 2.4.89
156 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
157 Requires:       pixman >= %{pixman_ver}
158 Requires:       sed >= 4.0
159 Requires:       udev-libs >= 1:143
160 Requires:       xkeyboard-config
161 # for rgb.txt
162 Requires:       xorg-app-rgb >= 0.99.3
163 Requires:       xorg-app-xkbcomp
164 Requires:       xorg-lib-libXfont2 >= 2.0.0
165 Requires:       xorg-lib-libpciaccess >= 0.12.901
166 Requires:       xorg-lib-libxshmfence >= 1.1
167 # for protocol.txt
168 Requires:       xorg-xserver-common = %{version}-%{release}
169 Suggests:       dbus-x11 >= 1.0
170 %{?with_hal:Suggests:   hal}
171 Suggests:       udev-acl >= 1:143
172 %{?with_udev:Suggests:  udev-core >= 1:143}
173 Suggests:       xkeyboard-config
174 Suggests:       xorg-driver-input-libinput
175 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
176 Suggests:       xorg-driver-video
177 Provides:       xorg-driver-video-modesetting
178 Provides:       xorg-xserver-libdri = %{version}-%{release}
179 Provides:       xorg-xserver-module(dri)
180 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
181 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
182 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
183 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
184 Obsoletes:      X11-Xserver < 1:7.0.0
185 Obsoletes:      X11-driver-i2c < 1:7.0.0
186 Obsoletes:      X11-modules < 1:7.0.0
187 Obsoletes:      X11-setup < 1:7.0.0
188 Obsoletes:      XFree86-Xserver < 1:7.0.0
189 Obsoletes:      XFree86-modules < 1:7.0.0
190 Obsoletes:      XFree86-setup < 1:7.0.0
191 Obsoletes:      Xserver
192 %{?with_glamor:Obsoletes:       glamor}
193 Obsoletes:      xorg-xserver-libdri
194 Obsoletes:      xorg-xserver-server-xorgcfg
195 Obsoletes:      xorg-driver-video-modesetting
196 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
197
198 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
199 %define         tirpc_libs      $(pkg-config --libs libtirpc)
200
201 %description
202 Xorg server is a generally used X server which uses display hardware.
203 It requires proper driver for your display hardware.
204
205 %description -l pl.UTF-8
206 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
207 graficznej. Do działania wymaga odpowiedniego sterownika.
208
209 %package devel
210 Summary:        Header files for X.org server
211 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
212 Group:          X11/Development/Libraries
213 Requires:       Mesa-libGL-devel >= 7.8.0
214 Requires:       libdrm-devel >= 2.4.89
215 Requires:       pixman-devel >= %{pixman_ver}
216 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
217 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
218 Requires:       xorg-lib-libxkbfile-devel
219 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
220 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
221 Requires:       xorg-proto-dri3proto-devel >= 1.0
222 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
223 Requires:       xorg-proto-glproto-devel >= 1.4.17
224 Requires:       xorg-proto-inputproto-devel >= 2.3
225 Requires:       xorg-proto-kbproto-devel >= 1.0.3
226 Requires:       xorg-proto-presentproto-devel >= 1.1
227 Requires:       xorg-proto-randrproto-devel >= 1.6.0
228 Requires:       xorg-proto-renderproto-devel >= 0.11
229 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
230 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
231 Requires:       xorg-proto-videoproto-devel
232 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
233 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
234 Requires:       xorg-proto-xineramaproto-devel
235 Requires:       xorg-proto-xproto-devel >= 7.0.31
236 Obsoletes:      X11-Xserver-devel < 1:7.0.0
237 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
238 %{?with_glamor:Obsoletes:       glamor-devel}
239
240 %description devel
241 Header files for X.org server.
242
243 %description devel -l pl.UTF-8
244 Pliki nagłówkowe dla serwera X.org.
245
246 %package source
247 Summary:        X.org server source code
248 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
249 Group:          X11/Development/Libraries
250
251 %description source
252 X.org server source code.
253
254 %description source -l pl.UTF-8
255 Pliki źródłowe dla serwera X.org.
256
257 %package -n xorg-xserver-libglx
258 Summary:        GLX extension library for X.org server
259 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
260 Group:          X11/Servers
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       Mesa-libGL >= 7.1.0
263 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
264 # Mesa version glapi tables in glx/ dir come from
265 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
266 Provides:       xorg-xserver-module(glx)
267 Obsoletes:      X11-OpenGL-core < 1:7.0.0
268 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
269
270 %description -n xorg-xserver-libglx
271 GLX extension library for X.org server.
272
273 %description -n xorg-xserver-libglx -l pl.UTF-8
274 Biblioteka rozszerzenia GLX dla serwera X.org.
275
276 %package -n xorg-xserver-Xdmx
277 Summary:        Xdmx - distributed multi-head X server
278 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
279 Group:          X11/Servers
280 Requires:       pixman >= %{pixman_ver}
281 Requires:       xorg-lib-libX11 >= 1.6
282 Requires:       xorg-lib-libXext >= 1.0.99.4
283 Requires:       xorg-lib-libXfont2 >= 2.0.0
284 Requires:       xorg-lib-libXi >= 1.2.99.1
285 Requires:       xorg-lib-libdmx >= 1.0.99.1
286
287 %description -n xorg-xserver-Xdmx
288 Xdmx - distributed multi-head X server.
289
290 %description -n xorg-xserver-Xdmx -l pl.UTF-8
291 Xdmx - rozproszony, wielomonitorowy serwer X.
292
293 %package -n xorg-xserver-Xephyr
294 Summary:        Xephyr - nested X server
295 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
296 Group:          X11/Servers
297 Requires:       Mesa-libGL >= 7.1.0
298 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
299 Requires:       libxcb >= 1.9.3
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       xorg-lib-libXfont2 >= 2.0.0
302
303 %description -n xorg-xserver-Xephyr
304 Xephyr is a kdrive server that outputs to a window on a pre-existing
305 'host' X display. Think Xnest but with support for modern extensions
306 like composite, damage and randr.
307
308 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
309 the host X server, Xephyr is a real X server which uses the host X
310 server window as "framebuffer" via fast SHM XImages.
311
312 It also has support for 'visually' debugging what the server is
313 painting.
314
315 %description -n xorg-xserver-Xephyr -l pl.UTF-8
316 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
317 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
318 wspólczesnych rozszerzeń jak composite, damage i randr.
319
320 %package -n xorg-xserver-Xnest
321 Summary:        Xnest - nested X server
322 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
323 Group:          X11/Servers
324 Requires:       pixman >= %{pixman_ver}
325 Requires:       xorg-lib-libXext >= 1.0.99.4
326 Requires:       xorg-lib-libXfont2 >= 2.0.0
327 Obsoletes:      X11-Xnest < 1:7.0.0
328 Obsoletes:      XFree86-Xnest < 1:7.0.0
329 Obsoletes:      Xserver-Xnest
330
331 %description -n xorg-xserver-Xnest
332 Xnest is an X Window System server which runs in an X window. Xnest is
333 a 'nested' window server, actually a client of the real X server,
334 which manages windows and graphics requests for Xnest, while Xnest
335 manages the windows and graphics requests for its own clients.
336
337 %description -n xorg-xserver-Xnest -l pl.UTF-8
338 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
339 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
340 serwer X dla własnych klientów.
341
342 %description -n xorg-xserver-Xnest -l ru.UTF-8
343 Xnest - это сервер X Window System, который работает в окне X. На
344 самом деле это клиент реального X-сервера, который управляет окнами и
345 графическими запросами для Xnest в то время, как Xnest управляет
346 окнами и графическими запросами для своих собственных клиентов.
347
348 %description -n xorg-xserver-Xnest -l uk.UTF-8
349 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
350 клієнт реального X-сервера, який керує вікнами та графічними запитами
351 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
352 своїх власних клієнтів.
353
354 %package -n xorg-xserver-Xvfb
355 Summary:        Xvfb - virtual framebuffer X server
356 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
357 Group:          X11/Servers
358 Requires:       Mesa-libGL >= 7.1.0
359 Requires:       mktemp
360 Requires:       pixman >= %{pixman_ver}
361 Requires:       util-linux
362 Requires:       which
363 Requires:       xkeyboard-config
364 Requires:       xorg-app-xauth
365 Requires:       xorg-app-xkbcomp
366 Requires:       xorg-lib-libXfont2 >= 2.0.0
367 Obsoletes:      X11-Xvfb < 1:7.0.0
368 Obsoletes:      XFree86-Xvfb < 1:7.0.0
369
370 %description -n xorg-xserver-Xvfb
371 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
372 capable of running on machines with no display hardware and no
373 physical input devices. Xvfb emulates a dumb framebuffer using virtual
374 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
375 display. Xvfb is normally used for testing servers. Using Xvfb, the
376 mfb or cfb code for any depth can be exercised without using real
377 hardware that supports the desired depths. Xvfb has also been used to
378 test X clients against unusual depths and screen configurations, to do
379 batch processing with Xvfb as a background rendering engine, to do
380 load testing, to help with porting an X server to a new platform, and
381 to provide an unobtrusive way of running applications which really
382 don't need an X server but insist on having one.
383
384 %description -n xorg-xserver-Xvfb -l pl.UTF-8
385 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
386 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
387 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
388 używany do testowania serwerów X, może też być używany do testowania
389 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
390 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
391 serwera X, ale odmawiają uruchomienia bez niego.
392
393 %package -n xorg-xserver-Xvfb-init
394 Summary:        Init scripts for Xvfb
395 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
396 Group:          X11/Servers
397 Requires:       xorg-xserver-Xvfb
398
399 %description -n xorg-xserver-Xvfb-init
400 This package contains init scripts for Xvfb and registers Xvfb as
401 system service.
402
403 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
404 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
405 usługę systemową.
406
407 %package -n xorg-xserver-Xwayland
408 Summary:        Xwayland - X server integrated into a Wayland window system
409 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
410 Group:          X11/Servers
411 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
412 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
413 Requires:       pixman >= %{pixman_ver}
414 Requires:       xorg-lib-libX11 >= 1.6
415 Requires:       xorg-lib-libXext >= 1.0.99.4
416 Requires:       xorg-lib-libXfont2 >= 2.0.0
417 Requires:       xorg-lib-libXi >= 1.2.99.1
418 # for protocol.txt
419 Requires:       xorg-xserver-common = %{version}-%{release}
420
421 %description -n xorg-xserver-Xwayland
422 Xwayland - server integrated into a Wayland window system.
423
424 %description -n xorg-xserver-Xwayland -l pl.UTF-8
425 Xwayland - serwer X integrowalny w Wayland.
426
427 %package -n xorg-xserver-common
428 Summary:        Common files for various X servers
429 Summary(pl.UTF-8):      Pliki wspólne dla serwerów X
430 Group:          X11/Servers
431 Conflicts:      xorg-xserver-server < 1.20.11-2
432
433 %description -n xorg-xserver-common
434 Common files for various X servers.
435
436 %description -n xorg-xserver-common -l pl.UTF-8
437 Pliki wspólne dla serwerów X.
438
439 %prep
440 %setup -q -n xorg-server-%{version}
441 %patch1 -p1
442
443 %patch4 -p1
444
445 %patch6 -p1
446 %patch7 -p1
447
448 # xserver uses pixman-1 API/ABI so put that explictly here
449 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
450
451 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
452 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
453
454 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
455
456 %build
457 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
458 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
459         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
460         exit 1
461 fi
462
463 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
464 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
465         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
466         exit 1
467 fi
468
469 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
470 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
471         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
472         exit 1
473 fi
474 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
475 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
476         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
477         exit 1
478 fi
479
480 %{__libtoolize}
481 %{__aclocal} -I m4
482 %{__autoconf}
483 %{__autoheader}
484 %{__automake}
485 %configure \
486         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
487         LIBS="%{tirpc_libs}" \
488         --libexecdir=%{_libdir}/xorg \
489         --with-os-name="PLD/Linux" \
490         --with-os-vendor="PLD/Team" \
491         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
492         --with-xkb-output=/var/lib/xkb \
493         --disable-linux-acpi \
494         --disable-linux-apm \
495         %{?with_dbus:--enable-config-dbus} \
496         --enable-config-hal%{!?with_hal:=no} \
497         --enable-config-udev%{!?with_udev:=no} \
498         --enable-dga \
499         %{?with_dmx:--enable-dmx} \
500         --enable-dri2%{!?with_dri2:=no} \
501         --enable-dri3%{!?with_dri3:=no} \
502         %{?with_glamor:--enable-glamor} \
503         --enable-kdrive \
504         %{?with_libunwind:--enable-libunwind} \
505         %{?with_record:--enable-record} \
506         --enable-secure-rpc \
507         %{?with_xcsecurity:--enable-xcsecurity} \
508         --enable-xephyr \
509         %{?with_xf86bigfont:--enable-xf86bigfont} \
510         %{?with_xselinux:--enable-xselinux} \
511         %{?with_wayland:--enable-xwayland} \
512         %{?with_eglstream:--enable-xwayland-eglstream} \
513         %{!?with_systemtap:--without-dtrace} \
514         --without-fop \
515         --enable-suid-wrapper \
516         --with-systemd-daemon
517
518 %{__make}
519
520 %install
521 rm -rf $RPM_BUILD_ROOT
522
523 %if "%{_libdir}" != "%{_exec_prefix}/lib"
524 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
525 %endif
526
527 %{__make} install \
528         DESTDIR=$RPM_BUILD_ROOT
529
530 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
531 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
532 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
533 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
534 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
535
536 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
537 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
538
539 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
540
541 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
542
543 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
544 install -d $RPM_BUILD_ROOT/etc/sysconfig
545 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
546 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
547
548 # Xorg.wrap config
549 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
550 # allowed values: rootonly console anybody pam
551 allowed_users = pam
552
553 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
554 #needs_root_rights = yes
555 EOF
556
557 # compatibility with old xwrapper
558 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
559
560 # prepare source package
561 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
562 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
563 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
564 %{__make} distclean
565 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
566 find -name '*.h' | xargs chmod a-x
567
568 %if %{with systemtap}
569 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
570 %endif
571
572 %clean
573 rm -rf $RPM_BUILD_ROOT
574
575 %triggerpostun -- xorg-xserver-server < 1.5.0
576 if [ -f /etc/X11/xorg.conf ]; then
577         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
578         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
579 %if %{without record}
580         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
581 %endif
582         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
583 fi
584
585 %post -n xorg-xserver-Xvfb-init
586 /sbin/chkconfig --add Xvfb
587 %service Xvfb restart
588
589 %preun -n xorg-xserver-Xvfb-init
590 if [ "$1" = "0" ]; then
591         %service -q Xvfb stop
592         /sbin/chkconfig --del Xvfb
593 fi
594
595 %files
596 %defattr(644,root,root,755)
597 %doc COPYING ChangeLog README.md
598 %attr(755,root,root) %{_bindir}/X
599 %attr(755,root,root) %{_bindir}/Xorg
600 %attr(4755,root,root) %{_bindir}/Xwrapper
601 %attr(755,root,root) %{_bindir}/cvt
602 %attr(755,root,root) %{_bindir}/gtf
603 %attr(755,root,root) %{_libdir}/xorg/Xorg
604 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
605 %dir %{_libdir}/xorg/modules
606 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
609 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
610 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
611 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
612 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
613 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
614 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
615 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
616 %dir %{_libdir}/xorg/modules/dri
617 %dir %{_libdir}/xorg/modules/drivers
618 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
619 %dir %{_libdir}/xorg/modules/extensions
620 %dir %{_libdir}/xorg/modules/input
621 %if "%{_libdir}" != "%{_exec_prefix}/lib"
622 %dir %{_exec_prefix}/lib/xorg
623 %dir %{_exec_prefix}/lib/xorg/modules
624 %dir %{_exec_prefix}/lib/xorg/modules/dri
625 %endif
626 %dir /var/lib/xkb
627 /var/lib/xkb/README.compiled
628 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
629 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
630 %config(missingok) /etc/security/console.apps/xserver
631 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
632 %dir /etc/X11/xorg.conf.d
633 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
634 %dir %{_datadir}/X11/xorg.conf.d
635 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
636 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
637 %{_mandir}/man1/Xorg.1*
638 %{_mandir}/man1/Xorg.wrap.1*
639 %{_mandir}/man1/cvt.1*
640 %{_mandir}/man1/gtf.1*
641 %{_mandir}/man4/exa.4*
642 %{_mandir}/man4/fbdevhw.4*
643 %{_mandir}/man4/modesetting.4*
644 %{_mandir}/man5/Xwrapper.config.5*
645 %{_mandir}/man5/xorg.conf.5*
646 %{_mandir}/man5/xorg.conf.d.5*
647
648 %files devel
649 %defattr(644,root,root,755)
650 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
651 %{_includedir}/xorg
652 %{_aclocaldir}/xorg-server.m4
653 %{_pkgconfigdir}/xorg-server.pc
654
655 %files source
656 %defattr(644,root,root,755)
657 # keep file perms from install time, but have default defattr to keep adapter happy
658 %defattr(-,root,root,755)
659 %{_usrsrc}/%{name}-%{version}
660
661 %files -n xorg-xserver-libglx
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
664
665 %if %{with dmx}
666 %files -n xorg-xserver-Xdmx
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/Xdmx
669 %attr(755,root,root) %{_bindir}/dmxaddinput
670 %attr(755,root,root) %{_bindir}/dmxaddscreen
671 %attr(755,root,root) %{_bindir}/dmxinfo
672 %attr(755,root,root) %{_bindir}/dmxreconfig
673 %attr(755,root,root) %{_bindir}/dmxresize
674 %attr(755,root,root) %{_bindir}/dmxrminput
675 %attr(755,root,root) %{_bindir}/dmxrmscreen
676 %attr(755,root,root) %{_bindir}/dmxtodmx
677 %attr(755,root,root) %{_bindir}/dmxwininfo
678 %attr(755,root,root) %{_bindir}/vdltodmx
679 %attr(755,root,root) %{_bindir}/xdmxconfig
680 %{_mandir}/man1/Xdmx.1*
681 %{_mandir}/man1/dmxtodmx.1*
682 %{_mandir}/man1/vdltodmx.1*
683 %{_mandir}/man1/xdmxconfig.1*
684 %endif
685
686 %files -n xorg-xserver-Xnest
687 %defattr(644,root,root,755)
688 %attr(755,root,root) %{_bindir}/Xnest
689 %{_mandir}/man1/Xnest.1*
690
691 %files -n xorg-xserver-Xephyr
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_bindir}/Xephyr
694 %{_mandir}/man1/Xephyr.1*
695
696 %files -n xorg-xserver-Xvfb
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_bindir}/Xvfb
699 %attr(755,root,root) %{_bindir}/xvfb-run
700 %{_mandir}/man1/Xvfb.1*
701
702 %files -n xorg-xserver-Xvfb-init
703 %defattr(644,root,root,755)
704 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
705 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
706
707 %if %{with wayland}
708 %files -n xorg-xserver-Xwayland
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/Xwayland
711 %endif
712
713 %files -n xorg-xserver-common
714 %defattr(644,root,root,755)
715 %dir %{_libdir}/xorg
716 %{_libdir}/xorg/protocol.txt
717 %{_mandir}/man1/Xserver.1*
This page took 0.104237 seconds and 3 git commands to generate.