]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
b71d18cf6201a65d566e2bba0d9dd343f1877679
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
5 %bcond_with     hal             # HAL support for configuration (if no udev)
6 %bcond_without  udev            # UDEV support for configuration
7 %bcond_without  dmx             # DMX support
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  record          # RECORD extension
10 %bcond_without  systemtap       # systemtap/dtrace probes
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       8.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        15.0
20 %define xorg_xserver_server_xinput_abi          20.0
21 #
22 %define pixman_ver      0.30.0
23
24 Summary:        X.org server
25 Summary(pl.UTF-8):      Serwer X.org
26 Name:           xorg-xserver-server
27 Version:        1.15.0
28 Release:        1
29 License:        MIT
30 Group:          X11/Servers
31 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
32 # Source0-md5:  c2ace3697b32414094cf8c597c39d7d9
33 Source1:        10-quirks.conf
34 Source2:        xserver.pamd
35 Source10:       %{name}-Xvfb.init
36 Source11:       %{name}-Xvfb.sysconfig
37 Source12:       xvfb-run.sh
38
39 Patch0:         %{name}-xwrapper.patch
40 Patch1:         %{name}-pic-libxf86config.patch
41
42 Patch4:         %{name}-builtin-SHA1.patch
43 Patch5:         %{name}-export-GetMaster.patch
44 Patch6:         110_nvidia_slowdow_fix.patch
45 Patch7:         %{name}-include-defs.patch
46 URL:            http://xorg.freedesktop.org/
47 BuildRequires:  Mesa-libGL-devel >= 7.8.1
48 # for glx headers
49 BuildRequires:  OpenGL-GLX-devel
50 %{?with_xselinux:BuildRequires: audit-libs-devel}
51 BuildRequires:  autoconf >= 2.60
52 BuildRequires:  automake
53 BuildRequires:  cpp
54 BuildRequires:  docbook-dtd43-xml
55 #BuildRequires: doxygen >= 1.6.1
56 %if %{with hal} || %{with dbus}
57 BuildRequires:  dbus-devel >= 1.0
58 %endif
59 %{?with_hal:BuildRequires:      hal-devel}
60 BuildRequires:  libdrm-devel >= 2.4.39
61 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
62 BuildRequires:  libtool
63 BuildRequires:  libunwind-devel
64 BuildRequires:  ncurses-devel
65 BuildRequires:  pam-devel
66 BuildRequires:  perl-base
67 BuildRequires:  pixman-devel >= %{pixman_ver}
68 BuildRequires:  pkgconfig >= 1:0.19
69 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
70 BuildRequires:  udev-devel >= 1:143
71 BuildRequires:  xcb-util-wm-devel
72 BuildRequires:  xmlto >= 0.0.20
73 BuildRequires:  xorg-app-mkfontscale
74 BuildRequires:  xorg-font-font-util >= 1.1
75 BuildRequires:  xorg-lib-libX11-devel
76 BuildRequires:  xorg-lib-libXau-devel
77 BuildRequires:  xorg-lib-libXaw-devel
78 BuildRequires:  xorg-lib-libXdamage-devel
79 BuildRequires:  xorg-lib-libXdmcp-devel
80 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
81 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
82 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
83 BuildRequires:  xorg-lib-libXmu-devel
84 BuildRequires:  xorg-lib-libXpm-devel
85 BuildRequires:  xorg-lib-libXrender-devel
86 BuildRequires:  xorg-lib-libXres-devel
87 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
88 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
89 BuildRequires:  xorg-lib-libXv-devel
90 BuildRequires:  xorg-lib-libXxf86dga-devel
91 BuildRequires:  xorg-lib-libXxf86misc-devel
92 BuildRequires:  xorg-lib-libXxf86vm-devel
93 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
94 BuildRequires:  xorg-lib-libfontenc-devel
95 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
96 BuildRequires:  xorg-lib-libxkbfile-devel
97 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
98 BuildRequires:  xorg-lib-libxshmfence-devel
99 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
100 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
101 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
102 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
103 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
104 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
105 BuildRequires:  xorg-proto-dri3proto-devel
106 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
107 BuildRequires:  xorg-proto-fontcacheproto-devel
108 BuildRequires:  xorg-proto-fontsproto-devel
109 BuildRequires:  xorg-proto-glproto-devel >= 1.4.16
110 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
111 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
112 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
113 BuildRequires:  xorg-proto-printproto-devel
114 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
115 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
116 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
117 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
118 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
119 BuildRequires:  xorg-proto-videoproto-devel
120 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
121 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
122 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
123 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
124 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
125 BuildRequires:  xorg-proto-xf86miscproto-devel
126 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
127 BuildRequires:  xorg-proto-xineramaproto-devel
128 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
129 BuildRequires:  xorg-sgml-doctools >= 1.8
130 BuildRequires:  xorg-util-util-macros >= 1.14
131 #BR: tslib (for KDRIVE only)
132 Requires(triggerpostun):        sed >= 4.0
133 Requires:       pixman >= %{pixman_ver}
134 Requires:       xkeyboard-config
135 # for rgb.txt
136 Requires:       xorg-app-rgb >= 0.99.3
137 Requires:       xorg-app-xkbcomp
138 %{?with_hal:Suggests:   hal}
139 Suggests:       udev-acl >= 1:143
140 %{?with_udev:Suggests:  udev-core >= 1:143}
141 Suggests:       xorg-driver-input-evdev
142 # xserver requires fixed and cursor fonts
143 Requires:       xorg-font-font-alias
144 Requires:       xorg-font-font-cursor-misc
145 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
146 Suggests:       dbus-x11 >= 1.0
147 Suggests:       xkeyboard-config
148 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
149 Suggests:       xorg-driver-video
150 Provides:       xorg-xserver-libdri = %{version}-%{release}
151 Provides:       xorg-xserver-module(dri)
152 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
153 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
154 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
155 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
156 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
157 Obsoletes:      X11-Xserver < 1:7.0.0
158 Obsoletes:      X11-driver-i2c < 1:7.0.0
159 Obsoletes:      X11-modules < 1:7.0.0
160 Obsoletes:      X11-setup < 1:7.0.0
161 Obsoletes:      XFree86-Xserver < 1:7.0.0
162 Obsoletes:      XFree86-modules < 1:7.0.0
163 Obsoletes:      XFree86-setup < 1:7.0.0
164 Obsoletes:      Xserver
165 Obsoletes:      xorg-xserver-libdri
166 Obsoletes:      xorg-xserver-server-xorgcfg
167 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
168
169 # avoid self-dependencies on included modules
170 %define         _noautoreq      libscanpci.so libxf1bpp.so
171
172 %description
173 Xorg server is a generally used X server which uses display hardware.
174 It requires proper driver for your display hardware.
175
176 %description -l pl.UTF-8
177 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
178 graficznej. Do działania wymaga odpowiedniego sterownika.
179
180 %package -n xorg-xserver-Xdmx
181 Summary:        Xdmx - distributed multi-head X server
182 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
183 Group:          X11/Servers
184
185 %description -n xorg-xserver-Xdmx
186 Xdmx - distributed multi-head X server.
187
188 %description -n xorg-xserver-Xdmx -l pl.UTF-8
189 Xdmx - rozproszony, wielomonitorowy serwer X.
190
191 %package -n xorg-xserver-Xnest
192 Summary:        Xnest - nested X server
193 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
194 Group:          X11/Servers
195 Obsoletes:      X11-Xnest < 1:7.0.0
196 Obsoletes:      XFree86-Xnest < 1:7.0.0
197 Obsoletes:      Xserver-Xnest
198
199 %description -n xorg-xserver-Xnest
200 Xnest is an X Window System server which runs in an X window. Xnest is
201 a 'nested' window server, actually a client of the real X server,
202 which manages windows and graphics requests for Xnest, while Xnest
203 manages the windows and graphics requests for its own clients.
204
205 %description -n xorg-xserver-Xnest -l pl.UTF-8
206 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
207 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
208 serwer X dla własnych klientów.
209
210 %description -n xorg-xserver-Xnest -l ru.UTF-8
211 Xnest - это сервер X Window System, который работает в окне X. На
212 самом деле это клиент реального X-сервера, который управляет окнами и
213 графическими запросами для Xnest в то время, как Xnest управляет
214 окнами и графическими запросами для своих собственных клиентов.
215
216 %description -n xorg-xserver-Xnest -l uk.UTF-8
217 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
218 клієнт реального X-сервера, який керує вікнами та графічними запитами
219 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
220 своїх власних клієнтів.
221
222 %package -n xorg-xserver-Xephyr
223 Summary:        Xephyr - nested X server
224 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
225 Group:          X11/Servers
226 Requires:       pixman >= %{pixman_ver}
227
228 %description -n xorg-xserver-Xephyr
229 Xephyr is a a kdrive server that outputs to a window on a pre-existing
230 'host' X display. Think Xnest but with support for modern extensions
231 like composite, damage and randr.
232
233 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
234 the host X server, Xephyr is a real X server which uses the host X
235 server window as "framebuffer" via fast SHM XImages.
236
237 It also has support for 'visually' debugging what the server is
238 painting.
239
240 %description -n xorg-xserver-Xephyr -l pl.UTF-8
241 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
242 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
243 wspólczesnych rozszerzeń jak composite, damage i randr.
244
245 %package -n xorg-xserver-Xfbdev
246 Summary:        Xfbdev - Linux framebuffer device X server
247 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
248 Group:          X11/Servers
249
250 %description -n xorg-xserver-Xfbdev
251 Xfbdev is a Linux framebuffer device X server based on the kdrive X
252 server.
253
254 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
255 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
256
257 %package -n xorg-xserver-Xvfb
258 Summary:        Xvfb - virtual framebuffer X server
259 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
260 Group:          X11/Servers
261 Requires:       mktemp
262 Requires:       util-linux
263 Requires:       which
264 Requires:       xorg-app-xauth
265 # requires fixed and cursor fonts
266 Requires:       xorg-font-font-alias
267 Requires:       xorg-font-font-cursor-misc
268 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
269 Obsoletes:      X11-Xvfb < 1:7.0.0
270 Obsoletes:      XFree86-Xvfb < 1:7.0.0
271
272 %description -n xorg-xserver-Xvfb
273 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
274 capable of running on machines with no display hardware and no
275 physical input devices. Xvfb emulates a dumb framebuffer using virtual
276 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
277 display. Xvfb is normally used for testing servers. Using Xvfb, the
278 mfb or cfb code for any depth can be exercised without using real
279 hardware that supports the desired depths. Xvfb has also been used to
280 test X clients against unusual depths and screen configurations, to do
281 batch processing with Xvfb as a background rendering engine, to do
282 load testing, to help with porting an X server to a new platform, and
283 to provide an unobtrusive way of running applications which really
284 don't need an X server but insist on having one.
285
286 %description -n xorg-xserver-Xvfb -l pl.UTF-8
287 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
288 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
289 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
290 używany do testowania serwerów X, może też być używany do testowania
291 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
292 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
293 serwera X, ale odmawiają uruchomienia bez niego.
294
295 %package -n xorg-xserver-Xvfb-init
296 Summary:        Init scripts for Xvfb
297 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
298 Group:          X11/Servers
299 Requires:       xorg-xserver-Xvfb
300
301 %description -n xorg-xserver-Xvfb-init
302 This package contains init scripts for Xvfb and registers Xvfb as
303 system service.
304
305 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
306 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
307 usługę systemową.
308
309 %package devel
310 Summary:        Header files for X.org server
311 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
312 Group:          X11/Development/Libraries
313 Requires:       libdrm-devel >= 2.4.39
314 Requires:       pixman-devel >= %{pixman_ver}
315 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
316 Requires:       xorg-lib-libxkbfile-devel
317 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
318 BuildRequires:  xorg-proto-dri3proto-devel
319 Requires:       xorg-proto-fontsproto-devel
320 Requires:       xorg-proto-inputproto-devel >= 2.3
321 Requires:       xorg-proto-kbproto-devel >= 1.0.3
322 Requires:       xorg-proto-randrproto-devel >= 1.4.0
323 Requires:       xorg-proto-renderproto-devel >= 0.11
324 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
325 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
326 Requires:       xorg-proto-videoproto-devel
327 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
328 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
329 Requires:       xorg-proto-xineramaproto-devel
330 Requires:       xorg-proto-xproto-devel >= 7.0.22
331 Obsoletes:      X11-Xserver-devel < 1:7.0.0
332 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
333
334 %description devel
335 Header files for X.org server.
336
337 %description devel -l pl.UTF-8
338 Pliki nagłówkowe dla serwera X.org.
339
340 %package source
341 Summary:        X.org server source code
342 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
343 Group:          X11/Development/Libraries
344
345 %description source
346 X.org server source code.
347
348 %description source -l pl.UTF-8
349 Pliki źródłowe dla serwera X.org.
350
351 %package -n xorg-xserver-libglx
352 Summary:        GLX extension library for X.org server
353 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
354 Group:          X11/Servers
355 Requires:       %{name} = %{version}-%{release}
356 # Mesa version glapi tables in glx/ dir come from
357 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
358 Provides:       xorg-xserver-module(glx)
359 Obsoletes:      X11-OpenGL-core < 1:7.0.0
360 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
361
362 %description -n xorg-xserver-libglx
363 GLX extension library for X.org server.
364
365 %description -n xorg-xserver-libglx -l pl.UTF-8
366 Biblioteka rozszerzenia GLX dla serwera X.org.
367
368 %prep
369 %setup -q -n xorg-server-%{version}
370 %patch0 -p0
371 %patch1 -p1
372
373 %patch4 -p1
374 %patch5 -p1
375 %patch6 -p1
376
377 #unfortunately breaks build
378 #patch7 -p1
379
380 # xserver uses pixman-1 API/ABI so put that explictly here
381 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
382
383 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
384 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
385
386 %build
387 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
388 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
389         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
390         exit 1
391 fi
392
393 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
394 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
395         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
396         exit 1
397 fi
398
399 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
400 if [ $API != %{xorg_xserver_server_font_abi} ]; then
401         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
402         exit 1
403 fi
404 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
405 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
406         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
407         exit 1
408 fi
409 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
410 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
411         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
412         exit 1
413 fi
414
415 %{__libtoolize}
416 %{__aclocal} -I m4
417 %{__autoconf}
418 %{__autoheader}
419 %{__automake}
420 %configure \
421         --with-os-name="PLD/Linux" \
422         --with-os-vendor="PLD/Team" \
423         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
424         --with-xkb-output=/var/lib/xkb \
425         %{!?with_systemtap:--without-dtrace} \
426         --without-fop \
427         --disable-linux-acpi \
428         --disable-linux-apm \
429         --enable-aiglx \
430         %{?with_dbus:--enable-config-dbus} \
431         --enable-config-hal%{!?with_hal:=no} \
432         --enable-config-udev%{!?with_udev:=no} \
433         --enable-dga \
434         %{?with_dmx:--enable-dmx} \
435         --enable-dri2%{!?with_dri2:=no} \
436         --enable-glx-tls \
437         --enable-install-libxf86config \
438         --enable-kdrive \
439         --enable-libunwind \
440         %{?with_record:--enable-record} \
441         --enable-secure-rpc \
442         %{?with_xcsecurity:--enable-xcsecurity} \
443         --enable-xephyr \
444         %{?with_xf86bigfont:--enable-xf86bigfont} \
445         --disable-xfake \
446         --enable-xfbdev \
447         %{?with_xselinux:--enable-xselinux}
448
449 %{__make}
450
451 %install
452 rm -rf $RPM_BUILD_ROOT
453
454 %if "%{_libdir}" != "%{_exec_prefix}/lib"
455 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
456 %endif
457
458 %{__make} install \
459         DESTDIR=$RPM_BUILD_ROOT
460
461 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
462 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
463 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
464 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
465 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
466
467 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
468 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
469
470 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
471
472 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
473
474 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
475 install -d $RPM_BUILD_ROOT/etc/sysconfig
476 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
477 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
478
479 # prepare source package
480 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
481 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
482 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
483 %{__make} distclean
484 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
485 find -name '*.h' | xargs chmod a-x
486
487 %if %{with systemtap}
488 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
489 %endif
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %triggerpostun -- xorg-xserver-server < 1.5.0
495 if [ -f /etc/X11/xorg.conf ]; then
496         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
497         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
498 %if %{without record}
499         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
500 %endif
501         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
502 fi
503
504 %post -n xorg-xserver-Xvfb-init
505 /sbin/chkconfig --add Xvfb
506 %service Xvfb restart
507
508 %preun -n xorg-xserver-Xvfb-init
509 if [ "$1" = "0" ]; then
510         %service -q Xvfb stop
511         /sbin/chkconfig --del Xvfb
512 fi
513
514 %files
515 %defattr(644,root,root,755)
516 %doc COPYING ChangeLog README
517 %attr(755,root,root) %{_bindir}/X
518 %attr(755,root,root) %{_bindir}/Xorg
519 %attr(4755,root,root) %{_bindir}/Xwrapper
520 %attr(755,root,root) %{_bindir}/cvt
521 %attr(755,root,root) %{_bindir}/gtf
522 %dir %{_libdir}/xorg
523 %{_libdir}/xorg/protocol.txt
524 %dir %{_libdir}/xorg/modules
525 %dir %{_libdir}/xorg/modules/dri
526 %dir %{_libdir}/xorg/modules/drivers
527 %dir %{_libdir}/xorg/modules/extensions
528 %dir %{_libdir}/xorg/modules/input
529 %dir %{_libdir}/xorg/modules/multimedia
530 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
531 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
532 %if "%{_libdir}" != "%{_exec_prefix}/lib"
533 %dir %{_exec_prefix}/lib/xorg
534 %dir %{_exec_prefix}/lib/xorg/modules
535 %dir %{_exec_prefix}/lib/xorg/modules/dri
536 %endif
537 %dir /var/lib/xkb
538 /var/lib/xkb/README.compiled
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
541 %config(missingok) /etc/security/console.apps/xserver
542 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
543 %dir /etc/X11/xorg.conf.d
544 %dir %{_datadir}/X11/xorg.conf.d
545 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
546 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
547 %{_mandir}/man1/Xorg.1*
548 %{_mandir}/man1/Xserver.1*
549 %{_mandir}/man1/cvt.1*
550 %{_mandir}/man1/gtf.1*
551 %{_mandir}/man4/exa.4*
552 %{_mandir}/man4/fbdevhw.4*
553 %{_mandir}/man5/xorg.conf.5*
554 %{_mandir}/man5/xorg.conf.d.5*
555
556 %if %{with dmx}
557 %files -n xorg-xserver-Xdmx
558 %defattr(644,root,root,755)
559 %attr(755,root,root) %{_bindir}/Xdmx
560 %attr(755,root,root) %{_bindir}/dmxaddinput
561 %attr(755,root,root) %{_bindir}/dmxaddscreen
562 %attr(755,root,root) %{_bindir}/dmxinfo
563 %attr(755,root,root) %{_bindir}/dmxreconfig
564 %attr(755,root,root) %{_bindir}/dmxresize
565 %attr(755,root,root) %{_bindir}/dmxrminput
566 %attr(755,root,root) %{_bindir}/dmxrmscreen
567 %attr(755,root,root) %{_bindir}/dmxtodmx
568 %attr(755,root,root) %{_bindir}/dmxwininfo
569 %attr(755,root,root) %{_bindir}/vdltodmx
570 %attr(755,root,root) %{_bindir}/xdmxconfig
571 %{_mandir}/man1/Xdmx.1*
572 %{_mandir}/man1/dmxtodmx.1*
573 %{_mandir}/man1/vdltodmx.1*
574 %{_mandir}/man1/xdmxconfig.1*
575 %endif
576
577 %files -n xorg-xserver-Xnest
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_bindir}/Xnest
580 %{_mandir}/man1/Xnest.1*
581
582 %files -n xorg-xserver-Xephyr
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_bindir}/Xephyr
585 %{_mandir}/man1/Xephyr.1*
586
587 %files -n xorg-xserver-Xfbdev
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/Xfbdev
590
591 %files -n xorg-xserver-Xvfb
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/Xvfb
594 %attr(755,root,root) %{_bindir}/xvfb-run
595 %{_mandir}/man1/Xvfb.1*
596
597 %files -n xorg-xserver-Xvfb-init
598 %defattr(644,root,root,755)
599 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
600 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
601
602 %files devel
603 %defattr(644,root,root,755)
604 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
605 %{_includedir}/xorg
606 %{_libdir}/libxf86config.a
607 %{_libdir}/libxf86config.la
608 %{_aclocaldir}/xorg-server.m4
609 %{_pkgconfigdir}/xorg-server.pc
610
611 %files source
612 %defattr(644,root,root,755)
613 # keep file perms from install time, but have default defattr to keep adapter happy
614 %defattr(-,root,root,755)
615 %{_usrsrc}/%{name}-%{version}
616
617 %files -n xorg-xserver-libglx
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.123145 seconds and 3 git commands to generate.