]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- xnest, xvfb, xephyr bconds
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  xnest           # Xnest DDX (Xnest server)
18 %bcond_without  xvfb            # Xvfb DDX (Xvfb server)
19 %bcond_without  xephyr          # kdrive Xephyr server
20 %bcond_with     eglstream       # XWayland eglstream support
21 %bcond_without  glamor          # glamor dix module
22 %bcond_without  systemtap       # systemtap/dtrace probes
23 %bcond_without  libunwind       # use libunwind for backtracing
24 #
25 # ABI versions, see hw/xfree86/common/xf86Module.h
26 %define xorg_xserver_server_ansic_abi           0.4
27 %define xorg_xserver_server_extension_abi       10.0
28 %define xorg_xserver_server_videodrv_abi        24.1
29 %define xorg_xserver_server_xinput_abi          24.1
30
31 %define pixman_ver      0.30.0
32
33 %ifarch x32
34 %undefine       with_libunwind
35 %endif
36
37 Summary:        X.org server
38 Summary(pl.UTF-8):      Serwer X.org
39 Name:           xorg-xserver-server
40 Version:        1.20.11
41 Release:        2
42 License:        MIT
43 Group:          X11/Servers
44 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
45 # Source0-md5:  a22ccd74a5eee721cad6805e489c7144
46 Source1:        10-quirks.conf
47 Source2:        xserver.pamd
48 Source10:       %{name}-Xvfb.init
49 Source11:       %{name}-Xvfb.sysconfig
50 Source12:       xvfb-run.sh
51 Patch1:         %{name}-xwrapper-pam.patch
52
53 Patch4:         %{name}-builtin-SHA1.patch
54
55 Patch6:         110_nvidia_slowdow_fix.patch
56 Patch7:         platform_probe_crash.patch
57 URL:            https://xorg.freedesktop.org/
58 BuildRequires:  Mesa-libGL-devel >= 7.8.1
59 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
60 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
61 # for glx headers
62 BuildRequires:  OpenGL-GLX-devel
63 %{?with_xselinux:BuildRequires: audit-libs-devel}
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  cpp
67 BuildRequires:  docbook-dtd43-xml
68 #BuildRequires: doxygen >= 1.6.1
69 %if %{with hal} || %{with dbus}
70 BuildRequires:  dbus-devel >= 1.0
71 %endif
72 %{?with_eglstream:BuildRequires:        egl-wayland-devel >= 1.0.2}
73 %{?with_hal:BuildRequires:      hal-devel}
74 BuildRequires:  libdrm-devel >= 2.4.89
75 %if %{with glamor}
76 BuildRequires:  libepoxy-devel >= 1.5.4
77 %endif
78 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
79 BuildRequires:  libtirpc-devel
80 BuildRequires:  libtool >= 2:2.2
81 %{?with_libunwind:BuildRequires:        libunwind-devel}
82 BuildRequires:  libxcb-devel >= 1.9.3
83 BuildRequires:  pam-devel
84 BuildRequires:  perl-base
85 BuildRequires:  pixman-devel >= %{pixman_ver}
86 BuildRequires:  pkgconfig >= 1:0.19
87 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
88 BuildRequires:  systemd-devel >= 1:209
89 BuildRequires:  udev-devel >= 1:143
90 # wayland-client
91 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
92 %{?with_wayland:BuildRequires:  wayland-protocols >= 1.10}
93 BuildRequires:  xcb-util-devel
94 BuildRequires:  xcb-util-image-devel
95 BuildRequires:  xcb-util-keysyms-devel
96 BuildRequires:  xcb-util-renderutil-devel
97 BuildRequires:  xcb-util-wm-devel
98 BuildRequires:  xmlto >= 0.0.20
99 BuildRequires:  xorg-app-mkfontscale
100 BuildRequires:  xorg-font-font-util >= 1.1
101 BuildRequires:  xorg-lib-libX11-devel >= 1.6
102 BuildRequires:  xorg-lib-libXau-devel
103 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
104 BuildRequires:  xorg-lib-libXdamage-devel
105 BuildRequires:  xorg-lib-libXdmcp-devel
106 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
107 BuildRequires:  xorg-lib-libXfixes-devel
108 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
109 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
110 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
111 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
112 BuildRequires:  xorg-lib-libXrender-devel
113 BuildRequires:  xorg-lib-libXres-devel
114 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
115 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
116 BuildRequires:  xorg-lib-libXv-devel
117 BuildRequires:  xorg-lib-libXxf86dga-devel
118 BuildRequires:  xorg-lib-libXxf86misc-devel
119 BuildRequires:  xorg-lib-libXxf86vm-devel
120 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
121 BuildRequires:  xorg-lib-libfontenc-devel
122 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
123 BuildRequires:  xorg-lib-libxkbfile-devel
124 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
125 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
126 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
127 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
128 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
129 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
130 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
131 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
132 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
133 BuildRequires:  xorg-proto-fontcacheproto-devel
134 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
135 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
136 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
137 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
138 BuildRequires:  xorg-proto-presentproto-devel >= 1.1
139 BuildRequires:  xorg-proto-printproto-devel
140 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
141 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
142 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
143 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
144 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
145 BuildRequires:  xorg-proto-videoproto-devel
146 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
147 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
148 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
149 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
150 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
151 BuildRequires:  xorg-proto-xf86miscproto-devel
152 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
153 BuildRequires:  xorg-proto-xineramaproto-devel
154 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
155 BuildRequires:  xorg-sgml-doctools >= 1.8
156 BuildRequires:  xorg-util-util-macros >= 1.14
157 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
158 Requires:       libdrm >= 2.4.89
159 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
160 Requires:       pixman >= %{pixman_ver}
161 Requires:       sed >= 4.0
162 Requires:       udev-libs >= 1:143
163 Requires:       xkeyboard-config
164 # for rgb.txt
165 Requires:       xorg-app-rgb >= 0.99.3
166 Requires:       xorg-app-xkbcomp
167 Requires:       xorg-lib-libXfont2 >= 2.0.0
168 Requires:       xorg-lib-libpciaccess >= 0.12.901
169 Requires:       xorg-lib-libxshmfence >= 1.1
170 # for protocol.txt
171 Requires:       xorg-xserver-common = %{version}-%{release}
172 Suggests:       dbus-x11 >= 1.0
173 %{?with_hal:Suggests:   hal}
174 Suggests:       udev-acl >= 1:143
175 %{?with_udev:Suggests:  udev-core >= 1:143}
176 Suggests:       xkeyboard-config
177 Suggests:       xorg-driver-input-libinput
178 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
179 Suggests:       xorg-driver-video
180 Provides:       xorg-driver-video-modesetting
181 Provides:       xorg-xserver-libdri = %{version}-%{release}
182 Provides:       xorg-xserver-module(dri)
183 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
184 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
185 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
186 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
187 Obsoletes:      X11-Xserver < 1:7.0.0
188 Obsoletes:      X11-driver-i2c < 1:7.0.0
189 Obsoletes:      X11-modules < 1:7.0.0
190 Obsoletes:      X11-setup < 1:7.0.0
191 Obsoletes:      XFree86-Xserver < 1:7.0.0
192 Obsoletes:      XFree86-modules < 1:7.0.0
193 Obsoletes:      XFree86-setup < 1:7.0.0
194 Obsoletes:      Xserver < 7.0
195 %{?with_glamor:Obsoletes:       glamor < 0.6.1}
196 Obsoletes:      xorg-xserver-libdri < 1.12.99
197 Obsoletes:      xorg-xserver-server-xorgcfg < 1.5.99
198 Obsoletes:      xorg-driver-video-modesetting < 0.9.1
199 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
200
201 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
202 %define         tirpc_libs      $(pkg-config --libs libtirpc)
203
204 %description
205 Xorg server is a generally used X server which uses display hardware.
206 It requires proper driver for your display hardware.
207
208 %description -l pl.UTF-8
209 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
210 graficznej. Do działania wymaga odpowiedniego sterownika.
211
212 %package devel
213 Summary:        Header files for X.org server
214 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
215 Group:          X11/Development/Libraries
216 Requires:       Mesa-libGL-devel >= 7.8.0
217 Requires:       libdrm-devel >= 2.4.89
218 Requires:       pixman-devel >= %{pixman_ver}
219 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
220 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
221 Requires:       xorg-lib-libxkbfile-devel
222 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
223 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
224 Requires:       xorg-proto-dri3proto-devel >= 1.0
225 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
226 Requires:       xorg-proto-glproto-devel >= 1.4.17
227 Requires:       xorg-proto-inputproto-devel >= 2.3
228 Requires:       xorg-proto-kbproto-devel >= 1.0.3
229 Requires:       xorg-proto-presentproto-devel >= 1.1
230 Requires:       xorg-proto-randrproto-devel >= 1.6.0
231 Requires:       xorg-proto-renderproto-devel >= 0.11
232 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
233 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
234 Requires:       xorg-proto-videoproto-devel
235 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
236 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
237 Requires:       xorg-proto-xineramaproto-devel
238 Requires:       xorg-proto-xproto-devel >= 7.0.31
239 Obsoletes:      X11-Xserver-devel < 1:7.0.0
240 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
241 %{?with_glamor:Obsoletes:       glamor-devel < 0.6.1}
242
243 %description devel
244 Header files for X.org server.
245
246 %description devel -l pl.UTF-8
247 Pliki nagłówkowe dla serwera X.org.
248
249 %package source
250 Summary:        X.org server source code
251 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
252 Group:          X11/Development/Libraries
253
254 %description source
255 X.org server source code.
256
257 %description source -l pl.UTF-8
258 Pliki źródłowe dla serwera X.org.
259
260 %package -n xorg-xserver-libglx
261 Summary:        GLX extension library for X.org server
262 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
263 Group:          X11/Servers
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       Mesa-libGL >= 7.1.0
266 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
267 # Mesa version glapi tables in glx/ dir come from
268 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
269 Provides:       xorg-xserver-module(glx)
270 Obsoletes:      X11-OpenGL-core < 1:7.0.0
271 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
272
273 %description -n xorg-xserver-libglx
274 GLX extension library for X.org server.
275
276 %description -n xorg-xserver-libglx -l pl.UTF-8
277 Biblioteka rozszerzenia GLX dla serwera X.org.
278
279 %package -n xorg-xserver-Xdmx
280 Summary:        Xdmx - distributed multi-head X server
281 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
282 Group:          X11/Servers
283 Requires:       pixman >= %{pixman_ver}
284 Requires:       xorg-lib-libX11 >= 1.6
285 Requires:       xorg-lib-libXext >= 1.0.99.4
286 Requires:       xorg-lib-libXfont2 >= 2.0.0
287 Requires:       xorg-lib-libXi >= 1.2.99.1
288 Requires:       xorg-lib-libdmx >= 1.0.99.1
289
290 %description -n xorg-xserver-Xdmx
291 Xdmx - distributed multi-head X server.
292
293 %description -n xorg-xserver-Xdmx -l pl.UTF-8
294 Xdmx - rozproszony, wielomonitorowy serwer X.
295
296 %package -n xorg-xserver-Xephyr
297 Summary:        Xephyr - nested X server
298 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
299 Group:          X11/Servers
300 Requires:       Mesa-libGL >= 7.1.0
301 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
302 Requires:       libxcb >= 1.9.3
303 Requires:       pixman >= %{pixman_ver}
304 Requires:       xorg-lib-libXfont2 >= 2.0.0
305
306 %description -n xorg-xserver-Xephyr
307 Xephyr is a kdrive server that outputs to a window on a pre-existing
308 'host' X display. Think Xnest but with support for modern extensions
309 like composite, damage and randr.
310
311 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
312 the host X server, Xephyr is a real X server which uses the host X
313 server window as "framebuffer" via fast SHM XImages.
314
315 It also has support for 'visually' debugging what the server is
316 painting.
317
318 %description -n xorg-xserver-Xephyr -l pl.UTF-8
319 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
320 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
321 wspólczesnych rozszerzeń jak composite, damage i randr.
322
323 %package -n xorg-xserver-Xnest
324 Summary:        Xnest - nested X server
325 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
326 Group:          X11/Servers
327 Requires:       pixman >= %{pixman_ver}
328 Requires:       xorg-lib-libXext >= 1.0.99.4
329 Requires:       xorg-lib-libXfont2 >= 2.0.0
330 Obsoletes:      X11-Xnest < 1:7.0.0
331 Obsoletes:      XFree86-Xnest < 1:7.0.0
332 Obsoletes:      Xserver-Xnest < 7.0
333
334 %description -n xorg-xserver-Xnest
335 Xnest is an X Window System server which runs in an X window. Xnest is
336 a 'nested' window server, actually a client of the real X server,
337 which manages windows and graphics requests for Xnest, while Xnest
338 manages the windows and graphics requests for its own clients.
339
340 %description -n xorg-xserver-Xnest -l pl.UTF-8
341 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
342 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
343 serwer X dla własnych klientów.
344
345 %description -n xorg-xserver-Xnest -l ru.UTF-8
346 Xnest - это сервер X Window System, который работает в окне X. На
347 самом деле это клиент реального X-сервера, который управляет окнами и
348 графическими запросами для Xnest в то время, как Xnest управляет
349 окнами и графическими запросами для своих собственных клиентов.
350
351 %description -n xorg-xserver-Xnest -l uk.UTF-8
352 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
353 клієнт реального X-сервера, який керує вікнами та графічними запитами
354 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
355 своїх власних клієнтів.
356
357 %package -n xorg-xserver-Xvfb
358 Summary:        Xvfb - virtual framebuffer X server
359 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
360 Group:          X11/Servers
361 Requires:       Mesa-libGL >= 7.1.0
362 Requires:       mktemp
363 Requires:       pixman >= %{pixman_ver}
364 Requires:       util-linux
365 Requires:       which
366 Requires:       xkeyboard-config
367 Requires:       xorg-app-xauth
368 Requires:       xorg-app-xkbcomp
369 Requires:       xorg-lib-libXfont2 >= 2.0.0
370 Obsoletes:      X11-Xvfb < 1:7.0.0
371 Obsoletes:      XFree86-Xvfb < 1:7.0.0
372
373 %description -n xorg-xserver-Xvfb
374 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
375 capable of running on machines with no display hardware and no
376 physical input devices. Xvfb emulates a dumb framebuffer using virtual
377 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
378 display. Xvfb is normally used for testing servers. Using Xvfb, the
379 mfb or cfb code for any depth can be exercised without using real
380 hardware that supports the desired depths. Xvfb has also been used to
381 test X clients against unusual depths and screen configurations, to do
382 batch processing with Xvfb as a background rendering engine, to do
383 load testing, to help with porting an X server to a new platform, and
384 to provide an unobtrusive way of running applications which really
385 don't need an X server but insist on having one.
386
387 %description -n xorg-xserver-Xvfb -l pl.UTF-8
388 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
389 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
390 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
391 używany do testowania serwerów X, może też być używany do testowania
392 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
393 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
394 serwera X, ale odmawiają uruchomienia bez niego.
395
396 %package -n xorg-xserver-Xvfb-init
397 Summary:        Init scripts for Xvfb
398 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
399 Group:          X11/Servers
400 Requires:       xorg-xserver-Xvfb = %{version}-%{release}
401
402 %description -n xorg-xserver-Xvfb-init
403 This package contains init scripts for Xvfb and registers Xvfb as
404 system service.
405
406 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
407 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
408 usługę systemową.
409
410 %package -n xorg-xserver-Xwayland
411 Summary:        Xwayland - X server integrated into a Wayland window system
412 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
413 Group:          X11/Servers
414 %{?with_eglstream:Requires:     egl-wayland >= 1.0.2}
415 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
416 Requires:       pixman >= %{pixman_ver}
417 Requires:       xorg-lib-libX11 >= 1.6
418 Requires:       xorg-lib-libXext >= 1.0.99.4
419 Requires:       xorg-lib-libXfont2 >= 2.0.0
420 Requires:       xorg-lib-libXi >= 1.2.99.1
421 # for protocol.txt
422 Requires:       xorg-xserver-common = %{version}-%{release}
423
424 %description -n xorg-xserver-Xwayland
425 Xwayland - server integrated into a Wayland window system.
426
427 %description -n xorg-xserver-Xwayland -l pl.UTF-8
428 Xwayland - serwer X integrowalny w Wayland.
429
430 %package -n xorg-xserver-common
431 Summary:        Common files for various X servers
432 Summary(pl.UTF-8):      Pliki wspólne dla serwerów X
433 Group:          X11/Servers
434 Conflicts:      xorg-xserver-server < 1.20.11-2
435
436 %description -n xorg-xserver-common
437 Common files for various X servers.
438
439 %description -n xorg-xserver-common -l pl.UTF-8
440 Pliki wspólne dla serwerów X.
441
442 %prep
443 %setup -q -n xorg-server-%{version}
444 %patch1 -p1
445
446 %patch4 -p1
447
448 %patch6 -p1
449 %patch7 -p1
450
451 # xserver uses pixman-1 API/ABI so put that explictly here
452 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
453
454 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
455 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
456
457 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
458
459 %build
460 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
461 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
462         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
463         exit 1
464 fi
465
466 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
467 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
468         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
469         exit 1
470 fi
471
472 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
473 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
474         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
475         exit 1
476 fi
477 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
478 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
479         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
480         exit 1
481 fi
482
483 %{__libtoolize}
484 %{__aclocal} -I m4
485 %{__autoconf}
486 %{__autoheader}
487 %{__automake}
488 %configure \
489         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
490         LIBS="%{tirpc_libs}" \
491         --libexecdir=%{_libdir}/xorg \
492         --with-os-name="PLD/Linux" \
493         --with-os-vendor="PLD/Team" \
494         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
495         --with-xkb-output=/var/lib/xkb \
496         --disable-linux-acpi \
497         --disable-linux-apm \
498         %{?with_dbus:--enable-config-dbus} \
499         --enable-config-hal%{!?with_hal:=no} \
500         --enable-config-udev%{!?with_udev:=no} \
501         --enable-dga \
502         %{?with_dmx:--enable-dmx} \
503         --enable-dri2%{!?with_dri2:=no} \
504         --enable-dri3%{!?with_dri3:=no} \
505         %{?with_glamor:--enable-glamor} \
506         --enable-kdrive \
507         %{?with_libunwind:--enable-libunwind} \
508         %{?with_record:--enable-record} \
509         --enable-secure-rpc \
510         --enable-suid-wrapper \
511         %{?with_xcsecurity:--enable-xcsecurity} \
512         --enable-xephyr%{!?with_xephyr:=no} \
513         %{?with_xf86bigfont:--enable-xf86bigfont} \
514         --enable-xnest%{!?with_xnest:=no} \
515         %{?with_xselinux:--enable-xselinux} \
516         %{!?with_xvfb:--disable-xvfb} \
517         %{?with_wayland:--enable-xwayland} \
518         %{?with_eglstream:--enable-xwayland-eglstream} \
519         %{!?with_systemtap:--without-dtrace} \
520         --without-fop \
521         --with-systemd-daemon
522
523 %{__make}
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527
528 %if "%{_libdir}" != "%{_exec_prefix}/lib"
529 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
530 %endif
531
532 %{__make} install \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
536 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
537 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
538 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
539 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
540
541 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
542 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
543
544 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
545
546 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
547
548 %if %{with xvfb}
549 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
550 install -d $RPM_BUILD_ROOT/etc/sysconfig
551 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
552 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
553 %endif
554
555 # Xorg.wrap config
556 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
557 # allowed values: rootonly console anybody pam
558 allowed_users = pam
559
560 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
561 #needs_root_rights = yes
562 EOF
563
564 # compatibility with old xwrapper
565 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
566
567 # prepare source package
568 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
569 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
570 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
571 %{__make} distclean
572 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
573 find -name '*.h' | xargs chmod a-x
574
575 %if %{with systemtap}
576 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
577 %endif
578
579 %clean
580 rm -rf $RPM_BUILD_ROOT
581
582 %triggerpostun -- xorg-xserver-server < 1.5.0
583 if [ -f /etc/X11/xorg.conf ]; then
584         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
585         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
586 %if %{without record}
587         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
588 %endif
589         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
590 fi
591
592 %post -n xorg-xserver-Xvfb-init
593 /sbin/chkconfig --add Xvfb
594 %service Xvfb restart
595
596 %preun -n xorg-xserver-Xvfb-init
597 if [ "$1" = "0" ]; then
598         %service -q Xvfb stop
599         /sbin/chkconfig --del Xvfb
600 fi
601
602 %files
603 %defattr(644,root,root,755)
604 %doc COPYING ChangeLog README.md
605 %attr(755,root,root) %{_bindir}/X
606 %attr(755,root,root) %{_bindir}/Xorg
607 %attr(4755,root,root) %{_bindir}/Xwrapper
608 %attr(755,root,root) %{_bindir}/cvt
609 %attr(755,root,root) %{_bindir}/gtf
610 %attr(755,root,root) %{_libdir}/xorg/Xorg
611 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
612 %dir %{_libdir}/xorg/modules
613 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
614 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
615 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
616 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
617 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
618 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
619 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
620 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
621 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
622 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
623 %dir %{_libdir}/xorg/modules/dri
624 %dir %{_libdir}/xorg/modules/drivers
625 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
626 %dir %{_libdir}/xorg/modules/extensions
627 %dir %{_libdir}/xorg/modules/input
628 %if "%{_libdir}" != "%{_exec_prefix}/lib"
629 %dir %{_exec_prefix}/lib/xorg
630 %dir %{_exec_prefix}/lib/xorg/modules
631 %dir %{_exec_prefix}/lib/xorg/modules/dri
632 %endif
633 %dir /var/lib/xkb
634 /var/lib/xkb/README.compiled
635 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
636 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
637 %config(missingok) /etc/security/console.apps/xserver
638 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
639 %dir /etc/X11/xorg.conf.d
640 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
641 %dir %{_datadir}/X11/xorg.conf.d
642 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
643 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
644 %{_mandir}/man1/Xorg.1*
645 %{_mandir}/man1/Xorg.wrap.1*
646 %{_mandir}/man1/cvt.1*
647 %{_mandir}/man1/gtf.1*
648 %{_mandir}/man4/exa.4*
649 %{_mandir}/man4/fbdevhw.4*
650 %{_mandir}/man4/modesetting.4*
651 %{_mandir}/man5/Xwrapper.config.5*
652 %{_mandir}/man5/xorg.conf.5*
653 %{_mandir}/man5/xorg.conf.d.5*
654
655 %files devel
656 %defattr(644,root,root,755)
657 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
658 %{_includedir}/xorg
659 %{_aclocaldir}/xorg-server.m4
660 %{_pkgconfigdir}/xorg-server.pc
661
662 %files source
663 %defattr(644,root,root,755)
664 # keep file perms from install time, but have default defattr to keep adapter happy
665 %defattr(-,root,root,755)
666 %{_usrsrc}/%{name}-%{version}
667
668 %files -n xorg-xserver-libglx
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
671
672 %if %{with dmx}
673 %files -n xorg-xserver-Xdmx
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/Xdmx
676 %attr(755,root,root) %{_bindir}/dmxaddinput
677 %attr(755,root,root) %{_bindir}/dmxaddscreen
678 %attr(755,root,root) %{_bindir}/dmxinfo
679 %attr(755,root,root) %{_bindir}/dmxreconfig
680 %attr(755,root,root) %{_bindir}/dmxresize
681 %attr(755,root,root) %{_bindir}/dmxrminput
682 %attr(755,root,root) %{_bindir}/dmxrmscreen
683 %attr(755,root,root) %{_bindir}/dmxtodmx
684 %attr(755,root,root) %{_bindir}/dmxwininfo
685 %attr(755,root,root) %{_bindir}/vdltodmx
686 %attr(755,root,root) %{_bindir}/xdmxconfig
687 %{_mandir}/man1/Xdmx.1*
688 %{_mandir}/man1/dmxtodmx.1*
689 %{_mandir}/man1/vdltodmx.1*
690 %{_mandir}/man1/xdmxconfig.1*
691 %endif
692
693 %if %{with xephyr}
694 %files -n xorg-xserver-Xephyr
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_bindir}/Xephyr
697 %{_mandir}/man1/Xephyr.1*
698 %endif
699
700 %if %{with xnest}
701 %files -n xorg-xserver-Xnest
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_bindir}/Xnest
704 %{_mandir}/man1/Xnest.1*
705 %endif
706
707 %if %{with xvfb}
708 %files -n xorg-xserver-Xvfb
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/Xvfb
711 %attr(755,root,root) %{_bindir}/xvfb-run
712 %{_mandir}/man1/Xvfb.1*
713
714 %files -n xorg-xserver-Xvfb-init
715 %defattr(644,root,root,755)
716 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
717 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
718 %endif
719
720 %if %{with wayland}
721 %files -n xorg-xserver-Xwayland
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_bindir}/Xwayland
724 %endif
725
726 %files -n xorg-xserver-common
727 %defattr(644,root,root,755)
728 %dir %{_libdir}/xorg
729 %{_libdir}/xorg/protocol.txt
730 %{_mandir}/man1/Xserver.1*
This page took 0.069174 seconds and 3 git commands to generate.