]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
9d5f2d36d24a937ece517bb98e61a2f5b457d402
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_with     dbus    # D-BUS support
6 %bcond_with     hal     # HAL support
7 %bcond_without  udev    # UDEV support
8 %bcond_without  dmx     # DMX support
9 %bcond_with     record  # RECORD extension
10 #
11 # ABI versions, see hw/xfree86/common/xf86Module.h
12 %define xorg_xserver_server_ansic_abi           0.4
13 %define xorg_xserver_server_extension_abi       3.0
14 %define xorg_xserver_server_font_abi            0.6
15 %define xorg_xserver_server_videodrv_abi        7.0
16 %define xorg_xserver_server_xinput_abi          9.0
17
18 %define         rel             4
19 Summary:        X.org server
20 Summary(pl.UTF-8):      Serwer X.org
21 Name:           xorg-xserver-server
22 Version:        1.8.0
23 Release:        %{rel}%{?with_multigl:.mgl}
24 License:        MIT
25 Group:          X11/Servers
26 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
27 # Source0-md5:  7cec3a11890bb53f4a07854319360348
28 Source2:        xserver.pamd
29 Patch0:         %{name}-xwrapper.patch
30 Patch1:         %{name}-pic-libxf86config.patch
31 Patch2:         %{name}-fb-size.patch
32 Patch3:         %{name}-less-acpi-brokenness.patch
33 URL:            http://xorg.freedesktop.org/
34 BuildRequires:  Mesa-libGL-devel >= 7.8.1
35 # for glx headers
36 BuildRequires:  OpenGL-GLX-devel
37 BuildRequires:  autoconf >= 2.57
38 BuildRequires:  automake
39 BuildRequires:  cpp
40 %if %{with hal} || %{with dbus}
41 BuildRequires:  dbus-devel
42 %endif
43 %{?with_hal:BuildRequires:      hal-devel}
44 BuildRequires:  libdrm-devel >= 2.4.5
45 BuildRequires:  libtool
46 BuildRequires:  ncurses-devel
47 BuildRequires:  openssl-devel
48 BuildRequires:  pam-devel
49 BuildRequires:  perl-base
50 BuildRequires:  pixman-devel >= 0.16.0
51 BuildRequires:  pkgconfig >= 1:0.19
52 BuildRequires:  udev-devel
53 BuildRequires:  xorg-app-mkfontscale
54 BuildRequires:  xorg-font-font-util >= 1.1
55 BuildRequires:  xorg-lib-libX11-devel
56 BuildRequires:  xorg-lib-libXau-devel
57 BuildRequires:  xorg-lib-libXaw-devel
58 BuildRequires:  xorg-lib-libXdamage-devel
59 BuildRequires:  xorg-lib-libXdmcp-devel
60 BuildRequires:  xorg-lib-libXext-devel
61 BuildRequires:  xorg-lib-libXfont-devel
62 BuildRequires:  xorg-lib-libXi-devel >= 1.2
63 BuildRequires:  xorg-lib-libXmu-devel
64 BuildRequires:  xorg-lib-libXpm-devel
65 BuildRequires:  xorg-lib-libXrender-devel
66 BuildRequires:  xorg-lib-libXres-devel
67 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
68 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
69 BuildRequires:  xorg-lib-libXv-devel
70 BuildRequires:  xorg-lib-libXxf86dga-devel
71 BuildRequires:  xorg-lib-libXxf86misc-devel
72 BuildRequires:  xorg-lib-libXxf86vm-devel
73 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
74 BuildRequires:  xorg-lib-libfontenc-devel
75 BuildRequires:  xorg-lib-libpciaccess-devel
76 BuildRequires:  xorg-lib-libxkbfile-devel
77 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
78 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
79 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
80 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
81 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
82 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel}
83 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.1}
84 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
85 BuildRequires:  xorg-proto-fontcacheproto-devel
86 BuildRequires:  xorg-proto-fontsproto-devel
87 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
88 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
89 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
90 BuildRequires:  xorg-proto-printproto-devel
91 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
92 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel}
93 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
94 BuildRequires:  xorg-proto-resourceproto-devel
95 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
96 BuildRequires:  xorg-proto-videoproto-devel
97 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
98 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
99 BuildRequires:  xorg-proto-xf86bigfontproto-devel
100 BuildRequires:  xorg-proto-xf86dgaproto-devel
101 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.0.4
102 BuildRequires:  xorg-proto-xf86miscproto-devel
103 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
104 BuildRequires:  xorg-proto-xineramaproto-devel
105 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
106 BuildRequires:  xorg-util-util-macros >= 1.5
107 #BR: xcalibrateproto, tslib (for KDRIVE only)
108 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
109 Requires(triggerpostun):        sed >= 4.0
110 Requires:       pixman >= 0.16.0
111 Requires:       xkeyboard-config
112 # for rgb.txt
113 Requires:       xorg-app-rgb >= 0.99.3
114 Requires:       xorg-app-xkbcomp
115 # xserver default config expects evdev+dbus+hald
116 %{?with_hal:Suggests:   dbus}
117 Suggests:       hal
118 Suggests:       udev-acl
119 Suggests:       xorg-driver-input-evdev
120 # xserver requires fixed and cursor fonts
121 Requires:       xorg-font-font-alias
122 Requires:       xorg-font-font-cursor-misc
123 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
124 Suggests:       xkeyboard-config
125 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
126 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
127 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
128 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
129 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
130 Obsoletes:      X11-Xserver < 1:7.0.0
131 Obsoletes:      X11-driver-i2c < 1:7.0.0
132 Obsoletes:      X11-modules < 1:7.0.0
133 Obsoletes:      X11-setup < 1:7.0.0
134 Obsoletes:      XFree86-Xserver < 1:7.0.0
135 Obsoletes:      XFree86-modules < 1:7.0.0
136 Obsoletes:      XFree86-setup < 1:7.0.0
137 Obsoletes:      Xserver
138 Obsoletes:      xorg-xserver-server-xorgcfg
139 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
140
141 # avoid self-dependencies on included modules
142 %define         _noautoreq      libscanpci.so libxf1bpp.so
143
144 %description
145 Xorg server is a generally used X server which uses display hardware.
146 It requires proper driver for your display hardware.
147
148 %description -l pl.UTF-8
149 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
150 graficznej. Do działania wymaga odpowiedniego sterownika.
151
152 %package -n xorg-xserver-Xdmx
153 Summary:        Xdmx - distributed multi-head X server
154 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
155 Group:          X11/Servers
156
157 %description -n xorg-xserver-Xdmx
158 Xdmx - distributed multi-head X server.
159
160 %description -n xorg-xserver-Xdmx -l pl.UTF-8
161 Xdmx - rozproszony, wielomonitorowy serwer X.
162
163 %package -n xorg-xserver-Xnest
164 Summary:        Xnest - nested X server
165 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
166 Group:          X11/Servers
167 Obsoletes:      X11-Xnest < 1:7.0.0
168 Obsoletes:      XFree86-Xnest < 1:7.0.0
169 Obsoletes:      Xserver-Xnest
170
171 %description -n xorg-xserver-Xnest
172 Xnest is an X Window System server which runs in an X window. Xnest is
173 a 'nested' window server, actually a client of the real X server,
174 which manages windows and graphics requests for Xnest, while Xnest
175 manages the windows and graphics requests for its own clients.
176
177 %description -n xorg-xserver-Xnest -l pl.UTF-8
178 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
179 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
180 serwer X dla własnych klientów.
181
182 %description -n xorg-xserver-Xnest -l ru.UTF-8
183 Xnest - это сервер X Window System, который работает в окне X. На
184 самом деле это клиент реального X-сервера, который управляет окнами и
185 графическими запросами для Xnest в то время, как Xnest управляет
186 окнами и графическими запросами для своих собственных клиентов.
187
188 %description -n xorg-xserver-Xnest -l uk.UTF-8
189 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
190 клієнт реального X-сервера, який керує вікнами та графічними запитами
191 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
192 своїх власних клієнтів.
193
194 %package -n xorg-xserver-Xephyr
195 Summary:        Xephyr - nested X server
196 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
197 Group:          X11/Servers
198 Requires:       pixman >= 0.15.0
199
200 %description -n xorg-xserver-Xephyr
201 Xephyr is a a kdrive server that outputs to a window on a pre-existing
202 'host' X display. Think Xnest but with support for modern extensions
203 like composite, damage and randr.
204
205 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
206 the host X server, Xephyr is a real X server which uses the host X
207 server window as "framebuffer" via fast SHM XImages.
208
209 It also has support for 'visually' debugging what the server is
210 painting.
211
212 %description -n xorg-xserver-Xephyr -l pl.UTF-8
213 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
214 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
215 wspólczesnych rozszerzeń jak composite, damage i randr.
216
217 %package -n xorg-xserver-Xfbdev
218 Summary:        Xfbdev - Linux framebuffer device X server
219 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
220 Group:          X11/Servers
221
222 %description -n xorg-xserver-Xfbdev
223 Xfbdev is a Linux framebuffer device X server based on the kdrive X
224 server.
225
226 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
227 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
228
229 %package -n xorg-xserver-Xvfb
230 Summary:        Xvfb - virtual framebuffer X server
231 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
232 Group:          X11/Servers
233 # requires fixed and cursor fonts
234 Requires:       xorg-font-font-alias
235 Requires:       xorg-font-font-cursor-misc
236 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
237 Obsoletes:      X11-Xvfb < 1:7.0.0
238 Obsoletes:      XFree86-Xvfb < 1:7.0.0
239
240 %description -n xorg-xserver-Xvfb
241 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
242 capable of running on machines with no display hardware and no
243 physical input devices. Xvfb emulates a dumb framebuffer using virtual
244 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
245 display. Xvfb is normally used for testing servers. Using Xvfb, the
246 mfb or cfb code for any depth can be exercised without using real
247 hardware that supports the desired depths. Xvfb has also been used to
248 test X clients against unusual depths and screen configurations, to do
249 batch processing with Xvfb as a background rendering engine, to do
250 load testing, to help with porting an X server to a new platform, and
251 to provide an unobtrusive way of running applications which really
252 don't need an X server but insist on having one.
253
254 %description -n xorg-xserver-Xvfb -l pl.UTF-8
255 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
256 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
257 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
258 używany do testowania serwerów X, może też być używany do testowania
259 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
260 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
261 serwera X, ale odmawiają uruchomienia bez niego.
262
263 %package devel
264 Summary:        Header files for X.org server
265 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
266 Group:          X11/Development/Libraries
267 Requires:       libdrm-devel >= 2.4.5
268 Requires:       pixman-devel >= 0.16.0
269 Requires:       xorg-lib-libpciaccess-devel
270 Requires:       xorg-lib-libxkbfile-devel
271 Requires:       xorg-proto-dri2proto-devel >= 2.1
272 Requires:       xorg-proto-fontsproto-devel
273 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
274 Requires:       xorg-proto-randrproto-devel >= 1.2.99.3
275 Requires:       xorg-proto-renderproto-devel >= 0.9.3
276 Requires:       xorg-proto-videoproto-devel
277 Requires:       xorg-proto-xextproto-devel >= 1:7.0.99.3
278 Requires:       xorg-proto-xproto-devel >= 7.0.13
279 Obsoletes:      X11-Xserver-devel < 1:7.0.0
280 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
281
282 %description devel
283 Header files for X.org server.
284
285 %description devel -l pl.UTF-8
286 Pliki nagłówkowe dla serwera X.org.
287
288 %package -n xorg-xserver-libdri
289 Summary:        DRI extension library for X.org server
290 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
291 Group:          X11/Servers
292 Requires:       %{name} = %{version}-%{release}
293 Provides:       xorg-xserver-module(dri)
294 %if %{without multigl}
295 Conflicts:      xorg-driver-video-fglrx-libdri
296 Conflicts:      xorg-driver-video-nvidia
297 %endif
298
299 %description -n xorg-xserver-libdri
300 DRI extension library for X.org server.
301
302 %description -n xorg-xserver-libdri -l pl.UTF-8
303 Biblioteka rozszerzenia DRI dla serwera X.org.
304
305 %package -n xorg-xserver-libglx
306 Summary:        GLX extension library for X.org server
307 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
308 Group:          X11/Servers
309 Requires:       %{name} = %{version}-%{release}
310 Requires:       xorg-xserver-libdri = %{version}-%{release}
311 # Mesa version glapi tables in glx/ dir come from
312 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
313 Provides:       xorg-xserver-module(glx)
314 Obsoletes:      X11-OpenGL-core < 1:7.0.0
315 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
316 %if %{without multigl}
317 Conflicts:      xorg-driver-video-fglrx-libglx
318 Conflicts:      xorg-driver-video-nvidia
319 %endif
320
321 %description -n xorg-xserver-libglx
322 GLX extension library for X.org server.
323
324 %description -n xorg-xserver-libglx -l pl.UTF-8
325 Biblioteka rozszerzenia GLX dla serwera X.org.
326
327 %prep
328 %setup -q -n xorg-server-%{version}
329 %patch0 -p0
330 %patch1 -p1
331 %patch2 -p1
332 %patch3 -p1
333
334 # xserver uses pixman-1 API/ABI so put that explictly here
335 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
336
337 %build
338 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
339 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
340         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
341         exit 1
342 fi
343
344 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
345 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
346         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
347         exit 1
348 fi
349
350 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
351 if [ $API != %{xorg_xserver_server_font_abi} ]; then
352         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
353         exit 1
354 fi
355 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
356 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
357         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
358         exit 1
359 fi
360 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
361 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
362         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
363         exit 1
364 fi
365
366 %{__libtoolize}
367 %{__aclocal} -I m4
368 %{__autoconf}
369 %{__autoheader}
370 %{__automake}
371 %configure \
372         --with-os-name="PLD/Linux" \
373         --with-os-vendor="PLD/Team" \
374         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
375         %{!?with_hal:--disable-config-hal} \
376         --%{?with_udev:en}%{!?with_udev:dis}able-config-udev \
377         --enable-aiglx \
378         --enable-builddocs \
379         --enable-dga \
380         %{?with_dmx:--enable-dmx} \
381         --enable-glx-tls \
382         --enable-install-libxf86config \
383         %{?with_record:--enable-record} \
384         --enable-kdrive \
385         --enable-xephyr \
386         --enable-xfbdev \
387         --enable-glx-tls \
388         --disable-xsdl \
389         --disable-xfake \
390         --enable-secure-rpc \
391         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
392         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
393         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
394         --with-xkb-output=/var/lib/xkb
395
396 %{__make}
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400
401 %{__make} install \
402         DESTDIR=$RPM_BUILD_ROOT
403
404 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
405 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
406 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
407 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
408 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
409
410 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
411
412 %if %{with udev}
413 mv $RPM_BUILD_ROOT%{_prefix}/etc/X11/xorg.conf.d/10-evdev.conf $RPM_BUILD_ROOT/etc/X11/xorg.conf.d
414 %endif
415
416 %if %{with multigl}
417 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
418 mv -f libglx.so libglx.so.%{version}
419 ln -sf libglx.so.%{version} libglx.so
420 %endif
421
422 %clean
423 rm -rf $RPM_BUILD_ROOT
424
425 %if %{with multigl}
426 %post -n xorg-xserver-libglx
427 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
428         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
429 fi
430 %endif
431
432 %triggerpostun -- xorg-xserver-server < 1.5.0
433 if [ -f /etc/X11/xorg.conf ]; then
434         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
435         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
436 %if %{without record}
437         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
438 %endif
439         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
440 fi
441
442 %files
443 %defattr(644,root,root,755)
444 %doc COPYING ChangeLog
445 %attr(755,root,root) %{_bindir}/X
446 %attr(755,root,root) %{_bindir}/Xorg
447 %attr(4755,root,root) %{_bindir}/Xwrapper
448 %attr(755,root,root) %{_bindir}/cvt
449 %attr(755,root,root) %{_bindir}/gtf
450 %dir %{_libdir}/xorg
451 %{_libdir}/xorg/protocol.txt
452 %dir %{_libdir}/xorg/modules
453 %dir %{_libdir}/xorg/modules/dri
454 %dir %{_libdir}/xorg/modules/drivers
455 %dir %{_libdir}/xorg/modules/extensions
456 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
457 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
458 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
459 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
460 %dir %{_libdir}/xorg/modules/input
461 %dir %{_libdir}/xorg/modules/linux
462 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
463 %dir %{_libdir}/xorg/modules/multimedia
464 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
465 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
466 %dir /var/lib/xkb
467 /var/lib/xkb/README.compiled
468 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
469 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
470 %config(missingok) /etc/security/console.apps/xserver
471 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
472 %dir /etc/X11/xorg.conf.d
473 %if %{with udev}
474 %config(noreplace) %verify(not md5 mtime size) /etc/X11/xorg.conf.d/10-evdev.conf
475 %endif
476 %{_mandir}/man1/Xorg.1x*
477 %{_mandir}/man1/Xserver.1x*
478 %{_mandir}/man1/cvt.1*
479 %{_mandir}/man1/gtf.1x*
480 %{_mandir}/man4/exa.4*
481 %{_mandir}/man4/fbdevhw.4*
482 %{_mandir}/man5/xorg.conf.5x*
483
484 %if %{with dmx}
485 %files -n xorg-xserver-Xdmx
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_bindir}/Xdmx
488 %attr(755,root,root) %{_bindir}/dmxaddinput
489 %attr(755,root,root) %{_bindir}/dmxaddscreen
490 %attr(755,root,root) %{_bindir}/dmxinfo
491 %attr(755,root,root) %{_bindir}/dmxreconfig
492 %attr(755,root,root) %{_bindir}/dmxresize
493 %attr(755,root,root) %{_bindir}/dmxrminput
494 %attr(755,root,root) %{_bindir}/dmxrmscreen
495 %attr(755,root,root) %{_bindir}/dmxtodmx
496 %attr(755,root,root) %{_bindir}/dmxwininfo
497 %attr(755,root,root) %{_bindir}/vdltodmx
498 %attr(755,root,root) %{_bindir}/xdmxconfig
499 %{_mandir}/man1/Xdmx.1x*
500 %{_mandir}/man1/dmxtodmx.1x*
501 %{_mandir}/man1/vdltodmx.1x*
502 %{_mandir}/man1/xdmxconfig.1x*
503 %endif
504
505 %files -n xorg-xserver-Xnest
506 %defattr(644,root,root,755)
507 %attr(755,root,root) %{_bindir}/Xnest
508 %{_mandir}/man1/Xnest.1x*
509
510 %files -n xorg-xserver-Xephyr
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_bindir}/Xephyr
513 %{_mandir}/man1/Xephyr.1x*
514
515 %files -n xorg-xserver-Xfbdev
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_bindir}/Xfbdev
518
519 %files -n xorg-xserver-Xvfb
520 %defattr(644,root,root,755)
521 %attr(755,root,root) %{_bindir}/Xvfb
522 %{_mandir}/man1/Xvfb.1x*
523
524 %files devel
525 %defattr(644,root,root,755)
526 %{_includedir}/xorg
527 %{_libdir}/libxf86config.a
528 %{_aclocaldir}/xorg-server.m4
529 %{_pkgconfigdir}/xorg-server.pc
530
531 %files -n xorg-xserver-libdri
532 %defattr(644,root,root,755)
533 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
534
535 %files -n xorg-xserver-libglx
536 %defattr(644,root,root,755)
537 %if %{with multigl}
538 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
539 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
540 %else
541 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
542 %endif
This page took 0.104778 seconds and 2 git commands to generate.