]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- updated to 21.1.1; Xserver.d is now included
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  dri3            # DRI3 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  xnest           # Xnest DDX (Xnest server)
16 %bcond_without  xvfb            # Xvfb DDX (Xvfb server)
17 %bcond_without  xephyr          # kdrive Xephyr server
18 %bcond_without  glamor          # glamor dix module
19 %bcond_without  systemtap       # systemtap/dtrace probes
20 %bcond_without  libunwind       # use libunwind for backtracing
21 #
22 # ABI versions, see hw/xfree86/common/xf86Module.h
23 %define xorg_xserver_server_ansic_abi           0.4
24 %define xorg_xserver_server_extension_abi       10.0
25 %define xorg_xserver_server_videodrv_abi        25.2
26 %define xorg_xserver_server_xinput_abi          24.4
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        21.1.1
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        https://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.xz
42 # Source0-md5:  6d8e557a6dbd5a9923c3564b64af7d94
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48 Patch1:         %{name}-xwrapper-pam.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 URL:            https://xorg.freedesktop.org/
54 BuildRequires:  Mesa-dri-devel >= 7.8.1
55 %{?with_dri2:BuildRequires:     Mesa-dri-devel >= 9.2.0}
56 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 17.1.0}
57 BuildRequires:  OpenGL-devel >= 3.0
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel >= 1.3
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.89
71 %if %{with glamor}
72 BuildRequires:  libepoxy-devel >= 1.5.4
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtirpc-devel
76 BuildRequires:  libtool >= 2:2.2
77 %{?with_libunwind:BuildRequires:        libunwind-devel}
78 BuildRequires:  libxcb-devel >= 1.9.3
79 BuildRequires:  pam-devel
80 BuildRequires:  perl-base
81 BuildRequires:  pixman-devel >= %{pixman_ver}
82 BuildRequires:  pkgconfig >= 1:0.19
83 BuildRequires:  pkgconfig(gl) >= 1.2
84 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
85 BuildRequires:  systemd-devel >= 1:209
86 BuildRequires:  tar >= 1:1.22
87 BuildRequires:  udev-devel >= 1:143
88 BuildRequires:  xcb-util-devel
89 BuildRequires:  xcb-util-image-devel
90 BuildRequires:  xcb-util-keysyms-devel
91 BuildRequires:  xcb-util-renderutil-devel
92 BuildRequires:  xcb-util-wm-devel
93 BuildRequires:  xmlto >= 0.0.20
94 BuildRequires:  xorg-app-mkfontscale
95 BuildRequires:  xorg-app-xkbcomp
96 BuildRequires:  xorg-font-font-util >= 1.1
97 BuildRequires:  xorg-lib-libX11-devel >= 1.6
98 BuildRequires:  xorg-lib-libXau-devel
99 BuildRequires:  xorg-lib-libXdamage-devel
100 BuildRequires:  xorg-lib-libXdmcp-devel
101 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
102 BuildRequires:  xorg-lib-libXfixes-devel
103 BuildRequires:  xorg-lib-libXfont2-devel >= 2.0.0
104 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
105 BuildRequires:  xorg-lib-libXrender-devel
106 BuildRequires:  xorg-lib-libXres-devel
107 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
108 BuildRequires:  xorg-lib-libXv-devel
109 BuildRequires:  xorg-lib-libXxf86dga-devel
110 BuildRequires:  xorg-lib-libXxf86misc-devel
111 BuildRequires:  xorg-lib-libXxf86vm-devel
112 BuildRequires:  xorg-lib-libfontenc-devel
113 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
114 BuildRequires:  xorg-lib-libxcvt-devel
115 BuildRequires:  xorg-lib-libxkbfile-devel
116 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
117 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
118 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
119 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
120 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
121 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
122 BuildRequires:  xorg-proto-dri3proto-devel >= 1.2
123 BuildRequires:  xorg-proto-fixesproto-devel >= 6.0
124 BuildRequires:  xorg-proto-fontcacheproto-devel
125 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
126 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
127 BuildRequires:  xorg-proto-inputproto-devel >= 2.3.99.1
128 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
129 BuildRequires:  xorg-proto-presentproto-devel >= 1.2
130 BuildRequires:  xorg-proto-printproto-devel
131 BuildRequires:  xorg-proto-randrproto-devel >= 1.6.0
132 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
133 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
134 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
135 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
136 BuildRequires:  xorg-proto-videoproto-devel
137 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
138 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
139 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
140 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
141 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
142 BuildRequires:  xorg-proto-xf86miscproto-devel
143 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
144 BuildRequires:  xorg-proto-xineramaproto-devel
145 BuildRequires:  xorg-proto-xproto-devel >= 7.0.31
146 BuildRequires:  xorg-sgml-doctools >= 1.8
147 BuildRequires:  xorg-util-util-macros >= 1.14
148 BuildRequires:  xz
149 %{?with_glamor:Requires:        Mesa-libgbm >= 17.1.0}
150 Requires:       libdrm >= 2.4.89
151 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
152 Requires:       pixman >= %{pixman_ver}
153 Requires:       sed >= 4.0
154 Requires:       udev-libs >= 1:143
155 Requires:       xkeyboard-config
156 # for rgb.txt
157 Requires:       xorg-app-rgb >= 0.99.3
158 Requires:       xorg-app-xkbcomp
159 Requires:       xorg-lib-libXfont2 >= 2.0.0
160 Requires:       xorg-lib-libpciaccess >= 0.12.901
161 Requires:       xorg-lib-libxshmfence >= 1.1
162 # for protocol.txt
163 Requires:       xorg-xserver-common = %{version}-%{release}
164 Suggests:       %{name}-tools = %{version}-%{release}
165 Suggests:       dbus-x11 >= 1.0
166 %{?with_hal:Suggests:   hal}
167 Suggests:       udev-acl >= 1:143
168 %{?with_udev:Suggests:  udev-core >= 1:143}
169 Suggests:       xkeyboard-config
170 Suggests:       xorg-driver-input-libinput
171 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
172 Suggests:       xorg-driver-video
173 Provides:       xorg-driver-video-modesetting
174 Provides:       xorg-xserver-libdri = %{version}-%{release}
175 Provides:       xorg-xserver-module(dri)
176 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
177 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
178 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
179 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
180 Obsoletes:      X11-Xserver < 1:7.0.0
181 Obsoletes:      X11-driver-i2c < 1:7.0.0
182 Obsoletes:      X11-modules < 1:7.0.0
183 Obsoletes:      X11-setup < 1:7.0.0
184 Obsoletes:      XFree86-Xserver < 1:7.0.0
185 Obsoletes:      XFree86-modules < 1:7.0.0
186 Obsoletes:      XFree86-setup < 1:7.0.0
187 Obsoletes:      Xserver < 7.0
188 %{?with_glamor:Obsoletes:       glamor < 0.6.1}
189 Obsoletes:      xorg-xserver-libdri < 1.12.99
190 Obsoletes:      xorg-xserver-server-xorgcfg < 1.5.99
191 Obsoletes:      xorg-driver-video-modesetting < 0.9.1
192 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
193
194 %define         tirpc_cflags    $(pkg-config --cflags libtirpc)
195 %define         tirpc_libs      $(pkg-config --libs libtirpc)
196
197 %description
198 Xorg server is a generally used X server which uses display hardware.
199 It requires proper driver for your display hardware.
200
201 %description -l pl.UTF-8
202 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
203 graficznej. Do działania wymaga odpowiedniego sterownika.
204
205 %package tools
206 Summary:        Tools to calculate modelines for X.org server
207 Summary(pl.UTF-8):      Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera X.org
208 Group:          X11/Applications
209 # for cvt
210 Requires:       xorg-lib-libxcvt-tools
211 Conflicts:      xorg-xserver-server < 1.20.11-4
212
213 %description tools
214 Tools to calculate modelines for X.org server (using Coordinated Video
215 Timing or Generalized Timing Formula).
216
217 %description tools -l pl.UTF-8
218 Narzędzia do liczenia opisów trybów graficznych (modeline) dla serwera
219 X.org (przy użyciu algorytmów Coordinated Video Timing lub
220 Generalizaed Timing Formula).
221
222 %package devel
223 Summary:        Header files for X.org server
224 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
225 Group:          X11/Development/Libraries
226 Requires:       Mesa-dri-devel >= 7.8.0
227 Requires:       libdrm-devel >= 2.4.89
228 Requires:       pixman-devel >= %{pixman_ver}
229 Requires:       xorg-lib-libXfont2-devel >= 2.0.0
230 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
231 Requires:       xorg-lib-libxkbfile-devel
232 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
233 %{?with_dri3:Requires:  xorg-proto-dri3proto-devel >= 1.0}
234 Requires:       xorg-proto-dri3proto-devel >= 1.0
235 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
236 Requires:       xorg-proto-glproto-devel >= 1.4.17
237 Requires:       xorg-proto-inputproto-devel >= 2.3.99.1
238 Requires:       xorg-proto-kbproto-devel >= 1.0.3
239 Requires:       xorg-proto-presentproto-devel >= 1.2
240 Requires:       xorg-proto-randrproto-devel >= 1.6.0
241 Requires:       xorg-proto-renderproto-devel >= 0.11
242 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
243 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
244 Requires:       xorg-proto-videoproto-devel
245 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
246 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
247 Requires:       xorg-proto-xineramaproto-devel
248 Requires:       xorg-proto-xproto-devel >= 7.0.31
249 Obsoletes:      X11-Xserver-devel < 1:7.0.0
250 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
251 %{?with_glamor:Obsoletes:       glamor-devel < 0.6.1}
252
253 %description devel
254 Header files for X.org server.
255
256 %description devel -l pl.UTF-8
257 Pliki nagłówkowe dla serwera X.org.
258
259 %package source
260 Summary:        X.org server source code
261 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
262 Group:          X11/Development/Libraries
263
264 %description source
265 X.org server source code.
266
267 %description source -l pl.UTF-8
268 Pliki źródłowe dla serwera X.org.
269
270 %package -n xorg-xserver-libglx
271 Summary:        GLX extension library for X.org server
272 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
273 Group:          X11/Servers
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       OpenGL >= 1.2
276 # Mesa version glapi tables in glx/ dir come from
277 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
278 Provides:       xorg-xserver-module(glx)
279 Obsoletes:      X11-OpenGL-core < 1:7.0.0
280 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
281
282 %description -n xorg-xserver-libglx
283 GLX extension library for X.org server.
284
285 %description -n xorg-xserver-libglx -l pl.UTF-8
286 Biblioteka rozszerzenia GLX dla serwera X.org.
287
288 %package -n xorg-xserver-Xephyr
289 Summary:        Xephyr - nested X server
290 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
291 Group:          X11/Servers
292 Requires:       OpenGL >= 3.0
293 %{?with_glamor:Requires:        libepoxy >= 1.5.4}
294 Requires:       libxcb >= 1.9.3
295 Requires:       pixman >= %{pixman_ver}
296 Requires:       xorg-lib-libXfont2 >= 2.0.0
297
298 %description -n xorg-xserver-Xephyr
299 Xephyr is a kdrive server that outputs to a window on a pre-existing
300 'host' X display. Think Xnest but with support for modern extensions
301 like composite, damage and randr.
302
303 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
304 the host X server, Xephyr is a real X server which uses the host X
305 server window as "framebuffer" via fast SHM XImages.
306
307 It also has support for 'visually' debugging what the server is
308 painting.
309
310 %description -n xorg-xserver-Xephyr -l pl.UTF-8
311 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
312 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
313 wspólczesnych rozszerzeń jak composite, damage i randr.
314
315 %package -n xorg-xserver-Xnest
316 Summary:        Xnest - nested X server
317 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
318 Group:          X11/Servers
319 Requires:       pixman >= %{pixman_ver}
320 Requires:       xorg-lib-libXext >= 1.0.99.4
321 Requires:       xorg-lib-libXfont2 >= 2.0.0
322 Obsoletes:      X11-Xnest < 1:7.0.0
323 Obsoletes:      XFree86-Xnest < 1:7.0.0
324 Obsoletes:      Xserver-Xnest < 7.0
325
326 %description -n xorg-xserver-Xnest
327 Xnest is an X Window System server which runs in an X window. Xnest is
328 a 'nested' window server, actually a client of the real X server,
329 which manages windows and graphics requests for Xnest, while Xnest
330 manages the windows and graphics requests for its own clients.
331
332 %description -n xorg-xserver-Xnest -l pl.UTF-8
333 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
334 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
335 serwer X dla własnych klientów.
336
337 %description -n xorg-xserver-Xnest -l ru.UTF-8
338 Xnest - это сервер X Window System, который работает в окне X. На
339 самом деле это клиент реального X-сервера, который управляет окнами и
340 графическими запросами для Xnest в то время, как Xnest управляет
341 окнами и графическими запросами для своих собственных клиентов.
342
343 %description -n xorg-xserver-Xnest -l uk.UTF-8
344 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
345 клієнт реального X-сервера, який керує вікнами та графічними запитами
346 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
347 своїх власних клієнтів.
348
349 %package -n xorg-xserver-Xvfb
350 Summary:        Xvfb - virtual framebuffer X server
351 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
352 Group:          X11/Servers
353 Requires:       OpenGL >= 1.2.1
354 Requires:       mktemp
355 Requires:       pixman >= %{pixman_ver}
356 Requires:       util-linux
357 Requires:       which
358 Requires:       xkeyboard-config
359 Requires:       xorg-app-xauth
360 Requires:       xorg-app-xkbcomp
361 Requires:       xorg-lib-libXfont2 >= 2.0.0
362 Obsoletes:      X11-Xvfb < 1:7.0.0
363 Obsoletes:      XFree86-Xvfb < 1:7.0.0
364
365 %description -n xorg-xserver-Xvfb
366 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
367 capable of running on machines with no display hardware and no
368 physical input devices. Xvfb emulates a dumb framebuffer using virtual
369 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
370 display. Xvfb is normally used for testing servers. Using Xvfb, the
371 mfb or cfb code for any depth can be exercised without using real
372 hardware that supports the desired depths. Xvfb has also been used to
373 test X clients against unusual depths and screen configurations, to do
374 batch processing with Xvfb as a background rendering engine, to do
375 load testing, to help with porting an X server to a new platform, and
376 to provide an unobtrusive way of running applications which really
377 don't need an X server but insist on having one.
378
379 %description -n xorg-xserver-Xvfb -l pl.UTF-8
380 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
381 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
382 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
383 używany do testowania serwerów X, może też być używany do testowania
384 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
385 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
386 serwera X, ale odmawiają uruchomienia bez niego.
387
388 %package -n xorg-xserver-Xvfb-init
389 Summary:        Init scripts for Xvfb
390 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
391 Group:          X11/Servers
392 Requires:       xorg-xserver-Xvfb = %{version}-%{release}
393
394 %description -n xorg-xserver-Xvfb-init
395 This package contains init scripts for Xvfb and registers Xvfb as
396 system service.
397
398 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
399 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
400 usługę systemową.
401
402 %package -n xorg-xserver-common
403 Summary:        Common files for various X servers
404 Summary(pl.UTF-8):      Pliki wspólne dla serwerów X
405 Group:          X11/Servers
406 Conflicts:      xorg-xserver-server < 1.20.11-2
407
408 %description -n xorg-xserver-common
409 Common files for various X servers.
410
411 %description -n xorg-xserver-common -l pl.UTF-8
412 Pliki wspólne dla serwerów X.
413
414 %prep
415 %setup -q -n xorg-server-%{version}
416 %patch1 -p1
417
418 %patch4 -p1
419
420 %patch6 -p1
421
422 # xserver uses pixman-1 API/ABI so put that explictly here
423 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
424
425 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
426 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
427
428 %{__sed} -i -e '1s|#!/usr/bin/python$|#!%{__python}|' config/fdi2iclass.py
429
430 %build
431 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
432 if [ "$API" != "%{xorg_xserver_server_ansic_abi}" ]; then
433         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
434         exit 1
435 fi
436
437 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
438 if [ "$API" != "%{xorg_xserver_server_extension_abi}" ]; then
439         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
440         exit 1
441 fi
442
443 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
444 if [ "$API" != "%{xorg_xserver_server_videodrv_abi}" ]; then
445         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
446         exit 1
447 fi
448 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
449 if [ "$API" != "%{xorg_xserver_server_xinput_abi}" ]; then
450         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
451         exit 1
452 fi
453
454 %{__libtoolize}
455 %{__aclocal} -I m4
456 %{__autoconf}
457 %{__autoheader}
458 %{__automake}
459 %configure \
460         CPPFLAGS="%{rpmcppflags} %{tirpc_cflags}" \
461         LIBS="%{tirpc_libs}" \
462         --libexecdir=%{_libdir}/xorg \
463         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
464         --with-xkb-output=/var/lib/xkb \
465         --disable-linux-acpi \
466         --disable-linux-apm \
467         %{?with_dbus:--enable-config-dbus} \
468         --enable-config-hal%{!?with_hal:=no} \
469         --enable-config-udev%{!?with_udev:=no} \
470         --enable-dga \
471         --enable-dri2%{!?with_dri2:=no} \
472         --enable-dri3%{!?with_dri3:=no} \
473         %{?with_glamor:--enable-glamor} \
474         --enable-kdrive \
475         %{?with_libunwind:--enable-libunwind} \
476         %{?with_record:--enable-record} \
477         --enable-secure-rpc \
478         --enable-suid-wrapper \
479         %{?with_xcsecurity:--enable-xcsecurity} \
480         --enable-xephyr%{!?with_xephyr:=no} \
481         %{?with_xf86bigfont:--enable-xf86bigfont} \
482         --enable-xnest%{!?with_xnest:=no} \
483         %{?with_xselinux:--enable-xselinux} \
484         %{!?with_xvfb:--disable-xvfb} \
485         %{!?with_systemtap:--without-dtrace} \
486         --without-fop \
487         --with-systemd-daemon
488
489 %{__make}
490
491 %install
492 rm -rf $RPM_BUILD_ROOT
493
494 %if "%{_libdir}" != "%{_exec_prefix}/lib"
495 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
496 %endif
497
498 %{__make} install \
499         DESTDIR=$RPM_BUILD_ROOT
500
501 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
502 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
503 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
504 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
505 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
506
507 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
508 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
509
510 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
511
512 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
513
514 %if %{with xvfb}
515 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
516 install -d $RPM_BUILD_ROOT/etc/sysconfig
517 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
518 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
519 %endif
520
521 # Xorg.wrap config
522 cat >$RPM_BUILD_ROOT/etc/X11/Xwrapper.config <<EOF
523 # allowed values: rootonly console anybody pam
524 allowed_users = pam
525
526 # set to yes if hardware or console access requires root rights (and Xwrapper fails to detect it)
527 #needs_root_rights = yes
528 EOF
529
530 # compatibility with old xwrapper
531 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
532
533 # prepare source package
534 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
535 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
536 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
537 %{__make} distclean
538 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
539 find -name '*.h' | xargs chmod a-x
540
541 %if %{with systemtap}
542 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
543 %endif
544
545 %clean
546 rm -rf $RPM_BUILD_ROOT
547
548 %triggerpostun -- xorg-xserver-server < 1.5.0
549 if [ -f /etc/X11/xorg.conf ]; then
550         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
551         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
552 %if %{without record}
553         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
554 %endif
555         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
556 fi
557
558 %post -n xorg-xserver-Xvfb-init
559 /sbin/chkconfig --add Xvfb
560 %service Xvfb restart
561
562 %preun -n xorg-xserver-Xvfb-init
563 if [ "$1" = "0" ]; then
564         %service -q Xvfb stop
565         /sbin/chkconfig --del Xvfb
566 fi
567
568 %files
569 %defattr(644,root,root,755)
570 %doc COPYING ChangeLog README.md
571 %attr(755,root,root) %{_bindir}/X
572 %attr(755,root,root) %{_bindir}/Xorg
573 %attr(4755,root,root) %{_bindir}/Xwrapper
574 %attr(755,root,root) %{_libdir}/xorg/Xorg
575 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
576 %dir %{_libdir}/xorg/modules
577 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
578 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
579 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
580 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
581 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
582 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
583 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
584 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
585 %dir %{_libdir}/xorg/modules/dri
586 %dir %{_libdir}/xorg/modules/drivers
587 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
588 %dir %{_libdir}/xorg/modules/extensions
589 %dir %{_libdir}/xorg/modules/input
590 %attr(755,root,root) %{_libdir}/xorg/modules/input/inputtest_drv.so
591 %if "%{_libdir}" != "%{_exec_prefix}/lib"
592 %dir %{_exec_prefix}/lib/xorg
593 %dir %{_exec_prefix}/lib/xorg/modules
594 %dir %{_exec_prefix}/lib/xorg/modules/dri
595 %endif
596 %dir /var/lib/xkb
597 /var/lib/xkb/README.compiled
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
599 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
600 %config(missingok) /etc/security/console.apps/xserver
601 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
602 %dir /etc/X11/xorg.conf.d
603 %config(noreplace) %verify(not md5 mtime size) /etc/X11/Xwrapper.config
604 %dir %{_datadir}/X11/xorg.conf.d
605 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
606 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
607 %{_mandir}/man1/Xorg.1*
608 %{_mandir}/man1/Xorg.wrap.1*
609 %{_mandir}/man4/exa.4*
610 %{_mandir}/man4/fbdevhw.4*
611 %{_mandir}/man4/inputtestdrv.4*
612 %{_mandir}/man4/modesetting.4*
613 %{_mandir}/man5/Xwrapper.config.5*
614 %{_mandir}/man5/xorg.conf.5*
615 %{_mandir}/man5/xorg.conf.d.5*
616
617 %files tools
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/gtf
620 %{_mandir}/man1/gtf.1*
621
622 %files devel
623 %defattr(644,root,root,755)
624 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
625 %{_includedir}/xorg
626 %{_aclocaldir}/xorg-server.m4
627 %{_pkgconfigdir}/xorg-server.pc
628
629 %files source
630 %defattr(644,root,root,755)
631 # keep file perms from install time, but have default defattr to keep adapter happy
632 %defattr(-,root,root,755)
633 %{_usrsrc}/%{name}-%{version}
634
635 %files -n xorg-xserver-libglx
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
638
639 %if %{with xephyr}
640 %files -n xorg-xserver-Xephyr
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/Xephyr
643 %{_mandir}/man1/Xephyr.1*
644 %endif
645
646 %if %{with xnest}
647 %files -n xorg-xserver-Xnest
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_bindir}/Xnest
650 %{_mandir}/man1/Xnest.1*
651 %endif
652
653 %if %{with xvfb}
654 %files -n xorg-xserver-Xvfb
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/Xvfb
657 %attr(755,root,root) %{_bindir}/xvfb-run
658 %{_mandir}/man1/Xvfb.1*
659
660 %files -n xorg-xserver-Xvfb-init
661 %defattr(644,root,root,755)
662 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
663 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
664 %endif
665
666 %files -n xorg-xserver-common
667 %defattr(644,root,root,755)
668 %dir %{_libdir}/xorg
669 %{_libdir}/xorg/protocol.txt
670 %{_mandir}/man1/Xserver.1*
This page took 0.078821 seconds and 3 git commands to generate.