]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
6841a242820eb8aa57c973820cddf0be748aa945
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 # - upstream --enable-suid-wrapper vs Xwrapper patch?
5 #
6 # Conditional build:
7 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
8 %bcond_with     hal             # HAL support for configuration (if no udev)
9 %bcond_without  udev            # UDEV support for configuration
10 %bcond_without  dri2            # DRI2 extension
11 %bcond_without  record          # RECORD extension
12 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
13 %bcond_with     xf86bigfont     # XF86BigFont extension
14 %bcond_with     xselinux        # SELinux extension
15 %bcond_without  dmx             # DMX DDX (Xdmx server)
16 %bcond_without  wayland         # Wayland DDX (Xwayland server)
17 %bcond_without  glamor          # glamor dix module
18 %bcond_without  systemtap       # systemtap/dtrace probes
19 %bcond_without  libunwind       # use libunwind for backtracing
20 #
21 # ABI versions, see hw/xfree86/common/xf86Module.h
22 %define xorg_xserver_server_ansic_abi           0.4
23 %define xorg_xserver_server_extension_abi       8.0
24 %define xorg_xserver_server_font_abi            0.6
25 %define xorg_xserver_server_videodrv_abi        18.0
26 %define xorg_xserver_server_xinput_abi          21.0
27
28 %define pixman_ver      0.30.0
29
30 %ifarch x32
31 %undefine       with_libunwind
32 %endif
33
34 Summary:        X.org server
35 Summary(pl.UTF-8):      Serwer X.org
36 Name:           xorg-xserver-server
37 Version:        1.16.3
38 Release:        1
39 License:        MIT
40 Group:          X11/Servers
41 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
42 # Source0-md5:  afd93977235584a9caa7528a737c1b52
43 Source1:        10-quirks.conf
44 Source2:        xserver.pamd
45 Source10:       %{name}-Xvfb.init
46 Source11:       %{name}-Xvfb.sysconfig
47 Source12:       xvfb-run.sh
48
49 Patch0:         %{name}-xwrapper.patch
50 Patch1:         %{name}-pic-libxf86config.patch
51 Patch2:         dtrace-link.patch
52
53 Patch4:         %{name}-builtin-SHA1.patch
54 Patch5:         %{name}-export-GetMaster.patch
55 Patch6:         110_nvidia_slowdow_fix.patch
56 Patch7:         %{name}-include-defs.patch
57 URL:            http://xorg.freedesktop.org/
58 BuildRequires:  Mesa-libGL-devel >= 7.8.1
59 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
60 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
61 # for glx headers
62 BuildRequires:  OpenGL-GLX-devel
63 %{?with_xselinux:BuildRequires: audit-libs-devel}
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  cpp
67 BuildRequires:  docbook-dtd43-xml
68 #BuildRequires: doxygen >= 1.6.1
69 %if %{with hal} || %{with dbus}
70 BuildRequires:  dbus-devel >= 1.0
71 %endif
72 %{?with_hal:BuildRequires:      hal-devel}
73 BuildRequires:  libdrm-devel >= 2.4.39
74 %if %{with glamor} || %{with wayland}
75 BuildRequires:  libepoxy-devel
76 %endif
77 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
78 BuildRequires:  libtool >= 2:2.2
79 %{?with_libunwind:BuildRequires:        libunwind-devel}
80 BuildRequires:  libxcb-devel >= 1.6
81 BuildRequires:  pam-devel
82 BuildRequires:  perl-base
83 BuildRequires:  pixman-devel >= %{pixman_ver}
84 BuildRequires:  pkgconfig >= 1:0.19
85 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
86 BuildRequires:  udev-devel >= 1:143
87 # wayland-client
88 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
89 BuildRequires:  xcb-util-devel
90 BuildRequires:  xcb-util-image-devel
91 BuildRequires:  xcb-util-keysyms-devel
92 BuildRequires:  xcb-util-wm-devel
93 BuildRequires:  xmlto >= 0.0.20
94 BuildRequires:  xorg-app-mkfontscale
95 BuildRequires:  xorg-lib-libX11-devel >= 1.6
96 BuildRequires:  xorg-lib-libXau-devel
97 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
98 BuildRequires:  xorg-lib-libXdamage-devel
99 BuildRequires:  xorg-lib-libXdmcp-devel
100 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
101 BuildRequires:  xorg-lib-libXfixes-devel
102 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
103 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
104 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
105 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
106 BuildRequires:  xorg-lib-libXrender-devel
107 BuildRequires:  xorg-lib-libXres-devel
108 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
109 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
110 BuildRequires:  xorg-lib-libXv-devel
111 BuildRequires:  xorg-lib-libXxf86dga-devel
112 BuildRequires:  xorg-lib-libXxf86misc-devel
113 BuildRequires:  xorg-lib-libXxf86vm-devel
114 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
115 BuildRequires:  xorg-lib-libfontenc-devel
116 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
117 BuildRequires:  xorg-lib-libxkbfile-devel
118 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
119 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.3
120 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
121 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
122 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
123 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
124 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
125 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
126 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
127 BuildRequires:  xorg-proto-fontcacheproto-devel
128 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
129 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
130 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
131 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
132 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
133 BuildRequires:  xorg-proto-printproto-devel
134 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
135 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
136 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
137 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
138 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
139 BuildRequires:  xorg-proto-videoproto-devel
140 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
141 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
142 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
143 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
144 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
145 BuildRequires:  xorg-proto-xf86miscproto-devel
146 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
147 BuildRequires:  xorg-proto-xineramaproto-devel
148 BuildRequires:  xorg-proto-xproto-devel >= 7.0.26
149 BuildRequires:  xorg-sgml-doctools >= 1.8
150 BuildRequires:  xorg-util-util-macros >= 1.14
151 #BR: tslib (for KDRIVE only)
152 Requires(triggerpostun):        sed >= 4.0
153 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
154 Requires:       libdrm >= 2.4.39
155 Requires:       pixman >= %{pixman_ver}
156 Requires:       udev-libs >= 1:143
157 Requires:       xkeyboard-config
158 # for rgb.txt
159 Requires:       xorg-app-rgb >= 0.99.3
160 Requires:       xorg-app-xkbcomp
161 Requires:       xorg-lib-libXfont >= 1.4.2
162 Requires:       xorg-lib-libpciaccess >= 0.12.901
163 Requires:       xorg-lib-libxshmfence >= 1.1
164 Suggests:       dbus-x11 >= 1.0
165 %{?with_hal:Suggests:   hal}
166 Suggests:       udev-acl >= 1:143
167 %{?with_udev:Suggests:  udev-core >= 1:143}
168 Suggests:       xkeyboard-config
169 Suggests:       xorg-driver-input-evdev
170 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
171 Suggests:       xorg-driver-video
172 Provides:       xorg-xserver-libdri = %{version}-%{release}
173 Provides:       xorg-xserver-module(dri)
174 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
175 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
176 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
177 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
178 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
179 Obsoletes:      X11-Xserver < 1:7.0.0
180 Obsoletes:      X11-driver-i2c < 1:7.0.0
181 Obsoletes:      X11-modules < 1:7.0.0
182 Obsoletes:      X11-setup < 1:7.0.0
183 Obsoletes:      XFree86-Xserver < 1:7.0.0
184 Obsoletes:      XFree86-modules < 1:7.0.0
185 Obsoletes:      XFree86-setup < 1:7.0.0
186 Obsoletes:      Xserver
187 %{?with_glamor:Obsoletes:       glamor}
188 Obsoletes:      xorg-xserver-libdri
189 Obsoletes:      xorg-xserver-server-xorgcfg
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 # avoid self-dependencies on included modules
193 %define         _noautoreq      libscanpci.so libxf1bpp.so
194
195 %description
196 Xorg server is a generally used X server which uses display hardware.
197 It requires proper driver for your display hardware.
198
199 %description -l pl.UTF-8
200 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
201 graficznej. Do działania wymaga odpowiedniego sterownika.
202
203 %package -n xorg-xserver-Xdmx
204 Summary:        Xdmx - distributed multi-head X server
205 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
206 Group:          X11/Servers
207 Requires:       pixman >= %{pixman_ver}
208 Requires:       xorg-lib-libX11 >= 1.6
209 Requires:       xorg-lib-libXext >= 1.0.99.4
210 Requires:       xorg-lib-libXfont >= 1.4.2
211 Requires:       xorg-lib-libXi >= 1.2.99.1
212 Requires:       xorg-lib-libdmx >= 1.0.99.1
213
214 %description -n xorg-xserver-Xdmx
215 Xdmx - distributed multi-head X server.
216
217 %description -n xorg-xserver-Xdmx -l pl.UTF-8
218 Xdmx - rozproszony, wielomonitorowy serwer X.
219
220 %package -n xorg-xserver-Xnest
221 Summary:        Xnest - nested X server
222 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
223 Group:          X11/Servers
224 Requires:       pixman >= %{pixman_ver}
225 Requires:       xorg-lib-libXext >= 1.0.99.4
226 Requires:       xorg-lib-libXfont >= 1.4.2
227 Obsoletes:      X11-Xnest < 1:7.0.0
228 Obsoletes:      XFree86-Xnest < 1:7.0.0
229 Obsoletes:      Xserver-Xnest
230
231 %description -n xorg-xserver-Xnest
232 Xnest is an X Window System server which runs in an X window. Xnest is
233 a 'nested' window server, actually a client of the real X server,
234 which manages windows and graphics requests for Xnest, while Xnest
235 manages the windows and graphics requests for its own clients.
236
237 %description -n xorg-xserver-Xnest -l pl.UTF-8
238 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
239 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
240 serwer X dla własnych klientów.
241
242 %description -n xorg-xserver-Xnest -l ru.UTF-8
243 Xnest - это сервер X Window System, который работает в окне X. На
244 самом деле это клиент реального X-сервера, который управляет окнами и
245 графическими запросами для Xnest в то время, как Xnest управляет
246 окнами и графическими запросами для своих собственных клиентов.
247
248 %description -n xorg-xserver-Xnest -l uk.UTF-8
249 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
250 клієнт реального X-сервера, який керує вікнами та графічними запитами
251 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
252 своїх власних клієнтів.
253
254 %package -n xorg-xserver-Xephyr
255 Summary:        Xephyr - nested X server
256 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
257 Group:          X11/Servers
258 Requires:       Mesa-libGL >= 7.1.0
259 Requires:       libxcb >= 1.6
260 Requires:       pixman >= %{pixman_ver}
261 Requires:       xorg-lib-libXfont >= 1.4.2
262
263 %description -n xorg-xserver-Xephyr
264 Xephyr is a kdrive server that outputs to a window on a pre-existing
265 'host' X display. Think Xnest but with support for modern extensions
266 like composite, damage and randr.
267
268 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
269 the host X server, Xephyr is a real X server which uses the host X
270 server window as "framebuffer" via fast SHM XImages.
271
272 It also has support for 'visually' debugging what the server is
273 painting.
274
275 %description -n xorg-xserver-Xephyr -l pl.UTF-8
276 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
277 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
278 wspólczesnych rozszerzeń jak composite, damage i randr.
279
280 %package -n xorg-xserver-Xfbdev
281 Summary:        Xfbdev - Linux framebuffer device X server
282 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
283 Group:          X11/Servers
284 Requires:       pixman >= %{pixman_ver}
285 Requires:       xorg-lib-libXfont >= 1.4.2
286
287 %description -n xorg-xserver-Xfbdev
288 Xfbdev is a Linux framebuffer device X server based on the kdrive X
289 server.
290
291 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
292 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
293
294 %package -n xorg-xserver-Xvfb
295 Summary:        Xvfb - virtual framebuffer X server
296 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
297 Group:          X11/Servers
298 Requires:       Mesa-libGL >= 7.1.0
299 Requires:       mktemp
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       util-linux
302 Requires:       which
303 Requires:       xkeyboard-config
304 Requires:       xorg-app-xauth
305 Requires:       xorg-app-xkbcomp
306 Requires:       xorg-lib-libXfont >= 1.4.2
307 Obsoletes:      X11-Xvfb < 1:7.0.0
308 Obsoletes:      XFree86-Xvfb < 1:7.0.0
309
310 %description -n xorg-xserver-Xvfb
311 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
312 capable of running on machines with no display hardware and no
313 physical input devices. Xvfb emulates a dumb framebuffer using virtual
314 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
315 display. Xvfb is normally used for testing servers. Using Xvfb, the
316 mfb or cfb code for any depth can be exercised without using real
317 hardware that supports the desired depths. Xvfb has also been used to
318 test X clients against unusual depths and screen configurations, to do
319 batch processing with Xvfb as a background rendering engine, to do
320 load testing, to help with porting an X server to a new platform, and
321 to provide an unobtrusive way of running applications which really
322 don't need an X server but insist on having one.
323
324 %description -n xorg-xserver-Xvfb -l pl.UTF-8
325 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
326 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
327 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
328 używany do testowania serwerów X, może też być używany do testowania
329 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
330 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
331 serwera X, ale odmawiają uruchomienia bez niego.
332
333 %package -n xorg-xserver-Xvfb-init
334 Summary:        Init scripts for Xvfb
335 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
336 Group:          X11/Servers
337 Requires:       xorg-xserver-Xvfb
338
339 %description -n xorg-xserver-Xvfb-init
340 This package contains init scripts for Xvfb and registers Xvfb as
341 system service.
342
343 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
344 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
345 usługę systemową.
346
347 %package -n xorg-xserver-Xwayland
348 Summary:        Xwayland - X server integrated into a Wayland window system
349 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
350 Group:          X11/Servers
351 Requires:       pixman >= %{pixman_ver}
352 Requires:       xorg-lib-libX11 >= 1.6
353 Requires:       xorg-lib-libXext >= 1.0.99.4
354 Requires:       xorg-lib-libXfont >= 1.4.2
355 Requires:       xorg-lib-libXi >= 1.2.99.1
356
357 %description -n xorg-xserver-Xwayland
358 Xwayland - server integrated into a Wayland window system.
359
360 %description -n xorg-xserver-Xwayland -l pl.UTF-8
361 Xwayland - serwer X integrowalny w Wayland.
362
363 %package devel
364 Summary:        Header files for X.org server
365 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
366 Group:          X11/Development/Libraries
367 Requires:       Mesa-libGL-devel >= 7.8.0
368 Requires:       libdrm-devel >= 2.4.39
369 Requires:       pixman-devel >= %{pixman_ver}
370 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
371 Requires:       xorg-lib-libxkbfile-devel
372 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
373 Requires:       xorg-proto-dri3proto-devel >= 1.0
374 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
375 Requires:       xorg-proto-glproto-devel >= 1.4.17
376 Requires:       xorg-proto-inputproto-devel >= 2.3
377 Requires:       xorg-proto-kbproto-devel >= 1.0.3
378 Requires:       xorg-proto-presentproto-devel >= 1.0
379 Requires:       xorg-proto-randrproto-devel >= 1.4.0
380 Requires:       xorg-proto-renderproto-devel >= 0.11
381 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
382 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
383 Requires:       xorg-proto-videoproto-devel
384 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
385 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
386 Requires:       xorg-proto-xineramaproto-devel
387 Requires:       xorg-proto-xproto-devel >= 7.0.26
388 Obsoletes:      X11-Xserver-devel < 1:7.0.0
389 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
390 %{?with_glamor:Obsoletes:       glamor-devel}
391
392 %description devel
393 Header files for X.org server.
394
395 %description devel -l pl.UTF-8
396 Pliki nagłówkowe dla serwera X.org.
397
398 %package source
399 Summary:        X.org server source code
400 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
401 Group:          X11/Development/Libraries
402
403 %description source
404 X.org server source code.
405
406 %description source -l pl.UTF-8
407 Pliki źródłowe dla serwera X.org.
408
409 %package -n xorg-xserver-libglx
410 Summary:        GLX extension library for X.org server
411 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
412 Group:          X11/Servers
413 Requires:       %{name} = %{version}-%{release}
414 Requires:       Mesa-libGL >= 7.1.0
415 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
416 # Mesa version glapi tables in glx/ dir come from
417 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
418 Provides:       xorg-xserver-module(glx)
419 Obsoletes:      X11-OpenGL-core < 1:7.0.0
420 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
421
422 %description -n xorg-xserver-libglx
423 GLX extension library for X.org server.
424
425 %description -n xorg-xserver-libglx -l pl.UTF-8
426 Biblioteka rozszerzenia GLX dla serwera X.org.
427
428 %prep
429 %setup -q -n xorg-server-%{version}
430 %patch0 -p0
431 %patch1 -p1
432 %patch2 -p1
433
434 %patch4 -p1
435 %patch5 -p1
436 %patch6 -p1
437
438 #unfortunately breaks build
439 #patch7 -p1
440
441 # xserver uses pixman-1 API/ABI so put that explictly here
442 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
443
444 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
445 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
446
447 %build
448 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
449 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
450         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
451         exit 1
452 fi
453
454 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
455 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
456         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
457         exit 1
458 fi
459
460 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
461 if [ $API != %{xorg_xserver_server_font_abi} ]; then
462         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
463         exit 1
464 fi
465 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
466 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
467         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
468         exit 1
469 fi
470 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
471 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
472         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
473         exit 1
474 fi
475
476 %{__libtoolize}
477 %{__aclocal} -I m4
478 %{__autoconf}
479 %{__autoheader}
480 %{__automake}
481 %configure \
482         --with-os-name="PLD/Linux" \
483         --with-os-vendor="PLD/Team" \
484         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
485         --with-xkb-output=/var/lib/xkb \
486         --disable-linux-acpi \
487         --disable-linux-apm \
488         --enable-aiglx \
489         %{?with_dbus:--enable-config-dbus} \
490         --enable-config-hal%{!?with_hal:=no} \
491         --enable-config-udev%{!?with_udev:=no} \
492         --enable-dga \
493         %{?with_dmx:--enable-dmx} \
494         --enable-dri2%{!?with_dri2:=no} \
495         %{?with_glamor:--enable-glamor} \
496         --enable-glx-tls \
497         --enable-install-libxf86config \
498         --enable-kdrive \
499         %{?with_libunwind:--enable-libunwind} \
500         %{?with_record:--enable-record} \
501         --enable-secure-rpc \
502         %{?with_xcsecurity:--enable-xcsecurity} \
503         --enable-xephyr \
504         %{?with_xf86bigfont:--enable-xf86bigfont} \
505         --disable-xfake \
506         --enable-xfbdev \
507         %{?with_xselinux:--enable-xselinux} \
508         %{?with_wayland:--enable-xwayland} \
509         %{!?with_systemtap:--without-dtrace} \
510         --without-fop \
511         --with-systemd-daemon
512
513 %{__make}
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517
518 %if "%{_libdir}" != "%{_exec_prefix}/lib"
519 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
520 %endif
521
522 %{__make} install \
523         DESTDIR=$RPM_BUILD_ROOT
524
525 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
526 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
527 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
528 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
529 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
530
531 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
532 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
533
534 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
535
536 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
537
538 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
539 install -d $RPM_BUILD_ROOT/etc/sysconfig
540 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
541 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
542
543 # prepare source package
544 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
545 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
546 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
547 %{__make} distclean
548 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
549 find -name '*.h' | xargs chmod a-x
550
551 %if %{with systemtap}
552 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
553 %endif
554
555 %clean
556 rm -rf $RPM_BUILD_ROOT
557
558 %triggerpostun -- xorg-xserver-server < 1.5.0
559 if [ -f /etc/X11/xorg.conf ]; then
560         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
561         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
562 %if %{without record}
563         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
564 %endif
565         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
566 fi
567
568 %post -n xorg-xserver-Xvfb-init
569 /sbin/chkconfig --add Xvfb
570 %service Xvfb restart
571
572 %preun -n xorg-xserver-Xvfb-init
573 if [ "$1" = "0" ]; then
574         %service -q Xvfb stop
575         /sbin/chkconfig --del Xvfb
576 fi
577
578 %files
579 %defattr(644,root,root,755)
580 %doc COPYING ChangeLog README
581 %attr(755,root,root) %{_bindir}/X
582 %attr(755,root,root) %{_bindir}/Xorg
583 %attr(4755,root,root) %{_bindir}/Xwrapper
584 %attr(755,root,root) %{_bindir}/cvt
585 %attr(755,root,root) %{_bindir}/gtf
586 %dir %{_libdir}/xorg
587 %{_libdir}/xorg/protocol.txt
588 %dir %{_libdir}/xorg/modules
589 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
590 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
591 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
592 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
593 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
594 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
595 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
596 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
599 %dir %{_libdir}/xorg/modules/dri
600 %dir %{_libdir}/xorg/modules/drivers
601 %dir %{_libdir}/xorg/modules/extensions
602 %dir %{_libdir}/xorg/modules/input
603 %dir %{_libdir}/xorg/modules/multimedia
604 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/bt829_drv.so
605 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/fi1236_drv.so
606 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/msp3430_drv.so
607 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda8425_drv.so
608 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9850_drv.so
609 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/tda9885_drv.so
610 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/uda1380_drv.so
611 %if "%{_libdir}" != "%{_exec_prefix}/lib"
612 %dir %{_exec_prefix}/lib/xorg
613 %dir %{_exec_prefix}/lib/xorg/modules
614 %dir %{_exec_prefix}/lib/xorg/modules/dri
615 %endif
616 %dir /var/lib/xkb
617 /var/lib/xkb/README.compiled
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
620 %config(missingok) /etc/security/console.apps/xserver
621 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
622 %dir /etc/X11/xorg.conf.d
623 %dir %{_datadir}/X11/xorg.conf.d
624 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
625 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-evdev.conf
626 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
627 %{_mandir}/man1/Xorg.1*
628 %{_mandir}/man1/Xserver.1*
629 %{_mandir}/man1/cvt.1*
630 %{_mandir}/man1/gtf.1*
631 %{_mandir}/man4/exa.4*
632 %{_mandir}/man4/fbdevhw.4*
633 %{_mandir}/man5/xorg.conf.5*
634 %{_mandir}/man5/xorg.conf.d.5*
635
636 %if %{with dmx}
637 %files -n xorg-xserver-Xdmx
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/Xdmx
640 %attr(755,root,root) %{_bindir}/dmxaddinput
641 %attr(755,root,root) %{_bindir}/dmxaddscreen
642 %attr(755,root,root) %{_bindir}/dmxinfo
643 %attr(755,root,root) %{_bindir}/dmxreconfig
644 %attr(755,root,root) %{_bindir}/dmxresize
645 %attr(755,root,root) %{_bindir}/dmxrminput
646 %attr(755,root,root) %{_bindir}/dmxrmscreen
647 %attr(755,root,root) %{_bindir}/dmxtodmx
648 %attr(755,root,root) %{_bindir}/dmxwininfo
649 %attr(755,root,root) %{_bindir}/vdltodmx
650 %attr(755,root,root) %{_bindir}/xdmxconfig
651 %{_mandir}/man1/Xdmx.1*
652 %{_mandir}/man1/dmxtodmx.1*
653 %{_mandir}/man1/vdltodmx.1*
654 %{_mandir}/man1/xdmxconfig.1*
655 %endif
656
657 %files -n xorg-xserver-Xnest
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_bindir}/Xnest
660 %{_mandir}/man1/Xnest.1*
661
662 %files -n xorg-xserver-Xephyr
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_bindir}/Xephyr
665 %{_mandir}/man1/Xephyr.1*
666
667 %files -n xorg-xserver-Xfbdev
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_bindir}/Xfbdev
670
671 %files -n xorg-xserver-Xvfb
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/Xvfb
674 %attr(755,root,root) %{_bindir}/xvfb-run
675 %{_mandir}/man1/Xvfb.1*
676
677 %files -n xorg-xserver-Xvfb-init
678 %defattr(644,root,root,755)
679 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
680 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
681
682 %if %{with wayland}
683 %files -n xorg-xserver-Xwayland
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/Xwayland
686 %endif
687
688 %files devel
689 %defattr(644,root,root,755)
690 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
691 %{_includedir}/xorg
692 %{_libdir}/libxf86config.a
693 %{_libdir}/libxf86config.la
694 %{_aclocaldir}/xorg-server.m4
695 %{_pkgconfigdir}/xorg-server.pc
696
697 %files source
698 %defattr(644,root,root,755)
699 # keep file perms from install time, but have default defattr to keep adapter happy
700 %defattr(-,root,root,755)
701 %{_usrsrc}/%{name}-%{version}
702
703 %files -n xorg-xserver-libglx
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.088611 seconds and 2 git commands to generate.