]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
50dc289cd299b470396ef00cea0c4bc68cb4bc5e
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO: consider XSELINUX
2 #
3 # Conditional build:
4 %bcond_with     multigl         # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
5 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
6 %bcond_with     hal             # HAL support for configuration (if no udev)
7 %bcond_without  udev            # UDEV support for configuration
8 %bcond_without  dri2            # DRI2 extension
9 %bcond_without  dmx             # DMX support
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 #
15 # ABI versions, see hw/xfree86/common/xf86Module.h
16 %define xorg_xserver_server_ansic_abi           0.4
17 %define xorg_xserver_server_extension_abi       6.0
18 %define xorg_xserver_server_font_abi            0.6
19 %define xorg_xserver_server_videodrv_abi        11.0
20 %define xorg_xserver_server_xinput_abi          13.0
21 #
22 %define pixman_ver      0.24.0
23
24 %define         rel     1
25 Summary:        X.org server
26 Summary(pl.UTF-8):      Serwer X.org
27 Name:           xorg-xserver-server
28 Version:        1.11.4
29 Release:        %{rel}%{?with_multigl:.mgl}
30 License:        MIT
31 Group:          X11/Servers
32 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
33 # Source0-md5:  256325e9b17dff479d92bed97f6b0adb
34 Source1:        10-quirks.conf
35 Source2:        xserver.pamd
36 Source10:       %{name}-Xvfb.init
37 Source11:       %{name}-Xvfb.sysconfig
38 Patch0:         %{name}-xwrapper.patch
39 Patch1:         %{name}-pic-libxf86config.patch
40 Patch2:         %{name}-fb-size.patch
41 Patch3:         %{name}-less-acpi-brokenness.patch
42 Patch4:         %{name}-builtin-SHA1.patch
43 Patch5:         %{name}-export-GetMaster.patch
44 Patch6:         110_nvidia_slowdow_fix.patch
45 URL:            http://xorg.freedesktop.org/
46 BuildRequires:  Mesa-libGL-devel >= 7.8.1
47 # for glx headers
48 BuildRequires:  OpenGL-GLX-devel
49 %{?with_xselinux:BuildRequires: audit-libs-devel}
50 BuildRequires:  autoconf >= 2.57
51 BuildRequires:  automake
52 BuildRequires:  cpp
53 BuildRequires:  docbook-dtd43-xml
54 #BuildRequires: doxygen >= 1.6.1
55 %if %{with hal} || %{with dbus}
56 BuildRequires:  dbus-devel >= 1.0
57 %endif
58 %{?with_hal:BuildRequires:      hal-devel}
59 BuildRequires:  libdrm-devel >= 2.4.5
60 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
61 BuildRequires:  libtool
62 BuildRequires:  ncurses-devel
63 BuildRequires:  pam-devel
64 BuildRequires:  perl-base
65 BuildRequires:  pixman-devel >= %{pixman_ver}
66 BuildRequires:  pkgconfig >= 1:0.19
67 BuildRequires:  udev-devel >= 1:143
68 BuildRequires:  xmlto >= 0.0.20
69 BuildRequires:  xorg-app-mkfontscale
70 BuildRequires:  xorg-font-font-util >= 1.1
71 BuildRequires:  xorg-lib-libX11-devel
72 BuildRequires:  xorg-lib-libXau-devel
73 BuildRequires:  xorg-lib-libXaw-devel
74 BuildRequires:  xorg-lib-libXdamage-devel
75 BuildRequires:  xorg-lib-libXdmcp-devel
76 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
77 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
78 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
79 BuildRequires:  xorg-lib-libXmu-devel
80 BuildRequires:  xorg-lib-libXpm-devel
81 BuildRequires:  xorg-lib-libXrender-devel
82 BuildRequires:  xorg-lib-libXres-devel
83 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
84 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
85 BuildRequires:  xorg-lib-libXv-devel
86 BuildRequires:  xorg-lib-libXxf86dga-devel
87 BuildRequires:  xorg-lib-libXxf86misc-devel
88 BuildRequires:  xorg-lib-libXxf86vm-devel
89 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
90 BuildRequires:  xorg-lib-libfontenc-devel
91 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
92 BuildRequires:  xorg-lib-libxkbfile-devel
93 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
94 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
95 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
96 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
97 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
98 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
99 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.6}
100 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
101 BuildRequires:  xorg-proto-fontcacheproto-devel
102 BuildRequires:  xorg-proto-fontsproto-devel
103 BuildRequires:  xorg-proto-glproto-devel >= 1.4.14
104 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
105 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
106 BuildRequires:  xorg-proto-printproto-devel
107 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
108 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
109 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
110 BuildRequires:  xorg-proto-resourceproto-devel
111 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
112 BuildRequires:  xorg-proto-videoproto-devel
113 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
114 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.2.0
115 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
116 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
117 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
118 BuildRequires:  xorg-proto-xf86miscproto-devel
119 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
120 BuildRequires:  xorg-proto-xineramaproto-devel
121 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
122 BuildRequires:  xorg-sgml-doctools >= 1.8
123 BuildRequires:  xorg-util-util-macros >= 1.14
124 #BR: xcalibrateproto, tslib (for KDRIVE only)
125 Requires(triggerpostun):        sed >= 4.0
126 Requires:       pixman >= %{pixman_ver}
127 Requires:       xkeyboard-config
128 # for rgb.txt
129 Requires:       xorg-app-rgb >= 0.99.3
130 Requires:       xorg-app-xkbcomp
131 %{?with_hal:Suggests:   hal}
132 Suggests:       udev-acl >= 1:143
133 %{?with_udev:Suggests:  udev-core >= 1:143}
134 Suggests:       xorg-driver-input-evdev
135 # xserver requires fixed and cursor fonts
136 Requires:       xorg-font-font-alias
137 Requires:       xorg-font-font-cursor-misc
138 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
139 Suggests:       dbus-x11 >= 1.0
140 Suggests:       xkeyboard-config
141 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
142 Suggests:       xorg-driver-video
143 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
144 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
145 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
146 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
147 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
148 Obsoletes:      X11-Xserver < 1:7.0.0
149 Obsoletes:      X11-driver-i2c < 1:7.0.0
150 Obsoletes:      X11-modules < 1:7.0.0
151 Obsoletes:      X11-setup < 1:7.0.0
152 Obsoletes:      XFree86-Xserver < 1:7.0.0
153 Obsoletes:      XFree86-modules < 1:7.0.0
154 Obsoletes:      XFree86-setup < 1:7.0.0
155 Obsoletes:      Xserver
156 Obsoletes:      xorg-xserver-server-xorgcfg
157 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
158
159 # avoid self-dependencies on included modules
160 %define         _noautoreq      libscanpci.so libxf1bpp.so
161
162 %if %{with multigl}
163 # executable Xorg provides symbols this library:
164 %define         skip_post_check_so      libglx.so.*
165 %endif
166
167 %description
168 Xorg server is a generally used X server which uses display hardware.
169 It requires proper driver for your display hardware.
170
171 %description -l pl.UTF-8
172 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
173 graficznej. Do działania wymaga odpowiedniego sterownika.
174
175 %package -n xorg-xserver-Xdmx
176 Summary:        Xdmx - distributed multi-head X server
177 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
178 Group:          X11/Servers
179
180 %description -n xorg-xserver-Xdmx
181 Xdmx - distributed multi-head X server.
182
183 %description -n xorg-xserver-Xdmx -l pl.UTF-8
184 Xdmx - rozproszony, wielomonitorowy serwer X.
185
186 %package -n xorg-xserver-Xnest
187 Summary:        Xnest - nested X server
188 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
189 Group:          X11/Servers
190 Obsoletes:      X11-Xnest < 1:7.0.0
191 Obsoletes:      XFree86-Xnest < 1:7.0.0
192 Obsoletes:      Xserver-Xnest
193
194 %description -n xorg-xserver-Xnest
195 Xnest is an X Window System server which runs in an X window. Xnest is
196 a 'nested' window server, actually a client of the real X server,
197 which manages windows and graphics requests for Xnest, while Xnest
198 manages the windows and graphics requests for its own clients.
199
200 %description -n xorg-xserver-Xnest -l pl.UTF-8
201 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
202 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
203 serwer X dla własnych klientów.
204
205 %description -n xorg-xserver-Xnest -l ru.UTF-8
206 Xnest - это сервер X Window System, который работает в окне X. На
207 самом деле это клиент реального X-сервера, который управляет окнами и
208 графическими запросами для Xnest в то время, как Xnest управляет
209 окнами и графическими запросами для своих собственных клиентов.
210
211 %description -n xorg-xserver-Xnest -l uk.UTF-8
212 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
213 клієнт реального X-сервера, який керує вікнами та графічними запитами
214 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
215 своїх власних клієнтів.
216
217 %package -n xorg-xserver-Xephyr
218 Summary:        Xephyr - nested X server
219 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
220 Group:          X11/Servers
221 Requires:       pixman >= %{pixman_ver}
222
223 %description -n xorg-xserver-Xephyr
224 Xephyr is a a kdrive server that outputs to a window on a pre-existing
225 'host' X display. Think Xnest but with support for modern extensions
226 like composite, damage and randr.
227
228 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
229 the host X server, Xephyr is a real X server which uses the host X
230 server window as "framebuffer" via fast SHM XImages.
231
232 It also has support for 'visually' debugging what the server is
233 painting.
234
235 %description -n xorg-xserver-Xephyr -l pl.UTF-8
236 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
237 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
238 wspólczesnych rozszerzeń jak composite, damage i randr.
239
240 %package -n xorg-xserver-Xfbdev
241 Summary:        Xfbdev - Linux framebuffer device X server
242 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
243 Group:          X11/Servers
244
245 %description -n xorg-xserver-Xfbdev
246 Xfbdev is a Linux framebuffer device X server based on the kdrive X
247 server.
248
249 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
250 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
251
252 %package -n xorg-xserver-Xvfb
253 Summary:        Xvfb - virtual framebuffer X server
254 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
255 Group:          X11/Servers
256 # requires fixed and cursor fonts
257 Requires:       xorg-font-font-alias
258 Requires:       xorg-font-font-cursor-misc
259 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
260 Obsoletes:      X11-Xvfb < 1:7.0.0
261 Obsoletes:      XFree86-Xvfb < 1:7.0.0
262
263 %description -n xorg-xserver-Xvfb
264 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
265 capable of running on machines with no display hardware and no
266 physical input devices. Xvfb emulates a dumb framebuffer using virtual
267 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
268 display. Xvfb is normally used for testing servers. Using Xvfb, the
269 mfb or cfb code for any depth can be exercised without using real
270 hardware that supports the desired depths. Xvfb has also been used to
271 test X clients against unusual depths and screen configurations, to do
272 batch processing with Xvfb as a background rendering engine, to do
273 load testing, to help with porting an X server to a new platform, and
274 to provide an unobtrusive way of running applications which really
275 don't need an X server but insist on having one.
276
277 %description -n xorg-xserver-Xvfb -l pl.UTF-8
278 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
279 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
280 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
281 używany do testowania serwerów X, może też być używany do testowania
282 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
283 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
284 serwera X, ale odmawiają uruchomienia bez niego.
285
286 %package -n xorg-xserver-Xvfb-init
287 Summary:        Init scripts for Xvfb
288 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
289 Group:          X11/Servers
290 Requires:       xorg-xserver-Xvfb
291
292 %description -n xorg-xserver-Xvfb-init
293 This package contains init scripts for Xvfb and registers Xvfb as
294 system service.
295
296 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
297 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
298 usługę systemową.
299
300 %package devel
301 Summary:        Header files for X.org server
302 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
303 Group:          X11/Development/Libraries
304 Requires:       libdrm-devel >= 2.4.5
305 Requires:       pixman-devel >= %{pixman_ver}
306 Requires:       xorg-lib-libpciaccess-devel >= 0.8.0
307 Requires:       xorg-lib-libxkbfile-devel
308 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.6}
309 Requires:       xorg-proto-fontsproto-devel
310 Requires:       xorg-proto-inputproto-devel >= 1.9.99.902
311 Requires:       xorg-proto-kbproto-devel >= 1.0.3
312 Requires:       xorg-proto-randrproto-devel >= 1.3
313 Requires:       xorg-proto-renderproto-devel >= 0.11
314 Requires:       xorg-proto-videoproto-devel
315 Requires:       xorg-proto-xextproto-devel >= 1:7.2.0
316 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
317 Requires:       xorg-proto-xineramaproto-devel
318 Requires:       xorg-proto-xproto-devel >= 7.0.22
319 Obsoletes:      X11-Xserver-devel < 1:7.0.0
320 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
321
322 %description devel
323 Header files for X.org server.
324
325 %description devel -l pl.UTF-8
326 Pliki nagłówkowe dla serwera X.org.
327
328 %package source
329 Summary:        X.org server source code
330 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
331 Group:          X11/Development/Libraries
332
333 %description source
334 X.org server source code.
335
336 %description source -l pl.UTF-8
337 Pliki źródłowe dla serwera X.org.
338
339 %package -n xorg-xserver-libdri
340 Summary:        DRI extension library for X.org server
341 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
342 Group:          X11/Servers
343 Requires:       %{name} = %{version}-%{release}
344 Provides:       xorg-xserver-module(dri)
345 %if %{without multigl}
346 Conflicts:      xorg-driver-video-fglrx
347 Conflicts:      xorg-driver-video-nvidia
348 %endif
349
350 %description -n xorg-xserver-libdri
351 DRI extension library for X.org server.
352
353 %description -n xorg-xserver-libdri -l pl.UTF-8
354 Biblioteka rozszerzenia DRI dla serwera X.org.
355
356 %package -n xorg-xserver-libglx
357 Summary:        GLX extension library for X.org server
358 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
359 Group:          X11/Servers
360 Requires:       %{name} = %{version}-%{release}
361 Requires:       xorg-xserver-libdri = %{version}-%{release}
362 # Mesa version glapi tables in glx/ dir come from
363 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
364 Provides:       xorg-xserver-module(glx)
365 Obsoletes:      X11-OpenGL-core < 1:7.0.0
366 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
367 %if %{without multigl}
368 Conflicts:      xorg-driver-video-fglrx
369 Conflicts:      xorg-driver-video-nvidia
370 %endif
371
372 %description -n xorg-xserver-libglx
373 GLX extension library for X.org server.
374
375 %description -n xorg-xserver-libglx -l pl.UTF-8
376 Biblioteka rozszerzenia GLX dla serwera X.org.
377
378 %prep
379 %setup -q -n xorg-server-%{version}
380 %patch0 -p0
381 %patch1 -p1
382 %patch2 -p1
383 %patch3 -p1
384 %patch4 -p1
385 %patch5 -p1
386 %patch6 -p1
387
388 # xserver uses pixman-1 API/ABI so put that explictly here
389 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
390
391 %build
392 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
393 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
394         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
395         exit 1
396 fi
397
398 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
399 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
400         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
401         exit 1
402 fi
403
404 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
405 if [ $API != %{xorg_xserver_server_font_abi} ]; then
406         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
407         exit 1
408 fi
409 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
410 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
411         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
412         exit 1
413 fi
414 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
415 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
416         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
417         exit 1
418 fi
419
420 %{__libtoolize}
421 %{__aclocal} -I m4
422 %{__autoconf}
423 %{__autoheader}
424 %{__automake}
425 %configure \
426         --with-os-name="PLD/Linux" \
427         --with-os-vendor="PLD/Team" \
428         --without-fop \
429         %{?with_dbus:--enable-config-dbus} \
430         --enable-config-hal%{!?with_hal:=no} \
431         --enable-config-udev%{!?with_udev:=no} \
432         --enable-aiglx \
433         --enable-dga \
434         %{?with_dmx:--enable-dmx} \
435         --enable-glx-tls \
436         --enable-install-libxf86config \
437         %{?with_record:--enable-record} \
438         --enable-kdrive \
439         %{?with_xcsecurity:--enable-xcsecurity} \
440         --enable-xephyr \
441         %{?with_xf86bigfont:--enable-xf86bigfont} \
442         --enable-xfbdev \
443         %{?with_xselinux:--enable-xselinux} \
444         --enable-glx-tls \
445         --disable-xfake \
446         --enable-secure-rpc \
447         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
448         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
449         --with-xkb-output=/var/lib/xkb
450
451 %{__make}
452
453 %install
454 rm -rf $RPM_BUILD_ROOT
455
456 %{__make} install \
457         DESTDIR=$RPM_BUILD_ROOT
458
459 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
460 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
461 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
462 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
463
464 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
465 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
466
467 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
468
469 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
470
471 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
472 install -d $RPM_BUILD_ROOT/etc/sysconfig
473 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
474 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
475
476 %if %{with multigl}
477 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
478 mv -f libglx.so libglx.so.%{version}
479 ln -sf libglx.so.%{version} libglx.so
480 cd -
481 %endif
482
483 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
484 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
485 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
486 %{__make} distclean
487 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
488 find -name '*.h' | xargs chmod a-x
489
490 %clean
491 rm -rf $RPM_BUILD_ROOT
492
493 %if %{with multigl}
494 %post -n xorg-xserver-libglx
495 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
496         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
497 fi
498 %endif
499
500 %triggerpostun -- xorg-xserver-server < 1.5.0
501 if [ -f /etc/X11/xorg.conf ]; then
502         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
503         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
504 %if %{without record}
505         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
506 %endif
507         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
508 fi
509
510 %post -n xorg-xserver-Xvfb-init
511 /sbin/chkconfig --add Xvfb
512 %service Xvfb restart
513
514 %preun -n xorg-xserver-Xvfb-init
515 if [ "$1" = "0" ]; then
516         %service -q Xvfb stop
517         /sbin/chkconfig --del Xvfb
518 fi
519
520 %files
521 %defattr(644,root,root,755)
522 %doc COPYING ChangeLog README
523 %attr(755,root,root) %{_bindir}/X
524 %attr(755,root,root) %{_bindir}/Xorg
525 %attr(4755,root,root) %{_bindir}/Xwrapper
526 %attr(755,root,root) %{_bindir}/cvt
527 %attr(755,root,root) %{_bindir}/gtf
528 %dir %{_libdir}/xorg
529 %{_libdir}/xorg/protocol.txt
530 %dir %{_libdir}/xorg/modules
531 %dir %{_libdir}/xorg/modules/dri
532 %dir %{_libdir}/xorg/modules/drivers
533 %dir %{_libdir}/xorg/modules/extensions
534 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
535 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
536 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
537 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
538 %dir %{_libdir}/xorg/modules/input
539 %dir %{_libdir}/xorg/modules/multimedia
540 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
541 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
542 %dir /var/lib/xkb
543 /var/lib/xkb/README.compiled
544 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
545 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
546 %config(missingok) /etc/security/console.apps/xserver
547 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
548 %dir /etc/X11/xorg.conf.d
549 %dir %{_datadir}/X11/xorg.conf.d
550 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
551 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/*.conf
552 %{_mandir}/man1/Xorg.1x*
553 %{_mandir}/man1/Xserver.1x*
554 %{_mandir}/man1/cvt.1*
555 %{_mandir}/man1/gtf.1x*
556 %{_mandir}/man4/exa.4*
557 %{_mandir}/man4/fbdevhw.4*
558 %{_mandir}/man5/xorg.conf.5x*
559 %{_mandir}/man5/xorg.conf.d.5x
560
561 %if %{with dmx}
562 %files -n xorg-xserver-Xdmx
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{_bindir}/Xdmx
565 %attr(755,root,root) %{_bindir}/dmxaddinput
566 %attr(755,root,root) %{_bindir}/dmxaddscreen
567 %attr(755,root,root) %{_bindir}/dmxinfo
568 %attr(755,root,root) %{_bindir}/dmxreconfig
569 %attr(755,root,root) %{_bindir}/dmxresize
570 %attr(755,root,root) %{_bindir}/dmxrminput
571 %attr(755,root,root) %{_bindir}/dmxrmscreen
572 %attr(755,root,root) %{_bindir}/dmxtodmx
573 %attr(755,root,root) %{_bindir}/dmxwininfo
574 %attr(755,root,root) %{_bindir}/vdltodmx
575 %attr(755,root,root) %{_bindir}/xdmxconfig
576 %{_mandir}/man1/Xdmx.1x*
577 %{_mandir}/man1/dmxtodmx.1x*
578 %{_mandir}/man1/vdltodmx.1x*
579 %{_mandir}/man1/xdmxconfig.1x*
580 %endif
581
582 %files -n xorg-xserver-Xnest
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_bindir}/Xnest
585 %{_mandir}/man1/Xnest.1x*
586
587 %files -n xorg-xserver-Xephyr
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/Xephyr
590 %{_mandir}/man1/Xephyr.1x*
591
592 %files -n xorg-xserver-Xfbdev
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_bindir}/Xfbdev
595
596 %files -n xorg-xserver-Xvfb
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_bindir}/Xvfb
599 %{_mandir}/man1/Xvfb.1x*
600
601 %files -n xorg-xserver-Xvfb-init
602 %defattr(644,root,root,755)
603 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
604 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
605
606 %files devel
607 %defattr(644,root,root,755)
608 %doc doc/{Xinput,Xserver-spec}.html
609 %{_includedir}/xorg
610 %{_libdir}/libxf86config.a
611 %{_libdir}/libxf86config.la
612 %{_aclocaldir}/xorg-server.m4
613 %{_pkgconfigdir}/xorg-server.pc
614
615 %files source
616 %defattr(644,root,root,755)
617 # keep file perms from install time, but have default defattr to keep adapter happy
618 %defattr(-,root,root,755)
619 %{_usrsrc}/%{name}-%{version}
620
621 %files -n xorg-xserver-libdri
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
624
625 %files -n xorg-xserver-libglx
626 %defattr(644,root,root,755)
627 %if %{with multigl}
628 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
629 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
630 %else
631 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
632 %endif
This page took 0.101185 seconds and 3 git commands to generate.