]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
- rel 3
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 #
2 # Conditional build:
3 %bcond_with     multigl # package libglx.so in a way allowing concurrent install with nvidia/fglrx drivers
4 %bcond_without  dri2    # DRI2 support
5 %bcond_without  dbus    # D-BUS support
6 %bcond_without  hal     # HAL support
7 %bcond_without  dmx     # DMX support
8 %bcond_with     record  # RECORD extension
9 #
10 # ABI versions, see hw/xfree86/common/xf86Module.h
11 %define xorg_xserver_server_ansic_abi           0.4
12 %define xorg_xserver_server_extension_abi       2.0
13 %define xorg_xserver_server_font_abi            0.6
14 %define xorg_xserver_server_videodrv_abi        5.0
15 %define xorg_xserver_server_xinput_abi          4.0
16
17 Summary:        X.org server
18 Summary(pl.UTF-8):      Serwer X.org
19 Name:           xorg-xserver-server
20 Version:        1.6.0
21 Release:        3%{?with_multigl:.mgl}
22 License:        MIT
23 Group:          X11/Servers
24 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
25 # Source0-md5:  aafe73f5807ce8bb534727ecb72467c7
26 Source2:        xserver.pamd
27 Patch0:         %{name}-xwrapper.patch
28 Patch1:         %{name}-pic-libxf86config.patch
29 Patch2:         %{name}-fb-size.patch
30 Patch3:         %{name}-exa.patch
31 URL:            http://xorg.freedesktop.org/
32 BuildRequires:  Mesa-libGL-devel >= 7.3
33 # for glx headers
34 BuildRequires:  OpenGL-GLX-devel
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 BuildRequires:  cpp
38 %if %{with hal} || %{with dbus}
39 BuildRequires:  dbus-devel
40 %endif
41 %{?with_hal:BuildRequires:      hal-devel}
42 BuildRequires:  libdrm-devel >= 2.4.5
43 BuildRequires:  libtool
44 BuildRequires:  ncurses-devel
45 BuildRequires:  pam-devel
46 BuildRequires:  perl-base
47 BuildRequires:  pixman-devel >= 0.14.0
48 BuildRequires:  pkgconfig >= 1:0.19
49 BuildRequires:  xorg-app-mkfontscale
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xorg-lib-libXau-devel
52 BuildRequires:  xorg-lib-libXaw-devel
53 BuildRequires:  xorg-lib-libXdmcp-devel
54 BuildRequires:  xorg-lib-libXext-devel
55 BuildRequires:  xorg-lib-libXfont-devel
56 BuildRequires:  xorg-lib-libXi-devel >= 1.2
57 BuildRequires:  xorg-lib-libXmu-devel
58 BuildRequires:  xorg-lib-libXpm-devel
59 BuildRequires:  xorg-lib-libXrender-devel
60 BuildRequires:  xorg-lib-libXres-devel
61 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
62 BuildRequires:  xorg-lib-libXtst-devel
63 BuildRequires:  xorg-lib-libXxf86dga-devel
64 BuildRequires:  xorg-lib-libXxf86misc-devel
65 BuildRequires:  xorg-lib-libXxf86vm-devel
66 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel}
67 BuildRequires:  xorg-lib-libfontenc-devel
68 BuildRequires:  xorg-lib-libpciaccess-devel
69 BuildRequires:  xorg-lib-libxkbfile-devel
70 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
71 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
72 BuildRequires:  xorg-proto-bigreqsproto-devel
73 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
74 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
75 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel}
76 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 1.99.3}
77 BuildRequires:  xorg-proto-evieext-devel
78 BuildRequires:  xorg-proto-fixesproto-devel >= 4.0
79 BuildRequires:  xorg-proto-fontcacheproto-devel
80 BuildRequires:  xorg-proto-fontsproto-devel
81 BuildRequires:  xorg-proto-glproto-devel >= 1.4.8
82 BuildRequires:  xorg-proto-inputproto-devel >= 1.5.0
83 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
84 BuildRequires:  xorg-proto-printproto-devel
85 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
86 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel}
87 BuildRequires:  xorg-proto-renderproto-devel >= 0.9.3
88 BuildRequires:  xorg-proto-resourceproto-devel
89 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
90 BuildRequires:  xorg-proto-videoproto-devel
91 BuildRequires:  xorg-proto-xcmiscproto-devel
92 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.3
93 BuildRequires:  xorg-proto-xf86bigfontproto-devel
94 BuildRequires:  xorg-proto-xf86dgaproto-devel
95 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.0.4
96 BuildRequires:  xorg-proto-xf86miscproto-devel
97 BuildRequires:  xorg-proto-xf86vidmodeproto-devel
98 BuildRequires:  xorg-proto-xineramaproto-devel
99 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
100 BuildRequires:  xorg-util-util-macros >= 0.99.2
101 #BR: xcalibrateproto, tslib (for KDRIVE only)
102 #BR: glitz-devel >= 0.4.3 (for XGL and EGL only)
103 Requires(triggerpostun):        sed >= 4.0
104 Requires:       pixman >= 0.14.0
105 Requires:       xkeyboard-config
106 # for rgb.txt
107 Requires:       xorg-app-rgb >= 0.99.3
108 Requires:       xorg-app-xkbcomp
109 # xserver requires fixed and cursor fonts
110 Requires:       xorg-font-font-alias
111 Requires:       xorg-font-font-cursor-misc
112 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
113 Suggests:       xkeyboard-config
114 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
115 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
116 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
117 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
118 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
119 Obsoletes:      X11-Xserver < 1:7.0.0
120 Obsoletes:      X11-driver-i2c < 1:7.0.0
121 Obsoletes:      X11-modules < 1:7.0.0
122 Obsoletes:      X11-setup < 1:7.0.0
123 Obsoletes:      XFree86-Xserver < 1:7.0.0
124 Obsoletes:      XFree86-modules < 1:7.0.0
125 Obsoletes:      XFree86-setup < 1:7.0.0
126 Obsoletes:      Xserver
127 Obsoletes:      xorg-xserver-server-xorgcfg
128 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
129
130 # avoid self-dependencies on included modules
131 %define         _noautoreq      libscanpci.so libxf1bpp.so
132
133 %description
134 Xorg server is a generally used X server which uses display hardware.
135 It requires proper driver for your display hardware.
136
137 %description -l pl.UTF-8
138 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
139 graficznej. Do działania wymaga odpowiedniego sterownika.
140
141 %package -n xorg-xserver-Xdmx
142 Summary:        Xdmx - distributed multi-head X server
143 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
144 Group:          X11/Servers
145
146 %description -n xorg-xserver-Xdmx
147 Xdmx - distributed multi-head X server.
148
149 %description -n xorg-xserver-Xdmx -l pl.UTF-8
150 Xdmx - rozproszony, wielomonitorowy serwer X.
151
152 %package -n xorg-xserver-Xnest
153 Summary:        Xnest - nested X server
154 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
155 Group:          X11/Servers
156 Obsoletes:      X11-Xnest < 1:7.0.0
157 Obsoletes:      XFree86-Xnest < 1:7.0.0
158 Obsoletes:      Xserver-Xnest
159
160 %description -n xorg-xserver-Xnest
161 Xnest is an X Window System server which runs in an X window. Xnest is
162 a 'nested' window server, actually a client of the real X server,
163 which manages windows and graphics requests for Xnest, while Xnest
164 manages the windows and graphics requests for its own clients.
165
166 %description -n xorg-xserver-Xnest -l pl.UTF-8
167 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
168 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
169 serwer X dla własnych klientów.
170
171 %description -n xorg-xserver-Xnest -l ru.UTF-8
172 Xnest - это сервер X Window System, который работает в окне X. На
173 самом деле это клиент реального X-сервера, который управляет окнами и
174 графическими запросами для Xnest в то время, как Xnest управляет
175 окнами и графическими запросами для своих собственных клиентов.
176
177 %description -n xorg-xserver-Xnest -l uk.UTF-8
178 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
179 клієнт реального X-сервера, який керує вікнами та графічними запитами
180 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
181 своїх власних клієнтів.
182
183 %package -n xorg-xserver-Xephyr
184 Summary:        Xephyr - nested X server
185 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
186 Group:          X11/Servers
187
188 %description -n xorg-xserver-Xephyr
189 Xephyr is a a kdrive server that outputs to a window on a pre-existing
190 'host' X display. Think Xnest but with support for modern extensions
191 like composite, damage and randr.
192
193 Unlike Xnest which is an X proxy, i.e.  limited to the
194 capabilities of the host X server, Xephyr is a real X server which
195 uses the host X server window as "framebuffer" via fast SHM XImages.
196
197 It also has support for 'visually' debugging what the server is
198 painting.
199
200 %description -n xorg-xserver-Xephyr -l pl.UTF-8
201 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
202 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem
203 do wspólczesnych rozszerzeń jak composite, damage i randr.
204
205 %package -n xorg-xserver-Xfbdev
206 Summary:        Xfbdev - Linux framebuffer device X server
207 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
208 Group:          X11/Servers
209
210 %description -n xorg-xserver-Xfbdev
211 Xfbdev is a Linux framebuffer device X server based on the
212 kdrive X server.
213
214 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
215 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
216
217 %package -n xorg-xserver-Xvfb
218 Summary:        Xvfb - virtual framebuffer X server
219 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
220 Group:          X11/Servers
221 # requires fixed and cursor fonts
222 Requires:       xorg-font-font-alias
223 Requires:       xorg-font-font-cursor-misc
224 Requires:       xorg-font-font-misc-misc-base >= 1.0.0-0.3
225 Obsoletes:      X11-Xvfb < 1:7.0.0
226 Obsoletes:      XFree86-Xvfb < 1:7.0.0
227
228 %description -n xorg-xserver-Xvfb
229 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
230 capable of running on machines with no display hardware and no
231 physical input devices. Xvfb emulates a dumb framebuffer using virtual
232 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
233 display. Xvfb is normally used for testing servers. Using Xvfb, the
234 mfb or cfb code for any depth can be exercised without using real
235 hardware that supports the desired depths. Xvfb has also been used to
236 test X clients against unusual depths and screen configurations, to do
237 batch processing with Xvfb as a background rendering engine, to do
238 load testing, to help with porting an X server to a new platform, and
239 to provide an unobtrusive way of running applications which really
240 don't need an X server but insist on having one.
241
242 %description -n xorg-xserver-Xvfb -l pl.UTF-8
243 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
244 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
245 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
246 używany do testowania serwerów X, może też być używany do testowania
247 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
248 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
249 serwera X, ale odmawiają uruchomienia bez niego.
250
251 %package devel
252 Summary:        Header files for X.org server
253 Summary(pl.UTF-8):      Pliki nagłówkowe dla servera X.org
254 Group:          X11/Development/Libraries
255 Requires:       libdrm-devel >= 2.4.5
256 Requires:       pixman-devel >= 0.14.0
257 Requires:       xorg-lib-libxkbfile-devel
258 Requires:       xorg-proto-fontsproto-devel
259 Requires:       xorg-proto-renderproto-devel >= 0.9.3
260 Requires:       xorg-proto-videoproto-devel
261 Requires:       xorg-proto-xextproto-devel
262 Requires:       xorg-proto-xproto-devel >= 7.0.9
263 Obsoletes:      X11-Xserver-devel < 1:7.0.0
264 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
265
266 %description devel
267 Header files for X.org server.
268
269 %description devel -l pl.UTF-8
270 Pliki nagłówkowe dla serwera X.org.
271
272 %package -n xorg-xserver-libdri
273 Summary:        DRI extension library for X.org server
274 Summary(pl.UTF-8):      Biblioteka rozszerzenia DRI dla serwera X.org
275 Group:          X11/Servers
276 Requires:       %{name} = %{version}-%{release}
277 Provides:       xorg-xserver-module(dri)
278 %if %{without multigl}
279 Conflicts:      xorg-driver-video-nvidia
280 Conflicts:      xorg-driver-video-fglrx-libdri
281 %endif
282
283 %description -n xorg-xserver-libdri
284 DRI extension library for X.org server.
285
286 %description -n xorg-xserver-libdri -l pl.UTF-8
287 Biblioteka rozszerzenia DRI dla serwera X.org.
288
289 %package -n xorg-xserver-libglx
290 Summary:        GLX extension library for X.org server
291 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
292 Group:          X11/Servers
293 Requires:       %{name} = %{version}-%{release}
294 Requires:       xorg-xserver-libdri = %{version}-%{release}
295 # Mesa version glapi tables in glx/ dir come from
296 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
297 Provides:       xorg-xserver-module(glx)
298 Obsoletes:      X11-OpenGL-core < 1:7.0.0
299 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
300 %if %{without multigl}
301 Conflicts:      xorg-driver-video-nvidia
302 Conflicts:      xorg-driver-video-fglrx-libglx
303 %endif
304
305 %description -n xorg-xserver-libglx
306 GLX extension library for X.org server.
307
308 %description -n xorg-xserver-libglx -l pl.UTF-8
309 Biblioteka rozszerzenia GLX dla serwera X.org.
310
311 %prep
312 %setup -q -n xorg-server-%{version}
313 %patch0 -p0
314 %patch1 -p1
315 %patch2 -p1
316 %patch3 -p1
317
318 # xserver uses pixman-1 API/ABI so put that explictly here
319 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
320
321 %build
322 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
323 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
324         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
325         exit 1
326 fi
327
328 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
329 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
330         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
331         exit 1
332 fi
333
334 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
335 if [ $API != %{xorg_xserver_server_font_abi} ]; then
336         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
337         exit 1
338 fi
339 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
340 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
341         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
342         exit 1
343 fi
344 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
345 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
346         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
347         exit 1
348 fi
349
350 %{__libtoolize}
351 %{__aclocal}
352 %{__autoconf}
353 %{__autoheader}
354 %{__automake}
355 %configure \
356         --with-os-name="PLD/Linux" \
357         --with-os-vendor="PLD/Team" \
358         --%{?with_dbus:en}%{!?with_dbus:dis}able-config-dbus \
359         %{!?with_hal:--disable-config-hal} \
360         --enable-aiglx \
361         --enable-builddocs \
362         --enable-dga \
363         %{?with_dmx:--enable-dmx} \
364         --enable-glx-tls \
365         --enable-install-libxf86config \
366         %{?with_record:--enable-record} \
367         --enable-kdrive \
368         --enable-xephyr \
369         --enable-xfbdev \
370         --disable-xsdl \
371         --disable-xfake \
372         --enable-secure-rpc \
373         --%{?with_dri2:en}%{!?with_dri2:dis}able-dri2 \
374         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
375         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
376         --with-xkb-output=/var/lib/xkb
377
378 %{__make}
379
380 %install
381 rm -rf $RPM_BUILD_ROOT
382
383 %{__make} install \
384         DESTDIR=$RPM_BUILD_ROOT
385
386 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
387 install -d $RPM_BUILD_ROOT/etc/security/console.apps
388 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
389 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
390 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
391
392 rm -f $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.{la,a}
393
394 %if %{with multigl}
395 cd $RPM_BUILD_ROOT%{_libdir}/xorg/modules/extensions
396 mv -f libglx.so libglx.so.%{version}
397 ln -sf libglx.so.%{version} libglx.so
398 %endif
399
400 %clean
401 rm -rf $RPM_BUILD_ROOT
402
403 %if %{with multigl}
404 %post -n xorg-xserver-libglx
405 if [ ! -e %{_libdir}/xorg/modules/extensions/libglx.so ]; then
406         ln -sf libglx.so.%{version} %{_libdir}/xorg/modules/extensions/libglx.so
407 fi
408 %endif
409
410 %triggerpostun -- xorg-xserver-server < 1.5.0
411 if [ -f /etc/X11/xorg.conf ]; then
412         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
413         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
414 %if %{without record}
415         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
416 %endif
417         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
418 fi
419
420 %files
421 %defattr(644,root,root,755)
422 %doc COPYING ChangeLog
423 %attr(755,root,root) %{_bindir}/X
424 %attr(755,root,root) %{_bindir}/Xorg
425 %attr(4755,root,root) %{_bindir}/Xwrapper
426 %attr(755,root,root) %{_bindir}/cvt
427 %attr(755,root,root) %{_bindir}/gtf
428 %{_libdir}/X11/Options
429 %dir %{_libdir}/xorg
430 %{_libdir}/xorg/protocol.txt
431 %dir %{_libdir}/xorg/modules
432 %dir %{_libdir}/xorg/modules/dri
433 %dir %{_libdir}/xorg/modules/drivers
434 %dir %{_libdir}/xorg/modules/extensions
435 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdbe.so
436 %{?with_dri2:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri2.so}
437 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libextmod.so
438 %{?with_record:%attr(755,root,root) %{_libdir}/xorg/modules/extensions/librecord.so}
439 %dir %{_libdir}/xorg/modules/input
440 %dir %{_libdir}/xorg/modules/linux
441 %attr(755,root,root) %{_libdir}/xorg/modules/linux/libfbdevhw.so
442 %dir %{_libdir}/xorg/modules/multimedia
443 %attr(755,root,root) %{_libdir}/xorg/modules/multimedia/*.so
444 %attr(755,root,root) %{_libdir}/xorg/modules/lib*.so
445 %dir /var/lib/xkb
446 /var/lib/xkb/README.compiled
447 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
448 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
449 %config(missingok) /etc/security/console.apps/xserver
450 %{?with_dbus:%{_sysconfdir}/dbus-1/system.d/xorg-server.conf}
451 %{_mandir}/man1/Xorg.1x*
452 %{_mandir}/man1/Xserver.1x*
453 %{_mandir}/man1/cvt.1*
454 %{_mandir}/man1/gtf.1x*
455 %{_mandir}/man4/exa.4*
456 %{_mandir}/man4/fbdevhw.4*
457 %{_mandir}/man5/xorg.conf.5x*
458
459 %if %{with dmx}
460 %files -n xorg-xserver-Xdmx
461 %defattr(644,root,root,755)
462 %attr(755,root,root) %{_bindir}/Xdmx
463 %attr(755,root,root) %{_bindir}/dmxaddinput
464 %attr(755,root,root) %{_bindir}/dmxaddscreen
465 %attr(755,root,root) %{_bindir}/dmxreconfig
466 %attr(755,root,root) %{_bindir}/dmxresize
467 %attr(755,root,root) %{_bindir}/dmxrminput
468 %attr(755,root,root) %{_bindir}/dmxrmscreen
469 %attr(755,root,root) %{_bindir}/dmxtodmx
470 %attr(755,root,root) %{_bindir}/dmxwininfo
471 %attr(755,root,root) %{_bindir}/vdltodmx
472 %attr(755,root,root) %{_bindir}/xdmx
473 %attr(755,root,root) %{_bindir}/xdmxconfig
474 %{_mandir}/man1/Xdmx.1x*
475 %{_mandir}/man1/dmxtodmx.1x*
476 %{_mandir}/man1/vdltodmx.1x*
477 %{_mandir}/man1/xdmxconfig.1x*
478 %endif
479
480 %files -n xorg-xserver-Xnest
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{_bindir}/Xnest
483 %{_mandir}/man1/Xnest.1x*
484
485 %files -n xorg-xserver-Xephyr
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_bindir}/Xephyr
488 %{_mandir}/man1/Xephyr.1x*
489
490 %files -n xorg-xserver-Xfbdev
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/Xfbdev
493
494 %files -n xorg-xserver-Xvfb
495 %defattr(644,root,root,755)
496 %attr(755,root,root) %{_bindir}/Xvfb
497 %{_mandir}/man1/Xvfb.1x*
498
499 %files devel
500 %defattr(644,root,root,755)
501 %{_includedir}/xorg
502 %{_libdir}/libxf86config.a
503 %{_aclocaldir}/xorg-server.m4
504 %{_pkgconfigdir}/xorg-server.pc
505
506 %files -n xorg-xserver-libdri
507 %defattr(644,root,root,755)
508 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libdri.so
509
510 %files -n xorg-xserver-libglx
511 %defattr(644,root,root,755)
512 %if %{with multigl}
513 %ghost %{_libdir}/xorg/modules/extensions/libglx.so
514 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so.%{version}
515 %else
516 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
517 %endif
This page took 0.293865 seconds and 3 git commands to generate.