]> git.pld-linux.org Git - packages/xorg-xserver-server.git/blob - xorg-xserver-server.spec
3aed7b21dc9afe5cd83d28f57e47fa5730abbb59
[packages/xorg-xserver-server.git] / xorg-xserver-server.spec
1 # TODO
2 # - consider XSELINUX by default
3 # - Xvfb initscript runs Xvfb as root! add user there!
4 #
5 # Conditional build:
6 %bcond_with     dbus            # D-BUS support for configuration (if no udev)
7 %bcond_with     hal             # HAL support for configuration (if no udev)
8 %bcond_without  udev            # UDEV support for configuration
9 %bcond_without  dri2            # DRI2 extension
10 %bcond_without  record          # RECORD extension
11 %bcond_with     xcsecurity      # XC-SECURITY extension (deprecated)
12 %bcond_with     xf86bigfont     # XF86BigFont extension
13 %bcond_with     xselinux        # SELinux extension
14 %bcond_without  dmx             # DMX DDX (Xdmx server)
15 %bcond_without  wayland         # Wayland DDX (Xwayland server)
16 %bcond_without  glamor          # glamor dix module
17 %bcond_without  systemtap       # systemtap/dtrace probes
18 %bcond_without  libunwind       # use libunwind for backtracing
19 #
20 # ABI versions, see hw/xfree86/common/xf86Module.h
21 %define xorg_xserver_server_ansic_abi           0.4
22 %define xorg_xserver_server_extension_abi       9.0
23 %define xorg_xserver_server_font_abi            0.6
24 %define xorg_xserver_server_videodrv_abi        20.0
25 %define xorg_xserver_server_xinput_abi          22.1
26
27 %define pixman_ver      0.30.0
28
29 %ifarch x32
30 %undefine       with_libunwind
31 %endif
32
33 Summary:        X.org server
34 Summary(pl.UTF-8):      Serwer X.org
35 Name:           xorg-xserver-server
36 Version:        1.18.0
37 Release:        1
38 License:        MIT
39 Group:          X11/Servers
40 Source0:        http://xorg.freedesktop.org/releases/individual/xserver/xorg-server-%{version}.tar.bz2
41 # Source0-md5:  3c1c1057d3ad27380d8dd87ffcc182cd
42 Source1:        10-quirks.conf
43 Source2:        xserver.pamd
44 Source10:       %{name}-Xvfb.init
45 Source11:       %{name}-Xvfb.sysconfig
46 Source12:       xvfb-run.sh
47
48 Patch2:         dtrace-link.patch
49
50 Patch4:         %{name}-builtin-SHA1.patch
51
52 Patch6:         110_nvidia_slowdow_fix.patch
53 Patch7:         %{name}-include-defs.patch
54 URL:            http://xorg.freedesktop.org/
55 BuildRequires:  Mesa-libGL-devel >= 7.8.1
56 %{?with_dri2:BuildRequires:     Mesa-libGL-devel >= 9.2.0}
57 %{?with_glamor:BuildRequires:   Mesa-libgbm-devel >= 10.2.0}
58 # for glx headers
59 BuildRequires:  OpenGL-GLX-devel
60 %{?with_xselinux:BuildRequires: audit-libs-devel}
61 BuildRequires:  autoconf >= 2.60
62 BuildRequires:  automake
63 BuildRequires:  cpp
64 BuildRequires:  docbook-dtd43-xml
65 #BuildRequires: doxygen >= 1.6.1
66 %if %{with hal} || %{with dbus}
67 BuildRequires:  dbus-devel >= 1.0
68 %endif
69 %{?with_hal:BuildRequires:      hal-devel}
70 BuildRequires:  libdrm-devel >= 2.4.46
71 %if %{with glamor} || %{with wayland}
72 BuildRequires:  libepoxy-devel
73 %endif
74 %{?with_xselinux:BuildRequires: libselinux-devel >= 2.0.86}
75 BuildRequires:  libtool >= 2:2.2
76 %{?with_libunwind:BuildRequires:        libunwind-devel}
77 BuildRequires:  libxcb-devel >= 1.6
78 BuildRequires:  pam-devel
79 BuildRequires:  perl-base
80 BuildRequires:  pixman-devel >= %{pixman_ver}
81 BuildRequires:  pkgconfig >= 1:0.19
82 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
83 BuildRequires:  systemd-devel
84 BuildRequires:  udev-devel >= 1:143
85 # wayland-client
86 %{?with_wayland:BuildRequires:  wayland-devel >= 1.3.0}
87 BuildRequires:  xcb-util-devel
88 BuildRequires:  xcb-util-image-devel
89 BuildRequires:  xcb-util-keysyms-devel
90 BuildRequires:  xcb-util-renderutil-devel
91 BuildRequires:  xcb-util-wm-devel
92 BuildRequires:  xmlto >= 0.0.20
93 BuildRequires:  xorg-app-mkfontscale
94 BuildRequires:  xorg-lib-libX11-devel >= 1.6
95 BuildRequires:  xorg-lib-libXau-devel
96 %{?with_dmx:BuildRequires:      xorg-lib-libXaw-devel}
97 BuildRequires:  xorg-lib-libXdamage-devel
98 BuildRequires:  xorg-lib-libXdmcp-devel
99 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
100 BuildRequires:  xorg-lib-libXfixes-devel
101 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
102 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
103 %{?with_dmx:BuildRequires:      xorg-lib-libXmu-devel}
104 %{?with_dmx:BuildRequires:      xorg-lib-libXpm-devel}
105 BuildRequires:  xorg-lib-libXrender-devel
106 BuildRequires:  xorg-lib-libXres-devel
107 %{?with_dmx:BuildRequires:      xorg-lib-libXt-devel >= 1.0.0}
108 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
109 BuildRequires:  xorg-lib-libXv-devel
110 BuildRequires:  xorg-lib-libXxf86dga-devel
111 BuildRequires:  xorg-lib-libXxf86misc-devel
112 BuildRequires:  xorg-lib-libXxf86vm-devel
113 %{?with_dmx:BuildRequires:      xorg-lib-libdmx-devel >= 1.0.99.1}
114 BuildRequires:  xorg-lib-libfontenc-devel
115 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.12.901
116 BuildRequires:  xorg-lib-libxkbfile-devel
117 BuildRequires:  xorg-lib-libxshmfence-devel >= 1.1
118 BuildRequires:  xorg-lib-xtrans-devel >= 1.3.5
119 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
120 BuildRequires:  xorg-proto-compositeproto-devel >= 0.4
121 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
122 %{?with_dmx:BuildRequires:      xorg-proto-dmxproto-devel >= 2.2.99.1}
123 %{?with_dri2:BuildRequires:     xorg-proto-dri2proto-devel >= 2.8}
124 BuildRequires:  xorg-proto-dri3proto-devel >= 1.0
125 BuildRequires:  xorg-proto-fixesproto-devel >= 5.0
126 BuildRequires:  xorg-proto-fontcacheproto-devel
127 BuildRequires:  xorg-proto-fontsproto-devel >= 2.1.3
128 BuildRequires:  xorg-proto-glproto-devel >= 1.4.17
129 BuildRequires:  xorg-proto-inputproto-devel >= 2.3
130 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
131 BuildRequires:  xorg-proto-presentproto-devel >= 1.0
132 BuildRequires:  xorg-proto-printproto-devel
133 BuildRequires:  xorg-proto-randrproto-devel >= 1.4.0
134 %{?with_record:BuildRequires:   xorg-proto-recordproto-devel >= 1.13.99.1}
135 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
136 BuildRequires:  xorg-proto-resourceproto-devel >= 1.2.0
137 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1
138 BuildRequires:  xorg-proto-videoproto-devel
139 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
140 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.3.0
141 %{?with_xf86bigfont:BuildRequires:      xorg-proto-xf86bigfontproto-devel >= 1.2.0}
142 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
143 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
144 BuildRequires:  xorg-proto-xf86miscproto-devel
145 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
146 BuildRequires:  xorg-proto-xineramaproto-devel
147 BuildRequires:  xorg-proto-xproto-devel >= 7.0.26
148 BuildRequires:  xorg-sgml-doctools >= 1.8
149 BuildRequires:  xorg-util-util-macros >= 1.14
150 #BR: tslib (for KDRIVE only)
151 Requires(triggerpostun):        sed >= 4.0
152 %{?with_glamor:Requires:        Mesa-libgbm >= 10.2.0}
153 Requires:       libdrm >= 2.4.46
154 Requires:       pixman >= %{pixman_ver}
155 Requires:       udev-libs >= 1:143
156 Requires:       xkeyboard-config
157 # for rgb.txt
158 Requires:       xorg-app-rgb >= 0.99.3
159 Requires:       xorg-app-xkbcomp
160 Requires:       xorg-lib-libXfont >= 1.4.2
161 Requires:       xorg-lib-libpciaccess >= 0.12.901
162 Requires:       xorg-lib-libxshmfence >= 1.1
163 Suggests:       dbus-x11 >= 1.0
164 %{?with_hal:Suggests:   hal}
165 Suggests:       udev-acl >= 1:143
166 %{?with_udev:Suggests:  udev-core >= 1:143}
167 Suggests:       xkeyboard-config
168 Suggests:       xorg-driver-input-evdev
169 # Usual desktop setups need least one video driver to run, see xorg.log which one exactly
170 Suggests:       xorg-driver-video
171 Provides:       xorg-xserver-libdri = %{version}-%{release}
172 Provides:       xorg-xserver-module(dri)
173 Provides:       xorg-xserver-server(ansic-abi) = %{xorg_xserver_server_ansic_abi}
174 Provides:       xorg-xserver-server(extension-abi) = %{xorg_xserver_server_extension_abi}
175 Provides:       xorg-xserver-server(font-abi) = %{xorg_xserver_server_font_abi}
176 Provides:       xorg-xserver-server(videodrv-abi) = %{xorg_xserver_server_videodrv_abi}
177 Provides:       xorg-xserver-server(xinput-abi) = %{xorg_xserver_server_xinput_abi}
178 Obsoletes:      X11-Xserver < 1:7.0.0
179 Obsoletes:      X11-driver-i2c < 1:7.0.0
180 Obsoletes:      X11-modules < 1:7.0.0
181 Obsoletes:      X11-setup < 1:7.0.0
182 Obsoletes:      XFree86-Xserver < 1:7.0.0
183 Obsoletes:      XFree86-modules < 1:7.0.0
184 Obsoletes:      XFree86-setup < 1:7.0.0
185 Obsoletes:      Xserver
186 %{?with_glamor:Obsoletes:       glamor}
187 Obsoletes:      xorg-xserver-libdri
188 Obsoletes:      xorg-xserver-server-xorgcfg
189 Obsoletes:      xorg-driver-video-modesetting
190 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
191
192 # avoid self-dependencies on included modules
193 %define         _noautoreq      libscanpci.so libxf1bpp.so
194
195 %description
196 Xorg server is a generally used X server which uses display hardware.
197 It requires proper driver for your display hardware.
198
199 %description -l pl.UTF-8
200 Serwer Xorg to podstawowy serwer X wyświetlający obraz na karcie
201 graficznej. Do działania wymaga odpowiedniego sterownika.
202
203 %package -n xorg-xserver-Xdmx
204 Summary:        Xdmx - distributed multi-head X server
205 Summary(pl.UTF-8):      Xdmx - rozproszony, wielomonitorowy serwer X
206 Group:          X11/Servers
207 Requires:       pixman >= %{pixman_ver}
208 Requires:       xorg-lib-libX11 >= 1.6
209 Requires:       xorg-lib-libXext >= 1.0.99.4
210 Requires:       xorg-lib-libXfont >= 1.4.2
211 Requires:       xorg-lib-libXi >= 1.2.99.1
212 Requires:       xorg-lib-libdmx >= 1.0.99.1
213
214 %description -n xorg-xserver-Xdmx
215 Xdmx - distributed multi-head X server.
216
217 %description -n xorg-xserver-Xdmx -l pl.UTF-8
218 Xdmx - rozproszony, wielomonitorowy serwer X.
219
220 %package -n xorg-xserver-Xnest
221 Summary:        Xnest - nested X server
222 Summary(pl.UTF-8):      Xnest - zagnieżdżony serwer X
223 Group:          X11/Servers
224 Requires:       pixman >= %{pixman_ver}
225 Requires:       xorg-lib-libXext >= 1.0.99.4
226 Requires:       xorg-lib-libXfont >= 1.4.2
227 Obsoletes:      X11-Xnest < 1:7.0.0
228 Obsoletes:      XFree86-Xnest < 1:7.0.0
229 Obsoletes:      Xserver-Xnest
230
231 %description -n xorg-xserver-Xnest
232 Xnest is an X Window System server which runs in an X window. Xnest is
233 a 'nested' window server, actually a client of the real X server,
234 which manages windows and graphics requests for Xnest, while Xnest
235 manages the windows and graphics requests for its own clients.
236
237 %description -n xorg-xserver-Xnest -l pl.UTF-8
238 Xnest jest serwerem X uruchamianym w okienku innego serwera X. Xnest
239 zachowuje się jak klient X w stosunku do prawdziwego serwera X, a jak
240 serwer X dla własnych klientów.
241
242 %description -n xorg-xserver-Xnest -l ru.UTF-8
243 Xnest - это сервер X Window System, который работает в окне X. На
244 самом деле это клиент реального X-сервера, который управляет окнами и
245 графическими запросами для Xnest в то время, как Xnest управляет
246 окнами и графическими запросами для своих собственных клиентов.
247
248 %description -n xorg-xserver-Xnest -l uk.UTF-8
249 Xnest - це сервер X Window System, який працює у вікні X. Фактично це
250 клієнт реального X-сервера, який керує вікнами та графічними запитами
251 для Xnest в той час, як Xnest керує вікнами та графічними запитами для
252 своїх власних клієнтів.
253
254 %package -n xorg-xserver-Xephyr
255 Summary:        Xephyr - nested X server
256 Summary(pl.UTF-8):      Xephyr - zagnieżdżony serwer X
257 Group:          X11/Servers
258 Requires:       Mesa-libGL >= 7.1.0
259 Requires:       libxcb >= 1.6
260 Requires:       pixman >= %{pixman_ver}
261 Requires:       xorg-lib-libXfont >= 1.4.2
262
263 %description -n xorg-xserver-Xephyr
264 Xephyr is a kdrive server that outputs to a window on a pre-existing
265 'host' X display. Think Xnest but with support for modern extensions
266 like composite, damage and randr.
267
268 Unlike Xnest which is an X proxy, i.e. limited to the capabilities of
269 the host X server, Xephyr is a real X server which uses the host X
270 server window as "framebuffer" via fast SHM XImages.
271
272 It also has support for 'visually' debugging what the server is
273 painting.
274
275 %description -n xorg-xserver-Xephyr -l pl.UTF-8
276 Xephyr jest serwerem opartym na kdrive wyświetlającym w oknie na
277 istniejącym ekranie X. Można o nim myśleć jako o Xnest ze wsparciem do
278 wspólczesnych rozszerzeń jak composite, damage i randr.
279
280 %package -n xorg-xserver-Xfbdev
281 Summary:        Xfbdev - Linux framebuffer device X server
282 Summary(pl.UTF-8):      Xfbdev - serwer X dla framebuffera
283 Group:          X11/Servers
284 Requires:       pixman >= %{pixman_ver}
285 Requires:       xorg-lib-libXfont >= 1.4.2
286
287 %description -n xorg-xserver-Xfbdev
288 Xfbdev is a Linux framebuffer device X server based on the kdrive X
289 server.
290
291 %description -n xorg-xserver-Xfbdev -l pl.UTF-8
292 Xfbdev jest serwerem X dla framebuffera opartym na kdrive.
293
294 %package -n xorg-xserver-Xvfb
295 Summary:        Xvfb - virtual framebuffer X server
296 Summary(pl.UTF-8):      Xvfb - serwer X z wirtualnym framebufferem
297 Group:          X11/Servers
298 Requires:       Mesa-libGL >= 7.1.0
299 Requires:       mktemp
300 Requires:       pixman >= %{pixman_ver}
301 Requires:       util-linux
302 Requires:       which
303 Requires:       xkeyboard-config
304 Requires:       xorg-app-xauth
305 Requires:       xorg-app-xkbcomp
306 Requires:       xorg-lib-libXfont >= 1.4.2
307 Obsoletes:      X11-Xvfb < 1:7.0.0
308 Obsoletes:      XFree86-Xvfb < 1:7.0.0
309
310 %description -n xorg-xserver-Xvfb
311 Xvfb (X Virtual Frame Buffer) is an X Window System server that is
312 capable of running on machines with no display hardware and no
313 physical input devices. Xvfb emulates a dumb framebuffer using virtual
314 memory. Xvfb doesn't open any devices, but behaves otherwise as an X
315 display. Xvfb is normally used for testing servers. Using Xvfb, the
316 mfb or cfb code for any depth can be exercised without using real
317 hardware that supports the desired depths. Xvfb has also been used to
318 test X clients against unusual depths and screen configurations, to do
319 batch processing with Xvfb as a background rendering engine, to do
320 load testing, to help with porting an X server to a new platform, and
321 to provide an unobtrusive way of running applications which really
322 don't need an X server but insist on having one.
323
324 %description -n xorg-xserver-Xvfb -l pl.UTF-8
325 Xvfb (X Virtual Frame Buffer) jest serwerem X, który można uruchamiać
326 na maszynach bez urządzeń wyświetlających ani fizycznych urządzeń
327 wejściowych. Xvfb emuluje prosty framebuffer w pamięci. Zwykle jest
328 używany do testowania serwerów X, może też być używany do testowania
329 klientów X w rzadko używanych konfiguracjach ekranu. Można też użyć
330 Xvfb do uruchomienia aplikacji, które w rzeczywistości nie wymagają
331 serwera X, ale odmawiają uruchomienia bez niego.
332
333 %package -n xorg-xserver-Xvfb-init
334 Summary:        Init scripts for Xvfb
335 Summary(pl.UTF-8):      Skrypty startowe dla Xvfb
336 Group:          X11/Servers
337 Requires:       xorg-xserver-Xvfb
338
339 %description -n xorg-xserver-Xvfb-init
340 This package contains init scripts for Xvfb and registers Xvfb as
341 system service.
342
343 %description -n xorg-xserver-Xvfb-init -l pl.UTF-8
344 Ten pakiet zawiera skrypty startowe dla Xvfb oraz rejestruje Xvfb jako
345 usługę systemową.
346
347 %package -n xorg-xserver-Xwayland
348 Summary:        Xwayland - X server integrated into a Wayland window system
349 Summary(pl.UTF-8):      Xwayland - serwer X integrowalny w Wayland
350 Group:          X11/Servers
351 Requires:       pixman >= %{pixman_ver}
352 Requires:       xorg-lib-libX11 >= 1.6
353 Requires:       xorg-lib-libXext >= 1.0.99.4
354 Requires:       xorg-lib-libXfont >= 1.4.2
355 Requires:       xorg-lib-libXi >= 1.2.99.1
356
357 %description -n xorg-xserver-Xwayland
358 Xwayland - server integrated into a Wayland window system.
359
360 %description -n xorg-xserver-Xwayland -l pl.UTF-8
361 Xwayland - serwer X integrowalny w Wayland.
362
363 %package devel
364 Summary:        Header files for X.org server
365 Summary(pl.UTF-8):      Pliki nagłówkowe dla serwera X.org
366 Group:          X11/Development/Libraries
367 Requires:       Mesa-libGL-devel >= 7.8.0
368 Requires:       libdrm-devel >= 2.4.46
369 Requires:       pixman-devel >= %{pixman_ver}
370 Requires:       xorg-lib-libXfont-devel
371 Requires:       xorg-lib-libpciaccess-devel >= 0.12.901
372 Requires:       xorg-lib-libxkbfile-devel
373 %{?with_dri2:Requires:  xorg-proto-dri2proto-devel >= 2.8}
374 Requires:       xorg-proto-dri3proto-devel >= 1.0
375 Requires:       xorg-proto-fontsproto-devel >= 2.1.3
376 Requires:       xorg-proto-glproto-devel >= 1.4.17
377 Requires:       xorg-proto-inputproto-devel >= 2.3
378 Requires:       xorg-proto-kbproto-devel >= 1.0.3
379 Requires:       xorg-proto-presentproto-devel >= 1.0
380 Requires:       xorg-proto-randrproto-devel >= 1.4.0
381 Requires:       xorg-proto-renderproto-devel >= 0.11
382 Requires:       xorg-proto-resourceproto-devel >= 1.2.0
383 Requires:       xorg-proto-scrnsaverproto-devel >= 1.1
384 Requires:       xorg-proto-videoproto-devel
385 Requires:       xorg-proto-xextproto-devel >= 1:7.3.0
386 Requires:       xorg-proto-xf86driproto-devel >= 2.1.0
387 Requires:       xorg-proto-xineramaproto-devel
388 Requires:       xorg-proto-xproto-devel >= 7.0.26
389 Obsoletes:      X11-Xserver-devel < 1:7.0.0
390 Obsoletes:      XFree86-Xserver-devel < 1:7.0.0
391 %{?with_glamor:Obsoletes:       glamor-devel}
392
393 %description devel
394 Header files for X.org server.
395
396 %description devel -l pl.UTF-8
397 Pliki nagłówkowe dla serwera X.org.
398
399 %package source
400 Summary:        X.org server source code
401 Summary(pl.UTF-8):      Pliki źródłowe dla serwera X.org
402 Group:          X11/Development/Libraries
403
404 %description source
405 X.org server source code.
406
407 %description source -l pl.UTF-8
408 Pliki źródłowe dla serwera X.org.
409
410 %package -n xorg-xserver-libglx
411 Summary:        GLX extension library for X.org server
412 Summary(pl.UTF-8):      Biblioteka rozszerzenia GLX dla serwera X.org
413 Group:          X11/Servers
414 Requires:       %{name} = %{version}-%{release}
415 Requires:       Mesa-libGL >= 7.1.0
416 %{?with_dri2:Requires:  Mesa-libGL >= 9.2.0}
417 # Mesa version glapi tables in glx/ dir come from
418 Provides:       xorg-xserver-libglx(glapi) = 7.1.0
419 Provides:       xorg-xserver-module(glx)
420 Obsoletes:      X11-OpenGL-core < 1:7.0.0
421 Obsoletes:      XFree86-OpenGL-core < 1:7.0.0
422
423 %description -n xorg-xserver-libglx
424 GLX extension library for X.org server.
425
426 %description -n xorg-xserver-libglx -l pl.UTF-8
427 Biblioteka rozszerzenia GLX dla serwera X.org.
428
429 %prep
430 %setup -q -n xorg-server-%{version}
431
432 %patch2 -p1
433
434 %patch4 -p1
435
436 %patch6 -p1
437 %patch7 -p1
438
439 # xserver uses pixman-1 API/ABI so put that explictly here
440 sed -i -e 's#<pixman\.h#<pixman-1/pixman.h#g' ./fb/fb.h ./include/miscstruct.h ./render/picture.h
441
442 # support __filemansuffix__ with "x" suffix (per FHS 2.3)
443 %{__sed} -i -e 's,\.so man__filemansuffix__/,.so man5/,' hw/xfree86/man/*.man
444
445 %build
446 API=$(awk '/#define ABI_ANSIC_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
447 if [ $API != %{xorg_xserver_server_ansic_abi} ]; then
448         echo "Set %%define xorg_xserver_server_ansic_abi to $API and rerun."
449         exit 1
450 fi
451
452 API=$(awk '/#define ABI_EXTENSION_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
453 if [ $API != %{xorg_xserver_server_extension_abi} ]; then
454         echo "Set %%define xorg_xserver_server_extension_abi to $API and rerun."
455         exit 1
456 fi
457
458 API=$(awk '/#define ABI_FONT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
459 if [ $API != %{xorg_xserver_server_font_abi} ]; then
460         echo "Set %%define xorg_xserver_server_font_abi to $API and rerun."
461         exit 1
462 fi
463 API=$(awk '/#define ABI_VIDEODRV_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
464 if [ $API != %{xorg_xserver_server_videodrv_abi} ]; then
465         echo "Set %%define xorg_xserver_server_videodrv_abi to $API and rerun."
466         exit 1
467 fi
468 API=$(awk '/#define ABI_XINPUT_VERSION/ { split($0,A,/[(,)]/); printf("%d.%d",A[2], A[3]); }' hw/xfree86/common/xf86Module.h)
469 if [ $API != %{xorg_xserver_server_xinput_abi} ]; then
470         echo "Set %%define xorg_xserver_server_xinput_abi to $API and rerun."
471         exit 1
472 fi
473
474 %{__libtoolize}
475 %{__aclocal} -I m4
476 %{__autoconf}
477 %{__autoheader}
478 %{__automake}
479 %configure \
480         --libexecdir=%{_libdir}/xorg \
481         --with-os-name="PLD/Linux" \
482         --with-os-vendor="PLD/Team" \
483         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
484         --with-xkb-output=/var/lib/xkb \
485         --disable-linux-acpi \
486         --disable-linux-apm \
487         --enable-aiglx \
488         %{?with_dbus:--enable-config-dbus} \
489         --enable-config-hal%{!?with_hal:=no} \
490         --enable-config-udev%{!?with_udev:=no} \
491         --enable-dga \
492         %{?with_dmx:--enable-dmx} \
493         --enable-dri2%{!?with_dri2:=no} \
494         %{?with_glamor:--enable-glamor} \
495         --enable-kdrive \
496         %{?with_libunwind:--enable-libunwind} \
497         %{?with_record:--enable-record} \
498         --enable-secure-rpc \
499         %{?with_xcsecurity:--enable-xcsecurity} \
500         --enable-xephyr \
501         %{?with_xf86bigfont:--enable-xf86bigfont} \
502         --disable-xfake \
503         --enable-xfbdev \
504         %{?with_xselinux:--enable-xselinux} \
505         %{?with_wayland:--enable-xwayland} \
506         %{!?with_systemtap:--without-dtrace} \
507         --without-fop \
508         --enable-suid-wrapper \
509         --with-systemd-daemon
510
511 %{__make} -j1
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515
516 %if "%{_libdir}" != "%{_exec_prefix}/lib"
517 install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/xorg/modules/dri
518 %endif
519
520 %{__make} install \
521         DESTDIR=$RPM_BUILD_ROOT
522
523 install -Dp %{SOURCE2} $RPM_BUILD_ROOT/etc/pam.d/xserver
524 install -d $RPM_BUILD_ROOT/etc/{security/console.apps,X11/xorg.conf.d}
525 install -d $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{dri,drivers,input}
526 install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
527 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/xvfb-run
528
529 :> $RPM_BUILD_ROOT/etc/security/console.apps/xserver
530 :> $RPM_BUILD_ROOT/etc/security/blacklist.xserver
531
532 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{*,*/*}.la
533
534 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/10-quirks.conf
535
536 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
537 install -d $RPM_BUILD_ROOT/etc/sysconfig
538 install -p %{SOURCE10} $RPM_BUILD_ROOT/etc/rc.d/init.d/Xvfb
539 cp -p %{SOURCE11} $RPM_BUILD_ROOT/etc/sysconfig/Xvfb
540
541 # compatibility with old xwrapper
542 ln -s %{_libdir}/xorg/Xorg.wrap $RPM_BUILD_ROOT%{_bindir}/Xwrapper
543
544 # prepare source package
545 install -d $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
546 cp -a * $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
547 cd $RPM_BUILD_ROOT%{_usrsrc}/%{name}-%{version}
548 %{__make} distclean
549 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
550 find -name '*.h' | xargs chmod a-x
551
552 %if %{with systemtap}
553 %{__rm} $RPM_BUILD_ROOT%{_docdir}/xorg-server/Xserver-DTrace.*
554 %endif
555
556 %clean
557 rm -rf $RPM_BUILD_ROOT
558
559 %triggerpostun -- xorg-xserver-server < 1.5.0
560 if [ -f /etc/X11/xorg.conf ]; then
561         sed -i -e 's/^\s*RgbPath.*$/#& # obsolete option/' /etc/X11/xorg.conf
562         sed -i -e 's/^\s*Load\s*"type1".*$/#& # obsolete module/' /etc/X11/xorg.conf
563 %if %{without record}
564         sed -i -e 's/^\s*Load\s*"record".*$/#& # module disabled in this build/' /etc/X11/xorg.conf
565 %endif
566         sed -i -e 's/^\s*Load\s*"xtrap".*$/#& # obsolete module/' /etc/X11/xorg.conf
567 fi
568
569 %post -n xorg-xserver-Xvfb-init
570 /sbin/chkconfig --add Xvfb
571 %service Xvfb restart
572
573 %preun -n xorg-xserver-Xvfb-init
574 if [ "$1" = "0" ]; then
575         %service -q Xvfb stop
576         /sbin/chkconfig --del Xvfb
577 fi
578
579 %files
580 %defattr(644,root,root,755)
581 %doc COPYING ChangeLog README
582 %attr(755,root,root) %{_bindir}/X
583 %attr(755,root,root) %{_bindir}/Xorg
584 %attr(4755,root,root) %{_bindir}/Xwrapper
585 %attr(755,root,root) %{_bindir}/cvt
586 %attr(755,root,root) %{_bindir}/gtf
587 %dir %{_libdir}/xorg
588 %{_libdir}/xorg/protocol.txt
589 %attr(755,root,root) %{_libdir}/xorg/Xorg
590 %attr(4755,root,root) %{_libdir}/xorg/Xorg.wrap
591 %dir %{_libdir}/xorg/modules
592 %attr(755,root,root) %{_libdir}/xorg/modules/libexa.so
593 %attr(755,root,root) %{_libdir}/xorg/modules/libfb.so
594 %attr(755,root,root) %{_libdir}/xorg/modules/libfbdevhw.so
595 %{?with_glamor:%attr(755,root,root) %{_libdir}/xorg/modules/libglamoregl.so}
596 %attr(755,root,root) %{_libdir}/xorg/modules/libint10.so
597 %attr(755,root,root) %{_libdir}/xorg/modules/libshadow.so
598 %attr(755,root,root) %{_libdir}/xorg/modules/libshadowfb.so
599 %attr(755,root,root) %{_libdir}/xorg/modules/libvbe.so
600 %attr(755,root,root) %{_libdir}/xorg/modules/libvgahw.so
601 %attr(755,root,root) %{_libdir}/xorg/modules/libwfb.so
602 %dir %{_libdir}/xorg/modules/dri
603 %dir %{_libdir}/xorg/modules/drivers
604 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/modesetting_drv.so
605 %dir %{_libdir}/xorg/modules/extensions
606 %dir %{_libdir}/xorg/modules/input
607 %if "%{_libdir}" != "%{_exec_prefix}/lib"
608 %dir %{_exec_prefix}/lib/xorg
609 %dir %{_exec_prefix}/lib/xorg/modules
610 %dir %{_exec_prefix}/lib/xorg/modules/dri
611 %endif
612 %dir /var/lib/xkb
613 /var/lib/xkb/README.compiled
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/xserver
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.xserver
616 %config(missingok) /etc/security/console.apps/xserver
617 %{?with_dbus:/etc/dbus-1/system.d/xorg-server.conf}
618 %dir /etc/X11/xorg.conf.d
619 %dir %{_datadir}/X11/xorg.conf.d
620 # overwrite these settings with local configs in /etc/X11/xorg.conf.d
621 %verify(not md5 mtime size) %{_datadir}/X11/xorg.conf.d/10-quirks.conf
622 %{_mandir}/man1/Xorg.1*
623 %{_mandir}/man1/Xorg.wrap.1*
624 %{_mandir}/man1/Xserver.1*
625 %{_mandir}/man1/cvt.1*
626 %{_mandir}/man1/gtf.1*
627 %{_mandir}/man4/exa.4*
628 %{_mandir}/man4/fbdevhw.4*
629 %{_mandir}/man4/modesetting.4*
630 %{_mandir}/man5/Xwrapper.config.5*
631 %{_mandir}/man5/xorg.conf.5*
632 %{_mandir}/man5/xorg.conf.d.5*
633
634 %if %{with dmx}
635 %files -n xorg-xserver-Xdmx
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/Xdmx
638 %attr(755,root,root) %{_bindir}/dmxaddinput
639 %attr(755,root,root) %{_bindir}/dmxaddscreen
640 %attr(755,root,root) %{_bindir}/dmxinfo
641 %attr(755,root,root) %{_bindir}/dmxreconfig
642 %attr(755,root,root) %{_bindir}/dmxresize
643 %attr(755,root,root) %{_bindir}/dmxrminput
644 %attr(755,root,root) %{_bindir}/dmxrmscreen
645 %attr(755,root,root) %{_bindir}/dmxtodmx
646 %attr(755,root,root) %{_bindir}/dmxwininfo
647 %attr(755,root,root) %{_bindir}/vdltodmx
648 %attr(755,root,root) %{_bindir}/xdmxconfig
649 %{_mandir}/man1/Xdmx.1*
650 %{_mandir}/man1/dmxtodmx.1*
651 %{_mandir}/man1/vdltodmx.1*
652 %{_mandir}/man1/xdmxconfig.1*
653 %endif
654
655 %files -n xorg-xserver-Xnest
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_bindir}/Xnest
658 %{_mandir}/man1/Xnest.1*
659
660 %files -n xorg-xserver-Xephyr
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_bindir}/Xephyr
663 %{_mandir}/man1/Xephyr.1*
664
665 %files -n xorg-xserver-Xfbdev
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_bindir}/Xfbdev
668
669 %files -n xorg-xserver-Xvfb
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_bindir}/Xvfb
672 %attr(755,root,root) %{_bindir}/xvfb-run
673 %{_mandir}/man1/Xvfb.1*
674
675 %files -n xorg-xserver-Xvfb-init
676 %defattr(644,root,root,755)
677 %attr(754,root,root) /etc/rc.d/init.d/Xvfb
678 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/Xvfb
679
680 %if %{with wayland}
681 %files -n xorg-xserver-Xwayland
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_bindir}/Xwayland
684 %endif
685
686 %files devel
687 %defattr(644,root,root,755)
688 %doc doc/{Xinput,Xserver-spec}.html %{?with_systemtap:doc/dtrace/Xserver-DTrace.html}
689 %{_includedir}/xorg
690 %{_aclocaldir}/xorg-server.m4
691 %{_pkgconfigdir}/xorg-server.pc
692
693 %files source
694 %defattr(644,root,root,755)
695 # keep file perms from install time, but have default defattr to keep adapter happy
696 %defattr(-,root,root,755)
697 %{_usrsrc}/%{name}-%{version}
698
699 %files -n xorg-xserver-libglx
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libglx.so
This page took 0.398714 seconds and 2 git commands to generate.