]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- proper xserver version wrt. sna bcond
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     sna     SandyBridge's New Acceleration (also for older generations)
4 #
5 %define libdrm_ver      2.4.31
6 %if %{with sna}
7 %define xserver_ver     1.10
8 %else
9 %define xserver_ver     1.6.3
10 %endif
11 Summary:        X.org video driver for Intel integrated graphics chipsets
12 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
13 Name:           xorg-driver-video-intel
14 Version:        2.19.0
15 Release:        1
16 License:        MIT
17 Group:          X11/Applications
18 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
19 # Source0-md5:  f397bddfc88d4c9b30b56526c1e02e8e
20 URL:            http://xorg.freedesktop.org/
21 BuildRequires:  Mesa-libGL-devel
22 #BuildRequires: autoconf >= 2.63
23 #BuildRequires: automake >= 1:1.10.2-2
24 BuildRequires:  libdrm-devel >= %{libdrm_ver}
25 #BuildRequires: libtool >= 2:2.2
26 BuildRequires:  libxcb-devel >= 1.5
27 BuildRequires:  pixman-devel >= 0.24.0
28 BuildRequires:  pkgconfig >= 1:0.19
29 BuildRequires:  rpmbuild(macros) >= 1.389
30 BuildRequires:  udev-devel
31 BuildRequires:  xcb-util-devel
32 BuildRequires:  xorg-lib-libXfixes-devel
33 BuildRequires:  xorg-lib-libXvMC-devel
34 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
35 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
36 BuildRequires:  xorg-proto-fontsproto-devel
37 BuildRequires:  xorg-proto-glproto-devel
38 BuildRequires:  xorg-proto-randrproto-devel
39 BuildRequires:  xorg-proto-renderproto-devel
40 BuildRequires:  xorg-proto-videoproto-devel
41 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
42 BuildRequires:  xorg-proto-xf86driproto-devel
43 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
44 BuildRequires:  xorg-util-util-macros >= 1.8
45 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
46 %{?requires_xorg_xserver_videodrv}
47 Requires:       libdrm >= %{libdrm_ver}
48 Requires:       xorg-lib-libpciaccess >= 0.10
49 Requires:       xorg-xserver-libdri >= %{xserver_ver}
50 Requires:       xorg-xserver-libglx >= %{xserver_ver}
51 Requires:       xorg-xserver-server >= %{xserver_ver}
52 Provides:       xorg-driver-video
53 Provides:       xorg-driver-video-i810
54 Obsoletes:      X11-driver-i810 < 1:7.0.0
55 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
56 Obsoletes:      XFree86-i810
57 Obsoletes:      xorg-driver-video-i810 < 1.7.2
58 Conflicts:      vbetool
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 X.org video driver for Intel integrated graphics chipsets. It
63 supports:
64 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
65   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
66   Q35, GM45, G45, Q45, G43, G41 chipsets,
67 - Pineview-M in Atom N400 series,
68 - Pineview-D in Atom D400/D500 series.
69
70 Requires Kernel Mode Setting (KMS) to be active.
71
72 %description -l pl.UTF-8
73 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
74 Obsługuje:
75 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
76   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
77   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
78 - Pineview-M w procesorach Atom z serii N400,
79 - Pineview-D w procesorach Atom z serii D400/D500.
80
81 Wymaga aktywnego Kernel Mode Setting (KMS).
82
83 %prep
84 %setup -q -n xf86-video-intel-%{version}
85
86 %build
87 %configure \
88         --disable-silent-rules \
89         --enable-sna%{!?with_sna:=no}
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
100         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING ChangeLog NEWS README
111 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
113 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
115 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
116 %{_mandir}/man4/intel.4*
This page took 0.055582 seconds and 4 git commands to generate.