]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- up to 2.20.4
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 # NOTE: pixman >= 0.27.1 for glyph cache (enable after stable pixman release)
2 #
3 # Conditional build:
4 %bcond_with     glamor  Glamor acceleration
5 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
6 #
7 %define libdrm_ver      2.4.38
8 %if %{with sna}
9 %define xserver_ver     1.10
10 %else
11 %define xserver_ver     1.6.3
12 %endif
13 Summary:        X.org video driver for Intel integrated graphics chipsets
14 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
15 Name:           xorg-driver-video-intel
16 Version:        2.20.4
17 Release:        1
18 License:        MIT
19 Group:          X11/Applications
20 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
21 # Source0-md5:  d22ad2071e5f5ff2e34663c0f199207a
22 URL:            http://xorg.freedesktop.org/
23 BuildRequires:  Mesa-libGL-devel
24 #BuildRequires: autoconf >= 2.63
25 #BuildRequires: automake >= 1:1.10.2-2
26 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
27 BuildRequires:  libdrm-devel >= %{libdrm_ver}
28 #BuildRequires: libtool >= 2:2.2
29 BuildRequires:  libxcb-devel >= 1.5
30 BuildRequires:  pixman-devel >= 0.24.0
31 BuildRequires:  pkgconfig >= 1:0.19
32 BuildRequires:  rpmbuild(macros) >= 1.389
33 BuildRequires:  udev-devel
34 BuildRequires:  xcb-util-devel
35 BuildRequires:  xorg-lib-libXfixes-devel
36 BuildRequires:  xorg-lib-libXvMC-devel
37 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
38 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
39 BuildRequires:  xorg-proto-fontsproto-devel
40 BuildRequires:  xorg-proto-glproto-devel
41 BuildRequires:  xorg-proto-randrproto-devel
42 BuildRequires:  xorg-proto-renderproto-devel
43 BuildRequires:  xorg-proto-videoproto-devel
44 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
45 BuildRequires:  xorg-proto-xf86driproto-devel
46 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
47 BuildRequires:  xorg-util-util-macros >= 1.8
48 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
49 %{?requires_xorg_xserver_videodrv}
50 %{?with_glamor:Requires:        glamor >= 0.3.1}
51 Requires:       libdrm >= %{libdrm_ver}
52 Requires:       xorg-lib-libpciaccess >= 0.10
53 Requires:       xorg-xserver-libdri >= %{xserver_ver}
54 Requires:       xorg-xserver-libglx >= %{xserver_ver}
55 Requires:       xorg-xserver-server >= %{xserver_ver}
56 Provides:       xorg-driver-video
57 Provides:       xorg-driver-video-i810
58 Obsoletes:      X11-driver-i810 < 1:7.0.0
59 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
60 Obsoletes:      XFree86-i810
61 Obsoletes:      xorg-driver-video-i810 < 1.7.2
62 Conflicts:      vbetool
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 X.org video driver for Intel integrated graphics chipsets. It
67 supports:
68 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
69   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
70   Q35, GM45, G45, Q45, G43, G41 chipsets,
71 - Pineview-M in Atom N400 series,
72 - Pineview-D in Atom D400/D500 series.
73
74 Requires Kernel Mode Setting (KMS) to be active.
75
76 %description -l pl.UTF-8
77 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
78 Obsługuje:
79 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
80   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
81   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
82 - Pineview-M w procesorach Atom z serii N400,
83 - Pineview-D w procesorach Atom z serii D400/D500.
84
85 Wymaga aktywnego Kernel Mode Setting (KMS).
86
87 %prep
88 %setup -q -n xf86-video-intel-%{version}
89
90 %build
91 %configure \
92         --disable-silent-rules \
93         %{?with_glamor:--enable-glamor} \
94         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
95         --enable-uxa \
96         --enable-sna%{!?with_sna:=no}
97
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
107         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS COPYING ChangeLog NEWS README
118 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
120 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
122 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
123 %{_mandir}/man4/intel.4*
This page took 0.145854 seconds and 4 git commands to generate.