]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- up to 2.20.12
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 # NOTE: pixman >= 0.27.1 for glyph cache (enable after stable pixman release)
2 #
3 # Conditional build:
4 %bcond_with     glamor  Glamor acceleration
5 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
6 #
7 %define libdrm_ver      2.4.39
8 %if %{with sna}
9 %define xserver_ver     1.10
10 %else
11 %define xserver_ver     1.6.3
12 %endif
13 Summary:        X.org video driver for Intel integrated graphics chipsets
14 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
15 Name:           xorg-driver-video-intel
16 Version:        2.20.12
17 Release:        1
18 License:        MIT
19 Group:          X11/Applications
20 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
21 # Source0-md5:  6d9565de03c167d8f621315476c20c73
22 URL:            http://xorg.freedesktop.org/
23 BuildRequires:  Mesa-libGL-devel
24 #BuildRequires: autoconf >= 2.63
25 #BuildRequires: automake >= 1:1.10.2-2
26 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
27 BuildRequires:  libdrm-devel >= %{libdrm_ver}
28 #BuildRequires: libtool >= 2:2.2
29 BuildRequires:  libxcb-devel >= 1.5
30 BuildRequires:  pixman-devel >= 0.24.0
31 BuildRequires:  pkgconfig >= 1:0.19
32 BuildRequires:  rpmbuild(macros) >= 1.389
33 BuildRequires:  udev-devel
34 BuildRequires:  xcb-util-devel
35 BuildRequires:  xorg-lib-libX11-devel
36 BuildRequires:  xorg-lib-libXfixes-devel
37 BuildRequires:  xorg-lib-libXrender-devel
38 BuildRequires:  xorg-lib-libXvMC-devel
39 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
40 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
41 BuildRequires:  xorg-proto-fontsproto-devel
42 BuildRequires:  xorg-proto-glproto-devel
43 BuildRequires:  xorg-proto-randrproto-devel
44 BuildRequires:  xorg-proto-renderproto-devel
45 BuildRequires:  xorg-proto-videoproto-devel
46 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
47 BuildRequires:  xorg-proto-xf86driproto-devel
48 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
49 BuildRequires:  xorg-util-util-macros >= 1.8
50 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
51 %{?requires_xorg_xserver_videodrv}
52 %{?with_glamor:Requires:        glamor >= 0.3.1}
53 Requires:       libdrm >= %{libdrm_ver}
54 Requires:       xorg-lib-libpciaccess >= 0.10
55 Requires:       xorg-xserver-libdri >= %{xserver_ver}
56 Requires:       xorg-xserver-libglx >= %{xserver_ver}
57 Requires:       xorg-xserver-server >= %{xserver_ver}
58 Provides:       xorg-driver-video
59 Provides:       xorg-driver-video-i810
60 Obsoletes:      X11-driver-i810 < 1:7.0.0
61 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
62 Obsoletes:      XFree86-i810
63 Obsoletes:      xorg-driver-video-i810 < 1.7.2
64 Conflicts:      vbetool
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 X.org video driver for Intel integrated graphics chipsets. It
69 supports:
70 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
71   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
72   Q35, GM45, G45, Q45, G43, G41 chipsets,
73 - Pineview-M in Atom N400 series,
74 - Pineview-D in Atom D400/D500 series.
75
76 Requires Kernel Mode Setting (KMS) to be active.
77
78 %description -l pl.UTF-8
79 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
80 Obsługuje:
81 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
82   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
83   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
84 - Pineview-M w procesorach Atom z serii N400,
85 - Pineview-D w procesorach Atom z serii D400/D500.
86
87 Wymaga aktywnego Kernel Mode Setting (KMS).
88
89 %prep
90 %setup -q -n xf86-video-intel-%{version}
91
92 %build
93 %configure \
94         --disable-silent-rules \
95         %{?with_glamor:--enable-glamor} \
96         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
97         --enable-uxa \
98         --enable-sna%{!?with_sna:=no}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
109         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS COPYING ChangeLog NEWS README
120 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
121 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
122 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
123 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
124 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
125 %{_mandir}/man4/intel.4*
This page took 0.050366 seconds and 4 git commands to generate.