]> git.pld-linux.org Git - packages/xorg-driver-video-intel.git/blob - xorg-driver-video-intel.spec
- up to 2.20.0; SNA is default (here and in upstream) now but you can switch to UXA...
[packages/xorg-driver-video-intel.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 #
6 %define libdrm_ver      2.4.31
7 %if %{with sna}
8 %define xserver_ver     1.10
9 %else
10 %define xserver_ver     1.6.3
11 %endif
12 Summary:        X.org video driver for Intel integrated graphics chipsets
13 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
14 Name:           xorg-driver-video-intel
15 Version:        2.20.0
16 Release:        1
17 License:        MIT
18 Group:          X11/Applications
19 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
20 # Source0-md5:  070bb866b05a16366bd9bb844c9b91aa
21 URL:            http://xorg.freedesktop.org/
22 BuildRequires:  Mesa-libGL-devel
23 #BuildRequires: autoconf >= 2.63
24 #BuildRequires: automake >= 1:1.10.2-2
25 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
26 BuildRequires:  libdrm-devel >= %{libdrm_ver}
27 #BuildRequires: libtool >= 2:2.2
28 BuildRequires:  libxcb-devel >= 1.5
29 BuildRequires:  pixman-devel >= 0.24.0
30 BuildRequires:  pkgconfig >= 1:0.19
31 BuildRequires:  rpmbuild(macros) >= 1.389
32 BuildRequires:  udev-devel
33 BuildRequires:  xcb-util-devel
34 BuildRequires:  xorg-lib-libXfixes-devel
35 BuildRequires:  xorg-lib-libXvMC-devel
36 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
37 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
38 BuildRequires:  xorg-proto-fontsproto-devel
39 BuildRequires:  xorg-proto-glproto-devel
40 BuildRequires:  xorg-proto-randrproto-devel
41 BuildRequires:  xorg-proto-renderproto-devel
42 BuildRequires:  xorg-proto-videoproto-devel
43 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
44 BuildRequires:  xorg-proto-xf86driproto-devel
45 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
46 BuildRequires:  xorg-util-util-macros >= 1.8
47 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
48 %{?requires_xorg_xserver_videodrv}
49 %{?with_glamor:Requires:        glamor >= 0.3.1}
50 Requires:       libdrm >= %{libdrm_ver}
51 Requires:       xorg-lib-libpciaccess >= 0.10
52 Requires:       xorg-xserver-libdri >= %{xserver_ver}
53 Requires:       xorg-xserver-libglx >= %{xserver_ver}
54 Requires:       xorg-xserver-server >= %{xserver_ver}
55 Provides:       xorg-driver-video
56 Provides:       xorg-driver-video-i810
57 Obsoletes:      X11-driver-i810 < 1:7.0.0
58 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
59 Obsoletes:      XFree86-i810
60 Obsoletes:      xorg-driver-video-i810 < 1.7.2
61 Conflicts:      vbetool
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 X.org video driver for Intel integrated graphics chipsets. It
66 supports:
67 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
68   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
69   Q35, GM45, G45, Q45, G43, G41 chipsets,
70 - Pineview-M in Atom N400 series,
71 - Pineview-D in Atom D400/D500 series.
72
73 Requires Kernel Mode Setting (KMS) to be active.
74
75 %description -l pl.UTF-8
76 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
77 Obsługuje:
78 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
79   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
80   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
81 - Pineview-M w procesorach Atom z serii N400,
82 - Pineview-D w procesorach Atom z serii D400/D500.
83
84 Wymaga aktywnego Kernel Mode Setting (KMS).
85
86 %prep
87 %setup -q -n xf86-video-intel-%{version}
88
89 %build
90 %configure \
91         --disable-silent-rules \
92         %{?with_glamor:--enable-glamor} \
93         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
94         --enable-uxa \
95         --enable-sna%{!?with_sna:=no}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
106         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING ChangeLog NEWS README
117 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
119 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
121 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
122 %{_mandir}/man4/intel.4*
This page took 0.137487 seconds and 3 git commands to generate.