]> git.pld-linux.org Git - SPECS.git/blob - xorg-driver-video-intel.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / xorg-driver-video-intel.spec
1 #
2 # Conditional build:
3 %bcond_with     glamor  Glamor acceleration
4 %bcond_without  sna     SandyBridge's New Acceleration (also for older generations)
5 %bcond_without  dri3    DRI3 support
6 #
7 %define libdrm_ver      2.4.41
8 %define pixman_ver      0.28.0
9 %if %{with sna}
10 %define xserver_ver     1.10
11 %else
12 %define xserver_ver     1.6.3
13 %endif
14 Summary:        X.org video driver for Intel integrated graphics chipsets
15 Summary(pl.UTF-8):      Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela
16 Name:           xorg-driver-video-intel
17 Version:        2.99.917
18 Release:        9
19 License:        MIT
20 Group:          X11/Applications
21 Source0:        http://xorg.freedesktop.org/releases/individual/driver/xf86-video-intel-%{version}.tar.bz2
22 # Source0-md5:  fa196a66e52c0c624fe5d350af7a5e7b
23 URL:            http://xorg.freedesktop.org/
24 Patch0:         xorg-driver-video-intel-git.patch
25 # Patch0-md5:   2283ea06b64d9c44321e1626190f17ee
26 Patch1:         driver-intel-sna-cursor-Make-sure-hw-cursors-are-disabled-before-disabling-secondary-planes.patch
27 BuildRequires:  Mesa-libGL-devel
28 #BuildRequires: autoconf >= 2.63
29 #BuildRequires: automake >= 1:1.10.2-2
30 %{?with_glamor:BuildRequires:   glamor-devel >= 0.3.1}
31 BuildRequires:  libdrm-devel >= %{libdrm_ver}
32 #BuildRequires: libtool >= 2:2.2
33 BuildRequires:  libxcb-devel >= 1.5
34 BuildRequires:  pixman-devel >= %{pixman_ver}
35 BuildRequires:  pkgconfig >= 1:0.19
36 BuildRequires:  rpmbuild(macros) >= 1.389
37 BuildRequires:  udev-devel
38 BuildRequires:  xcb-util-devel
39 BuildRequires:  xorg-lib-libX11-devel
40 BuildRequires:  xorg-lib-libXfixes-devel
41 BuildRequires:  xorg-lib-libXrender-devel
42 BuildRequires:  xorg-lib-libXtst-devel
43 BuildRequires:  xorg-lib-libXvMC-devel
44 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10
45 BuildRequires:  xorg-proto-dri2proto-devel >= 2.6
46 %{?with_dri3:BuildRequires:     xorg-proto-dri3proto-devel}
47 BuildRequires:  xorg-proto-fontsproto-devel
48 BuildRequires:  xorg-proto-glproto-devel
49 BuildRequires:  xorg-proto-randrproto-devel
50 BuildRequires:  xorg-proto-renderproto-devel
51 BuildRequires:  xorg-proto-videoproto-devel
52 BuildRequires:  xorg-proto-xextproto-devel >= 7.0.99.1
53 BuildRequires:  xorg-proto-xf86driproto-devel
54 BuildRequires:  xorg-proto-xproto-devel >= 7.0.13
55 BuildRequires:  xorg-util-util-macros >= 1.8
56 BuildRequires:  xorg-xserver-server-devel >= %{xserver_ver}
57 %{?requires_xorg_xserver_videodrv}
58 %{?with_glamor:Requires:        glamor >= 0.3.1}
59 Requires:       libdrm >= %{libdrm_ver}
60 Requires:       pixman >= %{pixman_ver}
61 Requires:       xorg-lib-libpciaccess >= 0.10
62 Requires:       xorg-xserver-libdri >= %{xserver_ver}
63 Requires:       xorg-xserver-libglx >= %{xserver_ver}
64 Requires:       xorg-xserver-server >= %{xserver_ver}
65 Provides:       xorg-driver-video
66 Provides:       xorg-driver-video-i810
67 Obsoletes:      X11-driver-i810 < 1:7.0.0
68 Obsoletes:      XFree86-driver-i810 < 1:7.0.0
69 Obsoletes:      XFree86-i810
70 Obsoletes:      xorg-driver-video-i810 < 1.7.2
71 Conflicts:      vbetool
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 X.org video driver for Intel integrated graphics chipsets. It
76 supports:
77 - i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM, 865G, 915G,
78   915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33, Q33, G35,
79   Q35, GM45, G45, Q45, G43, G41 chipsets,
80 - Pineview-M in Atom N400 series,
81 - Pineview-D in Atom D400/D500 series.
82
83 Requires Kernel Mode Setting (KMS) to be active.
84
85 %description -l pl.UTF-8
86 Sterownik obrazu X.org dla zintegrowanych układów graficznych Intela.
87 Obsługuje:
88 - układy i810, i810-DC100, i810e, i815, 830M, 845G, 852GM, 855GM,
89   865G, 915G, 915GM, 945G, 945GM, 965G, 965Q, 946GZ, 965GM, 945GME, G33,
90   Q33, G35, Q35, GM45, G45, Q45, G43, G41,
91 - Pineview-M w procesorach Atom z serii N400,
92 - Pineview-D w procesorach Atom z serii D400/D500.
93
94 Wymaga aktywnego Kernel Mode Setting (KMS).
95
96 %prep
97 %setup -q -n xf86-video-intel-%{version}
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 %{__aclocal}
103 %{__autoconf}
104 %{__autoheader}
105 %{__automake}
106 %configure \
107         --disable-silent-rules \
108         %{?with_glamor:--enable-glamor} \
109         --with-default-accel=%{?with_sna:sna}%{!?with_sna:uxa} \
110         --enable-uxa \
111         --enable-sna%{!?with_sna:=no} \
112         %{__enable_disable dri3}
113
114 %{__make}
115
116 %install
117 rm -rf $RPM_BUILD_ROOT
118
119 %{__make} install \
120         DESTDIR=$RPM_BUILD_ROOT
121
122 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xorg/modules/*/*.la \
123         $RPM_BUILD_ROOT%{_libdir}/lib*XvMC.{la,so}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS COPYING ChangeLog NEWS README
134 %attr(755,root,root) %{_bindir}/intel-virtual-output
135 %attr(755,root,root) %{_libexecdir}/xf86-video-intel-backlight-helper
136 %attr(755,root,root) %{_libdir}/libI810XvMC.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libI810XvMC.so.1
138 %attr(755,root,root) %{_libdir}/libIntelXvMC.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libIntelXvMC.so.1
140 %attr(755,root,root) %{_libdir}/xorg/modules/drivers/intel_drv.so
141 %{_mandir}/man4/intel.4*
142 %{_mandir}/man4/intel-virtual-output.4*
143 %{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
This page took 0.594304 seconds and 3 git commands to generate.