]> git.pld-linux.org Git - packages/xmp.git/blob - xmp.spec
- up to last available version (2.0.5pre3)
[packages/xmp.git] / xmp.spec
1 #
2 # Conditional build:
3 # _without_arts - without aRts audio plugin
4 # _without_esd  - without EsounD audio output plugin
5 # _without_nas  - without NAS audio output plugin
6 # _without_xmms - without XMP as XMMS plugin
7 # _with_nonfree - with ppunpack and fmopl (GPL-incompatible - non-distributable)
8 #
9 Summary:        Extended Module Player
10 Summary(pl):    Rozszerzony odtwarzacz modu³ów
11 Name:           xmp
12 Version:        2.0.5
13 %define pver    pre3
14 Release:        0.%{pver}.1
15 License:        GPL%{?_with_nonfree: with non-commercial additions}
16 Group:          Applications/Sound
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{pver}.tar.bz2
18 # Source0-md5:  db1813fec46c57757965c53a8cf33c4f
19 Patch0:         %{name}-gcc33.patch
20 Patch1:         %{name}-fix-shared.patch
21 Patch2:         %{name}-load-fix.patch
22 Patch3:         %{name}-nondfsg.patch
23 URL:            http://xmp.sourceforge.net/
24 BuildRequires:  XFree86-devel
25 %{!?_without_arts:BuildRequires:        arts-devel}
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %{!?_without_esd:BuildRequires: esound-devel}
29 %{!?_without_nas:BuildRequires: nas-devel}
30 %{!?_without_xmms:BuildRequires:        xmms-devel}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %if 0%{!?_without_xmms:1}
34 %define         xmmsplugindir   %(xmms-config --input-plugin-dir)
35 %endif
36
37 %description
38 xmp is a multi-format module player for UNIX. In machines with GUS or
39 AWE cards xmp takes advantage of the OSS sequencer to play modules
40 with virtually no system load. Using software mixing, xmp plays at
41 sampling rates up to 48kHz in mono or stereo, 8 or 16 bits, signed or
42 unsigned, little or big endian samples with 32 bit linear
43 interpolation.
44
45 %description -l pl
46 xmp jest odtwarzaczem modu³ów w wielu formatach. Potrafi obs³u¿yæ
47 karty GUS i AWE, korzystaj±c z sekwencera OSS, aby nie obci±¿aæ
48 systemu. U¿ywaj±c programowego miksowania, mo¿e odgrywaæ z
49 czêstotliwo¶ci± próbkowania do 48kHz mono lub stereo, 8 lub 16 bitów,
50 próbki ze znakiem lub bez, little- lub big-endian z 32-bitow±
51 interpolacj±.
52
53 %package X11
54 Summary:        Extended Module Player with GUI
55 Summary(pl):    Rozszerzony odtwarzacz modu³ów z graficznym interfejsem
56 Group:          X11/Applications/Sound
57 Requires:       %{name} = %{version}
58
59 %description X11
60 Extended Module Player with GUI.
61
62 %description X11 -l pl
63 Rozszerzony odtwarzacz modu³ów z graficznym interfejsem.
64
65 %package output-arts
66 Summary:        aRts audio output plugin for XMP
67 Summary(pl):    Wtyczka wyj¶cia d¼wiêku aRts dla XMP
68 Group:          Applications/Sound
69 Requires:       %{name} = %{version}
70
71 %description output-arts
72 aRts audio output plugin for XMP.
73
74 %description output-arts -l pl
75 Wtyczka wyj¶cia d¼wiêku aRts dla XMP.
76
77 %package output-esd
78 Summary:        EsounD audio output plugin for XMP
79 Summary(pl):    Wtyczka wyj¶cia d¼wiêku EsounD dla XMP
80 Group:          Applications/Sound
81 Requires:       %{name} = %{version}
82
83 %description output-esd
84 EsounD audio output plugin for XMP.
85
86 %description output-esd -l pl
87 Wtyczka wyj¶cia d¼wiêku EsounD dla XMP.
88
89 %package output-nas
90 Summary:        NAS audio output plugin for XMP
91 Summary(pl):    Wtyczka wyj¶cia d¼wiêku NAS dla XMP
92 Group:          Applications/Sound
93 Requires:       %{name} = %{version}
94
95 %description output-nas
96 NAS audio output plugin for XMP.
97
98 %description output-nas -l pl
99 Wtyczka wyj¶cia d¼wiêku NAS dla XMP.
100
101 %package -n xmms-input-xmp
102 Summary:        XMMS plugin that uses XMP library to play music modules
103 Summary(pl):    Wtyczka XMMS odtwarzaj±ca modu³y d¼wiêkowe z u¿yciem XMP
104 Group:          X11/Applications/Sound
105 Requires:       %{name}-%{version}
106
107 %description -n xmms-input-xmp
108 XMMS plugin that uses XMP library to play music modules.
109
110 %description -n xmms-input-xmp -l pl
111 Wtyczka XMMS odtwarzaj±ca modu³y d¼wiêkowe z u¿yciem biblioteki XMP.
112
113 %prep
114 %setup -q -n %{name}-%{version}-%{pver}
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118 %{?_with_nonfree:%patch3 -p1}
119
120 %build
121 cp -f /usr/share/automake/config.* scripts
122 %{__aclocal}
123 %{__autoconf}
124 # alsa disabled - only 0.5 supported for now
125 %configure \
126         --disable-alsa \
127         %{?_without_arts:--disable-arts} \
128         %{?_without_esd:--disable-esd} \
129         %{?_without_nas:--disable-nas} \
130         %{?_without_xmms:--disable-xmms} \
131         --enable-dynamic
132
133 %{__make}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137 install -d $RPM_BUILD_ROOT%{_sysconfdir}
138
139 %{__make} install \
140         DEST_DIR=$RPM_BUILD_ROOT \
141         BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
142         LIB_DIR=$RPM_BUILD_ROOT%{_libdir} \
143         MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc README docs/{CREDITS,ChangeLog,README.{awebug,fixloop,ppunpack,trackers,unsqsh},formats} etc/magic
154 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/xmp*.conf
155 %attr(755,root,root) %{_bindir}/xmp
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
157 %dir %{_libdir}/xmp
158 %dir %{_libdir}/xmp/drivers
159 %attr(755,root,root) %{_libdir}/xmp/drivers/oss*.so
160 %{_mandir}/man1/xmp.1*
161
162 %files X11
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/xxmp
165 %{_mandir}/man1/xxmp.1*
166
167 %if 0%{!?_without_arts:1}
168 %files output-arts
169 %defattr(644,root,root,755)
170 %attr(755,root,root) %{_libdir}/xmp/drivers/arts.so
171 %endif
172
173 %if 0%{!?_without_esd:1}
174 %files output-esd
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/xmp/drivers/esd.so
177 %endif
178
179 %if 0%{!?_without_nas:1}
180 %files output-nas
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/xmp/drivers/nas.so
183 %endif
184
185 %if 0%{!?_without_xmms:1}
186 %files -n xmms-input-xmp
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{xmmsplugindir}/*.so
189 %endif
This page took 0.067059 seconds and 4 git commands to generate.