]> git.pld-linux.org Git - packages/xmp.git/blob - xmp.spec
- bcond style, changelog cleanups
[packages/xmp.git] / xmp.spec
1 #
2 # Conditional build:
3 %bcond_without  arts            # without aRts audio plugin
4 %bcond_without  esd             # without EsounD audio output plugin
5 %bcond_without  nas             # without NAS audio output plugin
6 %bcond_without  xmms            # without XMP as XMMS plugin
7 %bcond_with     nonfree         # with ppunpack and fmopl (GPL-incompatible - non-distributable)
8 #
9 Summary:        Extended Module Player
10 Summary(pl):    Rozszerzony odtwarzacz modu³ów
11 Name:           xmp
12 Version:        2.0.5
13 %define pver    pre3
14 Release:        0.%{pver}.2
15 License:        GPL%{?with_nonfree: with non-commercial additions}
16 Group:          Applications/Sound
17 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}%{pver}.tar.bz2
18 # Source0-md5:  749db9c8da956b403a959b4c8b909447
19 Patch0:         %{name}-gcc33.patch
20 Patch1:         %{name}-fix-shared.patch
21 Patch2:         %{name}-load-fix.patch
22 Patch3:         %{name}-nondfsg.patch
23 URL:            http://xmp.sourceforge.net/
24 BuildRequires:  XFree86-devel
25 %{?with_arts:BuildRequires:     arts-devel}
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 %{?with_esd:BuildRequires:      esound-devel}
29 %{?with_nas:BuildRequires:      nas-devel}
30 %{?with_xmms:BuildRequires:     rpmbuild(macros) >= 1.125}
31 %{?with_xmms:BuildRequires:     xmms-devel}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 xmp is a multi-format module player for UNIX. In machines with GUS or
36 AWE cards xmp takes advantage of the OSS sequencer to play modules
37 with virtually no system load. Using software mixing, xmp plays at
38 sampling rates up to 48kHz in mono or stereo, 8 or 16 bits, signed or
39 unsigned, little or big endian samples with 32 bit linear
40 interpolation.
41
42 %description -l pl
43 xmp jest odtwarzaczem modu³ów w wielu formatach. Potrafi obs³u¿yæ
44 karty GUS i AWE, korzystaj±c z sekwencera OSS, aby nie obci±¿aæ
45 systemu. U¿ywaj±c programowego miksowania, mo¿e odgrywaæ z
46 czêstotliwo¶ci± próbkowania do 48kHz mono lub stereo, 8 lub 16 bitów,
47 próbki ze znakiem lub bez, little- lub big-endian z 32-bitow±
48 interpolacj±.
49
50 %package X11
51 Summary:        Extended Module Player with GUI
52 Summary(pl):    Rozszerzony odtwarzacz modu³ów z graficznym interfejsem
53 Group:          X11/Applications/Sound
54 Requires:       %{name} = %{version}
55
56 %description X11
57 Extended Module Player with GUI.
58
59 %description X11 -l pl
60 Rozszerzony odtwarzacz modu³ów z graficznym interfejsem.
61
62 %package output-arts
63 Summary:        aRts audio output plugin for XMP
64 Summary(pl):    Wtyczka wyj¶cia d¼wiêku aRts dla XMP
65 Group:          Applications/Sound
66 Requires:       %{name} = %{version}
67
68 %description output-arts
69 aRts audio output plugin for XMP.
70
71 %description output-arts -l pl
72 Wtyczka wyj¶cia d¼wiêku aRts dla XMP.
73
74 %package output-esd
75 Summary:        EsounD audio output plugin for XMP
76 Summary(pl):    Wtyczka wyj¶cia d¼wiêku EsounD dla XMP
77 Group:          Applications/Sound
78 Requires:       %{name} = %{version}
79
80 %description output-esd
81 EsounD audio output plugin for XMP.
82
83 %description output-esd -l pl
84 Wtyczka wyj¶cia d¼wiêku EsounD dla XMP.
85
86 %package output-nas
87 Summary:        NAS audio output plugin for XMP
88 Summary(pl):    Wtyczka wyj¶cia d¼wiêku NAS dla XMP
89 Group:          Applications/Sound
90 Requires:       %{name} = %{version}
91
92 %description output-nas
93 NAS audio output plugin for XMP.
94
95 %description output-nas -l pl
96 Wtyczka wyj¶cia d¼wiêku NAS dla XMP.
97
98 %package -n xmms-input-xmp
99 Summary:        XMMS plugin that uses XMP library to play music modules
100 Summary(pl):    Wtyczka XMMS odtwarzaj±ca modu³y d¼wiêkowe z u¿yciem XMP
101 Group:          X11/Applications/Sound
102 Requires:       %{name}-%{version}
103 Requires:       xmms
104
105 %description -n xmms-input-xmp
106 XMMS plugin that uses XMP library to play music modules.
107
108 %description -n xmms-input-xmp -l pl
109 Wtyczka XMMS odtwarzaj±ca modu³y d¼wiêkowe z u¿yciem biblioteki XMP.
110
111 %prep
112 %setup -q -n %{name}-%{version}-%{pver}
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116 %{?with_nonfree:%patch3 -p1}
117
118 %build
119 cp -f /usr/share/automake/config.* scripts
120 %{__aclocal}
121 %{__autoconf}
122 # alsa disabled - only 0.5 supported for now
123 %configure \
124         --disable-alsa \
125         %{!?with_arts:--disable-arts} \
126         %{!?with_esd:--disable-esd} \
127         %{!?with_nas:--disable-nas} \
128         %{!?with_xmms:--disable-xmms} \
129         --enable-dynamic
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134 install -d $RPM_BUILD_ROOT%{_sysconfdir}
135
136 %{__make} install \
137         DEST_DIR=$RPM_BUILD_ROOT \
138         BIN_DIR=$RPM_BUILD_ROOT%{_bindir} \
139         LIB_DIR=$RPM_BUILD_ROOT%{_libdir} \
140         MAN_DIR=$RPM_BUILD_ROOT%{_mandir}/man1
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 %doc README docs/{CREDITS,ChangeLog,README.{awebug,fixloop,ppunpack,trackers,unsqsh},formats} etc/magic
151 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/xmp*.conf
152 %attr(755,root,root) %{_bindir}/xmp
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
154 %dir %{_libdir}/xmp
155 %dir %{_libdir}/xmp/drivers
156 %attr(755,root,root) %{_libdir}/xmp/drivers/oss*.so
157 %{_mandir}/man1/xmp.1*
158
159 %files X11
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/xxmp
162 %{_mandir}/man1/xxmp.1*
163
164 %if %{with arts}
165 %files output-arts
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/xmp/drivers/arts.so
168 %endif
169
170 %if %{with esd}
171 %files output-esd
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/xmp/drivers/esd.so
174 %endif
175
176 %if %{with nas}
177 %files output-nas
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/xmp/drivers/nas.so
180 %endif
181
182 %if %{with xmms}
183 %files -n xmms-input-xmp
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{xmms_input_plugindir}/*.so
186 %endif
This page took 0.090434 seconds and 4 git commands to generate.