]> git.pld-linux.org Git - SPECS.git/blob - xmlwrapp.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / xmlwrapp.spec
1 Summary:        libxml2 C++ wrapper
2 Summary(pl.UTF-8):      Wiązania C++ dla libxml2
3 Name:           xmlwrapp
4 Version:        0.5.0
5 Release:        1
6 License:        BSD-like
7 Group:          Libraries
8 Vendor:         Peter J Jones <pjones@pmade.org>
9 Source0:        http://pmade.org/software/xmlwrapp/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  b8a07e77f8f8af9ca96bccab7d9dd310
11 URL:            http://pmade.org/software/xmlwrapp/
12 BuildRequires:  libxml2-devel
13 BuildRequires:  libxslt-devel >= 1.0.23
14 BuildRequires:  perl-base
15 BuildRequires:  pkgconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 xmlwrapp is a modern style C++ library for working with XML data. It
20 provides a simple and easy to use interface for the very powerful
21 libxml2 XML parser and the libxslt XSLT engine.
22
23 %description -l pl.UTF-8
24 xmlwrapp jest nowoczesną biblioteką napisaną w C++, służącą do pracy z
25 danymi w formacie XML. Dostarcza ona proste i łatwe w użyciu
26 międzymordzie do libxml2 oraz libxslt.
27
28 %package devel
29 Summary:        Development files for xmlwrapp
30 Summary(pl.UTF-8):      Pliki nagłówkowe dla xmlwrapp
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Development files for xmlwrapp.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe dla xmlwrapp.
39
40 %package static
41 Summary:        Static libraries for xmlwrapp
42 Summary(pl.UTF-8):      Biblioteki statyczne dla xmlwrapp
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static libraries for xmlwrapp.
48
49 %description static -l pl.UTF-8
50 Biblioteki statyczne dla xmlwrapp.
51
52 %prep
53 %setup -q
54
55 %build
56 CXX="%{__cxx}" \
57 %{__perl} ./configure.pl \
58         --prefix $RPM_BUILD_ROOT%{_prefix}
59
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 %{__make} install
65
66 %{__perl} -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT{%{_bindir}/*,%{_pkgconfigdir}/*}
67
68 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69 cd examples
70 for f in * ; do
71         test -d $f || continue
72         install $f/example.cxx $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f.cc
73 done
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc LICENSE
81 %attr(755,root,root) %{_libdir}/*.so.*
82
83 %files devel
84 %defattr(644,root,root,755)
85 # TODO: process this docbook, generate doxygen stuff
86 %doc README docs/CREDITS docs/TODO docs/manual docs/project
87 %attr(755,root,root) %{_bindir}/*
88 %attr(755,root,root) %{_libdir}/*.so
89 %{_includedir}/*
90 %{_pkgconfigdir}/%{name}.pc
91 %{_examplesdir}/%{name}-%{version}
92
93 %files static
94 %defattr(644,root,root,755)
95 %{_libdir}/*.a
This page took 0.926574 seconds and 3 git commands to generate.