]> git.pld-linux.org Git - packages/xinetd.git/blob - xinetd.spec
- use macros in %{pre,post}{,un}
[packages/xinetd.git] / xinetd.spec
1 Summary:        Secure replacement for inetd
2 Summary(pl):    Bezpieczny odpowiednik inetd
3 Name:           xinetd
4 Version:        2.3.0
5 Release:        1
6 Group:          Daemons
7 Group(de):      Server
8 Group(pl):      Serwery
9 License:        Distributable (BSD-like)
10 Source0:        http://www.xinetd.org/%{name}-%{version}.tar.gz
11 Source1:        %{name}.inet.sh
12 URL:            http://www.xinetd.org/
13 BuildRequires:  libwrap-devel
14 Requires:       rc-inetd
15 Prereq:         rc-scripts
16 Requires:       /etc/rc.d/init.d/rc-inetd
17 Provides:       inetdaemon
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      inetdaemon
20 Obsoletes:      inetd
21 Obsoletes:      rlinetd
22 Obsoletes:      netkit-base
23
24 %define         _sysconfdir     /etc
25
26 %description
27 Xinetd is a secure replacement for inetd, the Internet services
28 daemon. Xinetd provides access control for all services based on the
29 address of the remote host and/or on time of access and can prevent
30 denial-of-access attacks. Xinetd provides extensive logging, has no
31 limit on the number of server arguments and you can bind specific
32 services to specific IP addresses on your host machine.
33
34 %description -l pl
35 xinetd jest bezpieczniejszym i rozbudowanym odpowiednikiem inetd.
36 Niektóre funkcje to wbudowana kontrola dostêpu (oparta o libwrap),
37 kontrola zu¿ycia zasobów i wbudowana obs³uga IPv6.
38
39 %prep
40 %setup -q
41
42 %build
43 %configure  \
44         --with-libwrap \
45         %{?!_without_ipv6:--with-inet6}  \
46         --with-loadavg
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT/%{_sbindir} \
52         $RPM_BUILD_ROOT/%{_mandir}/man{5,8} \
53         $RPM_BUILD_ROOT/%{_sysconfdir}/{rc.d/init.d,sysconfig}
54
55 install xinetd/xinetd $RPM_BUILD_ROOT/%{_sbindir}
56 install xinetd/itox $RPM_BUILD_ROOT/%{_sbindir}
57 install xinetd/xinetd.conf.man $RPM_BUILD_ROOT/%{_mandir}/man5/xinetd.conf.5
58 install xinetd/xinetd.log.man $RPM_BUILD_ROOT/%{_mandir}/man8/xinetd.log.8
59 install xinetd/xinetd.man $RPM_BUILD_ROOT/%{_mandir}/man8/xinetd.8
60 install xinetd/itox.8 $RPM_BUILD_ROOT/%{_mandir}/man8/itox.8
61 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inet.script
62 :> $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.conf
63
64 cp xinetd/sample.conf .
65 cp xinetd/xconv.pl .
66
67 gzip -9nf README CHANGELOG sample.conf xconv.pl
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %rc_inetd_post
74
75 %preun
76 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
77         /etc/rc.d/init.d/rc-inetd stop
78 fi
79
80 %files
81 %defattr(644,root,root,755)
82 %doc *.gz
83 %attr(755,root,root) %{_sbindir}/*
84 %attr(640,root,root) %ghost %{_sysconfdir}/xinetd.conf
85 %attr(640,root,root) /etc/sysconfig/rc-inet.script
86 %{_mandir}/man[158]/*
This page took 0.067693 seconds and 4 git commands to generate.