]> git.pld-linux.org Git - packages/xinetd.git/blob - xinetd.spec
- added no_libnsl patch (remove redundant linking with libnsl).
[packages/xinetd.git] / xinetd.spec
1 Summary:        Secure replacement for inetd
2 Summary(pl):    Bezpieczny odpowiednik inetd
3 Name:           xinetd
4 Version:        2.3.7
5 Release:        1
6 Group:          Daemons
7 License:        distributable (BSD-like)
8 Source0:        http://www.xinetd.org/%{name}-%{version}.tar.gz
9 Source1:        %{name}.inet.sh
10 Patch0:         %{name}-no_libnsl.patch
11 URL:            http://www.xinetd.org/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libwrap-devel
15 Requires:       rc-inetd
16 Prereq:         rc-scripts
17 Requires:       /etc/rc.d/init.d/rc-inetd
18 Provides:       inetdaemon
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Obsoletes:      inetdaemon
21 Obsoletes:      inetd
22 Obsoletes:      rlinetd
23 Obsoletes:      netkit-base
24
25 %define         _sysconfdir     /etc
26
27 %description
28 Xinetd is a secure replacement for inetd, the Internet services
29 daemon. Xinetd provides access control for all services based on the
30 address of the remote host and/or on time of access and can prevent
31 denial-of-access attacks. Xinetd provides extensive logging, has no
32 limit on the number of server arguments and you can bind specific
33 services to specific IP addresses on your host machine.
34
35 %description -l pl
36 xinetd jest bezpieczniejszym i rozbudowanym odpowiednikiem inetd.
37 Niektóre funkcje to wbudowana kontrola dostêpu (oparta o libwrap),
38 kontrola zu¿ycia zasobów i wbudowana obs³uga IPv6.
39
40 %prep
41 %setup -q
42 %patch0 -p1
43
44 %build
45 aclocal
46 %{__autoconf}
47 %configure  \
48         --with-libwrap \
49         --with-inet6  \
50         --with-loadavg
51 %{__make}
52 cp xinetd/xinetd xinetd/xinetd-ipv6
53 %{__make} clean
54 rm -f config.cache
55 %configure  \
56         --with-libwrap \
57         --with-loadavg
58 %{__make}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_sbindir} \
63         $RPM_BUILD_ROOT%{_mandir}/man{5,8} \
64         $RPM_BUILD_ROOT%{_sysconfdir}/{rc.d/init.d,sysconfig}
65
66 install xinetd/xinetd $RPM_BUILD_ROOT%{_sbindir}
67 install xinetd/xinetd-ipv6 $RPM_BUILD_ROOT%{_sbindir}
68 install xinetd/itox $RPM_BUILD_ROOT%{_sbindir}
69 install xinetd/xinetd.conf.man $RPM_BUILD_ROOT%{_mandir}/man5/xinetd.conf.5
70 install xinetd/xinetd.log.man $RPM_BUILD_ROOT%{_mandir}/man8/xinetd.log.8
71 install xinetd/xinetd.man $RPM_BUILD_ROOT%{_mandir}/man8/xinetd.8
72 install xinetd/itox.8 $RPM_BUILD_ROOT%{_mandir}/man8/itox.8
73 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inet.script
74 :> $RPM_BUILD_ROOT%{_sysconfdir}/xinetd.conf
75
76 cp xinetd/sample.conf .
77 cp xinetd/xconv.pl .
78
79 gzip -9nf README CHANGELOG sample.conf xconv.pl
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 if [ -f /var/lock/subsys/rc-inetd ]; then
86         /etc/rc.d/init.d/rc-inetd restart 1>&2
87 else
88         echo "Type \"/etc/rc.d/init.d/rc-inetd start\" to start xinetd" 1>&2
89 fi
90
91 %preun
92 if [ "$1" = "0" -a -f /var/lock/subsys/rc-inetd ]; then
93         /etc/rc.d/init.d/rc-inetd stop
94 fi
95
96 %files
97 %defattr(644,root,root,755)
98 %doc *.gz
99 %attr(755,root,root) %{_sbindir}/*
100 %attr(640,root,root) %ghost %{_sysconfdir}/xinetd.conf
101 %attr(640,root,root) /etc/sysconfig/rc-inet.script
102 %{_mandir}/man[158]/*
This page took 0.046177 seconds and 4 git commands to generate.