]> git.pld-linux.org Git - packages/xen.git/blob - xen.spec
- added BR: rpm-pythonprov
[packages/xen.git] / xen.spec
1 # TODO:
2 # - pldized init scripts
3 # - script for rc-boot
4 Summary:        Xen - a virtual machine monitor
5 Summary(pl):    Xen - monitor maszyny wirtualnej
6 Name:           xen
7 Version:        2.0.7
8 Release:        0.1
9 Epoch:          0
10 Group:          Applications/System
11 License:        GPL
12 Source0:        http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/%{name}-%{version}-src.tgz
13 # Source0-md5:  ce09744be2b34ad6ffd8eb15dae2eb1f
14 Source1:        %{name}-xend.init
15 Source2:        %{name}-xendomains.init
16 Patch0:         %{name}-twisted.patch
17 Patch1:         %{name}-scripts.patch
18 URL:            http://www.cl.cam.ac.uk/Research/SRG/netos/xen/index.html
19 BuildRequires:  XFree86-devel
20 BuildRequires:  curl-devel
21 BuildRequires:  libidn-devel
22 BuildRequires:  ncurses-devel
23 BuildRequires:  python-Twisted
24 BuildRequires:  python-devel
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  tetex-dvips
27 BuildRequires:  tetex-format-latex
28 BuildRequires:  tetex-latex-psnfss
29 BuildRequires:  transfig
30 BuildRequires:  which
31 BuildRequires:  zlib-devel
32 Requires:       ZopeInterface
33 Requires:       bridge-utils
34 Requires:       losetup
35 Requires:       python-TwistedWeb
36 ExclusiveArch:  %{ix86}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 This package contains the Xen hypervisor and Xen tools, needed to run
41 virtual machines on x86 systems, together with the kernel-xen*
42 packages. Information on how to use Xen can be found at the Xen
43 project pages.
44
45 Virtualisation can be used to run multiple versions or multiple Linux
46 distributions on one system, or to test untrusted applications in a
47 sandboxed environment. Note that the Xen technology is still in
48 development, and this RPM has received extremely little testing. Don't
49 be surprised if this RPM eats your data, drinks your coffee or makes
50 fun of you in front of your friends.
51
52 %description -l pl
53 Ten pakiet zawiera nadzorcê oraz narzêdzia Xen, potrzebne do
54 uruchamiania wirtualnych maszyn w systemach x86, wraz z pakietami
55 kernel-xen*. Informacje jak u¿ywaæ Xena mo¿na znale¼æ na stronach
56 projektu.
57
58 Wirtualizacja mo¿e byæ u¿ywana do uruchamiania wielu wersji lub wielu
59 dystrybucji Linuksa na jednym systemie lub do testowania nie zaufanych
60 aplikacji w odizolowanym ¶rodowisku. Nale¿y zauwa¿yæ, ¿e technologia
61 Xen jest ci±gle rozwijana, a ten RPM by³ s³abo testowany. Nie nale¿y
62 byæ zdziwionym, je¶li ten pakiet zje dane, wypije ca³± kawê czy bêdzie
63 siê wy¶miewa³ w obecno¶ci przyjació³.
64
65 %package devel
66 Summary:        Header files for xen
67 Summary(pl):    Pliki nag³ówkowe xena
68 Group:          Development/Libraries
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70
71 %description devel
72 Header files for xen.
73
74 %description devel -l pl
75 Pliki nag³ówkowe xena.
76
77 %package static
78 Summary:        Static xen libraries
79 Summary(pl):    Statyczne biblioteki xena
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
82
83 %description static
84 Static xen libraries.
85
86 %description static -l pl
87 Statyczne biblioteki xena.
88
89 %package doc
90 Summary:        Xen documentation
91 Summary(pl):    Dokumentacja xena
92 Group:          Applications/System
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description doc
96 Xen documentation.
97
98 %description doc -l pl
99 Dokumentacja xena.
100
101 %prep
102 %setup -q -n %{name}-2.0
103 %patch0 -p1
104 %patch1 -p1
105 chmod -R u+w .
106 #echo 'CXXFLAGS+=-I/usr/include/ncurses' >> tools/ioemu/gui/Makefile
107
108 %build
109 CFLAGS="%{rpmcflags}" \
110 CXXFLAGS="%{rpmcflags}" \
111 %{__make} xen tools docs \
112         CC="%{__cc}" \
113         CXX="%{__cxx}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install-xen install-tools install-docs \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
122 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/xend
123 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/xendomains
124
125 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}/xend-db/{domain,vnet}
126
127 #install -d $RPM_BUILD_ROOT%{_mandir}
128 #cp -a $RPM_BUILD_ROOT%{_prefix}/man/* $RPM_BUILD_ROOT%{_mandir}
129
130 #install -d doc-html-install/{interface,user}
131 #cp -a docs/html/interface/*.{png,html,css} doc-html-install/interface
132 #cp -a docs/html/user/*.{png,html,css} doc-html-install/user
133
134 rm -f $RPM_BUILD_ROOT%{_includedir}/%{name}/COPYING
135
136 %{py_comp} $RPM_BUILD_ROOT%{_libdir}/python
137 %{py_ocomp} $RPM_BUILD_ROOT%{_libdir}/python
138 find $RPM_BUILD_ROOT%{_libdir}/python -name '*.py' -exec rm "{}" ";"
139
140 install -d $RPM_BUILD_ROOT%{_datadir}/xen/
141 cp -f $RPM_BUILD_ROOT%{_datadir}/doc/xen/pdf/*.pdf $RPM_BUILD_ROOT%{_datadir}/xen/
142
143 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen
144 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/{sv,xend-db}
145 install -d $RPM_BUILD_ROOT%{_sharedstatedir}/xen/xend-db/{domain,vnet,migrate}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 /sbin/ldconfig
152 /sbin/chkconfig --add xend
153 /sbin/chkconfig --add xendomains
154
155 %postun -p /sbin/ldconfig
156
157 %preun
158 if [ "$1" = "0" ]; then
159 #       if [ -f /var/lock/subsys/xend ]; then
160 #               /etc/rc.d/init.d/xend stop 1>&2
161 #       fi
162         /sbin/chkconfig --del xend
163 #       if [ -f /var/lock/subsys/xendomains ]; then
164 #               /etc/rc.d/init.d/xendomains stop 1>&2
165 #       fi
166         /sbin/chkconfig --del xendomains
167 fi
168
169 %files
170 %defattr(644,root,root,755)
171 #%doc COPYING ChangeLog README docs/misc/* doc-html-install/*
172 %doc COPYING ChangeLog README docs/misc/*
173 /boot/%{name}-syms-%{version}
174 /boot/%{name}-%{version}.gz
175 /boot/%{name}.gz
176 %attr(754,root,root) /etc/rc.d/init.d/*
177 %dir %{_sysconfdir}/xen
178 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/*.*
179 #%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/b*
180 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/xmexample[12]
181 %dir %{_sysconfdir}/xen/auto
182 %dir %{_sysconfdir}/xen/scripts
183 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xen/scripts/*
184 %attr(755,root,root) %{_bindir}/*
185 %attr(755,root,root) %{_sbindir}/*
186 %attr(755,root,root) %{_libdir}/lib*.so.*
187 %{_libdir}/python/%{name}
188 %attr(755,root,root) %{_libdir}/python/%{name}/lowlevel/*.so
189 %{_mandir}/man?/*
190 %dir %{_sharedstatedir}/xen
191 %dir %{_sharedstatedir}/xen/sv
192 %dir %{_sharedstatedir}/xen/xend-db
193 %dir %{_sharedstatedir}/xen/xend-db/domain
194 %dir %{_sharedstatedir}/xen/xend-db/vnet
195 %dir %{_sharedstatedir}/xen/xend-db/migrate
196
197 %files devel
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_libdir}/lib*.so
200 %{_includedir}/*
201
202 %files static
203 %defattr(644,root,root,755)
204 %{_libdir}/lib*.a
205
206 %files doc
207 %defattr(644,root,root,755)
208 %dir %{_datadir}/xen
209 %{_datadir}/xen/*.pdf
This page took 0.069874 seconds and 4 git commands to generate.