]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- updated to 2.8.0 rc1
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8 #
9 # Unpackaged files:
10 #  /usr/bin/wxrc-2.6
11 #  /usr/share/bakefile/presets/wx.bkl
12 #  /usr/share/bakefile/presets/wx_unix.bkl
13 #  /usr/share/bakefile/presets/wx_win32.bkl
14 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
15 #
16
17 %define         _rc     rc1
18 Summary:        wxWidgets library
19 Summary(pl):    Biblioteka wxWidgets
20 Name:           wxWidgets
21 Version:        2.8.0
22 Release:        0.%{_rc}.1
23 License:        wxWidgets Licence (LGPL with exception)
24 Group:          X11/Libraries
25 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}-%{_rc}.tar.bz2
26 # Source0-md5:  875864ca39a9293a2316a26cc6004104
27 Patch0:         %{name}-samples.patch
28 Patch1:         %{name}-ogl.patch
29 Patch2:         %{name}-ac.patch
30 Patch3:         %{name}-gif0delay.patch
31 Patch4:         %{name}-x11unicode.patch
32 Patch5:         %{name}-gcc4.patch
33 URL:            http://www.wxWidgets.org/
34 BuildRequires:  OpenGL-GLU-devel
35 #BuildRequires: SDL-devel
36 BuildRequires:  autoconf >= 2.59-9
37 BuildRequires:  automake
38 #BuildRequires: bakefile >= 0.1.9
39 BuildRequires:  cppunit-devel
40 BuildRequires:  esound-devel
41 BuildRequires:  expat-devel
42 BuildRequires:  flex
43 BuildRequires:  gettext-devel
44 BuildRequires:  gtk+2-devel >= 2.0.0
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libmng-devel
47 BuildRequires:  libmspack-devel
48 BuildRequires:  libpng-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtiff-devel
51 BuildRequires:  libtool
52 BuildRequires:  pkgconfig
53 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
54 # these are not supported by wxWidgets
55 Obsoletes:      LDAPExplorerTool <= 0.6-1
56 Obsoletes:      abridge <= 0.4.0-1
57 # and these are replaced
58 Obsoletes:      wxGTK
59 Obsoletes:      wxGTK-devel
60 Obsoletes:      wxGTK-gl
61 Obsoletes:      wxGTK-gl-devel
62 Obsoletes:      wxGTK-univ
63 Obsoletes:      wxGTK-univ-devel
64 Obsoletes:      wxGTK-univ-gl
65 Obsoletes:      wxGTK-univ-gl-devel
66 Obsoletes:      wxGTK2-univ
67 Obsoletes:      wxGTK2-univ-devel
68 Obsoletes:      wxGTK2-univ-gl
69 Obsoletes:      wxGTK2-univ-gl-devel
70 Obsoletes:      wxGTK2-univ-unicode
71 Obsoletes:      wxGTK2-univ-unicode-devel
72 Obsoletes:      wxGTK2-univ-unicode-gl
73 Obsoletes:      wxGTK2-univ-unicode-gl-devel
74 Obsoletes:      wxMotif
75 Obsoletes:      wxMotif-devel
76 Obsoletes:      wxMotif-gl
77 Obsoletes:      wxMotif-gl-devel
78 Obsoletes:      wxWidgets-afm
79 Obsoletes:      wxWindows
80 Obsoletes:      wxWindows-afm
81 Obsoletes:      wxwin-afm
82 Obsoletes:      wxwin-common
83 Conflicts:      wxGTK2 < 2.6.0
84 Conflicts:      wxGTK2-unicode < 2.6.0
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     %{_datadir}
88
89 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
90
91 %description
92 wxWidgets is a free C++ library for cross-platform GUI development.
93 With wxWidgets, you can create applications for different GUIs (GTK+,
94 Motif/LessTif, MS Windows, Mac) from the same source code.
95
96 %description -l pl
97 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
98 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
99 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
100 Windows, Mac) z tego samego kodu ¼ród³owego.
101
102 %package devel
103 Summary:        wxWidgets header files and development documentation
104 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
105 Group:          X11/Development/Libraries
106 Requires:       libstdc++-devel
107 Obsoletes:      wxWindows-devel
108
109 %description devel
110 Header files and development documentation for the wxWidgets
111 libraries.
112
113 %description devel -l pl
114 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
115
116 %package examples
117 Summary:        wxWidgets example programs
118 Summary(pl):    Przyk³adowe programy wxWidgets
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121 Obsoletes:      wxWindows-examples
122
123 %description examples
124 wxWidgets example programs.
125
126 %description examples -l pl
127 Przyk³adowe programy wxWidgets.
128
129 %package HelpGen
130 Summary:        Help file generator for wxWidgets programs
131 Summary(pl):    Generator plików pomocy dla programów wxWidgets
132 Group:          Development/Tools
133 Requires:       wxBase = %{version}-%{release}
134 Obsoletes:      wxWindows-HelpGen
135
136 %description HelpGen
137 Help file generator for wxWidgets programs.
138
139 %description HelpGen -l pl
140 Generator plików pomocy dla programów wxWidgets.
141
142 %package -n wxBase
143 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
144 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
145 Group:          X11/Libraries
146 Requires:       %{name} = %{version}-%{release}
147
148 %description -n wxBase
149 wxBase is a collection of C++ classes providing basic data structures
150 (strings, lists, arrays), powerful wxDateTime class for date
151 manipulations, portable wrappers around many OS-specific functions
152 allowing to build the same program under all supported folders,
153 wxThread class for writing multithreaded programs using either Win32
154 or POSIX threads and much more. wxBase currently supports the
155 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
156 HP-UX, ...) and BeOS.
157
158 %description -n wxBase -l pl
159 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
160 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
161 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
162 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
163 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
164 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
165 platformy: Win32, Unix i BeOS.
166
167 %package -n wxBase-devel
168 Summary:        wxBase headers needed for developping with wxBase
169 Summary(pl):    Pliki nag³ówkowe do wxBase
170 Group:          X11/Development/Libraries
171 Requires:       %{name}-devel = %{version}-%{release}
172 Requires:       wxBase = %{version}-%{release}
173
174 %description -n wxBase-devel
175 Header files for wxBase. You need them to develop programs using
176 wxBase.
177
178 %description -n wxBase-devel -l pl
179 Pliki nag³ówkowe do biblioteki wxBase.
180
181 %package -n wxBase-unicode
182 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
183 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
184 Group:          X11/Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description -n wxBase-unicode
188 wxBase is a collection of C++ classes providing basic data structures
189 (strings, lists, arrays), powerful wxDateTime class for date
190 manipulations, portable wrappers around many OS-specific functions
191 allowing to build the same program under all supported folders,
192 wxThread class for writing multithreaded programs using either Win32
193 or POSIX threads and much more. wxBase currently supports the
194 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
195 HP-UX, ...) and BeOS. This version is build with UNICODE support.
196
197 %description -n wxBase-unicode -l pl
198 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
199 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
200 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
201 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
202 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
203 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
204 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
205 UNICODE.
206
207 %package -n wxBase-unicode-devel
208 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
209 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
210 Group:          X11/Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       wxBase-unicode = %{version}-%{release}
213
214 %description -n wxBase-unicode-devel
215 Header files for wxBase. You need them to develop programs using
216 UNICODE-enabled wxBase.
217
218 %description -n wxBase-unicode-devel -l pl
219 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
220
221 %package -n wxGTK2
222 Summary:        wxGTK2 library
223 Summary(pl):    Biblioteka wxGTK2
224 Group:          X11/Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Obsoletes:      wxGTK2-univ
227
228 %description -n wxGTK2
229 wxWidgets library using GTK2 widgets.
230
231 %description -n wxGTK2 -l pl
232 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
233
234 %package -n wxGTK2-devel
235 Summary:        Header files for wxGTK2 library
236 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
237 Group:          X11/Development/Libraries
238 Requires:       wxBase-devel = %{version}-%{release}
239 Requires:       wxGTK2 = %{version}-%{release}
240 Obsoletes:      wxGTK2-univ-devel
241
242 %description -n wxGTK2-devel
243 Header files for wxWidgets library using GTK2 widgets.
244
245 %description -n wxGTK2-devel -l pl
246 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
247
248 %package -n wxGTK2-gl
249 Summary:        GL canvas library for wxGTK2
250 Summary(pl):    Biblioteka GL dla wxGTK2
251 Group:          X11/Libraries
252 Requires:       wxGTK2 = %{version}-%{release}
253 Obsoletes:      wxGTK2-univ-gl
254
255 %description -n wxGTK2-gl
256 wxGTK2 GL canvas library.
257
258 %description -n wxGTK2-gl -l pl
259 Biblioteka GL dla wxGTK2.
260
261 %package -n wxGTK2-gl-devel
262 Summary:        Development files for GL canvas library for wxGTK2
263 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
264 Group:          X11/Development/Libraries
265 Requires:       wxGTK2-devel = %{version}-%{release}
266 Requires:       wxGTK2-gl = %{version}-%{release}
267 Requires:       OpenGL-GLU-devel
268 Obsoletes:      wxGTK2-univ-gl-devel
269
270 %description -n wxGTK2-gl-devel
271 Development files for wxGTK2 GL canvas library.
272
273 %description -n wxGTK2-gl-devel -l pl
274 Pliki programistyczne biblioteki GL dla wxGTK2.
275
276 %package -n wxGTK2-unicode
277 Summary:        wxGTK2 library with UNICODE support
278 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
279 Group:          X11/Libraries
280 Requires:       %{name} = %{version}-%{release}
281 Obsoletes:      wxGTK2-univ-unicode
282
283 %description -n wxGTK2-unicode
284 wxWidgets library using GTK2 widgets with UNICODE support.
285
286 %description -n wxGTK2-unicode -l pl
287 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
288
289 %package -n wxGTK2-unicode-devel
290 Summary:        Header files for wxGTK2 library with UNICODE support
291 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
292 Group:          X11/Development/Libraries
293 Requires:       wxBase-unicode-devel = %{version}-%{release}
294 Requires:       wxGTK2-unicode = %{version}-%{release}
295 Obsoletes:      wxGTK2-univ-unicode-devel
296
297 %description -n wxGTK2-unicode-devel
298 Header files for wxWidgets library using GTK2 widgets with UNICODE
299 support.
300
301 %description -n wxGTK2-unicode-devel -l pl
302 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
303 obs³ug± UNICODE.
304
305 %package -n wxGTK2-unicode-gl
306 Summary:        GL canvas library for wxGTK2 with UNICODE support
307 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
308 Group:          X11/Libraries
309 Requires:       wxGTK2-unicode = %{version}-%{release}
310 Obsoletes:      wxGTK2-univ-unicode-gl
311
312 %description -n wxGTK2-unicode-gl
313 GL canvas library for wxGTK2 with UNICODE support.
314
315 %description -n wxGTK2-unicode-gl -l pl
316 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
317
318 %package -n wxGTK2-unicode-gl-devel
319 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
320 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
321 Group:          X11/Development/Libraries
322 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
323 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
324 Requires:       OpenGL-GLU-devel
325 Obsoletes:      wxGTK2-univ-unicode-gl-devel
326
327 %description -n wxGTK2-unicode-gl-devel
328 Development files for GL canvas library for wxGTK2 with UNICODE
329 support.
330
331 %description -n wxGTK2-unicode-gl-devel -l pl
332 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
333
334 %package utils
335 Summary:        Misc utils from wxWidgets project
336 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
337 Group:          X11/Development/Tools
338 Requires:       wxX11 = %{version}-%{release}
339 Obsoletes:      wxWindows-utils
340
341 %description utils
342 Misc utils from wxWidgets project: helpviewer, makegen, etc.
343
344 %description utils -l pl
345 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
346
347 %package -n wxX11
348 Summary:        wxUniversal-based wxX11 library
349 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
350 Group:          X11/Libraries
351 Requires:       %{name} = %{version}-%{release}
352 Obsoletes:      wxX11-univ
353
354 %description -n wxX11
355 wxUniversal-based wxX11 library.
356
357 %description -n wxX11 -l pl
358 Oparta na wxUniversal biblioteka wxX11.
359
360 %package -n wxX11-devel
361 Summary:        Header files for wxUniversal-based wxX11 library
362 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
363 Group:          X11/Libraries
364 Requires:       %{name}-devel = %{version}-%{release}
365 Requires:       wxX11 = %{version}-%{release}
366 Obsoletes:      wxX11-univ-devel
367
368 %description -n wxX11-devel
369 Header files for wxUniversal-based wxX11 library.
370
371 %description -n wxX11-devel -l pl
372 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
373
374 %package -n wxX11-gl
375 Summary:        GL canvas library for wxUniversal-based wxX11
376 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
377 Group:          X11/Libraries
378 Requires:       wxX11 = %{version}-%{release}
379 Obsoletes:      wxX11-univ-gl
380
381 %description -n wxX11-gl
382 GL canvas library for wxUniversal-based wxX11.
383
384 %description -n wxX11-gl -l pl
385 Biblioteka GL dla opartej na wxUniversal wxX11.
386
387 %package -n wxX11-gl-devel
388 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
389 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
390 Group:          X11/Development/Libraries
391 Requires:       wxX11-gl = %{version}-%{release}
392 Requires:       wxX11-devel = %{version}-%{release}
393 Requires:       OpenGL-GLU-devel
394 Obsoletes:      wxX11-univ-gl-devel
395
396 %description -n wxX11-gl-devel
397 Development files for GL canvas library for wxUniversal-based wxX11.
398
399 %description -n wxX11-gl-devel -l pl
400 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
401
402 %package -n wxX11-unicode
403 Summary:        wxUniversal-based wxX11 library with UNICODE support
404 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
405 Group:          X11/Libraries
406 Requires:       %{name} = %{version}-%{release}
407 Obsoletes:      wxX11-univ-unicode
408
409 %description -n wxX11-unicode
410 wxUniversal-based wxX11 library with UNICODE support.
411
412 %description -n wxX11-unicode -l pl
413 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
414
415 %package -n wxX11-unicode-devel
416 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
417 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
418 Group:          X11/Development/Libraries
419 Requires:       %{name}-devel = %{version}-%{release}
420 Requires:       wxX11-unicode = %{version}-%{release}
421 Obsoletes:      wxX11-univ-unicode-devel
422
423 %description -n wxX11-unicode-devel
424 Header files for wxUniversal-based wxX11 library with UNICODE support.
425
426 %description -n wxX11-unicode-devel -l pl
427 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
428
429 %package -n wxX11-unicode-gl
430 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
431 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
432 Group:          X11/Libraries
433 Requires:       wxX11-unicode = %{version}-%{release}
434 Obsoletes:      wxX11-univ-unicode-gl
435
436 %description -n wxX11-unicode-gl
437 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
438
439 %description -n wxX11-unicode-gl -l pl
440 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
441
442 %package -n wxX11-unicode-gl-devel
443 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
444 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
445 Group:          X11/Development/Libraries
446 Requires:       wxX11-unicode-gl = %{version}-%{release}
447 Requires:       wxX11-unicode-devel = %{version}-%{release}
448 Requires:       OpenGL-GLU-devel
449 Obsoletes:      wxX11-univ-unicode-gl-devel
450
451 %description -n wxX11-unicode-gl-devel
452 Development files for GL canvas library for wxUniversal-based wxX11
453 with UNICODE support.
454
455 %description -n wxX11-unicode-gl-devel -l pl
456 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
457 obs³ug± UNICODE.
458
459 %prep
460 %setup -q -n %{name}-%{version}-%{_rc}
461 %patch0 -p1
462 %patch1 -p1
463 %patch2 -p1
464 %patch3 -p1
465 %patch4 -p1
466 %patch5 -p1
467
468 %build
469 # if bakefiles rebuild is needed:
470 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
471 #cd build/bakefiles
472 #bakefile_gen -f autoconf
473 #cd ../..
474 #%endif
475 cp -f /usr/share/automake/config.sub .
476 %{__aclocal} -I build/aclocal
477 %{__autoconf}
478
479 CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
480 # avoid adding -s to LDFLAGS
481 LDFLAGS=" "; export LDFLAGS
482 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
483         --enable-plugins \
484         --enable-std_iostreams \
485         --without-sdl \
486         --with-opengl \
487         --enable-calendar \
488         --enable-controls \
489         --enable-tabdialog"
490
491 gui='--with-gtk'
492 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
493         '--enable-unicode' ; do
494         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
495         mkdir $objdir
496         cd $objdir
497         ../%configure \
498                 ${args} \
499                 ${gui} \
500                 --disable-universal \
501                 ${unicode}
502         %{__make}
503         %{__make} -C contrib/src
504         cd ..
505 done
506
507 %if %{with x11}
508 gui='--with-x11'
509 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
510         '--enable-unicode' ; do
511         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
512         mkdir $objdir
513         cd $objdir
514         ../%configure \
515                 ${args} \
516                 ${gui} \
517                 --enable-universal \
518                 ${unicode}
519         %{__make}
520         %{__make} -C contrib/src
521         if echo $objdir| grep -q disable-unicode ; then
522                 %{__make} -C utils
523                 %{__make} -C utils/emulator
524                 %{__make} -C utils/hhp2cached
525                 %{__make} -C contrib/utils
526         fi
527         cd ..
528 done
529 %endif
530
531 cd locale
532 %{__make} allmo
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT%{_bindir}
537
538 gui='--with-gtk'
539 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
540         '--enable-unicode' ; do
541         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
542         cd $objdir
543         %{__make} install \
544                 prefix=$RPM_BUILD_ROOT%{_prefix} \
545                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
546                 bindir=$RPM_BUILD_ROOT%{_bindir} \
547                 datadir=$RPM_BUILD_ROOT%{_datadir} \
548                 libdir=$RPM_BUILD_ROOT%{_libdir} \
549                 mandir=$RPM_BUILD_ROOT%{_mandir} \
550                 includedir=$RPM_BUILD_ROOT%{_includedir}
551
552         %{__make} -C contrib/src install \
553                 prefix=$RPM_BUILD_ROOT%{_prefix} \
554                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
555                 bindir=$RPM_BUILD_ROOT%{_bindir} \
556                 datadir=$RPM_BUILD_ROOT%{_datadir} \
557                 libdir=$RPM_BUILD_ROOT%{_libdir} \
558                 mandir=$RPM_BUILD_ROOT%{_mandir} \
559                 includedir=$RPM_BUILD_ROOT%{_includedir}
560         cd ..
561 done
562
563 %if %{with x11}
564 gui='--with-x11'
565 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
566         '--enable-unicode' ; do
567         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
568         cd $objdir
569         %{__make} install \
570                 prefix=$RPM_BUILD_ROOT%{_prefix} \
571                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
572                 bindir=$RPM_BUILD_ROOT%{_bindir} \
573                 datadir=$RPM_BUILD_ROOT%{_datadir} \
574                 libdir=$RPM_BUILD_ROOT%{_libdir} \
575                 mandir=$RPM_BUILD_ROOT%{_mandir} \
576                 includedir=$RPM_BUILD_ROOT%{_includedir}
577         if echo $objdir| grep -q disable-unicode ; then
578 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
579                 # TODO: install default config files and default backgrouds
580                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
581                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
582                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
583                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
584 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
585                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
586 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
587 #               install -m644 utils/makegen/templates/* \
588 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
589 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
590 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
591 #               install contrib/utils/wxrcedit/df/* \
592 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
593         fi
594
595         %{__make} -C contrib/src install \
596                 prefix=$RPM_BUILD_ROOT%{_prefix} \
597                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
598                 bindir=$RPM_BUILD_ROOT%{_bindir} \
599                 datadir=$RPM_BUILD_ROOT%{_datadir} \
600                 libdir=$RPM_BUILD_ROOT%{_libdir} \
601                 mandir=$RPM_BUILD_ROOT%{_mandir} \
602                 includedir=$RPM_BUILD_ROOT%{_includedir}
603
604         cd ..
605 done
606 %endif
607
608 set -x
609
610 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
611 do
612         b=`basename $i`
613         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
614 done
615
616 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
617 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
618 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
619
620 %find_lang wxstd
621
622 %clean
623 rm -rf $RPM_BUILD_ROOT
624
625 %post   -n wxBase -p /sbin/ldconfig
626 %postun -n wxBase -p /sbin/ldconfig
627
628 %post   -n wxBase-unicode -p /sbin/ldconfig
629 %postun -n wxBase-unicode -p /sbin/ldconfig
630
631 %post   -n wxGTK2 -p /sbin/ldconfig
632 %postun -n wxGTK2 -p /sbin/ldconfig
633
634 %post   -n wxGTK2-gl -p /sbin/ldconfig
635 %postun -n wxGTK2-gl -p /sbin/ldconfig
636
637 %post   -n wxGTK2-unicode -p /sbin/ldconfig
638 %postun -n wxGTK2-unicode -p /sbin/ldconfig
639
640 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
641 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
642
643 %post   -n wxX11 -p /sbin/ldconfig
644 %postun -n wxX11 -p /sbin/ldconfig
645
646 %post   -n wxX11-unicode -p /sbin/ldconfig
647 %postun -n wxX11-unicode -p /sbin/ldconfig
648
649 %define _libf %{?with_debug:d}
650 %define _configf %{?with_debug:-debug-2.8}
651
652 %files -f wxstd.lang
653 %defattr(644,root,root,755)
654 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
655
656 %files devel
657 %defattr(644,root,root,755)
658 %doc docs/html
659 %doc docs/tech docs/univ
660 %{_includedir}/wx*
661 %dir %{_libdir}/wx
662 %dir %{_libdir}/wx/include
663 %dir %{_libdir}/wx/config
664 %{_aclocaldir}/*.m4
665
666 %files examples
667 %defattr(644,root,root,755)
668 %{_examplesdir}/%{name}-%{version}
669
670 %if %{with x11}
671 %files HelpGen
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_bindir}/HelpGen
674 %endif
675
676 %if %{with ansi}
677 %files -n wxBase
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
680 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
681 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
682
683 %files -n wxBase-devel
684 %defattr(644,root,root,755)
685 %{_libdir}/libwx_base%{_libf}-*.so
686 %{_libdir}/libwx_base%{_libf}_*.so
687 %endif
688
689 %files -n wxBase-unicode
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
692 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
693 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
694
695 %files -n wxBase-unicode-devel
696 %defattr(644,root,root,755)
697 %{_libdir}/libwx_baseu%{_libf}-*.so
698 %{_libdir}/libwx_baseu%{_libf}_*.so
699
700 %if %{with ansi}
701 %files -n wxGTK2
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
704 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
705
706 %files -n wxGTK2-devel
707 %defattr(644,root,root,755)
708 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
709 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
710 %{_libdir}/wx/config/gtk2-ansi-*
711 %{_libdir}/wx/include/gtk2-ansi-*
712 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
713
714 %files -n wxGTK2-gl
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
717
718 %files -n wxGTK2-gl-devel
719 %defattr(644,root,root,755)
720 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
721 %endif
722
723 %files -n wxGTK2-unicode
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
726 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
727
728 %files -n wxGTK2-unicode-devel
729 %defattr(644,root,root,755)
730 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
731 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
732 %{_libdir}/wx/config/gtk2-unicode-*
733 %{_libdir}/wx/include/gtk2-unicode-*
734 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
735
736 %files -n wxGTK2-unicode-gl
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
739
740 %files -n wxGTK2-unicode-gl-devel
741 %defattr(644,root,root,755)
742 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
743
744 %if %{with x11}
745 %if %{with ansi}
746 %files utils
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_bindir}/*
749 %exclude %{_bindir}/HelpGen
750 %exclude %{_bindir}/wx*-config
751
752 %files -n wxX11
753 %defattr(644,root,root,755)
754 %doc docs/wxX11-readme.txt
755 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
756 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
757
758 %files -n wxX11-devel
759 %defattr(644,root,root,755)
760 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
761 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
762 %{_libdir}/wx/config/x11univ-ansi-*
763 %{_libdir}/wx/include/x11univ-ansi-*
764 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
765
766 %files -n wxX11-gl
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
769
770 %files -n wxX11-gl-devel
771 %defattr(644,root,root,755)
772 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
773 %endif
774
775 %files -n wxX11-unicode
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
778 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
779
780 %files -n wxX11-unicode-devel
781 %defattr(644,root,root,755)
782 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
783 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
784 %{_libdir}/wx/config/x11univ-unicode-*
785 %{_libdir}/wx/include/x11univ-unicode-*
786 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
787
788 %files -n wxX11-unicode-gl
789 %defattr(644,root,root,755)
790 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
791
792 %files -n wxX11-unicode-gl-devel
793 %defattr(644,root,root,755)
794 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
795 %endif
This page took 2.832085 seconds and 4 git commands to generate.