]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- BR: pkgconfig
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_with     x11                     # with wxX11 packages (broken)
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.5.5
13 Release:        0.1
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/wxAll-%{version}.tar.bz2
17 # Source0-md5:  108ab356e7ea5c495e1c1b2a2e803ba6
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-utils.patch
20 Patch2:         %{name}-ogl.patch
21 Patch3:         %{name}-ac.patch
22 Patch4:         %{name}-gif0delay.patch
23 URL:            http://www.wxWidgets.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  autoconf >= 2.58
27 BuildRequires:  automake
28 BuildRequires:  bakefile >= 0.1.7
29 BuildRequires:  cppunit-devel
30 BuildRequires:  esound-devel
31 BuildRequires:  flex
32 BuildRequires:  gettext-devel
33 BuildRequires:  gtk+2-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libmng-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig
41 Obsoletes:      wxwin-common
42 Obsoletes:      wxGTK
43 Obsoletes:      wxGTK-devel
44 Obsoletes:      wxGTK-gl
45 Obsoletes:      wxGTK-gl-devel
46 Obsoletes:      wxGTK-univ
47 Obsoletes:      wxGTK-univ-devel
48 Obsoletes:      wxGTK-univ-gl
49 Obsoletes:      wxGTK-univ-gl-devel
50 Obsoletes:      wxGTK2-univ
51 Obsoletes:      wxGTK2-univ-devel
52 Obsoletes:      wxGTK2-univ-gl
53 Obsoletes:      wxGTK2-univ-gl-devel
54 Obsoletes:      wxGTK2-univ-unicode
55 Obsoletes:      wxGTK2-univ-unicode-devel
56 Obsoletes:      wxGTK2-univ-unicode-gl
57 Obsoletes:      wxGTK2-univ-unicode-gl-devel
58 Obsoletes:      wxMotif
59 Obsoletes:      wxMotif-devel
60 Obsoletes:      wxMotif-gl
61 Obsoletes:      wxMotif-gl-devel
62 Obsoletes:      wxWindows
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     %{_datadir}
66
67 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
68
69 %description
70 wxWidgets is a free C++ library for cross-platform GUI development.
71 With wxWidgets, you can create applications for different GUIs (GTK+,
72 Motif/LessTif, MS Windows, Mac) from the same source code.
73
74 %description -l pl
75 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
76 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
77 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
78 Windows, Mac) z tego samego kodu ¼ród³owego.
79
80 %package afm
81 Summary:        Font metrics common for wxGTK, wxGTK2, wxMotif i wxX11
82 Summary(pl):    Metryki fontów wspólne dla wxGTK, wxGTK2, wxMotif i wxX11
83 Group:          X11/Libraries
84 Requires:       %{name} = %{version}-%{release}
85 Obsoletes:      wxwin-afm
86 Obsoletes:      wxWindows-afm
87
88 %description afm
89 Font metrics (in AFM format) common for wxGTK, wxGTK2, wxMotif and
90 wxX11 libraries.
91
92 %description afm -l pl
93 Metryki fontów (w formacie AFM) wspólne dla bibliotek wxGTK, wxGTK2,
94 wxMotif i wxX11.
95
96 %package devel
97 Summary:        wxWidgets header files and development documentation
98 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
99 Group:          X11/Development/Libraries
100 Requires:       libstdc++-devel
101 Obsoletes:      wxWindows-devel
102
103 %description devel
104 Header files and development documentation for the wxWidgets
105 libraries.
106
107 %description devel -l pl
108 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
109
110 %package examples
111 Summary:        wxWidgets example programs
112 Summary(pl):    Przyk³adowe programy wxWidgets
113 Group:          X11/Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115 Obsoletes:      wxWindows-examples
116
117 %description examples
118 wxWidgets example programs.
119
120 %description examples -l pl
121 Przyk³adowe programy wxWidgets.
122
123 %package HelpGen
124 Summary:        Help file generator for wxWidgets programs
125 Summary(pl):    Generator plików pomocy dla programów wxWidgets
126 Group:          Development/Tools
127 Requires:       wxBase = %{version}-%{release}
128 Obsoletes:      wxWindows-HelpGen
129
130 %description HelpGen
131 Help file generator for wxWidgets programs.
132
133 %description HelpGen -l pl
134 Generator plików pomocy dla programów wxWidgets.
135
136 %package -n wxBase
137 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
138 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
139 Group:          X11/Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description -n wxBase
143 wxBase is a collection of C++ classes providing basic data structures
144 (strings, lists, arrays), powerful wxDateTime class for date
145 manipulations, portable wrappers around many OS-specific functions
146 allowing to build the same program under all supported folders,
147 wxThread class for writing multithreaded programs using either Win32
148 or POSIX threads and much more. wxBase currently supports the
149 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
150 HP-UX, ...) and BeOS.
151
152 %description -n wxBase -l pl
153 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
154 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
155 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
156 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
157 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
158 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
159 platformy: Win32, Unix i BeOS.
160
161 %package -n wxBase-devel
162 Summary:        wxBase headers needed for developping with wxBase
163 Summary(pl):    Pliki nag³ówkowe do wxBase
164 Group:          X11/Development/Libraries
165 Requires:       %{name}-devel = %{version}-%{release}
166 Requires:       wxBase = %{version}-%{release}
167
168 %description -n wxBase-devel
169 Header files for wxBase. You need them to develop programs using
170 wxBase.
171
172 %description -n wxBase-devel -l pl
173 Pliki nag³ówkowe do biblioteki wxBase.
174
175 %package -n wxBase-unicode
176 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
177 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
178 Group:          X11/Libraries
179 Requires:       %{name} = %{version}-%{release}
180
181 %description -n wxBase-unicode
182 wxBase is a collection of C++ classes providing basic data structures
183 (strings, lists, arrays), powerful wxDateTime class for date
184 manipulations, portable wrappers around many OS-specific functions
185 allowing to build the same program under all supported folders,
186 wxThread class for writing multithreaded programs using either Win32
187 or POSIX threads and much more. wxBase currently supports the
188 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
189 HP-UX, ...) and BeOS. This version is build with UNICODE support.
190
191 %description -n wxBase-unicode -l pl
192 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
193 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
194 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
195 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
196 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
197 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
198 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
199 UNICODE.
200
201 %package -n wxBase-unicode-devel
202 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
203 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
204 Group:          X11/Development/Libraries
205 Requires:       %{name}-devel = %{version}-%{release}
206 Requires:       wxBase-unicode = %{version}-%{release}
207
208 %description -n wxBase-unicode-devel
209 Header files for wxBase. You need them to develop programs using
210 UNICODE-enabled wxBase.
211
212 %description -n wxBase-unicode-devel -l pl
213 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
214
215 %package -n wxGTK2
216 Summary:        wxGTK2 library
217 Summary(pl):    Biblioteka wxGTK2
218 Group:          X11/Libraries
219 Requires:       %{name} = %{version}-%{release}
220 #Requires:      %{name}-afm = %{version}-%{release}
221 Obsoletes:      wxGTK2-univ
222
223 %description -n wxGTK2
224 wxWidgets library using GTK2 widgets.
225
226 %description -n wxGTK2 -l pl
227 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
228
229 %package -n wxGTK2-devel
230 Summary:        Header files for wxGTK2 library
231 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
232 Group:          X11/Development/Libraries
233 Requires:       wxBase-devel = %{version}-%{release}
234 Requires:       wxGTK2 = %{version}-%{release}
235 Obsoletes:      wxGTK2-univ-devel
236
237 %description -n wxGTK2-devel
238 Header files for wxWidgets library using GTK2 widgets.
239
240 %description -n wxGTK2-devel -l pl
241 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
242
243 %package -n wxGTK2-gl
244 Summary:        GL canvas library for wxGTK2
245 Summary(pl):    Biblioteka GL dla wxGTK2
246 Group:          X11/Libraries
247 Requires:       wxGTK2 = %{version}-%{release}
248 Requires:       OpenGL
249 Obsoletes:      wxGTK2-univ-gl
250
251 %description -n wxGTK2-gl
252 wxGTK2 GL canvas library.
253
254 %description -n wxGTK2-gl -l pl
255 Biblioteka GL dla wxGTK2.
256
257 %package -n wxGTK2-gl-devel
258 Summary:        Development files for GL canvas library for wxGTK2
259 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
260 Group:          X11/Development/Libraries
261 Requires:       wxGTK2-devel = %{version}-%{release}
262 Requires:       wxGTK2-gl = %{version}-%{release}
263 Requires:       OpenGL-devel
264 Obsoletes:      wxGTK2-univ-gl-devel
265
266 %description -n wxGTK2-gl-devel
267 Development files for wxGTK2 GL canvas library.
268
269 %description -n wxGTK2-gl-devel -l pl
270 Pliki programistyczne biblioteki GL dla wxGTK2.
271
272 %package -n wxGTK2-unicode
273 Summary:        wxGTK2 library with UNICODE support
274 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
275 Group:          X11/Libraries
276 Requires:       %{name} = %{version}-%{release}
277 #Requires:      %{name}-afm = %{version}-%{release}
278 Obsoletes:      wxGTK2-univ-unicode
279
280 %description -n wxGTK2-unicode
281 wxWidgets library using GTK2 widgets with UNICODE support.
282
283 %description -n wxGTK2-unicode -l pl
284 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
285
286 %package -n wxGTK2-unicode-devel
287 Summary:        Header files for wxGTK2 library with UNICODE support
288 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
289 Group:          X11/Development/Libraries
290 Requires:       wxBase-unicode-devel = %{version}-%{release}
291 Requires:       wxGTK2-unicode = %{version}-%{release}
292 Obsoletes:      wxGTK2-univ-unicode-devel
293
294 %description -n wxGTK2-unicode-devel
295 Header files for wxWidgets library using GTK2 widgets with UNICODE
296 support.
297
298 %description -n wxGTK2-unicode-devel -l pl
299 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
300 obs³ug± UNICODE.
301
302 %package -n wxGTK2-unicode-gl
303 Summary:        GL canvas library for wxGTK2 with UNICODE support
304 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
305 Group:          X11/Libraries
306 Requires:       wxGTK2-unicode = %{version}-%{release}
307 Requires:       OpenGL
308 Obsoletes:      wxGTK2-univ-unicode-gl
309
310 %description -n wxGTK2-unicode-gl
311 GL canvas library for wxGTK2 with UNICODE support.
312
313 %description -n wxGTK2-unicode-gl -l pl
314 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
315
316 %package -n wxGTK2-unicode-gl-devel
317 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
318 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
319 Group:          X11/Development/Libraries
320 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
321 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
322 Requires:       OpenGL-devel
323 Obsoletes:      wxGTK2-univ-unicode-gl-devel
324
325 %description -n wxGTK2-unicode-gl-devel
326 Development files for GL canvas library for wxGTK2 with UNICODE
327 support.
328
329 %description -n wxGTK2-unicode-gl-devel -l pl
330 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
331
332 %package utils
333 Summary:        Misc utils from wxWidgets project
334 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
335 Group:          X11/Development/Tools
336 Requires:       wxX11 = %{version}-%{release}
337 Obsoletes:      wxWindows-utils
338
339 %description utils
340 Misc utils from wxWidgets project: helpviewer, makegen, etc.
341
342 %description utils -l pl
343 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
344
345 %package -n wxX11
346 Summary:        wxUniversal-based wxX11 library
347 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
348 Group:          X11/Libraries
349 Requires:       %{name} = %{version}-%{release}
350 #Requires:      %{name}-afm = %{version}-%{release}
351 Obsoletes:      wxX11-univ
352
353 %description -n wxX11
354 wxUniversal-based wxX11 library.
355
356 %description -n wxX11 -l pl
357 Oparta na wxUniversal biblioteka wxX11.
358
359 %package -n wxX11-devel
360 Summary:        Header files for wxUniversal-based wxX11 library
361 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
362 Group:          X11/Libraries
363 Requires:       %{name}-devel = %{version}-%{release}
364 Requires:       wxX11 = %{version}-%{release}
365 Obsoletes:      wxX11-univ-devel
366
367 %description -n wxX11-devel
368 Header files for wxUniversal-based wxX11 library.
369
370 %description -n wxX11-devel -l pl
371 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
372
373 %package -n wxX11-gl
374 Summary:        GL canvas library for wxUniversal-based wxX11
375 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
376 Group:          X11/Libraries
377 Requires:       wxX11 = %{version}-%{release}
378 Requires:       OpenGL
379 Obsoletes:      wxX11-univ-gl
380
381 %description -n wxX11-gl
382 GL canvas library for wxUniversal-based wxX11.
383
384 %description -n wxX11-gl -l pl
385 Biblioteka GL dla opartej na wxUniversal wxX11.
386
387 %package -n wxX11-gl-devel
388 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
389 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
390 Group:          X11/Development/Libraries
391 Requires:       wxX11-gl = %{version}-%{release}
392 Requires:       wxX11-devel = %{version}-%{release}
393 Requires:       OpenGL-devel
394 Obsoletes:      wxX11-univ-gl-devel
395
396 %description -n wxX11-gl-devel
397 Development files for GL canvas library for wxUniversal-based wxX11.
398
399 %description -n wxX11-gl-devel -l pl
400 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
401
402 %package -n wxX11-unicode
403 Summary:        wxUniversal-based wxX11 library with UNICODE support
404 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
405 Group:          X11/Libraries
406 Requires:       %{name} = %{version}-%{release}
407 #Requires:      %{name}-afm = %{version}-%{release}
408 Obsoletes:      wxX11-univ-unicode
409
410 %description -n wxX11-unicode
411 wxUniversal-based wxX11 library with UNICODE support.
412
413 %description -n wxX11-unicode -l pl
414 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
415
416 %package -n wxX11-unicode-devel
417 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
418 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
419 Group:          X11/Development/Libraries
420 Requires:       %{name}-devel = %{version}-%{release}
421 Requires:       wxX11-unicode = %{version}-%{release}
422 Obsoletes:      wxX11-univ-unicode-devel
423
424 %description -n wxX11-unicode-devel
425 Header files for wxUniversal-based wxX11 library with UNICODE support.
426
427 %description -n wxX11-unicode-devel -l pl
428 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
429
430 %package -n wxX11-unicode-gl
431 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
432 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
433 Group:          X11/Libraries
434 Requires:       wxX11-unicode = %{version}-%{release}
435 Requires:       OpenGL
436 Obsoletes:      wxX11-univ-unicode-gl
437
438 %description -n wxX11-unicode-gl
439 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
440
441 %description -n wxX11-unicode-gl -l pl
442 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
443
444 %package -n wxX11-unicode-gl-devel
445 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
446 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
447 Group:          X11/Development/Libraries
448 Requires:       wxX11-unicode-gl = %{version}-%{release}
449 Requires:       wxX11-unicode-devel = %{version}-%{release}
450 Requires:       OpenGL-devel
451 Obsoletes:      wxX11-univ-unicode-gl-devel
452
453 %description -n wxX11-unicode-gl-devel
454 Development files for GL canvas library for wxUniversal-based wxX11
455 with UNICODE support.
456
457 %description -n wxX11-unicode-gl-devel -l pl
458 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
459 obs³ug± UNICODE.
460
461 %prep
462 %setup -q
463 %patch0 -p1
464 %patch1 -p1
465 %patch2 -p1
466 %patch3 -p1
467 %patch4 -p1
468
469 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
470 echo 'AC_DEFUN([AC_BAKEFILE_PROG_CC],[:])' > fake-ac_bakefile_prog_cc.m4
471 echo 'AC_DEFUN([AC_BAKEFILE_PROG_CXX],[:])' > fake-ac_bakefile_prog_cxx.m4
472
473 # bakefile.m4 from 0.1.7
474 tail -n +1481 aclocal.m4 | head -n 1396 > bakefile.m4
475
476 %build
477 # if bakefiles rebuild is needed:
478 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.7"
479 #cd build/bakefiles
480 #bakefile_gen -f autoconf
481 #cd ../..
482 #%endif
483 cp -f /usr/share/automake/config.sub .
484 %{__aclocal} -I .
485 %{__autoconf}
486
487 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
488 # avoid adding -s to LDFLAGS
489 LDFLAGS=" "; export LDFLAGS
490 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
491         --enable-plugins \
492         --enable-std_iostreams \
493         --without-sdl \
494         --with-opengl \
495         --enable-calendar \
496         --enable-controls \
497         --enable-tabdialog"
498
499 gui='--with-gtk --enable-gtk2'
500 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
501         '--enable-unicode' ; do
502         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
503         mkdir $objdir
504         cd $objdir
505         ../%configure \
506                 ${args} \
507                 ${gui} \
508                 --disable-universal \
509                 ${unicode}
510         %{__make}
511         %{__make} -C contrib/src
512         cd ..
513 done
514
515 %if %{with x11}
516 gui='--with-x11'
517 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
518         '--enable-unicode' ; do
519         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
520         mkdir $objdir
521         cd $objdir
522         ../%configure \
523                 ${args} \
524                 ${gui} \
525                 --enable-universal \
526                 ${unicode}
527         %{__make}
528         %{__make} -C contrib/src
529         if echo $objdir| grep -q disable-unicode ; then
530                 %{__make} -C utils
531                 %{__make} -C utils/emulator
532                 %{__make} -C utils/hhp2cached
533                 %{__make} -C contrib/utils
534         fi
535         cd ..
536 done
537 %endif
538
539 cd locale
540 %{__make} allmo
541
542 %install
543 rm -rf $RPM_BUILD_ROOT
544 install -d $RPM_BUILD_ROOT%{_bindir}
545
546 gui='--with-gtk --enable-gtk2'
547 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
548         '--enable-unicode' ; do
549         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
550         cd $objdir
551         %{__make} install \
552                 prefix=$RPM_BUILD_ROOT%{_prefix} \
553                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
554                 bindir=$RPM_BUILD_ROOT%{_bindir} \
555                 datadir=$RPM_BUILD_ROOT%{_datadir} \
556                 libdir=$RPM_BUILD_ROOT%{_libdir} \
557                 mandir=$RPM_BUILD_ROOT%{_mandir} \
558                 includedir=$RPM_BUILD_ROOT%{_includedir}
559
560         %{__make} -C contrib/src install \
561                 prefix=$RPM_BUILD_ROOT%{_prefix} \
562                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
563                 bindir=$RPM_BUILD_ROOT%{_bindir} \
564                 datadir=$RPM_BUILD_ROOT%{_datadir} \
565                 libdir=$RPM_BUILD_ROOT%{_libdir} \
566                 mandir=$RPM_BUILD_ROOT%{_mandir} \
567                 includedir=$RPM_BUILD_ROOT%{_includedir}
568         cd ..
569 done
570
571 %if %{with x11}
572 gui='--with-x11'
573 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
574         '--enable-unicode' ; do
575         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
576         cd $objdir
577         %{__make} install \
578                 prefix=$RPM_BUILD_ROOT%{_prefix} \
579                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
580                 bindir=$RPM_BUILD_ROOT%{_bindir} \
581                 datadir=$RPM_BUILD_ROOT%{_datadir} \
582                 libdir=$RPM_BUILD_ROOT%{_libdir} \
583                 mandir=$RPM_BUILD_ROOT%{_mandir} \
584                 includedir=$RPM_BUILD_ROOT%{_includedir}
585         if echo $objdir| grep -q disable-unicode ; then
586 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
587                 # TODO: install default config files and default backgrouds
588                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
589                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
590                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
591                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
592 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
593                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
594 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
595 #               install -m644 utils/makegen/templates/* \
596 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
597 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
598 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
599 #               install contrib/utils/wxrcedit/df/* \
600 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
601         fi
602
603         %{__make} -C contrib/src install \
604                 prefix=$RPM_BUILD_ROOT%{_prefix} \
605                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
606                 bindir=$RPM_BUILD_ROOT%{_bindir} \
607                 datadir=$RPM_BUILD_ROOT%{_datadir} \
608                 libdir=$RPM_BUILD_ROOT%{_libdir} \
609                 mandir=$RPM_BUILD_ROOT%{_mandir} \
610                 includedir=$RPM_BUILD_ROOT%{_includedir}
611
612         cd ..
613 done
614 %endif
615
616 set -x
617
618 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
619 do
620         b=`basename $i`
621         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
622 done
623
624 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
625 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
626 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
627
628 %find_lang wxstd
629
630 %clean
631 rm -rf $RPM_BUILD_ROOT
632
633 %post   -n wxBase -p /sbin/ldconfig
634 %postun -n wxBase -p /sbin/ldconfig
635
636 %post   -n wxBase-unicode -p /sbin/ldconfig
637 %postun -n wxBase-unicode -p /sbin/ldconfig
638
639 %post   -n wxGTK2 -p /sbin/ldconfig
640 %postun -n wxGTK2 -p /sbin/ldconfig
641
642 %post   -n wxGTK2-gl -p /sbin/ldconfig
643 %postun -n wxGTK2-gl -p /sbin/ldconfig
644
645 %post   -n wxGTK2-unicode -p /sbin/ldconfig
646 %postun -n wxGTK2-unicode -p /sbin/ldconfig
647
648 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
649 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
650
651 %post   -n wxX11 -p /sbin/ldconfig
652 %postun -n wxX11 -p /sbin/ldconfig
653
654 %post   -n wxX11-unicode -p /sbin/ldconfig
655 %postun -n wxX11-unicode -p /sbin/ldconfig
656
657 %files -f wxstd.lang
658 %defattr(644,root,root,755)
659 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
660 #%dir %{_datadir}/wx
661 #%dir %{_datadir}/wx/2.5
662
663 #%files -n wxWidgets-afm
664 #%defattr(644,root,root,755)
665 #%{_datadir}/wx/2.5/afm
666 #%{_datadir}/wx/2.5/gs_afm
667
668 %files devel
669 %defattr(644,root,root,755)
670 %doc docs/html
671 %doc docs/tech docs/univ
672 %{_includedir}/wx*
673 %dir %{_libdir}/wx
674 %dir %{_libdir}/wx/include
675 %dir %{_libdir}/wx/config
676 %{_aclocaldir}/*.m4
677
678 %files examples
679 %defattr(644,root,root,755)
680 %{_examplesdir}/%{name}-%{version}
681
682 %if %{with x11}
683 %files HelpGen
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_bindir}/HelpGen
686 %endif
687
688 %if %{with ansi}
689 %files -n wxBase
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
692 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
693 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
694
695 %files -n wxBase-devel
696 %defattr(644,root,root,755)
697 %{_libdir}/libwx_base-*.so
698 %{_libdir}/libwx_base_*.so
699 %endif
700
701 %files -n wxBase-unicode
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
704 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
705 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
706
707 %files -n wxBase-unicode-devel
708 %defattr(644,root,root,755)
709 %{_libdir}/libwx_baseu-*.so
710 %{_libdir}/libwx_baseu_*.so
711
712 %if %{with ansi}
713 %files -n wxGTK2
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
716 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
717
718 %files -n wxGTK2-devel
719 %defattr(644,root,root,755)
720 %{_libdir}/libwx_gtk2_*-*.so
721 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
722 %{_libdir}/wx/config/gtk2-ansi-*
723 %{_libdir}/wx/include/gtk2-ansi-*
724 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
725
726 %files -n wxGTK2-gl
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
729
730 %files -n wxGTK2-gl-devel
731 %defattr(644,root,root,755)
732 %{_libdir}/libwx_gtk2_ogl-*.so
733 %endif
734
735 %files -n wxGTK2-unicode
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
738 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
739
740 %files -n wxGTK2-unicode-devel
741 %defattr(644,root,root,755)
742 %{_libdir}/libwx_gtk2u_*-*.so
743 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
744 %{_libdir}/wx/config/gtk2-unicode-*
745 %{_libdir}/wx/include/gtk2-unicode-*
746 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
747
748 %files -n wxGTK2-unicode-gl
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
751
752 %files -n wxGTK2-unicode-gl-devel
753 %defattr(644,root,root,755)
754 %{_libdir}/libwx_gtk2u_ogl-*.so
755
756 %if %{with x11}
757 %if %{with ansi}
758 %files utils
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_bindir}/*
761 %exclude %{_bindir}/HelpGen
762 %exclude %{_bindir}/wx*-config
763 #%{_datadir}/wx/makegen
764 #%{_datadir}/wx/wxrcedit
765
766 %files -n wxX11
767 %defattr(644,root,root,755)
768 %doc docs/wxX11-readme.txt
769 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
770 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
771
772 %files -n wxX11-devel
773 %defattr(644,root,root,755)
774 %{_libdir}/libwx_x11univ_*-*.so
775 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
776 %{_libdir}/wx/config/x11univ-ansi-*
777 %{_libdir}/wx/include/x11univ-ansi-*
778 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
779
780 %files -n wxX11-gl
781 %defattr(644,root,root,755)
782 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
783
784 %files -n wxX11-gl-devel
785 %defattr(644,root,root,755)
786 %{_libdir}/libwx_x11univ_ogl-*.so
787 %endif
788
789 %files -n wxX11-unicode
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
792 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
793
794 %files -n wxX11-unicode-devel
795 %defattr(644,root,root,755)
796 %{_libdir}/libwx_x11univu_*-*.so
797 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
798 %{_libdir}/wx/config/x11univ-unicode-*
799 %{_libdir}/wx/include/x11univ-unicode-*
800 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
801
802 %files -n wxX11-unicode-gl
803 %defattr(644,root,root,755)
804 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
805
806 %files -n wxX11-unicode-gl-devel
807 %defattr(644,root,root,755)
808 %{_libdir}/libwx_x11univu_ogl-*.so
809 %endif
This page took 0.098974 seconds and 4 git commands to generate.