]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- switched to modular xorg, release 3
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.2
13 Release:        3
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.bz2
17 # Source0-md5:  ee0aa211febd992c8540e6c9df749b51
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 Patch4:         %{name}-x11unicode.patch
23 Patch5:         %{name}-intl.patch
24 Patch6:         %{name}-gcc4.patch
25 URL:            http://www.wxWidgets.org/
26 BuildRequires:  OpenGL-GLU-devel
27 #BuildRequires: SDL-devel
28 BuildRequires:  autoconf >= 2.58
29 BuildRequires:  automake
30 #BuildRequires: bakefile >= 0.1.9
31 BuildRequires:  cppunit-devel
32 BuildRequires:  esound-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  flex
35 BuildRequires:  gettext-devel
36 BuildRequires:  gtk+2-devel >= 2.0.0
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libmng-devel
39 BuildRequires:  libmspack-devel
40 BuildRequires:  libpng-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtiff-devel
43 BuildRequires:  libtool
44 BuildRequires:  pkgconfig
45 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
46 # these are not supported by wxWidgets
47 Obsoletes:      LDAPExplorerTool <= 0.6-1
48 Obsoletes:      abridge <= 0.4.0-1
49 # and these are replaced
50 Obsoletes:      wxGTK
51 Obsoletes:      wxGTK-devel
52 Obsoletes:      wxGTK-gl
53 Obsoletes:      wxGTK-gl-devel
54 Obsoletes:      wxGTK-univ
55 Obsoletes:      wxGTK-univ-devel
56 Obsoletes:      wxGTK-univ-gl
57 Obsoletes:      wxGTK-univ-gl-devel
58 Obsoletes:      wxGTK2-univ
59 Obsoletes:      wxGTK2-univ-devel
60 Obsoletes:      wxGTK2-univ-gl
61 Obsoletes:      wxGTK2-univ-gl-devel
62 Obsoletes:      wxGTK2-univ-unicode
63 Obsoletes:      wxGTK2-univ-unicode-devel
64 Obsoletes:      wxGTK2-univ-unicode-gl
65 Obsoletes:      wxGTK2-univ-unicode-gl-devel
66 Obsoletes:      wxMotif
67 Obsoletes:      wxMotif-devel
68 Obsoletes:      wxMotif-gl
69 Obsoletes:      wxMotif-gl-devel
70 Obsoletes:      wxWidgets-afm
71 Obsoletes:      wxWindows
72 Obsoletes:      wxWindows-afm
73 Obsoletes:      wxwin-afm
74 Obsoletes:      wxwin-common
75 Conflicts:      wxGTK2 < 2.6.0
76 Conflicts:      wxGTK2-unicode < 2.6.0
77 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
79 %define         _sysconfdir     %{_datadir}
80
81 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
82
83 %description
84 wxWidgets is a free C++ library for cross-platform GUI development.
85 With wxWidgets, you can create applications for different GUIs (GTK+,
86 Motif/LessTif, MS Windows, Mac) from the same source code.
87
88 %description -l pl
89 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
90 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
91 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
92 Windows, Mac) z tego samego kodu ¼ród³owego.
93
94 %package devel
95 Summary:        wxWidgets header files and development documentation
96 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
97 Group:          X11/Development/Libraries
98 Requires:       libstdc++-devel
99 Obsoletes:      wxWindows-devel
100
101 %description devel
102 Header files and development documentation for the wxWidgets
103 libraries.
104
105 %description devel -l pl
106 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
107
108 %package examples
109 Summary:        wxWidgets example programs
110 Summary(pl):    Przyk³adowe programy wxWidgets
111 Group:          X11/Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113 Obsoletes:      wxWindows-examples
114
115 %description examples
116 wxWidgets example programs.
117
118 %description examples -l pl
119 Przyk³adowe programy wxWidgets.
120
121 %package HelpGen
122 Summary:        Help file generator for wxWidgets programs
123 Summary(pl):    Generator plików pomocy dla programów wxWidgets
124 Group:          Development/Tools
125 Requires:       wxBase = %{version}-%{release}
126 Obsoletes:      wxWindows-HelpGen
127
128 %description HelpGen
129 Help file generator for wxWidgets programs.
130
131 %description HelpGen -l pl
132 Generator plików pomocy dla programów wxWidgets.
133
134 %package -n wxBase
135 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
136 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
137 Group:          X11/Libraries
138 Requires:       %{name} = %{version}-%{release}
139
140 %description -n wxBase
141 wxBase is a collection of C++ classes providing basic data structures
142 (strings, lists, arrays), powerful wxDateTime class for date
143 manipulations, portable wrappers around many OS-specific functions
144 allowing to build the same program under all supported folders,
145 wxThread class for writing multithreaded programs using either Win32
146 or POSIX threads and much more. wxBase currently supports the
147 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
148 HP-UX, ...) and BeOS.
149
150 %description -n wxBase -l pl
151 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
152 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
153 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
154 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
155 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
156 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
157 platformy: Win32, Unix i BeOS.
158
159 %package -n wxBase-devel
160 Summary:        wxBase headers needed for developping with wxBase
161 Summary(pl):    Pliki nag³ówkowe do wxBase
162 Group:          X11/Development/Libraries
163 Requires:       %{name}-devel = %{version}-%{release}
164 Requires:       wxBase = %{version}-%{release}
165
166 %description -n wxBase-devel
167 Header files for wxBase. You need them to develop programs using
168 wxBase.
169
170 %description -n wxBase-devel -l pl
171 Pliki nag³ówkowe do biblioteki wxBase.
172
173 %package -n wxBase-unicode
174 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
175 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
176 Group:          X11/Libraries
177 Requires:       %{name} = %{version}-%{release}
178
179 %description -n wxBase-unicode
180 wxBase is a collection of C++ classes providing basic data structures
181 (strings, lists, arrays), powerful wxDateTime class for date
182 manipulations, portable wrappers around many OS-specific functions
183 allowing to build the same program under all supported folders,
184 wxThread class for writing multithreaded programs using either Win32
185 or POSIX threads and much more. wxBase currently supports the
186 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
187 HP-UX, ...) and BeOS. This version is build with UNICODE support.
188
189 %description -n wxBase-unicode -l pl
190 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
191 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
192 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
193 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
194 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
195 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
196 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
197 UNICODE.
198
199 %package -n wxBase-unicode-devel
200 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
201 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
202 Group:          X11/Development/Libraries
203 Requires:       %{name}-devel = %{version}-%{release}
204 Requires:       wxBase-unicode = %{version}-%{release}
205
206 %description -n wxBase-unicode-devel
207 Header files for wxBase. You need them to develop programs using
208 UNICODE-enabled wxBase.
209
210 %description -n wxBase-unicode-devel -l pl
211 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
212
213 %package -n wxGTK2
214 Summary:        wxGTK2 library
215 Summary(pl):    Biblioteka wxGTK2
216 Group:          X11/Libraries
217 Requires:       %{name} = %{version}-%{release}
218 Obsoletes:      wxGTK2-univ
219
220 %description -n wxGTK2
221 wxWidgets library using GTK2 widgets.
222
223 %description -n wxGTK2 -l pl
224 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
225
226 %package -n wxGTK2-devel
227 Summary:        Header files for wxGTK2 library
228 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
229 Group:          X11/Development/Libraries
230 Requires:       wxBase-devel = %{version}-%{release}
231 Requires:       wxGTK2 = %{version}-%{release}
232 Obsoletes:      wxGTK2-univ-devel
233
234 %description -n wxGTK2-devel
235 Header files for wxWidgets library using GTK2 widgets.
236
237 %description -n wxGTK2-devel -l pl
238 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
239
240 %package -n wxGTK2-gl
241 Summary:        GL canvas library for wxGTK2
242 Summary(pl):    Biblioteka GL dla wxGTK2
243 Group:          X11/Libraries
244 Requires:       wxGTK2 = %{version}-%{release}
245 Obsoletes:      wxGTK2-univ-gl
246
247 %description -n wxGTK2-gl
248 wxGTK2 GL canvas library.
249
250 %description -n wxGTK2-gl -l pl
251 Biblioteka GL dla wxGTK2.
252
253 %package -n wxGTK2-gl-devel
254 Summary:        Development files for GL canvas library for wxGTK2
255 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
256 Group:          X11/Development/Libraries
257 Requires:       wxGTK2-devel = %{version}-%{release}
258 Requires:       wxGTK2-gl = %{version}-%{release}
259 Requires:       OpenGL-GLU-devel
260 Obsoletes:      wxGTK2-univ-gl-devel
261
262 %description -n wxGTK2-gl-devel
263 Development files for wxGTK2 GL canvas library.
264
265 %description -n wxGTK2-gl-devel -l pl
266 Pliki programistyczne biblioteki GL dla wxGTK2.
267
268 %package -n wxGTK2-unicode
269 Summary:        wxGTK2 library with UNICODE support
270 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
271 Group:          X11/Libraries
272 Requires:       %{name} = %{version}-%{release}
273 Obsoletes:      wxGTK2-univ-unicode
274
275 %description -n wxGTK2-unicode
276 wxWidgets library using GTK2 widgets with UNICODE support.
277
278 %description -n wxGTK2-unicode -l pl
279 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
280
281 %package -n wxGTK2-unicode-devel
282 Summary:        Header files for wxGTK2 library with UNICODE support
283 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
284 Group:          X11/Development/Libraries
285 Requires:       wxBase-unicode-devel = %{version}-%{release}
286 Requires:       wxGTK2-unicode = %{version}-%{release}
287 Obsoletes:      wxGTK2-univ-unicode-devel
288
289 %description -n wxGTK2-unicode-devel
290 Header files for wxWidgets library using GTK2 widgets with UNICODE
291 support.
292
293 %description -n wxGTK2-unicode-devel -l pl
294 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
295 obs³ug± UNICODE.
296
297 %package -n wxGTK2-unicode-gl
298 Summary:        GL canvas library for wxGTK2 with UNICODE support
299 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
300 Group:          X11/Libraries
301 Requires:       wxGTK2-unicode = %{version}-%{release}
302 Obsoletes:      wxGTK2-univ-unicode-gl
303
304 %description -n wxGTK2-unicode-gl
305 GL canvas library for wxGTK2 with UNICODE support.
306
307 %description -n wxGTK2-unicode-gl -l pl
308 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
309
310 %package -n wxGTK2-unicode-gl-devel
311 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
312 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
313 Group:          X11/Development/Libraries
314 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
315 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
316 Requires:       OpenGL-GLU-devel
317 Obsoletes:      wxGTK2-univ-unicode-gl-devel
318
319 %description -n wxGTK2-unicode-gl-devel
320 Development files for GL canvas library for wxGTK2 with UNICODE
321 support.
322
323 %description -n wxGTK2-unicode-gl-devel -l pl
324 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
325
326 %package utils
327 Summary:        Misc utils from wxWidgets project
328 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
329 Group:          X11/Development/Tools
330 Requires:       wxX11 = %{version}-%{release}
331 Obsoletes:      wxWindows-utils
332
333 %description utils
334 Misc utils from wxWidgets project: helpviewer, makegen, etc.
335
336 %description utils -l pl
337 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
338
339 %package -n wxX11
340 Summary:        wxUniversal-based wxX11 library
341 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
342 Group:          X11/Libraries
343 Requires:       %{name} = %{version}-%{release}
344 Obsoletes:      wxX11-univ
345
346 %description -n wxX11
347 wxUniversal-based wxX11 library.
348
349 %description -n wxX11 -l pl
350 Oparta na wxUniversal biblioteka wxX11.
351
352 %package -n wxX11-devel
353 Summary:        Header files for wxUniversal-based wxX11 library
354 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
355 Group:          X11/Libraries
356 Requires:       %{name}-devel = %{version}-%{release}
357 Requires:       wxX11 = %{version}-%{release}
358 Obsoletes:      wxX11-univ-devel
359
360 %description -n wxX11-devel
361 Header files for wxUniversal-based wxX11 library.
362
363 %description -n wxX11-devel -l pl
364 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
365
366 %package -n wxX11-gl
367 Summary:        GL canvas library for wxUniversal-based wxX11
368 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
369 Group:          X11/Libraries
370 Requires:       wxX11 = %{version}-%{release}
371 Obsoletes:      wxX11-univ-gl
372
373 %description -n wxX11-gl
374 GL canvas library for wxUniversal-based wxX11.
375
376 %description -n wxX11-gl -l pl
377 Biblioteka GL dla opartej na wxUniversal wxX11.
378
379 %package -n wxX11-gl-devel
380 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
381 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
382 Group:          X11/Development/Libraries
383 Requires:       wxX11-gl = %{version}-%{release}
384 Requires:       wxX11-devel = %{version}-%{release}
385 Requires:       OpenGL-GLU-devel
386 Obsoletes:      wxX11-univ-gl-devel
387
388 %description -n wxX11-gl-devel
389 Development files for GL canvas library for wxUniversal-based wxX11.
390
391 %description -n wxX11-gl-devel -l pl
392 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
393
394 %package -n wxX11-unicode
395 Summary:        wxUniversal-based wxX11 library with UNICODE support
396 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
397 Group:          X11/Libraries
398 Requires:       %{name} = %{version}-%{release}
399 Obsoletes:      wxX11-univ-unicode
400
401 %description -n wxX11-unicode
402 wxUniversal-based wxX11 library with UNICODE support.
403
404 %description -n wxX11-unicode -l pl
405 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
406
407 %package -n wxX11-unicode-devel
408 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
409 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
410 Group:          X11/Development/Libraries
411 Requires:       %{name}-devel = %{version}-%{release}
412 Requires:       wxX11-unicode = %{version}-%{release}
413 Obsoletes:      wxX11-univ-unicode-devel
414
415 %description -n wxX11-unicode-devel
416 Header files for wxUniversal-based wxX11 library with UNICODE support.
417
418 %description -n wxX11-unicode-devel -l pl
419 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
420
421 %package -n wxX11-unicode-gl
422 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
423 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
424 Group:          X11/Libraries
425 Requires:       wxX11-unicode = %{version}-%{release}
426 Obsoletes:      wxX11-univ-unicode-gl
427
428 %description -n wxX11-unicode-gl
429 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
430
431 %description -n wxX11-unicode-gl -l pl
432 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
433
434 %package -n wxX11-unicode-gl-devel
435 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
436 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
437 Group:          X11/Development/Libraries
438 Requires:       wxX11-unicode-gl = %{version}-%{release}
439 Requires:       wxX11-unicode-devel = %{version}-%{release}
440 Requires:       OpenGL-GLU-devel
441 Obsoletes:      wxX11-univ-unicode-gl-devel
442
443 %description -n wxX11-unicode-gl-devel
444 Development files for GL canvas library for wxUniversal-based wxX11
445 with UNICODE support.
446
447 %description -n wxX11-unicode-gl-devel -l pl
448 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
449 obs³ug± UNICODE.
450
451 %prep
452 %setup -q
453 %patch0 -p1
454 %patch1 -p1
455 %patch2 -p1
456 %patch3 -p1
457 %patch4 -p1
458 %patch5 -p1
459 %patch6 -p1
460
461 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
462
463 %build
464 # if bakefiles rebuild is needed:
465 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
466 #cd build/bakefiles
467 #bakefile_gen -f autoconf
468 #cd ../..
469 #%endif
470 cp -f /usr/share/automake/config.sub .
471 %{__aclocal} -I build/aclocal
472 %{__autoconf}
473
474 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
475 # avoid adding -s to LDFLAGS
476 LDFLAGS=" "; export LDFLAGS
477 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
478         --enable-plugins \
479         --enable-std_iostreams \
480         --without-sdl \
481         --with-opengl \
482         --enable-calendar \
483         --enable-controls \
484         --enable-tabdialog"
485
486 gui='--with-gtk'
487 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
488         '--enable-unicode' ; do
489         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
490         mkdir $objdir
491         cd $objdir
492         ../%configure \
493                 ${args} \
494                 ${gui} \
495                 --disable-universal \
496                 ${unicode}
497         %{__make}
498         %{__make} -C contrib/src
499         cd ..
500 done
501
502 %if %{with x11}
503 gui='--with-x11'
504 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
505         '--enable-unicode' ; do
506         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
507         mkdir $objdir
508         cd $objdir
509         ../%configure \
510                 ${args} \
511                 ${gui} \
512                 --enable-universal \
513                 ${unicode}
514         %{__make}
515         %{__make} -C contrib/src
516         if echo $objdir| grep -q disable-unicode ; then
517                 %{__make} -C utils
518                 %{__make} -C utils/emulator
519                 %{__make} -C utils/hhp2cached
520                 %{__make} -C contrib/utils
521         fi
522         cd ..
523 done
524 %endif
525
526 cd locale
527 %{__make} allmo
528
529 %install
530 rm -rf $RPM_BUILD_ROOT
531 install -d $RPM_BUILD_ROOT%{_bindir}
532
533 gui='--with-gtk'
534 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
535         '--enable-unicode' ; do
536         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
537         cd $objdir
538         %{__make} install \
539                 prefix=$RPM_BUILD_ROOT%{_prefix} \
540                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
541                 bindir=$RPM_BUILD_ROOT%{_bindir} \
542                 datadir=$RPM_BUILD_ROOT%{_datadir} \
543                 libdir=$RPM_BUILD_ROOT%{_libdir} \
544                 mandir=$RPM_BUILD_ROOT%{_mandir} \
545                 includedir=$RPM_BUILD_ROOT%{_includedir}
546
547         %{__make} -C contrib/src install \
548                 prefix=$RPM_BUILD_ROOT%{_prefix} \
549                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
550                 bindir=$RPM_BUILD_ROOT%{_bindir} \
551                 datadir=$RPM_BUILD_ROOT%{_datadir} \
552                 libdir=$RPM_BUILD_ROOT%{_libdir} \
553                 mandir=$RPM_BUILD_ROOT%{_mandir} \
554                 includedir=$RPM_BUILD_ROOT%{_includedir}
555         cd ..
556 done
557
558 %if %{with x11}
559 gui='--with-x11'
560 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
561         '--enable-unicode' ; do
562         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
563         cd $objdir
564         %{__make} install \
565                 prefix=$RPM_BUILD_ROOT%{_prefix} \
566                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
567                 bindir=$RPM_BUILD_ROOT%{_bindir} \
568                 datadir=$RPM_BUILD_ROOT%{_datadir} \
569                 libdir=$RPM_BUILD_ROOT%{_libdir} \
570                 mandir=$RPM_BUILD_ROOT%{_mandir} \
571                 includedir=$RPM_BUILD_ROOT%{_includedir}
572         if echo $objdir| grep -q disable-unicode ; then
573 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
574                 # TODO: install default config files and default backgrouds
575                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
576                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
577                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
578                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
579 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
580                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
581 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
582 #               install -m644 utils/makegen/templates/* \
583 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
584 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
585 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
586 #               install contrib/utils/wxrcedit/df/* \
587 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
588         fi
589
590         %{__make} -C contrib/src install \
591                 prefix=$RPM_BUILD_ROOT%{_prefix} \
592                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
593                 bindir=$RPM_BUILD_ROOT%{_bindir} \
594                 datadir=$RPM_BUILD_ROOT%{_datadir} \
595                 libdir=$RPM_BUILD_ROOT%{_libdir} \
596                 mandir=$RPM_BUILD_ROOT%{_mandir} \
597                 includedir=$RPM_BUILD_ROOT%{_includedir}
598
599         cd ..
600 done
601 %endif
602
603 set -x
604
605 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
606 do
607         b=`basename $i`
608         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
609 done
610
611 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
612 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
613 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
614
615 %find_lang wxstd
616
617 %clean
618 rm -rf $RPM_BUILD_ROOT
619
620 %post   -n wxBase -p /sbin/ldconfig
621 %postun -n wxBase -p /sbin/ldconfig
622
623 %post   -n wxBase-unicode -p /sbin/ldconfig
624 %postun -n wxBase-unicode -p /sbin/ldconfig
625
626 %post   -n wxGTK2 -p /sbin/ldconfig
627 %postun -n wxGTK2 -p /sbin/ldconfig
628
629 %post   -n wxGTK2-gl -p /sbin/ldconfig
630 %postun -n wxGTK2-gl -p /sbin/ldconfig
631
632 %post   -n wxGTK2-unicode -p /sbin/ldconfig
633 %postun -n wxGTK2-unicode -p /sbin/ldconfig
634
635 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
636 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
637
638 %post   -n wxX11 -p /sbin/ldconfig
639 %postun -n wxX11 -p /sbin/ldconfig
640
641 %post   -n wxX11-unicode -p /sbin/ldconfig
642 %postun -n wxX11-unicode -p /sbin/ldconfig
643
644 %define _libf %{?with_debug:d}
645 %define _configf %{?with_debug:-debug-2.6}
646
647 %files -f wxstd.lang
648 %defattr(644,root,root,755)
649 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
650
651 %files devel
652 %defattr(644,root,root,755)
653 %doc docs/html
654 %doc docs/tech docs/univ
655 %{_includedir}/wx*
656 %dir %{_libdir}/wx
657 %dir %{_libdir}/wx/include
658 %dir %{_libdir}/wx/config
659 %{_aclocaldir}/*.m4
660
661 %files examples
662 %defattr(644,root,root,755)
663 %{_examplesdir}/%{name}-%{version}
664
665 %if %{with x11}
666 %files HelpGen
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_bindir}/HelpGen
669 %endif
670
671 %if %{with ansi}
672 %files -n wxBase
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
675 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
676 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
677
678 %files -n wxBase-devel
679 %defattr(644,root,root,755)
680 %{_libdir}/libwx_base%{_libf}-*.so
681 %{_libdir}/libwx_base%{_libf}_*.so
682 %endif
683
684 %files -n wxBase-unicode
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
687 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
688 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
689
690 %files -n wxBase-unicode-devel
691 %defattr(644,root,root,755)
692 %{_libdir}/libwx_baseu%{_libf}-*.so
693 %{_libdir}/libwx_baseu%{_libf}_*.so
694
695 %if %{with ansi}
696 %files -n wxGTK2
697 %defattr(644,root,root,755)
698 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
699 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
700
701 %files -n wxGTK2-devel
702 %defattr(644,root,root,755)
703 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
704 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
705 %{_libdir}/wx/config/gtk2-ansi-*
706 %{_libdir}/wx/include/gtk2-ansi-*
707 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
708
709 %files -n wxGTK2-gl
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
712
713 %files -n wxGTK2-gl-devel
714 %defattr(644,root,root,755)
715 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
716 %endif
717
718 %files -n wxGTK2-unicode
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
721 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
722
723 %files -n wxGTK2-unicode-devel
724 %defattr(644,root,root,755)
725 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
726 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
727 %{_libdir}/wx/config/gtk2-unicode-*
728 %{_libdir}/wx/include/gtk2-unicode-*
729 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
730
731 %files -n wxGTK2-unicode-gl
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
734
735 %files -n wxGTK2-unicode-gl-devel
736 %defattr(644,root,root,755)
737 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
738
739 %if %{with x11}
740 %if %{with ansi}
741 %files utils
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_bindir}/*
744 %exclude %{_bindir}/HelpGen
745 %exclude %{_bindir}/wx*-config
746
747 %files -n wxX11
748 %defattr(644,root,root,755)
749 %doc docs/wxX11-readme.txt
750 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
751 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
752
753 %files -n wxX11-devel
754 %defattr(644,root,root,755)
755 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
756 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
757 %{_libdir}/wx/config/x11univ-ansi-*
758 %{_libdir}/wx/include/x11univ-ansi-*
759 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
760
761 %files -n wxX11-gl
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
764
765 %files -n wxX11-gl-devel
766 %defattr(644,root,root,755)
767 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
768 %endif
769
770 %files -n wxX11-unicode
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
773 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
774
775 %files -n wxX11-unicode-devel
776 %defattr(644,root,root,755)
777 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
778 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
779 %{_libdir}/wx/config/x11univ-unicode-*
780 %{_libdir}/wx/include/x11univ-unicode-*
781 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
782
783 %files -n wxX11-unicode-gl
784 %defattr(644,root,root,755)
785 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
786
787 %files -n wxX11-unicode-gl-devel
788 %defattr(644,root,root,755)
789 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
790 %endif
This page took 0.095695 seconds and 4 git commands to generate.