]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- versioned O:
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.0
13 Release:        4
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.gz
17 # Source0-md5:  a9d87fec714c0dc79ba1f5b8f1ded50c
18 Patch0:         %{name}-samples.patch
19 Patch1:         %{name}-ogl.patch
20 Patch2:         %{name}-ac.patch
21 Patch3:         %{name}-gif0delay.patch
22 URL:            http://www.wxWidgets.org/
23 BuildRequires:  OpenGL-devel
24 BuildRequires:  SDL-devel
25 BuildRequires:  autoconf >= 2.58
26 BuildRequires:  automake
27 BuildRequires:  bakefile >= 0.1.8
28 BuildRequires:  cppunit-devel
29 BuildRequires:  esound-devel
30 BuildRequires:  expat-devel
31 BuildRequires:  flex
32 BuildRequires:  gettext-devel
33 BuildRequires:  gtk+2-devel
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libmng-devel
36 BuildRequires:  libpng-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtiff-devel
39 BuildRequires:  libtool
40 BuildRequires:  pkgconfig
41 # these are not supported by wxWidgets
42 Obsoletes:      LDAPExplorerTool <= 0.6-1
43 Obsoletes:      abridge <= 0.4.0-1
44 # and these are replaced
45 Obsoletes:      wxGTK
46 Obsoletes:      wxGTK-devel
47 Obsoletes:      wxGTK-gl
48 Obsoletes:      wxGTK-gl-devel
49 Obsoletes:      wxGTK-univ
50 Obsoletes:      wxGTK-univ-devel
51 Obsoletes:      wxGTK-univ-gl
52 Obsoletes:      wxGTK-univ-gl-devel
53 Obsoletes:      wxGTK2-univ
54 Obsoletes:      wxGTK2-univ-devel
55 Obsoletes:      wxGTK2-univ-gl
56 Obsoletes:      wxGTK2-univ-gl-devel
57 Obsoletes:      wxGTK2-univ-unicode
58 Obsoletes:      wxGTK2-univ-unicode-devel
59 Obsoletes:      wxGTK2-univ-unicode-gl
60 Obsoletes:      wxGTK2-univ-unicode-gl-devel
61 Obsoletes:      wxMotif
62 Obsoletes:      wxMotif-devel
63 Obsoletes:      wxMotif-gl
64 Obsoletes:      wxMotif-gl-devel
65 Obsoletes:      wxWidgets-afm
66 Obsoletes:      wxWindows
67 Obsoletes:      wxWindows-afm
68 Obsoletes:      wxwin-afm
69 Obsoletes:      wxwin-common
70 Conflicts:      wxGTK2 < 2.6.0
71 Conflicts:      wxGTK2-unicode < 2.6.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     %{_datadir}
75
76 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif/LessTif, MS Windows, Mac) from the same source code.
82
83 %description -l pl
84 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
85 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
86 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
87 Windows, Mac) z tego samego kodu ¼ród³owego.
88
89 %package devel
90 Summary:        wxWidgets header files and development documentation
91 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
92 Group:          X11/Development/Libraries
93 Requires:       libstdc++-devel
94 Obsoletes:      wxWindows-devel
95
96 %description devel
97 Header files and development documentation for the wxWidgets
98 libraries.
99
100 %description devel -l pl
101 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
102
103 %package examples
104 Summary:        wxWidgets example programs
105 Summary(pl):    Przyk³adowe programy wxWidgets
106 Group:          X11/Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108 Obsoletes:      wxWindows-examples
109
110 %description examples
111 wxWidgets example programs.
112
113 %description examples -l pl
114 Przyk³adowe programy wxWidgets.
115
116 %package HelpGen
117 Summary:        Help file generator for wxWidgets programs
118 Summary(pl):    Generator plików pomocy dla programów wxWidgets
119 Group:          Development/Tools
120 Requires:       wxBase = %{version}-%{release}
121 Obsoletes:      wxWindows-HelpGen
122
123 %description HelpGen
124 Help file generator for wxWidgets programs.
125
126 %description HelpGen -l pl
127 Generator plików pomocy dla programów wxWidgets.
128
129 %package -n wxBase
130 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
131 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
132 Group:          X11/Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description -n wxBase
136 wxBase is a collection of C++ classes providing basic data structures
137 (strings, lists, arrays), powerful wxDateTime class for date
138 manipulations, portable wrappers around many OS-specific functions
139 allowing to build the same program under all supported folders,
140 wxThread class for writing multithreaded programs using either Win32
141 or POSIX threads and much more. wxBase currently supports the
142 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
143 HP-UX, ...) and BeOS.
144
145 %description -n wxBase -l pl
146 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
147 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
148 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
149 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
150 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
151 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
152 platformy: Win32, Unix i BeOS.
153
154 %package -n wxBase-devel
155 Summary:        wxBase headers needed for developping with wxBase
156 Summary(pl):    Pliki nag³ówkowe do wxBase
157 Group:          X11/Development/Libraries
158 Requires:       %{name}-devel = %{version}-%{release}
159 Requires:       wxBase = %{version}-%{release}
160
161 %description -n wxBase-devel
162 Header files for wxBase. You need them to develop programs using
163 wxBase.
164
165 %description -n wxBase-devel -l pl
166 Pliki nag³ówkowe do biblioteki wxBase.
167
168 %package -n wxBase-unicode
169 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
170 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
171 Group:          X11/Libraries
172 Requires:       %{name} = %{version}-%{release}
173
174 %description -n wxBase-unicode
175 wxBase is a collection of C++ classes providing basic data structures
176 (strings, lists, arrays), powerful wxDateTime class for date
177 manipulations, portable wrappers around many OS-specific functions
178 allowing to build the same program under all supported folders,
179 wxThread class for writing multithreaded programs using either Win32
180 or POSIX threads and much more. wxBase currently supports the
181 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
182 HP-UX, ...) and BeOS. This version is build with UNICODE support.
183
184 %description -n wxBase-unicode -l pl
185 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
186 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
187 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
188 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
189 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
190 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
191 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
192 UNICODE.
193
194 %package -n wxBase-unicode-devel
195 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
196 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
197 Group:          X11/Development/Libraries
198 Requires:       %{name}-devel = %{version}-%{release}
199 Requires:       wxBase-unicode = %{version}-%{release}
200
201 %description -n wxBase-unicode-devel
202 Header files for wxBase. You need them to develop programs using
203 UNICODE-enabled wxBase.
204
205 %description -n wxBase-unicode-devel -l pl
206 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
207
208 %package -n wxGTK2
209 Summary:        wxGTK2 library
210 Summary(pl):    Biblioteka wxGTK2
211 Group:          X11/Libraries
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      wxGTK2-univ
214
215 %description -n wxGTK2
216 wxWidgets library using GTK2 widgets.
217
218 %description -n wxGTK2 -l pl
219 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
220
221 %package -n wxGTK2-devel
222 Summary:        Header files for wxGTK2 library
223 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
224 Group:          X11/Development/Libraries
225 Requires:       wxBase-devel = %{version}-%{release}
226 Requires:       wxGTK2 = %{version}-%{release}
227 Obsoletes:      wxGTK2-univ-devel
228
229 %description -n wxGTK2-devel
230 Header files for wxWidgets library using GTK2 widgets.
231
232 %description -n wxGTK2-devel -l pl
233 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
234
235 %package -n wxGTK2-gl
236 Summary:        GL canvas library for wxGTK2
237 Summary(pl):    Biblioteka GL dla wxGTK2
238 Group:          X11/Libraries
239 Requires:       wxGTK2 = %{version}-%{release}
240 Requires:       OpenGL
241 Obsoletes:      wxGTK2-univ-gl
242
243 %description -n wxGTK2-gl
244 wxGTK2 GL canvas library.
245
246 %description -n wxGTK2-gl -l pl
247 Biblioteka GL dla wxGTK2.
248
249 %package -n wxGTK2-gl-devel
250 Summary:        Development files for GL canvas library for wxGTK2
251 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
252 Group:          X11/Development/Libraries
253 Requires:       wxGTK2-devel = %{version}-%{release}
254 Requires:       wxGTK2-gl = %{version}-%{release}
255 Requires:       OpenGL-devel
256 Obsoletes:      wxGTK2-univ-gl-devel
257
258 %description -n wxGTK2-gl-devel
259 Development files for wxGTK2 GL canvas library.
260
261 %description -n wxGTK2-gl-devel -l pl
262 Pliki programistyczne biblioteki GL dla wxGTK2.
263
264 %package -n wxGTK2-unicode
265 Summary:        wxGTK2 library with UNICODE support
266 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
267 Group:          X11/Libraries
268 Requires:       %{name} = %{version}-%{release}
269 Obsoletes:      wxGTK2-univ-unicode
270
271 %description -n wxGTK2-unicode
272 wxWidgets library using GTK2 widgets with UNICODE support.
273
274 %description -n wxGTK2-unicode -l pl
275 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
276
277 %package -n wxGTK2-unicode-devel
278 Summary:        Header files for wxGTK2 library with UNICODE support
279 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
280 Group:          X11/Development/Libraries
281 Requires:       wxBase-unicode-devel = %{version}-%{release}
282 Requires:       wxGTK2-unicode = %{version}-%{release}
283 Obsoletes:      wxGTK2-univ-unicode-devel
284
285 %description -n wxGTK2-unicode-devel
286 Header files for wxWidgets library using GTK2 widgets with UNICODE
287 support.
288
289 %description -n wxGTK2-unicode-devel -l pl
290 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
291 obs³ug± UNICODE.
292
293 %package -n wxGTK2-unicode-gl
294 Summary:        GL canvas library for wxGTK2 with UNICODE support
295 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
296 Group:          X11/Libraries
297 Requires:       wxGTK2-unicode = %{version}-%{release}
298 Requires:       OpenGL
299 Obsoletes:      wxGTK2-univ-unicode-gl
300
301 %description -n wxGTK2-unicode-gl
302 GL canvas library for wxGTK2 with UNICODE support.
303
304 %description -n wxGTK2-unicode-gl -l pl
305 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
306
307 %package -n wxGTK2-unicode-gl-devel
308 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
309 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
310 Group:          X11/Development/Libraries
311 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
312 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
313 Requires:       OpenGL-devel
314 Obsoletes:      wxGTK2-univ-unicode-gl-devel
315
316 %description -n wxGTK2-unicode-gl-devel
317 Development files for GL canvas library for wxGTK2 with UNICODE
318 support.
319
320 %description -n wxGTK2-unicode-gl-devel -l pl
321 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
322
323 %package utils
324 Summary:        Misc utils from wxWidgets project
325 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
326 Group:          X11/Development/Tools
327 Requires:       wxX11 = %{version}-%{release}
328 Obsoletes:      wxWindows-utils
329
330 %description utils
331 Misc utils from wxWidgets project: helpviewer, makegen, etc.
332
333 %description utils -l pl
334 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
335
336 %package -n wxX11
337 Summary:        wxUniversal-based wxX11 library
338 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
339 Group:          X11/Libraries
340 Requires:       %{name} = %{version}-%{release}
341 Obsoletes:      wxX11-univ
342
343 %description -n wxX11
344 wxUniversal-based wxX11 library.
345
346 %description -n wxX11 -l pl
347 Oparta na wxUniversal biblioteka wxX11.
348
349 %package -n wxX11-devel
350 Summary:        Header files for wxUniversal-based wxX11 library
351 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
352 Group:          X11/Libraries
353 Requires:       %{name}-devel = %{version}-%{release}
354 Requires:       wxX11 = %{version}-%{release}
355 Obsoletes:      wxX11-univ-devel
356
357 %description -n wxX11-devel
358 Header files for wxUniversal-based wxX11 library.
359
360 %description -n wxX11-devel -l pl
361 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
362
363 %package -n wxX11-gl
364 Summary:        GL canvas library for wxUniversal-based wxX11
365 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
366 Group:          X11/Libraries
367 Requires:       wxX11 = %{version}-%{release}
368 Requires:       OpenGL
369 Obsoletes:      wxX11-univ-gl
370
371 %description -n wxX11-gl
372 GL canvas library for wxUniversal-based wxX11.
373
374 %description -n wxX11-gl -l pl
375 Biblioteka GL dla opartej na wxUniversal wxX11.
376
377 %package -n wxX11-gl-devel
378 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
379 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
380 Group:          X11/Development/Libraries
381 Requires:       wxX11-gl = %{version}-%{release}
382 Requires:       wxX11-devel = %{version}-%{release}
383 Requires:       OpenGL-devel
384 Obsoletes:      wxX11-univ-gl-devel
385
386 %description -n wxX11-gl-devel
387 Development files for GL canvas library for wxUniversal-based wxX11.
388
389 %description -n wxX11-gl-devel -l pl
390 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
391
392 %package -n wxX11-unicode
393 Summary:        wxUniversal-based wxX11 library with UNICODE support
394 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
395 Group:          X11/Libraries
396 Requires:       %{name} = %{version}-%{release}
397 Obsoletes:      wxX11-univ-unicode
398
399 %description -n wxX11-unicode
400 wxUniversal-based wxX11 library with UNICODE support.
401
402 %description -n wxX11-unicode -l pl
403 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
404
405 %package -n wxX11-unicode-devel
406 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
407 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
408 Group:          X11/Development/Libraries
409 Requires:       %{name}-devel = %{version}-%{release}
410 Requires:       wxX11-unicode = %{version}-%{release}
411 Obsoletes:      wxX11-univ-unicode-devel
412
413 %description -n wxX11-unicode-devel
414 Header files for wxUniversal-based wxX11 library with UNICODE support.
415
416 %description -n wxX11-unicode-devel -l pl
417 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
418
419 %package -n wxX11-unicode-gl
420 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
421 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
422 Group:          X11/Libraries
423 Requires:       wxX11-unicode = %{version}-%{release}
424 Requires:       OpenGL
425 Obsoletes:      wxX11-univ-unicode-gl
426
427 %description -n wxX11-unicode-gl
428 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
429
430 %description -n wxX11-unicode-gl -l pl
431 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
432
433 %package -n wxX11-unicode-gl-devel
434 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
435 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
436 Group:          X11/Development/Libraries
437 Requires:       wxX11-unicode-gl = %{version}-%{release}
438 Requires:       wxX11-unicode-devel = %{version}-%{release}
439 Requires:       OpenGL-devel
440 Obsoletes:      wxX11-univ-unicode-gl-devel
441
442 %description -n wxX11-unicode-gl-devel
443 Development files for GL canvas library for wxUniversal-based wxX11
444 with UNICODE support.
445
446 %description -n wxX11-unicode-gl-devel -l pl
447 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
448 obs³ug± UNICODE.
449
450 %prep
451 %setup -q
452 %patch0 -p1
453 %patch1 -p1
454 %patch2 -p1
455 %patch3 -p1
456
457 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
458
459 # bakefile.m4 from 0.1.8
460 tail -n +1481 aclocal.m4 | head -n 1396 > bakefile.m4
461 # AC_BAKEFILE_PROG_* macros
462 tail -n +684 aclocal.m4 | head -n 142 >> bakefile.m4
463
464 %build
465 # if bakefiles rebuild is needed:
466 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.8"
467 #cd build/bakefiles
468 #bakefile_gen -f autoconf
469 #cd ../..
470 #%endif
471 cp -f /usr/share/automake/config.sub .
472 %{__aclocal} -I .
473 %{__autoconf}
474
475 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
476 # avoid adding -s to LDFLAGS
477 LDFLAGS=" "; export LDFLAGS
478 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
479         --enable-plugins \
480         --enable-std_iostreams \
481         --without-sdl \
482         --with-opengl \
483         --enable-calendar \
484         --enable-controls \
485         --enable-tabdialog"
486
487 gui='--with-gtk'
488 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
489         '--enable-unicode' ; do
490         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
491         mkdir $objdir
492         cd $objdir
493         ../%configure \
494                 ${args} \
495                 ${gui} \
496                 --disable-universal \
497                 ${unicode}
498         %{__make}
499         %{__make} -C contrib/src
500         cd ..
501 done
502
503 %if %{with x11}
504 gui='--with-x11'
505 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
506         '--enable-unicode' ; do
507         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
508         mkdir $objdir
509         cd $objdir
510         ../%configure \
511                 ${args} \
512                 ${gui} \
513                 --enable-universal \
514                 ${unicode}
515         %{__make}
516         %{__make} -C contrib/src
517         if echo $objdir| grep -q disable-unicode ; then
518                 %{__make} -C utils
519                 %{__make} -C utils/emulator
520                 %{__make} -C utils/hhp2cached
521                 %{__make} -C contrib/utils
522         fi
523         cd ..
524 done
525 %endif
526
527 cd locale
528 %{__make} allmo
529
530 %install
531 rm -rf $RPM_BUILD_ROOT
532 install -d $RPM_BUILD_ROOT%{_bindir}
533
534 gui='--with-gtk'
535 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
536         '--enable-unicode' ; do
537         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
538         cd $objdir
539         %{__make} install \
540                 prefix=$RPM_BUILD_ROOT%{_prefix} \
541                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
542                 bindir=$RPM_BUILD_ROOT%{_bindir} \
543                 datadir=$RPM_BUILD_ROOT%{_datadir} \
544                 libdir=$RPM_BUILD_ROOT%{_libdir} \
545                 mandir=$RPM_BUILD_ROOT%{_mandir} \
546                 includedir=$RPM_BUILD_ROOT%{_includedir}
547
548         %{__make} -C contrib/src install \
549                 prefix=$RPM_BUILD_ROOT%{_prefix} \
550                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
551                 bindir=$RPM_BUILD_ROOT%{_bindir} \
552                 datadir=$RPM_BUILD_ROOT%{_datadir} \
553                 libdir=$RPM_BUILD_ROOT%{_libdir} \
554                 mandir=$RPM_BUILD_ROOT%{_mandir} \
555                 includedir=$RPM_BUILD_ROOT%{_includedir}
556         cd ..
557 done
558
559 %if %{with x11}
560 gui='--with-x11'
561 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
562         '--enable-unicode' ; do
563         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
564         cd $objdir
565         %{__make} install \
566                 prefix=$RPM_BUILD_ROOT%{_prefix} \
567                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
568                 bindir=$RPM_BUILD_ROOT%{_bindir} \
569                 datadir=$RPM_BUILD_ROOT%{_datadir} \
570                 libdir=$RPM_BUILD_ROOT%{_libdir} \
571                 mandir=$RPM_BUILD_ROOT%{_mandir} \
572                 includedir=$RPM_BUILD_ROOT%{_includedir}
573         if echo $objdir| grep -q disable-unicode ; then
574 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
575                 # TODO: install default config files and default backgrouds
576                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
577                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
578                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
579                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
580 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
581                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
582 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
583 #               install -m644 utils/makegen/templates/* \
584 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
585 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
586 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
587 #               install contrib/utils/wxrcedit/df/* \
588 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
589         fi
590
591         %{__make} -C contrib/src install \
592                 prefix=$RPM_BUILD_ROOT%{_prefix} \
593                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
594                 bindir=$RPM_BUILD_ROOT%{_bindir} \
595                 datadir=$RPM_BUILD_ROOT%{_datadir} \
596                 libdir=$RPM_BUILD_ROOT%{_libdir} \
597                 mandir=$RPM_BUILD_ROOT%{_mandir} \
598                 includedir=$RPM_BUILD_ROOT%{_includedir}
599
600         cd ..
601 done
602 %endif
603
604 set -x
605
606 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
607 do
608         b=`basename $i`
609         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
610 done
611
612 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
613 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
614 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
615
616 %find_lang wxstd
617
618 %clean
619 rm -rf $RPM_BUILD_ROOT
620
621 %post   -n wxBase -p /sbin/ldconfig
622 %postun -n wxBase -p /sbin/ldconfig
623
624 %post   -n wxBase-unicode -p /sbin/ldconfig
625 %postun -n wxBase-unicode -p /sbin/ldconfig
626
627 %post   -n wxGTK2 -p /sbin/ldconfig
628 %postun -n wxGTK2 -p /sbin/ldconfig
629
630 %post   -n wxGTK2-gl -p /sbin/ldconfig
631 %postun -n wxGTK2-gl -p /sbin/ldconfig
632
633 %post   -n wxGTK2-unicode -p /sbin/ldconfig
634 %postun -n wxGTK2-unicode -p /sbin/ldconfig
635
636 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
637 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
638
639 %post   -n wxX11 -p /sbin/ldconfig
640 %postun -n wxX11 -p /sbin/ldconfig
641
642 %post   -n wxX11-unicode -p /sbin/ldconfig
643 %postun -n wxX11-unicode -p /sbin/ldconfig
644
645 %files -f wxstd.lang
646 %defattr(644,root,root,755)
647 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
648
649 %files devel
650 %defattr(644,root,root,755)
651 %doc docs/html
652 %doc docs/tech docs/univ
653 %{_includedir}/wx*
654 %dir %{_libdir}/wx
655 %dir %{_libdir}/wx/include
656 %dir %{_libdir}/wx/config
657 %{_aclocaldir}/*.m4
658
659 %files examples
660 %defattr(644,root,root,755)
661 %{_examplesdir}/%{name}-%{version}
662
663 %if %{with x11}
664 %files HelpGen
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/HelpGen
667 %endif
668
669 %if %{with ansi}
670 %files -n wxBase
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
673 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
674 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
675
676 %files -n wxBase-devel
677 %defattr(644,root,root,755)
678 %{_libdir}/libwx_base-*.so
679 %{_libdir}/libwx_base_*.so
680 %endif
681
682 %files -n wxBase-unicode
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
685 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
686 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
687
688 %files -n wxBase-unicode-devel
689 %defattr(644,root,root,755)
690 %{_libdir}/libwx_baseu-*.so
691 %{_libdir}/libwx_baseu_*.so
692
693 %if %{with ansi}
694 %files -n wxGTK2
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
697 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
698
699 %files -n wxGTK2-devel
700 %defattr(644,root,root,755)
701 %{_libdir}/libwx_gtk2_*-*.so
702 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
703 %{_libdir}/wx/config/gtk2-ansi-*
704 %{_libdir}/wx/include/gtk2-ansi-*
705 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
706
707 %files -n wxGTK2-gl
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
710
711 %files -n wxGTK2-gl-devel
712 %defattr(644,root,root,755)
713 %{_libdir}/libwx_gtk2_ogl-*.so
714 %endif
715
716 %files -n wxGTK2-unicode
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
719 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
720
721 %files -n wxGTK2-unicode-devel
722 %defattr(644,root,root,755)
723 %{_libdir}/libwx_gtk2u_*-*.so
724 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
725 %{_libdir}/wx/config/gtk2-unicode-*
726 %{_libdir}/wx/include/gtk2-unicode-*
727 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
728
729 %files -n wxGTK2-unicode-gl
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
732
733 %files -n wxGTK2-unicode-gl-devel
734 %defattr(644,root,root,755)
735 %{_libdir}/libwx_gtk2u_ogl-*.so
736
737 %if %{with x11}
738 %if %{with ansi}
739 %files utils
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_bindir}/*
742 %exclude %{_bindir}/HelpGen
743 %exclude %{_bindir}/wx*-config
744
745 %files -n wxX11
746 %defattr(644,root,root,755)
747 %doc docs/wxX11-readme.txt
748 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
749 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
750
751 %files -n wxX11-devel
752 %defattr(644,root,root,755)
753 %{_libdir}/libwx_x11univ_*-*.so
754 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
755 %{_libdir}/wx/config/x11univ-ansi-*
756 %{_libdir}/wx/include/x11univ-ansi-*
757 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
758
759 %files -n wxX11-gl
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
762
763 %files -n wxX11-gl-devel
764 %defattr(644,root,root,755)
765 %{_libdir}/libwx_x11univ_ogl-*.so
766 %endif
767
768 %files -n wxX11-unicode
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
771 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
772
773 %files -n wxX11-unicode-devel
774 %defattr(644,root,root,755)
775 %{_libdir}/libwx_x11univu_*-*.so
776 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
777 %{_libdir}/wx/config/x11univ-unicode-*
778 %{_libdir}/wx/include/x11univ-unicode-*
779 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
780
781 %files -n wxX11-unicode-gl
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
784
785 %files -n wxX11-unicode-gl-devel
786 %defattr(644,root,root,755)
787 %{_libdir}/libwx_x11univu_ogl-*.so
788 %endif
This page took 0.107127 seconds and 4 git commands to generate.