]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- fix building OGL contrib lib (link with deprecated contrib lib for wxExpr)
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  odbc                    # without ODBC support
4 %bcond_without  x11                     # without wxX11 packages
5 %bcond_with     debug                   # build with \--enable-debug
6                                         # (binary incompatible with non-debug)
7
8 Summary:        wxWidgets library
9 Summary(pl):    Biblioteka wxWidgets
10 Name:           wxWidgets
11 Version:        2.5.3
12 Release:        1.2
13 License:        wxWidgets Licence (LGPL with exception)
14 Group:          X11/Libraries
15 Source0:        http://dl.sourceforge.net/wxwindows/wxAll-%{version}.tar.gz
16 # Source0-md5:  33994e85efc06307977d2ddb9cbd91a1
17 #Source1:       ftp://biolpc22.york.ac.uk/pub/%{version}/%{name}-%{version}-Patch02.tar.gz
18 Source1:        http://ftp.uoi.gr/mirror/X11/wxWindows/%{version}/%{name}-%{version}-Patch02.tar.gz
19 # Source1-md5:  96719aff7f9efa0aeea16e20277dc998
20 Patch0:         %{name}-samples.patch
21 Patch1:         %{name}-eggtrayicon.patch
22 Patch2:         %{name}-utils.patch
23 Patch3:         %{name}-ogl.patch
24 URL:            http://www.wxWidgets.org/
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  SDL-devel
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  bakefile >= 0.1.5
30 BuildRequires:  bison
31 BuildRequires:  cppunit-devel
32 BuildRequires:  esound-devel
33 BuildRequires:  expat-devel
34 BuildRequires:  flex
35 BuildRequires:  gettext-devel
36 BuildRequires:  gtk+2-devel
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libmng-devel
39 BuildRequires:  libpng-devel
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtiff-devel
42 BuildRequires:  libtool
43 BuildRequires:  pango-devel
44 Obsoletes:      wxwin-common
45 Obsoletes:      wxGTK
46 Obsoletes:      wxGTK-devel
47 Obsoletes:      wxGTK-gl
48 Obsoletes:      wxGTK-gl-devel
49 Obsoletes:      wxGTK-univ
50 Obsoletes:      wxGTK-univ-devel
51 Obsoletes:      wxGTK-univ-gl
52 Obsoletes:      wxGTK-univ-gl-devel
53 Obsoletes:      wxGTK2-univ
54 Obsoletes:      wxGTK2-univ-devel
55 Obsoletes:      wxGTK2-univ-gl
56 Obsoletes:      wxGTK2-univ-gl-devel
57 Obsoletes:      wxGTK2-univ-unicode
58 Obsoletes:      wxGTK2-univ-unicode-devel
59 Obsoletes:      wxGTK2-univ-unicode-gl
60 Obsoletes:      wxGTK2-univ-unicode-gl-devel
61 Obsoletes:      wxMotif
62 Obsoletes:      wxMotif-devel
63 Obsoletes:      wxMotif-gl
64 Obsoletes:      wxMotif-gl-devel
65 Obsoletes:      wxWindows
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _sysconfdir     %{_datadir}
69
70 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
71
72 %description
73 wxWidgets is a free C++ library for cross-platform GUI development.
74 With wxWidgets, you can create applications for different GUIs (GTK+,
75 Motif/LessTif, MS Windows, Mac) from the same source code.
76
77 %description -l pl
78 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
79 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
80 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
81 Windows, Mac) z tego samego kodu ¼ród³owego.
82
83 %package afm
84 Summary:        Font metrics common for wxGTK, wxGTK2, wxMotif i wxX11
85 Summary(pl):    Metryki fontów wspólne dla wxGTK, wxGTK2, wxMotif i wxX11
86 Group:          X11/Libraries
87 Requires:       %{name} = %{version}-%{release}
88 Obsoletes:      wxwin-afm
89 Obsoletes:      wxWindows-afm
90
91 %description afm
92 Font metrics (in AFM format) common for wxGTK, wxGTK2, wxMotif and
93 wxX11 libraries.
94
95 %description afm -l pl
96 Metryki fontów (w formacie AFM) wspólne dla bibliotek wxGTK, wxGTK2,
97 wxMotif i wxX11.
98
99 %package devel
100 Summary:        wxWidgets header files and development documentation
101 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
102 Group:          X11/Development/Libraries
103 Requires:       libstdc++-devel
104 Obsoletes:      wxWindows-devel
105
106 %description devel
107 Header files and development documentation for the wxWidgets
108 libraries.
109
110 %description devel -l pl
111 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
112
113 %package examples
114 Summary:        wxWidgets example programs
115 Summary(pl):    Przyk³adowe programy wxWidgets
116 Group:          X11/Development/Libraries
117 Requires:       %{name}-devel = %{version}-%{release}
118 Obsoletes:      wxWindows-examples
119
120 %description examples
121 wxWidgets example programs.
122
123 %description examples -l pl
124 Przyk³adowe programy wxWidgets.
125
126 %package HelpGen
127 Summary:        Help file generator for wxWidgets programs
128 Summary(pl):    Generator plików pomocy dla programów wxWidgets
129 Group:          Development/Tools
130 Requires:       wxBase = %{version}-%{release}
131 Obsoletes:      wxWindows-HelpGen
132
133 %description HelpGen
134 Help file generator for wxWidgets programs.
135
136 %description HelpGen -l pl
137 Generator plików pomocy dla programów wxWidgets.
138
139 %package -n wxBase
140 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
141 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
142 Group:          X11/Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description -n wxBase
146 wxBase is a collection of C++ classes providing basic data structures
147 (strings, lists, arrays), powerful wxDateTime class for date
148 manipulations, portable wrappers around many OS-specific functions
149 allowing to build the same program under all supported folders,
150 wxThread class for writing multithreaded programs using either Win32
151 or POSIX threads and much more. wxBase currently supports the
152 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
153 HP-UX, ...) and BeOS.
154
155 %description -n wxBase -l pl
156 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
157 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
158 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
159 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
160 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
161 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
162 platformy: Win32, Unix i BeOS.
163
164 %package -n wxBase-devel
165 Summary:        wxBase headers needed for developping with wxBase
166 Summary(pl):    Pliki nag³ówkowe do wxBase
167 Group:          X11/Development/Libraries
168 Requires:       %{name}-devel = %{version}-%{release}
169 Requires:       wxBase = %{version}-%{release}
170
171 %description -n wxBase-devel
172 Header files for wxBase. You need them to develop programs using
173 wxBase.
174
175 %description -n wxBase-devel -l pl
176 Pliki nag³ówkowe do biblioteki wxBase.
177
178 %package -n wxBase-unicode
179 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
180 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
181 Group:          X11/Libraries
182 Requires:       %{name} = %{version}-%{release}
183
184 %description -n wxBase-unicode
185 wxBase is a collection of C++ classes providing basic data structures
186 (strings, lists, arrays), powerful wxDateTime class for date
187 manipulations, portable wrappers around many OS-specific functions
188 allowing to build the same program under all supported folders,
189 wxThread class for writing multithreaded programs using either Win32
190 or POSIX threads and much more. wxBase currently supports the
191 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
192 HP-UX, ...) and BeOS. This version is build with UNICODE support.
193
194 %description -n wxBase-unicode -l pl
195 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
196 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
197 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
198 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
199 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
200 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
201 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
202 UNICODE.
203
204 %package -n wxBase-unicode-devel
205 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
206 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
207 Group:          X11/Development/Libraries
208 Requires:       %{name}-devel = %{version}-%{release}
209 Requires:       wxBase-unicode = %{version}-%{release}
210
211 %description -n wxBase-unicode-devel
212 Header files for wxBase. You need them to develop programs using
213 UNICODE-enabled wxBase.
214
215 %description -n wxBase-unicode-devel -l pl
216 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
217
218 %package -n wxGTK2
219 Summary:        wxGTK2 library
220 Summary(pl):    Biblioteka wxGTK2
221 Group:          X11/Libraries
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       %{name}-afm = %{version}-%{release}
224 Obsoletes:      wxGTK2-univ
225
226 %description -n wxGTK2
227 wxWidgets library using GTK2 widgets.
228
229 %description -n wxGTK2 -l pl
230 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
231
232 %package -n wxGTK2-devel
233 Summary:        Header files for wxGTK2 library
234 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
235 Group:          X11/Development/Libraries
236 Requires:       wxBase-devel = %{version}-%{release}
237 Requires:       wxGTK2 = %{version}-%{release}
238 Obsoletes:      wxGTK2-univ-devel
239
240 %description -n wxGTK2-devel
241 Header files for wxWidgets library using GTK2 widgets.
242
243 %description -n wxGTK2-devel -l pl
244 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
245
246 %package -n wxGTK2-gl
247 Summary:        GL canvas library for wxGTK2
248 Summary(pl):    Biblioteka GL dla wxGTK2
249 Group:          X11/Libraries
250 Requires:       wxGTK2 = %{version}-%{release}
251 Requires:       OpenGL
252 Obsoletes:      wxGTK2-univ-gl
253
254 %description -n wxGTK2-gl
255 wxGTK2 GL canvas library.
256
257 %description -n wxGTK2-gl -l pl
258 Biblioteka GL dla wxGTK2.
259
260 %package -n wxGTK2-gl-devel
261 Summary:        Development files for GL canvas library for wxGTK2
262 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
263 Group:          X11/Development/Libraries
264 Requires:       wxGTK2-devel = %{version}-%{release}
265 Requires:       wxGTK2-gl = %{version}-%{release}
266 Requires:       OpenGL-devel
267 Obsoletes:      wxGTK2-univ-gl-devel
268
269 %description -n wxGTK2-gl-devel
270 Development files for wxGTK2 GL canvas library.
271
272 %description -n wxGTK2-gl-devel -l pl
273 Pliki programistyczne biblioteki GL dla wxGTK2.
274
275 %package -n wxGTK2-unicode
276 Summary:        wxGTK2 library with UNICODE support
277 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
278 Group:          X11/Libraries
279 Requires:       %{name} = %{version}-%{release}
280 Requires:       %{name}-afm = %{version}-%{release}
281 Obsoletes:      wxGTK2-univ-unicode
282
283 %description -n wxGTK2-unicode
284 wxWidgets library using GTK2 widgets with UNICODE support.
285
286 %description -n wxGTK2-unicode -l pl
287 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
288
289 %package -n wxGTK2-unicode-devel
290 Summary:        Header files for wxGTK2 library with UNICODE support
291 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
292 Group:          X11/Development/Libraries
293 Requires:       wxBase-unicode-devel = %{version}-%{release}
294 Requires:       wxGTK2-unicode = %{version}-%{release}
295 Obsoletes:      wxGTK2-univ-unicode-devel
296
297 %description -n wxGTK2-unicode-devel
298 Header files for wxWidgets library using GTK2 widgets with UNICODE
299 support.
300
301 %description -n wxGTK2-unicode-devel -l pl
302 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
303 obs³ug± UNICODE.
304
305 %package -n wxGTK2-unicode-gl
306 Summary:        GL canvas library for wxGTK2 with UNICODE support
307 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
308 Group:          X11/Libraries
309 Requires:       wxGTK2-unicode = %{version}-%{release}
310 Requires:       OpenGL
311 Obsoletes:      wxGTK2-univ-unicode-gl
312
313 %description -n wxGTK2-unicode-gl
314 GL canvas library for wxGTK2 with UNICODE support.
315
316 %description -n wxGTK2-unicode-gl -l pl
317 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
318
319 %package -n wxGTK2-unicode-gl-devel
320 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
321 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
322 Group:          X11/Development/Libraries
323 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
324 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
325 Requires:       OpenGL-devel
326 Obsoletes:      wxGTK2-univ-unicode-gl-devel
327
328 %description -n wxGTK2-unicode-gl-devel
329 Development files for GL canvas library for wxGTK2 with UNICODE
330 support.
331
332 %description -n wxGTK2-unicode-gl-devel -l pl
333 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
334
335 %package utils
336 Summary:        Misc utils from wxWidgets project
337 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
338 Group:          X11/Development/Tools
339 Requires:       wxX11 = %{version}-%{release}
340 Obsoletes:      wxWindows-utils
341
342 %description utils
343 Misc utils from wxWidgets project: helpviewer, makegen, etc.
344
345 %description utils -l pl
346 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
347
348 %package -n wxX11
349 Summary:        wxUniversal-based wxX11 library
350 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
351 Group:          X11/Libraries
352 Requires:       %{name} = %{version}-%{release}
353 Requires:       %{name}-afm = %{version}-%{release}
354 Obsoletes:      wxX11-univ
355
356 %description -n wxX11
357 wxUniversal-based wxX11 library.
358
359 %description -n wxX11 -l pl
360 Oparta na wxUniversal biblioteka wxX11.
361
362 %package -n wxX11-devel
363 Summary:        Header files for wxUniversal-based wxX11 library
364 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
365 Group:          X11/Libraries
366 Requires:       %{name}-devel = %{version}-%{release}
367 Requires:       wxX11 = %{version}-%{release}
368 Obsoletes:      wxX11-univ-devel
369
370 %description -n wxX11-devel
371 Header files for wxUniversal-based wxX11 library.
372
373 %description -n wxX11-devel -l pl
374 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
375
376 %package -n wxX11-gl
377 Summary:        GL canvas library for wxUniversal-based wxX11
378 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
379 Group:          X11/Libraries
380 Requires:       wxX11 = %{version}-%{release}
381 Requires:       OpenGL
382 Obsoletes:      wxX11-univ-gl
383
384 %description -n wxX11-gl
385 GL canvas library for wxUniversal-based wxX11.
386
387 %description -n wxX11-gl -l pl
388 Biblioteka GL dla opartej na wxUniversal wxX11.
389
390 %package -n wxX11-gl-devel
391 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
392 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
393 Group:          X11/Development/Libraries
394 Requires:       wxX11-gl = %{version}-%{release}
395 Requires:       wxX11-devel = %{version}-%{release}
396 Requires:       OpenGL-devel
397 Obsoletes:      wxX11-univ-gl-devel
398
399 %description -n wxX11-gl-devel
400 Development files for GL canvas library for wxUniversal-based wxX11.
401
402 %description -n wxX11-gl-devel -l pl
403 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
404
405 %package -n wxX11-unicode
406 Summary:        wxUniversal-based wxX11 library with UNICODE support
407 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
408 Group:          X11/Libraries
409 Requires:       %{name} = %{version}-%{release}
410 Requires:       %{name}-afm = %{version}-%{release}
411 Obsoletes:      wxX11-univ-unicode
412
413 %description -n wxX11-unicode
414 wxUniversal-based wxX11 library with UNICODE support.
415
416 %description -n wxX11-unicode -l pl
417 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
418
419 %package -n wxX11-unicode-devel
420 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
421 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
422 Group:          X11/Development/Libraries
423 Requires:       %{name}-devel = %{version}-%{release}
424 Requires:       wxX11-unicode = %{version}-%{release}
425 Obsoletes:      wxX11-univ-unicode-devel
426
427 %description -n wxX11-unicode-devel
428 Header files for wxUniversal-based wxX11 library with UNICODE support.
429
430 %description -n wxX11-unicode-devel -l pl
431 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
432
433 %package -n wxX11-unicode-gl
434 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
435 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
436 Group:          X11/Libraries
437 Requires:       wxX11-unicode = %{version}-%{release}
438 Requires:       OpenGL
439 Obsoletes:      wxX11-univ-unicode-gl
440
441 %description -n wxX11-unicode-gl
442 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
443
444 %description -n wxX11-unicode-gl -l pl
445 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
446
447 %package -n wxX11-unicode-gl-devel
448 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
449 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
450 Group:          X11/Development/Libraries
451 Requires:       wxX11-unicode-gl = %{version}-%{release}
452 Requires:       wxX11-unicode-devel = %{version}-%{release}
453 Requires:       OpenGL-devel
454 Obsoletes:      wxX11-univ-unicode-gl-devel
455
456 %description -n wxX11-unicode-gl-devel
457 Development files for GL canvas library for wxUniversal-based wxX11
458 with UNICODE support.
459
460 %description -n wxX11-unicode-gl-devel -l pl
461 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
462 obs³ug± UNICODE.
463
464 %prep
465 %setup -q
466 %patch0 -p1
467 %patch1 -p1
468 %patch2 -p1
469 %patch3 -p1
470
471 %build
472 cd build/bakefiles
473 bakefile_gen -f autoconf
474 cd ../..
475 cp /usr/share/automake/config.sub .
476 %{__aclocal} -I .
477 %{__autoconf}
478
479 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
480 # avoid adding -s to LDFLAGS
481 LDFLAGS=" "; export LDFLAGS
482 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
483         --enable-plugins \
484         --enable-std_iostreams \
485         --with-sdl \
486         --with-opengl \
487         --enable-calendar \
488         --enable-controls \
489         --enable-tabdialog"
490
491 gui='--with-gtk --enable-gtk2'
492 for unicode in '--disable-unicode %{?with_odbc:--with-odbc}' \
493         '--enable-unicode' ; do
494         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
495         mkdir $objdir
496         cd $objdir
497         ../%configure \
498                 ${args} \
499                 ${gui} \
500                 --disable-universal \
501                 ${unicode}
502         %{__make}
503         %{__make} -C contrib/src
504         cd ..
505 done
506
507 %if %{with x11}
508 gui='--with-x11'
509 for unicode in '--disable-unicode %{?with_odbc:--with-odbc}' \
510         '--enable-unicode' ; do
511         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
512         mkdir $objdir
513         cd $objdir
514         ../%configure \
515                 ${args} \
516                 ${gui} \
517                 --enable-universal \
518                 ${unicode}
519         %{__make}
520         %{__make} -C contrib/src
521         if echo $objdir| grep -q disable-unicode ; then
522                 %{__make} -C utils
523                 %{__make} -C utils/emulator
524                 %{__make} -C utils/hhp2cached
525                 %{__make} -C contrib/utils
526         fi
527         cd ..
528 done
529 %endif
530
531 cd locale
532 %{__make} allmo
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d $RPM_BUILD_ROOT%{_bindir}
537
538 gui='--with-gtk --enable-gtk2'
539 for unicode in '--disable-unicode %{?with_odbc:--with-odbc}' \
540         '--enable-unicode' ; do
541         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
542         cd $objdir
543         %{__make} install \
544                 prefix=$RPM_BUILD_ROOT%{_prefix} \
545                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
546                 bindir=$RPM_BUILD_ROOT%{_bindir} \
547                 datadir=$RPM_BUILD_ROOT%{_datadir} \
548                 libdir=$RPM_BUILD_ROOT%{_libdir} \
549                 mandir=$RPM_BUILD_ROOT%{_mandir} \
550                 includedir=$RPM_BUILD_ROOT%{_includedir}
551
552         %{__make} -C contrib/src install \
553                 prefix=$RPM_BUILD_ROOT%{_prefix} \
554                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
555                 bindir=$RPM_BUILD_ROOT%{_bindir} \
556                 datadir=$RPM_BUILD_ROOT%{_datadir} \
557                 libdir=$RPM_BUILD_ROOT%{_libdir} \
558                 mandir=$RPM_BUILD_ROOT%{_mandir} \
559                 includedir=$RPM_BUILD_ROOT%{_includedir}
560
561         cd ..
562 done
563
564 %if %{with x11}
565 gui='--with-x11'
566 for unicode in '--disable-unicode %{?with_odbc:--with-odbc}' \
567         '--enable-unicode' ; do
568         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
569         cd $objdir
570         %{__make} install \
571                 prefix=$RPM_BUILD_ROOT%{_prefix} \
572                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
573                 bindir=$RPM_BUILD_ROOT%{_bindir} \
574                 datadir=$RPM_BUILD_ROOT%{_datadir} \
575                 libdir=$RPM_BUILD_ROOT%{_libdir} \
576                 mandir=$RPM_BUILD_ROOT%{_mandir} \
577                 includedir=$RPM_BUILD_ROOT%{_includedir}
578         if echo $objdir| grep -q disable-unicode ; then
579 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
580                 # TODO: install default config files and default backgrouds
581                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
582                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
583                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
584                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
585 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
586                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
587 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
588 #               install -m644 utils/makegen/templates/* \
589 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
590 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
591 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
592 #               install contrib/utils/wxrcedit/df/* \
593 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
594         fi
595
596         %{__make} -C contrib/src install \
597                 prefix=$RPM_BUILD_ROOT%{_prefix} \
598                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
599                 bindir=$RPM_BUILD_ROOT%{_bindir} \
600                 datadir=$RPM_BUILD_ROOT%{_datadir} \
601                 libdir=$RPM_BUILD_ROOT%{_libdir} \
602                 mandir=$RPM_BUILD_ROOT%{_mandir} \
603                 includedir=$RPM_BUILD_ROOT%{_includedir}
604
605         cd ..
606 done
607 %endif
608
609 set -x
610
611 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
612 do
613         b=`basename $i`
614         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
615 done
616
617 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
618 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
619 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
620
621 %find_lang wxstd
622
623 %clean
624 rm -rf $RPM_BUILD_ROOT
625
626 %post   -n wxBase -p /sbin/ldconfig
627 %postun -n wxBase -p /sbin/ldconfig
628
629 %post   -n wxBase-unicode -p /sbin/ldconfig
630 %postun -n wxBase-unicode -p /sbin/ldconfig
631
632 %post   -n wxGTK2 -p /sbin/ldconfig
633 %postun -n wxGTK2 -p /sbin/ldconfig
634
635 %post   -n wxGTK2-gl -p /sbin/ldconfig
636 %postun -n wxGTK2-gl -p /sbin/ldconfig
637
638 %post   -n wxGTK2-unicode -p /sbin/ldconfig
639 %postun -n wxGTK2-unicode -p /sbin/ldconfig
640
641 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
642 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
643
644 %post   -n wxX11 -p /sbin/ldconfig
645 %postun -n wxX11 -p /sbin/ldconfig
646
647 %post   -n wxX11-unicode -p /sbin/ldconfig
648 %postun -n wxX11-unicode -p /sbin/ldconfig
649
650 %files -f wxstd.lang
651 %defattr(644,root,root,755)
652 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
653 %doc docs/wxX11-readme.txt
654 %dir %{_datadir}/wx
655 %dir %{_datadir}/wx/2.5
656
657 %files -n wxWidgets-afm
658 %defattr(644,root,root,755)
659 %{_datadir}/wx/2.5/afm
660 %{_datadir}/wx/2.5/gs_afm
661
662 %files devel
663 %defattr(644,root,root,755)
664 %doc docs/html
665 %doc docs/tech docs/univ
666 %{_includedir}/wx*
667 %dir %{_libdir}/wx
668 %dir %{_libdir}/wx/include
669 %dir %{_libdir}/wx/config
670 %{_aclocaldir}/*.m4
671
672 %files examples
673 %defattr(644,root,root,755)
674 %{_examplesdir}/%{name}-%{version}
675
676 %if %{with x11}
677 %files HelpGen
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/HelpGen
680 %endif
681
682 %files -n wxBase
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
685 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
686 %attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
687
688 %files -n wxBase-devel
689 %defattr(644,root,root,755)
690 %{_libdir}/libwx_base-*.so
691 %{_libdir}/libwx_base_*.so
692
693 %files -n wxBase-unicode
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
696 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
697 %attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
698
699 %files -n wxBase-unicode-devel
700 %defattr(644,root,root,755)
701 %{_libdir}/libwx_baseu-*.so
702 %{_libdir}/libwx_baseu_*.so
703
704 %files -n wxGTK2
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
707 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
708
709 %files -n wxGTK2-devel
710 %defattr(644,root,root,755)
711 %{_libdir}/libwx_gtk2_*-*.so
712 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
713 %{_libdir}/wx/config/gtk2-ansi-*
714 %{_libdir}/wx/include/gtk2-ansi-*
715 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
716
717 %files -n wxGTK2-gl
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
720
721 %files -n wxGTK2-gl-devel
722 %defattr(644,root,root,755)
723 %{_libdir}/libwx_gtk2_ogl-*.so
724
725 %files -n wxGTK2-unicode
726 %defattr(644,root,root,755)
727 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
728 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
729
730 %files -n wxGTK2-unicode-devel
731 %defattr(644,root,root,755)
732 %{_libdir}/libwx_gtk2u_*-*.so
733 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
734 %{_libdir}/wx/config/gtk2-unicode-*
735 %{_libdir}/wx/include/gtk2-unicode-*
736 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
737
738 %files -n wxGTK2-unicode-gl
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
741
742 %files -n wxGTK2-unicode-gl-devel
743 %defattr(644,root,root,755)
744 %{_libdir}/libwx_gtk2u_ogl-*.so
745
746 %if %{with x11}
747 %files utils
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_bindir}/*
750 %exclude %{_bindir}/HelpGen
751 %exclude %{_bindir}/wx*-config
752 #%{_datadir}/wx/makegen
753 #%{_datadir}/wx/wxrcedit
754
755 %files -n wxX11
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
758 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
759
760 %files -n wxX11-devel
761 %defattr(644,root,root,755)
762 %{_libdir}/libwx_x11univ_*-*.so
763 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
764 %{_libdir}/wx/config/x11univ-ansi-*
765 %{_libdir}/wx/include/x11univ-ansi-*
766 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
767
768 %files -n wxX11-gl
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
771
772 %files -n wxX11-gl-devel
773 %defattr(644,root,root,755)
774 %{_libdir}/libwx_x11univ_ogl-*.so
775
776 %files -n wxX11-unicode
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
779 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
780
781 %files -n wxX11-unicode-devel
782 %defattr(644,root,root,755)
783 %{_libdir}/libwx_x11univu_*-*.so
784 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
785 %{_libdir}/wx/config/x11univ-unicode-*
786 %{_libdir}/wx/include/x11univ-unicode-*
787 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
788
789 %files -n wxX11-unicode-gl
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
792
793 %files -n wxX11-unicode-gl-devel
794 %defattr(644,root,root,755)
795 %{_libdir}/libwx_x11univu_ogl-*.so
796 %endif
This page took 0.100037 seconds and 4 git commands to generate.