]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
- rel 0.2; fixes from cvs (search functionality)
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8 #
9 # Unpackaged files:
10 #  /usr/bin/wxrc-2.6
11 #  /usr/share/bakefile/presets/wx.bkl
12 #  /usr/share/bakefile/presets/wx_unix.bkl
13 #  /usr/share/bakefile/presets/wx_win32.bkl
14 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
15 #
16
17 Summary:        wxWidgets library
18 Summary(pl):    Biblioteka wxWidgets
19 Name:           wxWidgets
20 Version:        2.8.0
21 Release:        0.2
22 License:        wxWidgets Licence (LGPL with exception)
23 Group:          X11/Libraries
24 Source0:        http://ftp.wxwidgets.org/pub/%{version}/%{name}-%{version}.tar.bz2
25 # Source0-md5:  4bf9c66cdb7cda1d2fe51376c211b9e1
26 Patch0:         %{name}-samples.patch
27 Patch1:         %{name}-ogl.patch
28 Patch2:         %{name}-ac.patch
29 Patch3:         %{name}-gif0delay.patch
30 Patch4:         %{name}-x11unicode.patch
31 Patch5:         %{name}-gcc4.patch
32 Patch6:         %{name}-cvs20061218.patch
33 URL:            http://www.wxWidgets.org/
34 BuildRequires:  OpenGL-GLU-devel
35 #BuildRequires: SDL-devel
36 BuildRequires:  autoconf >= 2.59-9
37 BuildRequires:  automake
38 #BuildRequires: bakefile >= 0.1.9
39 BuildRequires:  cppunit-devel
40 BuildRequires:  esound-devel
41 BuildRequires:  expat-devel
42 BuildRequires:  flex
43 BuildRequires:  gettext-devel
44 BuildRequires:  gtk+2-devel >= 2.0.0
45 BuildRequires:  libjpeg-devel
46 BuildRequires:  libmng-devel
47 BuildRequires:  libmspack-devel
48 BuildRequires:  libpng-devel
49 BuildRequires:  libstdc++-devel
50 BuildRequires:  libtiff-devel
51 BuildRequires:  libtool
52 BuildRequires:  pkgconfig
53 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
54 # these are not supported by wxWidgets
55 Obsoletes:      LDAPExplorerTool <= 0.6-1
56 Obsoletes:      abridge <= 0.4.0-1
57 # and these are replaced
58 Obsoletes:      wxGTK
59 Obsoletes:      wxGTK-devel
60 Obsoletes:      wxGTK-gl
61 Obsoletes:      wxGTK-gl-devel
62 Obsoletes:      wxGTK-univ
63 Obsoletes:      wxGTK-univ-devel
64 Obsoletes:      wxGTK-univ-gl
65 Obsoletes:      wxGTK-univ-gl-devel
66 Obsoletes:      wxGTK2-univ
67 Obsoletes:      wxGTK2-univ-devel
68 Obsoletes:      wxGTK2-univ-gl
69 Obsoletes:      wxGTK2-univ-gl-devel
70 Obsoletes:      wxGTK2-univ-unicode
71 Obsoletes:      wxGTK2-univ-unicode-devel
72 Obsoletes:      wxGTK2-univ-unicode-gl
73 Obsoletes:      wxGTK2-univ-unicode-gl-devel
74 Obsoletes:      wxMotif
75 Obsoletes:      wxMotif-devel
76 Obsoletes:      wxMotif-gl
77 Obsoletes:      wxMotif-gl-devel
78 Obsoletes:      wxWidgets-afm
79 Obsoletes:      wxWindows
80 Obsoletes:      wxWindows-afm
81 Obsoletes:      wxwin-afm
82 Obsoletes:      wxwin-common
83 Conflicts:      wxGTK2 < 2.6.0
84 Conflicts:      wxGTK2-unicode < 2.6.0
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     %{_datadir}
88
89 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
90
91 %description
92 wxWidgets is a free C++ library for cross-platform GUI development.
93 With wxWidgets, you can create applications for different GUIs (GTK+,
94 Motif/LessTif, MS Windows, Mac) from the same source code.
95
96 %description -l pl
97 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
98 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
99 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
100 Windows, Mac) z tego samego kodu ¼ród³owego.
101
102 %package devel
103 Summary:        wxWidgets header files and development documentation
104 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
105 Group:          X11/Development/Libraries
106 Requires:       libstdc++-devel
107 Obsoletes:      wxWindows-devel
108
109 %description devel
110 Header files and development documentation for the wxWidgets
111 libraries.
112
113 %description devel -l pl
114 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
115
116 %package examples
117 Summary:        wxWidgets example programs
118 Summary(pl):    Przyk³adowe programy wxWidgets
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121 Obsoletes:      wxWindows-examples
122
123 %description examples
124 wxWidgets example programs.
125
126 %description examples -l pl
127 Przyk³adowe programy wxWidgets.
128
129 %package HelpGen
130 Summary:        Help file generator for wxWidgets programs
131 Summary(pl):    Generator plików pomocy dla programów wxWidgets
132 Group:          Development/Tools
133 Requires:       wxBase = %{version}-%{release}
134 Obsoletes:      wxWindows-HelpGen
135
136 %description HelpGen
137 Help file generator for wxWidgets programs.
138
139 %description HelpGen -l pl
140 Generator plików pomocy dla programów wxWidgets.
141
142 %package -n wxBase
143 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
144 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
145 Group:          X11/Libraries
146 Requires:       %{name} = %{version}-%{release}
147
148 %description -n wxBase
149 wxBase is a collection of C++ classes providing basic data structures
150 (strings, lists, arrays), powerful wxDateTime class for date
151 manipulations, portable wrappers around many OS-specific functions
152 allowing to build the same program under all supported folders,
153 wxThread class for writing multithreaded programs using either Win32
154 or POSIX threads and much more. wxBase currently supports the
155 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
156 HP-UX, ...) and BeOS.
157
158 %description -n wxBase -l pl
159 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
160 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
161 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
162 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
163 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
164 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
165 platformy: Win32, Unix i BeOS.
166
167 %package -n wxBase-devel
168 Summary:        wxBase headers needed for developping with wxBase
169 Summary(pl):    Pliki nag³ówkowe do wxBase
170 Group:          X11/Development/Libraries
171 Requires:       %{name}-devel = %{version}-%{release}
172 Requires:       wxBase = %{version}-%{release}
173
174 %description -n wxBase-devel
175 Header files for wxBase. You need them to develop programs using
176 wxBase.
177
178 %description -n wxBase-devel -l pl
179 Pliki nag³ówkowe do biblioteki wxBase.
180
181 %package -n wxBase-unicode
182 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
183 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
184 Group:          X11/Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description -n wxBase-unicode
188 wxBase is a collection of C++ classes providing basic data structures
189 (strings, lists, arrays), powerful wxDateTime class for date
190 manipulations, portable wrappers around many OS-specific functions
191 allowing to build the same program under all supported folders,
192 wxThread class for writing multithreaded programs using either Win32
193 or POSIX threads and much more. wxBase currently supports the
194 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
195 HP-UX, ...) and BeOS. This version is build with UNICODE support.
196
197 %description -n wxBase-unicode -l pl
198 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
199 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
200 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
201 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
202 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
203 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
204 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
205 UNICODE.
206
207 %package -n wxBase-unicode-devel
208 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
209 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
210 Group:          X11/Development/Libraries
211 Requires:       %{name}-devel = %{version}-%{release}
212 Requires:       wxBase-unicode = %{version}-%{release}
213
214 %description -n wxBase-unicode-devel
215 Header files for wxBase. You need them to develop programs using
216 UNICODE-enabled wxBase.
217
218 %description -n wxBase-unicode-devel -l pl
219 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
220
221 %package -n wxGTK2
222 Summary:        wxGTK2 library
223 Summary(pl):    Biblioteka wxGTK2
224 Group:          X11/Libraries
225 Requires:       %{name} = %{version}-%{release}
226 Obsoletes:      wxGTK2-univ
227
228 %description -n wxGTK2
229 wxWidgets library using GTK2 widgets.
230
231 %description -n wxGTK2 -l pl
232 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
233
234 %package -n wxGTK2-devel
235 Summary:        Header files for wxGTK2 library
236 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
237 Group:          X11/Development/Libraries
238 Requires:       wxBase-devel = %{version}-%{release}
239 Requires:       wxGTK2 = %{version}-%{release}
240 Obsoletes:      wxGTK2-univ-devel
241
242 %description -n wxGTK2-devel
243 Header files for wxWidgets library using GTK2 widgets.
244
245 %description -n wxGTK2-devel -l pl
246 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
247
248 %package -n wxGTK2-gl
249 Summary:        GL canvas library for wxGTK2
250 Summary(pl):    Biblioteka GL dla wxGTK2
251 Group:          X11/Libraries
252 Requires:       wxGTK2 = %{version}-%{release}
253 Obsoletes:      wxGTK2-univ-gl
254
255 %description -n wxGTK2-gl
256 wxGTK2 GL canvas library.
257
258 %description -n wxGTK2-gl -l pl
259 Biblioteka GL dla wxGTK2.
260
261 %package -n wxGTK2-gl-devel
262 Summary:        Development files for GL canvas library for wxGTK2
263 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
264 Group:          X11/Development/Libraries
265 Requires:       wxGTK2-devel = %{version}-%{release}
266 Requires:       wxGTK2-gl = %{version}-%{release}
267 Requires:       OpenGL-GLU-devel
268 Obsoletes:      wxGTK2-univ-gl-devel
269
270 %description -n wxGTK2-gl-devel
271 Development files for wxGTK2 GL canvas library.
272
273 %description -n wxGTK2-gl-devel -l pl
274 Pliki programistyczne biblioteki GL dla wxGTK2.
275
276 %package -n wxGTK2-unicode
277 Summary:        wxGTK2 library with UNICODE support
278 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
279 Group:          X11/Libraries
280 Requires:       %{name} = %{version}-%{release}
281 Obsoletes:      wxGTK2-univ-unicode
282
283 %description -n wxGTK2-unicode
284 wxWidgets library using GTK2 widgets with UNICODE support.
285
286 %description -n wxGTK2-unicode -l pl
287 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
288
289 %package -n wxGTK2-unicode-devel
290 Summary:        Header files for wxGTK2 library with UNICODE support
291 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
292 Group:          X11/Development/Libraries
293 Requires:       wxBase-unicode-devel = %{version}-%{release}
294 Requires:       wxGTK2-unicode = %{version}-%{release}
295 Obsoletes:      wxGTK2-univ-unicode-devel
296
297 %description -n wxGTK2-unicode-devel
298 Header files for wxWidgets library using GTK2 widgets with UNICODE
299 support.
300
301 %description -n wxGTK2-unicode-devel -l pl
302 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
303 obs³ug± UNICODE.
304
305 %package -n wxGTK2-unicode-gl
306 Summary:        GL canvas library for wxGTK2 with UNICODE support
307 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
308 Group:          X11/Libraries
309 Requires:       wxGTK2-unicode = %{version}-%{release}
310 Obsoletes:      wxGTK2-univ-unicode-gl
311
312 %description -n wxGTK2-unicode-gl
313 GL canvas library for wxGTK2 with UNICODE support.
314
315 %description -n wxGTK2-unicode-gl -l pl
316 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
317
318 %package -n wxGTK2-unicode-gl-devel
319 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
320 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
321 Group:          X11/Development/Libraries
322 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
323 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
324 Requires:       OpenGL-GLU-devel
325 Obsoletes:      wxGTK2-univ-unicode-gl-devel
326
327 %description -n wxGTK2-unicode-gl-devel
328 Development files for GL canvas library for wxGTK2 with UNICODE
329 support.
330
331 %description -n wxGTK2-unicode-gl-devel -l pl
332 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
333
334 %package utils
335 Summary:        Misc utils from wxWidgets project
336 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
337 Group:          X11/Development/Tools
338 Requires:       wxX11 = %{version}-%{release}
339 Obsoletes:      wxWindows-utils
340
341 %description utils
342 Misc utils from wxWidgets project: helpviewer, makegen, etc.
343
344 %description utils -l pl
345 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
346
347 %package -n wxX11
348 Summary:        wxUniversal-based wxX11 library
349 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
350 Group:          X11/Libraries
351 Requires:       %{name} = %{version}-%{release}
352 Obsoletes:      wxX11-univ
353
354 %description -n wxX11
355 wxUniversal-based wxX11 library.
356
357 %description -n wxX11 -l pl
358 Oparta na wxUniversal biblioteka wxX11.
359
360 %package -n wxX11-devel
361 Summary:        Header files for wxUniversal-based wxX11 library
362 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
363 Group:          X11/Libraries
364 Requires:       %{name}-devel = %{version}-%{release}
365 Requires:       wxX11 = %{version}-%{release}
366 Obsoletes:      wxX11-univ-devel
367
368 %description -n wxX11-devel
369 Header files for wxUniversal-based wxX11 library.
370
371 %description -n wxX11-devel -l pl
372 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
373
374 %package -n wxX11-gl
375 Summary:        GL canvas library for wxUniversal-based wxX11
376 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
377 Group:          X11/Libraries
378 Requires:       wxX11 = %{version}-%{release}
379 Obsoletes:      wxX11-univ-gl
380
381 %description -n wxX11-gl
382 GL canvas library for wxUniversal-based wxX11.
383
384 %description -n wxX11-gl -l pl
385 Biblioteka GL dla opartej na wxUniversal wxX11.
386
387 %package -n wxX11-gl-devel
388 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
389 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
390 Group:          X11/Development/Libraries
391 Requires:       wxX11-gl = %{version}-%{release}
392 Requires:       wxX11-devel = %{version}-%{release}
393 Requires:       OpenGL-GLU-devel
394 Obsoletes:      wxX11-univ-gl-devel
395
396 %description -n wxX11-gl-devel
397 Development files for GL canvas library for wxUniversal-based wxX11.
398
399 %description -n wxX11-gl-devel -l pl
400 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
401
402 %package -n wxX11-unicode
403 Summary:        wxUniversal-based wxX11 library with UNICODE support
404 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
405 Group:          X11/Libraries
406 Requires:       %{name} = %{version}-%{release}
407 Obsoletes:      wxX11-univ-unicode
408
409 %description -n wxX11-unicode
410 wxUniversal-based wxX11 library with UNICODE support.
411
412 %description -n wxX11-unicode -l pl
413 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
414
415 %package -n wxX11-unicode-devel
416 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
417 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
418 Group:          X11/Development/Libraries
419 Requires:       %{name}-devel = %{version}-%{release}
420 Requires:       wxX11-unicode = %{version}-%{release}
421 Obsoletes:      wxX11-univ-unicode-devel
422
423 %description -n wxX11-unicode-devel
424 Header files for wxUniversal-based wxX11 library with UNICODE support.
425
426 %description -n wxX11-unicode-devel -l pl
427 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
428
429 %package -n wxX11-unicode-gl
430 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
431 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
432 Group:          X11/Libraries
433 Requires:       wxX11-unicode = %{version}-%{release}
434 Obsoletes:      wxX11-univ-unicode-gl
435
436 %description -n wxX11-unicode-gl
437 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
438
439 %description -n wxX11-unicode-gl -l pl
440 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
441
442 %package -n wxX11-unicode-gl-devel
443 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
444 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
445 Group:          X11/Development/Libraries
446 Requires:       wxX11-unicode-gl = %{version}-%{release}
447 Requires:       wxX11-unicode-devel = %{version}-%{release}
448 Requires:       OpenGL-GLU-devel
449 Obsoletes:      wxX11-univ-unicode-gl-devel
450
451 %description -n wxX11-unicode-gl-devel
452 Development files for GL canvas library for wxUniversal-based wxX11
453 with UNICODE support.
454
455 %description -n wxX11-unicode-gl-devel -l pl
456 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
457 obs³ug± UNICODE.
458
459 %prep
460 %setup -q
461 %patch0 -p1
462 %patch1 -p1
463 %patch2 -p1
464 %patch3 -p1
465 %patch4 -p1
466 %patch5 -p1
467 %patch6 -p1
468
469 %build
470 # if bakefiles rebuild is needed:
471 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
472 #cd build/bakefiles
473 #bakefile_gen -f autoconf
474 #cd ../..
475 #%endif
476 cp -f /usr/share/automake/config.sub .
477 %{__aclocal} -I build/aclocal
478 %{__autoconf}
479
480 CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
481 # avoid adding -s to LDFLAGS
482 LDFLAGS=" "; export LDFLAGS
483 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
484         --enable-plugins \
485         --enable-std_iostreams \
486         --without-sdl \
487         --with-opengl \
488         --enable-calendar \
489         --enable-controls \
490         --enable-tabdialog"
491
492 gui='--with-gtk'
493 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
494         '--enable-unicode' ; do
495         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
496         mkdir $objdir
497         cd $objdir
498         ../%configure \
499                 ${args} \
500                 ${gui} \
501                 --disable-universal \
502                 ${unicode}
503         %{__make}
504         %{__make} -C contrib/src
505         cd ..
506 done
507
508 %if %{with x11}
509 gui='--with-x11'
510 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
511         '--enable-unicode' ; do
512         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
513         mkdir $objdir
514         cd $objdir
515         ../%configure \
516                 ${args} \
517                 ${gui} \
518                 --enable-universal \
519                 ${unicode}
520         %{__make}
521         %{__make} -C contrib/src
522         if echo $objdir| grep -q disable-unicode ; then
523                 %{__make} -C utils
524                 %{__make} -C utils/emulator
525                 %{__make} -C utils/hhp2cached
526                 # %{__make} -C contrib/utils
527         fi
528         cd ..
529 done
530 %endif
531
532 cd locale
533 %{__make} allmo
534
535 %install
536 rm -rf $RPM_BUILD_ROOT
537 install -d $RPM_BUILD_ROOT%{_bindir}
538
539 gui='--with-gtk'
540 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
541         '--enable-unicode' ; do
542         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
543         cd $objdir
544         %{__make} install \
545                 prefix=$RPM_BUILD_ROOT%{_prefix} \
546                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
547                 bindir=$RPM_BUILD_ROOT%{_bindir} \
548                 datadir=$RPM_BUILD_ROOT%{_datadir} \
549                 libdir=$RPM_BUILD_ROOT%{_libdir} \
550                 mandir=$RPM_BUILD_ROOT%{_mandir} \
551                 includedir=$RPM_BUILD_ROOT%{_includedir}
552
553         %{__make} -C contrib/src install \
554                 prefix=$RPM_BUILD_ROOT%{_prefix} \
555                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
556                 bindir=$RPM_BUILD_ROOT%{_bindir} \
557                 datadir=$RPM_BUILD_ROOT%{_datadir} \
558                 libdir=$RPM_BUILD_ROOT%{_libdir} \
559                 mandir=$RPM_BUILD_ROOT%{_mandir} \
560                 includedir=$RPM_BUILD_ROOT%{_includedir}
561         cd ..
562 done
563
564 %if %{with x11}
565 gui='--with-x11'
566 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
567         '--enable-unicode' ; do
568         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
569         cd $objdir
570         %{__make} install \
571                 prefix=$RPM_BUILD_ROOT%{_prefix} \
572                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
573                 bindir=$RPM_BUILD_ROOT%{_bindir} \
574                 datadir=$RPM_BUILD_ROOT%{_datadir} \
575                 libdir=$RPM_BUILD_ROOT%{_libdir} \
576                 mandir=$RPM_BUILD_ROOT%{_mandir} \
577                 includedir=$RPM_BUILD_ROOT%{_includedir}
578         if echo $objdir| grep -q disable-unicode ; then
579 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
580                 # TODO: install default config files and default backgrouds
581                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
582                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
583                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
584                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
585 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
586                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
587 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
588 #               install -m644 utils/makegen/templates/* \
589 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
590 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
591 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
592 #               install contrib/utils/wxrcedit/df/* \
593 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
594         fi
595
596         %{__make} -C contrib/src install \
597                 prefix=$RPM_BUILD_ROOT%{_prefix} \
598                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
599                 bindir=$RPM_BUILD_ROOT%{_bindir} \
600                 datadir=$RPM_BUILD_ROOT%{_datadir} \
601                 libdir=$RPM_BUILD_ROOT%{_libdir} \
602                 mandir=$RPM_BUILD_ROOT%{_mandir} \
603                 includedir=$RPM_BUILD_ROOT%{_includedir}
604
605         cd ..
606 done
607 %endif
608
609 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
610 do
611         b=`basename $i`
612         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
613 done
614
615 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
616 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
617 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
618
619 %find_lang wxstd
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %post   -n wxBase -p /sbin/ldconfig
625 %postun -n wxBase -p /sbin/ldconfig
626
627 %post   -n wxBase-unicode -p /sbin/ldconfig
628 %postun -n wxBase-unicode -p /sbin/ldconfig
629
630 %post   -n wxGTK2 -p /sbin/ldconfig
631 %postun -n wxGTK2 -p /sbin/ldconfig
632
633 %post   -n wxGTK2-gl -p /sbin/ldconfig
634 %postun -n wxGTK2-gl -p /sbin/ldconfig
635
636 %post   -n wxGTK2-unicode -p /sbin/ldconfig
637 %postun -n wxGTK2-unicode -p /sbin/ldconfig
638
639 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
640 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
641
642 %post   -n wxX11 -p /sbin/ldconfig
643 %postun -n wxX11 -p /sbin/ldconfig
644
645 %post   -n wxX11-unicode -p /sbin/ldconfig
646 %postun -n wxX11-unicode -p /sbin/ldconfig
647
648 %define _libf %{?with_debug:d}
649 %define _configf %{?with_debug:-debug-2.8}
650
651 %files -f wxstd.lang
652 %defattr(644,root,root,755)
653 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
654
655 %files devel
656 %defattr(644,root,root,755)
657 %doc docs/html
658 %doc docs/tech docs/univ
659 %{_includedir}/wx*
660 %dir %{_libdir}/wx
661 %dir %{_libdir}/wx/include
662 %dir %{_libdir}/wx/config
663 %{_aclocaldir}/*.m4
664
665 %files examples
666 %defattr(644,root,root,755)
667 %{_examplesdir}/%{name}-%{version}
668
669 %if %{with x11}
670 %files HelpGen
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/HelpGen
673 %endif
674
675 %if %{with ansi}
676 %files -n wxBase
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
679 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
680 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
681
682 %files -n wxBase-devel
683 %defattr(644,root,root,755)
684 %{_libdir}/libwx_base%{_libf}-*.so
685 %{_libdir}/libwx_base%{_libf}_*.so
686 %endif
687
688 %files -n wxBase-unicode
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
691 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
692 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
693
694 %files -n wxBase-unicode-devel
695 %defattr(644,root,root,755)
696 %{_libdir}/libwx_baseu%{_libf}-*.so
697 %{_libdir}/libwx_baseu%{_libf}_*.so
698
699 %if %{with ansi}
700 %files -n wxGTK2
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
703 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
704
705 %files -n wxGTK2-devel
706 %defattr(644,root,root,755)
707 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
708 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
709 %{_libdir}/wx/config/gtk2-ansi-*
710 %{_libdir}/wx/include/gtk2-ansi-*
711 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
712
713 %files -n wxGTK2-gl
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
716
717 %files -n wxGTK2-gl-devel
718 %defattr(644,root,root,755)
719 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
720 %endif
721
722 %files -n wxGTK2-unicode
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
725 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
726
727 %files -n wxGTK2-unicode-devel
728 %defattr(644,root,root,755)
729 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
730 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
731 %{_libdir}/wx/config/gtk2-unicode-*
732 %{_libdir}/wx/include/gtk2-unicode-*
733 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
734
735 %files -n wxGTK2-unicode-gl
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
738
739 %files -n wxGTK2-unicode-gl-devel
740 %defattr(644,root,root,755)
741 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
742
743 %if %{with x11}
744 %if %{with ansi}
745 %files utils
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_bindir}/*
748 %exclude %{_bindir}/HelpGen
749 %exclude %{_bindir}/wx*-config
750
751 %files -n wxX11
752 %defattr(644,root,root,755)
753 %doc docs/wxX11-readme.txt
754 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
755 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
756
757 %files -n wxX11-devel
758 %defattr(644,root,root,755)
759 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
760 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
761 %{_libdir}/wx/config/x11univ-ansi-*
762 %{_libdir}/wx/include/x11univ-ansi-*
763 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
764
765 %files -n wxX11-gl
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
768
769 %files -n wxX11-gl-devel
770 %defattr(644,root,root,755)
771 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
772 %endif
773
774 %files -n wxX11-unicode
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
777 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
778
779 %files -n wxX11-unicode-devel
780 %defattr(644,root,root,755)
781 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
782 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
783 %{_libdir}/wx/config/x11univ-unicode-*
784 %{_libdir}/wx/include/x11univ-unicode-*
785 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
786
787 %files -n wxX11-unicode-gl
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
790
791 %files -n wxX11-unicode-gl-devel
792 %defattr(644,root,root,755)
793 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
794 %endif
This page took 0.109818 seconds and 4 git commands to generate.