]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
720775609a04b282da872ac8d60a3937a8da1bf3
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_without  x11                     # don't build wxX11 packages
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8 #
9 # Unpackaged files:
10 #  /usr/bin/wxrc-2.6
11 #  /usr/share/bakefile/presets/wx.bkl
12 #  /usr/share/bakefile/presets/wx_unix.bkl
13 #  /usr/share/bakefile/presets/wx_win32.bkl
14 #  /usr/share/locale/it/LC_MESSAGES/wxmsw.mo
15 #
16
17 Summary:        wxWidgets library
18 Summary(pl):    Biblioteka wxWidgets
19 Name:           wxWidgets
20 Version:        2.8.0
21 Release:        0.1
22 License:        wxWidgets Licence (LGPL with exception)
23 Group:          X11/Libraries
24 Source0:        http://ftp.wxwidgets.org/pub/%{version}/%{name}-%{version}.tar.bz2
25 # Source0-md5:  4bf9c66cdb7cda1d2fe51376c211b9e1
26 Patch0:         %{name}-samples.patch
27 Patch1:         %{name}-ogl.patch
28 Patch2:         %{name}-ac.patch
29 Patch3:         %{name}-gif0delay.patch
30 Patch4:         %{name}-x11unicode.patch
31 Patch5:         %{name}-gcc4.patch
32 URL:            http://www.wxWidgets.org/
33 BuildRequires:  OpenGL-GLU-devel
34 #BuildRequires: SDL-devel
35 BuildRequires:  autoconf >= 2.59-9
36 BuildRequires:  automake
37 #BuildRequires: bakefile >= 0.1.9
38 BuildRequires:  cppunit-devel
39 BuildRequires:  esound-devel
40 BuildRequires:  expat-devel
41 BuildRequires:  flex
42 BuildRequires:  gettext-devel
43 BuildRequires:  gtk+2-devel >= 2.0.0
44 BuildRequires:  libjpeg-devel
45 BuildRequires:  libmng-devel
46 BuildRequires:  libmspack-devel
47 BuildRequires:  libpng-devel
48 BuildRequires:  libstdc++-devel
49 BuildRequires:  libtiff-devel
50 BuildRequires:  libtool
51 BuildRequires:  pkgconfig
52 %{?with_x11:BuildRequires:      xorg-lib-libXext-devel}
53 # these are not supported by wxWidgets
54 Obsoletes:      LDAPExplorerTool <= 0.6-1
55 Obsoletes:      abridge <= 0.4.0-1
56 # and these are replaced
57 Obsoletes:      wxGTK
58 Obsoletes:      wxGTK-devel
59 Obsoletes:      wxGTK-gl
60 Obsoletes:      wxGTK-gl-devel
61 Obsoletes:      wxGTK-univ
62 Obsoletes:      wxGTK-univ-devel
63 Obsoletes:      wxGTK-univ-gl
64 Obsoletes:      wxGTK-univ-gl-devel
65 Obsoletes:      wxGTK2-univ
66 Obsoletes:      wxGTK2-univ-devel
67 Obsoletes:      wxGTK2-univ-gl
68 Obsoletes:      wxGTK2-univ-gl-devel
69 Obsoletes:      wxGTK2-univ-unicode
70 Obsoletes:      wxGTK2-univ-unicode-devel
71 Obsoletes:      wxGTK2-univ-unicode-gl
72 Obsoletes:      wxGTK2-univ-unicode-gl-devel
73 Obsoletes:      wxMotif
74 Obsoletes:      wxMotif-devel
75 Obsoletes:      wxMotif-gl
76 Obsoletes:      wxMotif-gl-devel
77 Obsoletes:      wxWidgets-afm
78 Obsoletes:      wxWindows
79 Obsoletes:      wxWindows-afm
80 Obsoletes:      wxwin-afm
81 Obsoletes:      wxwin-common
82 Conflicts:      wxGTK2 < 2.6.0
83 Conflicts:      wxGTK2-unicode < 2.6.0
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 %define         _sysconfdir     %{_datadir}
87
88 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
89
90 %description
91 wxWidgets is a free C++ library for cross-platform GUI development.
92 With wxWidgets, you can create applications for different GUIs (GTK+,
93 Motif/LessTif, MS Windows, Mac) from the same source code.
94
95 %description -l pl
96 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
97 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
98 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
99 Windows, Mac) z tego samego kodu ¼ród³owego.
100
101 %package devel
102 Summary:        wxWidgets header files and development documentation
103 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
104 Group:          X11/Development/Libraries
105 Requires:       libstdc++-devel
106 Obsoletes:      wxWindows-devel
107
108 %description devel
109 Header files and development documentation for the wxWidgets
110 libraries.
111
112 %description devel -l pl
113 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
114
115 %package examples
116 Summary:        wxWidgets example programs
117 Summary(pl):    Przyk³adowe programy wxWidgets
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Obsoletes:      wxWindows-examples
121
122 %description examples
123 wxWidgets example programs.
124
125 %description examples -l pl
126 Przyk³adowe programy wxWidgets.
127
128 %package HelpGen
129 Summary:        Help file generator for wxWidgets programs
130 Summary(pl):    Generator plików pomocy dla programów wxWidgets
131 Group:          Development/Tools
132 Requires:       wxBase = %{version}-%{release}
133 Obsoletes:      wxWindows-HelpGen
134
135 %description HelpGen
136 Help file generator for wxWidgets programs.
137
138 %description HelpGen -l pl
139 Generator plików pomocy dla programów wxWidgets.
140
141 %package -n wxBase
142 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
143 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
144 Group:          X11/Libraries
145 Requires:       %{name} = %{version}-%{release}
146
147 %description -n wxBase
148 wxBase is a collection of C++ classes providing basic data structures
149 (strings, lists, arrays), powerful wxDateTime class for date
150 manipulations, portable wrappers around many OS-specific functions
151 allowing to build the same program under all supported folders,
152 wxThread class for writing multithreaded programs using either Win32
153 or POSIX threads and much more. wxBase currently supports the
154 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
155 HP-UX, ...) and BeOS.
156
157 %description -n wxBase -l pl
158 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
159 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
160 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
161 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
162 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
163 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
164 platformy: Win32, Unix i BeOS.
165
166 %package -n wxBase-devel
167 Summary:        wxBase headers needed for developping with wxBase
168 Summary(pl):    Pliki nag³ówkowe do wxBase
169 Group:          X11/Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171 Requires:       wxBase = %{version}-%{release}
172
173 %description -n wxBase-devel
174 Header files for wxBase. You need them to develop programs using
175 wxBase.
176
177 %description -n wxBase-devel -l pl
178 Pliki nag³ówkowe do biblioteki wxBase.
179
180 %package -n wxBase-unicode
181 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
182 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
183 Group:          X11/Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description -n wxBase-unicode
187 wxBase is a collection of C++ classes providing basic data structures
188 (strings, lists, arrays), powerful wxDateTime class for date
189 manipulations, portable wrappers around many OS-specific functions
190 allowing to build the same program under all supported folders,
191 wxThread class for writing multithreaded programs using either Win32
192 or POSIX threads and much more. wxBase currently supports the
193 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
194 HP-UX, ...) and BeOS. This version is build with UNICODE support.
195
196 %description -n wxBase-unicode -l pl
197 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
198 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
199 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
200 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
201 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
202 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
203 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
204 UNICODE.
205
206 %package -n wxBase-unicode-devel
207 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
208 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
209 Group:          X11/Development/Libraries
210 Requires:       %{name}-devel = %{version}-%{release}
211 Requires:       wxBase-unicode = %{version}-%{release}
212
213 %description -n wxBase-unicode-devel
214 Header files for wxBase. You need them to develop programs using
215 UNICODE-enabled wxBase.
216
217 %description -n wxBase-unicode-devel -l pl
218 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
219
220 %package -n wxGTK2
221 Summary:        wxGTK2 library
222 Summary(pl):    Biblioteka wxGTK2
223 Group:          X11/Libraries
224 Requires:       %{name} = %{version}-%{release}
225 Obsoletes:      wxGTK2-univ
226
227 %description -n wxGTK2
228 wxWidgets library using GTK2 widgets.
229
230 %description -n wxGTK2 -l pl
231 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
232
233 %package -n wxGTK2-devel
234 Summary:        Header files for wxGTK2 library
235 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
236 Group:          X11/Development/Libraries
237 Requires:       wxBase-devel = %{version}-%{release}
238 Requires:       wxGTK2 = %{version}-%{release}
239 Obsoletes:      wxGTK2-univ-devel
240
241 %description -n wxGTK2-devel
242 Header files for wxWidgets library using GTK2 widgets.
243
244 %description -n wxGTK2-devel -l pl
245 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
246
247 %package -n wxGTK2-gl
248 Summary:        GL canvas library for wxGTK2
249 Summary(pl):    Biblioteka GL dla wxGTK2
250 Group:          X11/Libraries
251 Requires:       wxGTK2 = %{version}-%{release}
252 Obsoletes:      wxGTK2-univ-gl
253
254 %description -n wxGTK2-gl
255 wxGTK2 GL canvas library.
256
257 %description -n wxGTK2-gl -l pl
258 Biblioteka GL dla wxGTK2.
259
260 %package -n wxGTK2-gl-devel
261 Summary:        Development files for GL canvas library for wxGTK2
262 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
263 Group:          X11/Development/Libraries
264 Requires:       wxGTK2-devel = %{version}-%{release}
265 Requires:       wxGTK2-gl = %{version}-%{release}
266 Requires:       OpenGL-GLU-devel
267 Obsoletes:      wxGTK2-univ-gl-devel
268
269 %description -n wxGTK2-gl-devel
270 Development files for wxGTK2 GL canvas library.
271
272 %description -n wxGTK2-gl-devel -l pl
273 Pliki programistyczne biblioteki GL dla wxGTK2.
274
275 %package -n wxGTK2-unicode
276 Summary:        wxGTK2 library with UNICODE support
277 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
278 Group:          X11/Libraries
279 Requires:       %{name} = %{version}-%{release}
280 Obsoletes:      wxGTK2-univ-unicode
281
282 %description -n wxGTK2-unicode
283 wxWidgets library using GTK2 widgets with UNICODE support.
284
285 %description -n wxGTK2-unicode -l pl
286 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
287
288 %package -n wxGTK2-unicode-devel
289 Summary:        Header files for wxGTK2 library with UNICODE support
290 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
291 Group:          X11/Development/Libraries
292 Requires:       wxBase-unicode-devel = %{version}-%{release}
293 Requires:       wxGTK2-unicode = %{version}-%{release}
294 Obsoletes:      wxGTK2-univ-unicode-devel
295
296 %description -n wxGTK2-unicode-devel
297 Header files for wxWidgets library using GTK2 widgets with UNICODE
298 support.
299
300 %description -n wxGTK2-unicode-devel -l pl
301 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
302 obs³ug± UNICODE.
303
304 %package -n wxGTK2-unicode-gl
305 Summary:        GL canvas library for wxGTK2 with UNICODE support
306 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
307 Group:          X11/Libraries
308 Requires:       wxGTK2-unicode = %{version}-%{release}
309 Obsoletes:      wxGTK2-univ-unicode-gl
310
311 %description -n wxGTK2-unicode-gl
312 GL canvas library for wxGTK2 with UNICODE support.
313
314 %description -n wxGTK2-unicode-gl -l pl
315 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
316
317 %package -n wxGTK2-unicode-gl-devel
318 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
319 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
320 Group:          X11/Development/Libraries
321 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
322 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
323 Requires:       OpenGL-GLU-devel
324 Obsoletes:      wxGTK2-univ-unicode-gl-devel
325
326 %description -n wxGTK2-unicode-gl-devel
327 Development files for GL canvas library for wxGTK2 with UNICODE
328 support.
329
330 %description -n wxGTK2-unicode-gl-devel -l pl
331 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
332
333 %package utils
334 Summary:        Misc utils from wxWidgets project
335 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
336 Group:          X11/Development/Tools
337 Requires:       wxX11 = %{version}-%{release}
338 Obsoletes:      wxWindows-utils
339
340 %description utils
341 Misc utils from wxWidgets project: helpviewer, makegen, etc.
342
343 %description utils -l pl
344 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
345
346 %package -n wxX11
347 Summary:        wxUniversal-based wxX11 library
348 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
349 Group:          X11/Libraries
350 Requires:       %{name} = %{version}-%{release}
351 Obsoletes:      wxX11-univ
352
353 %description -n wxX11
354 wxUniversal-based wxX11 library.
355
356 %description -n wxX11 -l pl
357 Oparta na wxUniversal biblioteka wxX11.
358
359 %package -n wxX11-devel
360 Summary:        Header files for wxUniversal-based wxX11 library
361 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
362 Group:          X11/Libraries
363 Requires:       %{name}-devel = %{version}-%{release}
364 Requires:       wxX11 = %{version}-%{release}
365 Obsoletes:      wxX11-univ-devel
366
367 %description -n wxX11-devel
368 Header files for wxUniversal-based wxX11 library.
369
370 %description -n wxX11-devel -l pl
371 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
372
373 %package -n wxX11-gl
374 Summary:        GL canvas library for wxUniversal-based wxX11
375 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
376 Group:          X11/Libraries
377 Requires:       wxX11 = %{version}-%{release}
378 Obsoletes:      wxX11-univ-gl
379
380 %description -n wxX11-gl
381 GL canvas library for wxUniversal-based wxX11.
382
383 %description -n wxX11-gl -l pl
384 Biblioteka GL dla opartej na wxUniversal wxX11.
385
386 %package -n wxX11-gl-devel
387 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
388 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
389 Group:          X11/Development/Libraries
390 Requires:       wxX11-gl = %{version}-%{release}
391 Requires:       wxX11-devel = %{version}-%{release}
392 Requires:       OpenGL-GLU-devel
393 Obsoletes:      wxX11-univ-gl-devel
394
395 %description -n wxX11-gl-devel
396 Development files for GL canvas library for wxUniversal-based wxX11.
397
398 %description -n wxX11-gl-devel -l pl
399 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
400
401 %package -n wxX11-unicode
402 Summary:        wxUniversal-based wxX11 library with UNICODE support
403 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
404 Group:          X11/Libraries
405 Requires:       %{name} = %{version}-%{release}
406 Obsoletes:      wxX11-univ-unicode
407
408 %description -n wxX11-unicode
409 wxUniversal-based wxX11 library with UNICODE support.
410
411 %description -n wxX11-unicode -l pl
412 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
413
414 %package -n wxX11-unicode-devel
415 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
416 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
417 Group:          X11/Development/Libraries
418 Requires:       %{name}-devel = %{version}-%{release}
419 Requires:       wxX11-unicode = %{version}-%{release}
420 Obsoletes:      wxX11-univ-unicode-devel
421
422 %description -n wxX11-unicode-devel
423 Header files for wxUniversal-based wxX11 library with UNICODE support.
424
425 %description -n wxX11-unicode-devel -l pl
426 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
427
428 %package -n wxX11-unicode-gl
429 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
430 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
431 Group:          X11/Libraries
432 Requires:       wxX11-unicode = %{version}-%{release}
433 Obsoletes:      wxX11-univ-unicode-gl
434
435 %description -n wxX11-unicode-gl
436 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
437
438 %description -n wxX11-unicode-gl -l pl
439 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
440
441 %package -n wxX11-unicode-gl-devel
442 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
443 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
444 Group:          X11/Development/Libraries
445 Requires:       wxX11-unicode-gl = %{version}-%{release}
446 Requires:       wxX11-unicode-devel = %{version}-%{release}
447 Requires:       OpenGL-GLU-devel
448 Obsoletes:      wxX11-univ-unicode-gl-devel
449
450 %description -n wxX11-unicode-gl-devel
451 Development files for GL canvas library for wxUniversal-based wxX11
452 with UNICODE support.
453
454 %description -n wxX11-unicode-gl-devel -l pl
455 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
456 obs³ug± UNICODE.
457
458 %prep
459 %setup -q
460 %patch0 -p1
461 %patch1 -p1
462 %patch2 -p1
463 %patch3 -p1
464 %patch4 -p1
465 %patch5 -p1
466
467 %build
468 # if bakefiles rebuild is needed:
469 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.9"
470 #cd build/bakefiles
471 #bakefile_gen -f autoconf
472 #cd ../..
473 #%endif
474 cp -f /usr/share/automake/config.sub .
475 %{__aclocal} -I build/aclocal
476 %{__autoconf}
477
478 CPPFLAGS="%{rpmcflags} -I`pwd`/include"; export CPPFLAGS
479 # avoid adding -s to LDFLAGS
480 LDFLAGS=" "; export LDFLAGS
481 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
482         --enable-plugins \
483         --enable-std_iostreams \
484         --without-sdl \
485         --with-opengl \
486         --enable-calendar \
487         --enable-controls \
488         --enable-tabdialog"
489
490 gui='--with-gtk'
491 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
492         '--enable-unicode' ; do
493         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
494         mkdir $objdir
495         cd $objdir
496         ../%configure \
497                 ${args} \
498                 ${gui} \
499                 --disable-universal \
500                 ${unicode}
501         %{__make}
502         %{__make} -C contrib/src
503         cd ..
504 done
505
506 %if %{with x11}
507 gui='--with-x11'
508 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
509         '--enable-unicode' ; do
510         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
511         mkdir $objdir
512         cd $objdir
513         ../%configure \
514                 ${args} \
515                 ${gui} \
516                 --enable-universal \
517                 ${unicode}
518         %{__make}
519         %{__make} -C contrib/src
520         if echo $objdir| grep -q disable-unicode ; then
521                 %{__make} -C utils
522                 %{__make} -C utils/emulator
523                 %{__make} -C utils/hhp2cached
524                 # %{__make} -C contrib/utils
525         fi
526         cd ..
527 done
528 %endif
529
530 cd locale
531 %{__make} allmo
532
533 %install
534 rm -rf $RPM_BUILD_ROOT
535 install -d $RPM_BUILD_ROOT%{_bindir}
536
537 gui='--with-gtk'
538 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
539         '--enable-unicode' ; do
540         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
541         cd $objdir
542         %{__make} install \
543                 prefix=$RPM_BUILD_ROOT%{_prefix} \
544                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
545                 bindir=$RPM_BUILD_ROOT%{_bindir} \
546                 datadir=$RPM_BUILD_ROOT%{_datadir} \
547                 libdir=$RPM_BUILD_ROOT%{_libdir} \
548                 mandir=$RPM_BUILD_ROOT%{_mandir} \
549                 includedir=$RPM_BUILD_ROOT%{_includedir}
550
551         %{__make} -C contrib/src install \
552                 prefix=$RPM_BUILD_ROOT%{_prefix} \
553                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
554                 bindir=$RPM_BUILD_ROOT%{_bindir} \
555                 datadir=$RPM_BUILD_ROOT%{_datadir} \
556                 libdir=$RPM_BUILD_ROOT%{_libdir} \
557                 mandir=$RPM_BUILD_ROOT%{_mandir} \
558                 includedir=$RPM_BUILD_ROOT%{_includedir}
559         cd ..
560 done
561
562 %if %{with x11}
563 gui='--with-x11'
564 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
565         '--enable-unicode' ; do
566         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
567         cd $objdir
568         %{__make} install \
569                 prefix=$RPM_BUILD_ROOT%{_prefix} \
570                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
571                 bindir=$RPM_BUILD_ROOT%{_bindir} \
572                 datadir=$RPM_BUILD_ROOT%{_datadir} \
573                 libdir=$RPM_BUILD_ROOT%{_libdir} \
574                 mandir=$RPM_BUILD_ROOT%{_mandir} \
575                 includedir=$RPM_BUILD_ROOT%{_includedir}
576         if echo $objdir| grep -q disable-unicode ; then
577 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
578                 # TODO: install default config files and default backgrouds
579                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
580                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
581                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
582                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
583 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
584                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
585 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
586 #               install -m644 utils/makegen/templates/* \
587 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
588 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
589 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
590 #               install contrib/utils/wxrcedit/df/* \
591 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
592         fi
593
594         %{__make} -C contrib/src install \
595                 prefix=$RPM_BUILD_ROOT%{_prefix} \
596                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
597                 bindir=$RPM_BUILD_ROOT%{_bindir} \
598                 datadir=$RPM_BUILD_ROOT%{_datadir} \
599                 libdir=$RPM_BUILD_ROOT%{_libdir} \
600                 mandir=$RPM_BUILD_ROOT%{_mandir} \
601                 includedir=$RPM_BUILD_ROOT%{_includedir}
602
603         cd ..
604 done
605 %endif
606
607 set -x
608
609 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
610 do
611         b=`basename $i`
612         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
613 done
614
615 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
616 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
617 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
618
619 %find_lang wxstd
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %post   -n wxBase -p /sbin/ldconfig
625 %postun -n wxBase -p /sbin/ldconfig
626
627 %post   -n wxBase-unicode -p /sbin/ldconfig
628 %postun -n wxBase-unicode -p /sbin/ldconfig
629
630 %post   -n wxGTK2 -p /sbin/ldconfig
631 %postun -n wxGTK2 -p /sbin/ldconfig
632
633 %post   -n wxGTK2-gl -p /sbin/ldconfig
634 %postun -n wxGTK2-gl -p /sbin/ldconfig
635
636 %post   -n wxGTK2-unicode -p /sbin/ldconfig
637 %postun -n wxGTK2-unicode -p /sbin/ldconfig
638
639 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
640 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
641
642 %post   -n wxX11 -p /sbin/ldconfig
643 %postun -n wxX11 -p /sbin/ldconfig
644
645 %post   -n wxX11-unicode -p /sbin/ldconfig
646 %postun -n wxX11-unicode -p /sbin/ldconfig
647
648 %define _libf %{?with_debug:d}
649 %define _configf %{?with_debug:-debug-2.8}
650
651 %files -f wxstd.lang
652 %defattr(644,root,root,755)
653 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
654
655 %files devel
656 %defattr(644,root,root,755)
657 %doc docs/html
658 %doc docs/tech docs/univ
659 %{_includedir}/wx*
660 %dir %{_libdir}/wx
661 %dir %{_libdir}/wx/include
662 %dir %{_libdir}/wx/config
663 %{_aclocaldir}/*.m4
664
665 %files examples
666 %defattr(644,root,root,755)
667 %{_examplesdir}/%{name}-%{version}
668
669 %if %{with x11}
670 %files HelpGen
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_bindir}/HelpGen
673 %endif
674
675 %if %{with ansi}
676 %files -n wxBase
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}-*.so.*.*
679 %attr(755,root,root) %{_libdir}/libwx_base%{_libf}_*.so.*.*
680 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
681
682 %files -n wxBase-devel
683 %defattr(644,root,root,755)
684 %{_libdir}/libwx_base%{_libf}-*.so
685 %{_libdir}/libwx_base%{_libf}_*.so
686 %endif
687
688 %files -n wxBase-unicode
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}-*.so.*.*
691 %attr(755,root,root) %{_libdir}/libwx_baseu%{_libf}_*.so.*.*
692 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
693
694 %files -n wxBase-unicode-devel
695 %defattr(644,root,root,755)
696 %{_libdir}/libwx_baseu%{_libf}-*.so
697 %{_libdir}/libwx_baseu%{_libf}_*.so
698
699 %if %{with ansi}
700 %files -n wxGTK2
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_*.so.*.*
703 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
704
705 %files -n wxGTK2-devel
706 %defattr(644,root,root,755)
707 %{_libdir}/libwx_gtk2%{_libf}_*-*.so
708 %exclude %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
709 %{_libdir}/wx/config/gtk2-ansi-*
710 %{_libdir}/wx/include/gtk2-ansi-*
711 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi%{_configf}-config
712
713 %files -n wxGTK2-gl
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/libwx_gtk2%{_libf}_gl-*.so.*.*
716
717 %files -n wxGTK2-gl-devel
718 %defattr(644,root,root,755)
719 %{_libdir}/libwx_gtk2%{_libf}_gl-*.so
720 %endif
721
722 %files -n wxGTK2-unicode
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_*-*.so.*.*
725 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
726
727 %files -n wxGTK2-unicode-devel
728 %defattr(644,root,root,755)
729 %{_libdir}/libwx_gtk2u%{_libf}_*-*.so
730 %exclude %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
731 %{_libdir}/wx/config/gtk2-unicode-*
732 %{_libdir}/wx/include/gtk2-unicode-*
733 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode%{_configf}-config
734
735 %files -n wxGTK2-unicode-gl
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so.*.*
738
739 %files -n wxGTK2-unicode-gl-devel
740 %defattr(644,root,root,755)
741 %{_libdir}/libwx_gtk2u%{_libf}_gl-*.so
742
743 %if %{with x11}
744 %if %{with ansi}
745 %files utils
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_bindir}/*
748 %exclude %{_bindir}/HelpGen
749 %exclude %{_bindir}/wx*-config
750
751 %files -n wxX11
752 %defattr(644,root,root,755)
753 %doc docs/wxX11-readme.txt
754 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_*-*.so.*.*
755 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
756
757 %files -n wxX11-devel
758 %defattr(644,root,root,755)
759 %{_libdir}/libwx_x11univ%{_libf}_*-*.so
760 %exclude %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
761 %{_libdir}/wx/config/x11univ-ansi-*
762 %{_libdir}/wx/include/x11univ-ansi-*
763 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi%{_configf}-config
764
765 %files -n wxX11-gl
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_libdir}/libwx_x11univ%{_libf}_gl-*.so.*.*
768
769 %files -n wxX11-gl-devel
770 %defattr(644,root,root,755)
771 %{_libdir}/libwx_x11univ%{_libf}_gl-*.so
772 %endif
773
774 %files -n wxX11-unicode
775 %defattr(644,root,root,755)
776 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_*-*.so.*.*
777 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
778
779 %files -n wxX11-unicode-devel
780 %defattr(644,root,root,755)
781 %{_libdir}/libwx_x11univu%{_libf}_*-*.so
782 %exclude %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
783 %{_libdir}/wx/config/x11univ-unicode-*
784 %{_libdir}/wx/include/x11univ-unicode-*
785 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode%{_configf}-config
786
787 %files -n wxX11-unicode-gl
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/libwx_x11univu%{_libf}_gl-*.so.*.*
790
791 %files -n wxX11-unicode-gl-devel
792 %defattr(644,root,root,755)
793 %{_libdir}/libwx_x11univu%{_libf}_gl-*.so
794 %endif
This page took 0.083992 seconds and 3 git commands to generate.