]> git.pld-linux.org Git - packages/wxWidgets.git/blob - wxWidgets.spec
1bd31d6908df71aa90da05bd1518407013b4b0c6
[packages/wxWidgets.git] / wxWidgets.spec
1 #
2 # Conditional build:
3 %bcond_without  ansi                    # only unicode packages
4 %bcond_without  odbc                    # without ODBC support
5 %bcond_with     x11                     # with wxX11 packages (broken)
6 %bcond_with     debug                   # build with \--enable-debug
7                                         # (binary incompatible with non-debug)
8
9 Summary:        wxWidgets library
10 Summary(pl):    Biblioteka wxWidgets
11 Name:           wxWidgets
12 Version:        2.6.0
13 Release:        1
14 License:        wxWidgets Licence (LGPL with exception)
15 Group:          X11/Libraries
16 Source0:        http://dl.sourceforge.net/wxwindows/%{name}-%{version}.tar.gz
17 # Source0-md5:  a9d87fec714c0dc79ba1f5b8f1ded50c
18 Patch0:         %{name}-samples.patch
19 #Patch1:                %{name}-utils.patch
20 Patch2:         %{name}-ogl.patch
21 Patch3:         %{name}-ac.patch
22 Patch4:         %{name}-gif0delay.patch
23 URL:            http://www.wxWidgets.org/
24 BuildRequires:  OpenGL-devel
25 BuildRequires:  SDL-devel
26 BuildRequires:  autoconf >= 2.58
27 BuildRequires:  automake
28 BuildRequires:  bakefile >= 0.1.7
29 BuildRequires:  cppunit-devel
30 BuildRequires:  esound-devel
31 BuildRequires:  expat-devel
32 BuildRequires:  flex
33 BuildRequires:  gettext-devel
34 BuildRequires:  gtk+2-devel
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libmng-devel
37 BuildRequires:  libpng-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtiff-devel
40 BuildRequires:  libtool
41 BuildRequires:  pkgconfig
42 Obsoletes:      wxwin-common
43 Obsoletes:      wxGTK
44 Obsoletes:      wxGTK-devel
45 Obsoletes:      wxGTK-gl
46 Obsoletes:      wxGTK-gl-devel
47 Obsoletes:      wxGTK-univ
48 Obsoletes:      wxGTK-univ-devel
49 Obsoletes:      wxGTK-univ-gl
50 Obsoletes:      wxGTK-univ-gl-devel
51 Obsoletes:      wxGTK2-univ
52 Obsoletes:      wxGTK2-univ-devel
53 Obsoletes:      wxGTK2-univ-gl
54 Obsoletes:      wxGTK2-univ-gl-devel
55 Obsoletes:      wxGTK2-univ-unicode
56 Obsoletes:      wxGTK2-univ-unicode-devel
57 Obsoletes:      wxGTK2-univ-unicode-gl
58 Obsoletes:      wxGTK2-univ-unicode-gl-devel
59 Obsoletes:      wxMotif
60 Obsoletes:      wxMotif-devel
61 Obsoletes:      wxMotif-gl
62 Obsoletes:      wxMotif-gl-devel
63 Obsoletes:      wxWindows
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %define         _sysconfdir     %{_datadir}
67
68 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
69
70 %description
71 wxWidgets is a free C++ library for cross-platform GUI development.
72 With wxWidgets, you can create applications for different GUIs (GTK+,
73 Motif/LessTif, MS Windows, Mac) from the same source code.
74
75 %description -l pl
76 wxWidgets to wolnodostêpna biblioteka napisana w C++ umo¿liwiaj±ca
77 rozwijanie wieloplatformowych programów GUI. Przy u¿yciu wxWidgets
78 mo¿na tworzyæ aplikacje dla ró¿nych GUI (GTK+, Motif/LessTif, MS
79 Windows, Mac) z tego samego kodu ¼ród³owego.
80
81 %package afm
82 Summary:        Font metrics common for wxGTK, wxGTK2, wxMotif i wxX11
83 Summary(pl):    Metryki fontów wspólne dla wxGTK, wxGTK2, wxMotif i wxX11
84 Group:          X11/Libraries
85 Requires:       %{name} = %{version}-%{release}
86 Obsoletes:      wxwin-afm
87 Obsoletes:      wxWindows-afm
88
89 %description afm
90 Font metrics (in AFM format) common for wxGTK, wxGTK2, wxMotif and
91 wxX11 libraries.
92
93 %description afm -l pl
94 Metryki fontów (w formacie AFM) wspólne dla bibliotek wxGTK, wxGTK2,
95 wxMotif i wxX11.
96
97 %package devel
98 Summary:        wxWidgets header files and development documentation
99 Summary(pl):    Pliki nag³ówkowe i dokumentacja do wxWidgets
100 Group:          X11/Development/Libraries
101 Requires:       libstdc++-devel
102 Obsoletes:      wxWindows-devel
103
104 %description devel
105 Header files and development documentation for the wxWidgets
106 libraries.
107
108 %description devel -l pl
109 Pliki nag³ówkowe i dokumentacja do bibliotek wxWidgets.
110
111 %package examples
112 Summary:        wxWidgets example programs
113 Summary(pl):    Przyk³adowe programy wxWidgets
114 Group:          X11/Development/Libraries
115 Requires:       %{name}-devel = %{version}-%{release}
116 Obsoletes:      wxWindows-examples
117
118 %description examples
119 wxWidgets example programs.
120
121 %description examples -l pl
122 Przyk³adowe programy wxWidgets.
123
124 %package HelpGen
125 Summary:        Help file generator for wxWidgets programs
126 Summary(pl):    Generator plików pomocy dla programów wxWidgets
127 Group:          Development/Tools
128 Requires:       wxBase = %{version}-%{release}
129 Obsoletes:      wxWindows-HelpGen
130
131 %description HelpGen
132 Help file generator for wxWidgets programs.
133
134 %description HelpGen -l pl
135 Generator plików pomocy dla programów wxWidgets.
136
137 %package -n wxBase
138 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit
139 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI
140 Group:          X11/Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description -n wxBase
144 wxBase is a collection of C++ classes providing basic data structures
145 (strings, lists, arrays), powerful wxDateTime class for date
146 manipulations, portable wrappers around many OS-specific functions
147 allowing to build the same program under all supported folders,
148 wxThread class for writing multithreaded programs using either Win32
149 or POSIX threads and much more. wxBase currently supports the
150 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
151 HP-UX, ...) and BeOS.
152
153 %description -n wxBase -l pl
154 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
155 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
156 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
157 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
158 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
159 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
160 platformy: Win32, Unix i BeOS.
161
162 %package -n wxBase-devel
163 Summary:        wxBase headers needed for developping with wxBase
164 Summary(pl):    Pliki nag³ówkowe do wxBase
165 Group:          X11/Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167 Requires:       wxBase = %{version}-%{release}
168
169 %description -n wxBase-devel
170 Header files for wxBase. You need them to develop programs using
171 wxBase.
172
173 %description -n wxBase-devel -l pl
174 Pliki nag³ówkowe do biblioteki wxBase.
175
176 %package -n wxBase-unicode
177 Summary:        wxBase library - non-GUI support classes of wxWidgets toolkit with UNICODE support
178 Summary(pl):    wxBase - biblioteka klas wxWidgets nie zwi±zanych z GUI ze wsparciem dla UNICODE
179 Group:          X11/Libraries
180 Requires:       %{name} = %{version}-%{release}
181
182 %description -n wxBase-unicode
183 wxBase is a collection of C++ classes providing basic data structures
184 (strings, lists, arrays), powerful wxDateTime class for date
185 manipulations, portable wrappers around many OS-specific functions
186 allowing to build the same program under all supported folders,
187 wxThread class for writing multithreaded programs using either Win32
188 or POSIX threads and much more. wxBase currently supports the
189 following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris,
190 HP-UX, ...) and BeOS. This version is build with UNICODE support.
191
192 %description -n wxBase-unicode -l pl
193 wxBase jest zestawem klas C++ obs³uguj±cych podstawowe struktury
194 danych (stringi, listy, tablice), klasê wxDateTime do operacji na
195 datach, przeno¶ne wrappery do wielu funkcji zale¿nych od systemu
196 operacyjnego pozwalaj±ce na zbudowanie tego samego programu w ró¿nych
197 ¶rodowiskach, klasê wxThread do pisania programów wielow±tkowych
198 u¿ywaj±cych w±tków Win32 albo POSIX i inne. wxBase obs³uguje
199 platformy: Win32, Unix i BeOS. Ta wersja jest zbudowana z obs³ug±
200 UNICODE.
201
202 %package -n wxBase-unicode-devel
203 Summary:        wxBase headers needed for developping with UNICODE-enabled wxBase
204 Summary(pl):    Pliki nag³ówkowe do wxBase z obs³ug± UNICODE
205 Group:          X11/Development/Libraries
206 Requires:       %{name}-devel = %{version}-%{release}
207 Requires:       wxBase-unicode = %{version}-%{release}
208
209 %description -n wxBase-unicode-devel
210 Header files for wxBase. You need them to develop programs using
211 UNICODE-enabled wxBase.
212
213 %description -n wxBase-unicode-devel -l pl
214 Pliki nag³ówkowe do biblioteki wxBase z obs³ug± UNICODE.
215
216 %package -n wxGTK2
217 Summary:        wxGTK2 library
218 Summary(pl):    Biblioteka wxGTK2
219 Group:          X11/Libraries
220 Requires:       %{name} = %{version}-%{release}
221 #Requires:      %{name}-afm = %{version}-%{release}
222 Obsoletes:      wxGTK2-univ
223
224 %description -n wxGTK2
225 wxWidgets library using GTK2 widgets.
226
227 %description -n wxGTK2 -l pl
228 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2.
229
230 %package -n wxGTK2-devel
231 Summary:        Header files for wxGTK2 library
232 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2
233 Group:          X11/Development/Libraries
234 Requires:       wxBase-devel = %{version}-%{release}
235 Requires:       wxGTK2 = %{version}-%{release}
236 Obsoletes:      wxGTK2-univ-devel
237
238 %description -n wxGTK2-devel
239 Header files for wxWidgets library using GTK2 widgets.
240
241 %description -n wxGTK2-devel -l pl
242 Pliki nag³ówkowe dla biblioteki wxWidgets u¿ywaj±cej widgetów GTK2.
243
244 %package -n wxGTK2-gl
245 Summary:        GL canvas library for wxGTK2
246 Summary(pl):    Biblioteka GL dla wxGTK2
247 Group:          X11/Libraries
248 Requires:       wxGTK2 = %{version}-%{release}
249 Requires:       OpenGL
250 Obsoletes:      wxGTK2-univ-gl
251
252 %description -n wxGTK2-gl
253 wxGTK2 GL canvas library.
254
255 %description -n wxGTK2-gl -l pl
256 Biblioteka GL dla wxGTK2.
257
258 %package -n wxGTK2-gl-devel
259 Summary:        Development files for GL canvas library for wxGTK2
260 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2
261 Group:          X11/Development/Libraries
262 Requires:       wxGTK2-devel = %{version}-%{release}
263 Requires:       wxGTK2-gl = %{version}-%{release}
264 Requires:       OpenGL-devel
265 Obsoletes:      wxGTK2-univ-gl-devel
266
267 %description -n wxGTK2-gl-devel
268 Development files for wxGTK2 GL canvas library.
269
270 %description -n wxGTK2-gl-devel -l pl
271 Pliki programistyczne biblioteki GL dla wxGTK2.
272
273 %package -n wxGTK2-unicode
274 Summary:        wxGTK2 library with UNICODE support
275 Summary(pl):    Biblioteka wxGTK2 z obs³ug± UNICODE
276 Group:          X11/Libraries
277 Requires:       %{name} = %{version}-%{release}
278 #Requires:      %{name}-afm = %{version}-%{release}
279 Obsoletes:      wxGTK2-univ-unicode
280
281 %description -n wxGTK2-unicode
282 wxWidgets library using GTK2 widgets with UNICODE support.
283
284 %description -n wxGTK2-unicode -l pl
285 Biblioteka wxWidgets u¿ywaj±ca widgetów GTK2 z obs³ug± UNICODE.
286
287 %package -n wxGTK2-unicode-devel
288 Summary:        Header files for wxGTK2 library with UNICODE support
289 Summary(pl):    Pliki nag³ówkowe biblioteki wxGTK2 z obs³ug± UNICODE
290 Group:          X11/Development/Libraries
291 Requires:       wxBase-unicode-devel = %{version}-%{release}
292 Requires:       wxGTK2-unicode = %{version}-%{release}
293 Obsoletes:      wxGTK2-univ-unicode-devel
294
295 %description -n wxGTK2-unicode-devel
296 Header files for wxWidgets library using GTK2 widgets with UNICODE
297 support.
298
299 %description -n wxGTK2-unicode-devel -l pl
300 Pliki nag³ówkowe biblioteki wxWidgets u¿ywaj±cej widgetów GTK2 z
301 obs³ug± UNICODE.
302
303 %package -n wxGTK2-unicode-gl
304 Summary:        GL canvas library for wxGTK2 with UNICODE support
305 Summary(pl):    Biblioteka GL dla wxGTK2 z obs³ug± UNICODE
306 Group:          X11/Libraries
307 Requires:       wxGTK2-unicode = %{version}-%{release}
308 Requires:       OpenGL
309 Obsoletes:      wxGTK2-univ-unicode-gl
310
311 %description -n wxGTK2-unicode-gl
312 GL canvas library for wxGTK2 with UNICODE support.
313
314 %description -n wxGTK2-unicode-gl -l pl
315 Biblioteka GL dla wxGTK2 z obs³ug± UNICODE.
316
317 %package -n wxGTK2-unicode-gl-devel
318 Summary:        Development files for GL canvas library for wxGTK2 with UNICODE support
319 Summary(pl):    Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE
320 Group:          X11/Development/Libraries
321 Requires:       wxGTK2-unicode-devel = %{version}-%{release}
322 Requires:       wxGTK2-unicode-gl = %{version}-%{release}
323 Requires:       OpenGL-devel
324 Obsoletes:      wxGTK2-univ-unicode-gl-devel
325
326 %description -n wxGTK2-unicode-gl-devel
327 Development files for GL canvas library for wxGTK2 with UNICODE
328 support.
329
330 %description -n wxGTK2-unicode-gl-devel -l pl
331 Pliki programistyczne biblioteki GL dla wxGTK2 z obs³ug± UNICODE.
332
333 %package utils
334 Summary:        Misc utils from wxWidgets project
335 Summary(pl):    Ró¿ne narzêdzia z projektu wxWidgets
336 Group:          X11/Development/Tools
337 Requires:       wxX11 = %{version}-%{release}
338 Obsoletes:      wxWindows-utils
339
340 %description utils
341 Misc utils from wxWidgets project: helpviewer, makegen, etc.
342
343 %description utils -l pl
344 Ró¿ne narzêdzia z projektu wxWidgets: helpviewer, makegen itp.
345
346 %package -n wxX11
347 Summary:        wxUniversal-based wxX11 library
348 Summary(pl):    Oparta na wxUniversal biblioteka wxX11
349 Group:          X11/Libraries
350 Requires:       %{name} = %{version}-%{release}
351 #Requires:      %{name}-afm = %{version}-%{release}
352 Obsoletes:      wxX11-univ
353
354 %description -n wxX11
355 wxUniversal-based wxX11 library.
356
357 %description -n wxX11 -l pl
358 Oparta na wxUniversal biblioteka wxX11.
359
360 %package -n wxX11-devel
361 Summary:        Header files for wxUniversal-based wxX11 library
362 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11
363 Group:          X11/Libraries
364 Requires:       %{name}-devel = %{version}-%{release}
365 Requires:       wxX11 = %{version}-%{release}
366 Obsoletes:      wxX11-univ-devel
367
368 %description -n wxX11-devel
369 Header files for wxUniversal-based wxX11 library.
370
371 %description -n wxX11-devel -l pl
372 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11.
373
374 %package -n wxX11-gl
375 Summary:        GL canvas library for wxUniversal-based wxX11
376 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11
377 Group:          X11/Libraries
378 Requires:       wxX11 = %{version}-%{release}
379 Requires:       OpenGL
380 Obsoletes:      wxX11-univ-gl
381
382 %description -n wxX11-gl
383 GL canvas library for wxUniversal-based wxX11.
384
385 %description -n wxX11-gl -l pl
386 Biblioteka GL dla opartej na wxUniversal wxX11.
387
388 %package -n wxX11-gl-devel
389 Summary:        Development files for GL canvas library for wxUniversal-based wxX11
390 Summary(pl):    Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11
391 Group:          X11/Development/Libraries
392 Requires:       wxX11-gl = %{version}-%{release}
393 Requires:       wxX11-devel = %{version}-%{release}
394 Requires:       OpenGL-devel
395 Obsoletes:      wxX11-univ-gl-devel
396
397 %description -n wxX11-gl-devel
398 Development files for GL canvas library for wxUniversal-based wxX11.
399
400 %description -n wxX11-gl-devel -l pl
401 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11.
402
403 %package -n wxX11-unicode
404 Summary:        wxUniversal-based wxX11 library with UNICODE support
405 Summary(pl):    Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE
406 Group:          X11/Libraries
407 Requires:       %{name} = %{version}-%{release}
408 #Requires:      %{name}-afm = %{version}-%{release}
409 Obsoletes:      wxX11-univ-unicode
410
411 %description -n wxX11-unicode
412 wxUniversal-based wxX11 library with UNICODE support.
413
414 %description -n wxX11-unicode -l pl
415 Oparta na wxUniversal biblioteka wxX11 z obs³ug± UNICODE.
416
417 %package -n wxX11-unicode-devel
418 Summary:        Header files for wxUniversal-based wxX11 library with UNICODE support
419 Summary(pl):    Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE
420 Group:          X11/Development/Libraries
421 Requires:       %{name}-devel = %{version}-%{release}
422 Requires:       wxX11-unicode = %{version}-%{release}
423 Obsoletes:      wxX11-univ-unicode-devel
424
425 %description -n wxX11-unicode-devel
426 Header files for wxUniversal-based wxX11 library with UNICODE support.
427
428 %description -n wxX11-unicode-devel -l pl
429 Pliki nag³ówkowe opartej na wxUniversal biblioteki wxX11 z obs³ug± UNICODE.
430
431 %package -n wxX11-unicode-gl
432 Summary:        GL canvas library for wxUniversal-based wxX11 with UNICODE support
433 Summary(pl):    Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE
434 Group:          X11/Libraries
435 Requires:       wxX11-unicode = %{version}-%{release}
436 Requires:       OpenGL
437 Obsoletes:      wxX11-univ-unicode-gl
438
439 %description -n wxX11-unicode-gl
440 GL canvas library for wxUniversal-based wxX11 with UNICODE support.
441
442 %description -n wxX11-unicode-gl -l pl
443 Biblioteka GL dla opartej na wxUniversal wxX11 z obs³ug± UNICODE.
444
445 %package -n wxX11-unicode-gl-devel
446 Summary:        Development files for GL canvas library for wxX11 with UNICODE support
447 Summary(pl):    Pliki programistyczne biblioteki GL dla wxX11 z obs³ug± UNICODE
448 Group:          X11/Development/Libraries
449 Requires:       wxX11-unicode-gl = %{version}-%{release}
450 Requires:       wxX11-unicode-devel = %{version}-%{release}
451 Requires:       OpenGL-devel
452 Obsoletes:      wxX11-univ-unicode-gl-devel
453
454 %description -n wxX11-unicode-gl-devel
455 Development files for GL canvas library for wxUniversal-based wxX11
456 with UNICODE support.
457
458 %description -n wxX11-unicode-gl-devel -l pl
459 Pliki programistyczne biblioteki GL dla opartej na wxUniversal wxX11 z
460 obs³ug± UNICODE.
461
462 %prep
463 %setup -q
464 %patch0 -p1
465 #%%patch1 -p1
466 %patch2 -p1
467 %patch3 -p1
468 %patch4 -p1
469
470 echo 'AC_DEFUN([AM_PATH_GTK],[:])' > fake-am_path_gtk.m4
471 echo 'AC_DEFUN([AC_BAKEFILE_PROG_CC],[:])' > fake-ac_bakefile_prog_cc.m4
472 echo 'AC_DEFUN([AC_BAKEFILE_PROG_CXX],[:])' > fake-ac_bakefile_prog_cxx.m4
473
474 # bakefile.m4 from 0.1.7
475 tail -n +1481 aclocal.m4 | head -n 1396 > bakefile.m4
476
477 %build
478 # if bakefiles rebuild is needed:
479 #%if "%(rpm -q bakefile --qf '%%{VERSION}')" != "0.1.7"
480 #cd build/bakefiles
481 #bakefile_gen -f autoconf
482 #cd ../..
483 #%endif
484 cp -f /usr/share/automake/config.sub .
485 %{__aclocal} -I .
486 %{__autoconf}
487
488 CPPFLAGS="%{rpmcflags} -I`pwd`/include -I/usr/X11R6/include"; export CPPFLAGS
489 # avoid adding -s to LDFLAGS
490 LDFLAGS=" "; export LDFLAGS
491 args="%{?with_debug:--enable-debug}%{!?with_debug:--disable-debug} \
492         --enable-plugins \
493         --enable-std_iostreams \
494         --without-sdl \
495         --with-opengl \
496         --enable-calendar \
497         --enable-controls \
498         --enable-tabdialog"
499
500 gui='--with-gtk --enable-gtk2'
501 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
502         '--enable-unicode' ; do
503         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
504         mkdir $objdir
505         cd $objdir
506         ../%configure \
507                 ${args} \
508                 ${gui} \
509                 --disable-universal \
510                 ${unicode}
511         %{__make}
512         %{__make} -C contrib/src
513         cd ..
514 done
515
516 %if %{with x11}
517 gui='--with-x11'
518 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
519         '--enable-unicode' ; do
520         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
521         mkdir $objdir
522         cd $objdir
523         ../%configure \
524                 ${args} \
525                 ${gui} \
526                 --enable-universal \
527                 ${unicode}
528         %{__make}
529         %{__make} -C contrib/src
530         if echo $objdir| grep -q disable-unicode ; then
531                 %{__make} -C utils
532                 %{__make} -C utils/emulator
533                 %{__make} -C utils/hhp2cached
534                 %{__make} -C contrib/utils
535         fi
536         cd ..
537 done
538 %endif
539
540 cd locale
541 %{__make} allmo
542
543 %install
544 rm -rf $RPM_BUILD_ROOT
545 install -d $RPM_BUILD_ROOT%{_bindir}
546
547 gui='--with-gtk --enable-gtk2'
548 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
549         '--enable-unicode' ; do
550         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
551         cd $objdir
552         %{__make} install \
553                 prefix=$RPM_BUILD_ROOT%{_prefix} \
554                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
555                 bindir=$RPM_BUILD_ROOT%{_bindir} \
556                 datadir=$RPM_BUILD_ROOT%{_datadir} \
557                 libdir=$RPM_BUILD_ROOT%{_libdir} \
558                 mandir=$RPM_BUILD_ROOT%{_mandir} \
559                 includedir=$RPM_BUILD_ROOT%{_includedir}
560
561         %{__make} -C contrib/src install \
562                 prefix=$RPM_BUILD_ROOT%{_prefix} \
563                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
564                 bindir=$RPM_BUILD_ROOT%{_bindir} \
565                 datadir=$RPM_BUILD_ROOT%{_datadir} \
566                 libdir=$RPM_BUILD_ROOT%{_libdir} \
567                 mandir=$RPM_BUILD_ROOT%{_mandir} \
568                 includedir=$RPM_BUILD_ROOT%{_includedir}
569         cd ..
570 done
571
572 %if %{with x11}
573 gui='--with-x11'
574 for unicode in %{?with_ansi:'--disable-unicode %{?with_odbc:--with-odbc}'} \
575         '--enable-unicode' ; do
576         objdir=`echo obj${gui}${unicode}|sed 's/ /_/g'`
577         cd $objdir
578         %{__make} install \
579                 prefix=$RPM_BUILD_ROOT%{_prefix} \
580                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
581                 bindir=$RPM_BUILD_ROOT%{_bindir} \
582                 datadir=$RPM_BUILD_ROOT%{_datadir} \
583                 libdir=$RPM_BUILD_ROOT%{_libdir} \
584                 mandir=$RPM_BUILD_ROOT%{_mandir} \
585                 includedir=$RPM_BUILD_ROOT%{_includedir}
586         if echo $objdir| grep -q disable-unicode ; then
587 #               install utils/dialoged/src/DialogEd $RPM_BUILD_ROOT%{_bindir}
588                 # TODO: install default config files and default backgrouds
589                 install utils/HelpGen/src/HelpGen $RPM_BUILD_ROOT%{_bindir}
590                 install utils/emulator/src/wxemulator $RPM_BUILD_ROOT%{_bindir}
591                 install utils/tex2rtf/src/tex2rtf $RPM_BUILD_ROOT%{_bindir}
592                 install utils/hhp2cached/hhp2cached $RPM_BUILD_ROOT%{_bindir}
593 #               install utils/makegen/makegen $RPM_BUILD_ROOT%{_bindir}
594                 install utils/wxrc/wxrc $RPM_BUILD_ROOT%{_bindir}
595 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
596 #               install -m644 utils/makegen/templates/* \
597 #                       $RPM_BUILD_ROOT%{_datadir}/wx/makegen/templates
598 #               install contrib/utils/wxrcedit/wxrcedit $RPM_BUILD_ROOT%{_bindir}
599 #               install -d $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit
600 #               install contrib/utils/wxrcedit/df/* \
601 #                       $RPM_BUILD_ROOT%{_datadir}/wx/wxrcedit/
602         fi
603
604         %{__make} -C contrib/src install \
605                 prefix=$RPM_BUILD_ROOT%{_prefix} \
606                 exec_prefix=$RPM_BUILD_ROOT%{_exec_prefix} \
607                 bindir=$RPM_BUILD_ROOT%{_bindir} \
608                 datadir=$RPM_BUILD_ROOT%{_datadir} \
609                 libdir=$RPM_BUILD_ROOT%{_libdir} \
610                 mandir=$RPM_BUILD_ROOT%{_mandir} \
611                 includedir=$RPM_BUILD_ROOT%{_includedir}
612
613         cd ..
614 done
615 %endif
616
617 set -x
618
619 for i in $RPM_BUILD_ROOT%{_libdir}/wx/config/*
620 do
621         b=`basename $i`
622         cp $i $RPM_BUILD_ROOT%{_bindir}/wx-`echo $b|sed -e 's/\(.*\)-release-.*/\1/'`-config
623 done
624
625 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
626 cp -a demos samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
627 cp -f docs/x11/readme.txt docs/wxX11-readme.txt
628
629 %find_lang wxstd
630
631 %clean
632 rm -rf $RPM_BUILD_ROOT
633
634 %post   -n wxBase -p /sbin/ldconfig
635 %postun -n wxBase -p /sbin/ldconfig
636
637 %post   -n wxBase-unicode -p /sbin/ldconfig
638 %postun -n wxBase-unicode -p /sbin/ldconfig
639
640 %post   -n wxGTK2 -p /sbin/ldconfig
641 %postun -n wxGTK2 -p /sbin/ldconfig
642
643 %post   -n wxGTK2-gl -p /sbin/ldconfig
644 %postun -n wxGTK2-gl -p /sbin/ldconfig
645
646 %post   -n wxGTK2-unicode -p /sbin/ldconfig
647 %postun -n wxGTK2-unicode -p /sbin/ldconfig
648
649 %post   -n wxGTK2-unicode-gl -p /sbin/ldconfig
650 %postun -n wxGTK2-unicode-gl -p /sbin/ldconfig
651
652 %post   -n wxX11 -p /sbin/ldconfig
653 %postun -n wxX11 -p /sbin/ldconfig
654
655 %post   -n wxX11-unicode -p /sbin/ldconfig
656 %postun -n wxX11-unicode -p /sbin/ldconfig
657
658 %files -f wxstd.lang
659 %defattr(644,root,root,755)
660 %doc docs/{changes,licence,licendoc,preamble,readme,todo}.txt
661 #%dir %{_datadir}/wx
662 #%dir %{_datadir}/wx/2.5
663
664 #%files -n wxWidgets-afm
665 #%defattr(644,root,root,755)
666 #%{_datadir}/wx/2.5/afm
667 #%{_datadir}/wx/2.5/gs_afm
668
669 %files devel
670 %defattr(644,root,root,755)
671 %doc docs/html
672 %doc docs/tech docs/univ
673 %{_includedir}/wx*
674 %dir %{_libdir}/wx
675 %dir %{_libdir}/wx/include
676 %dir %{_libdir}/wx/config
677 %{_aclocaldir}/*.m4
678
679 %files examples
680 %defattr(644,root,root,755)
681 %{_examplesdir}/%{name}-%{version}
682
683 %if %{with x11}
684 %files HelpGen
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_bindir}/HelpGen
687 %endif
688
689 %if %{with ansi}
690 %files -n wxBase
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/libwx_base-*.so.*.*
693 %attr(755,root,root) %{_libdir}/libwx_base_*.so.*.*
694 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdl-*.so
695
696 %files -n wxBase-devel
697 %defattr(644,root,root,755)
698 %{_libdir}/libwx_base-*.so
699 %{_libdir}/libwx_base_*.so
700 %endif
701
702 %files -n wxBase-unicode
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/libwx_baseu-*.so.*.*
705 %attr(755,root,root) %{_libdir}/libwx_baseu_*.so.*.*
706 #%attr(755,root,root) %{_libdir}/wx/%{version}/sound_sdlu-*.so
707
708 %files -n wxBase-unicode-devel
709 %defattr(644,root,root,755)
710 %{_libdir}/libwx_baseu-*.so
711 %{_libdir}/libwx_baseu_*.so
712
713 %if %{with ansi}
714 %files -n wxGTK2
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/libwx_gtk2_*.so.*.*
717 %exclude %{_libdir}/libwx_gtk2_ogl-*.so.*.*
718
719 %files -n wxGTK2-devel
720 %defattr(644,root,root,755)
721 %{_libdir}/libwx_gtk2_*-*.so
722 %exclude %{_libdir}/libwx_gtk2_ogl-*.so
723 %{_libdir}/wx/config/gtk2-ansi-*
724 %{_libdir}/wx/include/gtk2-ansi-*
725 %attr(755,root,root) %{_bindir}/wx-gtk2-ansi-config
726
727 %files -n wxGTK2-gl
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/libwx_gtk2_ogl-*.so.*.*
730
731 %files -n wxGTK2-gl-devel
732 %defattr(644,root,root,755)
733 %{_libdir}/libwx_gtk2_ogl-*.so
734 %endif
735
736 %files -n wxGTK2-unicode
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/libwx_gtk2u_*-*.so.*.*
739 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
740
741 %files -n wxGTK2-unicode-devel
742 %defattr(644,root,root,755)
743 %{_libdir}/libwx_gtk2u_*-*.so
744 %exclude %{_libdir}/libwx_gtk2u_ogl-*.so
745 %{_libdir}/wx/config/gtk2-unicode-*
746 %{_libdir}/wx/include/gtk2-unicode-*
747 %attr(755,root,root) %{_bindir}/wx-gtk2-unicode-config
748
749 %files -n wxGTK2-unicode-gl
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/libwx_gtk2u_ogl-*.so.*.*
752
753 %files -n wxGTK2-unicode-gl-devel
754 %defattr(644,root,root,755)
755 %{_libdir}/libwx_gtk2u_ogl-*.so
756
757 %if %{with x11}
758 %if %{with ansi}
759 %files utils
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_bindir}/*
762 %exclude %{_bindir}/HelpGen
763 %exclude %{_bindir}/wx*-config
764 #%{_datadir}/wx/makegen
765 #%{_datadir}/wx/wxrcedit
766
767 %files -n wxX11
768 %defattr(644,root,root,755)
769 %doc docs/wxX11-readme.txt
770 %attr(755,root,root) %{_libdir}/libwx_x11univ_*-*.so.*.*
771 %exclude %{_libdir}/libwx_x11univ_ogl-*.so.*.*
772
773 %files -n wxX11-devel
774 %defattr(644,root,root,755)
775 %{_libdir}/libwx_x11univ_*-*.so
776 %exclude %{_libdir}/libwx_x11univ_ogl-*.so
777 %{_libdir}/wx/config/x11univ-ansi-*
778 %{_libdir}/wx/include/x11univ-ansi-*
779 %attr(755,root,root) %{_bindir}/wx-x11univ-ansi-config
780
781 %files -n wxX11-gl
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libwx_x11univ_ogl-*.so.*.*
784
785 %files -n wxX11-gl-devel
786 %defattr(644,root,root,755)
787 %{_libdir}/libwx_x11univ_ogl-*.so
788 %endif
789
790 %files -n wxX11-unicode
791 %defattr(644,root,root,755)
792 %attr(755,root,root) %{_libdir}/libwx_x11univu_*-*.so.*.*
793 %exclude %{_libdir}/libwx_x11univu_ogl-*.so.*.*
794
795 %files -n wxX11-unicode-devel
796 %defattr(644,root,root,755)
797 %{_libdir}/libwx_x11univu_*-*.so
798 %exclude %{_libdir}/libwx_x11univu_ogl-*.so
799 %{_libdir}/wx/config/x11univ-unicode-*
800 %{_libdir}/wx/include/x11univ-unicode-*
801 %attr(755,root,root) %{_bindir}/wx-x11univ-unicode-config
802
803 %files -n wxX11-unicode-gl
804 %defattr(644,root,root,755)
805 %attr(755,root,root) %{_libdir}/libwx_x11univu_ogl-*.so.*.*
806
807 %files -n wxX11-unicode-gl-devel
808 %defattr(644,root,root,755)
809 %{_libdir}/libwx_x11univu_ogl-*.so
810 %endif
This page took 0.069914 seconds and 2 git commands to generate.