]> git.pld-linux.org Git - packages/wv.git/blob - wv.spec
- place correctly new input field (fixes abiword .doc import crash)
[packages/wv.git] / wv.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # without static version
4 #
5 Summary:        MSWord Document to HTML converter
6 Summary(pl):    Konwerter dokumentów MS Worda do HTML
7 Summary(pt_BR): Conversor de arquivos formato Word (6/7/8/9) para html
8 Name:           wv
9 Version:        1.2.1
10 Release:        3
11 License:        GPL
12 Group:          Applications/Text
13 Source0:        http://dl.sourceforge.net/wvware/%{name}-%{version}.tar.gz
14 # Source0-md5:  d757080af4595839d5d82a1a573c692c
15 URL:            http://wvware.sourceforge.net/
16 BuildRequires:  autoconf >= 2.50
17 BuildRequires:  automake
18 BuildRequires:  glib2-devel >= 1:2.12.0
19 BuildRequires:  libgsf-devel >= 1.14.1
20 BuildRequires:  libpng-devel >= 1.2.12
21 BuildRequires:  libtool
22 BuildRequires:  libwmf-devel >= 2:0.2.8.4
23 BuildRequires:  libxml2-devel >= 1:2.6.26
24 BuildRequires:  pkgconfig
25 BuildRequires:  zlib-devel
26 # these are required for full libwmf
27 BuildRequires:  freetype-devel >= 2.0
28 BuildRequires:  libjpeg-devel
29 BuildRequires:  xorg-lib-libX11-devel
30 Obsoletes:      mswordview
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags_ia32   -fomit-frame-pointer 
34
35 %description
36 MSWordView is a program that understands the Microsoft Word 8 binary
37 file format (Office97, Office2000) and is able to convert Word
38 documents into HTML, which can then be read with a browser.
39
40 wv is a suite of programs to help convert Word Documents to HTML.
41
42 %description -l pl
43 MSWordView jest programem, który rozumie binarne dokumenty programu
44 Microsoft Word 8 (Office97, Office2000) i jest w stanie skonwertowaæ
45 je do dokumentu HTML, który mo¿e byæ przeczytany w przegl±darce WWW.
46
47 wv jest elementem programów, które pomagaj± przekonwertowaæ dokumenty
48 Worda do HTML.
49
50 %description -l pt_BR
51 Conversor de arquivos formato Word (6/7/8/9) para html.
52
53 %package devel
54 Summary:        Include files needed to compile
55 Summary(pl):    Pliki nag³ówkowe do biblioteki wv
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       glib2-devel >= 1:2.12.0
59 Requires:       libgsf-devel >= 1.14.1
60 Requires:       libpng-devel >= 1.2.12
61 Requires:       libwmf-devel >= 2:0.2.8.4
62 Requires:       libxml2-devel >= 1:2.6.26
63 # these are required for full libwmf
64 Requires:       freetype-devel >= 2.0
65 Requires:       libjpeg-devel
66 Requires:       xorg-lib-libX11-devel
67
68 %description devel
69 Contains the header files.
70
71 %description devel -l pl
72 Pakiet tem zawiera pliki nag³ówkowe wv.
73
74 %package static
75 Summary:        Static wv libraries
76 Summary(pl):    Biblioteki statyczne wv
77 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o wv
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Contains static wv libraries.
83
84 %description static -l pl
85 Pakiet zawiera statyczne biblioteki wv.
86
87 %prep
88 %setup -q
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 LDFLAGS="%{rpmldflags} -Wl,--as-needed"
97 %configure \
98         --with-zlib \
99         --with-png \
100         --with-libwmf \
101         --%{!?with_static_libs:dis}%{?with_static_libs:en}able-static
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %clean
112 rm -fr $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc README
120 %attr(755,root,root) %{_bindir}/wv*
121 %attr(755,root,root) %{_libdir}/libwv-*.so.*.*.*
122 %{_datadir}/wv
123 %{_mandir}/man*/*
124
125 %files devel
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_libdir}/libwv.so
128 %{_libdir}/libwv.la
129 %{_includedir}/wv
130 %{_pkgconfigdir}/wv-*.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libwv.a
136 %endif
This page took 0.058226 seconds and 3 git commands to generate.